Windows Script Host Version 2.0-Tutorium

Microsoft® Windows® Script Host
Windows Script Host Version 2.0-Tutorium 		WSH-Referenz
Weiter

Thema | Informationen hierzu
Liste der in diesem Tutorium verwendeten Konventionen | Dokumentkonventionen
Überblick über Windows Script Host | Informationen zu Windows Script Host
Informationen zu Windows-Script-Dateien (WSF-Dateien) | Verwenden von Windows Script-Dateien
Anpassen der Ausführungsweise von Skripten | Anpassen von Skripteinstellungen
Erstellen von Dateien zum Festlegen von Skripteigenschaften | Festlegen von Skripteigenschaften
Überblick über die Ausführung von Skripten | Ausführen von Skripten
Ausführen von Skripten in der Windows-Umgebung | Ausführen von Skripten mit WScript.exe
Ausführen von Skripten von der Eingabeaufforderung | Ausführen von Skripten mit CScript.exe
Ausführen von Skripten mit Drag & Drop-Funktionalität | Drag & Drop-Unterstützung
Anzeigen der Windows Script Host-Referenz | Windows Script Host-Referenz
Liste der Windows Script Host-Fehlermeldungen | Fehlermeldungen
Liste der nach Versionen aufgeschlüsselten Funktionsmerkmale | Versionsinformationen


Dokumentkonventionen

Dokumentkonventionen 		WSH-Tutorium
Weiter

In diesem Tutorium werden die folgenden Konventionen durchgehend verwendet:

  • Skriptingbeispiele sind in der Microsoft Visual Basic® Scripting Edition (VBScript)-Sprache geschrieben.
  • Bei in Microsoft JScript® geschriebenen Methoden ist die Groß-/Kleinschreibung relevant. Allgemein sollten Sie dieselbe Schreibweise wie in den Syntaxbeispielen des vorliegenden Dokuments verwenden.
  • In Klammern gesetzte Parameter (beispielsweise [anyWert]) sind optional.

In der folgenden Tabelle werden Variablenpräfixe in Parameterauflistungen sowie Codebeispiele mit den zugehörigen Beschreibungen aufgeführt.

Präfix | Beschreibung
any | Beliebiger Typ
b | Boolescher Wert (Boolean)
int | Ganzzahl (Integer)
nat | Natürliche Zahl oder nicht-negative Ganzzahl
obj | Objekt (IDispatch-Schnittstelle)
str | Zeichenfolge (String)


Informationen zu Windows Script Host

Informationen zu Windows Script Host 		WSH-Tutorium
Zurück
Weiter

Microsoft® Windows® Script Host ist ein sprachenunabhängiger Scripting-Host für ActiveX®-Skriptmodule. Dieser Host stellt einfache, leistungsfähige und flexible Skripteigenschaften der 32-Bit-Plattform von Windows zur Verfügung, sodass Skripte sowohl vom Windows-Desktop als auch von der Eingabeaufforderung aus ausgeführt werden können.

Windows Script Host eignet sich besonders für nicht-interaktive Skriptanforderungen, wie beispielsweise Anmelde- und Administrationsskripte sowie Automatisierungen.

Vorteile von Windows Script Host

Windows Script Host bietet die folgenden Vorteile:

  • Zwei separate ausführbare Dateien, WScript.exe und CScript.exe, um Skripte von der Windows- oder von der Eingabeaufforderungsebene aus auszuführen. Während WScript.exe eine Windows-basierte Eigenschaftseite zum Einstellen von Skripteigenschaften bietet, stellt CScript.exe hierfür Befehlszeilenparameter zur Verfügung.
  • Unterstützung von mehreren Dateien. Sie können mehrere Skriptmodule aufrufen und gleichzeitig mehrere Vorgänge von einer einzigen Windows Script-Datei (.WSF) aus durchführen.
  • Sehr geringe Speicheranforderungen.
  • Zuordnen von Skripterweiterungen zu programmatischen Bezeichnern (ProgIDs). Wenn Sie ein Skript vom Windows-Desktop oder der Eingabeaufforderung aus starten, liest Script Host den Inhalt der entsprechenden Skriptdatei und gibt ihn an das registrierte Skriptmodul weiter. Der Host benutzt Dateierweiterungen und nicht die HTML SCRIPT-Tags, um das Skript zu identifizieren; beispielsweise wird .VBS für Microsoft Visual Basic® Scripting Edition (VBScript)-Dateien und .JS für Microsoft JScript®-Dateien verwendet. Die Verwendung von Erweiterungen bedeutet, dass Sie für ein bestimmtes Skriptmodul nicht mehr die genauen ProgID kennen müssen. Windows Script Host übernimmt diese Aufgabe, indem Zuordnungen von Skripterweiterungen zu ProgIDs durchgeführt und das zugehörige Modul für ein bestimmtes Skript gestartet wird.
Objektmodell für Windows Script Host
Windows Script Host stellt ActiveX-Schnittstellen für die direkte Bearbeitung von Skriptausführungen sowie Hilfefunktionen für andere Vorgänge bereit. Die Dokumentelemente, Methoden, Objekte und Eigenschaften der Windows Script Host-Referenz, mit denen Sie die nachstehend aufgeführten Aufgaben durchführen können:
  • Ausgeben von Meldungen über den Monitor
  • Ausführen elementarer Funktionen, wie beispielsweise CreateObject bzw. GetObject
  • Zuordnen von Netzwerklaufwerken
  • Verbinden zu Druckern
  • Abrufen und Bearbeiten von Umgebungsvariablen
  • Ändern von Registrierungsschlüsseln
Integration von Windows Script Host
Windows Script Host ist in Windows 98, Windows 2000 Professional sowie Windows 2000 Server integriert. Version 2.0 umfasst die Skriptmodule von VBScript und JScript. Zukünftig werden auch andere Softwareunternehmen ActiveX-Skriptmodule für Sprachen, wie beispielsweise PerlScript, TCL, REXX und Python, bereitstellen.


Verwenden von Windows Script-Dateien

Verwenden von Windows Script-Dateien 		WSH-Tutorium
Zurück
Weiter

Die Windows-Skriptdatei (.WSF), ein Textdokument mit XML (Extensible Markup Language)-Code, beinhaltet verschiedene Funktionen, die Ihnen eine erweiterte Skriptflexibilität zur Verfügung stellen. Da Windows-Skriptdateien nicht modulspezifisch sind, können diese Skript von einem beliebigen ActiveX®-kompatiblen Skriptmodul enthalten.

Mit WSF-Dateien können Sie die folgenden Vorteile beim Erstellen eigener Skripte nutzen:

  • Unterstützung für Include-Anweisungen - ermöglicht Ihnen die Einbindung bereits geschriebener Funktionen aus VBScript- oder JScript-Dateien in ein Windows Script Host-Projekt.
  • Unterstützung für mehrere Module - ermöglicht Ihnen die Verwendung mehrerer Skriptsprachen in einer Datei.
  • Unterstützung für Typbibliotheken - ermöglicht das Hinzufügen von Konstanten in eigenen Code.
  • Unterstützung für Tools - ermöglicht Ihnen die Bearbeitung von Dateien mithilfe eines XML-Editors.
  • Unterstützung für mehrere Bearbeitungsvorgänge in einer Datei - ermöglicht die Speicherung Ihres Codes an einem einzigen Speicherort.
Include-Anweisungen
Wenn Sie über JS- und VBS-Dateien aus früheren Windows Script Host-Projekten verfügen, können Sie diese mithilfe einer WSF-Datei mit Windows Script Host verwenden. Eine WSF-Datei kapselt eine Bibliothek mit Funktionen ein, die wiederum von mehreren WSF-Dateien verwendet werden kann.

Das folgende Beispiel zeigt den Inhalt einer WSF-Datei, die eine JScript-Datei (fso.js) sowie eine VBScript-Funktion beinhaltet, die eine in der Datei enthaltene Funktion (FreienSpeicherAnzeigen) aufruft. Die Inhalte der Datei fso.js sind ebenfalls enthalten.

<Job id="IncludeBeispiel">
<script language="JScript" src="FSO.JS"/>
<script language="VBScript">
    ' Gibt die Größe des freien Speicherplatzes auf Laufwerk C: zurück.
    s = FreienSpeicherAnzeigen("c:")
    WScript.Echo s
</Script>
</Job>
Inhalt der Datei fso.js:
function FreienSpeicherAnzeigen(lwPfad) {
    var fs, d, s;
    fs = new ActiveXObject("Scripting.FileSystemObject");
    d = fs.GetDrive(fs.GetDriveName(lwPfad));
    s = "Drive " + lwPfad + " - " ;
    s += d.VolumeName;
    s += "Freier Speicherplatz: " + d.FreeSpace/1024 + " KB";
    return s;
}
Unterstützung mehrerer Module
Da eine Skriptsprache möglicherweise nicht über die gesamte benötigte Funktionalität verfügt, können Sie mit Windows Script Host mehrere Sprachen in einer einzigen WSF-Datei kombinieren. Das folgende Beispiel stellt den Inhalt einer WSF-Datei dar, die sowohl VBScript®- als auch PerlScript-Code umfasst:
<job id="PERLundVBS">
<script language=PerlScript RUNAT=Server>
    sub PerlHallo
    {
        my $str = @_[0];
        $WScript->Echo($str);
    }
</script>

<script language="VBScript">
    WScript.Echo "Ein Hallo von VBScript"
    PerlHallo "Ein Hallo von PERLScript"
</Script>
</Job>
Unterstützung für Typbibliotheken
Im folgenden Beispiel wurde MeineKomponente mit Microsoft® Visual Basic® 5.0 entwickelt. MeineKomponente legt die Konstante MeinFehler mit der folgenden Anweisung fest.
Public Const MeinFehler = "Du verwendest MeineKomponente falsch."
Die Typbibliothek ist in der Datei meinekomponente.lib enthalten, die unter C:\MeineKomponente installiert ist.
<Job id="IncludeBeispiel">
<Reference progid="MeineKomponente.MeineKlasse">
<Script language="VBScript">
    Dim MeineVariable
    Set MeineVariable = CreateObject("MeineKomponente.MeineKlasse")
    aktuelleRueckgabe = MeineVariable.MeineMethode
    If aktuelleRueckgabe = False then
        WScript.Echo MeinFehler
    End If
</Script>
</Job>
Toolunterstützung
Da die WSF-Datei im XML-Format vorliegt, können Sie einen beliebigen Editor verwenden, der dieses Format unterstützt, um WSF-Dateien zu bearbeiten. Sie können auch einen Texteditor verwenden, wie beispielsweise Notepad.
Unterstützung für mehrere Bearbeitungsvorgänge in einer Datei
Um nicht sämtliche Skripte in mehreren Einzeldateien zu verwalten, können Sie diese auch in eine einzige WSF-Datei einbinden und sie in verschiedene Bearbeitungsvorgänge aufteilen. Sie können die einzelnen Vorgänge dann separat mit einer Syntax ähnlich der folgenden ausführen, wobei MeinErsterJob der Name des Auftrags in der Datei MeineSkripte.wsf ist:
CScript //Job:MeinErsterJob MeineSkripte.wsf


Anpassen von Skripteinstellungen

Anpassen von Skripteinstellungen 		WSH-Tutorium
Zurück
Weiter

Sie können bestimmte Einstellungen für jedes einzelne, von Ihnen erstellte Skript mithilfe einer Windows Script Host-Steuerungsdatei (.WSH) aufzeichnen. Bei einer WSH-Datei handelt es sich um ein Textdokument, in dem Sie die Ausführung von einem oder mehreren Skripten anpassen können.

Sie können mehrere WSH-Dateien für ein einzelnes Skript erstellen, sodass Sie die Ausführung eines Skriptes entsprechend den Anforderungen bestimmter Gruppen oder Einzelbenutzer innerhalb des Unternehmens anpassen können. Auf diese Weise kann ein einziges Anmeldeskript erstellt werden, das von zwei verschiedenen WSH-Dateien mit jeweils unterschiedlichen Einstellungen und Parametern aufgerufen wird, sodass zwei verschiedene Gruppen unterstützt werden.

Die WSH-Datei entspricht einer PIF-Datei, die für die Ausführung älterer 16-Bit-Anwendungen verwendet wurde. Diese Datei wird automatisch erstellt, wenn Sie die Eigenschaften für eine unterstützte Skriptdatei setzen. Sie können diese wie eine ausführbare oder Stapelverarbeitungsdatei verwenden.

Sie verfügen beispielsweise über das Skript MeinSkript.vbs, für das Sie die WSH-Datei MeinSkript.wsh erstellt haben. Zum Ausführen von MeinSkript.vbs mit den in MeinSkript.wsh aufgezeichneten Optionen können Sie entweder im Windows-Explorer auf MeinSkript.wsh doppelklicken oder MeinSkript.wsh als Skriptargument an CScript.exe oder WScript.exe weitergeben. Hierzu geben Sie den folgenden Befehl an der Eingabeaufforderung ein:

c:\>cscript MeinSkript.wsh
Weitere Informationen hierzu finden Sie unter Festlegen von Skripteigenschaften.


Festlegen von Skripteigenschaften

Festlegen von Skripteigenschaften 		WSH-Tutorium
Zurück
Weiter

Für die einzelnen auszuführenden Skripte können Sie bestimmte Einstellungen mithilfe einer Steuerungsdatei (.WSH) aufzeichnen. Bei einer WSH-Datei handelt es sich um eine Textdatei, die ein INI-Dateien ähnliches Format aufweist. Diese Datei wird automatisch erstellt, wenn Sie die Eigenschaften für eine unterstützte Skriptdatei setzen.

So erstellen Sie eine WSH-Datei für ein bestimmtes Skript
  1. Klicken Sie mit der rechten Maustaste im Windows-Explorer auf die Skriptdatei.
  2. Wählen Sie im Kontextmenü Eigenschaften.
  3. Wählen Sie auf der Eigenschaftsseite die gewünschten Einstellungen für das Skript.
  4. Klicken Sie auf OK oder auf Übernehmen.
Eine WSH-Datei wird mit demselben Dateinamen der Skriptdatei erstellt, auf die Sie mit der rechten Maustaste geklickt haben. Beispielsweise kann eine WSH-Datei den folgenden Text enthalten:
[ScriptFile]
Path=C:\WINNT\Beispiele\WSH\eigenschaftanz.vbs
[Options]
Timeout=0
DisplayLogo=1
BatchMode=0
Die Path-Einstellung im Abschnitt [ScriptFile] legt die Skriptdatei fest, der diese WSH-Datei zugeordnet wird. Die Schlüssel im Abschnitt [Options] entsprechen den Einstellungen der Registerkarte Skript im Dialogfeld Eigenschaften.
Funktionsweise der WSH-Datei

Wenn Sie auf die WSH-Datei doppelklicken oder sie von der Eingabeaufforderung aus ausführen, liest CScript.exe oder WScript.exe den Inhalt der Datei und legt die entsprechenden Einstellungen fest, die zur Ausführung des Skriptes verwendet werden sollen. CScript/WScript führt das Originalskript mit den Eigenschaften aus, die in der WSH-Datei festgelegt wurden.

Stellen Sie sicher, dass Sie über die Originalskriptdatei verfügen, wenn Sie die WSH-Datei ausführen. Kann das Skript mithilfe der WSH-Datei nicht ausgeführt werden, überprüfen Sie in dieser Datei die Zeile Path= , um sicherzustellen, dass sie auf das Skript zeigt, das ausgeführt werden soll.


Ausführen von Skripten

Ausführen von Skripten 		WSH-Tutorium
Zurück
Weiter

Aufgabenstellung | Informationen hierzu
Ausführen von Skripten in der Windows-Umgebung | Ausführen von Skripten mit WScript.exe
Ausführen von Skripten von der Eingabeaufforderung | Ausführen von Skripten mit CScript.exe
Nutzen der Drag & Drop-Funktionalität | Drag & Drop-Unterstützung


Ausführen von Skripten mit "WScript.exe"

Ausführen von Skripten mit WScript.exe 		WSH-Tutorium
Zurück
Weiter

WScript.exe ist die Version von Windows Script Host, die die Ausführung von Skripten von Windows aus ermöglicht. WScript.exe stellt zum Setzen von Skripteigenschaften ein Windows-Dialogfeld bereit. Mit WScript.exe haben Sie die folgenden Möglichkeiten zur Ausführung von Skripten unter Windows:
  • Doppelklicken auf Dateien oder Symbole. Hierbei kann es sich um Dateien und Symbole handeln, die unter Arbeitsplatz, im Windows-Explorer, dem Fenster Suchen nach, dem Start-Menü oder auf dem Desktop aufgeführt werden.
  • Eingabe eines Skriptnamens unter Start/Ausführen. Klicken Sie auf Start, wählen Sie den Befehl Ausführen aus, und geben Sie dann den vollständigen Namen des auszuführenden Skriptes (mit Erweiterung und Pfad) ein.
  • Eingabe von WScript.exe, gefolgt von einem Skriptnamen, unter Start/Ausführen. Klicken Sie auf Start, wählen Sie den Befehl Ausführen aus, und geben Sie dann WScript, gefolgt vom vollständigen Namen des auszuführenden Skriptes ein.
Wenn Sie auf eine Skriptdatei doppelklicken, für deren Dateityp (Erweiterung) noch keine Zuordnung zu WScript.exe eingerichtet wurde, erscheint das Dialogfeld Öffnen mit, in dem Sie nach dem Programm zum Öffnen der Datei gefragt werden. Wählen Sie WScript aus, und aktivieren Sie das Kontrollkästchen Diesen Dateityp immer mit diesem Programm öffnen, um WScript als Standardanwendung für alle Dateien mit dieser Erweiterung zu registrieren. Wenn Sie beispielsweise beim Aufruf von Chart.vbs dieses Kontrollkästchen aktivieren, wird WScript die Standardanwendung für alle Dateien mit der Erweiterung VBS.

Das Eigenschaftendialogfeld von WScript.exe unterstützt die folgenden Optionen:

Eigenschaft | Beschreibung | CScript-Äquivalent
Abbruch der Skriptausführung nach einer vorgegebenen Zeitspanne (Sekunden). | Legt die maximale Ausführungsdauer (in Sekunden) für ein Skript fest. Standardmäßig gibt es keine solche Beschränkung. | //T:nn
Anzeige des Logos bei Ausführung des Skriptes in einem MS-DOS-Fenster. Anzeige eines Banners vor Ausführung des Skriptes. (Standardeinstellung). Das Gegenstück hierzu ist //nologo. //logo oder
//nologo

Mithilfe des Eigenschaften-Dialogfeldes von WScript.exe können Sie für alle auf dem lokalen Computer mittels WScript ausgeführten Skripte globale Skriptoptionen festlegen. Mithilfe einer WSH-Datei können Sie darüber hinaus auch Optionen für individuelle Skripten einstellen. Weitere Informationen hierzu finden Sie unter Festlegen von Skripteigenschaften.

Bei der mit Windows NT® 2000 ausgelieferten Version von Windows Script Host besteht nicht mehr die Notwendigkeit, die Erweiterung der Skriptdatei anzugeben. Hier genügt es, wenn Sie den Skriptnamen eingeben oder im Windows-Explorer auf das Skript doppelklicken.


Ausführen von Skripten mit "CScript.exe"

Ausführen von Skripten mit CScript.exe 		WSH-Tutorium
Zurück
Weiter

CScript.exe ist die Version von Windows Script Host, die die Ausführung von Skripten von der Eingabeaufforderung aus ermöglicht. CScript.exe stellt verschiedene Befehlszeilenparameter zum Setzen von Skripteigenschaften bereit. Zur Verwendung von Cscript.exe geben Sie an der Eingabeaufforderung eine Befehlszeile gemäß der folgenden Syntax ein:
cscript [Hostoptionen...] [Skriptname] [Skriptoptionen und -parameter]
Die einzelnen Teile der Syntax haben die folgende Bedeutung:
  • Hostoptionen aktivieren oder deaktivieren verschiedene Funktionsmerkmale von Windows Script Host. Hostoptionen werden durch zwei voranstehende Schrägstriche (//) eingeleitet.
  • Skriptname ist der Name der Skriptdatei (komplett mit Erweiterung und ggf. Pfadangabe, z. B. d:\admin\vbscripts\chart.vbs.
  • Skriptoptionen und -parameter werden an das Skript übergeben. Skriptparameter werden durch einen einzelnen Schrägstrich (/) eingeleitet.
Alle Parameter sind optional; ohne Angabe des Skriptnamen können Sie jedoch keine Skriptoptionen angeben. Beim Aufruf ohne Parameter zeigt CScript die CScript-Syntax sowie die zulässigen Hostoptionen an. CScript.exe unterstützt die in der folgenden Tabelle angegebenen Hostoptionen.

Parameter | Beschreibung
//I | Interaktiver Modus: Ermöglicht die Anzeige von Eingabeaufforderungen an den Benutzer und von Skriptfehlern (dies ist der Standardmodus, das Verhalten ist dem der Option //B genau entgegengesetzt).
//B | Batch-Modus: Unterdrückung der Anzeige von Eingabeaufforderungen an den Benutzer und Skriptfehlern in der Befehlszeile.
//T:nn | Ermöglicht den Abbruch eines Skriptes wegen Zeitüberschreitung. nn bezeichnet die maximale Dauer (in Sekunden), die ein Skript ausgeführt werden kann. Standardmäßig gibt es keine solche Beschränkung. (Weitere Informationen zu diesem Parameter finden Sie anschließend an die Tabelle.)
//logo | Standard. Zeigt ein Banner an (Gegenteil von //nologo).
//nologo | Verhindert die Anzeige des Ausführungsbanners zur Laufzeit.
//H:CScript oder
//H:WScript 		Registriert CScript.exe oder WScript.exe als Standardanwendung für die Ausführung von Skripten. Wird keine dieser Optionen angegeben, so wird standardmäßig WScript verwendet.
//S | Speichert die aktuellen Befehlszeilenoptionen für diesen Benutzer.
//? Zeigt Hilfen zur Verwendung des Befehls an (gleiches Verhalten wie beim Aufruf ohne Argumente).
//E:Modul | Führt das Skript mit dem angegebenen Skriptmodul aus.
//D | Aktiviert den Debugger.
//X | Startet das Programm im Debugger.
//Job:<JobID> | Startet die spezifizierte JobID aus der WSF-Datei.

Der Parameter //T verhindert mithilfe eines Zeitgebers übermäßig lange Ausführungszeiten von Skripten. Übersteigt die Ausführungszeit den vorgegebenen Wert, so unterbricht CScript das Skriptmodul mithilfe der IActiveScript::InterruptThread-Methode und terminiert den Prozess.

Ein CScript-Beispiel
Wenn Sie die endgültige Version von Windows Script Host installieren, werden gleichzeitig eine Anzahl von Beispielskripten installiert. Sie können diese auch unter folgender Adresse downloaden: http://www.microsoft.com/germany/scripting/

Im folgenden Beispiel wird vorausgesetzt, dass Sie das Beispielskript Chart.vbs in den Ordner

c:\Beispielskripte\chart.vbs

kopiert haben. Sie können das Skript wie im Folgenden dargestellt mit und ohne Logo ausführen:

  1. Rufen Sie über Start/Programme die MS-DOS®-Eingabeaufforderung auf.
  2. Geben Sie an der Eingabeaufforderung die folgenden Befehle ein (wenn Sie die Beispielskripte in einem anderen Ordner gespeichert haben, müssen Sie die Befehle entsprechend abwandeln):
cscript //logo c:\Beispielskripte\chart.vbs
cscript //nologo c:\Beispielskripte\chart.vbs


Drag & Drop-Unterstützung

Drag & Drop-Unterstützung 		WSH-Tutorium
Zurück
Weiter

Das Betriebssystem Windows unterstützt derzeit die Drag & Drop-Funktionalität mit Stapelverarbeitungsdateien. Diese Funktionalität, mit der Sie eine oder mehrere Dateien in eine Stapelverarbeitungsdatei ziehen und ablegen und mit den Dateien als Argumente ausführen können, wird nun ebenfalls unter Windows Script Host, Version 2.0, unterstützt.

Wenn Sie Dateien in ein WSH-Skript ziehen, werden die Dateinamen in Argumente für die Befehlszeile übersetzt. Diese Dateinamen können in einer Liste dargestellt werden, die Sie zum Bearbeiten von Dateien mit Skriptobjekten verwenden können.

So zeigen Sie die Argumentliste eines Skriptes an

  1. Erstellen Sie eine Datei mit der Dateinamenerweiterung VBS (beispielsweise DragDrop.vbs).

  2. Fügen Sie den folgenden Code in der VBS-Datei ein:

    3. Set objArgs = WScript.Arguments
For i = 0 to objArgs.Count - 1
  WScript.Echo objArgs(i)
Next
  3. Speichern Sie die Datei auf der Festplatte.

  4. Ziehen Sie eine oder mehrere Dateien, und legen Sie diese auf der VBS-Datei ab. Die Dateinamen werden auf dem Bildschirm ausgegeben.

Anmerkungen
Die Anzahl der Dateien, die Sie auf ein Skript ziehen können, wird durch die maximale vom System zulässige Befehlszeilenlänge eingeschränkt. Ist die Gesamtzahl aller Zeichen in den Namen der verwendeten Dateien größer als die vom System zulässige Anzahl, kann der Drag & Drop-Vorgang nicht durchgeführt werden.


Microsoft Windows Script Host-Referenz

Windows Script Host-Referenz 		WSH-Tutorium
Versionsinformation

Alphabetische Schlüsselwortliste

Eigenschaften

Elemente

Fehler

Methoden

Objekte

Willkommen bei der Windows Script Host-Referenz

Diese kompakten Informationsblöcke unterstützen Sie beim Arbeiten in den vielen verschiedenen Bereichen des Windows Script Hosts.

Sie finden eine alphabetische Auflistung sämtlicher Bereiche des WSH unter der alphabetischen Liste der Schlüsselwörter. Wenn Sie jedoch lediglich zu einer Kategorie, wie z. B. Objekten, etwas nachschlagen möchten, können Sie für jede einzelne Sprachkategorie einen eigenen, ausführlichen Bereich anzeigen.

Wie funktioniert es? Klicken Sie auf eine der links angezeigten Überschriften, um eine Auflistung der in dieser Kategorie enthaltenen Themen einzublenden. Wählen Sie aus dieser Auflistung das gewünschte Thema aus. Nachdem Sie das gewünschte Thema eingeblendet haben, können Sie problemlos zu anderen thematisch verknüpften Bereichen wechseln.

Tauchen Sie also ein! Informieren Sie sich über die vorhandenen Elemente, setzen Sie sich mit den Methoden auseinander, oder testen Sie die verschiedenen Eigenschaften. Sie werden feststellen, dass WSH ausgesprochen vielseitig ist!

Sprachelement | Beschreibung
<?job ?>-Element | XML-Verarbeitungsanweisung, die Attribute zur Fehlerbehandlung angibt.
<?XML ?>-Element | Gibt an, dass die Datei als XML analysiert werden soll.
<job>-Element | Ermöglicht die Definition mehrerer Aufträge in einer einzigen Datei. Da es sich um ein einschließendes Tag handelt, gilt jedes Tag innerhalb des Job-Tags für diesen Auftrag.
<object>-Element | In Skriptkomponentendateien verwendetes XML-Element zur Definition von Objekten, auf die vom Skript verwiesen werden kann.
<package>-Element | Schließt mehrere Auftragsdefinitionen ein.
<reference>-Element | In Windows Skriptkomponentendateien verwendetes XML-Element, das einen Verweis auf eine externe Typbibliothek enthält.
<resource>-Element | Dieses XML-Element isoliert Text- oder numerische Daten, die in Skripten nicht fest kodiert sein sollten.
<script>-Element | XML-Element, das Skriptbefehle zur Definition des Verhaltens von Windows Script Component enthält.
AddPrinterConnection-Methode | Ordnet den von strRemoteName angegebenen Netzwerkdrucker dem lokalen Ressourcennamen strLokalerName zu.
AddWindowsPrinterConnection-Methode | Fügt Windows eine Druckerverbindung hinzu.
AppActivate-Methode | Aktiviert ein Anwendungsfenster.
Application-Eigenschaft | Stellt für das WScript-Objekt die IDispatch-Oberfläche zur Verfügung.
Arguments-Eigenschaft | Gibt einen Zeiger auf die WshArguments-Auflistung zurück oder bezeichnet die Argumente für die Verknüpfung.
AtEndOfLine-Eigenschaft | Gibt True zurück, wenn sich der Streamzeiger in einem Eingabestream unmittelbar vor der Zeilenendemarke befindet, andernfalls False.
AtEndOfStream-Eigenschaft | Gibt True zurück, wenn sich der Streamzeiger am Ende des Eingabestreams befindet, andernfalls False.
Close-Methode | Schließt einen geöffneten Stream.
Column-Eigenschaft | Gibt die Spaltennummer der aktuellen Zeichenposition in einem Eingabestream zurück.
ComputerName-Eigenschaft | Enthält eine Zeichenfolgendarstellung des Computernamens.
ConnectObject-Methode | Verbindet die Ereignisquellen eines Objekts mit Funktionen mit einem gegebenen Präfix.
Count-Eigenschaft | Gibt die Zahl der Elemente in einer Auflistung zurück.
CreateObject-Methode | Erstellt das durch den Parameter strProgID angegebene Objekt.
CreateShortcut-Methode | Erstellt einen Objektverweis auf eine Verknüpfung oder eine URL-Verknüpfung.
Description-Eigenschaft | Enthält die Beschreibung eines Verknüpfungsobjekts.
DisconnectObject-Methode | Trennt ein zuvor verbundenes Objekt von Windows Script Host.
Echo-Methode | Zeigt Parameter in einem Fenster an.
EnumNetworkDrives-Methode | Gibt die aktuellen Netzlaufwerkzuordnungen zurück.
EnumPrinterConnections-Methode | Gibt die aktuellen Netzdruckerzuordnungen zurück.
Environment-Eigenschaft | Gibt das WshEnvironment-Objekt zurück.
Fehlermeldungen | Liste der Windows Script Host-Fehlermeldungen.
ExpandEnvironmentStrings-Methode | Erweitert die Umgebungsvariable PROCESS und gibt die Ergebniszeichenfolge zurück.
FullName-Eigenschaft | Gibt eine Zeichenfolge zurück, die den vollständigen Pfad zur ausführbaren Hostdatei oder zum Verknüpfungsobjekt enthält.
GetObject-Methode | Ruft ein Automatisierungsobjekt aus einer Datei oder ein durch den Parameter strProgID angegebenes Objekt ab.
getResource-Methode | Ermittelt den Wert einer mit dem <resource>-Element definierten Ressource.
HotKey-Eigenschaft | Enthält den Hotkey eines Verknüpfungsobjekts.
IconLocation-Eigenschaft | Enthält den Speicherort des Symbols eines Verknüpfungsobjekts.
Item-Eigenschaft | Gibt ein bestimmtes Element aus einer Auflistung zurück.
Length-Eigenschaft | Gibt die Anzahl der Elemente in einer Auflistung zurück.
Line-Eigenschaft | Gibt die aktuelle Zeilennummer in einem Eingabestream zurück.
LogEvent-Methode | Protokolliert ein Ereignis im Windows NT-Ereignisprotokoll oder in der Datei WSH.log.
MapNetworkDrive-Methode | Ordnet den von strRemoteName angegebenen Freigabepunkt dem Namen der lokalen Ressource strLokalerName zu.
Name-Eigenschaft | Enthält eine Zeichenfolge mit dem ausführlichen Namen des WScript-Objekts.
Path-Eigenschaft | Stellt eine Zeichenfolge zur Verfügung, die den Namen des Verzeichnisses mit WScript.Exe oder Cscript.Exe enthält.
Popup-Methode | Zeigt ein Popup-Meldungsfeld an, das die in strText enthaltene Meldung enthält.
Quit-Methode | Beendet die Ausführung mit dem angegebenen Fehlercode.
Read-Methode | Liest die angegeben Anzahl Zeichen aus einem Eingabestream und gibt die resultierende Zeichenfolge zurück.
ReadAll-Methode | Liest einen kompletten Eingabestream und gibt die resultierende Zeichenfolge zurück.
ReadLine-Methode | Liest eine komplette Zeile (bis zum Zeilenumbruchzeichen; dieses nicht eingeschlossen) aus einem Eingabestream und gibt die resultierende Zeichenfolge zurück.
RegDelete-Methode | Löscht den Schlüssel oder Wert von strName aus der Registrierung.
RegRead-Methode | Gibt den Registrierungsschlüssel oder -wert von strName zurück.
RegWrite-Methode | Legt den Registrierungsschlüssel oder -wert von strName fest.
Remove-Methode | Löscht die von strName angegebene Umgebungsvariable.
RemoveNetworkDrive-Methode | Entfernt die von strName bezeichnete aktuelle Ressourcenverbindung.
RemovePrinterConnection-Methode | Entfernt die von strName bezeichnete aktuelle Ressourcenverbindung.
Run-Methode | Erstellt einen neuen Prozess, der strBefehl ausführt.
Save-Methode | Speichert eine Verknüpfung zum angegebenen Ort.
ScriptFullName-Eigenschaft | Enthält den vollständigen Pfad zum ausgeführten Skript.
ScriptName-Eigenschaft | Enthält den Dateinamen des ausgeführten Skriptes.
SendKeys-Methode | Sendet eine oder mehrere Tasten an das aktive Fenster, als ob sie auf der Tastatur eingegeben würden.
SetDefaultPrinter-Methode | Legt den angegebenen Netzwerkdrucker als Standarddrucker fest.
Skip-Methode | Überspringt beim Lesen eines Eingabestreams die angegebene Zahl von Zeichen.
SkipLine-Methode | Überspringt beim Lesen eines Eingabestreams die nächste Zeile.
Sleep-Methode | Versetzt den Skriptprozess während der angegebenen Anzahl Millisekunden in einen inaktiven Zustand und setzt dann die Ausführung fort.
SpecialFolders-Eigenschaft | Enthält das WshSpecialFolders-Objekt zum Zugriff auf Windows-Shellordner, wie den Ordner Desktop, den Startmenüordner und den Ordner Eigene Dateien.
StdErr-Eigenschaft | Legt den nur zum Schreiben verfügbaren Fehlerausgabestream für das aktuelle Skript offen.
StdIn-Eigenschaft | Legt den schreibgeschützten Eingabestream für das aktuelle Skript offen.
StdOut-Eigenschaft | Legt den nur zum Schreiben verfügbaren Ausgabestream für das aktuelle Skript offen.
TargetPath-Eigenschaft | Legt für ein Verknüpfungsobjekt den Pfad der auszuführenden Datei fest.
UserDomain-Eigenschaft | Enthält eine Zeichenfolgendarstellung des Domänennamens des Benutzers.
UserName-Eigenschaft | Enthält eine Zeichenfolgendarstellung des Benutzernamens.
Version-Eigenschaft | Gibt die Version von Windows Script Host zurück.
WindowStyle-Eigenschaft | Enthält den Fensterstil eines Verknüpfungsobjekts.
WorkingDirectory-Eigenschaft | Enthält das Arbeitsverzeichnis eines Verknüpfungsobjekts.
Write-Methode | Schreibt die angegebene Zeichenfolge in einen Ausgabestream.
WriteBlankLines-Methode | Schreibt eine angegebene Zahl von Zeilenumbruchzeichen in einen Ausgabestream.
WriteLine-Methode | Schreibt eine angegebene Zeichenfolge und ein Zeilenumbruchzeichen in einen Ausgabestream.
WScript-Objekt | Legt Eigenschaften wie den Pfad des ausgeführten Scripting-Hosts (wscript.exe oder cscript.exe), seine Argumente und den Arbeitsmodus (interaktiv oder Batch) offen. Das WScript-Objekt stellt auch Methoden zum Erstellen und Lesen von Objekten bereit.
WshArguments-Objekt | Gibt einen Zeiger auf die Auflistung von Befehlszeilenparametern zurück.
WshEnvironment-Objekt | Ruft die Systemumgebungsvariablen ab.
WshNetwork-Objekt | Ordnet das Netzwerk zu, sodass es einfach ist, Remotelaufwerke und -drucker zu verbinden und zu trennen.
WshShell-Objekt | Startet neue Prozesse, erstellt Verknüpfungen und stellt die Environment-Auflistung zur Verfügung, um Umgebungsvariablen wie WINDIR, PATH oder PROMPT zu verwalten.
WshShortcut-Objekt | Erstellt einen Objektverweis auf eine Verknüpfung.
WshSpecialFolders-Objekt | Greift auf Windows-Shellordner, wie den Ordner Desktop, den Startmenüordner und den Ordner Eigene Dateien, zu.
WshUrlShortcut-Objekt | Erstellt einen Objektverweis auf eine URL-Verknüpfung.
Sprachelement | Beschreibung
<?job ?>-Element | XML-Verarbeitungsanweisung, die Attribute zur Fehlerbehandlung angibt.
<?XML ?>-Element | Gibt an, dass die Datei als XML analysiert werden soll.
<job>-Element | Ermöglicht die Definition mehrerer Aufträge in einer einzigen Datei. Da es sich um ein einschließendes Tag handelt, gilt jedes Tag innerhalb des Job-Tags für diesen Auftrag.
<object>-Element | In Windows Skriptkomponentendateien verwendetes XML-Element zur Definition von Objekten, auf die vom Skript verwiesen werden kann.
<package>-Element | Schließt mehrere Auftragsdefinitionen ein.
<reference>-Element | In Windows Skriptkomponentendateien verwendetes XML-Element, das einen Verweis auf eine externe Typbibliothek enthält.
<resource>-Element | Dieses XML-Element isoliert Text- oder numerische Daten, die in Skripten nicht fest kodiert sein sollten.
<script>-Element | XML-Element, das Skriptbefehle zur Definition des Verhaltens von Windows Script Component enthält.
Sprachelement | Beschreibung
Fehlermeldungen | Liste der Windows Script Host-Fehlermeldungen.
Sprachelement | Beschreibung
AddPrinterConnection-Methode | Ordnet den von strRemoteName angegebenen Netzwerkdrucker dem lokalen Ressourcennamen strLokalerName zu.
AddWindowsPrinterConnection-Methode | Fügt Windows eine Druckerverbindung hinzu.
AppActivate-Methode | Aktiviert ein Anwendungsfenster.
Close-Methode | Schließt einen geöffneten Stream.
ConnectObject-Methode | Verbindet die Ereignisquellen eines Objekts mit Funktionen mit einem gegebenen Präfix.
CreateObject-Methode | Erstellt das durch den Parameter strProgID angegebene Objekt.
CreateShortcut-Methode | Erstellt einen Objektverweis auf eine Verknüpfung oder eine URL-Verknüpfung.
DisconnectObject-Methode | Trennt ein zuvor verbundenes Objekt von Windows Script Host.
Echo-Methode | Zeigt Parameter in einem Fenster an.
EnumNetworkDrives-Methode | Gibt die aktuellen Netzlaufwerkzuordnungen zurück.
EnumPrinterConnections-Methode | Gibt die aktuellen Netzdruckerzuordnungen zurück.
ExpandEnvironmentStrings-Methode | Erweitert die Umgebungsvariable PROCESS und gibt die Ergebniszeichenfolge zurück.
GetObject-Methode | Ruft ein Automatisierungsobjekt aus einer Datei oder ein durch den Parameter strProgID angegebenes Objekt ab.
getResource-Methode | Ermittelt den Wert einer mit dem <resource>-Element definierten Ressource.
LogEvent-Methode | Protokolliert ein Ereignis im Windows NT-Ereignisprotokoll oder in der Datei WSH.log.
MapNetworkDrive-Methode | Ordnet den von strRemoteName angegebenen Freigabepunkt dem Namen der lokalen Ressource strLokalerName zu.
Popup-Methode | Zeigt ein Popup-Meldungsfeld an, das die in strText enthaltene Meldung enthält.
Quit-Methode | Beendet die Ausführung mit dem angegebenen Fehlercode.
Read-Methode | Liest die angegeben Anzahl Zeichen aus einem Eingabestream und gibt die resultierende Zeichenfolge zurück.
ReadAll-Methode | Liest einen kompletten Eingabestream und gibt die resultierende Zeichenfolge zurück.
ReadLine-Methode | Liest eine komplette Zeile (bis zum Zeilenumbruchzeichen; dieses nicht eingeschlossen) aus einem Eingabestream und gibt die resultierende Zeichenfolge zurück.
RegDelete-Methode | Löscht den Schlüssel oder Wert von strName aus der Registrierung.
RegRead-Methode | Gibt den Registrierungsschlüssel oder -wert von strName zurück.
RegWrite-Methode | Legt den Registrierungsschlüssel oder -wert von strName fest.
Remove-Methode | Löscht die von strName angegebene Umgebungsvariable.
RemoveNetworkDrive-Methode | Entfernt die von strName bezeichnete aktuelle Ressourcenverbindung.
RemovePrinterConnection-Methode | Entfernt die von strName bezeichnete aktuelle Ressourcenverbindung.
Run-Methode | Erstellt einen neuen Prozess, der strBefehl ausführt.
Save-Methode | Speichert eine Verknüpfung zum angegebenen Ort.
SendKeys-Methode | Sendet eine oder mehrere Tasten an das aktive Fenster, als ob sie auf der Tastatur eingegeben würden.
SetDefaultPrinter-Methode | Legt den angegebenen Netzwerkdrucker als Standarddrucker fest.
Skip-Methode | Überspringt beim Lesen eines Eingabestreams die angegebene Zahl von Zeichen.
SkipLine-Methode | Überspringt beim Lesen eines Eingabestreams die nächste Zeile.
Sleep-Methode | Versetzt den Skriptprozess während der angegebenen Anzahl Millisekunden in einen inaktiven Zustand und setzt dann die Ausführung fort.
Write-Methode | Schreibt die angegebene Zeichenfolge in einen Ausgabestream.
WriteBlankLines-Methode | Schreibt eine angegebene Zahl von Zeilenumbruchzeichen in einen Ausgabestream.
WriteLine-Methode | Schreibt eine angegebene Zeichenfolge und ein Zeilenumbruchzeichen in einen Ausgabestream.
Sprachelement | Beschreibung
WScript-Objekt | Legt Eigenschaften wie den Pfad des ausgeführten Scripting-Hosts (wscript.exe oder cscript.exe), seine Argumente und den Arbeitsmodus (interaktiv oder Batch) offen. Das WScript-Objekt stellt auch Methoden zum Erstellen und Lesen von Objekten bereit.
WshArguments-Objekt | Gibt einen Zeiger auf die Auflistung von Befehlszeilenparametern zurück.
WshEnvironment-Objekt | Ruft die Systemumgebungsvariablen ab.
WshNetwork-Objekt | Ordnet das Netzwerk zu, sodass es einfach ist, Remotelaufwerke und -drucker zu verbinden und zu trennen.
WshShell-Objekt | Startet neue Prozesse, erstellt Verknüpfungen und stellt die Environment-Auflistung zur Verfügung, um Umgebungsvariablen wie WINDIR, PATH oder PROMPT zu verwalten.
WshShortcut-Objekt | Erstellt einen Objektverweis auf eine Verknüpfung.
WshSpecialFolders-Objekt | Greift auf Windows-Shellordner, wie den Ordner Desktop, den Startmenüordner und den Ordner Eigene Dateien, zu.
WshUrlShortcut-Objekt | Erstellt einen Objektverweis auf eine URL-Verknüpfung.
Sprachelement | Beschreibung
Application-Eigenschaft | Stellt für das WScript-Objekt die IDispatch-Oberfläche zur Verfügung.
Arguments-Eigenschaft | Gibt einen Zeiger auf die WshArguments-Auflistung zurück oder bezeichnet die Argumente für die Verknüpfung.
AtEndOfLine-Eigenschaft | Gibt True zurück, wenn sich der Streamzeiger in einem Eingabestream unmittelbar vor der Zeilenendemarke befindet, andernfalls False.
AtEndOfStream-Eigenschaft | Gibt True zurück, wenn sich der Streamzeiger am Ende des Eingabestreams befindet, andernfalls False.
Column-Eigenschaft | Gibt die Spaltennummer der aktuellen Zeichenposition in einem Eingabestream zurück.
ComputerName-Eigenschaft | Enthält eine Zeichenfolgendarstellung des Computernamens.
Count-Eigenschaft | Gibt die Anzahl der Elemente in einer Auflistung zurück.
Description-Eigenschaft | Enthält die Beschreibung eines Verknüpfungsobjekts.
Environment-Eigenschaft | Gibt das WshEnvironment-Objekt zurück.
FullName-Eigenschaft | Gibt eine Zeichenfolge zurück, die den vollständigen Pfad zur ausführbaren Hostdatei oder zum Verknüpfungsobjekt enthält.
HotKey-Eigenschaft | Enthält den Hotkey eines Verknüpfungsobjekts.
IconLocation-Eigenschaft | Enthält den Speicherort des Symbols eines Verknüpfungsobjekts.
Item-Eigenschaft | Gibt ein bestimmtes Element aus einer Auflistung zurück.
Length-Eigenschaft | Gibt die Anzahl der Elemente in einer Auflistung zurück.
Line-Eigenschaft | Gibt die aktuelle Zeilennummer in einem Eingabestream zurück.
Name-Eigenschaft | Enthält eine Zeichenfolge mit dem ausführlichen Namen des WScript-Objekts.
Path-Eigenschaft | Stellt eine Zeichenfolge zur Verfügung, die den Namen des Verzeichnisses mit WScript.Exe oder CScript.Exe enthält.
ScriptFullName-Eigenschaft | Enthält den vollständigen Pfad zum ausgeführten Skript.
ScriptName-Eigenschaft | Enthält den Dateinamen des ausgeführten Skriptes.
SpecialFolders-Eigenschaft | Enthält das WshSpecialFolders-Objekt zum Zugriff auf Windows-Shellordner, wie den Ordner Desktop, den Startmenüordner und den Ordner Eigene Dateien.
StdErr-Eigenschaft | Legt den nur zum Schreiben verfügbaren Fehlerausgabestream für das aktuelle Skript offen.
StdIn-Eigenschaft | Legt den schreibgeschützten Eingabestream für das aktuelle Skript offen.
StdOut-Eigenschaft | Legt den nur zum Schreiben verfügbaren Ausgabestream für das aktuelle Skript offen.
TargetPath-Eigenschaft | Legt für ein Verknüpfungsobjekt den Pfad der auszuführenden Datei fest.
UserDomain-Eigenschaft | Enthält eine Zeichenfolgendarstellung des Domänennamens des Benutzers.
UserName-Eigenschaft | Enthält eine Zeichenfolgendarstellung des Benutzernamens.
Version-Eigenschaft | Gibt die Version von Windows Script Host zurück.
WindowStyle-Eigenschaft | Enthält den Fensterstil eines Verknüpfungsobjekts.
WorkingDirectory-Eigenschaft | Enthält das Arbeitsverzeichnis eines Verknüpfungsobjekts.

© 1999 Microsoft Corporation. Alle Rechte vorbalten.


Eigenschaften

Eigenschaften 		WSH-Referenz

Application-Eigenschaft
Arguments-Eigenschaft
AtEndOfLine-Eigenschaft
AtEndOfStream-Eigenschaft
Column-Eigenschaft
ComputerName-Eigenschaft
Count-Eigenschaft
Description-Eigenschaft
Environment-Eigenschaft
FullName-Eigenschaft
Hotkey-Eigenschaft
IconLocation-Eigenschaft
Item-Eigenschaft
Length-Eigenschaft
Line-Eigenschaft
Name-Eigenschaft
Path-Eigenschaft
ScriptFullName-Eigenschaft
ScriptName-Eigenschaft
SpecialFolders-Eigenschaft
StdErr-Eigenschaft
StdIn-Eigenschaft
StdOut-Eigenschaft
TargetPath-Eigenschaft
UserDomain-Eigenschaft
UserName-Eigenschaft
Version-Eigenschaft
WindowStyle-Eigenschaft
WorkingDirectory-Eigenschaft


Elemente

Elemente 		WSH-Referenz

<?job ?>-Element
<?XML ?>-Element
<job>-Element
<object>-Element
<package>-Element
<reference>-Element
<resource>-Element
<script>-Element


Fehlermeldungen

Fehlermeldungen 		WSH-Referenz

Fehlermeldung | Mögliche Ursache
Der Pfad der Verknüpfung muss mit .lnk oder .url enden. | Versuch einer Verknüpfung mit einer falschen Dateinamenerweiterung.
Ein Drucker mit der Bezeichnung ""%1"" ist nicht vorhanden. | Falscher Druckername in SetDefaultPrinter.
Umgebungsvariable ""%1"" kann nicht entfernt werden. | Aufrufen von Environment.Remove für eine nichtexistierende Umgebungsvariable.
Registrierungsschlüssel ""%1"" kann nicht entfernt werden. | Aufrufen von RegDelete für einen nicht vorhandenen Registrierungsschlüssel.
Ungültiger Stammordner in Registrierungsschlüssel ""%1"". | Aufrufen von RegRead oder RegWrite für einen ungültigen Registrierungsschlüssel.
Registrierungsschlüssel ""%1"" kann nicht zum Lesen geöffnet werden. | Aufrufen von RegRead für einen nicht vorhandenen Registrierungsschlüssel.
Fehler beim Schreiben in die Datei wsh.log. Bitte wenden Sie sich an Ihren Administrator. | Aufrufen von LogEvent auf Win9x bei gesperrter %windir%\wsh.log-Datei.
Die Verknüpfung ""%1"" kann nicht gespeichert werden. | Versuch, eine bereits vorhandene und schreibgeschützte Verknüpfung oder URL-Verknüpfung zu speichern.
Protokollbehandlungsroutine für ""%1"" konnte nicht ausgeführt werden. | Versuch, eine URL-Verknüpfung zu einer nicht ordnungsgemäß registrierten Protokollbehandlungsroutine einzurichten.
Ungültige Syntax in URL: ""%1"". | Versuch, eine URL-Verknüpfung zu einem falsch eingegebenen URL einzurichten.
Protokollbehandlungsroutine für ""%1"" nicht gefunden. | Versuch, eine URL-Verknüpfung zu einem URL mit einer nicht vorhandenen Protokollbehandlungsroutine einzurichten.
Ausführung fehlgeschlagen - Argumentliste zu lang. | Zu viele Elemente während eines Drag & Drop-Vorgangs auf einer Skriptdatei abgelegt.
Warten auf Prozess nicht möglich. | Warten auf einen Vorgang, auf den nicht gewartet werden kann, wie z. B. das Ergebnis beim Ausführen einer Verknüpfung.


Methoden

Methoden 		WSH-Referenz

AddPrinterConnection-Methode
AddWindowsPrinterConnection-Methode
AppActivate-Methode
Close-Methode
ConnectObject-Methode
CreateObject-Methode
CreateShortcut-Methode
DisconnectObject-Methode
Echo-Methode
EnumNetworkDrives-Methode
EnumPrinterConnections-Methode
ExpandEnvironmentStrings-Methode
GetObject-Methode
getResource-Methode
LogEvent-Methode
MapNetworkDrive-Methode
Popup-Methode
Quit-Methode
Read-Methode
ReadAll-Methode
ReadLine-Methode
RegDelete-Methode
RegRead-Methode
RegWrite-Methode
Remove-Methode
RemoveNetworkDrive-Methode
RemovePrinterConnection-Methode
Run-Methode
Save-Methode
SendKeys-Methode
SetDefaultPrinter-Methode
Skip-Methode
SkipLine-Methode
Sleep-Methode
Write-Methode
WriteBlankLines-Methode
WriteLine-Methode


Objekte

Objekte 		WSH-Referenz

WScript-Objekt
WshArguments-Objekt
WshEnvironment-Objekt
WshNetwork-Objekt
WshShell-Objekt
WshShortcut-Objekt
WshSpecialFolders-Objekt
WshUrlShortcut-Objekt


WSH-Versionsinformationen

Versionsinformationen 		WSH-Referenz

Die folgende Tabelle führt die in den verschiedenen Microsoft-Hostanwendungen implementierten Versionen von Windows Script Host auf.

Hostanwendung | WSH-Version
1.0 | 2.0
Microsoft Windows 98 | x
Microsoft Windows NT 4 Option Pack | x
Microsoft Windows 2000 | x

Die folgende Tabelle listet die Sprachelemente von Windows Script Host auf und gibt an, in welcher WSH-Version diese eingeführt wurden.

Element | Erstmalig in Version
1.0 | 2.0
<?job ?>-Element | x
<?XML ?>-Element | x
<job>-Element | x
<object>-Element | x
<package>-Element | x
<reference>-Element | x
<resource>-Element | x
<script>-Element | x
AddPrinterConnection-Methode | x
AddWindowsPrinterConnection-Methode | x
AppActivate-Methode | x
Application-Eigenschaft | x
Arguments-Eigenschaft | x
AtEndOfLine-Eigenschaft | x
AtEndOfStream-Eigenschaft | x
Close-Methode | x
Column-Eigenschaft | x
ComputerName-Eigenschaft | x
ConnectObject-Methode | x
Count-Eigenschaft | x
CreateObject-Methode | x
CreateShortcut-Methode | x
Description-Eigenschaft | x
DisconnectObject-Methode | x
Echo-Methode | x
EnumNetworkDrives-Methode | x
EnumPrinterConnections-Methode | x
Environment-Eigenschaft | x
ExpandEnvironmentStrings-Methode | x
FullName-Eigenschaft | x
GetObject-Methode | x
getResource-Methode | x
HotKey-Eigenschaft | x
IconLocation-Eigenschaft | x
Item-Eigenschaft | x
Length-Eigenschaft | x
Line-Eigenschaft | x
LogEvent-Methode | x
MapNetworkDrive-Methode | x
Name-Eigenschaft | x
Path-Eigenschaft | x
Popup-Methode | x
Quit-Methode | x
Read-Methode | x
ReadAll-Methode | x
ReadLine-Methode | x
RegDelete-Methode | x
RegRead-Methode | x
RegWrite-Methode | x
Remove-Methode | x
RemoveNetworkDrive-Methode | x
RemovePrinterConnection-Methode | x
Run-Methode | x
Save-Methode | x
ScriptFullName-Eigenschaft | x
ScriptName-Eigenschaft | x
SendKeys-Methode | x
SetDefaultPrinter-Methode | x
Skip-Methode | x
SkipLine-Methode | x
Sleep-Methode | x
SpecialFolders-Eigenschaft | x
StdErr-Eigenschaft | x
StdIn-Eigenschaft | x
StdOut-Eigenschaft | x
TargetPath-Eigenschaft | x
UserDomain-Eigenschaft | x
UserName-Eigenschaft | x
Version-Eigenschaft | x
WindowStyle-Eigenschaft | x
WorkingDirectory-Eigenschaft | x
Write-Methode | x
WriteBlankLines-Methode | x
WriteLine-Methode | x
WScript-Objekt | x
WshArguments-Objekt | x
WshEnvironment-Objekt | x
WshNetwork-Objekt | x
WshShell-Objekt | x
WshShortcut-Objekt | x
WshSpecialFolders-Objekt | x
WshUrlShortcut-Objekt | x


Copyright

Die in diesen Unterlagen enthaltenen Angaben und Daten können ohne vorherige Ankündigung geändert werden. Die hierin genannten Namen von Firmen, Produkten, Personen, Charakteren und/oder Daten sind fiktiv und sollen in keiner Weise reale Individuen, Firmen, Produkte oder Ereignisse darstellen, falls dies nicht ausdrücklich angemerkt ist. Die Benutzerinnen und Benutzer sind verpflichtet, sich an alle anwendbaren Urheberrechtsgesetze zu halten. Ohne ausdrückliche schriftliche Erlaubnis von Microsoft Corporation darf kein Teil dieser Unterlagen für irgendwelche Zwecke vervielfältigt oder übertragen werden, unabhängig davon, auf welche Weise oder mit welchen Mitteln, elektronisch oder mechanisch, dies geschieht.

Microsoft verfügt möglicherweise über Patente, angemeldete Patente, Marken, Urheberrechte oder andere geistige Eigentumsrechte an Inhalten in diesen Unterlagen. Durch die Bereitstellung dieser Unterlagen erhalten Sie keinerlei Lizenzrechte an diesen Patenten, Marken, Urheberrechten oder anderen Rechten geistigen Eigentums, es sei denn, dies wurde explizit durch einen schriftlichen Lizenzvertrag mit Microsoft vereinbart.

© 1991-1999 Microsoft Corporation. Alle Rechte vorbehalten.

Microsoft, MS, MS-DOS, ActiveX, JScript, Microsoft Press, Visual Basic, Windows, Windows NT, Win32 und Win32s sind Marken oder eingetragene Marken der Microsoft Corporation in den USA und/oder anderen Ländern.

Andere hierin genannten Produkt- oder Firmennamen können Marken der jeweiligen Eigentümer sein.


<?job ?>-Element

<job>-Element 		WSH-Referenz
Version 2

Beschreibung
Ermöglicht die Definition mehrerer Aufträge in einer einzigen Datei. Da es sich um ein einschließendes Tag handelt, gilt jedes Tag innerhalb des Job-Tags für diesen Auftrag.
Syntax
<job [id=AuftragsID]>
Auftragscode
</job>
Parameter
Teil | Beschreibung
AuftragsID | Optional. Die (für die Datei) eindeutige Auftragskennung.
Beispiel
Im folgenden Beispiel werden zwei Aufträge unter Verwendung von zwei unterschiedlichen Skripterstellungssprachen in eine WSF-Datei integriert:
<package>

<job id="InVBS">
<?job debug="true"?>
<script language="VBScript">
    WScript.Echo "Das ist VBScript"
</script>
</job>

<job id="InJS">
<?job debug="true"?>
<script language="JScript">
    WScript.Echo("Das ist JScript");
</script>
</job>

</package>


<object>-Element

<object>-Element 		WSH-Referenz
Version 2

Beschreibung
In Windows Skriptkomponentendateien verwendetes XML-Element zur Definition von Objekten, auf die vom Skript verwiesen werden kann.
Syntax
<object id="objID" [classid="clsid:GUID" | progid="progID"] />

Parameter
Teil | Beschreibung
objID Ein Name, unter dem im Skript auf das Objekt verwiesen werden kann. Objekt-ID-Werte müssen mit einem Buchstaben beginnen und können Buchstaben, Ziffern und Unterstreichungzeichen (_) enthalten. Die Objekt-ID muss im gesamten Gültigkeitsbereich von Windows Script Component eindeutig sein. Wenn Sie z. B. den Namen CObj angeben, können Sie im Skript auf folgende Weise auf das Objekt verweisen:
x = CObj.Eigensch1
GUID (Optional) Ein Verweis auf die Klassen-ID (GUID), mit der das Objekt registriert wurde. Verwenden Sie "clsid:" und direkt dahinter die Klassen-ID (ohne Klammern). Sie müssen entweder ein classid- oder ein progid-Attribut wie im nachstehenden Beispiel angeben:
classid="clsid:2154c700-9253-11d1-a3ac-0aa0044eb5f"
progID | (Optional) Die Programm-ID des Objekts, die alternativ zu der Klassen-ID angegeben werden kann. Sie müssen entweder das classid- oder das progid-Attribut angeben.
Hinweise
Das <object>-Element bietet eine Möglichkeit, Objekte global für den Einsatz im Skript innerhalb von Windows Script Component offen zu legen, ohne dazu eine Funktion wie CreateObject() verwenden zu müssen. Durch Verwenden des <object>-Elements steht das Objekt im globalen Gültigkeitsbereich zur Verfügung und ermöglicht Skripterstellungstools das Bereitstellen der Anweisungsvervollständigung für die Mitglieder des Objekts.


<package>-Element

<package>-Element 		WSH-Referenz
Version 2

Beschreibung
Schließt mehrere Auftragsdefinitionen in einer Windows Script Host-Steuerungsdatei (.WSF) ein.
Syntax
<package>
Code für einen oder mehrere Aufträge
</package>
Anmerkungen
Das <package>-Element ist optional, wenn eine WSF-Datei nur einen Auftrag enthält.
Beispiel
Im folgenden Beispiel werden zwei Aufträge unter Verwendung von zwei verschiedenen Skripterstellungssprachen in eine WSF-Datei integriert:
<package>

<job id="InVBS">
<?job debug="true"?>
<script language="VBScript">
    WScript.Echo "Das ist VBScript"
</script>
</job>

<job id="InJS">
<?job debug="true"?>
<script language="JScript">
    WScript.Echo("Das ist JScript");
</script>
</job>

</package>


<reference>-Element

<reference>-Element 		WSH-Referenz
Version 2

Beschreibung
XML-Element, das eine Referenz auf eine externe Typbibliothek enthält.
Syntax
<reference [object="ProgID"|guid="TypbiblGUID"] [version="Version"] />

Parameter
Teil | Beschreibung
ProgID | Die Programm-ID, aus der die Typbibliothek abgeleitet werden kann. Diese kann eine Versionsnummer (z.B. ADO.Recordset.2.0) oder die explizite Programm-ID einer Typbibliothek oder einer ausführbaren Datei (z. B. einer DLL-Datei) enthalten, die die Typbibliothek integriert. Bei Verwendung des object-Attributs ist die Angabe eines Versionsattributs nicht erforderlich, da die Version von der Programm-ID abgeleitet werden kann. Wird ein object-Attribut angegeben, kann nicht gleichzeitig ein guid-Attribut verwendet werden.
TypbiblGUID | Die GUID der Typbibliothek, auf die verwiesen wird. Wenn das guid-Attribut angegeben wird, können Sie nicht auch ein object-Attribut angeben.
Version | (Optional) Die Versionsnummer der zu verwendenden Typbibliothek. Diese muss das Format <major version>[.<minor version>] aufweisen. Wurde keine Version angegeben, ist 1.0 die Standardversion. Bei Verwendung des object-Attributs zum Angeben der Typbibliothek anstelle der Version wird die Version aus dem Registrierungsschlüssel für die angegebene Programm-ID abgeleitet. Wird keine Programm-ID gefunden, ist die Voreinstellung 1.0.
Hinweise
Durch das Verweisen auf eine Typbibliothek in einer Windows-Skriptkomponente können Sie Konstanten verwenden, die in Skripten in der Typbibliothek definiert sind. Das <reference>-Element sucht die Typbibliothek, die mit einer bestimmten Programm-ID oder einem Typbibliotheksnamen verknüpft ist, und macht diese verfügbar. Typbibliotheksinformationen können in .TLB-, .OLB- oder .DLL-Dateien enthalten sein.

Fehlerwerte
Die folgenden, auf das Typbibliotheken bezogenen Fehlermeldungen können vom WSH-Laufzeitmodul ausgegeben werden:

Fehler | Beschreibung | Grund
WSH 0201: Ungültige Typbibliotheksbezeichnung | Das TYPELIB-Tag enthält eine ungültige Typbibliotheksbezeichnung. | Typbibliothek ist beschädigt.
WSH 0202: Die Typbibliothek kann nicht geladen werden | Windows Script Host kann die im TYPELIB-Tag genannte Typbibliothek nicht laden. | Die Typbibliothek kann nicht gefunden/geladen werden.
WSH 0203:Die Typbibliothek kann nicht umbrochen werden | Windows Script Host kann kein Type Library Wrapper-Objekt aus den im TYPELIB-Tag genannten Typbibliotheken erstellen. | Anderer Grund.


<resource>-Element

<resource>-Element 		WSH-Referenz
Version 2

Beschreibung
XML-Element, das Text- oder numerische Daten isoliert, die in Skripten nicht explizit kodiert sein sollten.
Syntax
<resource id="RessourceID">
Text oder Zahlen
</resource>
Parameter
Teil | Beschreibung
RessourceID | Ein eindeutiger Bezeichner für die Ressource im Skript.
Hinweise
Mithilfe des <resource>-Elements können Sie Zeichenfolgen oder Zahlen in einer Windows-Skriptdatei isolieren, auf die Sie in Skripten verweisen möchten. In der Regel werden resource-Elemente für die Verwaltung von Zeichenfolgen verwendet, die möglicherweise in eine andere Sprache lokalisiert werden.

Um den Wert einer Ressource zu erhalten, rufen Sie die getResource-Methode auf und übergeben an diese die ID der zu verwendenden Ressource.

Beispiel
Das folgende Codefragment definiert eine Ressource (errNichtNumerisch) und gibt deren Wert zurück, wenn die Variable für obereGrenze nicht numerisch ist.
<resource id="errNichtNumerisch">
    Nicht-numerischen Wert übergeben
</resource>

<script language="VBScript">
<![CDATA[
Function erzeugeZufallszahl(obereGrenze)
    If IsNumeric(obereGrenze) Then
        erzeugeZufallszahl = CInt(obereGrenze * Rnd + 1)
    Else
        erzeugeZufallszahl=getResource("errNichtNumerisch")
    End If
End Function
]]>
</script>


<script>-Element

<script>-Element 		WSH-Referenz
Version 2

Beschreibung
XML-Element, das Skriptbefehle zur Definition des Verhaltens einer Windows-Skriptkomponente enthält.
Syntax
<script language="Sprache" [src="strFile"]>
Skriptinformationen
</script>
Parameter
Teil | Beschreibung
Sprache | Der Name der Skripterstellungssprache, die in der Windows-Skriptkomponentendatei verwendet wird, z. B. Microsoft® Visual Basic® Scripting Edition (VBScript) oder Microsoft JScript®.
strFile | Der Name der Skriptdatei, die im <script>-Block angegeben wird.
Hinweise
Ist die XML-Überprüfung nicht aktiviert, ignoriert die XML-Syntaxanalyse alle Zeilen innerhalb des <script>-Elements. Wenn die XML-Überprüfung jedoch aktiviert wurde, indem die <?XML ?>-Deklaration oben in die Skriptkomponentendatei eingefügt wurde, kann die XML-Syntaxanalyse Zeichen wie "Größer als" (>), "Kleiner als" (<) und andere Symbole falsch interpretieren, die im Skript als XML-Trennzeichen verwendet werden.

Wenn Sie eine Datei erstellen, die nahezu der XML-Syntax entspricht, müssen Sie sicherstellen, dass die Zeichen im script-Element nicht als reservierte XML-Zeichen behandelt werden. Fügen Sie dazu das tatsächliche Skript in einen <![CDATA[ ... ]]>-Abschnitt ein.

Anmerkung Fügen Sie nur dann einen CDATA-Abschnitt ein, wenn Sie auch eine <?XML ?>-Deklaration einfügen.

Beispiel
Im folgenden Beispiel werden zwei Aufträge unter Verwendung von zwei verschiedenen Skriptsprachen in eine WSF-Datei integriert:
<package>

<job id="InVBS">
<?job debug="true"?>
<script language="VBScript">
    WScript.Echo "Das ist VBScript"
</script>
</job>

<job id="InJS">
<?job debug="true"?>
<script language="JScript">
    WScript.Echo("Das ist JScript");
</script>
</job>

</package>


<?XML ?>-Element

<?XML ?>
Element 		WSH-Referenz
Version 2

Beschreibung
Gibt an, dass die Datei als XML analysiert werden soll.
Syntax
<?XML version="Version" [standalone="DTD-Flag"] ?>
Parameter
Teil | Beschreibung
Version | Eine Zeichenfolge im Format n.n, die die XML-Stufe der Datei angibt. Verwenden Sie den Wert 1.0.
DTD-Flag | Optional. Ein boolescher Wert, der angibt, ob die XML-Datei eine Referenz auf eine externe Dokumenttypdefinition (DTD) enthält. Skriptkomponenten-XML-Dateien enthalten diese Referenz nicht, sodass der Wert für dieses Attribut stets "YES" ist.
Hinweise
Diese Deklaration muss das erste Element in der Datei sein, und es dürfen keine Leerzeilen vorangestellt werden.

Durch das Vorhandensein dieser Deklaration wird der Skriptkomponenten-Compiler in einen strikten XML-Modus versetzt, in dem Elementtypen und Attributnamen Groß- und Kleinschreibung unterscheiden, Attributwerte in einfache oder doppelte Anführungszeichen gesetzt werden müssen und die Syntax aller Elemente analysiert wird. Wird die Deklaration nicht eingefügt, erlaubt der Compiler eine losere Syntax.

In der Regel sollten Sie diese Deklaration einfügen und die XML-Richtlinien befolgen, wenn eine Skriptkomponentendatei von einem Editor bearbeitet werden soll, der XML unterstützt.

Beispiel
<?XML version="1.0" standalone="yes" ?>


<?job ?>-Element

<?job ?>-Element
 WSH-Referenz
Version 2

Beschreibung
XML-Verarbeitungsanweisung, die Attribute zur Fehlerbehandlung enthält.
Syntax
<?job Fehler="flag" Debug="flag" ?>
Parameter
Teil | Beschreibung
Fehler, Debug | Ein boolescher Wert: "true" oder "false," 1 oder 0 bzw. "yes" oder "no". Die Voreinstellung für alle Attribute ist "false".
Hinweise
Normalerweise werden Batchdateien zwar unbemerkbar ausgeführt, eventuell ist jedoch eine Benachrichtung im Falle von Fehlern sinnvoll, die bei der Entwicklung von Windows-Skriptkomponentendateien auftreten. Die folgenden Typen von Fehlermeldungen können angegeben werden:

Attribute | Beschreibung
Fehler Setzen Sie diese auf "true", um Fehlermeldungen zu Syntax- oder Laufzeitfehlern in der Windows-Skriptdatei anzuzeigen.
Debug | Setzen Sie diese auf "true", um den Debugvorgang zu aktivieren. Wenn der Debugvorgang nicht aktiviert ist, ist das Starten des Skript-Debuggers für eine WSH-Batchdatei nicht möglich.

Beispiel
Im folgenden Beispiel werden zwei Aufträge unter Verwendung von zwei verschiedenen Skripterstellungssprachen in eine WSF-Datei integriert:
<package>

<job id="InVBS">
<?job debug="true"?>
<script language="VBScript">
    WScript.Echo "Das ist VBScript"
</script>
</job>

<job id="InJS">
<?job debug="true"?>
<script language="JScript">
    WScript.Echo("Das ist JScript");
</script>
</job>

</package>


Microsoft Windows Script Host-Referenz

Windows Script Host-Referenz 		WSH-Tutorium
 Versionsinformationen

Alphabetische
Schlüsselwortliste
Eigenschaften

Elemente

Fehler

Methoden

Objekte

© 1998 Microsoft Corporation. Alle Rechte vorbehalten.


AddPrinterConnection-Methode

AddPrinterConnection-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Ordnet den von strRemoteName angegebenen Netzwerkdrucker dem lokalen Ressourcennamen strLokalerName zu.
Syntax
Objekt.AddPrinterConnection strLokalerName, strRemoteName[,bProfilAktual][,strBenutzer][,strKennwort]
Parameter
Teil | Beschreibung
Objekt | WshNetwork-Objekt.
strLokalerName | Lokale Druckerressource.
strRemoteName | Remote-Druckerressource.
bProfilAktual | Optional. Wenn bProfilAktual angegeben wird und dessen Wert TRUE ist, wird diese Zuordnung im Benutzerprofil gespeichert.
strBenutzer | Optional. Wenn Sie einen Netzwerkdrucker mit den Angaben eines anderen Benutzers als dem aktuellen zuordnen, können Sie strBenutzer und strKennwort angeben.
strKennwort | Optional. Wenn Sie einen Netzwerkdrucker mit den Angaben eines anderen Benutzers als dem aktuellen zuordnen, können Sie strBenutzer und strKennwort angeben.
Beispiel
Im folgenden Beispiel wird die AddPrinterConnection-Methode zum Verbinden eines Netzwerkdruckers mit LPT1 verwendet.
Set objNetzwerk = CreateObject("WScript.Network")
objNetzwerk.AddPrinterConnection "LPT1", "\\Server\Druck1"


AddPrinterConnection-Methode

AddPrinterConnection-Methode
Betrifft 		WSH-Referenz
WshNetwork-Objekt


AddPrinterConnection-Methode

AddPrinterConnection-Methode
Siehe auch 		WSH-Referenz
AddWindowsPrinterConnection-Methode
EnumPrinterConnections-Methode
RemovePrinterConnection-Methode
SetDefaultPrinter-Methode


AddWindowsPrinterConnection-Methode

AddWindowsPrinterConnection-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Fügt Windows eine Druckerverbindung hinzu.
Syntax
Windows NT/Windows 2000:
Objekt.AddWindowsPrinterConnection(strDruckerPfad)

Windows 95/98:
Objekt.AddWindowsPrinterConnection(strDruckerPfad, strTreiberName[,strAnschluss])
Parameter
Teil | Beschreibung
Objekt | WshNetwork-Objekt.
strDruckerPfad | Verzeichnispfad des Druckers.
strTreiberName | Der Name des zu verwendenden Treibers. Erforderlich bei der Ausführung unter Windows 95/98; wird unter Windows NT/Windows 2000 nicht verwendet.
strAnschluss | Optional. Gibt den Anschluss an, mit dem der Drucker unter Windows 95/98 verbunden wird. Der Standardanschluss ist LPT1. Wird unter Windows NT/Windows 2000 nicht verwendet.
Hinweise
Diese Vorgehensweise entspricht dem Einrichten einer Druckerverbindung über die Option Drucker in der Systemsteuerung. Im Gegensatz zur AddPrinterConnection-Methode kann eine Druckerverbindung ohne Angabe eines bestimmten Anschlusses, wie z. B. LPT1, eingerichtet werden. Wenn die Verbindung fehlschlägt, wird eine Fehlermeldung angezeigt.

Unter Windows 95/98 muss der Druckertreiber bereits auf dem Computer installiert sein, damit die AddWindowsPrinterConnection-Methode ordnungsgemäß ausgeführt wird. Wenn der Treiber nicht installiert ist, gibt Windows die Fehlermeldung "Unbekannter Druckertreiber" aus.

Beispiel
Im folgenden Beispiel wird die AddWindowsPrinterConnection-Methode zum Verbinden eines Netzwerkdruckers mit LPT1 verwendet.
Set objNetzwerk = CreateObject("WScript.Network")
DruckerPfad = "\\druckserv\StandardDrucker"
DruckerTreiber = "Lexmark Optra S 1650"
objNetzwerk.AddWindowsPrinterConnection DruckerPfad, DruckerTreiber


AddWindowsPrinterConnection-Methode

AddWindowsPrinterConnection-Methode
Betrifft 		WSH-Referenz
WshNetwork-Objekt


AppActivate-Methode

AppActivate-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Aktiviert ein Anwendungsfenster.
Syntax
AppActivate Titel
Parameter
Teil | Beschreibung
Titel | Erforderlich. Zeichenfolgenausdruck, der den Titel angibt, der in der Titelleiste des zu aktivierenden Anwendungsfensters enthalten ist. Zum Aktivieren einer Anwendung können Sie anstelle des Fenstertitels die von der Shell-Funktion zurückgegebene Task-ID verwenden.
Hinweise

Die AppActivate-Anweisung ändert den Fokus auf die genannte Anwendung oder das Fenster, verändert aber nicht dessen Größe. Der Fokus wird vom aktivierten Anwendungsfenster entfernt, wenn der Benutzer Aktionen zum Ändern des Fokus oder Schließen des Fensters ausführt. Verwenden Sie die Shell-Funktion zum Starten einer Anwendung und Festlegen des Fensterstils.
Durch Vergleichen von Titel mit den einzelnen Titeln aller laufenden Anwendungen wird die auszuführende Anwendung festgelegt. Wenn keine exakte Übereinstimmung vorliegt, wird jede Anwendung aktiviert, deren Titel mit "Titel" beginnt. Wenn auch in diesem Fall keine entsprechende Anwendung gefunden werden kann, wird jede Anwendung aktiviert, deren Titel mit "Titel" endet. Wenn mehrere Instanzen der im Titel genannten Anwendung vorhanden sind, wird eine beliebige Instanz aktiviert.

Beispiel
Im folgenden Beispiel wird der Windows-Rechner gestartet, und es werden einige einfache Rechenoperationen ausgeführt.
set WshShell = CreateObject("WScript.Shell")
WshShell.Run "calc"
WScript.Sleep 100
WshShell.AppActivate "Rechner"
WScript.Sleep 100
WshShell.SendKeys "1{+}"
WScript.Sleep 500
WshShell.SendKeys "2"
WScript.Sleep 500
WshShell.SendKeys "~"
WScript.Sleep 500
WshShell.SendKeys "*3"
WScript.Sleep 500
WshShell.SendKeys "~"
WScript.Sleep 2500


AppActivate-Methode

AppActivate-Methode
Betrifft 		WSH-Referenz
WshShell-Objekt


Close-Methode

Close-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Schließt einen geöffneten Stream.
Syntax
Objekt.strStream.Close
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdIn, StdOut oder StdErr-Eigenschaft.
Hinweise
Die StdIn, StdOut und StdErr-Eigenschaften und -Methoden funktionieren nur, wenn das Skript mit CScript.exe ausgeführt wird. Bei Verwendung von WScript.exe wird die Fehlermeldung "Ungültige Zugriffsnummer" ausgegeben. Weitere Informationen finden Sie unter Fehlermeldungen.


Close-Methode

Close-Methode
Betrifft 		WSH-Referenz
StdErr-Eigenschaft
StdIn-Eigenschaft
StdOut-Eigenschaft


ConnectObject-Methode

ConnectObject-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Verbindet die Ereignisquellen eines Objekts mit Funktionen mit einem bestimmten Präfix.
Syntax
Objekt.ConnectObject strObjekt, strPräfix
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strObjekt | Name des zu verbindenden Objekts.
strPräfix | Präfix der Ereignisfunktion.
Hinweise
Das Objekt muss die Menge seiner Klassenereignisse aufzählen können.
Beispiel
Im folgenden Beispiel wird ein fiktives Objekt instanziiert und mit der Skriptdatei verbunden. Dann ruft das Skript die "IrgendeineMethode"-Methode für das Objekt auf. Erscheint ein Ereignis mit dem Namen "Event" im Objekt, wird die Unterroutine MeinEreignis_Event aufgerufen.
Set MeinObjekt = WScript.CreateObject("IrgendeinObjekt")
MeinObjekt.IrgendeineMethode
WScript.ConnectObject MeinObjekt, "MeinEreignis"

Sub MeinEreignis_Event(strName)
  WScript.Echo strName
End Sub

WScript.DisconnectObject MeinObjekt


ConnectObject-Methode

ConnectObject-Methode
Betrifft 		WSH-Referenz
Wscript-Objekt


CreateObject-Methode

CreateObject-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Erstellt das durch den Parameter strProgID angegebene Objekt.
Syntax
Objekt.CreateObject(strProgID[,strPräfix])
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strProgID | Die Programm-ID des zu erstellenden Objekts.
strPräfix | Optional.
Hinweise
Wenn der Parameter strPräfix angegeben wird, verbindet Windows Script Host die ausgehende Schnittstelle des Objekts nach Erstellen des Objekts mit der Skriptdatei. Wenn das Objekt ein Ereignis auslöst, ruft Windows Script Host eine Unterroutine auf, deren Name aus strPräfix und dem Ereignisnamen besteht. Lautet das Präfix beispielsweise strPräfix "MEINOBJ_" und das Objekt löst ein Ereignis mit dem Namen "BeimAufruf" aus, ruft Windows Script Host die Unterroutine "MEINOBJ_BeimAufruf" auf, die sich im Skript befindet.

Beispiel
Das folgende Beispiel zeigt die Verwendung der CreateObject-Methode zum Erstellen eines WshNetwork-Objekts.
Set objNetzwerk = WScript.CreateObject("WScript.Network")


CreateObject-Methode

CreateObject-Methode
Betrifft 		WSH-Referenz
Wscript-Objekt


CreateObject-Methode

CreateObject-Methode
Siehe auch 		WSH-Referenz
GetObject-Methode
DisconnectObject-Methode


CreateShortcut-Methode

CreateShortcut-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Erstellt einen Objektverweis auf eine Verknüpfung oder eine URL-Verknüpfung.
Syntax
Objekt.CreateShortcut(strPathname)
Parameter
Teil | Beschreibung
Objekt | WshShell-Objekt.
strPathname | Pfad- und Dateiname der zu erstellenden Verknüpfung.
Hinweise
Die CreateShortcut-Methode erstellt ein WshShortcut-Objekt und gibt es zurück. Diese Methode kann verwendet werden, um eine neue Verknüpfung zu erstellen oder um eine vorhandene Verknüpfung zu öffnen, deren Eigenschaften geändert werden sollen. Eine Verknüpfung mit Windows muss die Erweiterung ".lnk" haben. Endet der Name der Verknüpfung mit ".url", wird ein WshURLShortcut-Objekt erstellt.

Beispiel
In den folgenden Beispielen wird eine Verknüpfung mit dem gerade ausgeführten Skript und eine URL-Verknüpfung zu www.microsoft.de erstellt.

Set WshShell = WScript.CreateObject("WScript.Shell")
Set oVerknuepfung = WshShell.CreateShortcut("Aktuelles Skript.lnk")
oVerknuepfung.TargetPath = WScript.ScriptFullName
oVerknuepfung.Save

Set oUrlVerkn = WshShell.CreateShortcut("Microsoft Web Site.URL")
oUrlVerkn.TargetPath = "http://www.microsoft.de"
oUrlVerkn.Save


CreateShortcut-Methode

CreateShortcut-Methode
Betrifft 		WSH-Referenz
WshShell-Objekt


CreateShortcut-Methode

CreateShortcut-Methode
Siehe auch 		WSH-Referenz
WshShortcut-Objekt
WshUrlShortcut-Objekt


DisconnectObject-Methode

DisconnectObject-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Trennt ein zuvor verbundenes Objekt von Windows Script Host.
Syntax
Objekt.DisconnectObject obj
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
obj | Name des zu trennenden Objekts.
Hinweise
Ist das angegebene Objekt nicht bereits mit Windows Script Host verbunden, bleibt diese Methode wirkungslos.
Beispiel
Im folgenden Beispiel wird eine Instanz eines fiktiven Objekts erstellt und mit der Scriptdatei verbunden. Dann ruft das Skript die "IrgendeineMethode"-Methode für das Objekt auf. Erscheint ein Fehler mit dem Namen "Event" im Objekt, wird die Unterroutine MeinEreignis_Event aufgerufen.
Set MeinObjekt = WScript.CreateObject("IrgendeinObjekt", "Mein Ereignis")
MeinObjekt.IrgendeineMethode
Sub MeinEreignis_Event(strName)
  WScript.Echo strName
End Sub
WScript.DisconnectObject MeinObjekt


DisconnectObject-Methode

DisconnectObject-Methode
Betrifft 		WSH-Referenz
Wscript-Objekt


DisconnectObject-Methode

DisconnectObject-Methode
Siehe auch 		WSH-Referenz
CreateObject-Methode
GetObject-Methode


Echo-Methode

Echo-Methode 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Sendet die Ausgabe an ein Dialogfeld oder die Konsole.
Syntax
Objekt.Echo [Arg1] [,Arg2] [,Arg3] ...
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
Arg1, Arg2, Arg3 ... | Liste der anzuzeigenden Elemente.
Hinweise
Mit dieser Methode wird die Ausgabe in einem Dialogfeld angezeigt, wenn auf dem Host WScript.exe verwendet wird, und in einer Konsole, wenn es sich um CScript.exe handelt. Die Elemente sind durch ein Leerzeichen voneinander getrennt. Unter CScript.exe wird ein Zeilenumbruchzeichen an das Ende der Ausgabe gesetzt. Werden keine Elemente vorgegeben, wird eine leere Zeile angezeigt.

Beispiel
Im folgenden Beispiel werden einige Zahlen und Text ausgegeben:

WScript.Echo
WScript.Echo 1, 2, 3
WScript.Echo "Windows Script Host ist irre."


Echo-Methode

Echo-Methode
Betrifft 		WSH-Referenz
Wscript-Objekt


EnumNetworkDrives-Methode

EnumNetworkDrives-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die aktuellen Netzlaufwerkzuordnungen zurück.
Syntax
objDrives = Objekt.EnumNetworkDrive
Parameter
Teil | Beschreibung
Objekt | WshNetwork-Objekt.
objDrives | Variablenverweis auf die Auflistung von Laufwerken.
Hinweise
Die Elemente dieser Auflistung sind lokale Namen und Netzwerknamen. Das erste Element in der Auflistung ist der Laufwerkbuchstabe und das zweite Element die Netzzuordnung. Dieses Muster gilt für alle Netzlaufwerke in der Auflistung.
Beispiel
Das folgende Beispiel gibt die Laufwerkbuchstaben und Netzzuordnungen aus:

Set objNetzwerk = WScript.CreateObject("WScript.Network")
Set oLWs = objNetzwerk.EnumNetworkDrives
For i = 0 to oLWs.Count - 1
    WScript.Echo oLWs.Element(i)
Next


EnumNetworkDrives-Methode

EnumNetworkDrives-Methode
Betrifft 		WSH-Referenz
WshNetwork-Objekt


EnumNetworkDrives-Methode

EnumNetworkDrives-Methode
Siehe auch 		WSH-Referenz
MapNetworkDrive-Methode
RemoveNetworkDrive-Methode


EnumPrinterConnections-Methode

EnumPrinterConnections-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die aktuellen Netzwerkdruckerzuordnungen zurück.
Syntax
objPrinters = Objekt.EnumPrinterConnections
Parameter
Teil | Beschreibung
Objekt | WshNetwork-Objekt.
objPrinters | Variablenverweis auf die Auflistung von Druckern.
Hinweise
Die Element dieser Auflistung sind lokale Namen und Netzwerknamen. Das erste Element in der Auflistung ist der Anschluss und das zweite Element die Netzzuordnung. Dieses Muster gilt für alle Netzwerkdrucker in der Auflistung.

Beispiel
Das folgende Beispiel gibt die Druckeranschlüsse und Netzzuordnungen aus:

Set objNetzwerk = WScript.CreateObject("WScript.Network")
Set oDrucker = objNetzwerk.EnumPrinterConnections
For i = 0 to oDrucker.Count - 1
    WScript.Echo oDrucker.Element(i)
Next


EnumPrinterConnections-Methode

EnumPrinterConnections-Methode
Betrifft 		WSH-Referenz
WshNetwork-Objekt


EnumPrinterConnections-Methode

EnumPrinterConnections-Methode
Siehe auch 		WSH-Referenz
AddPrinterConnection-Methode
AddWindowsPrinterConnection-Methode
RemovePrinterConnection-Methode
SetDefaultPrinter-Methode


ExpandEnvironmentStrings-Methode

ExpandEnvironmentStrings-Methode 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Erweitert die angeforderte Umgebungsvariable des aktuell ausgeführten Prozesses und gibt die Ergebniszeichenfolge zurück.
Syntax
Objekt.ExpandEnvironmentStrings(strZeichenfolge)
Parameter
Teil | Beschreibung
Objekt | WshShell-Objekt.
strZeichenfolge | Der Name der zu erweiternden Umgebungsvariable.
Hinweise
Variablen sind in "%"-Zeichen eingeschlossen. Bei Namen von Umgebungsvariablen wird die Groß-/Kleinschreibung nicht berücksichtigt.
Beispiel
Im folgenden Beispiel wird die Umgebungsvariable "WinDir" erweitert und in einer Meldung ausgegeben.
set WshShell = CreateObject("WScript.Shell")
WScript.Echo "WinDir ist " & WshShell.ExpandEnvironmentStrings("%WinDir%")


ExpandEnvironmentStrings-Methode

ExpandEnvironmentStrings-Methode
Betrifft 		WSH-Referenz
WshShell-Objekt


GetObject-Methode

GetObject-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Ruft ein Automatisierungsobjekt aus einer Datei oder einem durch den Parameter strProgID spezifizierten Objekt ab.
Syntax
Objekt.GetObject(strPfadname [,strProgID], [strPräfix])
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strPfadname | Erforderlich. Der vollständige Pfad und Name der Datei, die das abzurufende Objekt enthält.
strProgID | Optional. Eine Zeichenfolge, die den Programmbezeichner (ProgID) des Objekts darstellt.
strPräfix Optional. Wird der Parameter strPräfix angegeben, so verknüpft Windows Script Host nach dem Erstellen des Objekts die nach außen sichtbare Schnittstelle des Objekts mit der Skriptdatei. Löst das Objekt ein Ereignis aus, so ruft Windows Script Host eine Unterroutine auf, deren Name sich aus strPräfix und dem Namen des Ereignisses zusammensetzt.
Hat beispielsweise strPräfix den Wert "MEINOBJ_" und löst das Objekt ein Ereignis namens "BeimAufruf" aus, so ruft Windows Script Host die in der Skriptdatei enthaltene Unterroutine "MEINOBJ_BeimAufruf" auf.
Hinweise
Verwenden Sie die GetObject-Methode, wenn es eine aktuelle Instanz des Objekts gibt oder Sie das Objekt mit einer bereits geöffneten Datei erzeugen möchten. Wenn es keine aktuelle Instanz gibt oder Sie das Objekt nicht mit einer geladenen Datei starten möchten, so verwenden Sie die CreateObject-Methode.

Wenn sich ein Objekt als Einzelinstanzobjekt registriert hat (z. B. das Word.Basic-Objekt in Microsoft Word 7.0), so wird nur eine einzige Instanz dieses Objekts erstellt, gleich wie oft CreateObject ausgeführt wird. Bei einem Einzelinstanzobjekt gibt GetObject bei einem Aufruf mit der Zeichenfolge der Länge Null ("") stets die gleiche Instanz zurück; wird dabei das Argument Pfadname nicht angegeben, so tritt ein Fehler auf. Es ist nicht möglich, mittels GetObject eine Verknüpfung auf eine Microsoft Visual Basic®-Klasse zu erhalten, die mit Visual Basic, Version 4.0 oder älter, erstellt wurde.

GetObject funktioniert ungeachtet der zum Erstellen des Objekts verwendeten Sprache mit allen COM-Klassen.

Beispiel
Bei der Ausführung des folgenden Codes startet die in strPfadname angegebene Anwendung, und das Objekt in der angegebenen Datei wird aktiviert. Ist strPfadname eine Zeichenfolge der Länge Null (""), so gibt GetObject eine neue Objektinstanz des angegebenen Types zurück. Wird das Argument strPfadname überhaupt nicht angegeben, so gibt GetObject ein derzeit aktives Objekt des angegebenen Types zurück. Existiert kein Objekt des angegebenen Types, so tritt ein Fehler auf.

Dim MeinObjekt As Object
Set MeinObjekt = GetObject("C:\CAD\SCHEMA.CAD")
MeineAnw = MeinObjekt.Application
Bei einigen Anwendungen können Sie einen Teil einer Datei aktivieren. Fügen Sie dazu an den Dateinamen ein Ausrufungszeichen (!) an, gefolgt von der Zeichenfolge mit dem Namen des zu aktivierenden Teils. Weitere Informationen zum Erstellen dieser Zeichenfolge finden Sie in der Dokumentation der Anwendung, die das Objekt erstellt hat.

In einem Zeichenprogramm zum Beispiel kann eine in einer Datei gespeicherte Zeichnung beispielsweise mehrere Ebenen haben. Mit der folgenden Anweisung können Sie eine Ebene in einer Zeichnung namens schema.cad aktivieren:

Set EbenenObjekt = GetObject("C:\CAD\SCHEMA.CAD!Ebene3")
Wenn Sie die Objektklasse nicht angeben, bestimmt COM die zu startende Anwendung und das zu aktivierende Objekt automatisch anhand des angegebenen Dateinamens. Einige Dateien unterstützen jedoch mehr als nur eine Objektklasse. Eine Zeichnung kann z. B. drei unterschiedliche Typen von Objekten unterstützen: ein Anwendungs-Objekt, ein Zeichen-Objekt und ein Symbolleisten-Objekt, die sich alle in derselben Datei befinden.

Im folgenden Beispiel ist ERDICHTUNG der Name eines Zeichenprogramms, und ZEICHNUNG ist einer der von diesem Programm unterstützten Objekttypen.

Dim MeinObjekt As Object
Set MeinObjekt = GetObject("C:\ZEICHNUNGEN\BEISPIEL.DRW", "ERDICHTUNG.ZEICHNUNG")


GetObject-Methode

GetObject-Methode
Betrifft 		WSH-Referenz
WScript-Objekt


GetObject-Methode

GetObject-Methode
Siehe auch 		WSH-Referenz
CreateObject-Methode
DisconnectObject-Methode


getResource-Methode

getResource-Methode 		WSH-Referenz
Version 2

Beschreibung
Gibt den Wert einer durch das <resource>-Element definierten Ressource zurück.
Syntax
getResource(RessourcenID)
Parameter
Teil | Beschreibung
RessourcenID | Ein eindeutiger Bezeichner für die Ressource innerhalb des Skriptes.
Hinweise

Mithilfe des <resource>-Elements können Sie Zeichenfolgen oder Zahlen in einer Windows-Skriptdatei isolieren, auf die Sie in Skripten verweisen möchten. In der Regel werden resource-Elemente für die Verwaltung von Zeichenfolgen verwendet, die möglicherweise in eine andere Sprache lokalisiert werden. Sie können die getResource-Methode im Skript einsetzen, um den Inhalt eines <resource>-Elements abzurufen.

Beispiel
Das folgende Codefragment definiert eine Ressource (errNichtNumerisch) und gibt deren Wert zurück, wenn der Wert der Variable obereGrenze nicht numerisch ist.
<resource id="errNichtNumerisch">
    Nicht-numerischen Wert übergeben
</resource>

<script language="VBScript">
<![CDATA[
Function ErzeugeZufallszahlen(obereGrenze)
    If IsNumeric(obereGrenze) Then
        ErzeugeZufallszahlen = CInt(obereGrenze * Rnd + 1)
    Else
        ErzeugeZufallszahlen = getResource("errNichtNumerisch")
    End If
End Function
]]>
</script>


LogEvent-Methode

LogEvent-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Protokolliert ein Ereignis im Windows NT-Ereignisprotokoll oder in der Datei WSH.log.
Syntax
Objekt.LogEvent(intTyp, strMeldung [,strZiel])
Parameter
Teil | Beschreibung
Objekt | WshShell-Objekt.
intTyp | Den Typ des Ereignisses angebende Zahl.
strMeldung | Text für den Protokolleintrag.
strZiel | Optional; Nur bei Windows NT. Der Name des Systems, auf dem das Ereignis protokolliert werden soll. Standardmäßig wird das lokale System verwendet. Dieser Parameter wird bei Windows 9x ignoriert.
Hinweise
Die folgenden Typen stehen für LogEvent zur Verfügung:

Typ | Wert
0 | SUCCESS
1 | ERROR
2 | WARNING
4 | INFORMATION
8 | AUDIT_SUCCESS
16 | AUDIT_FAILURE

Windows NT: Protokolliert ein Ereignis im Windows NT-Ereignisprotokoll.

Windows 9x: Protokolliert ein Ereignis in der Datei WSH.log. Diese befindet sich im Windows-Verzeichnis des Benutzers. Die Datei WSH.log enthält Zeitangabe, Typ und Text des Ereignisses.

Wurde das Ereignis erfolgreich protokolliert, so gibt diese Methode true zurück, andernfalls false.

Beispiel
Das folgende Beispiel protokolliert Erfolg oder Misserfolg einer Anmeldung:
Set WshShell = WScript.CreateObject("WScript.Shell")
rc = anmeldeSkriptAusf()	'Gibt bei erfolgreicher Anmeldung true zurück
if rc then
    WshShell.LogEvent 0, "Anmelde-Skript erfolgreich vollendet"
else
    WshShell.LogEvent 1, "Anmelde-Skript gescheitert"
end if


LogEvent-Methode

LogEvent-Methode
Betrifft 		WSH-Referenz
WshShell-Objekt


MapNetworkDrive-Methode

MapNetworkDrive-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Ordnet den durch strRemoteName spezifizierten Freigabepunkt dem Namen der lokalen Ressource strLokalerName zu.
Syntax
Objekt.MapNetworkDrive strLokalerName, strRemoteName, [bProfilAktual], [strBenutzer], [strKennwort]
Parameter
Teil | Beschreibung
Objekt | WshNetwork-Objekt.
strLokalerName | Name der lokalen Ressource.
strRemoteName | Zuzuordnender Freigabepunkt.
bProfilAktual | Optional. Wenn bProfilAktual angegeben wird und sein Wert TRUE ist, wird die Zuordnung im Benutzerprofil gespeichert. Der Standardwert ist FALSE.
strBenutzer, strKennwort | Optional. Wenn Sie den Freigabepunkt mit den Angaben eines anderen Benutzers als des aktuellen zuordnen, können Sie strBenutzer und strKennwort angeben.
Beispiel
Das folgende Beispiel zeigt die Zuordnung des Laufwerkes "Z" zu einer Netzwerkfreigabe:
Set objNetzwerk = WScript.CreateObject("WScript.Network")
objNetzwerk.MapNetworkDrive "Z:", "\\Server\Freigabe"


MapNetworkDrive-Methode

MapNetworkDrive-Methode
Betrifft 		WSH-Referenz
WshNetwork-Objekt


MapNetworkDrive-Methode

MapNetworkDrive-Methode
Siehe auch 		WSH-Referenz
EnumNetworkDrives-Methode
RemoveNetworkDrive-Methode


Popup-Methode

Popup-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Zeigt ein Popup-Meldungsfeld mit der in strText enthaltenen Meldung an.
Syntax
intSchaltf = Objekt.Popup(strText, [natWarteSekunden], [strTitel], [natTyp])
Parameter
Teil | Beschreibung
Objekt | WshShell-Objekt.
strText | Der Text für das Popup-Fenster.
natWarteSekunden | Optional. Wartezeit in Sekunden, bevor das Popup-Fenster wieder geschlossen wird.
strTitel | Optional. Der Text für den Titel des Popup-Fensters.
natTyp | Optional. Legt fest, welche Schaltflächen und Symbole im Popup-Fenster angezeigt werden sollen.
Hinweise
strTitel legt den Fenstertitel für das Meldungsfeld fest. Wird für strTitel nichts angegeben, so wird der Fenstertitel "Windows Script Host" verwendet.

Wird der Wert natWarteSekunden angegeben und ist er größer als 0, so wird das Meldungsfeld nach natWarteSekunden Sekunden automatisch geschlossen.

Die Interpretation des Parameters natTyp entspricht der der Funktion MessageBox der Microsoft Win32®-API. Die folgenden Tabellen geben die möglichen Werte und deren Bedeutung an. Sie können die Werte in diesen Tabellen kombinieren.

Schaltflächen

Wert | Beschreibung
0 | Schaltfläche OK anzeigen.
1 | Schaltflächen OK und Abbrechen anzeigen.
2 | Schaltflächen Abbrechen, Wiederholen und Ignorieren anzeigen.
3 | Schaltflächen Ja, Nein und Abbrechen anzeigen.
4 | Schaltflächen Ja und Nein anzeigen.
5 | Schaltflächen Wiederholen und Abbrechen anzeigen.

Symbole

Wert | Beschreibung
16 | "Stoppzeichen"-Symbol anzeigen.
32 | "Fragezeichen"-Symbol anzeigen.
48 | "Ausrufezeichen"-Symbol anzeigen.
64 | "Infozeichen"-Symbol anzeigen.

Diese beiden Tabellen führen nicht alle möglichen Werte für natTyp auf. Eine vollständige Liste finden Sie in der Microsoft Win32-Dokumentation.

Der Rückgabewert intSchaltf gibt die Nummer der geklickten Schaltfläche an. Klickt der Benutzer vor Ablauf der Wartezeit natWarteSekunden nicht auf eine Schaltfläche, so wird intSchaltf der Wert -1 zugewiesen.

Wert | Beschreibung
1 | Schaltfläche OK
2 | Schaltfläche Abbrechen
3 | Schaltfläche Abbrechen
4 | Schaltfläche Wiederholen
5 | Schaltfläche Ignorieren
6 | Schaltfläche Ja
7 | Schaltfläche Nein

Beispiel
Das folgende Beispiel erzeugt ein einfaches Popup-Fenster:
Set WshShell = WScript.CreateObject("WScript.Shell")
WshShell.Popup "Where do you want to go today?"


Popup-Methode

Popup-Methode
Betrifft 		WSH-Referenz
WshShell-Objekt


Popup-Methode

Popup-Methode
Siehe auch 		WSH-Referenz
Echo-Methode


Quit-Methode

Quit-Methode 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Beendet die Ausführung mit einem angegebenen Fehlercode.
Syntax
Objekt.Quit [intFehlercode]
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
intFehlercode | Optional. Wird dieser Parameter angegeben, so gibt WScript diesen als den Terminierungscode des Prozesses zurück. Wird intFehlercode nicht angegeben, so gibt WScript als Terminierungscode des Prozesses den Wert Null (0) zurück.
Beispiel
Das folgende Beispiel terminiert die Ausführung und gibt den Fehlercode 1 zurück:
WScript.Quit 1


Quit-Methode

Quit-Methode
Betrifft 		WSH-Referenz
WScript-Objekt


Read-Methode

Read-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Liest eine angegebene Anzahl Zeichen aus einem Eingabestream und gibt die resultierende Zeichenfolge zurück.
Syntax
Objekt.strStream.Read(Zeichen)
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdIn-Eigenschaft.
Zeichen | Anzahl der aus dem Stream zu lesenden Zeichen.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf.


Read-Methode

Read-Methode
Betrifft 		WSH-Referenz
StdIn-Eigenschaft


ReadAll-Methode

ReadAll-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Liest einen kompletten Eingabestream und gibt die resultierende Zeichenfolge zurück.
Syntax
Objekt.strStream.ReadAll
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdIn-Eigenschaft.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf.


ReadAll-Methode

ReadAll-Methode
Betrifft 		WSH-Referenz
StdIn-Eigenschaft


ReadLine-Methode

ReadLine-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Liest eine ganze Zeile (bis zum Zeilenumbruchzeichen, jedoch ohne dieses) aus einem Eingabestream und gibt die resultierende Zeichenfolge zurück.
Syntax
Objekt.strStream.ReadLine
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdIn-Eigenschaft.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf.


ReadLine-Methode

ReadLine-Methode
Betrifft 		WSH-Referenz
StdIn-Eigenschaft


RegDelete-Methode

RegDelete-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Löscht den durch strName spezifizierten Schlüssel oder Wert aus der Registrierung.
Syntax
Objekt.RegDelete strName
Parameter
Teil | Beschreibung
Objekt | WshShell-Objekt.
strName | Name des zu löschenden Schlüssels oder Wertes.
Hinweise
Endet strName mit einem umgekehrten Schrägstrich (\), so löscht diese Methode den Schlüssel. Im anderen Fall wird nur der Wert gelöscht. Der Parameter strName muss mit einem der folgenden Stamm-Schlüsselnamen beginnen:

Kurzform | Langform
HKCU | HKEY_CURRENT_USER
HKLM | HKEY_LOCAL_MACHINE
HKCR | HKEY_CLASSES_ROOT
HKEY_USERS
HKEY_CURRENT_CONFIG

Beispiel
Im folgenden Beispiel werden ein Wert und ein Schlüssel aus der Registrierung gelöscht:
Set WshShell = WScript.CreateObject("WScript.Shell")
WshShell.RegDelete "HKCU\ScriptEngine\Value" ' Wert "Value" löschen.
WshShell.RegDelete "HKCU\ScriptEngine\Key\"  ' Schlüssel "Key" löschen.


RegDelete-Methode

RegDelete-Methode
Betrifft 		WSH-Referenz
WshShell-Objekt


RegDelete-Methode

RegDelete-Methode
Siehe auch 		WSH-Referenz
RegRead-Methode
RegWrite-Methode


RegRead-Methode

RegRead-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den durch strName spezifizierten Registrierungsschlüssel oder -wert zurück.
Syntax
Objekt.RegRead(strName)
Parameter
Teil | Beschreibung
Objekt | WshShell-Objekt.
strName | Name des zu lesenden Schlüssels oder Wertes.
Hinweise
Endet strName mit einem umgekehrten Schrägstrich (\), so gibt diese Methode den Schlüssel zurück. Im anderen Fall wird der Wert zurückgegeben. Der Parameter strName muss mit einem der folgenden Stamm-Schlüsselnamen beginnen:

Kurzform | Langform
HKCU | HKEY_CURRENT_USER
HKLM | HKEY_LOCAL_MACHINE
HKCR | HKEY_CLASSES_ROOT
HKEY_USERS
HKEY_CURRENT_CONFIG

Die Methode RegRead unterstützt nur die Datentypen REG_SZ, REG_EXPAND_SZ, REG_DWORD, REG_BINARY und REG_MULTI_SZ. Enthält die Registrierung andere Datentypen, so gibt RegRead DISP_E_TYPEMISMATCH zurück.

Beispiel
Im folgenden Beispiel werden ein Wert und ein Schlüssel aus der Registrierung gelesen:
Set WshShell = WScript.CreateObject("WScript.Shell")
WScript.Echo WshShell.RegRead("HKCU\ScriptEngine\Val")  ' Wert "Val" lesen.
WScript.Echo WshShell.RegRead("HKCU\ScriptEngine\Key\") ' Schlüssel "Key" lesen.


RegRead-Methode

RegRead-Methode
Betrifft 		WSH-Referenz
WshShell-Objekt


RegRead-Methode

RegRead-Methode
Siehe auch 		WSH-Referenz
RegDelete-Methode
RegWrite-Methode


RegWrite-Methode

RegWrite-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Legt den durch strName spezifizierten Registrierungsschlüssel oder -wert fest.
Syntax
Objekt.RegWrite strName, Wert [,strTyp]
Parameter
Teil | Beschreibung
Objekt | WshShell-Objekt.
strName | Name des zu schreibenden Schlüssels oder Wertes.
Wert | Der in den Registrierungsschlüssel oder -wert zu schreibende Wert.
strTyp | Optional. Der Datentyp für den in der Registrierung zu speichernden Wert.
Hinweise
Endet strName mit einem umgekehrten Schrägstrich (\), so setzt diese Methode den Wert des Schlüssels. Im anderen Fall wird ein Wert gesetzt. Der Parameter strName muss mit einem der folgenden Stamm-Schlüsselnamen beginnen:

Kurzform | Langform
HKCU | HKEY_CURRENT_USER
HKLM | HKEY_LOCAL_MACHINE
HKCR | HKEY_CLASSES_ROOT
HKEY_USERS
HKEY_CURRENT_CONFIG

Die Methode RegWrite unterstützt für strTyp die Typen REG_SZ, REG_EXPAND_SZ, REG_DWORD und REG_BINARY. Wird ein anderer Datentyp als strTyp übergeben, so gibt RegWrite E_INVALIDARG zurück.

Hat strTyp den Wert REG_SZ oder REG_EXPAND_SZ, so konvertiert RegWrite Wert automatisch zu einer Zeichenfolge. Hat strTyp den Wert REG_DWORD, so konvertiert RegWrite Wert automatisch zu einer Ganzzahl. Hat strTyp den Wert REG_BINARY, so muss Wert eine Ganzzahl sein.

Beispiel
Im folgenden Beispiel werden ein Wert und ein Schlüsseleintrag in die Registrierung geschrieben:
Set WshShell = WScript.CreateObject("WScript.Shell")
WshShell.RegWrite "HKCU\ScriptEngine\Value", "Beliebige Zeichenfolge"
WshShell.RegWrite "HKCU\ScriptEngine\Key\", 1 ,"REG_DWORD"


RegWrite-Methode

RegWrite-Methode
Betrifft 		WSH-Referenz
WshShell-Objekt


RegWrite-Methode

RegWrite-Methode
Siehe auch 		WSH-Referenz
RegDelete-Methode
RegRead-Methode


Remove-Methode

Remove-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Löscht die durch strName spezifizierte Umgebungsvariable.
Syntax
Objekt.Remove(strName)
Parameter
Teil | Beschreibung
Objekt | WshEnvironment-Objekt.
strName | Name der zu löschenden Umgebungsvariable.
Beispiel
Das folgende Beispiel löscht die Volatile-Umgebungsvariable BEISPIEL und anschließend mehrere Variablen aus der User-Umgebung:
Set WshShell = WScript.CreateObject("WScript.Shell")
WshShell.Environment("VOLATILE").Remove("BEISPIEL")

Set WshUsrEnv = WScript.Environment("User")
WshUsrEnv.Remove("BEISPIEL_1")
WshUsrEnv.Remove("BEISPIEL_2")
WshUsrEnv.Remove("BEISPIEL_3")
WshUsrEnv.Remove("BEISPIEL_4")


Remove-Methode

Remove-Methode
Betrifft 		WSH-Referenz
WshEnvironment-Objekt


Remove-Methode

Remove-Methode
Siehe auch 		WSH-Referenz
Environment-Eigenschaft


RemoveNetworkDrive-Methode

RemoveNetworkDrive-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Entfernt die durch strName bezeichnete aktuelle Ressourcenverbindung.
Syntax
Objekt.RemoveNetworkDrive strName, [bErzwingen], [bProfilAktual]
Parameter
Teil | Beschreibung
Objekt | WshNetwork-Objekt.
strName | Je nach Art der Zuordnung des Laufwerkes kann es sich bei dem Parameter strName um einen lokalen oder einen Remotenamen handeln. Besteht für das Laufwerk eine Zuordnung zwischen einem lokalen Namen (Laufwerkbuchstaben) und einem Remotenamen, so muss strName den lokalen Namen angeben. Besteht für den Netzwerkpfad keine Zuordnung zu einem lokalen Namen (Laufwerkbuchstaben), so muss strName den Remotenamen angeben.
bErzwingen | Optional. Wird bErzwingen mit dem Wert TRUE angegeben, so löscht diese Methode die Verbindung ohne zu berücksichtigen, ob die Ressource in Verwendung ist oder nicht.
bProfilAktual | Optional. Wenn bProfilAktual angegeben wird und der Wert des Parameters TRUE ist, wird diese Zuordnung im Benutzerprofil gelöscht.
Hinweise
Das folgende Beispiel zeigt die Zuordnung des Laufwerkes "Z" zu einer Netzwerkfreigabe und das anschließende Löschen dieser Verbindung:
Set objNetzwerk = WScript.CreateObject("WScript.Network")
objNetzwerk.MapNetworkDrive "Z:", "\\Server\Freigabe"
objNetzwerk.RemoveNetworkDrive "Z:"


RemoveNetworkDrive-Methode

RemoveNetworkDrive-Methode
Betrifft 		WSH-Referenz
WshNetwork-Objekt


RemoveNetworkDrive-Methode

RemoveNetworkDrive-Methode
Siehe auch 		WSH-Referenz
EnumNetworkDrives-Methode
MapNetworkDrive-Methode


RemovePrinterConnection-Methode

RemovePrinterConnection-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Entfernt die durch strName bezeichnete aktuelle Ressourcenverbindung.
Syntax
Objekt.RemovePrinterConnection strName, [bErzwingen], [bProfilAktual]
Parameter
Teil | Beschreibung
Objekt | WshNetwork-Objekt.
strName | Je nach Art des Anschlusses des Druckers kann es sich bei dem Parameter strName um einen lokalen Namen oder einen Remotenamen handeln. Besteht für den Drucker eine Zuordnung zwischen einem lokalen Namen (z. B. LPT1) und einem Remotenamen, so muss strName den lokalen Namen angeben. Besteht für den Netzwerkpfad keine Zuordnung zu einem lokalen Namen, so muss strName den Remotenamen angeben.
bErzwingen | Optional. Wird bErzwingen mit dem Wert TRUE angegeben, so löscht diese Methode die Verbindung ohne zu berücksichtigen, ob die Ressource in Verwendung ist oder nicht.
bProfilAktual | Optional. Wenn bProfilAktual angegeben wird und der Wert des Parameters TRUE ist, wird diese Zuordnung im Benutzerprofil gelöscht.
Beispiel
Das folgende Beispiel löscht eine Druckerverbindung mit LPT1:
Set objNetzwerk = WScript.CreateObject("WScript.Network")
objNetzwerk.RemovePrinterConnection "LPT1:"


RemovePrinterConnection-Methode

RemovePrinterConnection-Methode
Betrifft 		WSH-Referenz
WshNetwork-Objekt


RemovePrinterConnection-Methode

RemovePrinterConnection-Methode
Siehe auch 		WSH-Referenz
AddPrinterConnection-Methode
AddWindowsPrinterConnection-Methode
EnumPrinterConnections-Methode
SetDefaultPrinter-Methode


Run-Methode

Run-Methode 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Erstellt einen neuen Prozess, der strBefehl ausführt.
Syntax
Objekt.Run(strBefehl, [intFensterStil], [bAufRückkehrWarten])
Parameter
Teil | Beschreibung
Objekt | WshShell-Objekt.
strBefehl | Umgebungsvariablen im Parameter strBefehl werden automatisch erweitert.
intFensterStil | Optional. Setzt den Fensterstil des auszuführenden Programms.
bAufRückkehrWarten Optional. Wird bAufRückkehrWarten nicht angegeben oder hat dieser Parameter den Wert FALSE, so wird nicht auf die Terminierung des Prozesses gewartet, sondern die Ausführung des Skriptes sofort fortgesetzt.

Hat der Parameter bAufRückkehrWarten den Wert TRUE, so gibt die Run-Methode den von der Anwendung gelieferten Terminierungscode zurück.

Wird bAufRückkehrWarten nicht angegeben oder hat dieser Parameter den Wert FALSE, so gibt die Run-Methode den Terminierungscode 0 (Null) zurück.

Hinweise
Die folgende Tabelle führt die möglichen Werte für intFensterStil auf:

intFensterStil | Beschreibung
0 | Verbirgt das Fenster und aktiviert ein neues Fenster.
1 | Aktiviert ein Fenster und zeigt es an. Wird das Fenster minimiert oder maximiert, so stellt das System die ursprüngliche Größe und Position wieder her. Zeigt eine Anwendung ein Fenster zum ersten Mal an, so sollte dieser Wert angegeben werden.
2 | Aktiviert das Fenster und zeigt es minimiert an.
3 | Aktiviert das Fenster und zeigt es maximiert an.
4 | Zeigt ein Fenster in der Größe und an der Position an, in bzw. an der es zuletzt angezeigt wurde. Das aktive Fenster bleibt aktiv.
5 | Aktiviert das Fenster und zeigt es in seiner aktuellen Größe und an seiner aktuellen Position an.
6 | Minimiert das spezifizierte Fenster und aktiviert das nächste Fenster in der Z-Reihenfolge der Fenster.
7 | Zeigt das Fenster minimiert an. Das aktive Fenster bleibt aktiv.
8 | Zeigt das Fenster im aktuellen Zustand an. Das aktive Fenster bleibt aktiv.
9 | Aktiviert ein Fenster und zeigt es an. Wird das Fenster minimiert oder maximiert, so stellt das System die ursprüngliche Größe und Position wieder her. Stellt eine Anwendung ein minimiertes Fenster wieder her, so sollte dieser Wert angegeben werden.
10 | Setzt den Anzeigestatus gemäß dem des die Anwendung startenden Programms.

Beispiel
Das folgende Beispiel startet Windows Editor und öffnet das derzeit ausgeführte Skript:
Set WshShell = WScript.CreateObject("WScript.Shell")
WshShell.Run("%windir%\notepad" & WScript.ScriptFullName)
Das folgende Beispiel gibt den Terminierungscode der ausgeführten Anwendung zurück:
Set WshShell = WScript.CreateObject("WScript.Shell")
Return = WshShell.Run("notepad" & WScript.ScriptFullName, 1, TRUE)


Run-Methode

Run-Methode
Betrifft 		WSH-Referenz
WshShell-Objekt


Save-Methode

Save-Methode 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Speichert eine Verknüpfung zum spezifizierten Ort.
Syntax
Objekt.Save
Parameter
Teil | Beschreibung
Objekt | WshShortcut- oder WshUrlShortcut-Objekt.
Beispiel
Die folgenden Beispiele erstellen eine Verknüpfung zum derzeit ausgeführten Skript sowie eine URL-Verknüpfung zu www.microsoft.de.

Set WshShell = WScript.CreateObject("WScript.Shell")
Set oShellVerknuepfung = WshShell.CreateShortcut("Current Script.lnk")
oShellVerknuepfung.TargetPath = WScript.ScriptFullName
oShellVerknuepfung.Save
Set oUrlVerknuepfung = WshShell.CreateShortcut("Microsoft Web Site.URL")
oUrlVerknuepfung.TargetPath = "http://www.microsoft.de" oUrlVerknuepfung.Save


Save-Methode

Save-Methode
Betrifft 		WSH-Referenz
WshShortcut-Objekt
WshUrlShortcut-Objekt


SendKeys-Methode

SendKeys-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Sendet einen Tastendruck oder mehrere Tastendrücke an das aktive Fenster, als ob sie auf der Tastatur eingegeben würden.
Syntax
SendKeys Zeichenfolge
Parameter
Teil | Beschreibung
Zeichenfolge | Erforderlich. Zeichenfolgenausdruck, der die zu sendenden Tastendrücke spezifiziert.
Hinweise

Jede Taste wird durch ein oder mehrere Zeichen repräsentiert. Für eine einfache Taste (Buchstaben, Ziffern, die meisten Zeichen) verwenden Sie das Zeichen selbst. Für den Buchstaben A geben Sie beispielsweise die Zeichenfolge "A" an. Um mehr als ein Zeichen anzugeben, schreiben Sie diese einfach hintereinander. Für die Buchstabenfolge A, B, C geben Sie die Zeichenfolge "ABC" an.
Die Zeichen Plus (+), Zirkumflex (^), Prozent (%), Tilde (~) sowie die Klammern () haben für SendKeys eine besondere Bedeutung. Zum Spezifizieren eines dieser Zeichen müssen Sie es mit geschweiften Klammern ({}) umschließen. Um beispielsweise das Pluszeichen zu spezifizieren, verwenden Sie die Zeichenfolge "{+}". Eckige Klammern ([]) haben zwar keinerlei Spezialbedeutung für SendKeys, müssen aber auch durch geschweifte Klammern umschlossen werden. In anderen Anwendungen haben eckige Klammern eine Spezialbedeutung, die bei Verwendung von DDE zum Tragen kommen kann. Zum Spezifizieren geschweifter Klammern verwenden Sie die Zeichenfolgen "{{}" und "{}}".

Verwenden Sie die im Folgenden aufgeführten Codes für Tasten wie die EINGABE- oder die TAB-TASTE sowie andere Tasten, bei denen kein Zeichen angezeigt, sondern eine Aktion ausgeführt wird:

Taste | Code
RÜCKTASTE | {BACKSPACE}, {BS} oder {BKSP}
UNTERBR | {BREAK}
FESTSTELLTASTE | {CAPSLOCK}
ENTF | {DELETE} oder {DEL}
NACH-UNTEN-TASTE | {DOWN}
ENDE | {END}
EINGABETASTE | {ENTER} oder ~
ESC | {ESC}
HILFE | {HELP}
POS1 | {HOME}
EINFG | {INSERT} oder {INS}
NACH-LINKS-TASTE | {LEFT}
NUM | {NUMLOCK}
BILD-AB | {PGDN}
BILD-AUF | {PGUP}
DRUCK | {PRTSC}
NACH-RECHTS-TASTE | {RIGHT}
ROLLEN | {SCROLLLOCK}
TAB | {TAB}
NACH-OBEN-TASTE | {UP}
F1 | {F1}
F2 | {F2}
F3 | {F3}
F4 | {F4}
F5 | {F5}
F6 | {F6}
F7 | {F7}
F8 | {F8}
F9 | {F9}
F10 | {F10}
F11 | {F11}
F12 | {F12}
F13 | {F13}
F14 | {F14}
F15 | {F15}
F16 | {F16}

Um Tastenkombinationen mit UMSCH, STRG und ALT zu spezifizieren, stellen Sie dem Tastencode einen oder mehrere der folgenden Codes voran:

Taste Code
UMSCH +
STRG ^
ALT %

Um festzulegen, dass eine beliebige Kombination der Tasten UMSCH, STRG und ALT gedrückt gehalten werden soll, während mehrere andere Tasten gedrückt werden, umschließen Sie die Codes für diese Tasten mit Klammern. Um beispielsweise festzulegen, dass UMSCH gedrückt gehalten werden soll, während die Tasten E und C gedrückt werden, verwenden Sie die Zeichenfolge "+(EC)". Um beispielsweise festzulegen, dass UMSCH gedrückt gehalten werden soll, während die Taste E gedrückt wird, und anschließend die Taste C ohne UMSCH gedrückt werden soll, verwenden Sie die Zeichenfolge "+EC".

Mithilfe der Syntax {Taste Anzahl} können Sie einen wiederholten Tastendruck festlegen. Zwischen Taste und Zahl muss ein Leerzeichen stehen. So simuliert beispielsweise {LEFT 42} ein 42-maliges Drücken der NACH-LINKS-TASTE, {h 10} ein zehnmaliges Drücken der Taste H.

Anmerkung Sie können mit SendKeys nur Tastendrücke an Anwendungen schicken, die für Microsoft Windows entwickelt wurden. Die Taste DRUCK ({PRTSC}) kann mit SendKeys nicht an eine Anwendung gesendet werden.

Beispiel
Im folgenden Beispiel wird der Windows-Rechner gestartet, und einige einfache Rechenoperationen werden ausgeführt.
set WshShell = CreateObject("WScript.Shell")
WshShell.Run "calc"
WScript.Sleep 100
WshShell.AppActivate "Rechner"
WScript.Sleep 100
WshShell.SendKeys "1{+}"
WScript.Sleep 500
WshShell.SendKeys "2"
WScript.Sleep 500
WshShell.SendKeys "~"
WScript.Sleep 500
WshShell.SendKeys "*3"
WScript.Sleep 500
WshShell.SendKeys "~"
WScript.Sleep 2500


SendKeys-Methode

SendKeys-Methode
Betrifft 		WSH-Referenz
WshShell-Objekt


SetDefaultPrinter-Methode

SetDefaultPrinter-Methode 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Legt den angegebenen Remotedrucker als Standarddrucker fest.
Syntax
Objekt.SetDefaultPrinter strDruckername
Parameter
Teil | Beschreibung
Objekt | WshNetwork-Objekt.
strDruckername | Name des als Standarddrucker festzulegenden Remotedruckers, z. B. \\Server\Drucker1.
Beispiel
Im folgenden Beispiel wird mithilfe der AddPrinterConnection-Methode ein Netzwerkdrucker mit LPT1 verbunden und dieser anschließend als Standarddrucker festgelegt.
Set objNetzwerk = WScript.CreateObject("WScript.Network")
objNetzwerk.AddPrinterConnection "LPT1:", "\\Server\Drucker1"
objNetzwerk.SetDefaultPrinter "\\Server\Drucker1"


SetDefaultPrinter-Methode

SetDefaultPrinter-Methode
Betrifft 		WSH-Referenz
WshNetwork-Objekt


SetDefaultPrinter-Methode

SetDefaultPrinter-Methode
Siehe auch 		WSH-Referenz
AddPrinterConnection-Methode
AddWindowsPrinterConnection-Methode
EnumPrinterConnections-Methode
RemovePrinterConnection-Methode


Skip-Methode

Skip-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Überliest beim Lesen eines Eingabestreams die angegebene Anzahl von Zeichen.
Syntax
Objekt.strStream.Skip(Zeichen)
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdIn-Eigenschaft.
Zeichen | Anzahl der beim Einlesen zu überlesenden Zeichen.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf.


Skip-Methode

Skip-Methode
Betrifft 		WSH-Referenz
StdIn-Eigenschaft


SkipLine-Methode

SkipLine-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Überliest beim Lesen eines Eingabestreams die nächste Zeile.
Syntax
Objekt.strStream.SkipLine
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdIn-Eigenschaft.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf.


SkipLine-Methode

SkipLine-Methode
Betrifft 		WSH-Referenz
StdIn-Eigenschaft


Sleep-Methode

Sleep-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Versetzt den Skriptprozess für die angegebene Dauer (in Millisekunden) in einen inaktiven Zustand und setzt dann die Ausführung fort.
Syntax
object.Sleep(intDauer)
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
intDauer | Dauer der Inaktivität des Skript-Prozesses (in Millisekunden).
Hinweise
Durch das Skript behandelte Ereignisse werden während der Dauer der Inaktivität weiterhin behandelt. Tritt im Skriptmodul eine Zeitüberschreitung oder eine andere Unterbrechung auf, so wird die Inaktivitätsphase sofort beendet.
Beispiel
Das folgende Beispiel deaktiviert das Skript für fünf Sekunden:
WScript.Echo "Gestartet"
WScript.Sleep 5000
WScript.Echo "Beendet"


Sleep-Methode

Sleep-Methode
Betrifft 		WSH-Referenz
WScript-Objekt


Write-Methode

Write-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Schreibt die angegebene Zeichenfolge in einen Ausgabestream.
Syntax
Objekt.strStream.Write(strText)
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdOut- oder StdErr-Eigenschaft.
strText | Der in den Stream zu schreibende Text.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf.


Write-Methode

Write-Methode
Betrifft 		WSH-Referenz
StdErr-Eigenschaft
StdOut-Eigenschaft


WriteBlankLines-Methode

WriteBlankLines-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Schreibt eine angegebene Anzahl von Zeilenumbruchzeichen in einen Ausgabestream.
Syntax
Objekt.strStream.WriteBlankLines(intZeilen)
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdOut- oder StdErr-Eigenschaft.
intZeilen | Anzahl der in den Stream zu schreibenden Zeilenumbruchzeichen.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf.


WriteBlankLines-Methode

WriteBlankLines-Methode
Betrifft 		WSH-Referenz
StdErr-Eigenschaft
StdOut-Eigenschaft


WriteLine-Methode

WriteLine-Methode 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Schreibt eine angegebene Zeichenfolge und ein Zeilenumbruchzeichen in einen Ausgabestream.
Syntax
Objekt.strStream.WriteLine([strText])
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdOut- oder StdErr-Eigenschaft.
strText | Optional. Der in den Stream zu schreibende Text. Ohne Angabe wird ein Zeilenumbruchzeichen in den Stream geschrieben.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf.


WriteLine-Methode

WriteLine-Methode
Betrifft 		WSH-Referenz
StdErr-Eigenschaft
StdOut-Eigenschaft


WScript-Objekt

WScript-Objekt 		WSH-Referenz
Version 1

Siehe auch Eigenschaften Methoden

Beschreibung
Legt Eigenschaften wie den Pfad des ausgeführten Scripting-Hosts (wscript.exe bzw. cscript.exe), seine Argumente und den Arbeitsmodus (interaktiver Modus oder Batchmodus) offen. Das WScript-Objekt stellt auch Methoden zum Erstellen und Lesen von Objekten bereit.
Beispiel
Im folgenden Bespiel werden die Werte der Umgebungsvariablen mithilfe der Echo-Methode ausgegeben:
Set WshShell = WScript.CreateObject( "WScript.Shell" )
WScript.Echo WshShell.Environment("Process").Item("WINDIR")
WScript.Echo WshShell.Environment("Process").Item("PATH")
WScript.Echo WshShell.Environment("Process").Item("PROMPT")
WScript.Echo WshShell.ExpandEnvironmentStrings("%WINDIR%")


Wscript-Objekt

WScript-Objekt
Siehe auch 		WSH-Referenz
WshShell-Objekt


Wscript-Objekt

WScript-Objekt
Methoden 		WSH-Referenz
CreateObject-Methode
ConnectObject-Methode
DisconnectObject-Methode
Echo-Methode
GetObject-Methode
Quit-Methode
Sleep-Methode


WScript-Objekt

WScript-Objekt
Eigenschaften 		WSH-Referenz
Application-Eigenschaft
Arguments-Eigenschaft
FullName-Eigenschaft
Name-Eigenschaft
Path-Eigenschaft
ScriptFullName-Eigenschaft
ScriptName-Eigenschaft
StdErr-Eigenschaft
StdIn-Eigenschaft
StdOut-Eigenschaft
Version-Eigenschaft


WshArguments-Objekt

WshArguments-Objekt 		WSH-Referenz
Version 1

Siehe auch Eigenschaften

Beschreibung
Gibt einen Zeiger auf die Auflistung der Befehlszeilenparameter zurück.
Hinweise
Nicht offen gelegt; der Zugriff erfolgt über die Arguments-Eigenschaft.

Beispiel
Das folgende Beispiel zeigt alle in der Arguments-Auflistung enthaltenen Befehlszeilen-Parameter an:
Set objArgs = WScript.Arguments
For i = 0 to objArgs.Count - 1
  WScript.Echo objArgs(i)
Next


WshArguments-Objekt

WshArguments-Objekt
Siehe auch 		WSH-Referenz
Arguments-Eigenschaft


WshArguments-Objekt

WshArguments-Objekt
Eigenschaften 		WSH-Referenz
Item-Eigenschaft
Count-Eigenschaft
Length-Eigenschaft


WshEnvironment-Objekt

WshEnvironment-Objekt 		WSH-Referenz
Version 1

Siehe auch Eigenschaften Methoden

Beschreibung
Abrufen der Microsoft Windows-Systemumgebungsvariablen.
Hinweise
Nicht offen gelegt; der Zugriff erfolgt über die Environment-Eigenschaft.

Beispiel
Das folgende Beispiel ruft die Systemumgebungsvariable NUMBER_OF_PROCESSORS ab:
Set WshShell = WScript.CreateObject("WScript.Shell")
Set WshSysEnv = WshShell.Environment("SYSTEM")
WScript.Echo WshSysEnv("NUMBER_OF_PROCESSORS")


WshEnvironment-Objekt

WshEnvironment-Objekt
Siehe auch 		WSH-Referenz
Environment-Eigenschaft


WshEnvironment-Objekt

WshEnvironment-Objekt
Methoden 		WSH-Referenz
Remove-Methode


WshEnvironment-Objekt

WshEnvironment-Objekt
Eigenschaften 		WSH-Referenz
Item-Eigenschaft
Count-Eigenschaft
Length-Eigenschaft


WshNetwork-Objekt

WshNetwork-Objekt 		WSH-Referenz
Version 1

Eigenschaften Methoden

Beschreibung
Legt das Microsoft Windows-Netzwerk offen und erleichtert so das Herstellen und Löschen von Verbindungen mit Remotelaufwerken und druckern.
Beispiel
Im folgenden Beispiel werden die Namen des Computers und des aktuellen Benutzers ausgegeben:
Set objNetzwerk = WScript.CreateObject("WScript.Network")
WScript.Echo objNetzwerk.ComputerName & " - " & objNetzwerk.UserName


WshNetwork-Objekt

WshNetwork-Objekt
Methoden 		WSH-Referenz
AddPrinterConnection-Methode
AddWindowsPrinterConnection-Methode
EnumNetworkDrives-Methode
EnumPrinterConnection-Methode
MapNetworkDrive-Methode
RemoveNetworkDrive-Methode
RemovePrinterConnection-Methode
SetDefaultPrinter-Methode


WshNetwork-Objekt

WshNetwork-Objekt
Eigenschaften 		WSH-Referenz
ComputerName-Eigenschaft
UserDomain-Eigenschaft
UserName-Eigenschaft


WshShell-Objekt

WshShell-Objekt 		WSH-Referenz
Version 1

Eigenschaften Methoden

Beschreibung
Startet neue Prozesse, erstellt Verknüpfungen und stellt die Environment-Auflistung zur Verwaltung von Umgebungsvariablen wie WINDIR, PATH oder PROMPT zur Verfügung.
Beispiel
Im folgenden Beispiel werden die Werte der Umgebungsvariablen mithilfe der Echo-Methode ausgegeben:
Set WshShell = WScript.CreateObject("WScript.Shell")
WScript.Echo WshShell.Environment.Item("WINDIR")
WScript.Echo WshShell.Environment.Item("PATH")
WScript.Echo WshShell.Environment.Item("PROMPT")
WScript.Echo WshShell.ExpandEnvironmentStrings("%WINDIR%")


WshShell-Objekt

WshShell-Objekt
Methoden 		WSH-Referenz
AppActivate-Methode
CreateShortcut-Methode
ExpandEnvironmentStrings-Methode
LogEvent-Methode
Popup-Methode
RegDelete-Methode
RegRead-Methode
RegWrite-Methode
Run-Methode
SendKeys-Methode


WshShell-Objekt

WshShell-Objekt
Eigenschaften 		WSH-Referenz
Environment-Eigenschaft
SpecialFolders-Eigenschaft


WshShortcut-Objekt

WshShortcut-Objekt 		WSH-Referenz
Version 1

Siehe auch Eigenschaften Methoden

Beschreibung
Erstellt einen Objektverweis auf eine Verknüpfung.
Hinweise
Nicht offen gelegt; der Zugriff erfolgt über die CreateShortcut-Methode.

Beispiel
Das folgende Beispiel erstellt eine Verknüpfung mit dem derzeit ausgeführten Skript.
Set WshShell = WScript.CreateObject("WScript.Shell")
Set oShellVerknuepfung = WshShell.CreateShortcut("Aktuelles Skript.lnk")
oShellVerknuepfung.TargetPath = WScript.ScriptFullName
oShellVerknuepfung.Save


WshShortcut-Objekt

WshShortcut-Objekt
Siehe auch 		WSH-Referenz
CreateShortcut-Methode


WshShortcut-Objekt

WshShortcut-Objekt
Methoden 		WSH-Referenz
Save-Methode


WshShortcut-Objekt

WshShortcut-Objekt
Eigenschaften 		WSH-Referenz
Arguments-Eigenschaft
Description-Eigenschaft
FullName-Eigenschaft
Hotkey-Eigenschaft
IconLocation-Eigenschaft
TargetPath-Eigenschaft
WindowStyle-Eigenschaft
WorkingDirectory-Eigenschaft


WshSpecialFolders-Objekt

WshSpecialFolders-Objekt 		WSH-Referenz
Version 1

Siehe auch Eigenschaften

Beschreibung
Bestimmt die Pfade von Windows-Shellordnern wie Desktop, Startmenü oder Eigene Dateien.
Hinweise
Nicht offen gelegt; der Zugriff erfolgt über die SpecialFolders-Eigenschaft. Mithilfe dieses Objekts können Sie den Pfad des Ordners Desktop bestimmen, um Verknüpfungen auf dem Desktop anlegen zu können.

Beispiel
Das folgende Beispiel zeigt in einem Meldungsfeld den Pfad des Ordners Desktop an:
Set WshShell = WScript.CreateObject("WScript.Shell")
MsgBox "Der Pfad Ihres Desktops lautet: " & WshShell.SpecialFolders("Desktop")


WshSpecialFolders-Objekt

WshSpecialFolders-Objekt
Siehe auch 		WSH-Referenz
SpecialFolders-Eigenschaft


WshSpecialFolders-Objekt

WshSpecialFolders-Objekt
Eigenschaften 		WSH-Referenz
Item-Eigenschaft
Count-Eigenschaft
Length-Eigenschaft


WshUrlShortcut-Objekt

WshUrlShortcut-Objekt 		WSH-Referenz
Version 1

Siehe auch Eigenschaften Methoden

Beschreibung
Erstellt einen Objektverweis auf eine URL-Verknüpfung.
Hinweise
Nicht offen gelegt; der Zugriff erfolgt über die CreateShortcut-Methode.

Beispiel
Das folgende Beispiel erstellt eine URL-Verknüpfung mit www.microsoft.de:
Set WshShell = WScript.CreateObject("WScript.Shell")
Set oUrlVerknuepfung = WshShell.CreateShortcut("Microsoft Web Site.URL")
oUrlVerknuepfung.TargetPath = "http://www.microsoft.de"
oUrlVerknuepfung.Save


WshUrlShortcut-Objekt

WshUrlShortcut-Objekt
Siehe auch 		WSH-Referenz
CreateShortcut-Methode


WshUrlShortcut-Objekt

WshUrlShortcut-Objekt
Methoden 		WSH-Referenz
Save-Methode


WshUrlShortcut-Objekt

WshUrlShortcut-Objekt
Eigenschaften 		WSH-Referenz
FullName-Eigenschaft
TargetPath-Eigenschaft


Application-Eigenschaft

Application-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Stellt die IDispatch-Schnittstelle für das WScript-Objekt zur Verfügung.
Syntax
Objekt.Application
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.


Application-Eigenschaft

Application-Eigenschaft
Betrifft 		WSH-Referenz
WScript-Objekt


Arguments-Eigenschaft

Arguments-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Gibt einen Zeiger auf die WshArguments-Auflistung zurück oder bezeichnet die Argumente für die Verknüpfung mit der Auflistung.
Syntax
Objekt.Arguments
Parameter
Teil | Beschreibung
Objekt | WScript- oder WshShortcut-Objekt.
Beispiel
Das folgende Beispiel zeigt alle in der Arguments-Auflistung enthaltenen Befehlszeilen-Parameter an:
Set objArgs = WScript.Arguments
For i = 0 to objArgs.Count - 1
  WScript.Echo objArgs(i)
Next


Arguments-Eigenschaft

Arguments-Eigenschaft
Betrifft 		WSH-Referenz
WshShortcut-Objekt
WScript-Objekt
WshArguments-Objekt


AtEndOfLine-Eigenschaft

AtEndOfLine-Eigenschaft 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Gibt True zurück, wenn sich der Streamzeiger in einem Eingabestream unmittelbar vor der Zeilenendemarke befindet, andernfalls False.
Syntax
Objekt.strStream.AtEndOfLine
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdIn-Eigenschaft.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf. Weitergehende Informationen finden Sie unter Fehlermeldungen.


AtEndOfLine-Eigenschaft

AtEndOfLine-Eigenschaft
Betrifft 		WSH-Referenz
StdIn-Eigenschaft


AtEndOfStream-Eigenschaft

AtEndOfStream-Eigenschaft 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Gibt True zurück, wenn sich der Streamzeiger am Ende des Eingabestreams befindet, andernfalls False.
Syntax
Objekt.strStream.AtEndOfStream
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdIn-Eigenschaft.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf. Weitergehende Informationen finden Sie unter Fehlermeldungen.


AtEndOfStream-Eigenschaft

AtEndOfStream-Eigenschaft
Betrifft 		WSH-Referenz
StdIn-Eigenschaft


Column-Eigenschaft

Column-Eigenschaft 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Gibt die Spaltennummer der aktuellen Zeichenposition in einem Eingabestream zurück.
Syntax
Objekt.strStream.Column
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdIn-Eigenschaft.
Hinweise
Diese Eigenschaft ist schreibgeschützt. Wurde ein Zeilenumbruchzeichen geschrieben, so hat Column den Wert 1, sofern noch kein weiteres Zeichen geschrieben wurde.

Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf. Weitergehende Informationen finden Sie unter Fehlermeldungen.


Column-Eigenschaft

Column-Eigenschaft
Betrifft 		WSH-Referenz
StdIn-Eigenschaft


ComputerName-Eigenschaft

ComputerName-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Enthält eine Zeichenfolgendarstellung des Computernamens.
Syntax
Objekt.ComputerName
Parameter
Teil | Beschreibung
Objekt | WshNetwork-Objekt.
Beispiel
Im folgenden Beispiel werden die Namen des Computers und des aktuellen Benutzers ausgegeben:
Set objNetzwerk = WScript.CreateObject("WScript.Network")
WScript.Echo objNetzwerk.ComputerName & " - " & objNetzwerk.UserName


ComputerName-Eigenschaft

ComputerName-Eigenschaft
Betrifft 		WSH-Referenz
WshNetwork-Objekt


Count-Eigenschaft

Count-Eigenschaft 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die Anzahl der Elemente in einer Auflistung zurück.
Syntax
Objekt.Count
Parameter
Teil | Beschreibung
Objekt | Das Ergebnis der EnumNetworkDrive- oder EnumPrinterConnections-Methode oder das von der Arguments-Eigenschaft zurückgegebene Objekt.
Hinweise
In JScript ist die Count-Eigenschaft nicht wie in VBScript als Eigenschaft, sondern als Methode implementiert. Wenn Sie daher Count wie im folgenden Beispiel in JScript einsetzen, müssen Sie am Ende der Anweisung einen Satz Klammern anfügen:
objArgs.Count()
Beispiel
Das folgende Beispiel zeigt alle in der Arguments-Auflistung enthaltenen Befehlszeilen-Parameter an:
Set objArgs = WScript.Arguments
For i = 0 to objArgs.Count - 1
  WScript.Echo objArgs(i)
Next


Count-Eigenschaft

Count-Eigenschaft
Betrifft 		WSH-Referenz
EnumNetworkDrives-Methode
EnumPrinterConnections-Methode
Arguments-Eigenschaft


Count-Eigenschaft

Count-Eigenschaft
Siehe auch 		WSH-Referenz
Arguments-Eigenschaft
Length-Eigenschaft


Description-Eigenschaft

Description-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Enthält die Beschreibung eines Verknüpfungsobjekts.
Syntax
Objekt.Description
Parameter
Teil | Beschreibung
Objekt | WshShortcut-Objekt.
Beispiel
Das folgende Beispiel erstellt eine Verknüpfung mit dem derzeit ausgeführten Skript:
Set WshShell = WScript.CreateObject("WScript.Shell")
Set oShellVerknuepfung = WshShell.CreateShortcut("Aktuelles Skript.lnk")
oShellVerknuepfung.TargetPath = WScript.ScriptFullName
oShellVerknuepfung.Description = "Derzeit ausgeführtes Skript."
oShellVerknuepfung.Save


Description-Eigenschaft

Description-Eigenschaft
Betrifft 		WSH-Referenz
WshShortcut-Objekt


Environment-Eigenschaft

Environment-Eigenschaft 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Gibt das WshEnvironment-Objekt zurück.
Syntax
Objekt.Environment ([strTyp])
Parameter
Teil | Beschreibung
Objekt | WshShell-Objekt.
strTyp | Optional. Gibt die Herkunft der Umgebungsvariable an.
Hinweise
Wird strTyp angegeben, so legt dieser Parameter die Herkunft der Umgebungsvariable an. Mögliche Werte sind "System", "User", "Volatile" und "Process". Wird strTyp nicht angegeben, so ruft diese Methode unter Windows 2000 die System-Umgebungsvariablen ab, unter Windows 9x die Prozess-Umgebungsvariablen. Unter Windows 9x wird nur "Process" als Wert für den Parameter strTyp unterstützt.

Die folgende Tabelle listet einige der beim Betriebssystem Windows vorhandenen Variablen auf. Skripte können außerdem auch von anderen Anwendungen definierte Umgebungsvariablen abrufen. Beim Typ "Volatile" steht keine dieser Variablen zur Verfügung.

Name | Beschreibung | Windows 2000 | Windows 95/98
System | User | Volatile | Process
NUMBER_OF_PROCESSORS | Anzahl der Prozessoren des Computers. | X | X
PROCESSOR_ARCHITECTURE | Prozessortyp der Benutzer-Workstation. | X | X
PROCESSOR_IDENTIFIER | Kennung des Prozessors der Benutzer-Workstation. | X | X
PROCESSOR_LEVEL | Prozessorstufe der Benutzer-Workstation. | X | X
PROCESSOR_VERSION | Version des Prozessors der Benutzer-Workstation. | X | X
OS | Betriebssystem der Benutzer-Workstation. | X | X
COMSPEC | Ausführbare Datei für die Befehlseingabeaufforderung (normalerweise cmd.exe). | X | X | X
HOMEDRIVE | Primäres lokales Laufwerk (normalerweise Laufwerk C). | X
HOMEPATH | Standardverzeichnis für Benutzer (bei Windows 2000 normalerweise \users\default). | X
PATH | Umgebungsvariable PATH. | X | X | X | X
PATHEXT | Erweiterungen für ausführbare Dateien (normalerweise COM, EXE, BAT und CMD). | X | X
PROMPT | Befehlseingabeaufforderung (normalerweise $P$G). | X | X
SYSTEMDRIVE | Lokales Laufwerk, auf dem sich das Systemverzeichnis befindet (normalerweise C:\). | X
SYSTEMROOT | Systemverzeichnis (z. B. C:\WINNT). Entspricht WINDIR. | X
WINDIR | Systemverzeichnis (z. B. C:\WINNT). Entspricht SYSTEMROOT. | X | X | X
TEMP | Verzeichnis für die Speicherung temporärer Dateien (z. B. C:\TEMP). | X | X | X
TMP | Verzeichnis für die Speicherung temporärer Dateien (z. B. C:\TEMP). | X | X | X

Beispiel
Das folgende Beispiel ruft die Systemumgebungsvariable NUMBER_OF_PROCESSORS ab:
Set WshShell = WScript.CreateObject("WScript.Shell")
Set WshSysEnv = WshShell.Environment("SYSTEM")
WScript.Echo WshSysEnv("NUMBER_OF_PROCESSORS")


Environment-Eigenschaft

Environment-Eigenschaft
Betrifft 		WSH-Referenz
WshShell-Objekt


Environment-Eigenschaft

Environment-Eigenschaft
Siehe auch 		WSH-Referenz
WshEnvironment-Objekt


FullName-Eigenschaft

FullName-Eigenschaft 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Gibt eine Zeichenfolge zurück, die den vollständigen Pfad zur ausführbaren Hostdatei oder zum Verknüpfungsobjekt enthält.
Syntax
Objekt.FullName
Parameter
Teil | Beschreibung
Objekt | WScript-, WshShortcut- oder WshUrlShortcut-Objekt.
Beispiel
Das folgende Beispiel gibt den Pfad der ausführbaren Hostdatei zurück:
WScript.Echo WScript.Fullname


FullName-Eigenschaft

FullName-Eigenschaft
Betrifft 		WSH-Referenz
WScript-Objekt
WshShortcut-Objekt
WshUrlShortcut-Objekt


FullName-Eigenschaft

FullName-Eigenschaft
Siehe auch 		WSH-Referenz
Path-Eigenschaft


Hotkey-Eigenschaft

Hotkey-Eigenschaft 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Enthält den Hotkey eines Verknüpfungsobjekts. Ein Hotkey ist eine Tastenkombination, mit der ein Programm gestartet oder zu diesem gewechselt werden kann.
Syntax
Objekt.Hotkey = strHotkey
Parameter
Teil | Beschreibung
Objekt | WshShortcut-Objekt.
strHotkey | Zuzuweisende Tastenfolge.
Hinweise
strHotkey hat die folgende Syntax, wobei keine Unterscheidung zwischen Klein- und Großbuchstaben getroffen wird:

Teil Beschreibung
Modifikator "ALT+" | "CTRL+" | "SHIFT+" | "EXT+"
Taste "A" .. "Z" |
"0".. "9" |
"Back" | "Tab" | "Clear" | "Return" |
"Escape" | "Space" | "Prior" | ...

Hotkeys können nur Verknüpfungen auf dem Windows-Desktop oder im Windows-Startmenü aktivieren.

Beispiel
Das folgende Beispiel erstellt eine Verknüpfung und weist dieser einen Hotkey zu:
Set WshShell = WScript.CreateObject("WScript.Shell")
strDesktop = WshShell.SpecialFolders("Desktop")
Set oMeinShortcut = WshShell.CreateShortcut(strDesktop & "\eine_Taste.lnk")
oMeinShortcut.TargetPath = "%windir%\notepad.exe"
oMeinShortcut.Hotkey = "ALT+CTRL+F"
oMeinShortcut.Save
WScript.Echo oMeinShortcut.Hotkey


Hotkey-Eigenschaft

Hotkey-Eigenschaft
Betrifft 		WSH-Referenz
WshShortcut-Objekt


Hotkey-Eigenschaft

Hotkey-Eigenschaft
Siehe auch 		WSH-Referenz
WshSpecialFolders-Objekt


IconLocation-Eigenschaft

IconLocation-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Enthält den Speicherort des Symbols eines Verknüpfungsobjekts.
Syntax
Objekt.IconLocation = strSymbolSpeicherort
Parameter
Teil | Beschreibung
Objekt | WshShortcut-Objekt.
strSymbolSpeicherort | Speicherort und Index des Symbols. Diese Angabe hat das Format "Pfad, Index".
Beispiel
Das folgende Beispiel erstellt eine Verknüpfung mit dem derzeit ausgeführten Skript:
Set WshShell = WScript.CreateObject("WScript.Shell")
Set oShellVerknuepfung = WshShell.CreateShortcut("Aktuelles Skript.lnk")
oShellVerknuepfung.TargetPath = WScript.ScriptFullName
oShellVerknuepfung.IconLocation = "notepad.exe, 0"
oShellVerknuepfung.Save


IconLocation-Eigenschaft

IconLocation-Eigenschaft
Betrifft 		WSH-Referenz
WshShortcut-Objekt


Item-Eigenschaft

Item-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Gibt ein bestimmtes Element aus einer Auflistung zurück.
Syntax
Objekt.Item(natIndex)
Parameter
Teil | Beschreibung
Objekt | Das Ergebnis der EnumNetworkDrive- oder EnumPrinterConnections-Methode oder das von der Environment- oder der SpecialFolders-Eigenschaft zurückgegebene Objekt.
natIndex | Gewünschtes Element.
Hinweise
Item ist für alle Auflistungen die Standardeigenschaft. Für die EnumNetworkDrive- und EnumPrinterConnections-Auflistungen ist natIndex eine Ganzzahl. Für die Environment- und SpecialFolders-Auflistungen ist natIndex eine Zeichenfolge.

WshShell.SpecialFolders.Item("strOrdnername") gibt NULL zurück, wenn der angeforderte Ordner (strOrdnername) nicht verfügbar sein sollte. So verfügt beispielsweise Windows 9x nicht über den Ordner AllUsersDesktop. Wird dieser abgerufen (strOrdnername = AllUsersDesktop), so gibt die Eigenschaft NULL zurück.

Die folgende Tabelle führt die Sonderordner auf und gibt an, in welchen Versionen von Windows diese vorkommen:

Windows-Sonderordner
Ordner | Windows-Version
AllUsersDesktop | Windows 2000
AllUsersStartMenu | Windows 2000
AllUsersPrograms | Windows 2000
AllUsersStartup | Windows 2000
Autostart (Startup) | Windows 2000
Desktop | Windows 9x, Windows 2000
Eigene Dateien (My Documents) | Windows 9x, Windows 2000
Favoriten (Favorites) | Windows 9x, Windows 2000
Fonts | Windows 9x, Windows 2000
NetHood | Windows 9x, Windows 2000
PrintHood | Windows 9x, Windows 2000
Programme (Programs) | Windows 9x, Windows 2000
Recent | Windows 9x, Windows 2000
SendTo | Windows 9x, Windows 2000
Startmenü (Start Menu) | Windows 9x, Windows 2000
Vorlagen (Templates) | Windows 2000
Beispiel
Das folgende Beispiel gibt die Laufwerkbuchstaben und Netzwerkzuordnungen aus:

Set objNetzwerk = WScript.CreateObject("WScript.Network")
Set oLaufwerke = objNetzwerk.EnumNetworkDrives
For i = 0 to oLaufwerke.Count -1
    WScript.Echo oLaufwerke.Item(i)
Next


Item-Eigenschaft

Item-Eigenschaft
Betrifft 		WSH-Referenz
EnumNetworkDrive-Methode
EnumPrinterConnections-Methode
Environment-Eigenschaft
SpecialFolders-Eigenschaft


Item-Eigenschaft

Item-Eigenschaft
Siehe auch 		WSH-Referenz
Arguments-Eigenschaft
Environment-Eigenschaft
SpecialFolders-Eigenschaft


Length-Eigenschaft

Length-Eigenschaft 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Gibt die Anzahl der Elemente in einer Auflistung zurück.
Syntax
Objekt.length
Parameter
Teil | Beschreibung
Objekt | WshArguments-, WshEnvironment- oder WshSpecialFolders-Objekt.

Hinweise
Diese Methode bietet dieselbe Funktionalität wie die Count-Eigenschaft. Sie existiert im Wesentlichen, um die Kompatibilität mit Microsoft® JScript® zu wahren.


Length-Eigenschaft

Length-Eigenschaft
Betrifft 		WSH-Referenz
WshEnvironment-Objekt
WshArguments-Objekt
WshSpecialFolders-Objekt


Length-Eigenschaft

Length-Eigenschaft
Siehe auch 		WSH-Referenz
Arguments-Eigenschaft
Count-Eigenschaft


Line-Eigenschaft

Line-Eigenschaft 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Gibt die aktuelle Zeilennummer in einem Eingabestream zurück.
Syntax
Objekt.strStream.Line
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
strStream | StdIn-Eigenschaft.
Hinweise
Diese Eigenschaft ist schreibgeschützt. Unmittelbar nach dem Öffnen einer Datei (vor jedem Schreibzugriff) hat Line den Wert 1.

Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf. Weitergehende Informationen finden Sie unter Fehlermeldungen.


Line-Eigenschaft

Line-Eigenschaft
Betrifft 		WSH-Referenz
StdIn-Eigenschaft


Name-Eigenschaft

Name-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Enthält eine Zeichenfolge mit dem ausführlichen Namen des WScript-Objekts.
Syntax
Objekt.Name
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
Hinweise
Diese Eigenschaft ist die schreibgeschützte Standardeigenschaft.

Beispiel
Das folgende Beispiel zeigt zwei mögliche Arten zur Verwendung dieser Eigenschaft:
WScript.Echo WScript.Name
WScript.Echo WScript


Name-Eigenschaft

Name-Eigenschaft
Betrifft 		WSH-Referenz
WScript-Objekt


Path-Eigenschaft

Path-Eigenschaft 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Enthält eine Zeichenfolge mit dem Namen des Verzeichnisses, das WScript.exe bzw. CScript.exe enthält.
Syntax
Objekt.Path
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
Beispiel
Das folgende Beispiel gibt den Pfad des Verzeichnisses mit der ausführbaren Datei aus:
WScript.Echo WScript.Path


Path-Eigenschaft

Path-Eigenschaft
Betrifft 		WSH-Referenz
WScript-Objekt


Path-Eigenschaft

Path-Eigenschaft
Siehe auch 		WSH-Referenz
FullName-Eigenschaft


ScriptFullName-Eigenschaft

ScriptFullName-Eigenschaft 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Enthält den vollständigen Pfad zum derzeit ausgeführten Skript.
Syntax
Objekt.ScriptFullName
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
Beispiel
Das folgende Beispiel gibt den vollständigen Pfad des ausgeführten Skriptes aus:
WScript.Echo WScript.ScriptFullName


ScriptFullName-Eigenschaft

ScriptFullName-Eigenschaft
Betrifft 		WSH-Referenz
WScript-Objekt


ScriptFullName-Eigenschaft

ScriptFullName-Eigenschaft
Siehe auch 		WSH-Referenz
ScriptName-Eigenschaft


ScriptName-Eigenschaft

ScriptName-Eigenschaft 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Enthält den Dateinamen des derzeit ausgeführten Skriptes.
Syntax
Objekt.ScriptName
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
Beispiel
Das folgende Beispiel gibt den Namen des ausgeführten Skriptes aus:
WScript.Echo WScript.ScriptName


ScriptName-Eigenschaft

ScriptName-Eigenschaft
Betrifft 		WSH-Referenz
WScript-Objekt


ScriptName-Eigenschaft

ScriptName-Eigenschaft
Siehe auch 		WSH-Referenz
ScriptFullName-Eigenschaft


SpecialFolders-Eigenschaft

SpecialFolders-Eigenschaft 		WSH-Referenz
Version 1

Siehe auch Betrifft

Beschreibung
Enthält das WshSpecialFolders-Objekt zum Zugriff auf Windows-Shellordner, wie den Ordner Desktop, den Ordner Startmenü und den Ordner Eigene Dateien.
Syntax
Objekt.SpecialFolders(objWshSonderOrdner)
Parameter
Teil | Beschreibung
Objekt | WshShell-Objekt.
objWshSonderOrdner | Der Name des zurückzugebenden Sonderordners.
Hinweise
SpecialFolders gibt NULL zurück, wenn der angeforderte Ordner (objWshSonderOrdner) nicht verfügbar sein sollte. So verfügt beispielsweise Windows 9x nicht über den Ordner AllUsersDesktop. Wird dieser abgerufen (objWshSonderOrdner = AllUsersDesktop), so gibt Windows 9x die Eigenschaft NULL zurück.

Die Betriebssysteme Windows 9x und Windows NT 4.0 stellen die folgenden Sonderordner bereit:

AllUsersDesktop
AllUsersStartMenu
AllUsersPrograms
AllUsersStartup
Autostart (Startup)
Desktop
Eigene Dateien (MyDocuments)
Favoriten (Favorites)
Fonts
NetHood
PrintHood
Programme (Programs)
Recent
SendTo
Startmenü (StartMenu)
Vorlagen (Templates)

Beispiel
Das folgende Beispiel greift auf den Ordner Desktop zu und zeigt dessen Namen an:
Set WshShell = WScript.CreateObject("WScript.Shell")
MsgBox "Ihr Desktop hat den folgenden Pfad:  " & WshShell.SpecialFolders("Desktop")


SpecialFolders-Eigenschaft

SpecialFolders-Eigenschaft
Betrifft 		WSH-Referenz
WshShell-Objekt


SpecialFolders-Eigenschaft

SpecialFolders-Eigenschaft
Siehe auch 		WSH-Referenz
WshSpecialFolders-Objekt


StdErr-Eigenschaft

StdErr-Eigenschaft 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Legt den nur zum Schreiben verfügbaren Fehlerausgabestream für das aktuelle Skript offen.
Syntax
Objekt.StdErr
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf. Weitergehende Informationen finden Sie unter Fehlermeldungen.


StdErr-Eigenschaft

StdErr-Eigenschaft
Betrifft 		WSH-Referenz
WScript-Objekt


StdIn-Eigenschaft

StdIn-Eigenschaft 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Legt den schreibgeschützten Eingabestream für das aktuelle Skript offen.
Syntax
Objekt.StdIn
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf. Weitergehende Informationen finden Sie unter Fehlermeldungen.


StdIn-Eigenschaft

StdIn-Eigenschaft
Betrifft 		WSH-Referenz
WScript-Objekt


StdOut-Eigenschaft

StdOut-Eigenschaft 		WSH-Referenz
Version 2

Betrifft

Beschreibung
Legt den nur zum Schreiben verfügbaren Ausgabestream für das aktuelle Skript offen.
Syntax
Objekt.StdOut
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
Hinweise
Die Methoden und Eigenschaften von StdIn, StdOut und StdErr funktionieren nur dann, wenn das Skript mit CScript.exe ausgeführt wird. Bei der Ausführung mit WScript.exe tritt der Fehler "Ungültige Zugriffsnummer" auf. Weitergehende Informationen finden Sie unter Fehlermeldungen.


StdOut-Eigenschaft

StdOut-Eigenschaft
Betrifft 		WSH-Referenz
WScript-Objekt


TargetPath-Eigenschaft

TargetPath-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Legt den Pfad der auszuführenden Datei für ein Verknüpfungsobjekt fest.
Syntax
Objekt.TargetPath
Parameter
Teil | Beschreibung
Objekt | WshShortcut- oder WshUrlShortcut-Objekt.
Beispiel
Das folgende Beispiel erstellt eine Verknüpfung zum derzeit ausgeführten Skript sowie eine URL-Verknüpfung zu www.microsoft.de:
Set WshShell = WScript.CreateObject("WScript.Shell")
Set oShellVerknuepfung = WshShell.CreateShortcut("Aktuelles Skript.lnk")
oShellVerknuepfung.TargetPath = WScript.ScriptFullName
oShellVerknuepfung.Save
Set oUrlVerknuepfung = WshShell.CreateShortcut("Microsoft Web Site.URL")
oUrlVerknuepfung.TargetPath = "http://www.microsoft.de"
oUrlVerknuepfung.Save


TargetPath-Eigenschaft

TargetPath-Eigenschaft
Betrifft 		WSH-Referenz
WshShortcut-Objekt
WshUrlShortcut-Objekt


UserDomain-Eigenschaft

UserDomain-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Enthält eine Zeichenfolgendarstellung des Benutzerdomänennamens.
Syntax
Objekt.UserDomain
Parameter
Teil | Beschreibung
Objekt | WshNetwork-Objekt.
Beispiel
Das folgende Beispiel gibt den Namen des Computers und die Benutzerdomäne aus:
Set objNetzwerk = WScript.CreateObject("WScript.Network")
WScript.Echo objNetzwerk.ComputerName & " - " & objNetzwerk.UserDomain


UserDomain-Eigenschaft

UserDomain-Eigenschaft
Betrifft 		WSH-Referenz
WshNetwork-Objekt


UserName-Eigenschaft

UserName-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Enthält eine Zeichenfolgendarstellung des Benutzernamens.
Syntax
Objekt.UserName
Parameter
Teil | Beschreibung
Objekt | WshNetwork-Objekt.
Beispiel
Im folgenden Beispiel werden die Namen des Computers und des aktuellen Benutzers ausgegeben:
Set objNetzwerk = WScript.CreateObject("WScript.Network")
WScript.Echo objNetzwerk.ComputerName & " - " & objNetzwerk.UserName


UserName-Eigenschaft

UserName-Eigenschaft
Betrifft 		WSH-Referenz
WshNetwork-Objekt


Version-Eigenschaft

Version-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Gibt die Version von Microsoft Windows Script Host zurück.
Syntax
Objekt.Version
Parameter
Teil | Beschreibung
Objekt | WScript-Objekt.
Beispiel
Das folgende Beispiel gibt die aktuelle Version von Windows Script Host aus:
WScript.Echo WScript.Version


Version-Eigenschaft

Version-Eigenschaft
Betrifft 		WSH-Referenz
WScript-Objekt


WindowStyle-Eigenschaft

WindowStyle-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Enthält den Fensterstil eines Verknüpfungsobjekts.
Syntax
Objekt.WindowStyle = intFensterstil
Parameter
Teil | Beschreibung
Objekt | WshShortcut-Objekt.
intFensterStil | Setzt den Fensterstil des ausgeführten Programms.
Hinweise
Die folgende Tabelle führt die möglichen Einstellungen für intFensterStil auf:

intFensterStil | Beschreibung
1 | Aktiviert ein Fenster und zeigt es an. Wird das Fenster minimiert oder maximiert, so stellt das System die ursprüngliche Größe und Position wieder her.
3 | Aktiviert das Fenster und zeigt es maximiert an.
7 | Minimiert das Fenster und aktiviert das nächste Fenster in der Z-Reihenfolge der Fenster.

Beispiel
Das folgende Beispiel erstellt eine Verknüpfung mit dem derzeit ausgeführten Skript:
Set WshShell = WScript.CreateObject("WScript.Shell")
Set oShellVerknuepfung = WshShell.CreateShortcut("Aktuelles Skript.lnk")
oShellVerknuepfung.TargetPath = WScript.ScriptFullName
oShellVerknuepfung.WindowStyle = 1
oShellVerknuepfung.Save


WindowStyle-Eigenschaft

WindowStyle-Eigenschaft
Betrifft 		WSH-Referenz
WshShortcut-Objekt


WorkingDirectory-Eigenschaft

WorkingDirectory-Eigenschaft 		WSH-Referenz
Version 1

Betrifft

Beschreibung
Enthält das Arbeitsverzeichnis eines Verknüpfungsobjekts.
Syntax
Objekt.WorkingDirectory = strArbeitsverzeichnis
Parameter
Teil | Beschreibung
Objekt | WshShortcut-Objekt.
strArbeitsverzeichnis | Startverzeichnis für die Verknüpfung.
Beispiel
Das folgende Beispiel erstellt eine Verknüpfung mit Windows Editor:

Set WshShell = WScript.CreateObject("WScript.Shell")
Set oShellVerknuepfung = WshShell.CreateShortcut("Editor.lnk")
oShellVerknuepfung.TargetPath = "notepad.exe"
oShellVerknuepfung.WorkingDirectory = "c:\"
oShellVerknuepfung.Save


WorkingDirectory-Eigenschaft

WorkingDirectory-Eigenschaft
Betrifft 		WSH-Referenz
WshShortcut-Objekt