VBScript-Sprachverzeichnis

Microsoft® Visual Basic® Scripting Edition
VBScript-Sprachverzeichnis 		VBScript-Tutorium
Versionsinformationen

Informationen über Funktionsmerkmale

Alphabetische Schlüsselwortliste

Anweisungen

Eigenschaften

Ereignisse

Fehler

Funktionen

Konstanten

Methoden

Objekte

Operatoren

Willkommen beim VBScript-Sprachverzeichnis

Diese kompakten Informationsblöcke unterstützen Sie beim Arbeiten in den zahlreichen unterschiedlichen Bereichen der Scripting-Sprache von Visual Basic.

Sie finden eine alphabetische Auflistung sämtlicher Bereiche der VBScript-Sprache unter der alphabetischen Liste der Schlüsselwörter. Wenn Sie jedoch lediglich zu einer Kategorie, wie z. B. Objekten, etwas nachschlagen möchten, sehen Sie, dass die einzelnen Sprachkategorien jeweils eigene, kompaktere Bereiche enthalten.

Die Funktionsweise ist denkbar einfach. Klicken Sie auf eine der links angezeigten Überschriften, um eine Auflistung der in dieser Kategorie enthaltenen Themen einzublenden. Wählen Sie aus dieser Auflistung anschließend das gewünschte Thema aus. Nachdem Sie das gewünschte Thema eingeblendet haben, können Sie problemlos zu anderen thematisch verknüpften Bereichen wechseln.

Tauchen Sie also ein! Lesen Sie Wissenswertes über Anweisungen, überdenken Sie die Methoden, oder probieren Sie einige Funktionen aus. Sie werden feststellen, dass die VBScript-Sprache ausgesprochen vielseitig ist!

Funktionsmerkmale | Beschreibung
Versionsinformationen | Auflistung von VBScript-Versionen nach Hostanwendung und Auflistung von Funktionsmerkmalen nach Version.
VBScript-Funktionen | Auflistung der zur Zeit in VBScript integrierten Funktionsmerkmale.
Nicht in VBScript enthaltene Visual Basic für Applikationen-Funktionen | Auflistung der Funktionsmerkmale, die derzeit in Visual Basic für Applikationen, nicht jedoch in VBScript vorhanden sind.
VBScript-Funktionen, die nicht in Visual Basic für Applikationen verfügbar sind | Auflistung der Funktionsmerkmale, die in VBScript, nicht jedoch in Visual Basic für Applikationen vorhanden sind.
Merkmale der Microsoft Scripting-Laufzeitbibliothek | Auflistung der zur Zeit in VBScript integrierten Laufzeitmerkmale.
Sprachelement | Beschreibung
Abs-Funktion | Gibt den Absolutwert einer Zahl zurück.
Additionsoperator (+) | Addiert zwei Zahlen miteinander.
And-Operator | Führt eine logische Konjunktion zweier Ausdrücke durch.
Array-Funktion | Gibt einen Variant-Wert zurück, der ein Datenfeld enthält.
Asc-Funktion | Gibt den ANSI-Zeichencode zurück, der dem ersten Buchstaben in einer Zeichenfolge entspricht.
Atn-Funktion | Gibt den Arkustangens einer Zahl zurück.
Call-Anweisung | Überträgt die Steuerung auf eine Sub- oder Function-Prozedur.
CBool-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Boolean konvertiert wurde.
CByte-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Byte konvertiert wurde.
CCur-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Currency konvertiert wurde.
CDate-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Date konvertiert wurde.
CDbl-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Double konvertiert wurde.
Chr-Funktion | Gibt das Zeichen mit dem angegebenen ANSI-Zeichencode zurück.
CInt-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Integer konvertiert wurde.
Class-Anweisung | Deklariert den Namen einer Klasse.
Class-Objekt | Ermöglicht den Zugriff auf Ereignisse einer erstellten Klasse.
Clear-Methode | Löscht die Einstellungen aller Eigenschaften des Err-Objekts.
CLng-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Long konvertiert wurde.
Const-Anweisung | Deklariert Konstanten für die Verwendung anstelle von Literalwerten.
Cos-Funktion | Berechnet den Kosinus eines Winkels.
CreateObject-Funktion | Erstellt einen Verweis auf ein Automatisierungsobjekt und gibt dieses zurück.
CSng-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Single konvertiert wurde.
CStr-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp String konvertiert wurde.
Date-Funktion | Gibt das aktuelle Systemdatum zurück.
DateAdd-Funktion | Gibt ein Datum, zu dem ein angegebenes Zeitintervall addiert wurde, zurück.
DateDiff-Funktion | Gibt den Zeitraum zwischen zwei Datumsangaben zurück.
DatePart-Funktion | Gibt den angegebenen Teil eines Datums zurück.
DateSerial-Funktion | Gibt einen Wert vom Typ Variant mit dem Untertyp Date einer Tages-, Monats- oder Jahresangabe zurück.
DateValue-Funktion | Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück.
Datums- und Uhrzeitkonstanten | Auflistung von Konstanten, die für Datums- und Zeitvorgänge relevant sind, wie z. B. Konstanten für Wochentage.
Datumsformat-Konstanten | Auflistung von Konstanten für die Formatierung von Datums- und Zeitangaben.
Day-Funktion | Gibt den Tag des Monats als ganze Zahl im Bereich von 1 bis 31 zurück.
Description-Eigenschaft | Gibt eine beschreibende Zeichenfolge zu einem Fehler zurück oder legt sie fest.
Dictionary-Objekt | Ein Objekt, das Element/Schlüssel-Paare speichert.
Dim-Anweisung | Deklariert Variablen und reserviert Speicherplatz für sie.
Divisionsoperator (/) | Dividiert zwei Zahlen und gibt ein Fließkommaergebnis zurück.
Do...Loop-Anweisung | Wiederholt einen Block mit Anweisungen, solange eine Bedingung True ist oder bis eine Bedingung True wird.
Empty | Zeigt einen nicht initialisierten Variablenwert an.
Eqv-Operator | Führt eine logische Äquivalenz auf zwei Ausdrücken aus.
Erase-Anweisung | Initialisiert die Elemente in Datenfeldern mit fester Größe neu und gibt den von einem dynamischen Datenfeld belegten Speicherplatz frei.
Err-Objekt | Enthält Informationen zu Laufzeitfehlern.
Eval-Funktion | Wertet einen Ausdruck aus und gibt das Ergebnis zurück.
Execute-Anweisung | Führt eine oder mehrere angegebene Anweisungen aus.
Execute-Methode | Führt eine Suche mit regulärem Ausdruck auf einer angegebenen Zeichenfolge aus.
ExecuteGlobal-Anweisung | Führt eine oder mehrere angegebene Anweisungen im globalen Namensraum eines Skriptes aus.
Exit-Anweisung | Beendet die Ausführung eines durch Do...Loop, For...Next, Function oder Sub definierten Codeblockes.
Exp-Funktion | Gibt e (die Basis des natürlichen Logarithmus) potenziert mit einer Zahl zurück.
Exponentialoperator (^) | Erhebt eine Zahl zur Potenz eines Exponenten.
False | Schlüsselwort mit dem Wert Null (0).
Farbkonstanten | Auflistung von Farbkonstanten.
FileSystemObject-Objekt | Ermöglicht den Zugriff auf das Dateisystem des Computers.
Filter-Funktion | Gibt ein nullbasiertes Datenfeld zurück, das anhand bestimmter Filterkriterien einen Teilbereich eines Zeichenfolgendatenfeldes enthält.
FirstIndex-Eigenschaft | Gibt die Position in einer Suchzeichenfolge zurück, an der eine Entsprechung gefunden wurde.
Fix-Funktion | Gibt den ganzzahligen Anteil einer Zahl zurück.
For Each...Next-Anweisung | Wiederholt eine Reihe von Anweisungen für alle Elemente eines Datenfeldes oder einer Auflistung.
For...Next-Anweisung | Wiederholt eine Reihe von Anweisungen, bis ein Schleifenzähler einen bestimmten Wert erreicht.
FormatCurrency-Funktion | Gibt einen Ausdruck als Währungsbetrag zurück, der mit dem in der Systemsteuerung festgelegten Währungssymbol formatiert ist.
FormatDateTime-Funktion | Gibt einen Ausdruck im Datums- oder Zeitformat zurück.
FormatNumber-Funktion | Gibt einen als Zahl formatierten Ausdruck zurück.
FormatPercent-Funktion | Gibt einen Ausdruck als Prozentangabe (multipliziert mit 100) und einem abschließenden %-Zeichen zurück.
Function-Anweisung | Deklariert den Namen, die Argumente und den Code für den Rumpf einer Function-Prozedur.
Ganzzahl-Divisionsoperator (\) | Dividiert zwei Zahlen miteinander und gibt das Ergebnis als Ganzzahl zurück.
Gebietsschema-ID (LCID)-Diagramm | Auflistung von Gebietsschema-IDs mit den zugehörigen Werten.
GetLocale-Funktion | Gibt den aktuellen Gebietsschema-ID-Wert zurück.
GetObject-Funktion | Gibt einen Verweis auf ein Automatisierungsobjekt aus einer Datei zurück.
GetRef-Funktion | Gibt einen Verweis auf eine Prozedur zurück, die an ein Ereignis gebunden werden kann.
Global-Eigenschaft | Legt einen booleschen Wert fest oder gibt diesen zurück.
HelpContext-Eigenschaft | Gibt die Kontext-ID eines Themas in einer Hilfedatei zurück oder legt eine Kontext-ID fest.
HelpFile-Eigenschaft | Legt einen vollständigen Pfad zu einer Hilfedatei fest oder gibt diesen zurück.
Hex-Funktion | Gibt eine Zeichenfolge mit der Hexadezimaldarstellung einer Zahl zurück.
Hour-Funktion | Gibt eine ganze Zahl im Bereich von 0 bis 23 zurück, die die Stunde des Tages darstellt.
If...Then...Else-Anweisung | Wertet einen Ausdruck aus und führt in Abhängigkeit vom Ergebnis eine Reihe von Anweisungen aus.
IgnoreCase-Eigenschaft | Legt einen booleschen Wert fest, der anzeigt, ob bei einer Mustersuche die Groß-/Kleinschreibung relevant ist, oder gibt diesen zurück.
Imp-Operator | Führt eine logische Implikation auf zwei Ausdrücken durch.
Initialize-Ereignis | Tritt beim Erstellen einer Instanz der zugeordneten Klasse auf.
InputBox-Funktion | Zeigt in einem Dialogfeld eine Eingabeaufforderung an, wartet auf eine Texteingabe oder die Auswahl einer Schaltfläche durch den Benutzer und gibt den Inhalt des Textfeldes zurück.
InStr-Funktion | Gibt die Position des ersten Auftretens einer Zeichenfolge innerhalb einer anderen Zeichenfolge zurück.
InStrRev-Funktion | Gibt die Position des Vorkommens einer Zeichenfolge in einer anderen Zeichenfolge zurück, wobei vom Ende der Zeichenfolge aus gezählt wird.
Int-Funktion | Gibt den ganzzahligen Anteil einer Zahl zurück.
Is-Operator | Vergleicht zwei Objektverweisvariablen miteinander.
IsArray-Funktion | Gibt einen booleschen Wert zurück, der angibt, ob es sich bei einer Variablen um ein Datenfeld handelt.
IsDate-Funktion | Gibt einen booleschen Wert zurück, der angibt, ob ein Ausdruck in ein Datum umgewandelt werden kann.
IsEmpty-Funktion | Gibt einen booleschen Wert zurück, der angibt, ob eine Variable initialisiert wurde.
IsNull-Funktion | Gibt einen booleschen Wert zurück, der angibt, ob ein Ausdruck ungültige Daten (Null) enthält.
IsNumeric-Funktion | Gibt einen booleschen Wert zurück, der angibt, ob ein Ausdruck als Zahl ausgewertet werden kann.
IsObject-Funktion | Gibt einen booleschen Wert zurück, der angibt, ob ein Ausdruck auf ein gültiges Automatisierungsobjekt verweist.
Join-Funktion | Gibt eine Zeichenfolge zurück, die durch Verbinden mehrerer Teilzeichenfolgen in einem Datenfeld erstellt wurde.
Laufzeitfehler | Auflistung von VBScript-Laufzeitfehlern.
LBound-Funktion | Gibt den kleinsten verfügbaren Index für die angegebene Dimension eines Datenfeldes zurück.
LCase-Funktion | Gibt eine Zeichenfolge zurück, in der alle Buchstaben in Kleinbuchstaben umgewandelt wurden.
Left-Funktion | Gibt eine bestimmte Anzahl von Zeichen ab dem ersten (linken) Zeichen einer Zeichenfolge zurück.
Len-Funktion | Gibt die Anzahl der Zeichen in einer Zeichenfolge oder die zum Speichern einer Variablen erforderlichen Bytes zurück.
Length-Eigenschaft | Gibt die Länge einer Entsprechung in einer Suchzeichenfolge zurück.
LoadPicture-Funktion | Gibt ein Bildobjekt zurück. Diese Funktion ist nur auf 32-Bit-Plattformen verfügbar.
Log-Funktion | Gibt den natürlichen Logarithmus einer Zahl zurück.
LTrim-Funktion | Gibt eine Kopie einer Zeichenfolge ohne vorangestellte Leerzeichen zurück.
Match-Objekt | Bietet Zugriff auf die schreibgeschützten Eigenschaften einer Suche mit regulärem Ausdruck.
Matches-Auflistung | Auflistung von Match-Objekten aus Suche mit regulärem Ausdruck.
Mid-Funktion | Gibt eine bestimmte Anzahl von Zeichen aus einer Zeichenfolge zurück.
Minute-Funktion | Gibt eine ganze Zahl im Bereich von 0 bis 59 zurück, die die Minute in der Stunde darstellt.
Mod-Operator | Dividiert zwei Zahlen und gibt nur den Rest zurück.
Month-Funktion | Gibt eine ganze Zahl im Bereich von 1 bis 12 zurück, die den Monat im Jahr darstellt.
MonthName-Funktion | Gibt eine Zeichenfolge für den angegebenen Monat zurück.
MsgBox-Funktion | Zeigt eine Meldung in einem Dialogfeld an, wartet darauf, dass der Benutzer auf eine Schaltfläche klickt, und gibt einen Wert zurück, der anzeigt, auf welche Schaltfläche geklickt wurde.
MsgBox-Konstanten | Auflistung von Konstanten, die mit der MsgBox-Funktion verwendet werden.
Multiplikationsoperator (*) | Multipliziert zwei Zahlen miteinander.
Negationsoperator (-) | Gibt den negativen Wert eines numerischen Ausdruckes an.
Not-Operator | Führt eine logische Negation auf einem Ausdruck durch.
Nothing | Hebt die Zuordnung einer Objektvariablen zu dem eigentlichen Objekt auf.
Now-Funktion | Gibt das aktuelle Datum und die aktuelle Zeit aus den Einstellungen für das Systemdatum und die Systemzeit auf Ihrem Computer zurück.
Null | Gibt an, dass eine Variable keine gültigen Daten enthält.
Number-Eigenschaft | Gibt einen numerischen Wert zurück oder legt einen numerischen Wert fest, der einen Fehler angibt.
Oct-Funktion | Gibt eine Zeichenfolge mit der Oktaldarstellung einer Zahl zurück.
On Error-Anweisung | Aktiviert eine Fehlerbehandlungsroutine.
Operatorvorrang | Auflistung mit Informationen zum Vorrang der verschiedenen in VBScript verwendeten Operatoren.
Option Explicit-Anweisung | Erzwingt die explizite Deklaration aller Variablen in einem Skript.
Or-Operator | Führt eine logische Disjunktion auf zwei Ausdrücken durch.
Pattern-Eigenschaft | Legt das Suchmuster eines regulären Ausdruckes fest oder gibt dieses zurück.
Private-Anweisung | Deklariert private Variablen und reserviert Speicherplatz.
Property Get-Anweisung | Deklariert Namen, Argumente sowie Code, die den Rumpf einer Property-Prozedur darstellen, die den Wert einer Eigenschaft liest (bzw. zurück gibt).
Property Let-Anweisung | Deklariert Namen, Argumente sowie Code, die den Rumpf einer Property-Prozedur darstellen, die den Wert einer Eigenschaft zuweist.
Property Set-Anweisung | Deklariert Namen, Argumente sowie Code, die den Rumpf einer Property-Prozedur darstellen, die einen Objektverweis festlegt.
Public-Anweisung | Deklariert allgemeine Variablen und reserviert Speicherplatz für sie.
Raise-Methode | Löst einen Laufzeitfehler aus.
Randomize-Anweisung | Initialisiert den Zufallszahlengenerator.
ReDim-Anweisung | Deklariert dynamische Datenfeldvariablen und reserviert Speicherplatz auf Prozedurebene (neu).
RegExp-Objekt | Bietet Unterstützung einfacher regulärer Ausdrücke.
Rem-Anweisung | Markiert erläuternde Kommentare in einem Programm.
Replace-Funktion | Gibt eine Zeichenfolge zurück, in der eine bestimmte Zeichenfolge durch eine andere Zeichenfolge so oft wie angegeben ersetzt wurde.
Replace-Methode | Ersetzt den bei einer Suche mit regulärem Ausdruck gefundenen Text.
RGB-Funktion | Gibt eine Zahl zurück, die einen RGB-Farbwert darstellt.
Right-Funktion | Gibt eine bestimmte Anzahl von Zeichen vom rechten Teil (dem Ende) einer Zeichenfolge zurück.
Rnd-Funktion | Gibt eine Zufallszahl zurück.
Round-Funktion | Gibt eine auf die angegebene Anzahl Dezimalstellen gerundete Zahl zurück.
RTrim-Funktion | Gibt die Kopie einer Zeichenfolge ohne nachfolgende Leerzeichen zurück.
ScriptEngine-Funktion | Gibt eine Zeichenfolge mit der gerade verwendeten Skriptsprache zurück.
ScriptEngineBuildVersion-Funktion | Gibt die Build-Versionsnummer des verwendeten Skriptmoduls zurück.
ScriptEngineMajorVersion- Funktion | Gibt die Haupt-Versionsnummer des verwendeten Skriptmoduls zurück.
ScriptEngineMinorVersion- Funktion | Gibt die Neben-Versionsnummer des verwendeten Skriptmoduls zurück.
Second-Funktion | Gibt eine ganze Zahl im Bereich von 0 bis 59 zurück, die die Sekunde in der Minute darstellt.
Select Case-Anweisung | Führt abhängig vom Wert eines Ausdruckes eine von mehreren Anweisungsgruppen aus.
Set-Anweisung | Weist einer Variablen oder Eigenschaft einen Objektverweis zu.
SetLocale-Funktion | Legt das globale Gebietsschema fest und gibt das vorherige Gebietsschema zurück.
Sgn-Funktion | Gibt einen ganzzahligen Wert zurück, der das Vorzeichen einer Zahl darstellt.
Sin-Funktion | Berechnet den Sinus eines Winkels.
Source-Eigenschaft | Gibt den Namen des Objekts oder der Anwendung zurück, das/die ursprünglich den Fehler ausgelöst hat, oder legt den Namen fest.
Space-Funktion | Gibt eine Zeichenfolge mit einer bestimmten Anzahl an Leerzeichen zurück.
Split-Funktion | Gibt ein nullbasiertes eindimensionales Datenfeld zurück, das eine bestimmte Anzahl von Teilzeichenfolgen enthält.
Sqr-Funktion | Gibt die Quadratwurzel einer Zahl zurück.
StrComp-Funktion | Gibt einen Wert zurück, der das Ergebnis eines Zeichenfolgenvergleichs angibt.
String-Funktion | Gibt eine Zeichenfolge der angegebenen Länge mit einem sich wiederholenden Zeichen zurück.
StrReverse-Funktion | Gibt eine Zeichenfolge zurück, in der die Reihenfolge der Zeichen der angegebenen Zeichenfolge umgekehrt wurde.
Sub-Anweisung | Deklariert Namen, Argumente und Code für den Rumpf einer Sub-Prozedur.
Subtraktionsoperator (-) | Ermittelt die Differenz zwischen zwei Zahlen.
Syntaxfehler | Auflistung von VBScript-Syntaxfehlern.
Tan-Funktion | Berechnet den Tangens eines Winkels.
Terminate-Ereignis | Tritt auf, wenn die Instanz der zugehörigen Klasse beendet wird.
Test-Methode | Führt eine Suche mit regulärem Ausdruck auf einer angegebenen Zeichenfolge aus.
Time-Funktion | Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück, der die aktuelle Systemzeit angibt.
Timer-Funktion | Gibt die Anzahl der seit 24:00 Uhr (Mitternacht) vergangenen Sekunden an.
TimeSerial-Funktion | Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück, der die Uhrzeit für eine bestimmte Stunde, Minute und Sekunde enthält.
TimeValue-Funktion | Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück, der die Uhrzeit enthält.
Trim-Funktion | Gibt die Kopie einer Zeichenfolge ohne vorangestellte oder nachfolgende Leerzeichen zurück.
Tristate-Konstanten | Verwenden Sie diese Konstanten in Ihrem Code an beliebiger Stelle, um ihre jeweils angezeigten Werte darzustellen.
True | Ein Schlüsselwort, das dem Wert -1 entspricht.
TypeName-Funktion | Gibt eine Zeichenfolge mit Informationen zum Variant-Untertyp einer Variablen zurück.
UBound-Funktion | Gibt den größten verfügbaren Index für die angegebene Dimension eines Datenfeldes zurück.
UCase-Funktion | Gibt eine Zeichenfolge zurück, die in Großbuchstaben umgewandelt wurde.
Value-Eigenschaft | Gibt den Wert oder Text einer Entsprechung zurück, der in einer Suchzeichenfolge gefunden wurde.
VarType-Funktion | Gibt einen Wert zurück, der den Untertyp einer Variablen angibt.
VarType-Konstanten | Auflistung der Konstanten, die Variant-Untertypen definieren.
VBScript-Konstanten | Verschiedene in VBScript verfügbare Kategorien von Konstanten.
Vergleichskonstanten | Auflistung von Konstanten, die in Vergleichsoperationen verwendet werden.
Verkettungsoperator (&) | Erzwingt eine Zeichenfolgenverkettung zweier Ausdrücke.
Verschiedene Konstanten | Auflistung von Konstanten, die keiner anderen Kategorie zugeordnet werden können.
Weekday-Funktion | Gibt den Wochentag als ganze Zahl zurück.
WeekdayName-Funktion | Gibt eine Zeichenfolge mit dem angegebenen Wochentag zurück.
While...Wend-Anweisung | Führt eine Reihe von Anweisungen aus, solange eine gegebene Bedingung True ist.
With-Anweisung | Führt eine Reihe von Anweisungen auf einem einzelnen Objekt aus.
Xor-Operator | Führt einen logischen Ausschluss auf zwei Ausdrücken durch.
Year-Funktion | Gibt das Jahr als ganze Zahl zurück.
Zeichenfolgenkonstanten | Auflistung von Zeichenfolgenkonstanten.
Zuweisungsoperator (=) | Weist einer Variablen oder Eigenschaft einen Wert zu.
Sprachelement | Beschreibung
Datums- und Uhrzeitkonstanten | Auflistung von Konstanten, die für Datums- und Zeitvorgänge relevant sind, wie z. B. Konstanten für Wochentage.
Datumsformat-Konstanten | Auflistung von Konstanten für die Formatierung von Datums- und Zeitangaben.
Farbkonstanten | Auflistung von Farbkonstanten.
Gebietsschema-ID (LCID)-Diagramm | Auflistung von Gebietsschema-IDs mit den zugehörigen Werten.
MsgBox-Konstanten | Auflistung von Konstanten, die mit der MsgBox-Funktion verwendet werden.
Tristate-Konstanten | Verwenden Sie diese Konstanten in Ihrem Code an beliebiger Stelle, um ihre jeweils angezeigten Werte darzustellen.
VarType-Konstanten | Auflistung der Konstanten, die Variant-Untertypen definieren.
VBScript-Konstanten | Verschiedene in VBScript verfügbare Kategorien von Konstanten.
Vergleichskonstanten | Auflistung von Konstanten, die in Vergleichsoperationen verwendet werden.
Verschiedene Konstanten | Auflistung von Konstanten, die keiner anderen Kategorie zugeordnet werden können.
Zeichenfolgenkonstanten | Auflistung von Zeichenfolgenkonstanten.
Fehler | Beschreibung
Laufzeitfehler | Auflistung von VBScript-Laufzeitfehlern.
Syntaxfehler | Auflistung von VBScript-Syntaxfehlern.
Sprachelement | Beschreibung
Initialize-Ereignis | Tritt beim Erstellen einer Instanz der zugehörigen Klasse auf.
Terminate-Ereignis | Tritt auf, wenn die Instanz der zugehörigen Klasse beendet wird.
Sprachelement | Beschreibung
Abs-Funktion | Gibt den Absolutwert einer Zahl zurück.
Array-Funktion | Gibt einen Variant-Wert zurück, der ein Datenfeld enthält.
Asc-Funktion | Gibt den Zeichencode zurück, der dem ersten Buchstaben in einer Zeichenfolge entspricht.
Atn-Funktion | Gibt den Arkustangens einer Zahl zurück.
CBool-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Boolean konvertiert wurde.
CByte-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Byte konvertiert wurde.
CCur-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Currency konvertiert wurde.
CDate-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Date konvertiert wurde.
CDbl-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Double konvertiert wurde.
Chr-Funktion | Gibt das Zeichen mit dem angegebenen ANSI-Zeichencode zurück.
CInt-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Integer konvertiert wurde.
CLng-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Long konvertiert wurde.
Cos-Funktion | Berechnet den Kosinus eines Winkels.
CreateObject-Funktion | Erstellt einen Verweis auf ein Automatisierungsobjekt und gibt diesen zurück.
CSng-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Single konvertiert wurde.
CStr-Funktion | Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp String konvertiert wurde.
Date-Funktion | Gibt das aktuelle Systemdatum zurück.
DateAdd-Funktion | Gibt ein Datum, zu dem ein angegebenes Zeitintervall addiert wurde, zurück.
DateDiff-Funktion | Gibt den Zeitraum zwischen zwei Datumsangaben zurück.
DatePart-Funktion | Gibt den angegebenen Teil eines Datums zurück.
DateSerial-Funktion | Gibt einen Wert vom Typ Variant mit dem Untertyp Date einer Tages-, Monats- oder Jahresangabe zurück.
DateValue-Funktion | Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück.
Day-Funktion | Gibt den Tag des Monats als ganze Zahl im Bereich von 1 bis 31 zurück.
Eval-Funktion | Wertet einen Ausdruck aus und gibt das Ergebnis zurück.
Exp-Funktion | Gibt e (die Basis des natürlichen Logarithmus) potenziert mit einer Zahl zurück.
Filter-Funktion | Gibt ein nullbasiertes Datenfeld zurück, das anhand bestimmter Filterkriterien einen Teilbereich eines Zeichenfolgendatenfeldes enthält.
Fix-Funktion | Gibt den ganzzahligen Anteil einer Zahl zurück.
FormatCurrency-Funktion | Gibt einen Ausdruck als Währungsbetrag zurück, der mit dem in der Systemsteuerung festgelegten Währungssymbol formatiert ist.
FormatDateTime-Funktion | Gibt einen Ausdruck im Datums- oder Zeitformat zurück.
FormatNumber-Funktion | Gibt einen als Zahl formatierten Ausdruck zurück.
FormatPercent-Funktion | Gibt einen Ausdruck als Prozentangabe (multipliziert mit 100) und einem abschließenden %-Zeichen zurück.
GetLocale-Funktion | Gibt den aktuellen Gebietsschema-ID-Wert zurück.
GetObject-Funktion | Gibt einen Verweis auf ein Automatisierungsobjekt aus einer Datei zurück.
GetRef-Funktion | Gibt einen Verweis auf eine Prozedur zurück, die an ein Ereignis gebunden werden kann.
Hex-Funktion | Gibt eine Zeichenfolge mit der Hexadezimaldarstellung einer Zahl zurück.
Hour-Funktion | Gibt eine ganze Zahl im Bereich von 0 bis 23 zurück, die die Stunde des Tages darstellt.
InputBox-Funktion | Zeigt in einem Dialogfeld eine Eingabeaufforderung an, wartet auf eine Texteingabe oder die Auswahl einer Schaltfläche durch den Benutzer und gibt den Inhalt des Textfeldes zurück.
InStr-Funktion | Gibt die Position des ersten Auftretens einer Zeichenfolge innerhalb einer anderen Zeichenfolge zurück.
InStrRev-Funktion | Gibt die Position des Vorkommens einer Zeichenfolge in einer anderen Zeichenfolge zurück, wobei vom Ende der Zeichenfolge aus gezählt wird.
Int-Funktion | Gibt den ganzzahligen Anteil einer Zahl zurück.
IsArray-Funktion | Gibt einen Boolean-Wert zurück, der angibt, ob es sich bei einer Variablen um ein Datenfeld handelt.
IsDate-Funktion | Gibt einen Boolean-Wert zurück, der angibt, ob ein Ausdruck in ein Datum konvertiert werden kann.
IsEmpty-Funktion | Gibt einen Boolean-Wert zurück, der angibt, ob eine Variable initialisiert wurde.
IsNull-Funktion | Gibt einen Boolean-Wert zurück, der angibt, ob ein Ausdruck ungültige Daten (Null) enthält.
IsNumeric-Funktion | Gibt einen Boolean-Wert zurück, der angibt, ob ein Ausdruck als Zahl ausgewertet werden kann.
IsObject-Funktion | Gibt einen Boolean-Wert zurück, der angibt, ob ein Ausdruck auf ein gültiges Automatisierungsobjekt verweist.
Join-Funktion | Gibt eine Zeichenfolge zurück, die durch Verbinden mehrerer Teilzeichenfolgen in einem Datenfeld erstellt wurde.
LBound-Funktion | Gibt den kleinsten verfügbaren Index für die angegebene Dimension eines Datenfeldes zurück.
LCase-Funktion | Gibt eine Zeichenfolge zurück, in der alle Buchstaben in Kleinbuchstaben umgewandelt wurden.
Left-Funktion | Gibt eine bestimmte Anzahl von Zeichen ab dem ersten (linken) Zeichen einer Zeichenfolge zurück.
Len-Funktion | Gibt die Anzahl der Zeichen in einer Zeichenfolge oder die zum Speichern einer Variablen erforderlichen Bytes zurück.
LoadPicture-Funktion | Gibt ein Bildobjekt zurück. Diese Funktion ist nur auf 32-Bit-Plattformen verfügbar.
Log-Funktion | Gibt den natürlichen Logarithmus einer Zahl zurück.
LTrim-Funktion | Gibt eine Kopie einer Zeichenfolge ohne vorangestellte Leerzeichen zurück.
Mid-Funktion | Gibt eine bestimmte Anzahl von Zeichen aus einer Zeichenfolge zurück.
Minute-Funktion | Gibt eine ganze Zahl im Bereich von 0 bis 59 zurück, die die Minute in der Stunde darstellt.
Month-Funktion | Gibt eine ganze Zahl im Bereich von 1 bis 12 zurück, die den Monat im Jahr darstellt.
MonthName-Funktion | Gibt eine Zeichenfolge für den angegebenen Monat zurück.
MsgBox-Funktion | Zeigt eine Meldung in einem Dialogfeld an, wartet darauf, dass der Benutzer auf eine Schaltfläche klickt, und gibt einen Wert zurück, der anzeigt, auf welche Schaltfläche geklickt wurde.
Now-Funktion | Gibt das aktuelle Datum und die aktuelle Zeit aus den Einstellungen für das Systemdatum und die Systemzeit auf Ihrem Computer zurück.
Oct-Funktion | Gibt eine Zeichenfolge mit der Oktaldarstellung einer Zahl zurück.
Replace-Funktion | Gibt eine Zeichenfolge zurück, in der eine bestimmte Zeichenfolge durch eine andere Zeichenfolge so oft wie angegeben ersetzt wurde.
RGB-Funktion | Gibt eine Zahl zurück, die einen RGB-Farbwert darstellt.
Right-Funktion | Gibt eine bestimmte Anzahl von Zeichen vom rechten Teil (dem Ende) einer Zeichenfolge zurück.
Rnd-Funktion | Gibt eine Zufallszahl zurück.
Round-Funktion | Gibt eine auf die angegebene Anzahl Dezimalstellen gerundete Zahl zurück.
RTrim-Funktion | Gibt die Kopie einer Zeichenfolge ohne nachfolgende Leerzeichen zurück.
ScriptEngine-Funktion | Gibt eine Zeichenfolge mit der gerade verwendeten Skriptsprache zurück.
ScriptEngineBuildVersion-Funktion | Gibt die Build-Versionsnummer des verwendeten Skriptmoduls zurück.
ScriptEngineMajorVersion- Funktion | Gibt die Haupt-Versionsnummer des verwendeten Skriptmoduls zurück.
ScriptEngineMinorVersion- Funktion | Gibt die Neben-Versionsnummer des verwendeten Skriptmoduls zurück.
Second-Funktion | Gibt eine ganze Zahl im Bereich von 0 bis 59 zurück, die die Sekunde in der Minute darstellt.
SetLocale-Funktion | Legt das globale Gebietsschema fest und gibt das vorherige Gebietsschema zurück.
Sgn-Funktion | Gibt einen ganzzahligen Wert zurück, der das Vorzeichen einer Zahl darstellt.
Sin-Funktion | Berechnet den Sinus eines Winkels.
Space-Funktion | Gibt eine Zeichenfolge mit einer bestimmten Anzahl an Leerzeichen zurück.
Split-Funktion | Gibt ein nullbasiertes eindimensionales Datenfeld zurück, das eine bestimmte Anzahl von Teilzeichenfolgen enthält.
Sqr-Funktion | Gibt die Quadratwurzel einer Zahl zurück.
StrComp-Funktion | Gibt einen Wert zurück, der das Ergebnis eines Zeichenfolgenvergleichs angibt.
String-Funktion | Gibt eine Zeichenfolge der angegebenen Länge mit einem sich wiederholenden Zeichen zurück.
StrReverse-Funktion | Gibt eine Zeichenfolge zurück, in der die Reihenfolge der Zeichen der angegebenen Zeichenfolge umgekehrt wurde.
Tan-Funktion | Berechnet den Tangens eines Winkels.
Time-Funktion | Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück, der die aktuelle Systemzeit angibt.
Timer-Funktion | Gibt die Anzahl der seit 24:00 Uhr (Mitternacht) vergangenen Sekunden an.
TimeSerial-Funktion | Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück, der die Uhrzeit für eine bestimmte Stunde, Minute und Sekunde enthält.
TimeValue-Funktion | Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück, der die Uhrzeit enthält.
Trim-Funktion | Gibt die Kopie einer Zeichenfolge ohne vorangestellte oder nachfolgende Leerzeichen zurück.
TypeName-Funktion | Gibt eine Zeichenfolge mit Informationen zum Variant-Untertyp einer Variablen zurück.
UBound-Funktion | Gibt den größten verfügbaren Index für die angegebene Dimension eines Datenfeldes zurück.
UCase-Funktion | Gibt eine Zeichenfolge zurück, die in Großbuchstaben umgewandelt wurde.
VarType-Funktion | Gibt einen Wert zurück, der den Untertyp einer Variablen angibt.
Weekday-Funktion | Gibt den Wochentag als ganze Zahl zurück.
WeekdayName-Funktion | Gibt eine Zeichenfolge mit dem angegebenen Wochentag zurück.
Year-Funktion | Gibt das Jahr als ganze Zahl zurück.
Sprachelement | Beschreibung
Clear-Methode | Löscht die Einstellungen aller Eigenschaften des Err-Objekts.
Execute-Methode | Führt eine Suche mit regulärem Ausdruck auf einer angegebenen Zeichenfolge aus.
Raise-Methode | Löst einen Laufzeitfehler aus.
Replace-Methode | Ersetzt den bei einer Suche mit regulärem Ausdruck gefundenen Text.
Test-Methode | Führt eine Suche mit regulärem Ausdruck auf einer angegebenen Zeichenfolge aus.
Sprachelement | Beschreibung
Class-Objekt | Bietet Zugriff auf die Ereignisse einer erstellten Klasse.
Dictionary-Objekt | Ein Objekt, das Element/Schlüssel-Paare speichert.
Err-Objekt | Enthält Informationen zu Laufzeitfehlern.
FileSystemObject-Objekt | Ermöglicht den Zugriff auf das Dateisystem des Computers.
Match-Objekt | Bietet Zugriff auf die schreibgeschützten Eigenschaften einer Suche mit regulärem Ausdruck.
Matches-Auflistung | Auflistung von Match-Objekten aus Suche mit regulärem Ausdruck.
RegExp-Objekt | Bietet Unterstützung einfacher regulärer Ausdrücke.
Sprachelement | Beschreibung
Additionsoperator (+) | Addiert zwei Zahlen miteinander.
And-Operator | Führt eine logische Konjunktion zweier Ausdrücke durch.
Divisionsoperator (/) | Dividiert zwei Zahlen und gibt ein Fließkommaergebnis zurück.
Eqv-Operator | Führt eine logische Äquivalenz auf zwei Ausdrücken aus.
Exponentialoperator (^) | Erhebt eine Zahl zur Potenz eines Exponenten.
Ganzzahl-Divisionsoperator (\) | Dividiert zwei Zahlen miteinander und gibt das Ergebnis als Ganzzahl zurück.
Imp-Operator | Führt eine logische Implikation auf zwei Ausdrücken durch.
Is-Operator | Vergleicht zwei Objektverweisvariablen miteinander.
Mod-Operator | Dividiert zwei Zahlen und gibt nur den Rest zurück.
Multiplikationsoperator (*) | Multipliziert zwei Zahlen miteinander.
Negationsoperator (-) | Gibt den negativen Wert eines numerischen Ausdruckes an.
Not-Operator | Führt eine logische Negation auf einem Ausdruck durch.
Operatorvorrang | Auflistung mit Informationen zum Vorrang der verschiedenen in VBScript verwendeten Operatoren.
Or-Operator | Führt eine logische Disjunktion auf zwei Ausdrücken durch.
Subtraktionsoperator (-) | Ermittelt die Differenz zwischen zwei Zahlen.
Verkettungsoperator (&) | Erzwingt eine Zeichenfolgenverkettung zweier Ausdrücke.
Xor-Operator | Führt einen logischen Ausschluss auf zwei Ausdrücken durch.
Zuweisungsoperator (=) | Weist einer Variablen oder einer Eigenschaft einen Wert zu.
Sprachelement | Beschreibung
Description-Eigenschaft | Gibt eine beschreibende Zeichenfolge zu einem Fehler zurück oder legt sie fest.
FirstIndex-Eigenschaft | Gibt die Position in einer Suchzeichenfolge zurück, an der eine Entsprechung gefunden wurde.
Global-Eigenschaft | Legt einen booleschen Wert fest oder gibt diesen zurück.
HelpContext-Eigenschaft | Gibt die Kontext-ID eines Themas in einer Hilfedatei zurück oder legt eine Kontext-ID fest.
HelpFile-Eigenschaft | Legt einen vollständigen Pfad zu einer Hilfedatei fest oder gibt diesen zurück.
IgnoreCase-Eigenschaft | Legt einen booleschen Wert fest, der anzeigt, ob bei einer Mustersuche die Groß-/Kleinschreibung relevant ist, oder gibt diesen zurück.
Length-Eigenschaft | Gibt die Länge einer Entsprechung in einer Suchzeichenfolge zurück.
Number-Eigenschaft | Gibt einen numerischen Wert zurück oder legt einen numerischen Wert fest, der einen Fehler angibt.
Pattern-Eigenschaft | Legt das Suchmuster eines regulären Ausdruckes fest oder gibt dieses zurück.
Source-Eigenschaft | Gibt den Namen des Objekts oder der Anwendung zurück, das/die ursprünglich den Fehler ausgelöst hat, oder legt den Namen fest.
Value-Eigenschaft | Gibt den Wert oder Text einer Entsprechung zurück, der in einer Suchzeichenfolge gefunden wurde.
Sprachelement | Beschreibung
Call-Anweisung | Überträgt die Steuerung auf eine Sub- oder Function-Prozedur.
Class-Anweisung | Deklariert den Namen einer Klasse.
Const-Anweisung | Deklariert Konstanten für die Verwendung anstelle von Literalwerten.
Dim-Anweisung | Deklariert Variablen und reserviert Speicherplatz für sie.
Do...Loop-Anweisung | Wiederholt einen Block mit Anweisungen, solange eine Bedingung True ist oder bis eine Bedingung True wird.
Erase-Anweisung | Initialisiert die Elemente in Datenfeldern mit fester Größe neu und gibt den von einem dynamischen Datenfeld belegten Speicherplatz frei.
Execute-Anweisung | Führt eine oder mehrere angegebene Anweisungen aus.
ExecuteGlobal-Anweisung | Führt eine oder mehrere angegebene Anweisungen im globalen Namensraum eines Skriptes aus.
Exit-Anweisung | Beendet die Ausführung eines durch Do...Loop, For...Next, Function oder Sub definierten Codeblockes.
For Each...Next-Anweisung | Wiederholt eine Reihe von Anweisungen für alle Elemente eines Datenfeldes oder einer Auflistung.
For...Next-Anweisung | Wiederholt eine Reihe von Anweisungen, bis ein Schleifenzähler einen bestimmten Wert erreicht.
Function-Anweisung | Deklariert Namen, Argumente und Code für den Rumpf einer Function-Prozedur.
If...Then...Else-Anweisung | Wertet einen Ausdruck aus und führt in Abhängigkeit vom Ergebnis eine Reihe von Anweisungen aus.
On Error-Anweisung | Aktiviert eine Fehlerbehandlungsroutine.
Option Explicit-Anweisung | Erzwingt die explizite Deklaration aller Variablen in einem Skript.
Private-Anweisung | Deklariert private Variablen und reserviert Speicherplatz.
Property Get-Anweisung | Deklariert Namen, Argumente sowie Code, die den Rumpf einer Property-Prozedur darstellen, die den Wert einer Eigenschaft liest (bzw. zurück gibt).
Property Let-Anweisung | Deklariert Namen, Argumente sowie Code, die den Rumpf einer Property-Prozedur darstellen, die den Wert einer Eigenschaft zuweist.
Property Set-Anweisung | Deklariert Namen, Argumente sowie Code, die den Rumpf einer Property-Prozedur darstellen, die einen Objektverweis festlegt.
Public-Anweisung | Deklariert allgemeine Variablen und reserviert Speicherplatz für sie.
Randomize-Anweisung | Initialisiert den Zufallszahlengenerator.
ReDim-Anweisung | Deklariert dynamische Datenfeldvariablen und reserviert auf Prozedurebene Speicherplatz (neu) bzw. gibt diesen frei.
Rem-Anweisung | Markiert erläuternde Kommentare in einem Programm.
Select Case-Anweisung | Führt abhängig vom Wert eines Ausdruckes eine von mehreren Anweisungsgruppen aus.
Set-Anweisung | Weist einer Variablen oder Eigenschaft einen Objektverweis zu.
Sub-Anweisung | Deklariert Namen, Argumente und Code für den Rumpf einer Sub-Prozedur.
While...Wend-Anweisung | Führt eine Reihe von Anweisungen aus, solange eine gegebene Bedingung True ist.
With-Anweisung | Führt eine Reihe von Anweisungen auf einem einzelnen Objekt aus.

© 1999 Microsoft Corporation. Alle Rechte vorbehalten.


Informationen über Funktionsmerkmale

Informationen über Funktionsmerkmale 		Sprachverzeichnis
Versionsinformationen

Merkmale der Microsoft Scripting-Laufzeitbibliothek
Nicht in VBScript enthaltene Visual Basic für Applikationen-Funktionen
VBScript-Funktionen
VBScript-Funktionen, die nicht in Visual Basic für Applikationen verfügbar sind


Alphabetische Schlüsselwortliste

Alphabetische Schlüsselwortliste 		Sprachverzeichnis
Versionsinformationen

Abs-Funktion
Additionsoperator (+)
And-Operator
Array-Funktion
Asc-Funktion
Atn-Funktion
Call-Anweisung
CBool-Funktion
CByte-Funktion
CCur-Funktion
CDate-Funktion
CDbl-Funktion
Chr-Funktion
CInt-Funktion
Class-Objekt
Class-Anweisung
Clear-Methode
CLng-Funktion
Const-Anweisung
Cos-Funktion
CreateObject-Funktion
CSng-Funktion
CStr-Funktion
Date-Funktion
DateAdd-Funktion
DateDiff-Funktion
DatePart-Funktion
DateSerial-Funktion
DateValue-Funktion
Datums- und Uhrzeitkonstanten
Datumsformat-Konstanten
Day-Funktion
Description-Eigenschaft
Dictionary-Objekt
Dim-Anweisung
Divisionsoperator (/)
Do...Loop-Anweisung
Empty
Eqv-Operator
Erase-Anweisung
Err-Objekt
Eval-Funktion
Execute-Anweisung
Execute-Methode
Exit-Anweisung
Exp-Funktion
Exponentialoperator (^)
False
Farbkonstanten
FileSystemObject-Objekt
Filter-Funktion
FirstIndex-Eigenschaft
Fix-Funktion
For Each...Next-Anweisung
For...Next-Anweisung
FormatCurrency-Funktion
FormatDateTime-Funktion
FormatNumber-Funktion
FormatPercent-Funktion
Function-Anweisung
Ganzzahl-Divisionsoperator (\)
GetObject-Funktion
GetRef-Funktion
Global-Eigenschaft
HelpContext-Eigenschaft
HelpFile-Eigenschaft
Hex-Funktion
Hour-Funktion
If...Then...Else-Anweisung
IgnoreCase-Eigenschaft
Imp-Operator
Initialize-Ereignis
InputBox-Funktion
InStr-Funktion
InStrRev-Funktion
Int-Funktion
Is-Operator
IsArray-Funktion
IsDate-Funktion
IsEmpty-Funktion
IsNull-Funktion
IsNumeric-Funktion
IsObject-Funktion
Join-Funktion
LBound-Funktion
LCase-Funktion
Left-Funktion
Len-Funktion
Length-Eigenschaft
LoadPicture-Funktion
Log-Funktion
LTrim-Funktion
Match-Objekt
Matches-Auflistung
Mid-Funktion
Minute-Funktion
Mod-Operator
Month-Funktion
MonthName-Funktion
MsgBox-Funktion
MsgBox-Konstanten
Multiplikationsoperator (*)
Negationsoperator (-)
Not-Operator
Nothing
Now-Funktion
Null
Number-Eigenschaft
Oct-Funktion
On Error-Anweisung
Operatorvorrang
Option Explicit-Anweisung
Or-Operator
Pattern-Eigenschaft
Private-Anweisung
Property Get-Anweisung
Property Let-Anweisung
Property Set-Anweisung
Public-Anweisung
Raise-Methode
Randomize-Anweisung
ReDim-Anweisung
RegExp-Objekt
Rem-Anweisung
Replace-Funktion
Replace-Methode
RGB-Funktion
Right-Funktion
Rnd-Funktion
Round-Funktion
RTrim-Funktion
ScriptEngine-Funktion
ScriptEngineBuildVersion-Funktion
ScriptEngineMajorVersion-Funktion
ScriptEngineMinorVersion-Funktion
Second-Funktion
Select Case-Anweisung
Set-Anweisung
Sgn-Funktion
Sin-Funktion
Source-Eigenschaft
Space-Funktion
Split-Funktion
Sqr-Funktion
StrComp-Funktion
String-Funktion
StrReverse-Funktion
Sub-Anweisung
Subtraktionsoperator (-)
Tan-Funktion
Terminate-Ereignis
Test-Methode
Time-Funktion
Timer-Funktion
TimeSerial-Funktion
TimeValue-Funktion
Trim-Funktion
Tristate-Konstanten
True
TypeName-Funktion
UBound-Funktion
UCase-Funktion
Value-Eigenschaft
VarType-Funktion
VarType-Konstanten
VBScript-Konstanten
Vergleichskonstanten
Verkettungsoperator (&)
Verschiedene Konstanten
Weekday-Funktion
WeekdayName-Funktion
While...Wend-Anweisung
With-Anweisung
Xor-Operator
Year-Funktion
Zeichenfolgenkonstanten
Zuweisungsoperator (=)


Anweisungen

Anweisungen 		Sprachverzeichnis
Versionsinformationen

Call-Anweisung
Class-Anweisung
Const-Anweisung
Dim-Anweisung
Do...Loop-Anweisung
Erase-Anweisung
Execute-Anweisung
Exit-Anweisung
For...Next-Anweisung
For Each...Next-Anweisung
Function-Anweisung
If...Then...Else-Anweisung
On Error-Anweisung
Option Explicit-Anweisung
Private-Anweisung
Property Get-Anweisung
Property Let-Anweisung
Property Set-Anweisung
Public-Anweisung
Randomize-Anweisung
ReDim-Anweisung
Rem-Anweisung
Select Case-Anweisung
Set-Anweisung
Sub-Anweisung
While...Wend-Anweisung
With-Anweisung


Eigenschaften

Eigenschaften 		Sprachverzeichnis
Versionsinformationen

Description-Eigenschaft
FirstIndex-Eigenschaft
Global-Eigenschaft
HelpContext-Eigenschaft
HelpFile-Eigenschaft
IgnoreCase-Eigenschaft
Length-Eigenschaft
Number-Eigenschaft
Pattern-Eigenschaft
Source-Eigenschaft
Value-Eigenschaft


Ereignisse

Ereignisse 		Sprachverzeichnis
Versionsinformationen

Initialize-Ereignis
Terminate-Ereignis


Fehler

Fehler 		Sprachverzeichnis
Versionsinformationen

Laufzeitfehler
Syntaxfehler


Funktionen

Funktionen 		Sprachverzeichnis
Versionsinformationen

Abs-Funktion
Array-Funktion
Asc-Funktion
Atn-Funktion
CBool-Funktion
CByte-Funktion
CCur-Funktion
CDate-Funktion
CDbl-Funktion
Chr-Funktion
CInt-Funktion
CLng-Funktion
Cos-Funktion
CreateObject-Funktion
CSng-Funktion
CStr-Funktion
Date-Funktion
DateAdd-Funktion
DateDiff-Funktion
DatePart-Funktion
DateSerial-Funktion
DateValue-Funktion
Day-Funktion
Eval-Funktion
Exp-Funktion
Filter-Funktion
Fix-Funktion
FormatCurrency-Funktion
FormatDateTime-Funktion
FormatNumber-Funktion
FormatPercent-Funktion
GetObject-Funktion
GetRef-Funktion
Hex-Funktion
Hour-Funktion
InputBox-Funktion
InStr-Funktion
InStrRev-Funktion
Int-Funktion
IsArray-Funktion
IsDate-Funktion
IsEmpty-Funktion
IsNull-Funktion
IsNumeric-Funktion
IsObject-Funktion
Join-Funktion
LBound-Funktion
LCase-Funktion
Left-Funktion
Len-Funktion
LoadPicture-Funktion
Log-Funktion
LTrim-Funktion
Mid-Funktion
Minute-Funktion
Month-Funktion
MonthName-Funktion
MsgBox-Funktion
Now-Funktion
Oct-Funktion
Replace-Funktion
RGB-Funktion
Right-Funktion
Rnd-Funktion
Round-Funktion
RTrim-Funktion
ScriptEngine-Funktion
ScriptEngineBuildVersion-Funktion
ScriptEngineMajorVersion-Funktion
ScriptEngineMinorVersion-Funktion
Second-Funktion
Sgn-Funktion
Sin-Funktion
Space-Funktion
Split-Funktion
Sqr-Funktion
StrComp-Funktion
String-Funktion
StrReverse-Funktion
Tan-Funktion
Time-Funktion
Timer-Funktion
TimeSerial-Funktion
TimeValue-Funktion
Trim-Funktion
TypeName-Funktion
UBound-Funktion
UCase-Funktion
VarType-Funktion
Weekday-Funktion
WeekdayName-Funktion
Year-Funktion


Konstanten

Konstanten 		Sprachverzeichnis
Versionsinformationen

Datums- und Uhrzeitkonstanten
Datumsformat-Konstanten
Farbkonstanten
MsgBox-Konstanten
Tristate-Konstanten
VarType-Konstanten
VBScript-Konstanten
Vergleichskonstanten
Verschiedene Konstanten
Zeichenfolgenkonstanten


Methoden

Methoden 		Sprachverzeichnis
Versionsinformationen

Clear-Methode
Execute-Methode
Raise-Methode
Replace-Methode
Test-Methode


Objekte

Objekte 		Sprachverzeichnis
Versionsinformationen

Class-Objekt
Dictionary-Objekt
Err-Objekt
FileSystemObject-Objekt
Match-Objekt
Matches-Auflistung
RegExp-Objekt


Operatoren

Operatoren 		Sprachverzeichnis
Versionsinformationen

Additionsoperator (+)
And-Operator
Divisionsoperator (/)
Eqv-Operator
Exponentialoperator (^)
Ganzzahl-Divisionsoperator (\)
Imp-Operator
Is-Operator
Mod-Operator
Multiplikationsoperator (*)
Negationsoperator (-)
Not-Operator
Operatorvorrang
Or-Operator
Subtraktionsoperator (-)
Verkettungsoperator (&)
Xor-Operator
Zuweisungsoperator (=)


VBScript-Tutorium

VBScript-Tutorium 		Sprachverzeichnis

Was ist VBScript?
Hinzufügen von VBScript-Code zu einer HTML-Seite

VBScript-Grundlagen

VBScript-Datentypen
VBScript-Variablen
VBScript-Konstanten
VBScript-Operatoren
Verwenden von Bedingungsanweisungen
Durchlaufen von Codeschleifen
VBScript-Prozeduren
VBScript-Codekonventionen

Verwenden von VBScript im Internet Explorer

Eine einfache VBScript-Seite
VBScript und Formulare
Verwenden von VBScript mit Objekten


Was ist VBScript?

Was ist VBScript? 		VBScript-Tutorium
Weiter

Microsoft Visual Basic Scripting Edition, das jüngste Mitglied der Visual Basic-Programmiersprachen, ermöglicht das Erstellen aktiver Skripten für eine Vielzahl von Umgebungen, einschließlich Webclientscripting in Microsoft Internet Explorer und Webserverscripting in Microsoft Internet Information Server.
Leicht zu lernen und anzuwenden
Wenn Sie Visual Basic oder Visual Basic für Applikationen bereits kennen, wird Ihnen VBScript bekannt vorkommen. Und wenn Sie Visual Basic nicht kennen und sich darin einarbeiten, erlernen Sie gleichzeitig alle Visual Basic-Programmiersprachen. Obwohl Sie VBScript mithilfe dieser wenigen Webseiten kennen lernen können, erlernen Sie hier nicht die Technik des Programmierens. Eine gute Einführung in das Programmieren erhalten Sie in den von Microsoft Press verfügbaren Step-by-Step-Büchern.
ActiveX-Scripting
VBScript verwendet ActiveX®-Scripting zur Kommunikation mit Hostanwendungen. ActiveX-Scripting erspart Browsern und anderen Hostanwendungen die Implementierung von speziellem Integrationscode für jede Scriptingkomponente. ActiveX-Scripting ermöglicht einem Host die Kompilierung von Skripten, das Anfordern und den Aufruf von Einsprungpunkten und die Verwaltung des Namensraumes, der dem Entwickler zur Verfügung steht. Mit ActiveX-Scripting können Compilerhersteller Standardlaufzeitmodule der jeweiligen Sprache für Skripten erstellen. Microsoft wird Laufzeitunterstützung für VBScript anbieten. Microsoft arbeitet mit verschiedenen Internetgruppen an der Definition des ActiveX-Scripting-Standards, um die Austauschbarkeit von Scriptingmodulen zu definieren. ActiveX-Scripting wird im Microsoft® Internet Explorer und im Microsoft® Internet Information Server verwendet.
VBScript in anderen Anwendungen und Browsern
Als Programmentwickler ist es Ihnen gestattet, die VBScript-Quellen kostenlos in Ihren Produkten zu verwenden und weiterzugeben. Von Microsoft sind für die 32-Bit Windows® API, die 16-Bit-Windows API und den Macintosh® binäre Implementationen von VBScript erhältlich. VBScript ist Bestandteil von Word-Wide-Web-Browsern. VBScript und ActiveX-Scripting kann auch in anderen Anwendungen als allgemeine Scripting-Programmiersprache verwendet werden.


Hinzufügen von VBScript-Code zu einer HTML-Seite

Hinzufügen von VBScript-Code zu einer HTML-Seite 		VBScript-Tutorium
Zurück
Weiter

Sie können das SCRIPT-Element verwenden, um einer HTML-Seite VBScript-Code hinzuzufügen.
Das <SCRIPT>-Tag
VBScript-Code wird in einer HTML-Seite zwischen paarweisen <SCRIPT>-Tags abgelegt. Eine Prozedur zur Überprüfung eines Lieferdatums könnte beispielsweise folgendermaßen aussehen:

<SCRIPT LANGUAGE="VBScript">
<!--
   Function KannLiefern(Dt)
      KannLiefern = (CDate(Dt) - Now()) > 2
   End Function
-->
</SCRIPT>
Der Code ist zwischen Anfangs- und Ende-<SCRIPT>-Tags eingeschlossen. Sie können sehen, dass das LANGUAGE-Attribut die Skriptsprache angibt. Sie müssen die Sprache angeben, weil Browser auch andere Skriptsprachen verwenden können. Sie können außerdem sehen, dass die Funktion KannLiefern zwischen Kommentar-Tags (<!-- und -->) eingeschlossen ist. Damit wird verhindert, dass Browser, die das <SCRIPT>-Tags nicht verarbeiten können, den Code anzeigen.

Weil die Beispielfunktion eine allgemeine Funktion darstellt - sie ist nicht an eine bestimmte Art von Formular gebunden - können Sie diese in den HEAD-Abschnitt der Seite aufnehmen:

<HTML>
<HEAD>
<TITLE>Geben Sie Ihre Bestellung auf</TITLE>
<SCRIPT LANGUAGE="VBScript">
<!--
   Function KannLiefern(Dt)
      KannLiefern = (CDate(Dt) - Now()) > 2
   End Function
-->
</SCRIPT>
</HEAD>
<BODY>
...
Sie können SCRIPT-Blöcke überall auf einer HTML-Seite verwenden. Sie können sie sowohl im BODY-Abschnitt als auch im HEAD-Abschnitt unterbringen. Es ist jedoch sinnvoll, sämtlichen allgemeinen Scripting-Code im HEAD-Abschnitt unterzubringen, um den gesamten Code beisammen zu halten. Wenn Sie Ihren Code im HEAD-Abschnitt unterbringen, wird sichergestellt, dass der gesamte Code gelesen und dekodiert wird, bevor er von einem Aufruf im BODY-Abschnitt benötigt wird.

Eine wichtige Ausnahme von dieser Regel ist, wenn Sie in Formularen Scripting-Code einfügen, um auf Ereignisse von Objekten in Ihrem Formular zu reagieren. Sie können zum Beispiel Scripting-Code einbetten, um auf Klicken auf eine Schaltfläche zu reagieren:

<HTML>
<HEAD>
<TITLE>Schaltflächen-Ereignisse testen</TITLE>
</HEAD>
<BODY>
<FORM NAME="Formular1">
   <INPUT TYPE="Button" NAME="Schaltflaeche1" VALUE="Klicken">
   <SCRIPT FOR="Schaltflaeche1" EVENT="onClick" LANGUAGE="VBScript">
      MsgBox "Schaltfläche geklickt!"
   </SCRIPT>
</FORM>
</BODY>
</HTML>
Der von Ihnen geschriebene Code steht meist entweder in Sub- oder in Function-Prozeduren und wird nur bei Aufruf durch von Ihnen geschriebenem Code ausgeführt. VBScript-Code kann innerhalb eines SCRIPT-Blockes aber auch außerhalb von Prozeduren stehen. Ein solcher Code wird nur einmalig beim Laden der HTML-Seite ausgeführt. Auf diese Weise können beim Laden der Webseite Daten initialisiert und das Erscheinungsbild der Seite dynamisch verändert werden.


VBScript-Datentypen

VBScript-Datentypen 		VBScript-Tutorium
Zurück
Weiter

Welche VBScript-Datentypen gibt es?
VBScript kennt nur einen Datentyp namens Variant. Ein Variant ist eine besondere Art von Datentyp, der je nach Verwendung verschiedene Arten von Informationen aufnehmen kann. Weil Variant der einzige Datentyp in VBScript ist, geben alle Funktionen in VBScript diesen Datentyp zurück.

Im einfachsten Fall kann Variant numerische Werte oder Zeichenfolgen enthalten. Ein Variant verhält sich wie eine Zahl, wenn Sie ihn in einem numerischen Zusammenhang verwenden, und wie eine Zeichenfolge, wenn Sie ihn wie eine Zeichenfolge verwenden. Wenn Sie also mit Daten arbeiten, die wie Zahlen "aussehen", interpretiert VBScript diese als Zahlen und verfährt entsprechend. Wenn Sie mit Daten arbeiten, die nur als Zeichenfolgen interpretiert werden können, behandelt VBScript diese als Zeichenfolgen. Natürlich können Sie immer dafür sorgen, dass sich Zahlen wie Zeichenfolgen verhalten, indem Sie diese in Anführungszeichen (" ") einschließen.

Untertypen des Datentypes "Variant"
Über die einfache Einteilung in numerische Werte und Zeichenfolgen hinaus kann bei Variant-Werten zwischen weiteren Arten von numerischen Informationen unterschieden werden. Numerische Informationen können beispielsweise ein Datum oder eine Uhrzeit darstellen. In Verbindung mit anderen Datums- oder Uhrzeitinformationen wird das Ergebnis immer als Datum oder Uhrzeit ausgedrückt. Natürlich stehen auch viele verschiedene Arten numerischer Informationen zur Verfügung, angefangen von booleschen Werten bis hin zu großen Fließkommazahlen. Diese unterschiedlichen Informationskategorien, die ein Variant aufnehmen kann, werden als Untertypen bezeichnet. Meistens genügt es, einem Variant einfach die gewünschten Daten zuzuweisen, damit er sich entsprechend verhält.

Die folgende Tabelle zeigt die verschiedenen Untertypen von Daten, die ein Variant enthalten kann.

Untertyp | Beschreibung
Empty | Variant ist nicht initialisiert. Der Wert ist 0 bei numerischen Variablen und eine Nullzeichenfolge ("") bei Zeichenfolgenvariablen.
Null | Variant enthält absichtlich keine gültigen Daten.
Boolean | Enthält entweder True oder False.
Byte | Enthält eine Ganzzahl von 0 bis 255.
Integer | Enthält eine Ganzzahl von -32.768 bis 32.767.
Currency | -922.337.203.685.477,5808 bis 922.337.203.685.477,5807.
Long | Enthält eine Ganzzahl von -2.147.483.648 bis 2.147.483.647.
Single | Enthält eine Fließkommazahl einfacher Genauigkeit von -3,402823E38 bis -1,401298E-45 für negative Werte und von 1,401298E-45 bis 3,402823E38 für positive Werte.
Double | Enthält eine Fließkommazahl doppelter Genauigkeit von -1,79769313486232E308 bis -4,94065645841247E-324 für negative Werte und von 4,94065645841247E-324 bis 1.79769313486232E308 für positive Werte.
Date (Time) | Enthält eine Zahl, die ein Datum vom 1. Januar 100 bis zum 31. Dezember 9999 darstellt.
String | Enthält eine Zeichenfolge variabler Länge, die bis zu etwa 2 Milliarden Zeichen lang sein kann.
Object | Enthält ein Objekt.
Error | Enthält eine Fehlernummer.

Daten können mithilfe von Konvertierungsfunktionen von einem Untertyp in den anderen konvertiert werden. Zusätzlich gibt die Funktion VarType Informationen über die Art und Weise der Speicherung von Daten in einem Variant zurück.


VBScript-Variablen

VBScript-Variablen 		VBScript-Tutorium
Zurück
Weiter

Was ist eine Variable?
Eine Variable ist ein praktischer Platzhalter, der auf eine Stelle im Speicher des Computers verweist, an der Sie Programmdaten, die sich während der Ausführung des Skriptes möglicherweise ändern, speichern können. Sie können beispielsweise eine Variable namens KlickZaehler einrichten, um zu speichern, wie oft ein Benutzer auf ein Objekt auf einer bestimmten Webseite klickt. Es ist unwichtig, wo sich die Variable im Computerspeicher befindet. Wichtig ist, dass Sie nur ihren Namen angeben müssen, um den Wert der Variablen abzurufen oder zu ändern. In VBScript haben Variablen immer den grundlegenden Datentyp Variant.
Deklarieren von Variablen
Sie deklarieren Variablen in Ihrem Skript explizit mit den Anweisungen Dim, Public und Private. Beispiel:
 Dim GradCelsius
Sie deklarieren mehrere Variablen, indem Sie diese durch Kommas voneinander trennen. Beispiel:
 Dim Oben, Unten, Links, Rechts
Sie können eine Variable auch implizit deklarieren, indem Sie einfach ihren Namen an einer beliebigen Stelle in Ihrem Skript verwenden. Dies gilt allgemein als schlechter Programmierstil, weil Sie den Variablennamen an der einen oder anderen Stelle falsch eingeben könnten, was bei der Ausführung des Skriptes zu unerwarteten Ergebnissen führt. Aus diesem Grund gibt es die Option Explicit-Anweisung, mit der Sie die explizite Deklaration aller Variablen erzwingen können. Die Option Explicit-Anweisung sollte die erste Anweisung innerhalb Ihres Skriptes sein.
Einschränkungen für Namen
Für Variablennamen gelten die Standardregeln zum Benennen von Sprachelementen in VBScript. Für Variablennamen gilt:
  • Sie müssen mit einem Zeichen des Alphabets beginnen.
  • Sie dürfen keinen Punkt enthalten.
  • Sie dürfen nicht länger als 255 Zeichen sein.
  • Sie müssen innerhalb des Gültigkeitsbereichs, für den sie deklariert werden, eindeutig sein.
Gültigkeitsbereich und Lebensdauer von Variablen
Der Gültigkeitsbereich einer Variablen hängt davon ab, wo sie deklariert wurde. Wenn Sie eine Variable in einer Prozedur deklarieren, kann normalerweise nur Code innerhalb dieser Prozedur auf den Variablenwert zugreifen oder ihn ändern. Sie hat somit einen lokalen Gültigkeitsbereich und wird als Variable auf Prozedurebene bezeichnet. Wenn Sie eine Variable außerhalb einer Prozedur deklarieren, ist sie für alle Prozeduren in Ihrem Skript sichtbar. Es handelt sich somit um eine Variable auf Skriptebene mit der Skriptebene als Gültigkeitsbereich.

Die Zeitspanne, in der eine Variable existiert, wird als ihre Lebensdauer bezeichnet. Die Lebensdauer einer Variablen auf Skriptebene reicht vom Zeitpunkt der Deklaration bis zur Beendigung des Skriptes. Eine Variable auf Prozedurebene existiert nur solange, wie die Prozedur aktiv ist. Bei Verlassen der Prozedur wird die Variable "vernichtet". Lokale Variablen eignen sich gut als temporärer Speicherplatz während der Ausführung einer Prozedur. Sie können lokale Variablen mit demselben Namen in mehreren Prozeduren verwenden, da jede nur von der Prozedur erkannt wird, in der sie deklariert wurde.

Zuweisen von Werten zu Variablen
Variablen werden Werte zugewiesen, indem ein Ausdruck in folgender Form erstellt wird: Die Variable steht auf der linken Seite des Ausdruckes, und der Wert, welcher der Variablen zugewiesen werden soll, steht auf der rechten Seite. Beispiel:
 B = 200
Skalare Variablen und Datenfeldvariablen
Meistens weisen Sie einer deklarierten Variablen nur einen einzelnen Wert zu. Solche Variablen werden skalare Variablen genannt. In anderen Fällen ist es sinnvoll, einer Variablen mehrere zusammenhängende Werte zuzuweisen. In diesen Fällen können Sie eine Variable erstellen, die eine Folge von Werten enthalten kann. Solche Variablen werden Datenfeldvariablen genannt. Datenfeldvariablen werden fast genauso deklariert wie skalare Variablen. Der einzige Unterschied besteht darin, dass bei der Deklaration von Datenfeldvariablen auf den Namen Klammern folgen. Im folgenden Beispiel wird ein eindimensionales Datenfeld mit 11 Elementen deklariert:
 Dim A(10)
Obwohl in Klammern die Zahl 10 angegeben wird, enthält dieses Datenfeld 11 Elemente, weil alle Datenfelder in VBScript nullbasiert sind, d. h. mit dem Index Null beginnen. In einem nullbasierten Datenfeld ist die Anzahl der Elemente immer um Eins höher als der in Klammern angegebene Wert. Diese Art von Datenfeld nennt man Datenfeld fester Größe.

Zur Zuweisung von Daten an die Elemente des Datenfeldes verwenden Sie einen Index im Datenfeld. Mit Indizes von Null bis 10 können den Elementen eines Datenfeldes auf folgende Weise Werte zugewiesen werden:

 A(0) = 256
 A(1) = 324
 A(2) = 100
 . . .
 A(10) = 55
Auf ähnliche Weise (mit einem Index im Datenfeld) kann der Wert eines beliebigen Datenfeldelements wieder abgerufen werden. Beispiel:
 . . .
 EineVariable = A(8)
 . . .
Datenfelder sind nicht auf eine einzige Dimension beschränkt. Sie können bis zu 60 Dimensionen angeben, obwohl sich die meisten Menschen nur drei oder vier Dimensionen vorstellen können. Mehrere Dimensionen werden durch Angabe von mehreren Datenfeldgrößen zwischen den Klammern deklariert und jeweils durch ein Komma voneinander getrennt. Im folgenden Beispiel ist die Variable MeineTabelle ein zweidimensionales Datenfeld mit 6 Zeilen und 11 Spalten:
Dim MeineTabelle(5, 10)
In einem zweidimensionalen Datenfeld gibt die erste Zahl immer die Anzahl der Zeilen und die zweite Zahl die Anzahl der Spalten an.

Sie können auch Datenfelder deklarieren, deren Größe sich während des Ablaufs Ihres Skriptes ändern kann. Solche Datenfelder werden als dynamische Datenfelder bezeichnet. Das Datenfeld wird in einer Prozedur anfänglich mit einer Dim-Anweisung (wie jedes andere Datenfeld auch) oder mit einer ReDim-Anweisung deklariert. Der Unterschied besteht darin, dass zwischen den Klammern keine Größe oder Anzahl von Dimensionen angegeben wird. Beispiel:

 Dim MeinDatenfeld()
 ReDim EinAnderesDatenfeld()
Um ein dynamisches Datenfeld verwenden zu können, müssen Sie anschließend die Zahl der Dimensionen und deren Größen mit ReDim bestimmen. Im folgenden Beispiel wird die anfängliche Größe des dynamischen Datenfeldes mit ReDim auf 25 fest gelegt. Eine darauf folgende ReDim-Anweisung ändert die Größe des Datenfeldes auf 30. Mithilfe des Schlüsselwortes Preserve wird der Inhalt des Datenfeldes vor der Größenänderung gesichert.
 ReDim MeinDatenfeld(25)
 . . .
 ReDim Preserve MeinDatenfeld(30)
Die Größe eines dynamischen Datenfeldes kann beliebig oft geändert werden. Beachten Sie jedoch, dass bei einer Verkleinerung des Datenfeldes die Daten in den eliminierten Elementen verloren gehen.


VBScript-Konstanten

VBScript-Konstanten 		VBScript-Tutorium
Zurück
Weiter

Was ist eine Konstante?
Eine Konstante ist ein aussagekräftiger Name, der anstelle einer Zahl oder einer Zeichenfolge verwendet wird, und dessen Wert sich nie ändert. VBScript legt eine Anzahl integrierter Konstanten fest. Weitere Informationen zu diesen integrierten Konstanten finden Sie im VBScript-Sprachverzeichnis.
Erstellen von Konstanten
In VBScript können Sie benutzerdefinierte Konstanten mit der Const-Anweisung definieren. Die Const-Anweisung ermöglicht das Definieren von Zeichenfolgenkonstanten oder numerischen Konstanten mit aussagekräftigen Namen und das Zuweisen von Literalwerten. Beispiele:
Const MeineZf = "Dies ist eine Zeichenfolge."
Const MeinAlter = 49
Beachten Sie, dass das Zeichenfolgenliteral in Anführungszeichen (" ") eingeschlossen ist. Anführungszeichen eignen sich am besten, um Zeichenfolgenwerte von numerischen Werten zu unterscheiden. Datums-/Uhrzeitliterale werden in Nummernzeichen (#) eingeschlossen. Beispiele:
Const MeinDatum = #6-1-97#
Um Konstanten einfach von Variablen unterscheiden zu können, sollten Sie sich ein Namensschema vorgeben. Dadurch können Sie Versuche zur Neuzuweisung von Werten an Konstanten während der Ausführung des Skriptes vermeiden. So können Sie z. B. Konstantennamen mit einem Präfix "vb" oder "con" versehen. Auch das Benennen von Konstanten mit ausschließlich Großbuchstaben wäre eine Möglichkeit. Ein unterschiedliches Erscheinungsbild von Konstanten- und Variablennamen vermeidet Verwechslungen beim Entwickeln komplexer Skripte.


VBScript-Operatoren

VBScript-Operatoren 		VBScript-Tutorium
Zurück
Weiter

VBScript verfügt über eine Vielzahl von Operatoren, u. a. für arithmetische, Vergleichs-, Verkettungs- und logische Operationen.
Operatorvorrang
Treten mehrere Operationen in einem Ausdruck auf, wird jeder Teil in einer vorbestimmten Reihenfolge ausgewertet und aufgelöst. Diese wird als Operatorvorrang bezeichnet. Sie können den Operatorvorrang mit Klammern übergehen und die Auswertung von Teilen eines Ausdruckes vor anderen Teilen erzwingen. Operationen innerhalb von Klammern werden immer vor Operationen außerhalb von Klammern ausgeführt. Innerhalb der Klammern gilt jedoch der normale Operatorvorrang.

Wenn Ausdrücke Operatoren aus verschiedenen Kategorien enthalten, werden zuerst arithmetische, dann Vergleichs- und schließlich logische Operatoren ausgewertet. Vergleichsoperatoren haben alle denselben Rang, d. h. sie werden von links nach rechts in der Reihenfolge ihres Erscheinens ausgewertet. Arithmetische und logische Operatoren werden in der folgenden Reihenfolge ausgewertet.

Arithmetisch | Vergleich | Logisch
Beschreibung | Symbol | Beschreibung | Symbol | Beschreibung | Symbol
Potenzierung ^ Gleichheit = Logische Negation Not
Unäre Negation - Ungleichheit <> Logische Konjunktion And
Multiplikation * Kleiner als < Logische Disjunktion Or
Division / Größer als > Logische Exklusion Xor
Ganzzahldivision \ Kleiner oder gleich <= Logische Äquivalenz Eqv
Modulo-Arithmetik Mod Größer oder gleich >= Logische Implikation Imp
Addition + Objektäquivalenz Is
Subtraktion -
Zeichenfolgenverkettung &

Wenn in einem Ausdruck sowohl Multiplikationen als auch Divisionen ausgeführt werden, erfolgt die Berechnung in der Reihenfolge des Auftretens von links nach rechts. Desgleichen wird beim Auftreten von Addition und Subtraktion in einem Ausdruck jede Operation entsprechend ihres Auftretens von links nach rechts ausgewertet.

Der Operator für die Zeichenfolgenverkettung (&) ist zwar kein arithmetischer Operator, kommt aber in der Rangfolge nach den arithmetischen und vor den Vergleichsoperatoren. Der Operator Is ist ein Vergleichsoperator für Objektverweise. Er vergleicht weder Objekte noch deren Werte, sondern bestimmt lediglich, ob zwei Objektverweise auf dasselbe Objekt verweisen.


Verwenden von Bedingungsanweisungen

Verwenden von Bedingungsanweisungen 		VBScript-Tutorium
Zurück
Weiter

Steuern der Programmausführung
Sie können den Ablauf eines Skriptes mit Bedingungs- und Schleifenanweisungen steuern. Mithilfe von Bedingungsanweisungen können Sie VBScript-Code schreiben, mit dem Entscheidungen getroffen und Aktionen wiederholt werden können. Die folgenden Bedingungsanweisungen sind in VBScript verfügbar:
  • If...Then...Else-Anweisung
  • Select Case-Anweisung
Treffen von Entscheidungen mithilfe von If...Then...Else
Die If...Then...Else-Anweisung wird verwendet, um zu bestimmen, ob eine Bedingung True oder False ist, und um anzugeben, ob je nach Ergebnis eine oder mehrere Anweisungen ausgeführt werden. Im Allgemeinen ist die Bedingung ein Ausdruck, der einen Vergleichsoperator zum Vergleichen eines Wertes oder einer Variablen mit einem/r anderen verwendet. Informationen zu Vergleichsoperatoren finden Sie unter Vergleichsoperatoren. If...Then...Else-Anweisungen können nach Bedarf auf beliebig vielen Ebenen verschachtelt werden.

Ausführen von Anweisungen, wenn eine Bedingung True ist
Um nur eine Anweisung auszuführen, wenn eine Bedingung True ist, verwenden Sie die einzeilige Syntax für die If...Then...Else-Anweisung. Das folgende Beispiel zeigt die einzeilige Syntax. Beachten Sie, dass in diesem Beispiel das Schlüsselwort Else weggelassen wird.
 Sub DatumSetzen()
     Dim meinDatum
     meinDatum = #2/13/95#
     If meinDatum < Now Then meinDatum = Now
 End Sub
Zum Ausführen von mehr als einer Codezeile müssen Sie die mehrzeilige Syntax oder Blocksyntax verwenden. Diese Syntax enthält die End If-Anweisung ,wie im folgenden Beispiel gezeigt:
 Sub BenutzerWarnen(wert)
     If wert = 0 Then
         AlertLabel.ForeColor = vbRed
         AlertLabel.Font.Bold = True
         AlertLabel.Font.Italic = True
     End If
 End Sub
Ausführen bestimmter Anweisungen, wenn eine Bedingung True ist, und Ausführen anderer Anweisungen, wenn eine Bedingung False ist
Mit der If...Then...Else-Anweisung können Sie zwei Blöcke mit ausführbaren Anweisungen definieren: ein Block wird ausgeführt, wenn die Bedingung True ist, der andere wird ausgeführt, wenn die Bedingung False ist.
 Sub BenutzerWarnen(wert)
     If wert = 0 Then
         AlertLabel.ForeColor = vbRed
         AlertLabel.Font.Bold = True
         AlertLabel.Font.Italic = True
     Else
         AlertLabel.Forecolor = vbBlack
         AlertLabel.Font.Bold = False
         AlertLabel.Font.Italic = False
     End If
 End Sub
Entscheiden zwischen mehreren Alternativen
Mithilfe einer Variante der If...Then...Else-Anweisung können Sie aus mehreren Alternativen auswählen. Durch das Hinzufügen der ElseIf-Klausel können Sie die Funktionalität der If...Then...Else-Anweisung erweitern, so dass der Programmablauf auf mehreren Möglichkeiten basiert. Beispiele:
 Sub WertAusgeben(wert)
     If wert = 0 Then
         MsgBox wert
     ElseIf wert = 1 Then
         MsgBox wert
     ElseIf wert = 2 then
         MsgBox wert
     Else
         Msgbox "Wert außerhalb des Bereichs!"
     End If
Sie können nach Bedarf beliebig viele ElseIf-Klauseln hinzufügen, um alternative Möglichkeiten bereitzustellen. Durch eine zu häufige Verwendung der ElseIf-Klausel wird der Code allerdings umständlich. Eine bessere Möglichkeit zum Auswählen aus mehreren Alternativen bietet die Select Case-Anweisung.
Treffen von Entscheidungen mit "Select Case"
Die Select Case-Struktur bietet eine Alternative zu If...Then...ElseIf, um gezielt einen Anweisungsblock aus mehreren Anweisungsblöcken auszuführen. Eine Select Case-Anweisung bietet dieselbe Funktionalität wie die If...Then...Else-Anweisung, macht den Code jedoch effizienter und leichter lesbar.

Eine Select Case-Struktur arbeitet mit einem einzelnen Testausdruck, der einmalig, auf der obersten Ebene der Struktur, ausgewertet wird. Das Ergebnis der Struktur wird dann mit den Werten für jedes Case in der Struktur verglichen. Gibt es eine Übereinstimmung, wird der mit diesem Case verknüpfte Anweisungsblock ausgeführt:

 Select Case Document.Formular1.Kartentyp.Options(SelectedIndex).Text
    Case "MasterCard"
        MCLogoAnzeigen
        MCKontoPruefen
    Case "Visa"
        VisaLogoAnzeigen
        VisaKontoPruefen
    Case "American Express"
        AMEXCOLogoAnzeigen
        AMEXCOKontoPruefen
    Case Else
        UnbekanntBildAnzeigen
        ErneutAuffordern
End Select
Beachten Sie, dass die Select Case-Struktur einen Ausdruck einmalig am Anfang der Struktur auswertet. Im Gegensatz dazu kann eine If...Then...ElseIf-Struktur für jede ElseIf-Anweisung unterschiedliche Ausdrücke auswerten. Eine If...Then...ElseIf -Struktur kann nur dann durch eine Select Case-Struktur ersetzt werden, wenn in jeder ElseIf-Anweisung derselbe Ausdruck ausgewertet wird.


Durchlaufen von Codeschleifen

Durchlaufen von Codeschleifen 		VBScript-Tutorium
Zurück
Weiter

Verwenden von Schleifen zum Wiederholen von Code
Das Durchlaufen von Schleifen ermöglicht Ihnen, eine Anweisungsgruppe wiederholt auszuführen. Einige Schleifen wiederholen Anweisungen, bis eine Bedingung falsch (False) ist, andere wiederholen Anweisungen, bis eine Bedingung wahr (True) ist. Es gibt auch Schleifen, die Anweisungen in einer bestimmten Anzahl wiederholen.

Die folgenden Schleifenanweisungen sind in VBScript verfügbar:

  • Do...Loop: Schleife durchlaufen, solange oder bis eine Bedingung True ist.
  • While...Wend: Schleife durchlaufen, solange eine Bedingung True ist.
  • For...Next: Verwendet einen Zähler, der angibt, wie häufig Anweisungen ausgeführt werden.
  • For Each...Next: Wiederholt eine Anweisungsgruppe für jedes Element in einer Auflistung oder jedes Element in einem Datenfeld.
Verwenden von Do-Schleifen
Sie können Do...Loop-Anweisungen verwenden, um einen Anweisungblock mehrmals auszuführen, ohne dass die Anzahl der Durchläufe festgelegt ist. Die Anweisungen werden entweder wiederholt, solange eine Bedingung True ist oder bis eine Bedingung True ist.
Wiederholung von Anweisungen, während eine Bedingung True ist
Verwenden Sie das Schlüsselwort While, um eine Bedingung in einer Do...Loop-Anweisung zu überprüfen. Sie können die Bedingung überprüfen, bevor die Schleife ausgeführt wird (wie im folgenden Beispiel WhileZuerst gezeigt), oder Sie können sie überprüfen, nachdem die Schleife mindestens einmal ausgeführt wurde (wie im Beispiel WhileDanach gezeigt). Wenn in der WhileZuerst-Prozedur meineZahl auf 9 anstatt auf 20 festgelegt wird, werden die Anweisungen in der Schleife niemals ausgeführt. In der WhileDanach-Prozedur werden die Anweisungen in der Schleife nur 1-mal ausgeführt, weil die Bedingung bereits False ist.
 Sub WhileZuerst()
     Dim zaehler, meineZahl
     zaehler = 0
     meineZahl = 20
     Do While meineZahl > 10
         meineZahl = meineZahl - 1
         zaehler = zaehler + 1
     Loop
     MsgBox "Die Schleife wurde " & zaehler & " mal wiederholt."
 End Sub

 Sub WhileDanach()
     Dim zaehler, meineZahl
     zaehler = 0
     meineZahl = 9
     Do
         meineZahl = meineZahl - 1
         zaehler = zaehler + 1
     Loop While meineZahl > 10
     MsgBox "Die Schleife wurde " & zaehler & " mal wiederholt."
 End Sub
Wiederholen einer Anweisung bis eine Bedingung True wird
Sie können das Schlüsselwort Until auf zwei Arten verwenden, um eine Bedingung in einer Do...Loop-Anweisung zu überprüfen. Sie können die Bedingung überprüfen, bevor die Schleife ausgeführt wird (wie im folgenden Beispiel UntilZuerst gezeigt), oder Sie können sie überprüfen, nachdem die Schleife mindestens einmal ausgeführt wurde (wie im Beispiel UntilDanach gezeigt). Solange die Bedingung False ist, wird die Schleife durchlaufen.
 Sub UntilZuerst()
     Dim zaehler, meineZahl
     zaehler = 0
     meineZahl = 20
     Do Until meineZahl = 10
         meineZahl = meineZahl - 1
         zaehler = zaehler + 1
     Loop
     MsgBox "Die Schleife wurde " & zaehler & " mal wiederholt."
 End Sub

 Sub UntilDanach()
     Dim zaehler, meineZahl
     zaehler = 0
     meineZahl = 1
     Do
         meineZahl = meineZahl + 1
         zaehler = zaehler + 1
     Loop Until meineZahl = 10
     MsgBox "Die Schleife wurde " & zaehler & " mal wiederholt."
 End Sub
Beenden einer Do...Loop-Anweisung aus der Schleife heraus
Sie können eine Do...Loop-Schleife beenden, indem Sie die Exit Do-Anweisung verwenden. Da die Schleifenausführung normalerweise nur in bestimmten Situationen beendet werden soll, z. B. um eine Endlosschleife zu vermeiden, müssen Sie die Exit Do-Anweisung im True-Anweisungsblock einer If...Then...Else-Anweisung verwenden. Wenn die Bedingung False ist, wird die Schleife normal ausgeführt.

Im folgenden Beispiel wird meineZahl ein Wert zugewiesen, der eine Endlosschleife verursacht. Die If...Then...Else-Anweisung überprüft, ob dieser Zustand eintritt, und verhindert die endlose Wiederholung.

 Sub ExitBeispiel()
     Dim zaehler, meineZahl
     zaehler = 0
     meineZahl = 9
     Do Until meineZahl = 10
         meineZahl = meineZahl - 1
         zaehler = zaehler + 1
         If meineZahl < 10 Then Exit Do
     Loop
     MsgBox "Die Schleife wurde " & zaehler & " mal wiederholt."
 End Sub
Verwenden von While...Wend
Die While...Wend-Anweisung wird in VBScript für Entwickler zur Verfügung gestellt, die mit ihrer Verwendung vertraut sind. Auf Grund der eingeschränkten Flexibilität von While...Wend wird jedoch empfohlen, stattdessen Do...Loop zu verwenden.
Verwenden von For...Next
Sie können For...Next-Anweisungen verwenden, um genau festzulegen, wie oft ein Anweisungblock ausgeführt werden soll. Für Schleifen verwenden Sie eine Zählervariable, deren Wert mit jeder Wiederholung der Schleife vergrößert oder verkleinert wird.

Beispielsweise hat die folgende Prozedur zur Folge, dass eine Prozedur mit dem Namen MeineProz 50-mal ausgeführt wird. Die For-Anweisung gibt als Zählervariable x an und legt den zugehörigen Start- und Endwert fest. Die Next-Anweisung zählt die Zählervariable jeweils um 1 hoch.

 Sub MeineProz50Mal()
     Dim x
     For x = 1 To 50
         MeineProz
     Next
 End Sub
Mit dem Schlüsselwort Step können Sie die Zählervariable um den darin angegebenen Wert vergrößern oder verkleinern. Im folgenden Beispiel wird die Zählervariable j bei jedem Schleifendurchlauf um 2 hochgezählt. Wenn die Schleife beendet ist, enthält ergebnis die Summe von 2, 4, 6, 8 und 10.
 Sub ZweierSumme()
     Dim j, ergebnis
     For j = 2 To 10 Step 2
         ergebnis = ergebnis + j
     Next
     MsgBox "Die Summe ist " & ergebnis
 End Sub
Zum Verkleinern der Zählervariable verwenden Sie einen negativen Wert für Step. Sie müssen einen Endwert angeben, der kleiner als der Startwert ist. Im folgenden Beispiel wird die Zählervariable meineZahl bei jedem Schleifendurchlauf um 2 verkleinert. Wenn die Schleife beendet ist, enthält ergebnis die Summe von 16, 14, 12, 10, 8, 6, 4 und 2.

 Sub NeueSumme()
     Dim meineZahl, ergebnis
     For meineZahl = 16 To 2 Step -2
         ergebnis = ergebnis + meineZahl
     Next
     MsgBox "Die Summe ist " & ergebnis
 End Sub
Sie können jede For...Next-Anweisung beenden, bevor der Zähler seinen Endwert erreicht, indem Sie die Exit For-Anweisung verwenden. Da die Schleifenausführung normalerweise nur in bestimmten Situationen beendet werden soll, z. B. wenn ein Fehler auftritt, müssen Sie die Exit For-Anweisung im True-Anweisungsblock einer If...Then...Else-Anweisung verwenden. Wenn die Bedingung False ist, wird die Schleife normal ausgeführt.

Verwenden von For Each...Next
Eine For Each...Next-Schleife ist einer For...Next -Schleife ähnlich. Anstatt die Anzahl der Schleifendurchläufe zum Wiederholen der Anweisungen anzugeben, wird in einer For Each...Next-Schleife eine Anweisungsgruppe für jedes Element in einer Auflistung von Objekten oder für jedes Element in einem Datenfeld ausgeführt. Dies ist besonders dann hilfreich, wenn nicht bekannt ist, wie viele Elemente in einer Gruppe enthalten sind.

Im folgenden HTML-Codebeispiel wird der Inhalt eines Dictionary-Objekts verwendet, um Text in mehrere Textfelder einzusetzen:

 <HTML>
 <HEAD><TITLE>Formulare und Elemente</TITLE></HEAD>
 <SCRIPT LANGUAGE="VBScript">
 <!--
 Sub cmdAendern_OnClick
    Dim d                   ' Erstellen einer Variablen
    Set d = CreateObject("Scripting.Dictionary")
    d.Add "0", "Athen"      ' Einige Schlüssel und Elemente hinzufügen
    d.Add "1", "Belgrad"
    d.Add "2", "Kairo"

    For Each I in d
        Document.frmFormular.Elements(I).Value = D.Item(I)
    Next
 End Sub
 -->
 </SCRIPT>
 <BODY>
 <CENTER>
 <FORM NAME="frmFormular"

 <Input Type = "Text"><p>
 <Input Type = "Text"><p>
 <Input Type = "Text"><p>
 <Input Type = "Text"><p>
 <Input Type = "Button" NAME="cmdAendern" VALUE="Hier klicken"><p>
 </FORM>
 </CENTER>
 </BODY>
 </HTML>


VBScript-Prozeduren

VBScript-Prozeduren 		VBScript-Tutorium
Zurück
Weiter

Arten von Prozeduren
In VBScript gibt es zwei Arten von Prozeduren, die Sub-Prozedur und die Function-Prozedur.
Sub-Prozeduren
Eine Sub-Prozedur ist eine Folge von VBScript-Anweisungen, die zwischen den Anweisungen Sub und End Sub eingeschlossen sind und Aktionen ausführen, aber keine Werte zurückgeben. Eine Sub-Prozedur kann Argumente (Konstanten, Variablen oder Ausdrücke, die von einer aufrufenden Prozedur übergeben wurden) übernehmen. Wenn eine Sub-Prozedur keine Argumente hat, muss ihre Sub-Anweisung ein leeres Klammernpaar () enthalten.

Die folgende Sub-Prozedur verwendet zwei integrierte (oder eingebaute) VBScript-Funktionen,MsgBox und InputBox, um einen Benutzer zur Eingabe von Informationen aufzufordern. Dann zeigt sie das Ergebnis einer Berechnung an, die auf diesen Informationen basiert. Die Berechnung wird in einer mit VBScript erstellten Function-Prozedur ausgeführt. Diese wird in der Behandlung der nachfolgenden Function-Prozedur ebenfalls gezeigt.

 Sub KonvertTemp()
    temp = InputBox("Geben Sie die Temperatur in Fahrenheit ein.", 1)
    MsgBox "Die Temperatur ist " & Celsius(temp) & " Grad Celsius."
 End Sub
Function-Prozeduren
Eine Function-Prozedur ist eine Folge von VBScript-Anweisungen, die zwischen den Anweisungen Function und End Function eingeschlossen sind. Eine Function-Prozedur ist einer Sub-Prozedur ähnlich, kann aber auch einen Wert zurückgeben. Eine Function-Prozedur kann Argumente (Konstanten, Variablen oder Ausdrücke, die von einer aufrufenden Prozedur übergeben werden) übernehmen. Wenn eine Function-Prozedur keine Argumente hat, muss ihre Function-Anweisung ein leeres Klammernpaar enthalten. Eine Function-Prozedur gibt Werte zurück, indem ihrem Namen in einer oder mehreren Anweisung(en) der Prozedur ein Wert zugewiesen wird. Der Typ des Rückgabewertes einer Function-Prozedur ist immer ein Variant.

Die Funktion Celsius im folgenden Beispiel berechnet aus Temperaturangaben in Fahrenheit die entsprechenden Werte in Grad Celsius. Beim Aufruf der Funktion aus der Sub-Prozedur KonvertTemp wird eine Variable mit dem Argumentwert an die Funktion übergeben. Das Ergebnis der Berechnung wird an die aufrufende Prozedur zurückgegeben und in einem Meldungsfeld angezeigt.

 Sub KonvertTemp()
     temp = InputBox("Geben Sie die Temperatur in Fahrenheit ein.", 1)
     MsgBox "Die Temperatur ist " & Celsius(temp) & " Grad Celsius."
 End Sub

 Function Celsius(GradF)
     Celsius = (GradF - 32) * 5 / 9
 End Function
Übergeben von Daten an bzw. aus Prozeduren
Die Übergabe eines Datenelements an Prozeduren erfolgt über ein Argument. Argumente dienen als Platzhalter für die an die Prozedur zu übergebenden Daten. Als Bezeichner für Argumente können Sie jeden als Variablennamen gültigen Bezeichner verwenden. Wenn Sie eine Prozedur mit der Sub- oder der Function-Anweisung erstellen, müssen nach dem Namen der Prozedur Klammern eingefügt werden. Alle Argumente werden zwischen diesen Klammern angegeben und durch Kommas getrennt. In der folgenden Prozedur ist beispielsweise GradF ein Platzhalter für den Wert, der an die Funktion Celsius zur Konvertierung übergeben wird:
 Function Celsius(GradF)
    Celsius = (GradF - 32) * 5 / 9
 End Function
Um Daten von einer Prozedur als Rückgabe zu erhalten, müssen Sie eine Function-Prozedur definieren. Denken Sie daran, dass eine Function-Prozedur einen Wert zurückgeben kann, eine Sub-Prozedur dagegen nicht.
Verwenden von Sub- und Function-Prozeduren im Code
Um eine Function-Prozedur in Ihrem Code zu verwenden, müssen Sie diese auf der rechten Seite einer Variablenzuweisung oder in einem Ausdruck verwenden. Beispiele:

 temperatur = Celsius(temp)
oder
 MsgBox "Die Temperatur ist " & Celsius(temp) & " Grad Celsius."
Um eine Sub-Prozedur aus einer anderen Prozedur aufzurufen, müssen Sie lediglich den Namen der Prozedur zusammen mit den erforderlichen Argumenten (durch Kommas getrennt) eingeben. Die Call-Anweisung ist nicht erforderlich. Wenn Sie sie jedoch verwenden, müssen Sie die Argumente in Klammern einschließen.

Das folgende Beispiel zeigt zwei Aufrufe der Prozedur MeineProz. In einem Fall wird die Call-Anweisung im Code verwendet, im anderen nicht. Beide Aufrufe haben genau dieselbe Wirkung.

 Call MeineProz(erstesArg, zweitesArg)
 MeineProz erstesArg, zweitesArg
Beachten Sie, dass bei Nichtverwendung der Call-Anweisung die Klammern weggelassen werden müssen.


VBScript-Codekonventionen

VBScript-Codekonventionen 		VBScript-Tutorium
Zurück
Weiter

Was sind Konventionen für die Programmierung?
Konventionen für die Programmierung sind Vorschläge, die Ihnen das Schreiben von Code mit der Microsoft Visual Basic Scripting Edition erleichtern sollen. Konventionen für die Programmierung umfassen unter anderem folgende Richtlinien:
  • Namenskonventionen für Objekte, Variablen und Prozeduren
  • Konventionen für Kommentare
  • Richtlinien für die Formatierung und das Einrücken von Text
Der wichtigste Grund für einheitliche Konventionen für die Programmierung ist die Standardisierung der Codestruktur und des Programmierstils für ein oder mehrere Skripten, damit der Code für Sie und andere leichter lesbar und verständlicher ist. Mit sinnvollen Konventionen für die Programmierung erhalten Sie präzisen, lesbaren und eindeutigen Code, der den für andere Programmiersprachen verwendeten Konventionen entspricht und so intuitiv wie möglich ist.
Namenskonventionen für Konstanten
Frühere Versionen von VBScript besaßen keine Mechanismen für die Erstellung benutzerdefinierter Konstanten. Konstanten wurden, wenn notwendig, wie Variablen implementiert und von anderen Variablen dadurch unterschieden, dass nur Großbuchstaben verwendet wurden. Mehrere Wörter wurden durch den Unterstrich (_) getrennt. Beispiele:
 BENUTZER_HIER_SPEICHERN
 NEUE_ZEILE
Obwohl dies auch eine akzeptable Möglichkeit zum Benennen von Konstanten ist, sollten Sie eventuell ein anderes Namensschema verwenden, da Sie ja jetzt mit der Const-Anweisung echte Konstanten anlegen können. Diese Konvention verwendet ein Format mit gemischter Groß- und Kleinschreibung, in dem Konstanten das Präfix "con" vorangestellt wird. Beispiele:
 conIhreEigeneKonstante
Namenskonventionen für Variablen
Um die Lesbarkeit und die Konsistenz zu verbessern, verwenden Sie in VBScript die in der folgenden Tabelle aufgeführten Präfixe zusammen mit aussagekräftigen Variablennamen.

Untertyp | Präfix | Beispiel
Boolean | bln | blnGefunden
Byte | byt | bytRasterDaten
Date (Time) | dtm | dtmStart
Double | dbl | dblToleranz
Error | err | errBestellNr
Integer | int | intAnzahl
Long | lng | lngEntfernung
Object | obj | objAktuell
Single | sng | sngDurchschnitt
String | str | strVorname

Gültigkeitsbereich von Variablen
Variablen sollten immer mit dem kleinstmöglichen Gültigkeitsbereich definiert werden. VBScript-Variablen können einen der folgenden Gültigkeitsbereiche haben.

Gültigkeitsbereich | Variablendeklaration in | Sichtbarkeit
Prozedurebene | Ereignis-, Function- oder Sub-Prozedur | Sichtbar in der Prozedur, in der sie deklariert wird.
Skriptebene | HEAD-Abschnitt einer HTML-Seite, außerhalb jeder Prozedur | Sichtbar in jeder Prozedur des Skriptes

Präfixe für den Gültigkeitsbereich von Variablen
Mit zunehmender Skriptgröße wird es immer wichtiger, die Gültigkeitsbereiche der Variablen schnell unterscheiden zu können. Dies wird durch einen Gültigkeitsbereichs-Präfix aus einem Buchstaben vor dem Typ-Präfix erreicht, ohne die Variablennamen übermäßig zu verlängern.

Gültigkeitsbereich | Präfix | Beispiel
Prozedurebene | kein | dblGeschwindigkeit
Skriptebene | s | sblnBerechnungInArbeit

Aussagekräftige Variablen- und Prozedurnamen
In einem Variablen- oder Prozedurnamen sollte Groß- und Kleinschreibung verwendet werden. Der Name sollte so ausführlich sein wie nötig, um den Zweck der Variablen zu beschreiben. Darüber hinaus sollten Prozedurnamen mit einem Verb beginnen, wie z. B. InitialisiereFeldName oder SchliesseDialogfeld.

Für häufig verwendete oder lange Ausdrücke sind Standardabkürzungen zu empfehlen, um die Namen kurz zu halten. Im Allgemeinen sind Variablennamen mit mehr als 32 Zeichen schwer lesbar. Stellen Sie sicher, dass die verwendeten Abkürzungen im gesamten Skript einheitlich sind. Der grundlose Wechsel zwischen Zaehler und Zhlr innerhalb eines oder mehrerer zusammenhängender Skripten kann Probleme bereiten.

Namenskonventionen für Objekte
Die folgende Tabelle führt die empfohlenen Konventionen für die verschiedenen Objekte auf, die beim Programmieren in VBScript verwendet werden.

Objekttyp | Präfix | Beispiel
3D-Grundfläche (3D Panel) | pnl | pnlGruppe
Animierte Schaltfläche | ani | aniMailBox
Befehlsschaltfläche (command button) | cmd | cmdBeenden
Bezeichnungsfeld (label) | lbl | lblHilfeMeldung
Bildlauffeld (slider) | sld | sldSkala
Drehfeld (spin) | spn | spnSeiten
Grafik (image) | img | imgSymbol
Horizontale Bildlaufleiste (horizontal scroll bar) | hsb | hsbLautstaerke
Kombinationsfeld (combo box), Dropdown-Listenfeld (drop-down list box) | cbo | cboDeutsch
Kontrollkästchen (check box) | chk | chkNurLesen
Linie (line) | lin | linVertikal
Listenfeld (list box) | lst | lstVersicherungsnummern
Rahmen (frame) | fra | fraSprache
Standarddialogfeld (common dialog) | dlg | dlgDateiOeffnen
Textfeld (text box) | txt | txtNachname
Vertikale Bildlaufleiste (vertical scroll bar) | vsb | vsbRate

Konventionen für Codekommentare
Jede Prozedur sollte mit einem kurzen Kommentar beginnen, der den Zweck der Prozedur beschreibt. Diese Beschreibung sollte nicht auf die Implementierungsdetails (wie die Operationen durchgeführt werden) eingehen, weil sich diese im Laufe der Zeit ändern können, was zu unnötigen Wartungsarbeiten bei den Kommentaren oder, noch schlimmer, zu falschen Kommentaren führen kann. Der Code selbst und ggf. nötige Kommentare im Code beschreiben die Implementierung.

Die an eine Prozedur übergebenen Argumente sollten beschrieben werden, wenn ihr Zweck nicht offensichtlich ist und wenn die Prozedur die Argumente in einem bestimmten Wertebereich erwartet. Rückgabewerte von Funktionen und andere Variablen, die von der Prozedur geändert werden, vor allem über Argumente, die als Referenz übergeben werden, sollten ebenfalls am Anfang jeder Prozedur beschrieben werden.

Die Kommentare im Prozedurkopf sollten folgende Abschnittsüberschriften enthalten. Beispiele finden Sie im nachfolgenden Abschnitt "Codeformatierung".

Abschnittsüberschrift | Kommentar-Inhalte
Zweck | Was die Prozedur tut (nicht, wie sie es tut).
Annahmen | Liste der Auswirkungen dieser Prozedur auf externe Variablen, Steuerelemente oder andere Elemente.
Auswirkungen | Liste der Auswirkungen dieser Prozedur auf externe Variablen, Steuerelemente oder andere Elemente.
Eingehende Werte | Erläuterung jedes Arguments, das nicht offensichtlich ist. Jedes Argument sollte in einer separaten Zeile mit Kommentaren im Code beschrieben werden.
Rückgabewerte | Erklärung des zurückgegebenen Wertes.

Berücksichtigen Sie folgende Punkte:

  • Die Deklaration jeder wichtigen Variablen sollte einen Kommentar im Code enthalten, der die Verwendung der deklarierten Variablen beschreibt.
  • Variablen, Steuerelemente und Prozeduren sollten so klar benannt werden, dass Kommentare im Code nur noch für komplexe Implementierungsdetails nötig sind.
  • Sie sollten am Anfang Ihres Skriptes eine Übersicht einfügen, die das Skript beschreibt und die Objekte, Prozeduren, Algorithmen, Dialogfelder und andere Systemabhängigkeiten auflistet. Manchmal kann ein Stück Pseudocode helfen, einen Algorithmus zu beschreiben.
Codeformatierung
Sie sollten mit dem Platz auf dem Bildschirm möglichst sparsam umgehen und trotzdem den Code so formatieren, dass die logische Struktur und Verschachtelung deutlich wird. Hier sind einige Hinweise:
  • Normal verschachtelte Blöcke sollten um vier Leerzeichen eingerückt sein.
  • Der Übersichtskommentar einer Prozedur sollte um ein Leerzeichen eingerückt sein.
  • Die Anweisungen auf höchster Ebene, die auf den Übersichtskommentar folgen, sollten um vier Leerzeichen eingerückt sein. Jeder verschachtelte Block sollte jeweils um weitere vier Leerzeichen eingerückt werden. Beispiele:

 '********************************************************************
 ' Zweck:          Sucht das erste Vorkommen des angegebenen
 '                 Benutzers im Datenfeld BenutzerListe.
 ' Eingaben  strBenutzerListe():   Zu durchsuchende Benutzerliste.
 '           strZielBenutzer:      Name des zu suchenden Benutzers.
 ' Rückgabewerte:  Index des ersten Vorkommens von
 '                 strZielBenutzer im Datenfeld strBenutzerListe.
 '                 Wenn der gesuchte Benutzer nicht gefunden wird: -1.
 '********************************************************************

 Function intSucheBenutzer(strBenutzerListe(), strZielBenutzer)
     Dim i                           ' Schleifenzähler.
     Dim blnGefunden                 ' "Ziel gefunden"-Kennung
     intSucheBenutzer = -1
     i = 0                           ' Schleifenzähler initialisieren
     Do While i <= Ubound(strBenutzerListe) and Not blnGefunden
         If strBenutzerListe(i) = strZielBenutzer Then
             blnGefunden = True      ' Kennung auf True setzen
             intSucheBenutzer = i    ' Rückgabewert für Schleifenzähler setzen
         End If
         i = i + 1                   ' Schleifenzähler erhöhen
     Loop
 End Function


Eine einfache VBScript-Seite

Eine einfache VBScript-Seite 		VBScript-Tutorium
Zurück
Weiter

Eine einfache Seite
Mit Microsoft® Internet Explorer können Sie die mit dem folgenden HTML-Code erstellte Seite anzeigen. Wenn Sie auf die Schaltfläche auf der Seite klicken, sehen Sie VBScript in Aktion.
<HTML>
<HEAD><TITLE>Eine einfache erste Seite</TITLE>
<SCRIPT LANGUAGE="VBScript">
<!--
Sub Schaltfl1_OnClick
        MsgBox "Mirabile visu."
End Sub
-->
</SCRIPT>
</HEAD>
<BODY>
<H3>Eine einfache erste Seite</H3><HR>
<FORM><INPUT NAME="Schaltfl1" TYPE="BUTTON" VALUE="Hier klicken"></FORM>
</BODY>
</HTML>
Das Ergebnis ist nicht gerade überwältigend: Sie sehen ein Dialogfeld mit einem Satz (Lateinisch für "Wunderbar anzusehen"). Es passiert jedoch einiges.

Wenn Internet Explorer die Seite einliest, wird das <SCRIPT>-Tag gefunden, ein VBScript-Codeabschnitt erkannt und gespeichert. Wenn Sie dann auf die Schaltfläche klicken, stellt Internet Explorer die Verbindung zwischen der Schaltfläche und dem Code her und führt die Prozedur aus.

Die Sub-Prozedur innerhalb der <SCRIPT>-Tags wird auch als Ereignisprozedur bezeichnet. Sie sehen, dass der Prozedurname aus zwei Teilen besteht: dem Namen der Schaltfläche, Schaltfl1 (vom NAME-Attribut im <INPUT>-Tag), und dem Ereignisnamen OnClick. Die beiden Teile sind durch einen Unterstrich (_) miteinander verbunden. Jedes Mal, wenn auf die Schaltfläche geklickt wird, sucht Internet Explorer nach der zugehörigen Ereignisprozedur Schaltfl1_OnClick und führt sie aus.

Informationen zu Internet Explorer-Definitionen zu verfügbaren Ereignissen für Formular-Steuerelemente finden Sie in der Dokumentation des Internet Explorer Scripting-Objektmodells auf der Website von Microsoft® (http://www.microsoft.com).

Seiten können auch eine Kombination von Steuerelementen und Prozeduren enthalten. Die nächste Seite, VBScript und Formulare, demonstriert einige einfache Wechselbeziehungen zwischen Steuerelementen.

Andere Möglichkeiten, Code mit Ereignissen zu verknüpfen
Sie können VBScript-Code auf zwei andere Arten mit Ereignissen verknüpfen, obwohl die weiter oben vorgestellte Möglichkeit wahrscheinlich die allgemeinste und einfachste ist. Internet Explorer ermöglicht Ihnen, in das Tag, das ein Steuerelement definiert, kurze Abschnitte mit Inline-Code einzufügen. Das folgende <INPUT>-Tag führt genau dieselbe Aktion aus wie das weiter oben gezeigte Codebeispiel, wenn Sie auf die Schaltfläche klicken:
<INPUT NAME="Schaltfl1" TYPE="BUTTON"
       VALUE="Hier klicken" OnClick='MsgBox "Mirabile visu."'>
Beachten Sie, dass der Funktionsaufruf selbst in Hochkommas eingeschlossen ist, während die Zeichenfolge für die MsgBox-Funktion in Anführungszeichen eingeschlossen ist. Sie können mehrere Anweisungen durch Doppelpunkte (:) getrennt eingeben.

Sie können ein <SCRIPT>-Tag auch so schreiben, dass es nur ein bestimmtes Ereignis für ein bestimmtes Steuerelement betrifft:

<SCRIPT LANGUAGE="VBScript" EVENT="OnClick" FOR="Schaltfl1">
<!--
    MsgBox "Mirabile visu."
-->
</SCRIPT>
Da das <SCRIPT>-Tag bereits Ereignis und Steuerelement angibt, werden die Anweisungen Sub und End Sub nicht verwendet.


VBScript und Formulare

VBScript und Formulare 		VBScript-Tutorium
Zurück
Weiter

Einfache Gültigkeitsprüfung
Mit Visual Basic Scripting Edition können Sie einen großen Teil der normalerweise auf einem Server anfallenden Formularverarbeitung durchführen. Ihnen stehen sogar Funktionen zur Verfügung, die auf dem Server überhaupt nicht verfügbar sind.

Es folgt ein Beispiel für einfache Gültigkeitsprüfung auf Clientseite. Der HTML-Code realisiert ein Textfeld und eine Schaltfläche. Wenn Sie die mit dem folgenden Code erstellte Seite mit dem Microsoft® Internet Explorer anzeigen, sehen Sie ein kleines Textfeld mit einer Schaltfläche daneben.

<HTML>
<HEAD><TITLE>Einfache Gültigkeitsüberprüfung</TITLE>
<SCRIPT LANGUAGE="VBScript">
<!--
Sub Schaltfl1_OnClick
  Dim DasFormular
  Set DasFormular = Document.GueltFormular
  If IsNumeric(DasFormular.Text1.Value) Then
    If DasFormular.Text1.Value < 1 Or DasFormular.Text1.Value > 10 Then
      MsgBox "Geben Sie bitte eine Zahl zwischen 1 und 10 ein."
    Else
      MsgBox "Vielen Dank."
    End If
  Else
    MsgBox "Geben Sie bitte einen numerischen Wert ein."
  End If
End Sub
-->
</SCRIPT>
</HEAD>
<BODY>
<H3>Einfache Gültigkeitsüberprüfung</H3><HR>
<FORM NAME="GueltFormular">
Geben Sie einen Wert zwischen 1 und 10 ein:
<INPUT NAME="Text1" TYPE="TEXT" SIZE="2">
<INPUT NAME="Schaltfl1" TYPE="BUTTON" VALUE="Übermitteln">
</FORM>
</BODY>
</HTML>
Der einzige Unterschied zwischen diesem Beispiel und den Beispielen unter Eine einfache VBScript-Seite besteht darin, dass die Value-Eigenschaft des Textfeldes verwendet wird, um den eingegebenen Wert zu überprüfen. Um jedoch den Wert der Value-Eigenschaft zu erhalten, muss der Code den Verweis auf den Namen des Textfeldes explizit angeben.

Sie können immer den vollständigen Verweis, Document.GueltFormular.Text1, verwenden. Wenn Sie jedoch mehrere Verweise auf Formular-Steuerelemente haben, sollten Sie besser das hier verwendete Verfahren einsetzen. Zunächst deklarieren Sie eine Variable. Dann verwenden Sie die Set-Anweisung, um der Variablen DasFormular das Formular zuzuweisen. Eine reguläre Zuweisung, wie z. B. Dim, würde hier nicht funktionieren: Sie müssen Set verwenden, um den Verweis auf ein Objekt zu erhalten.

Verwenden numerischer Werte
Beachten Sie, dass in diesem Beispiel der Wert direkt mit einer Zahl geprüft wird. Mithilfe der IsNumeric-Funktion wird sichergestellt, dass die Zeichenfolge im Textfeld eine Zahl ist. Obwohl Zeichenfolgen und Zahlen automatisch von VBScript konvertiert werden, sollte bei einer guten Programmierung bei einem von einem Anwender eingegebenen Wert immer der Untertyp ermittelt und nötigenfalls Konvertierungsfunktionen verwendet werden. Vor dem Addieren von Textfeld-Werten müssen die Werte explizit konvertiert werden, da der Additionsoperator (+) sowohl eine Addition als auch eine Zeichenfolgenverkettung darstellen kann. Wenn z. B. Text1 eine "1" enthält und Text2 eine "2", sehen Sie folgende Ergebnisse:
A = Text1.Value + Text2.Value		' A ist "12"
A = CDbl(Text1.Value) + Text2.Value	' A ist 3
Gültigkeitsüberprüfung für Daten und Rückgabe von Daten an den Server
Das Beispiel für eine einfache Gültigkeitsprüfung enthält ein normales Schaltflächensteuerelement. Wenn im Beispiel ein Submit-Steuerelement verwenden würde, könnte es die Daten niemals auswerten, da alle Daten direkt an den Server gesendet würden. Wenn Sie das Submit-Steuerelement nicht einsetzen, können Sie die Daten prüfen, aber sie werden nicht an den Server übergeben. Dazu ist eine zusätzliche Codezeile notwendig:
<SCRIPT LANGUAGE="VBScript">
<!--
Sub Schaltfl1_OnClick
  Dim DasFormular
  Set DasFormular = Document.GueltFormular
  If IsNumeric(DasFormular.Text1.Value) Then
    If DasFormular.Text1.Value < 1 Or DasFormular.Text1.Value > 10 Then
      MsgBox "Geben Sie bitte eine Zahl zwischen 1 und 10 ein."
    Else
      MsgBox "Vielen Dank."
      DasFormular.Submit	' Daten sind korrekt und werden an den Server übergeben.
    End If
  Else
    MsgBox "Geben Sie bitte einen numerischen Wert ein."
  End If
End Sub
-->
</SCRIPT>
Sind die Daten korrekt, ruft der Code zum Übertragen von Daten zum Server die Submit-Methode auf dem Formularobjekt auf. Anschließend werden die Daten wie gewohnt vom Server behandelt, mit der Ausnahme, dass die Daten korrekt sind, bevor sie übertragen werden. Weitere Informationen zur Submit-Methode sowie zu anderen Methoden finden Sie in der Dokumentation des Internet Explorer Scripting-Objektmodells auf der Website von Microsoft® (http://www.microsoft.com).

Bis jetzt haben Sie nur die Standard HTML-<FORM>-Objekte kennen gelernt. Mit Internet Explorer können Sie die volle Leistungsfähigkeit der ActiveX®-Steuerelemente (früher OLE-Steuerelemente genannt) und der Java™-Objekte ausnutzen.


Verwenden von VBScript mit Objekten

Verwenden von VBScript mit Objekten 		VBScript-Tutorium
Zurück

Verwenden von Objekten
Es ist nicht relevant, ob Sie ein ActiveX®-Steuerelement (in der Vergangenheit als OLE-Steuerelement bezeichnet) oder ein Java™-Objekt verwenden, da diese von Microsoft Visual Basic Scripting Edition und Microsoft® Internet Explorer auf die gleiche Weise behandelt werden. Wenn Sie Internet Explorer einsetzen und das Label-Steuerelement installiert ist, können Sie die mit dem folgenden Code erstellte Seite anzeigen.

Sie fügen ein Objekt mithilfe der <OBJECT>-Tags ein und stellen dessen anfängliche Eigenschaften mithilfe von <PARAM>-Tags ein. Wenn Sie Visual Basic-Programmierer sind, werden Sie bemerken, dass die Verwendung der <PARAM>-Tags genau der Anfangseinstellung der Eigenschaften eines Steuerelements in einem Formular entspricht. Zum Beispiel fügt die folgende Gruppe von <OBJECT>- und <PARAM>-Tags einer Seite das ActiveX-Label-Steuerelement hinzu:

<OBJECT
    classid="clsid:99B42120-6EC7-11CF-A6C7-00AA00A47DD2"
    id=lblActiveLbl
    width=250
    height=250
    align=left
    hspace=20
    vspace=0
>
<PARAM NAME="Angle" VALUE="90">
<PARAM NAME="Alignment" VALUE="4">
<PARAM NAME="BackStyle" VALUE="0">
<PARAM NAME="Caption" VALUE="Ein Bezeichner">
<PARAM NAME="FontName" VALUE="Verdana, Arial, Helvetica">
<PARAM NAME="FontSize" VALUE="20">
<PARAM NAME="FontBold" VALUE="1">
<PARAM NAME="FrColor" VALUE="0">
</OBJECT>
Genau wie bei anderen Formular-Steuerelementen können Sie Eigenschaften lesen und ändern sowie Methoden aufrufen. Zum Beispiel enthält der folgende Code <FORM>-Steuerelemente, die Sie zur Anpassung von zwei Eigenschaften des Label-Steuerelements verwenden können:
<FORM NAME="Steuerelemente">
<INPUT TYPE="TEXT" NAME="NeuerText" SIZE=25>
<INPUT TYPE="BUTTON" NAME="cmdAendern" VALUE="Bezeichnung ändern">
<INPUT TYPE="BUTTON" NAME="cmdDrehen" VALUE="Bezeichnung drehen">
</FORM>
In dem so definierten Formular ändert eine Ereignisprozedur für die Schaltfläche cmdAendern den Text des Bezeichners:
<SCRIPT LANGUAGE="VBScript">
<!--
Sub cmdAendern_OnClick
    Dim DasFormular
    Set DasFormular = Document.Steuerelemente
    lblActiveLbl.Caption = DasFormular.NeuerText.Value
End Sub
-->
</SCRIPT>
Der Code verweist auf Steuerelemente und Werte im Formular genau wie im Beispiel Einfache Gültigkeitsprüfung.

Für die Verwendung mit Internet Explorer stehen zahlreiche ActiveX-Steuerelemente zur Verfügung. Vollständige Informationen zu Eigenschaften, Methoden und Ereignissen sowie CLSID (class identifiers, Klassenbezeichner) für diese Steuerelemente finden Sie auf der Website von Microsoft® (http://www.microsoft.com). Weitere Informationen zu <OBJECT>-Tags finden Sie auf der Seite Internet Explorer 4.0 Author's Guide and HTML Reference.

Hinweis Frühere Versionen von Internet Explorer benötigten um classid-Attribute Klammern ({}) und entsprachen nicht den W3C-Spezifikationen. Beim Verwenden von Klammern in der aktuellen Version wird eine Fehlermeldung angezeigt, dass diese Seite eine veraltete Version des <OBJECT>-Tags verwendet.


Scripting-Laufzeitreferenz

Scripting-Laufzeitreferenz 		Sprachverzeichnis
Versionsinformationen

Informationen über Funktionsmerkmale

Alphabetische Schlüsselwortliste

Eigenschaften

Konstanten

Methoden

Objekte

Willkommen bei der Referenz zur Scripting-Laufzeitbibliothek

Diese kompakten Informationsblöcke unterstützen Sie beim Arbeiten in den zahlreichen unterschiedlichen Bereichen der Scripting-Laufzeitbibliothek.

Sie finden eine alphabetische Auflistung sämtlicher Bereiche der Scripting-Laufzeitbibliothek in der alphabetischen Schlüsselwortliste. Wenn Sie jedoch lediglich zu einer Kategorie, wie z. B. Objekten, etwas nachschlagen möchten, sehen Sie, dass die einzelnen Sprachkategorien jeweils eigene, kompaktere Bereiche enthalten.

Die Funktionsweise ist denkbar einfach. Klicken Sie auf eine der links angezeigten Überschriften, um eine Auflistung der in dieser Kategorie enthaltenen Themen einzublenden. Wählen Sie aus dieser Auflistung anschließend das gewünschte Thema aus. Nachdem Sie das gewünschte Thema eingeblendet haben, können Sie problemlos zu anderen thematisch verknüpften Bereichen wechseln.

Tauchen Sie also ein! Lesen Sie Wissenswertes über Anweisungen, sinnieren Sie über die Methoden, oder probieren Sie einige Funktionen aus. Sie werden feststellen, dass diese Scripting-Laufzeitbibliothek ausgesprochen vielseitig ist!

Funktionsmerkmale | Beschreibung
Merkmale der Microsoft Scripting-Laufzeitbibliothek | Auflistung der Funktionsmerkmale, die zur Zeit in der Microsoft Scripting-Laufzeitbibliothek vorhanden sind.
Sprachelement | Beschreibung
Add-Methode (Dictionary) | Fügt ein neues Element/Schlüssel-Paar zu einem Dictionary-Objekt hinzu.
Add-Methode (Folders) | Fügt der Folders-Auflistung einen neuen Ordner hinzu.
AtEndOfLine-Eigenschaft | Gibt True zurück, wenn sich der Dateizeiger unmittelbar vor dem Zeilenendezeichen einer TextStream-Datei befindet, andernfalls False.
AtEndOfStream-Eigenschaft | Gibt True zurück, wenn sich der Dateizeiger am Ende einer TextStream-Datei befindet, andernfalls False.
Attributes-Eigenschaft | Legt die Attribute von Dateien bzw. Ordnern fest oder gibt sie zurück.
AvailableSpace-Eigenschaft | Gibt die Größe des Speicherplatzes zurück, der einem Benutzer auf dem angegebenen Laufwerk bzw. der angegebenen Netzwerkfreigabe zur Verfügung steht.
BuildPath-Methode | Hängt einen Namen an einen vorhandenen Pfad an.
Close-Methode | Schließt eine geöffnete TextStream-Datei.
Column-Eigenschaft | Gibt die Spaltennummer der aktuellen Zeichenposition in einer TextStream-Datei zurück.
CompareMode-Eigenschaft | Legt den Vergleichsmodus zum Vergleich von Zeichenfolge-Schlüsseln in einem Dictionary-Objekt fest oder gibt ihn zurück.
Copy-Methode | Kopiert eine angegebene Datei bzw. einen angegebenen Ordner von einem Speicherort in einen anderen.
CopyFile-Methode | Kopiert eine Datei oder mehrere Dateien von einem Speicherort in einen anderen.
CopyFolder-Methode | Kopiert rekursiv einen Ordner von einem Speicherort in einen anderen.
Count-Eigenschaft | Gibt die Anzahl der Elemente in einer Auflistung oder in einem Dictionary-Objekt zurück.
CreateFolder-Methode | Erstellt einen Ordner.
CreateTextFile-Methode | Erstellt eine Datei mit dem angegebenen Namen und gibt ein TextStream-Objekt für Schreib- und Lesezugriffe auf die Datei zurück.
DateCreated-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an denen die angegebene Datei bzw. der angegebene Ordner erstellt wurde.
Dateiattributkonstanten | Definiert verschiedene Konstanten für Dateiattribute, wie beispielsweise Versteckt, Schreibgeschützt etc.
Dateieingabe-/-ausgabekonstanten | Definiert Konstanten zur Verwendung mit Dateieingabe- und -ausgabe.
DateLastAccessed-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an denen auf die angegebene Datei bzw. den angegebenen Ordner zuletzt zugegriffen wurde.
DateLastModified-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an denen die angegebene Datei bzw. der angegebene Ordner zuletzt geändert wurde.
Delete-Methode | Löscht eine angegebene Datei bzw. einen angegebenen Ordner.
DeleteFile-Methode | Löscht eine angegebene Datei.
DeleteFolder-Methode | Löscht einen angegebenen Ordner mitsamt Inhalt.
Dictionary-Objekt | Ein Objekt, das Element/Schlüssel-Paare speichert.
Drive-Eigenschaft | Gibt den Buchstaben des Laufwerkes zurück, auf dem sich die angegebene Datei bzw. der angegebene Ordner befindet.
Drive-Objekt | Bietet Zugriff auf die Eigenschaften eines bestimmten Festplattenlaufwerkes oder einer bestimmten Netzwerkfreigabe.
DriveExists-Methode | Gibt True zurück, wenn das angegebene Laufwerk vorhanden ist, andernfalls False.
DriveLetter-Eigenschaft | Gibt den Laufwerkbuchstaben eines physischen lokalen Laufwerkes oder einer Netzwerkfreigabe zurück.
Drives-Auflistung | Schreibgeschützte Auflistung aller verfügbaren Laufwerke.
Drives-Eigenschaft | Gibt die Drives-Auflistung zurück, die alle Drive-Objekte enthält, die auf dem lokalen Computer verfügbar sind.
DriveType-Eigenschaft | Gibt einen Wert zurück, der den Typ des angegebenen Laufwerkes anzeigt.
Exists-Methode | Gibt True zurück, wenn ein angegebener Schlüssel in einem Dictionary-Objekt existiert, andernfalls False.
File-Objekt | Bietet Zugriff auf alle Eigenschaften einer Datei.
FileExists-Methode | Gibt True zurück, wenn die angegebene Datei vorhanden ist, andernfalls False.
Files-Auflistung | Auflistung aller File-Objekte in einem Ordner.
Files-Eigenschaft | Gibt eine Files-Auflistung zurück, die alle File-Objekte in dem angegebenen Ordner enthält, einschließlich der Dateien, deren Attribute "Versteckt" (Hidden) und "System" gesetzt sind.
FileSystem-Eigenschaft | Gibt das für das angegebene Laufwerk verwendete Dateisystem zurück.
FileSystemObject-Konstanten | Liste von Konstanten für das Automatisierungsobjekt des Dateisystems.
FileSystemObject-Objekt | Ermöglicht den Zugriff auf das Dateisystem des Computers.
Folder-Objekt | Bietet Zugriff auf alle Eigenschaften eines Ordners.
FolderExists-Methode | Gibt True zurück, wenn der angegebene Ordner vorhanden ist, andernfalls False.
Folders-Auflistung | Auflistung aller Folder-Objekte in einem Folder-Objekt.
FreeSpace-Eigenschaft | Gibt die Größe des freien Speicherplatzes zurück, der einem Benutzer auf dem angegebenen Laufwerk bzw. der angegebenen Netzwerkfreigabe zur Verfügung steht.
GetAbsolutePathName-Methode | Gibt aus einer angegebenen Pfadangabe einen vollständigen und eindeutigen Pfad zurück.
GetBaseName-Methode | Gibt eine Zeichenfolge zurück, die den Basisnamen einer Datei (Name ohne Erweiterung) oder den Ordner aus einer Pfadangabe enthält.
GetDrive-Methode | Gibt ein Drive-Objekt zurück, das dem Laufwerk in einem angegebenen Pfad entspricht.
GetDriveName-Methode | Gibt eine Zeichenfolge zurück, die den Namen des Laufwerkes in einem angegebenen Pfad enthält.
GetExtensionName-Methode | Gibt eine Zeichenfolge zurück, die den Erweiterungsnamen der letzten Komponente eines Pfades enthält.
GetFile-Methode | Gibt ein File-Objekt zurück, das der Datei in einem angegebenen Pfad entspricht.
GetFileName-Methode | Gibt den letzten Datei- oder Ordnernamen eines angegebenen Pfades zurück, der nicht Teil der Laufwerkangabe ist.
GetFileVersion-Methode | Gibt die Versionsnummer einer angegebenen Datei zurück.
GetFolder-Methode | Gibt ein Folder-Objekt zurück, das dem Ordner in einem angegebenen Pfad entspricht.
GetParentFolderName-Methode | Gibt eine Zeichenfolge zurück, die den Namen des übergeordneten Ordners der letzten Datei oder Ordners in einem angegebenen Pfad enthält.
GetSpecialFolder-Methode | Gibt den angegebenen Sonderordner zurück.
GetTempName-Methode | Gibt einen willkürlich erstellten Namen einer temporären Datei bzw. eines temporären Ordners zurück.
IsReady-Eigenschaft | Gibt True zurück, wenn das angegebene Laufwerk bereit ist, andernfalls False.
IsRootFolder-Eigenschaft | Gibt True zurück, wenn der angegebene Ordner der Stammordner ist, andernfalls False.
Item-Eigenschaft | Legt einen Eintrag für einen angegebenen Schlüssel in einem Dictionary-Objekt fest oder gibt diesen zurück.
Items-Methode | Gibt ein Datenfeld zurück, das alle Elemente eines Dictionary-Objekts enthält.
Key-Eigenschaft | Legt einen Schlüssel in einem Dictionary-Objekt fest oder gibt diesen zurück.
Keys-Methode | Gibt ein Datenfeld mit allen Schlüsseln in einem Dictionary-Objekt zurück.
Laufwerktypkonstanten | Definiert verschiedene Konstanten für auf dem Hostcomputer verfügbare Laufwerktypen, wie z. B. Fest, Austauschbar, CD-ROM usw.
Line-Eigenschaft | Gibt die aktuelle Zeilennummer in einer TextStream-Datei zurück.
Move-Methode | Verschiebt eine angegebene Datei bzw. einen angegebenen Ordner von einem Speicherort zu einem anderen.
MoveFile-Methode | Verschiebt eine Datei oder mehrere Dateien von einem Speicherort in einen anderen.
MoveFolder-Methode | Verschiebt einen oder mehrere Ordner von einem Speicherort in einen anderen.
Name-Eigenschaft | Legt den Namen einer angegebenen Datei bzw. eines angegebenen Ordners fest oder gibt diesen zurück.
Number-Eigenschaft | Gibt einen numerischen Wert zurück oder legt einen numerischen Wert fest, der einen Fehler angibt.
OpenAsTextStream-Methode | Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zum Lesen aus der Datei, Schreiben in die Datei oder Anfügen an die Datei zurück.
OpenTextFile-Methode | Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zum Lesen aus der Datei, Schreiben in die Datei oder Anfügen an die Datei zurück.
ParentFolder-Eigenschaft | Gibt das Folder-Objekt des übergeordneten Ordners der angegebenen Datei bzw. des angegebenen Ordners zurück.
Path-Eigenschaft | Gibt den Pfad einer angegebenen Datei bzw. eines angegebenen Ordners oder Laufwerkes zurück.
Read-Methode | Liest eine angegebene Anzahl von Zeichen aus einer TextStream-Datei und gibt die daraus resultierende Zeichenfolge zurück.
ReadAll-Methode | Liest eine ganze TextStream-Datei und gibt die daraus resultierende Zeichenfolge zurück.
ReadLine-Methode | Liest eine ganze Zeile (bis zum Zeilenumbruchzeichen, aber nicht dieses Zeichen selbst) aus einer TextStream-Datei und gibt die resultierende Zeichenfolge zurück.
Remove-Methode | Entfernt ein Element/Schlüssel-Paar aus einem Dictionary-Objekt.
RemoveAll-Methode | Entfernt sämtliche Element/Schlüssel-Paare aus einem Dictionary-Objekt.
RootFolder-Eigenschaft | Gibt ein Folder-Objekt zurück, das den Stammordner eines angegebenen Laufwerkes darstellt.
SerialNumber-Eigenschaft | Gibt die dezimale Seriennummer zurück, mit der ein Datenträger eindeutig gekennzeichnet wird.
ShareName-Eigenschaft | Gibt den Netzwerkfreigabenamen eines angegebenen Laufwerkes zurück.
ShortName-Eigenschaft | Gibt den Kurznamen zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
ShortPath-Eigenschaft | Gibt den Kurzpfad zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
Size-Eigenschaft | Gibt die Größe (in Byte) der angegebenen Datei bzw. des angegebenen Ordners an.
Skip-Methode | Überspringt eine bestimmte Anzahl von Zeichen beim Einlesen einer TextStream-Datei.
SkipLine-Methode | Überspringt die nächste Zeile beim Einlesen einer TextStream-Datei.
SpecialFolder-Konstanten | Definiert Konstanten für die in Ihrem Betriebssystem verfügbaren Sonderordner.
SubFolders-Eigenschaft | Gibt eine Folders-Auflistung zurück, die alle Ordner in dem angegebenen Ordner einschließlich derjenigen enthält, deren Attribute "Versteckt" (Hidden) und "System" gesetzt sind.
TextStream-Objekt | Vereinfacht den sequenziellen Zugriff auf eine Datei.
TotalSize-Eigenschaft | Gibt den gesamten Speicherplatz (in Byte) eines Laufwerkes oder einer Netzwerkfreigabe zurück.
Type-Eigenschaft | Gibt Informationen zum Datei- oder Ordnertyp zurück.
VolumeName-Eigenschaft | Legt den Datenträgernamen des angegebenen Laufwerkes fest bzw. gibt diesen zurück.
Write-Methode | Schreibt eine angegebene Zeichenfolge in eine TextStream-Datei.
WriteBlankLines-Methode | Schreibt eine angegebene Anzahl von Zeilenumbruchzeichen in eine TextStream-Datei.
WriteLine-Methode | Schreibt eine angegebene Zeichenfolge und ein Zeilenumbruchzeichen in eine TextStream-Datei.
Sprachelement | Beschreibung
Dateiattributkonstanten | Definiert verschiedene Konstanten für Dateiattribute, wie beispielsweise Versteckt, Schreibgeschützt etc.
Dateieingabe-/-ausgabekonstanten | Definiert Konstanten zur Verwendung mit Dateieingabe- und -ausgabe.
FileSystemObject-Konstanten | Liste von Konstanten für das Automatisierungsobjekt des Dateisystems.
Laufwerktypkonstanten | Definiert verschiedene Konstanten für auf dem Hostcomputer verfügbare Laufwerktypen, wie z. B. Fest, Austauschbar, CD-ROM usw.
SpecialFolder-Konstante | Definiert Konstanten für die in Ihrem Betriebssystem verfügbaren Sonderordner.
Sprachelement | Beschreibung
Add-Methode (Dictionary) | Fügt ein neues Element/Schlüssel-Paar zu einem Dictionary-Objekt hinzu.
Add-Methode (Folders) | Fügt der Folders-Auflistung einen neuen Ordner hinzu.
BuildPath-Methode | Hängt einen Namen an einen vorhandenen Pfad an.
Close-Methode | Schließt eine geöffnete TextStream-Datei.
Copy-Methode | Kopiert eine angegebene Datei bzw. einen angegebenen Ordner von einem Speicherort in einen anderen.
CopyFile-Methode | Kopiert eine Datei oder mehrere Dateien von einem Speicherort in einen anderen.
CopyFolder-Methode | Kopiert rekursiv einen Ordner von einem Speicherort in einen anderen.
CreateFolder-Methode | Erstellt einen Ordner.
CreateTextFile-Methode | Erstellt eine Datei mit dem angegebenen Namen und gibt ein TextStream-Objekt für Schreib- und Lesezugriffe auf die Datei zurück.
Delete-Methode | Löscht eine angegebene Datei bzw. einen angegebenen Ordner.
DeleteFile-Methode | Löscht eine angegebene Datei.
DeleteFolder-Methode | Löscht einen angegebenen Ordner mitsamt Inhalt.
DriveExists-Methode | Gibt True zurück, wenn das angegebene Laufwerk vorhanden ist, andernfalls False.
Exists-Methode | Gibt True zurück, wenn ein angegebener Schlüssel in einem Dictionary-Objekt existiert, andernfalls False.
FileExists-Methode | Gibt True zurück, wenn die angegebene Datei vorhanden ist, andernfalls False.
FolderExists-Methode | Gibt True zurück, wenn der angegebene Ordner vorhanden ist, andernfalls False.
GetAbsolutePathName-Methode | Gibt aus einer angegebenen Pfadangabe einen vollständigen und eindeutigen Pfad zurück.
GetBaseName-Methode | Gibt eine Zeichenfolge zurück, die den Basisnamen einer Datei (Name ohne Erweiterung) oder den Ordner aus einer Pfadangabe enthält.
GetDrive-Methode | Gibt ein Drive-Objekt zurück, das dem Laufwerk in einem angegebenen Pfad entspricht.
GetDriveName-Methode | Gibt eine Zeichenfolge zurück, die den Namen des Laufwerkes in einem angegebenen Pfad enthält.
GetExtensionName-Methode | Gibt eine Zeichenfolge zurück, die den Erweiterungsnamen der letzten Komponente eines Pfades enthält.
GetFile-Methode | Gibt ein File-Objekt zurück, das der Datei in einem angegebenen Pfad entspricht.
GetFileName-Methode | Gibt den letzten Datei- oder Ordnernamen eines angegebenen Pfades zurück, der nicht Teil der Laufwerkangabe ist.
GetFileVersion-Methode | Gibt die Versionsnummer einer angegebenen Datei zurück.
GetFolder-Methode | Gibt ein Folder-Objekt zurück, das dem Ordner in einem angegebenen Pfad entspricht.
GetParentFolderName-Methode | Gibt eine Zeichenfolge zurück, die den Namen des übergeordneten Ordners der letzten Datei oder Ordners in einem angegebenen Pfad enthält.
GetSpecialFolder-Methode | Gibt den angegebenen Sonderordner zurück.
GetTempName-Methode | Gibt einen willkürlich erstellten Namen einer temporären Datei bzw. eines temporären Ordners zurück.
Items-Methode | Gibt ein Datenfeld zurück, das alle Elemente eines Dictionary-Objekts enthält.
Keys-Methode | Gibt ein Datenfeld mit allen Schlüsseln in einem Dictionary-Objekt zurück.
Move-Methode | Verschiebt eine angegebene Datei bzw. einen angegebenen Ordner von einem Speicherort zu einem anderen.
MoveFile-Methode | Verschiebt eine Datei oder mehrere Dateien von einem Speicherort in einen anderen.
MoveFolder-Methode | Verschiebt einen oder mehrere Ordner von einem Speicherort in einen anderen.
OpenAsTextStream-Methode | Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zum Lesen aus der Datei, Schreiben in die Datei oder Anfügen an die Datei zurück.
OpenTextFile-Methode | Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zum Lesen aus der Datei, Schreiben in die Datei oder Anfügen an die Datei zurück.
Read-Methode | Liest eine angegebene Anzahl von Zeichen aus einer TextStream-Datei und gibt die daraus resultierende Zeichenfolge zurück.
ReadAll-Methode | Liest eine ganze TextStream-Datei und gibt die daraus resultierende Zeichenfolge zurück.
ReadLine-Methode | Liest eine ganze Zeile (bis zum Zeilenumbruchzeichen, aber nicht dieses Zeichen selbst) aus einer TextStream-Datei und gibt die resultierende Zeichenfolge zurück.
Remove-Methode | Entfernt ein Element/Schlüssel-Paar aus einem Dictionary-Objekt.
RemoveAll-Methode | Entfernt sämtliche Element/Schlüssel-Paare aus einem Dictionary-Objekt.
Skip-Methode | Überspringt eine bestimmte Anzahl von Zeichen beim Einlesen einer TextStream-Datei.
SkipLine-Methode | Überspringt die nächste Zeile beim Einlesen einer TextStream-Datei.
Write-Methode | Schreibt eine angegebene Zeichenfolge in eine TextStream-Datei.
WriteBlankLines-Methode | Schreibt eine angegebene Anzahl von Zeilenumbruchzeichen in eine TextStream-Datei.
WriteLine-Methode | Schreibt eine angegebene Zeichenfolge und ein Zeilenumbruchzeichen in eine TextStream-Datei.
Sprachelement | Beschreibung
Dictionary-Objekt | Ein Objekt, das Element/Schlüssel-Paare speichert.
Drive-Objekt | Bietet Zugriff auf die Eigenschaften eines bestimmten Festplattenlaufwerkes oder einer bestimmten Netzwerkfreigabe.
Drives-Auflistung | Schreibgeschützte Auflistung aller verfügbaren Laufwerke.
File-Objekt | Bietet Zugriff auf alle Eigenschaften einer Datei.
Files-Auflistung | Auflistung aller File-Objekte in einem Ordner.
FileSystemObject-Objekt | Ermöglicht den Zugriff auf das Dateisystem des Computers.
Folder-Objekt | Bietet Zugriff auf alle Eigenschaften eines Ordners.
Folders-Auflistung | Auflistung aller Folder-Objekte in einem Folder-Objekt.
TextStream-Objekt | Erleichtert den sequenziellen Zugriff auf eine Datei.
Sprachelement | Beschreibung
AtEndOfLine-Eigenschaft | Gibt True zurück, wenn sich der Dateizeiger unmittelbar vor dem Zeilenendezeichen einer TextStream-Datei befindet, andernfalls False.
AtEndOfStream-Eigenschaft | Gibt True zurück, wenn sich der Dateizeiger am Ende einer TextStream-Datei befindet, andernfalls False.
Attributes-Eigenschaft | Legt die Attribute von Dateien bzw. Ordnern fest oder gibt sie zurück.
AvailableSpace-Eigenschaft | Gibt die Größe des Speicherplatzes zurück, der einem Benutzer auf dem angegebenen Laufwerk bzw. der angegebenen Netzwerkfreigabe zur Verfügung steht.
Column-Eigenschaft | Gibt die Spaltennummer der aktuellen Zeichenposition in einer TextStream-Datei zurück.
CompareMode-Eigenschaft | Legt den Vergleichsmodus zum Vergleich von Zeichenfolge- Schlüsseln in einem Dictionary-Objekt fest oder gibt ihn zurück.
Count-Eigenschaft | Gibt die Anzahl der Elemente in einer Auflistung oder in einem Dictionary-Objekt zurück.
DateCreated-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an denen die angegebene Datei bzw. der angegebene Ordner erstellt wurde.
DateLastAccessed-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an denen auf die angegebene Datei bzw. den angegebenen Ordner zuletzt zugegriffen wurde.
DateLastModified-Eigenschaft | Gibt Datum und Zeitpunkt zurück, an denen die angegebene Datei bzw. der angegebene Ordner zuletzt geändert wurde.
Drive-Eigenschaft | Gibt den Buchstaben des Laufwerkes zurück, auf dem sich die angegebene Datei bzw. der angegebene Ordner befindet.
DriveLetter-Eigenschaft | Gibt den Laufwerkbuchstaben eines physischen lokalen Laufwerkes oder einer Netzwerkfreigabe zurück.
Drives-Eigenschaft | Gibt die Drives-Auflistung zurück, die alle Drive-Objekte enthält, die auf dem lokalen Computer verfügbar sind.
DriveType-Eigenschaft | Gibt einen Wert zurück, der den Typ des angegebenen Laufwerkes anzeigt.
Files-Eigenschaft | Gibt eine Files-Auflistung zurück, die alle File-Objekte in dem angegebenen Ordner enthält, einschließlich der Dateien, deren Attribute "Versteckt" (Hidden) und "System" gesetzt sind.
FileSystem-Eigenschaft | Gibt das für das angegebene Laufwerk verwendete Dateisystem zurück.
FreeSpace-Eigenschaft | Gibt die Größe des freien Speicherplatzes zurück, der einem Benutzer auf dem angegebenen Laufwerk bzw. der angegebenen Netzwerkfreigabe zur Verfügung steht.
IsReady-Eigenschaft | Gibt True zurück, wenn das angegebene Laufwerk bereit ist, andernfalls False.
IsRootFolder-Eigenschaft | Gibt True zurück, wenn der angegebene Ordner der Stammordner ist, andernfalls False.
Item-Eigenschaft | Legt einen Eintrag für einen angegebenen Schlüssel in einem Dictionary-Objekt fest oder gibt diesen zurück.
Key-Eigenschaft | Legt einen Schlüssel in einem Dictionary-Objekt fest oder gibt diesen zurück.
Line-Eigenschaft | Gibt die aktuelle Zeilennummer in einer TextStream-Datei zurück.
Name-Eigenschaft | Legt den Namen einer angegebenen Datei bzw. eines angegebenen Ordners fest oder gibt diesen zurück.
Number-Eigenschaft | Gibt einen numerischen Wert zurück oder legt einen numerischen Wert fest, der einen Fehler angibt.
ParentFolder-Eigenschaft | Gibt das Folder-Objekt des übergeordneten Ordners der angegebenen Datei bzw. des angegebenen Ordners zurück.
Path-Eigenschaft | Gibt den Pfad einer angegebenen Datei bzw. eines angegebenen Ordners oder Laufwerkes zurück.
RootFolder-Eigenschaft | Gibt ein Folder-Objekt zurück, das den Stammordner eines angegebenen Laufwerkes darstellt.
SerialNumber-Eigenschaft | Gibt die dezimale Seriennummer zurück, mit der ein Datenträger eindeutig gekennzeichnet wird.
ShareName-Eigenschaft | Gibt den Netzwerkfreigabenamen eines angegebenen Laufwerkes zurück.
ShortName-Eigenschaft | Gibt den Kurznamen zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
ShortPath-Eigenschaft | Gibt den Kurzpfad zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
Size-Eigenschaft | Gibt die Größe (in Byte) der angegebenen Datei bzw. des angegebenen Ordners an.
SubFolders-Eigenschaft | Gibt eine Folders-Auflistung zurück, die alle Ordner in dem angegebenen Ordner einschließlich derjenigen enthält, deren Attribute "Versteckt" (Hidden) und "System" gesetzt sind.
TotalSize-Eigenschaft | Gibt den gesamten Speicherplatz (in Byte) eines Laufwerkes oder einer Netzwerkfreigabe zurück.
Type-Eigenschaft | Gibt Informationen zum Datei- oder Ordnertyp zurück.
VolumeName-Eigenschaft | Legt den Datenträgernamen des angegebenen Laufwerkes fest bzw. gibt diesen zurück.

© 1999 Microsoft Corporation. Alle Rechte vorbehalten.


Informationen über Funktionsmerkmale

Informationen über
Funktionsmerkmale 		Scripting-Laufzeitreferenz
Versionsinformationen

Merkmale der Microsoft Scripting-Laufzeitbibliothek


Alphabetische Schlüsselwortliste

Alphabetische Schlüsselwortliste 		Scripting-Laufzeitreferenz
Versionsinformationen

Add-Methode (Dictionary)
Add-Methode (Folders)
AtEndOfLine-Eigenschaft
AtEndOfStream-Eigenschaft
Attributes-Eigenschaft
AvailableSpace-Eigenschaft
BuildPath-Methode
Close-Methode
Column-Eigenschaft
CompareMode-Eigenschaft
Copy-Methode
CopyFile-Methode
CopyFolder-Methode
Count-Eigenschaft
CreateFolder-Methode
CreateTextFile-Methode
DateCreated-Eigenschaft
Dateiattributkonstanten
Dateieingabe-/-ausgabekonstanten
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Delete-Methode
DeleteFile-Methode
DeleteFolder-Methode
Dictionary-Objekt
Drive-Eigenschaft
Drive-Objekt
DriveExists-Methode
DriveLetter-Eigenschaft
Drives-Auflistung
Drives-Eigenschaft
DriveType-Eigenschaft
Exists-Methode
FileExists-Methode
File-Objekt
Files-Auflistung
Files-Eigenschaft
FileSystem-Eigenschaft
FileSystemObject-Konstanten
FileSystemObject-Objekt
Folder-Objekt
FolderExists-Methode
Folders-Auflistung
FreeSpace-Eigenschaft
GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFileVersion-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode
IsReady-Eigenschaft
IsRootFolder-Eigenschaft
Item-Eigenschaft
Items-Methode
Key-Eigenschaft
Keys-Methode
Laufwerktypkonstanten
Line-Eigenschaft
Move-Methode
MoveFile-Methode
MoveFolder-Methode
Name-Eigenschaft
OpenAsTextStream-Methode
OpenTextFile-Methode
ParentFolder-Eigenschaft
Path-Eigenschaft
Read-Methode
ReadAll-Methode
ReadLine-Methode
Remove-Methode
RemoveAll-Methode
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
Skip-Methode
SkipLine-Methode
SpecialFolder-Konstanten
Subfolders-Eigenschaft
TextStream-Objekt
TotalSize-Eigenschaft
Type-Eigenschaft
VolumeName-Eigenschaft
Write-Methode
WriteBlankLines-Methode
WriteLine-Methode


Eigenschaften

Eigenschaften 		Scripting-Laufzeitreferenz
Versionsinformationen

AtEndOfLine-Eigenschaft
AtEndOfStream-Eigenschaft
Attributes-Eigenschaft
AvailableSpace-Eigenschaft
Column-Eigenschaft
CompareMode-Eigenschaft
Count-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
DriveLetter-Eigenschaft
Drives-Eigenschaft
DriveType-Eigenschaft
Files-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
IsRootFolder-Eigenschaft
Item-Eigenschaft
Key-Eigenschaft
Line-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
TotalSize-Eigenschaft
Type-Eigenschaft
VolumeName-Eigenschaft


Konstanten

Konstanten 		Scripting-Laufzeitreferenz
Versionsinformationen

Dateiattributkonstanten
Dateieingabe-/-ausgabekonstanten
FileSystemObject-Konstanten
Laufwerktypkonstanten
SpecialFolder-Konstante


Methoden

Methoden 		Scripting-Laufzeitreferenz
Versionsinformationen

Add-Methode (Dictionary)
Add-Methode (Folders)
BuildPath-Methode
Close-Methode
Copy-Methode
CopyFile-Methode
CopyFolder-Methode
CreateFolder-Methode
CreateTextFile-Methode
Delete-Methode
DeleteFile-Methode
DeleteFolder-Methode
DriveExists-Methode
Exists-Methode
FileExists-Methode
FolderExists-Methode
GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFileVersion-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode
Items-Methode
Keys-Methode
Move-Methode
MoveFile-Methode
MoveFolder-Methode
OpenAsTextStream-Methode
OpenTextFile-Methode
Read-Methode
ReadAll-Methode
ReadLine-Methode
Remove-Methode
RemoveAll-Methode
Skip-Methode
SkipLine-Methode
Write-Methode
WriteBlankLines-Methode
WriteLine-Methode


Objekte

Objekte 		Scripting-Laufzeitreferenz
Versionsinformationen

Dictionary-Objekt
Drive-Objekt
Drives-Auflistung
File-Objekt
Files-Auflistung
FileSystemObject-Objekt
Folder-Objekt
Folders-Auflistung
TextStream-Objekt


FileSystemObject-Objekt-Tutorium

FileSystemObject-Objekt-Tutorium
 Scripting-Laufzeitreferenz

Das FileSystemObject-Objektmodell
Einführung in FileSystemObject sowie in die Scripting-Laufzeitbibliothek
FileSystemObject-Objekte
Programmieren des FileSystemObject-Objekts
Arbeiten mit Laufwerken und Ordnern
Arbeiten mit Dateien
FileSystemObject-Beispielcode


Microsoft® Scripting-Bibliothek - Das FileSystemObject-Objektmodell

Microsoft® Scripting-Bibliothek - FileSystemObject
Das FileSystemObject-Objektmodell
 Weiter

Beim Schreiben von Skripten für Active Server Pages, Windows Scripting Host oder andere Anwendungen, bei denen Scripting verwendet werden kann, müssen oft Ordner (Verzeichnisse) und Dateien auf dem Webserver hinzugefügt, verschoben, geändert, erstellt oder gelöscht werden. Darüber hinaus kann es auch notwendig sein, über Informationen zu sowie Möglichkeiten zum Bearbeiten von Laufwerken zu verfügen, die im Webserver eingebunden sind.

Scripting ermöglicht Ihnen unter Verwendung des in den nachstehenden Abschnitten beschriebenen FileSystemObject-Objektmodells (FSO) das Arbeiten mit Laufwerken, Ordnern und Dateien:

  • Einführung in FileSystemObject sowie in die Scripting-Laufzeitbibliothek

  • FileSystemObject-Objekte

  • Programmieren des FileSystemObject-Objekts

  • Arbeiten mit Laufwerken und Ordnern

  • Arbeiten mit Dateien

  • FileSystemObject-Beispielcode


Microsoft® Scripting-Bibliothek - Einführung in FileSystemObject sowie in die Scripting-Laufzeitbibliothek

Microsoft® Scripting-Bibliothek - FileSystemObject
Einführung in FileSystemObject
sowie in die
Scripting-Laufzeitbibliothek
 Zurück
Weiter

Das FileSystemObject-Objektmodell (FSO) ermöglicht Ihnen die Verwendung der vertrauten objekt.methode-Syntax mit einer umfangreichen Menge von Eigenschaften, Methoden und Ereignissen, um Ordner sowie Dateien verarbeiten zu können.

Verwenden Sie dieses objektbasierte Werkzeug mit:

  • HTML zum Erstellen von Webseiten

  • Windows Scripting Host zum Erstellen von Stapelverarbeitungsdateien für Microsoft Windows

  • Script Control zum Bereitstellen von Scriptingfunktionalität für in anderen Sprachen entwickelte Anwendungen

Da bei der clientseitigen Verwendung von FSO schwerwiegende Sicherheitslücken bei möglichen unbefugten Zugriffen auf das lokale Dateisystem des Clients entstehen können, wird in dieser Dokumentation davon ausgegangen, dass die Verwendung des FSO-Objektmodells dem Erstellen von Skripten dient, die von serverseitigen Internetwebseiten ausgeführt werden. Da die Serverseite verwendet wird, kann aufgrund der Sicherheitseinstellungen von Internet Explorer keine clientseitige Verwendung des FileSystemObject-Objekts erfolgen. Durch Deaktivierung dieser Standardeinstellungen besteht die Möglichkeit, unbefugten Zugriff auf das Dateisystem eines lokalen Computers zu gewähren. Dies kann zur vollständigen Zerstörung der Dateisystemintegrität und Datenverlusten führen oder weitaus schlimmere Folgen haben.

Das FSO-Objektmodell ermöglicht serverseitigen Anwendungen das Erstellen, Ändern, Verschieben und Löschen von Ordnern bzw. das Überprüfen, ob und wo bestimmte Ordner vorhanden sind. Darüber hinaus können Sie Informationen zu Ordnern suchen, wie beispielsweise ihren Namen oder ihr Erstellungs- bzw. Änderungsdatum.

Das FSO-Objektmodell erleichtert zudem die Verarbeitung von Dateien. Bei der Verarbeitung von Dateien ist das oberste Ziel, Daten in einem kapazitäts- und ressourceneffizienten Format zu speichern, auf das problemlos zugegriffen werden kann. Sie müssen in der Lage sein, Dateien zu erstellen, Daten einzufügen bzw. zu ändern und auszugeben (lesen). Da das Speichern von Daten in Datenbanken, wie zum Beispiel in Access oder SQL Server, einen beträchtlichen Verwaltungsaufwand für Ihre Anwendung mit sich bringt, stellen Binär- oder Textdateien die wohl effizienteste Lösung dar. Möglicherweise haben Sie diesen Verwaltungsaufwand aber auch nicht, oder die Anforderungen an den Datenzugriff erfordern nicht den Einsatz sämtlicher integrierter Funktionsmerkmale einer komplexen Datenbankanwendung.

Das in der Scripting-Typbibliothek (Scrrun.dll) integrierte FSO-Objektmodell unterstützt das Erstellen und Bearbeiten von Textdateien mithilfe des TextStream-Objekts. Das Erstellen und Bearbeiten von Binärdateien wird derzeit zwar noch nicht unterstützt, jedoch ist dies für zukünftige Entwicklungen geplant.


FileSystemObject-Objekte

Microsoft® Scripting-Bibliothek - FileSystemObject
FileSystemObject-Objekte
 Zurück
Weiter

Das FileSystemObject-Objektmodell (FSO) enthält die folgenden Objekte und Auflistungen.

Objekt/Auflistung | Beschreibung
FileSystemObject | Hauptobjekt. Enthält Methoden und Eigenschaften sowohl zum Erstellen, Löschen sowie Abrufen von Informationen zu als auch allgemein zum Ändern von Laufwerken, Ordnern und Dateien. Zahlreiche der mit diesem Objekt verknüpften Methoden entsprechen denen in anderen FSO-Objekten; die Bereitstellung dient lediglich einer benutzerfreundlicheren Handhabung.
Drive | Objekt. Enthält Methoden und Eigenschaften zum Abrufen von Informationen zu einem systemintegrierten Laufwerk, wie beispielsweise dem Freigabenamen oder dem verfügbaren Speicherplatz. Beachten Sie dabei jedoch, dass ein "Laufwerk" nicht notwendigerweise mit einer Festplatte gleichgesetzt werden kann, da es sich auch um ein CD-ROM-, ein RAM-Laufwerk oder Ähnliches handeln kann. Ein Laufwerk muss nicht physisch im System integriert sein. Es kann sich auch um ein logisches Laufwerk handeln, das über ein Netzwerk verbunden ist.
Drives | Auflistung. Stellt eine Übersicht der in das System eingebundenen physischen oder logischen Laufwerke bereit. Die Drives-Auflistung umfasst alle Laufwerke, ungeachtet des Types. In Laufwerken mit austauschbaren Datenträgern müssen keine Datenträger eingelegt sein, damit diese in der Auflistung angezeigt werden.
File | Objekt. Enthält Methoden und Eigenschaften zum Erstellen, Löschen sowie Verschieben von Dateien. Darüber hinaus können Sie Systemabfragen nach einem Dateinamen und -pfad sowie anderen Eigenschaften durchführen.
Files | Auflistung. Stellt eine Übersicht sämtlicher in einem Ordner enthaltenen Dateien bereit.
Folder | Objekt. Enthält Methoden und Eigenschaften zum Erstellen, Löschen sowie Verschieben von Ordnern. Darüber hinaus können Sie Systemabfragen nach einem Ordnernamen und -pfad sowie anderen Eigenschaften durchführen.
Folders | Auflistung. Stellt eine Übersicht sämtlicher in einem Folder-Objekt enthaltenen Ordner bereit.
TextStream | Objekt. Ermöglicht Ihnen das Lesen und Schreiben von Textdateien.


Programmieren des FileSystemObject-Objekts

Microsoft® Scripting-Bibliothek - FileSystemObject
Programmieren des FileSystemObject-Objekts
 Zurück
Weiter

So programmieren Sie mit dem FileSystemObject-Objektmodell (FSO):

  • Verwenden Sie die CreateObject-Methode, um ein FileSystemObject-Objekt zu erstellen.
  • Wenden Sie die entsprechenden Methoden auf das neu erstellte Objekt an.
  • Greifen Sie auf die Eigenschaften des Objekts zu.
Das FSO-Objektmodell ist in der Scripting-Typbibliothek enthalten, die sich in der Datei Scrrun.dll befindet. Die Datei Scrrun.dll muss sich daher im entsprechenden Systemverzeichnis auf dem Webserver befinden, um das FSO-Objektmodell verwenden zu können.

Erstellen eines FileSystemObject-Objekts
Erstellen Sie mit der CreateObject-Methode zunächst ein FileSystemObject-Objekt. Verwenden Sie in VBScript den folgenden Code, um eine Instanz von FileSystemObject zu erstellen:

Dim fso
Set fso = CreateObject("Scripting.FileSystemObject")
Dieser Beispielcode zeigt, wie eine Instanz von FileSystemObject erstellt wird.

In JScript verwenden Sie den folgenden Code für die Erstellung:

var fso;
fso = new ActiveXObject("Scripting.FileSystemObject");
In beiden Fällen ist Scripting der Name der Typbibliothek und FileSystemObject der Name des zu erstellenden Objekts. Sie können nur jeweils eine Instanz des FileSystemObject-Objekts erstellen, unabhängig von der Anzahl der Versuche.

Verwenden der geeigneten Methode
Verwenden Sie dann die geeignete Methode des FileSystemObject-Objekts. Wenn Sie beispielsweise ein neues Objekt erstellen möchten, verwenden Sie entweder CreateTextFile oder CreateFolder (das FSO-Objektmodell unterstützt keine Vorgänge zum Erstellen oder Löschen von Laufwerken).

Sie löschen Objekte, indem Sie die DeleteFile- und DeleteFolder-Methoden des FileSystemObject-Objekts oder die Delete-Methode der File- und Folder-Objekte verwenden. Sie können Dateien und Ordner auch kopieren oder verschieben, indem Sie die entsprechenden Methoden einsetzen.

Anmerkung Im FileSystemObject-Objektmodell sind einige Funktionalitätsmerkmale redundant. Beispielsweise können Sie eine Datei über die CopyFile-Methode des FileSystemObject-Objekts oder die Copy-Methode des File-Objekts kopieren. Die Funktionsweise ist bei beiden Methoden gleich; die zwei verschiedenen Methoden sind vorhanden, um eine gewisse Flexibilität beim Programmieren zu gewährleisten.

Zugreifen auf vorhandene Laufwerke, Dateien und Ordner
Verwenden Sie die entsprechende "Get"-Methode des FileSystemObject-Objekts, um auf die vorhandenen Laufwerke, Dateien oder Ordner zuzugreifen:

  • GetDrive
  • GetFolder
  • GetFile
So können Sie in VBScript auf eine vorhandene Datei zugreifen:

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
Set f1 = fso.GetFile("c:\test.txt")
Für JScript verwenden Sie hierfür den folgenden Code:

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
f1 = fso.GetFile("c:\\test.txt");
Verwenden Sie die "Get"-Methoden nicht für neu erstellte Objekte, da die "Create"-Funktionen bereits einen Zeiger auf das Objekt zurückgeben. Wenn Sie beispielsweise mit der CreateFolder-Methode einen neuen Ordner erstellen, verwenden Sie nicht die GetFolder-Methode, um auf die zugehörigen Eigenschaften (wie z. B. Name, Path oder Size) zuzugreifen. Setzen Sie einfach eine Variable auf die CreateFolder-Funktion, um einen Zeiger auf den neu erstellten Ordner zu setzen, und greifen Sie dann auf die Eigenschaften, Methoden und Ereignisse zu. Verwenden Sie dazu in VBScript den folgenden Code:

Sub ErzeugeOrdner
  Dim fso, ordner
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set ordner = fso.CreateFolder("C:\MeinTest")
  document.write "Erstellter Ordner: " & ordner.Name
End Sub
Verwenden Sie in JScript die folgende Syntax, um eine Variable auf die CreateFolder-Funktion zu setzen:

function ErzeugeOrdner()
{
  var fso, ordner;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  ordner = fso.CreateFolder("C:\\MeinTest");
  document.write("Erstellter Ordner: " + ordner.Name);
}
Zugreifen auf die Eigenschaften des Objekts
Nachdem Sie über einen Zeiger auf das Objekt verfügen, können Sie auf dessen Eigenschaften zugreifen. Wenn Sie beispielsweise den Namen eines bestimmten Ordners abrufen möchten, erstellen Sie zunächst eine Instanz des Objekts und dann mit der entsprechenden Methode (in diesem Fall mit der GetFolder-Methode, da der Ordner bereits vorhanden ist) einen Zeiger darauf.

Verwenden Sie in VBScript diesen Code, um einen Zeiger auf die GetFolder-Methode zu legen:

Set ordner = fso.GetFolder("c:")

Für JScript verwenden Sie hierfür den folgenden Code:

var ordner = fso.GetFolder("c:\\");
Da Sie jetzt über einen Zeiger auf das Folder-Objekt verfügen, können Sie seine Name-Eigenschaft prüfen. Verwenden Sie hierfür in VBScript den folgenden Code:

document.write "Ordnername: " & ordner.Name
Verwenden Sie die folgende Syntax, um in JScript eine Name-Eigenschaft zu prüfen:

document.write("Ordnername: " + ordner.Name);
Verwenden Sie die folgende Syntax, um in VBScript anzuzeigen, wann eine Datei zuletzt geändert wurde:

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
' Lädt ein zu prüfendes File-Objekt.
Set f1 = fso.GetFile("c:\detlog.txt")
' Gibt die Informationen aus.
document.write "Datei zuletzt geändert am: " & f1.DateLastModified
Für JScript verwenden Sie hierfür den folgenden Code:

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
// Lädt ein zu prüfendes File-Objekt.
f1 = fso.GetFile("c:\\detlog.txt");
// Gibt die Informationen aus.
document.write("Datei zuletzt geändert am: " + f1.DateLastModified);


Arbeiten mit Laufwerken und Ordnern

Microsoft® Scripting-Bibliothek - FileSystemObject
Arbeiten mit Laufwerken und Ordnern
 Zurück
Weiter

So wie Sie mit Laufwerken und Ordnern im Windows-Explorer interaktiv arbeiten, können Sie mit dem FileSystemObject-Objektmodell (FSO) programmgesteuert arbeiten. Sie können unter anderem Ordner kopieren und verschieben sowie Informationen zu Laufwerken und Ordnern abrufen.

Abrufen von Informationen zu Laufwerken
Mit dem Drive-Objekt können Sie sich Informationen zu den verschiedenen in das System eingebundenen physischen oder Netzlaufwerken anzeigen lassen. Durch die zugehörigen Eigenschaften erhalten Sie die folgenden Informationen:

  • Gesamtgröße des Laufwerkes in Byte (TotalSize-Eigenschaft)
  • Verfügbarer Speicherplatz auf dem Laufwerk in Byte (AvailableSpace- oder FreeSpace-Eigenschaft)
  • Zugeordneter Laufwerkbuchstabe (DriveLetter-Eigenschaft)
  • Laufwerktyp, wie beispielsweise austauschbarer bzw. fester Datenträger, Netzwerk-, CD-ROM- bzw. RAM-Laufwerk (DriveType-Eigenschaft)
  • Seriennummer des Laufwerkes (SerialNumber-Eigenschaft)
  • Mit dem Laufwerk verwendetes Dateisystem, wie z. B. FAT, FAT32, NTFS usw. (FileSystem-Eigenschaft)
  • Status zur Verfügbarkeit des Laufwerkes (IsReady-Eigenschaft)
  • Freigabe- und/oder Datenträgername (ShareName- und VolumeName-Eigenschaft)
  • Pfad oder Stammverzeichnis des Laufwerkes (Path- und Folder-Eigenschaft)
Praktische Beispiele zur Verwendung dieser Eigenschaften mit FileSystemObject finden Sie unter Beispielcode.

Beispiel zur Verwendung des Drive-Objekts
Verwenden Sie das Drive-Objekt, um Informationen zu einem Laufwerk zu erhalten. Im nachstehenden Code befindet sich kein Verweis auf ein tatsächliches Drive-Objekt; verwenden Sie daher die GetDrive-Methode, um einen Verweis auf ein vorhandenes Drive-Objekt zu erhalten (in diesem Fall auf lw).

Das folgende Beispiel zeigt die Verwendung des Drive-Objekts in VBScript:

Sub ZeigeLWInfo(lwPfad)
  Dim fso, lw, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set lw = fso.GetDrive(fso.GetDriveName(lwPfad))
  s = "Laufwerk" & UCase(lwPfad) & " - "
  s = s & lw.VolumeName & "<br>"
  s = s & "Speicherplatz insgesamt: " & FormatNumber(lw.TotalSize / 1024, 0)
  s = s & " KB" & "<br>"
  s = s & "Freier Speicherplatz: " & FormatNumber(lw.FreeSpace / 1024, 0)
  s = s & " KB" & "<br>"
  document.write s
End Sub
Der folgende Code zeigt die gleiche Funktionalität in JScript:
function ZeigeLWInfo1(lwPfad)
{
  var fso, lw, s ="";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  lw = fso.GetDrive(fso.GetDriveName(lwPfad));
  s += "Laufwerk " + lwPfad.toUpperCase()+ " - ";
  s += lw.VolumeName + "<br>";
  s += "Speicherplatz insgesamt: " + lw.TotalSize / 1024;
  s += " KB" + "<br>";
  s += "Freier Speicherplatz: " + lw.FreeSpace / 1024;
  s += " KB" + "<br>";
  document.write(s);
}
Arbeiten mit Ordnern
In der nachstehenden Tabelle werden allgemeine Aufgaben mit Ordnern sowie dazu passende Methoden beschrieben.

Aufgabe | Methode
Einen Ordner erstellen. | FileSystemObject.CreateFolder
Einen Ordner löschen. | Folder.Delete oder FileSystemObject.DeleteFolder
Einen Ordner verschieben. | Folder.Move oder FileSystemObject.MoveFolder
Einen Ordner kopieren. | Folder.Copy oder FileSystemObject.CopyFolder
Einen Ordnernamen abrufen. | Folder.Name
Feststellen, ob ein Ordner auf einem Laufwerk vorhanden ist. | FileSystemObject.FolderExists
Eine Instanz eines vorhandenen Folder-Objekts laden. | FileSystemObject.GetFolder
Den Namen des übergeordneten Ordners eines angegebenen Ordners suchen. | FileSystemObject.GetParentFolderName
Den Pfad von Systemordnern suchen. | FileSystemObject.GetSpecialFolder

Informationen zur Anzahl der in FileSystemObject verwendeten Methoden und Eigenschaften finden Sie unter Beispielcode.

Das nachstehende Beispiel zeigt die Verwendung der Folder- und FileSystemObject-Objekte, um in VBScript Ordner zu bearbeiten und Informationen zu diesen zu erhalten:

Sub ZeigeOrdnerInfo()
  Dim fso, ordner, s
  ' Lesen einer Instanz von FileSystemObject.
  Set fso = CreateObject("Scripting.FileSystemObject")
  ' Lesen des Drive-Objekts.
  Set ordner = fso.GetFolder("c:")
  ' Ausgeben des Namens des übergeordneten Ordners.
  document.write "Name des übergeordneten Ordners ist: " & ordner & "<br>"
  ' Ausgeben des Laufwerknamens.
  document.write "Enthalten auf Laufwerk " & ordner.Drive & "<br>"
  ' Ausgeben des Stammdateinamens.
  If ordner.Is Folder = True Then
    document.write "Dies ist der Stammordner." & "<br><br>"
  Else
    document.write "Dieser Ordner ist kein Stammordner." & "<br><br>"
  End If
  ' Erstellen eines neuen Ordners mit dem FileSystemObject-Objekt.
  fso.CreateFolder ("C:\Test")
  document.write "Ordner C:\Test erstellt" & "<br>"
  ' Ausgeben des Basisnamens des Ordners.
  document.write "Basisname= " & fso.GetBaseName("c:\Test") & "<br>"
  ' Löschen des soeben angelegten Ordners.
  fso.DeleteFolder("C:\Test")
  document.write "Ordner C:\Test gelöscht" & "<br>"
End Sub
Dieses Beispiel zeigt die Verwendung der Folder- und FileSystemObject-Objekte in JScript:
function ZeigeOrdnerInfo()
{
  var fso, ordner, s = "";
  // Lesen einer Instanz von FileSystemObject.
  fso = new ActiveXObject("Scripting.FileSystemObject");
  // Lesen des Drive-Objekts.
  ordner = fso.GetFolder("c:");
  // Ausgeben des Namens des übergeordneten Ordners.
  document.write("Name des übergeordneten Ordners ist: " + ordner + "<br>");
  // Ausgeben des Laufwerknamens.
  document.write("Enthalten auf Laufwerk " + ordner.Drive + "<br>");
  // Ausgeben des Stammdateinamens.
  if (ordner.Is Folder)
    document.write("Dies ist der Stammordner.");
  else
    document.write("Dieser Ordner ist kein Stammordner.");
  document.write("<br><br>");
  // Erstellen eines neuen Ordners mit dem FileSystemObject-Objekt.
  fso.CreateFolder ("C:\\Test");
  document.write("Ordner C:\\Test erstellt" + "<br>");
  // Ausgeben des Basisnamens des Ordners.
  document.write("Basisname = " + fso.GetBaseName("c:\\Test") + "<br>");
  // Löschen des soeben angelegten Ordners.
  fso.DeleteFolder ("C:\\Test");
  document.write("Ordner C:\\Test gelöscht" + "<br>");
}


Arbeiten mit Dateien

Microsoft® Scripting-Bibliothek - FileSystemObject
Arbeiten mit Dateien
 Zurück
Weiter

Beim Bearbeiten von Dateien sind die folgenden beiden Hauptkategorien zu unterscheiden:

  • Erstellen, Hinzufügen bzw. Entfernen von Daten sowie Lesen von Dateien
  • Verschieben, Kopieren und Löschen von Dateien
Erstellen von Dateien
Es gibt drei Möglichkeiten, eine leere Textdatei (auch als "text stream" bezeichnet) zu erstellen.

Die erste Möglichkeit besteht in der Verwendung der CreateTextFile-Methode. Das folgende Beispiel zeigt das Erstellen einer Textdatei mit dieser Methode mit VBScript:

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
Set f1 = fso.CreateTextFile("c:\test.txt", True)
In JScript verwenden Sie hierfür diesen Code:

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
f1 = fso.CreateTextFile("c:\\test.txt", true);
Praktische Beispiele zur Verwendung der CreateTextFile-Methode mit FileSystemObject finden Sie unter Beispielcode.

Die zweite Möglichkeit zum Erstellen einer Textdatei ist die Verwendung der OpenTextFile-Methode des FileSystemObject-Objekts mit gesetztem Schreibattribut. In VBScript sieht der Code folgendermaßen aus:

Dim fso, ts
Const ForWriting = 2
Set fso = CreateObject("Scripting.FileSystemObject")
Set ts = fso.OpenTextFile("c:\test.txt", ForWriting, True)
Zum Erstellen einer Textdatei mit dieser Methode unter JScript verwenden Sie diesen Code:

var fso, ts;
var ForWriting = 2;
fso = new ActiveXObject("Scripting.FileSystemObject");
ts = fso.OpenTextFile("c:\\test.txt", ForWriting, true);
Eine dritte Möglichkeit ist die Verwendung der OpenAsTextStream-Methode mit gesetztem Schreibattribut. Verwenden Sie in VBScript für diese Methode den folgenden Code:

Dim fso, f1, ts
Const ForWriting = 2
Set fso = CreateObject("Scripting.FileSystemObject")
fso.CreateTextFile ("c:\test1.txt")
Set f1 = fso.GetFile("c:\test1.txt")
Set ts = f1.OpenAsTextStream(ForWriting, True)
Verwenden Sie in JScript den Code des folgenden Beispiels:

var fso, f1, ts;
var ForWriting = 2;
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CreateTextFile ("c:\\test1.txt");
f1 = fso.GetFile("c:\\test1.txt");
ts = f1.OpenAsTextStream(ForWriting, true);
Hinzufügen von Daten zu einer Datei
Nachdem Sie eine Textdatei erstellt haben, fügen Sie entsprechend der folgenden drei Schritte Daten ein:

  1. Öffnen Sie die Textdatei.
  2. Schreiben Sie die Daten.
  3. Schließen Sie die Datei.
Verwenden Sie zum Öffnen einer vorhandenen Datei entweder die OpenTextFile-Methode des FileSystemObject-Objekts oder die OpenAsTextStream-Methode des File-Objekts.

Verwenden Sie zum Schreiben von Daten in die geöffnete Textdatei je nach Aufgabe die Write-, WriteLine- oder die WriteBlankLines-Methode des TextStream-Objekts (siehe folgende Tabelle).

Aufgabe | Methode
Schreiben von Daten in eine geöffnete Textdatei ohne nachstehendes Zeilenumbruchzeichen. | Write
Schreiben von Daten in eine geöffnete Textdatei mit nachstehendem Zeilenumbruchzeichen. | WriteLine
Schreiben einer oder mehrerer Leerzeilen in eine geöffnete Textdatei. | WriteBlankLines

Praktische Beispiele zur Verwendung der Write-, WriteLine- und WriteBlankLines-Methoden mit FileSystemObject finden Sie unter Beispielcode.

Verwenden Sie zum Schließen einer geöffneten Datei die Close-Methode des TextStream-Objekts.

Beispiele zur Verwendung der Close-Methode mit FileSystemObject finden Sie unter Beispielcode.

Anmerkung Das Zeilenumbruchzeichen enthält ein oder mehrere Zeichen (je nach Betriebssystem), die die Einfügemarke am Beginn einer neuen Zeile positionieren (Wagenrücklauf/Zeilenvorschub). Achten Sie darauf, dass einige Zeichenfolgen diese nicht darstellbaren Zeichen bereits aufweisen.

Das folgende VBScript-Beispiel zeigt, wie eine Datei geöffnet wird, wie die drei Schreibmethoden zum Hinzufügen von Daten verwendet werden und die Datei anschließend geschlossen wird:

Sub ErzeugeDatei()
  Dim fso, tf
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set tf = fso.CreateTextFile("c:\test.txt", True)
  ' Zeile mit Zeilenumbruchzeichen schreiben.
  tf.WriteLine("Test 1, 2, 3.")
  ' Drei Zeilenumbruchzeichen in die Datei schreiben.
  tf.WriteBlankLines(3)
  ' Eine Zeile schreiben.
  tf.Write ("Dies ist ein Test.")
  tf.Close
End Sub
Dieses Beispiel zeigt die Verwendung dieser drei Methoden in JScript:

function ErzeugeDatei()
{
  var fso, tf;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  tf = fso.CreateTextFile("c:\\test.txt", true);
  // Eine Zeile mit Zeilenumbruchzeichen schreiben.
  tf.WriteLine("Test 1, 2, 3.") ;
  // Drei Zeilenumbruchzeichen in die Datei schreiben.
  tf.WriteBlankLines(3) ;
  // Eine Zeile schreiben.
  tf.Write ("Dies ist ein Test.");
  tf.Close();
}
Lesen von Dateien
Verwenden Sie zum Lesen von Daten in einer Textdatei die Read-, ReadLine- oder ReadAll-Methode des TextStream-Objekts. Die folgende Tabelle erläutert die für die verschiedenen Aufgaben zu verwendenden Methoden.

Aufgabe | Methode
Lesen einer bestimmten Zeichenanzahl aus einer Datei. | Read
Lesen einer vollständigen Zeile (bis zum Zeilenumbruchzeichen, aber nicht einschließlich des Zeichens). | ReadLine
Lesen des gesamten Inhalts einer Textdatei. | ReadAll

Beispiele zur Verwendung der ReadAll- und ReadLine-Methoden mit FileSystemObject finden Sie unter Beispielcode.

Wenn Sie die Read- oder ReadLine-Methode verwenden und einen bestimmten Datenbereich überspringen möchten, verwenden Sie die Skip- oder SkipLine-Methode. Der resultierende Text dieser Lesemethoden wird in einer Zeichenfolge gespeichert, die dann z. B. in einem Steuerelement angezeigt, von Zeichenfolgenfunktionen analysiert (z. B. Left, Right und Mid) oder verkettet werden kann.

Das folgende VBScript-Beispiel zeigt das Öffnen einer Datei, das Schreiben sowie das Lesen aus dieser:

Sub LeseDatei
  Dim fso, f1, ts, s
  Const ForReading = 1
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f1 = fso.CreateTextFile("c:\test.txt", True)
  ' Eine Zeile schreiben.
  document.write "Schreibvorgang in Datei <br>"
  f1.WriteLine "Hallo Welt"
  f1.WriteBlankLines(1)
  f1.Close
  ' Inhalt der Datei lesen.
  document.write "Lesevorgang aus Datei <br>"
  Set ts = fso.OpenTextFile("c:\test.txt", ForReading)
  s = ts.ReadLine
  document.write "Dateiinhalt = '" & s & "'"
  ts.Close
End Sub
Der nachfolgende Code zeigt die gleichen Vorgänge in JScript:

function LeseDatei()
{
  var fso, f1, ts, s;
  var ForReading = 1;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f1 = fso.CreateTextFile("c:\\test.txt", true);
  // Eine Zeile schreiben.
  document.write("Schreibe Datei <br>");
  f1.WriteLine("Hallo Welt");
  f1.WriteBlankLines(1);
  f1.Close();
  // Inhalt der Datei lesen.
  document.write("Lese Datei <br>");
  ts = fso.OpenTextFile("c:\\test.txt", ForReading);
  s = ts.ReadLine();
  document.write("Dateiinhalt = '" + s + "'");
  ts.Close();
}
Verschieben, Kopieren und Löschen von Dateien
Das FSO-Objektmodell verfügt - wie in der nachstehenden Tabelle beschrieben - über jeweils zwei Methoden zum Verschieben, Kopieren und Löschen von Dateien.

Aufgabe | Methode
Verschieben einer Datei | File.Move oder FileSystemObject.MoveFile
Kopieren einer Datei | File.Copy oder FileSystemObject.CopyFile
Löschen einer Datei | File.Delete oder FileSystemObject.DeleteFile

Die beiden Möglichkeiten zum Löschen einer Datei mit FileSystemObject finden Sie unter Beispielcode.

Das folgende VBScript-Beispiel erstellt eine Textdatei im Stammverzeichnis von Laufwerk C, schreibt Daten in die Datei, verschiebt diese anschließend in das Verzeichnis \tmp, erstellt eine Kopie im Verzeichnis \temp und löscht dann die Kopien in beiden Verzeichnissen.

Erstellen Sie im Stammverzeichnis von Laufwerk C die beiden Verzeichnisse \tmp und \temp, um das folgende Beispiel ausführen zu können:

Sub BearbeiteDateien
  Dim fso, f1, f2, f3, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f1 = fso.CreateTextFile("c:\test.txt", True)
  document.write "Schreibvorgang in Datei <br>"
  ' Eine Zeile schreiben.
  f1.Write ("Dies ist ein Test.")
  ' Schließen der Datei zum Schreiben.
  f1.Close
  document.write "Datei verschieben nach c:\tmp <br>"
  ' Holen eines Zeigers für die Datei im Stamm von C:\.
  Set f2 = fso.GetFile("c:\test.txt")
  ' Verschieben der Datei in das Verzeichnis \tmp.
  f2.Move ("c:\tmp\test.txt")
  document.write "Datei kopieren nach c:\temp <br>"
  ' Kopieren der Datei nach \temp.
  f2.Copy ("c:\temp\test.txt")
  document.write "Löschen von Dateien <br>"
  ' Holen von Zeigern für den aktuellen Pfad der Dateien.
  Set f2 = fso.GetFile("c:\tmp\test.txt")
  Set f3 = fso.GetFile("c:\temp\test.txt")
  ' Löschen der Dateien.
  f2.Delete
  f3.Delete
  document.write "Alle bearbeitet!"
End Sub
Dieser Code zeigt die gleichen Vorgänge in JScript:

function BearbeiteDateien()
{
  var fso, f1, f2, f3, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f1 = fso.CreateTextFile("c:\\test.txt", true);
  document.write("Schreibe Datei <br>");
  // Eine Zeile schreiben.
  f1.Write("Dies ist ein Test.");
  // Schließen der Datei zum Schreiben.
  f1.Close();
  document.write("Verschieben der Datei nach c:\\tmp <br>");
  // Holen eines Zeigers für die Datei im Stamm von C:\.
  f2 = fso.GetFile("c:\\test.txt");
  // Verschieben der Datei in das Verzeichnis \tmp.
  f2.Move("c:\\tmp\\test.txt");
  document.write("Kopieren der Datei nach c:\\temp <br>");
  // Kopieren der Datei nach \temp.
  f2.Copy ("c:\\temp\\test.txt");
  document.write("Lösche Dateien <br>");
  // Holen von Zeigern für den aktuellen Pfad der Dateien.
  f2 = fso.GetFile("c:\\tmp\\test.txt");
  f3 = fso.GetFile("c:\\temp\\test.txt");
  // Löschen der Dateien.
  f2.Delete();
  f3.Delete();
  document.write("Alle bearbeitet!");
}


FileSystemObject-Beispielcode

Microsoft® Scripting-Bibliothek - FileSystemObject
FileSystemObject-
Beispielcode
 Zurück

Der in diesem Abschnitt beschriebene Beispielcode stellt ein reales Beispiel dar, das der Veranschaulichung zahlreicher, im FileSystemObject-Objektmodell verfügbarer Funktionsmerkmale dient. Dieser Code zeigt das Zusammenwirken aller Funktionsmerkmale des Objektmodells und soll Ihnen den effektiven Einsatz in Ihrem eigenen Code verständlich darlegen.

Beachten Sie, dass dieser Code recht allgemein gehalten ist. Zusätzlicher Code und kleine Änderungen sind erforderlich, um ihn tatsächlich auf Ihrem Computer ausführen zu können. Diese Änderungen sind aufgrund der unterschiedlichen Möglichkeiten notwendig, die beim Zusammenwirken zwischen Active Server Pages und Windows Scripting Host für die Ein- und Ausgabe zum Benutzer verwendet werden.

Gehen Sie folgendermaßen vor, um diesen Code auf einer Active Server Page auszuführen:

  1. Erstellen Sie eine herkömmliche Webseite mit der Dateinamenerweiterung ASP.
  2. Kopieren Sie den nachstehenden Beispielcode in diese Datei zwischen die Tags <BODY>...</BODY>.
  3. Schließen Sie den gesamten Code in <%...%>-Tags ein.
  4. Verschieben Sie die Option Explicit-Anweisung von der aktuellen Codeposition ganz nach oben an den HTML-Seitenanfang vor das eröffnende <HTML>-Tag.
  5. Setzen Sie <%...%>-Tags um die Option Explicit-Anweisung, um sicherzustellen, dass sie serverseitig ausgeführt wird.
  6. Fügen Sie den nachstehenden Code am Ende des Beispielcodes hinzu:
Sub Ausgabe(x)
  Response.Write "<PRE><FONT FACE=""Courier New"" SIZE=""1"">"
  Response.Write x
  Response.Write "</FONT></PRE>"
End Sub
Main
Der Code weiter oben fügt eine Druckprozedur hinzu, die zwar serverseitig ausgeführt wird, deren Ergebnisse jedoch clientseitig angezeigt werden. Fügen Sie den folgenden Code am Ende des Beispielcodes ein, um diesen auf dem Windows Scripting Host auszuführen:
Sub Ausgabe(x)
    WScript.Echo x
End Sub
Main
Der Code ist im nachstehenden Abschnitt enthalten:

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' FileSystemObject-Beispielcode
'
' Copyright 1998 Microsoft Corporation.  Alle Rechte vorbehalten.
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Option Explicit

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Informationen zur Codequalität:
'
' 1) Der folgende Code führt eine Anzahl von Zeichenfolgenmanipulationen aus. Dabei werden kurze
'    Zeichenfolgen mit dem Operator "&" verkettet. Da Zeichenfolgenverkettungen lange dauern,
'    ist dieser Code nicht sehr effizient. Es ist jedoch ein sehr gängiger Weg zum Schreiben
'    von Code. Dieser Weg wird hier verwendet, da dieses Programm intensive Festplattenoperationen
'    ausführt und diese Operationen wesentlich langsamer als die Operationen zum Verketten der Zeichenfolgen
'    im Speicher sind. Beachten Sie auch, dass dieser Code zu Demonstrationszwecken geschrieben wurde.
'
' 2) Es wird "Option Explicit" verwendet, da der Zugriff auf deklarierte Variablen etwas schneller als
'    der Zugriff auf undeklarierte Variablen ist. Außerdem wird so das Entstehen von Fehlern im Code verhindert,
'    wie z. B. durch den Schreibfehler DriveTypeCDORM statt DriveTypeCDROM.
'
' 3) In diesem Code wurde keine Fehlerbehandlung vorgesehen. Der Code ist so besser lesbar. Obwohl
'    Vorkehrungen zum Verhindern von Fehlern in normalen Fällen getroffen wurden, können sich
'    Dateisysteme eventuell unvorhersehbar verhalten. In kommerziellem Code sollten Sie "On Error Resume Next"
'    und das Err-Objekt verwenden, um mögliche Fehler abzufangen.
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Einige hilfreiche globale Variablen
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Dim Tabulator
Dim NeueZeile

Const TestLW = "C"
Const TestDateiPfad = "C:\Test"

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Von Drive.DriveType zurückgegebene Konstanten
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const DriveTypeWechselbar = 1
Const DriveTypeFest = 2
Const DriveTypeNetzwerk = 3
Const DriveTypeCDROM = 4
Const DriveTypeRAMLW = 5

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Von File.Attributes zurückgegebene Konstanten
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const AttributNormal = 0
Const AttributSchreibgesch = 1
Const AttributVersteckt = 2
Const AttributSystem = 4
Const AttributDatentr = 8
Const AttributVerzeichnis = 16
Const AttributArchiv = 32
Const AttributAlias = 64
Const AttributKomprimiert = 128

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Konstanten zum Öffnen von Dateien
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const DateiOeffnenZumLesen = 1
Const DateiOeffnenZumSchreiben = 2
Const DateiOeffnenZumAnfuegen = 8

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ZeigeLWTyp
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den Laufwerktyp eines angegebenen Drive-Objekts beschreibt.
'
' Zeigt Folgendes
'
' - Drive.DriveType
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ZeigeLWTyp(LW)

    Dim S

    Select Case LW.DriveType
    Case DriveTypeWechselbar
        S = "Wechselmedium"
    Case DriveTypeFest
        S = "Fest"
    Case DriveTypeNetzwerk
        S = "Netzwerk"
    Case DriveTypeCDROM
        S = "CD-ROM"
    Case DriveTypeRAMLW
        S = "RAM-Laufwerk"
    Case Else
        S = "Unbekannt"
    End Select

    ZeigeLWTyp = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ZeigeDateiAttribute
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die Datei- oder Ordnerattribute beschreibt.
'
' Zeigt Folgendes
'
' - File.Attributes
' - Folder.Attributes
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ZeigeDateiAttribute(Datei) ' Datei kann Datei oder Ordner sein

    Dim S
      Dim Attr

    Attr = Datei.Attributes

    If Attr = 0 Then
        ZeigeDateiAttribute = "Normal"
        Exit Function
    End If

    If Attr And AttributVerzeichnis  Then S = S & "Verzeichnis "
    If Attr And AttributSchreibgesch   Then S = S & "Schreibgeschützt "
    If Attr And AttributVersteckt     Then S = S & "Versteckt "
    If Attr And AttributSystem     Then S = S & "System "
    If Attr And AttributDatentr     Then S = S & "Datenträger "
    If Attr And AttributArchiv    Then S = S & "Archiv "
    If Attr And AttributAlias      Then S = S & "Alias "
    If Attr And AttributKomprimiert Then S = S & "Komprimiert "

    ZeigeDateiAttribute = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ErzeugeLWInformation
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den aktuellen Status der verfügbaren Laufwerke beschreibt.
'
' Zeigt Folgendes
'
' - FileSystemObject.Drives
' - Iteration der Drives-Auflistung
' - Drives.Count
' - Drive.AvailableSpace
' - Drive.DriveLetter
' - Drive.DriveType
' - Drive.FileSystem
' - Drive.FreeSpace
' - Drive.IsReady
' - Drive.Path
' - Drive.SerialNumber
' - Drive.ShareName
' - Drive.TotalSize
' - Drive.VolumeName
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ErzeugeLWInformation(FSO)

    Dim LWs
    Dim LW
    Dim S

    Set LWs = FSO.Drives

    S = "Anzahl der Laufwerke:" & Tabulator & LWs.Count & NeueZeile & NeueZeile

    ' Erstellt die erste Zeile des Berichts.
    S = S & String(2, Tabulator) & "Laufwerk"
    S = S & String(3, Tabulator) & "Datei"
    S = S & Tabulator & "Gesamt"
    S = S & Tabulator & "Frei"
    S = S & Tabulator & "Verfügbar"
    S = S & Tabulator & "Seriennummer" & NeueZeile

    ' Erstellt die zweite Zeile des Berichts.
    S = S & "Laufwerkbuchstabe"
    S = S & Tabulator & "Pfad"
    S = S & Tabulator & "Typ"
    S = S & Tabulator & "Bereit?"
    S = S & Tabulator & "Name"
    S = S & Tabulator & "System"
    S = S & Tabulator & "Speicherplatz"
    S = S & Tabulator & "Speicherplatz"
    S = S & Tabulator & "Speicherplatz"
    S = S & Tabulator & "Nummer" & NeueZeile

    ' Trennlinie.
    S = S & String(105, "-") & NeueZeile

    For Each LW In LWs

        S = S & LW.DriveLetter
        S = S & Tabulator & LW.Path
        S = S & Tabulator & ZeigeLWTyp(LW)
        S = S & Tabulator & LW.IsReady

        If LW.IsReady Then
            If DriveTypeNetzwerk = LW.DriveType Then
                S = S & Tabulator & LW.ShareName
            Else
                S = S & Tabulator & LW.VolumeName
            End If

            S = S & Tabulator & LW.FileSystem
            S = S & Tabulator & LW.TotalSize
            S = S & Tabulator & LW.FreeSpace
            S = S & Tabulator & LW.AvailableSpace
            S = S & Tabulator & Hex(LW.SerialNumber)

        End If

        S = S & NeueZeile

    Next

    ErzeugeLWInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ErzeugeDateiInformation
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den aktuellen Status einer Datei beschreibt.
'
' Zeigt Folgendes
'
' - File.Path
' - File.Name
' - File.Type
' - File.DateCreated
' - File.DateLastAccessed
' - File.DateLastModified
' - File.Size
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ErzeugeDateiInformation(Datei)

    Dim S

    S = NeueZeile & "Pfad:" & Tabulator & Datei.Path
    S = S & NeueZeile & "Name:" & Tabulator & Datei.Name
    S = S & NeueZeile & "Typ:" & Tabulator & Datei.Type
    S = S & NeueZeile & "Attribute:" & Tabulator & ZeigeDateiAttribute(Datei)
    S = S & NeueZeile & "Erstellt:" & Tabulator & Datei.DateCreated
    S = S & NeueZeile & "Letzter Zugriff:" & Tabulator & Datei.DateLastAccessed
    S = S & NeueZeile & "Letzte Änderung:" & Tabulator & Datei.DateLastModified
    S = S & NeueZeile & "Größe" & Tabulator & Datei.Size & NeueZeile

    ErzeugeDateiInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ErzeugeOrdnerInformation
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den aktuellen Status eines Ordners beschreibt.
'
' Zeigt Folgendes
'
' - Folder.Path
' - Folder.Name
' - Folder.DateCreated
' - Folder.DateLastAccessed
' - Folder.DateLastModified
' - Folder.Size
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ErzeugeOrdnerInformation(Ordner)

    Dim S

    S = "Pfad:" & Tabulator & Ordner.Path
    S = S & NeueZeile & "Name:" & Tabulator & Ordner.Name
    S = S & NeueZeile & "Attribute:" & Tabulator & ZeigeDateiAttribute(Ordner)
    S = S & NeueZeile & "Erstellt:" & Tabulator & Ordner.DateCreated
    S = S & NeueZeile & "Letzter Zugriff:" & Tabulator & Ordner.DateLastAccessed
    S = S & NeueZeile & "Letzte Änderung:" & Tabulator & Ordner.DateLastModified
    S = S & NeueZeile & "Größe:" & Tabulator & Ordner.Size & NeueZeile

    ErzeugeOrdnerInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ErzeugeAlleOrdnerInformationen
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den aktuellen Status eines Ordners
' und all seiner Dateien und untergeordneten Ordner beschreibt.
'
' Zeigt Folgendes
'
' - Folder.Path
' - Folder.SubFolders
' - Folders.Count
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ErzeugeAlleOrdnerInformationen(Ordner)

    Dim S
    Dim UnterOrdnerAuflistung
    Dim UnterOrdner
    Dim Dateien
    Dim Datei

    S = "Ordner:" & Tabulator & Ordner.Path & NeueZeile & NeueZeile

    Set Dateien = Ordner.Files

    If 1 = Dateien.Count Then
        S = S & "Es ist 1 Datei vorhanden" & NeueZeile
    Else
        S = S & "Es sind " & Dateien.Count & "Dateien vorhanden" & NeueZeile
    End If

    If Dateien.Count <> 0 Then

        For Each Datei In Dateien
            S = S & ErzeugeDateiInformation(Datei)
        Next

    End If

    Set UnterOrdnerAuflistung = Ordner.SubFolders

    If 1 = UnterOrdnerAuflistung.Count Then
        S = S & NeueZeile & "Es ist 1 Unterordner vorhanden" & NeueZeile & NeueZeile
    Else
        S = S & NeueZeile & "Es sind" & UnterOrdnerAuflistung.Count & "Unterordner vorhanden" & NeueZeile & NeueZeile
    End If

    If UnterOrdnerAuflistung.Count <> 0 Then

        For Each UnterOrdner In UnterOrdnerAuflistung
            S = S & ErzeugeOrdnerInformation(UnterOrdner)
        Next

        S = S & NeueZeile

        For Each UnterOrdner In UnterOrdnerAuflistung
            S = S & ErzeugeAlleOrdnerInformationen(UnterOrdner)
        Next

    End If

    ErzeugeAlleOrdnerInformationen = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ErzeugeTestInformation
'
' Zweck:
'
' Erstellt eine Zeichenfolge, die den aktuellen Status des Ordners C:\Test
' und all seiner Dateien und untergeordneten Ordner beschreibt.
'
' Zeigt Folgendes
'
' - FileSystemObject.DriveExists
' - FileSystemObject.FolderExists
' - FileSystemObject.GetFolder
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ErzeugeTestInformation(FSO)

    Dim TestOrdner
    Dim S

    If Not FSO.DriveExists(TestLW) Then Exit Function
    If Not FSO.FolderExists(TestDateiPfad) Then Exit Function

    Set TestOrdner = FSO.GetFolder(TestDateiPfad)

    ErzeugeTestInformation = ErzeugeAlleOrdnerInformationen(TestOrdner)

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' LoescheTestVerzeichnis
'
' Zweck:
'
' Bereinigt das Testverzeichnis.
'
' Zeigt Folgendes
'
' - FileSystemObject.GetFolder
' - FileSystemObject.DeleteFile
' - FileSystemObject.DeleteFolder
' - Folder.Delete
' - File.Delete
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub LoescheTestVerzeichnis(FSO)

    Dim TestOrdner
    Dim UnterOrdner
    Dim Datei

    ' Zwei Möglichkeiten, eine Datei zu löschen:

    FSO.DeleteFile(TestDateiPfad & "\Beatles\OctopusGarden.txt")

    Set Datei = FSO.GetFile(TestDateiPfad & "\Beatles\BathroomWindow.txt")
    Datei.Delete

    ' Zwei Möglichkeiten, einen Ordner zu löschen:

    FSO.DeleteFolder(TestDateiPfad & "\Beatles")

    FSO.DeleteFile(TestDateiPfad & "\Liesmich.txt")

    Set TestOrdner = FSO.GetFolder(TestDateiPfad)
    TestOrdner.Delete

End Sub

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ErzeugeLiedText
'
' Zweck:
'
' Erstellt mehrere Textdateien in einem Ordner.
'
'
' Zeigt Folgendes
'
' - FileSystemObject.CreateTextFile
' - TextStream.writeLine
' - TextStream.write
' - TextStream.writeBlankLines
' - TextStream.Close
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub ErzeugeLiedText(Ordner)

    Dim TextStream

    Set TextStream = Ordner.CreateTextFile("OctopusGarden.txt")

    TextStream.write("Octopus' Garden") ' Beachten Sie, dass der Datei kein Zeilenvorschub hinzugefügt wird.
    TextStream.WriteLine("(von Ringo Starr)")
    TextStream.writeBlankLines(1)
    TextStream.writeLine("I'd like to be under the sea, in an octopus' garden in the shade,")
    TextStream.writeLine("He'd let us in, knows where we've been - in his octopus' garden in the shade.")
    TextStream.writeBlankLines(2)

    TextStream.Close

    Set TextStream = Ordner.CreateTextFile("BathroomWindow.txt")
    TextStream.writeLine("She Came In Through The Bathroom Window (von Lennon/McCartney)")
    TextStream.writeLine("")
    TextStream.writeLine("She came in through the bathroom window, protected by a silver spoon")
    TextStream.writeLine("But now she sucks her thumb and wanders by the banks of her own lagoon")
    TextStream.writeBlankLines(2)
    TextStream.Close

End Sub

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' HoleLiedText
'
' Zweck:
'
' Zeigt den Inhalt der Liedtexte an.
'
'
' Zeigt Folgendes
'
' - FileSystemObject.OpenTextFile
' - FileSystemObject.GetFile
' - TextStream.ReadAll
' - TextStream.Close
' - File.OpenAsTextStream
' - TextStream.AtEndOfStream
' - TextStream.ReadLine
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function HoleLiedText(FSO)

    Dim TextStream
    Dim S
    Dim Datei

    ' Es gibt verschiedene Möglichkeiten, eine Textdatei zu öffnen und die
    ' Daten dieser Datei zu lesen.  Hier sind zwei Möglichkeiten:

    Set TextStream = FSO.OpenTextFile(TestDateiPfad & "\Beatles\OctopusGarden.txt", DateiOeffnenZumLesen)

    S = TextStream.ReadAll & NeueZeile & NeueZeile
    TextStream.Close

    Set Datei = FSO.GetFile(TestDateiPfad & "\Beatles\BathroomWindow.txt")
    Set TextStream = Datei.OpenAsTextStream(DateiOeffnenZumLesen)
    Do 	While Not TextStream.AtEndOfStream
        S = S & TextStream.ReadLine & NeueZeile
    Loop
    TextStream.Close

    HoleLiedText = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ErzeugeTestVerzeichnis
'
' Zweck:
'
' Erstellt eine Verzeichnishierarchie, um das FileSystemObject-Objekt zu beschreiben.
'
' Die Hierarchie wird in dieser Reihenfolge erstellt:
'
' C:\Test
' C:\Test\Liesmich.txt
' C:\Test\Beatles
' C:\Test\Beatles\OctopusGarden.txt
' C:\Test\Beatles\BathroomWindow.txt
'
'
' Zeigt Folgendes
'
' - FileSystemObject.DriveExists
' - FileSystemObject.FolderExists
' - FileSystemObject.CreateFolder
' - FileSystemObject.CreateTextFile
' - Folders.Add
' - Folder.CreateTextFile
' - TextStream.writeLine
' - TextStream.Close
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ErzeugeTestVerzeichnis(FSO)

    Dim TestOrdner
    Dim UnterOrdnerAuflistung
    Dim UnterOrdner
    Dim TextStream

    ' Bricht ab, wenn (a) das Laufwerk nicht vorhanden oder (b) das zu erstellende Verzeichnis bereits
    ' vorhanden ist.

    If Not FSO.DriveExists(TestLW) Then
        ErzeugeTestVerzeichnis = False
        Exit Function
    End If

    If FSO.FolderExists(TestDateiPfad) Then
        ErzeugeTestVerzeichnis = False
        Exit Function
    End If

    Set TestOrdner = FSO.CreateFolder(TestDateiPfad)

    Set TextStream = FSO.CreateTextFile(TestDateiPfad & "\Liesmich.txt")
    TextStream.writeLine("Meine Liedtextsammlung")
    TextStream.Close

    Set UnterOrdnerAuflistung = TestOrdner.SubFolders

    Set UnterOrdner = UnterOrdnerAuflistung.Add("Beatles")

    ErzeugeLiedText UnterOrdner

    ErzeugeTestVerzeichnis = True

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Die Hauptroutine
'
' Zunächst wird ein Testverzeichnis mit einigen Unterordnern und Dateien erstellt.
' Anschließend werden Informationen über die verfügbaren Festplattenlaufwerke und
' über das Testverzeichnis ausgegeben und danach alles wieder entfernt.
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub Main

    Dim FSO

    ' Einrichten globaler Daten.
    Tabulator = Chr(9)
    NeueZeile = Chr(10)

    Set FSO = CreateObject("Scripting.FileSystemObject")

    If Not ErzeugeTestVerzeichnis(FSO) Then
        Ausgabe "Testverzeichnis ist bereits vorhanden oder kann nicht erstellt werden. Fortsetzung nicht möglich."
        Exit Sub
    End If

    Ausgabe ErzeugeLWInformation(FSO) & NeueZeile & NeueZeile

    Ausgabe ErzeugeTestInformation(FSO) & NeueZeile & NeueZeile

    Ausgabe HoleLiedText(FSO) & NeueZeile & NeueZeile

    LoescheTestVerzeichnis(FSO)

End Sub


FileSystemObject-Glossar

Microsoft® Scripting-Bibliothek - FileSystemObject
FileSystemObject-Glossar 		Scripting-Laufzeitreferenz

Auflistung
Ein Objekt, das eine Gruppe zusammengehöriger Objekte enthält. Die Position eines Objekts in der Auflistung kann sich bei Änderungen in der Auflistung ebenfalls ändern, weshalb die Position aller Objekte in der Auflistung variieren kann.

Datenfeld
Eine Gruppe von Elementen des gleichen Datentypes, die mit einem fortlaufenden Index versehen sind. Jedes Element in einem Datenfeld (Array) hat eine eindeutige Indexnummer. An einem Element vorgenommene Änderungen haben keinen Einfluss auf die anderen Elemente.

Laufzeitfehler
Ein Fehler, der beim Ausführen von Code auftritt. Laufzeitfehler treten auf, wenn eine Anweisung versucht, einen ungültigen Vorgang durchzuführen.

Typbibliothek
Eine Datei oder Komponente innerhalb einer anderen Datei, die Standardbeschreibungen verfügbarer Objekte, Eigenschaften sowie Methoden enthält.

Zeichenfolgenausdruck
Alle Ausdrücke, die zu einer Sequenz aufeinander folgender Zeichen führen. Elemente eines Zeichenfolgenausdrucks können eine Funktion enthalten, die eine Zeichenfolge, ein Zeichenfolgenliteral, eine Zeichenfolgenkonstante oder eine Zeichenfolgenvariable zurückgibt.


VBScript-Glossar

VBScript-Glossar 		Sprachverzeichnis

ActiveX-Objekt
Ein Objekt, das für andere Anwendungen oder Programmierwerkzeuge über Automatisierungsschnittstellen sichtbar ist.

ActiveX-Steuerelement
Ein Objekt, das Sie auf einem Formular positionieren können, um die Interaktion eines Benutzers mit einer Anwendung zu ermöglichen oder zu erweitern. ActiveX-Steuerelemente besitzen Ereignisse und können in anderen Steuerelementen verwendet werden. Die Steuerelemente haben die Dateinamenerweiterung OCX.

Argument
Konstanten, Variablen und Ausdrücke, die an eine Prozedur übergeben werden.

ASCII-Zeichensatz
Ein dem ASCII (American Standard Code for Information Interchange)-Code entsprechender 7-Bit-Zeichensatz, der weitverbreitete Verwendung zum Darstellen der auf einer Standard-US-Tastatur vorhandenen Symbole gefunden hat. Der ASCII-Zeichensatz ist mit den ersten 128 Zeichen (0-127) des ANSI-Zeichensatzes identisch.

Auflistung
Ein Objekt, das eine Gruppe zusammengehöriger Objekte enthält. Die Position eines Objekts in der Auflistung kann sich bei Änderungen in der Auflistung ebenfalls ändern, weshalb die Position aller Objekte in der Auflistung variieren kann.

Ausdruck
Eine Kombination aus Schlüsselwörtern, Operatoren, Variablen und Konstanten, die eine Zeichenfolge, eine Zahl oder ein Objekt ergeben. Ein Ausdruck kann zum Ausführen einer Berechnung, zum Verändern von Zeichen oder zum Testen von Daten verwendet werden.

Automatisierungsobjekt
Ein Objekt, das für andere Anwendungen oder Programmierwerkzeuge über Automatisierungsschnittstellen sichtbar ist.

Bitweiser Vergleich
Ein Bit-für-Bit-Vergleich der Bits an identischen Positionen in zwei numerischen Ausdrücken.

Boolescher Ausdruck
Ein Ausdruck, der als Ergebnis entweder True oder False haben kann.

Datenfeld
Eine Gruppe von Elementen des gleichen Datentyps, die mit einem fortlaufenden Index versehen sind. Jedes Element in einem Datenfeld (Array) hat eine eindeutige Indexnummer. An einem Element vorgenommene Änderungen haben keinen Einfluss auf die anderen Elemente.

Datenbereiche
Jeder Variant-Untertyp verfügt über einen bestimmten zulässigen Wertebereich:

Untertyp | Bereich
Byte | 0 bis 255.
Boolean | True oder False.
Integer | -32.768 bis 32.767.
Long | -2.147.483.648 bis 2.147.483.647.
Single | -3,402823E38 bis -1,401298E-45 für negative Werte; 1,401298E-45 bis 3,402823E38 für positive Werte.
Double | -1,79769313486232E308 bis -4,94065645841247E-324 für negative Werte; 4.94065645841247E-324 bis 1,79769313486232E308 für positive Werte.
Currency | -922.337.203.685.477,5808 bis 922.337.203.685.477,5807.
Date | 1. Januar 100 bis 31. Dezember 9999 (je einschließlich).
Object | Jeder Object-Verweis.
String | Zeichenfolgen mit variabler Länge können eine Länge zwischen 0 und etwa 2 Milliarden Zeichen aufweisen.

Datumsausdruck
Jeder Ausdruck, der als eine Datumsangabe interpretiert werden kann. Dazu gehören alle Kombinationen aus Datumsbezeichnungen, Zahlen mit der äußeren Form von Datumsangaben, Zeichenfolgen mit der äußeren Form von Datumsangaben und von Funktionen zurückgegebenen Datumsangaben. Ein Datumsausdruck wird auf Zahlen oder Zeichenfolgen in jeder beliebigen Kombination, die ein Datum vom 1. Januar 100 bis 31. Dezember 9999 darstellen, begrenzt.

Datumsangaben werden als Bestandteil einer reellen Zahl gespeichert. Werte links vom Dezimalpunkt stellen das Datum dar, Werte rechts vom Dezimalpunkt die Uhrzeit. Negative Zahlen stellen Datumsangaben vor dem 30. Dezember 1899 dar.

Datumsliteral
Jede Folge von Zeichen mit einem gültigen Format, die zwischen Nummernzeichen (#) steht. Gültige Formate sind das in der Ländereinstellung des Codes festgelegte Datumsformat und das universelle Datumsformat. So repräsentiert z. B. das Datumsliteral #12/31/99# für Anwendungen mit der Ländereinstellung Englisch (USA) den 31. Dezember 1999.

VBScript interpretiert ein Datumsliteral immer als US-Englisch, sofern dies möglich ist. Wenn ein Datumsliteral nicht als Datum interpretiert werden kann, tritt ein Fehler auf.

Datumstrennzeichen
Zeichen, die zum Trennen von Tag, Monat und Jahr bei formatierten Datumswerten verwendet werden.

Eigenschaft
Ein benanntes Attribut eines Objekts. Mit Eigenschaften werden Objektcharakteristika, wie z. B. Größe, Farbe und Bildschirmposition, oder der Status eines Objekts, wie z. B. aktiviert oder deaktiviert, definiert.

Empty
Ein Wert, der anzeigt, dass der Variablen kein Anfangswert zugewiesen wurde. Numerische Variablen mit dem Wert Empty sind 0; Zeichenfolgen haben die Länge 0.

Fehlernummer
Eine ganze Zahl von 0 bis einschließlich 65.535, die der Number-Eigenschaft des Objekts Err entspricht. Kombiniert mit der Eigenschaft Name des Objekts Err stellt diese Zahl eine bestimmte Fehlermeldung dar.

Gebietsschema
Zusammenstellung von Informationen, die sprach- und landesspezifisch sind. Ein Gebietsschema hat Auswirkungen auf die Sprache der vordefinierten Programmierelemente und auf andere Einstellungen, die vom Gebietsschema abhängig sind. Das Gebietsschema ist in den folgenden beiden Bereichen von Bedeutung:
  • Das Code-Gebietsschema hat Auswirkungen auf die Sprache der Programmierelemente, z. B. die Schlüsselwörter, und definiert gebietsbezogene Einstellungen, z. B. Dezimal- und Listentrennzeichen, Datumsformate und Sortierreihenfolgen von Zeichen.
  • Das System-Gebietsschema hat Auswirkungen auf das Verhalten von gebietsbezogenen Funktionen, zum Beispiel bei der Anzeige von Zahlen oder der Konvertierung von Zeichenfolgen in Datumsangaben. Sie stellen das System-Gebietsschema mithilfe der Dienstprogramme in der Systemsteuerung des Betriebssystems ein.

Gültigkeitsbereich
Definiert die Sichtbarkeit von Variablen, Prozeduren oder Objekten. So ist eine als Public deklarierte Variable z. B. für alle Prozeduren in allen Modulen sichtbar. In Prozeduren deklarierte Variablen sind nur innerhalb der Prozedur sichtbar und verlieren zwischen den Aufrufen ihren Wert.

Integrierte Konstante
Eine von einer Anwendung vorgegebene Konstante. Da integrierte Konstanten nicht deaktiviert werden können, ist das Erstellen einer benutzerdefinierten Konstanten mit demselben Namen nicht möglich.

Klasse
Die formale Definition eines Objekts. Die Klasse dient als Vorlage zum Erzeugen einer Instanz eines Objekts zur Laufzeit. In der Klasse werden die Eigenschaften eines Objekts und die zum Steuern des Verhaltens des Objekts verwendeten Methoden definiert.

Klassenmodul
Ein Modul, welches die Definition einer Klasse (Definitionen ihre Eigenschaften und Methoden) enthält.

Kommentar
Text, der vom Programmierer in den Code eingefügt wird, um die Funktionsweise des Codes zu erläutern. In Visual Basic Scripting Edition beginnt ein Kommentar grundsätzlich mit einem Apostroph ('). Sie können auch das Schlüsselwort Rem, gefolgt von einem Leerzeichen, verwenden.

Konstante
Ein benanntes Element, welches während der gesamten Ausführung eines Programms einen konstanten Wert beibehält. Konstanten können überall im Programmcode anstelle von tatsächlichen Werten verwendet werden. Bei einer Konstanten kann es sich um eine Zeichenfolge, eine numerische Darstellung, eine andere Konstante oder eine durch arithmetische bzw. logische Operatoren (außer Is und Exponent) erzeugte beliebige Kombination aus diesen handeln. Beispiele:

Const A = "MeineZeichenfolge"

Laufzeit
Die Zeit, zu welcher Code ausgeführt wird. Während der Laufzeit kann der Code nicht bearbeitet werden.

Laufzeitfehler
Ein Fehler, der beim Ausführen von Code auftritt. Laufzeitfehler treten auf, wenn eine Anweisung versucht, einen ungültigen Vorgang durchzuführen.

Nach Referenz ("by reference")
Eine Möglichkeit der Übergabe von Argumenten an Prozeduren. Dabei wird statt des Wertes die Adresse des Arguments übergeben. Dadurch kann die Prozedur auf die tatsächliche Variable zugreifen. Somit kann der tatsächliche Wert der Variablen durch die Prozedur, an die sie übergeben wurde, geändert werden.

Nach Wert ("by value")
Eine Möglichkeit der Übergabe von Argumenten an Prozeduren. Dabei wird statt der Adresse der Wert des Arguments übergeben. Dadurch kann die Prozedur auf die Kopie der Variablen zugreifen. Somit kann nicht der tatsächliche Wert der Variablen durch die Prozedur, an die sie übergeben wurde, geändert werden.

Nothing
Dieser spezielle Wert zeigt an, dass eine Objektvariable nicht mehr mit einem tatsächlich vorhandenen Objekt verknüpft ist.

Null
Ein Wert, der angibt, dass eine Variable keine gültigen Daten enthält. Null ist das Ergebnis von:
  • Einer expliziten Zuweisung von Null zu einer Variablen.
  • Jeder Operation zwischen Ausdrücken, die Null enthalten.

Numerischer Ausdruck
Jeder Ausdruck, der als eine Zahl ausgewertet werden kann. Elemente des Ausdrucks können beliebige Kombinationen aus Schlüsselwörtern, Variablen, Konstanten und Operatoren, die als Ergebnis eine Zahl haben, sein.

Objekttyp
Ein Typ eines Objekts, der durch eine Anwendung offen gelegt wird, z. B. Application, File, Range und Sheet (Anwendung, Datei, Bereich und Tabelle). Eine vollständige Liste der verfügbaren Objekte ist in der Dokumentation der Anwendungen (Microsoft Excel, Microsoft Project, Microsoft Word usw.) enthalten.

pi
Pi ist eine mathematische Konstante mit dem ungefähren Wert 3.1415926535897932.

Private
Variablen, die nur in dem Skript, in dem sie definiert wurden, sichtbar sind.

Prozedur
Eine benannte Folge von Anweisungen, die als einheitliches Ganzes ausgeführt werden. Prozeduren sind z. B. Function und Sub.

Prozedurebene
Beschreibt die Anweisungen innerhalb einer Function- oder Sub-Prozedur. Deklarationen stehen normalerweise vor Zuweisungen und anderem ausführbaren Code. Beispiele:

Sub MeineProz()          ' Diese Anweisung deklariert einen Unterprozedurblock.
    Dim A                ' Mit dieser Anweisung beginnt der Prozedurblock.
    A = "Meine Variable" ' Code auf Prozedurebene.
    Debug.Print A        ' Code auf Prozedurebene.
End Sub                  ' Diese Anweisung beendet einen Unterprozedurblock.
Beachten Sie, dass sich im Gegensatz dazu Code auf Modulebene außerhalb aller Prozedurblöcke befindet.

Public
Mit der Public-Anweisung deklarierte Variablen sind in allen Prozeduren in allen Modulen in allen Anwendungen sichtbar.

Schlüsselwort
Ein Wort oder Symbol, das als Element der Sprache VBScript erkannt wurde, z. B. eine Anweisung, ein Funktionsname oder ein Operator.

SCODE
Ein Wert vom Typ Long Integer, der zur Übergabe von Detailinformationen an die Routine verwendet wird, die eine Schnittstellenkomponente oder eine API-Funktion aufgerufen hat. Die Statuscodes für OLE-Schnittstellen und API-Funktionen sind in FACILITY_ITF beschrieben.

Skriptebene
Jeglicher Code außerhalb einer Prozedur wird als auf Skriptebene angesehen.

Startwert ("Seed")
Ein Anfangswert zum Erzeugen von Pseudozufallszahlen. So erzeugt die Randomize-Anweisung z. B. eine Seed-Zahl. Diese Seed-Zahl wird von der Funktion Rnd verwendet, um eindeutige Folgen von Pseudozufallszahlen zu erzeugen.

Typbibliothek
Eine Datei oder Komponente innerhalb einer anderen Datei, die Standardbeschreibungen verfügbarer Objekte, Eigenschaften sowie Methoden enthält.

Variable
Eine benannte Speicherposition, welche während der Programmausführung änderbare Daten enthält. Jede Variable hat einen Namen, durch den sie innerhalb ihres Gültigkeitsbereichs eindeutig identifiziert wird.

Variablennamen:

  • Sie müssen mit einem Zeichen des Alphabets beginnen.
  • Sie dürfen keine eingebetteten Punkte oder Typdeklarationszeichen enthalten.
  • Sie müssen im gleichen Gültigkeitsbereich eindeutig sein.
  • Sie dürfen nicht mehr als 255 Zeichen aufweisen.

Vergleichsoperator
Ein Zeichen oder Symbol zum Anzeigen einer Beziehung zwischen zwei oder mehr Werten oder Ausdrücken. Operatoren sind: kleiner als (<), kleiner oder gleich (<=), größer als (>), größer oder gleich (>=), ungleich (<>) und gleich (=).

Is ist ebenfalls ein Vergleichsoperator. Er wird aber ausschließlich zum Bestimmen, ob eine Objektreferenz dieselbe wie eine andere ist, verwendet.

Zeichencode
Eine Zahl, die ein bestimmtes Zeichen eines Zeichensatzes, wie z. B. des ASCII-Zeichensatzes, darstellt.

Zeichenfolgenausdruck
Alle Ausdrücke, die zu einer Sequenz aufeinanderfolgender Zeichen führen. Elemente eines Zeichenfolgenausdrucks können eine Funktion enthalten, die eine Zeichenfolge, ein Zeichenfolgeliteral, eine Zeichenfolgekonstante oder eine Zeichenfolgevariable zurückgeben.

Zeichenfolgenvergleich
Ein Vergleich von zwei Zeichenfolgen. Alle Zeichenfolgenvergleiche erfolgen binär, sofern in der Funktion, die den Vergleich durchführt, nichts anderes angegeben wird. Für Deutsch wird bei binären Vergleichen zwischen Groß- und Kleinschreibung unterschieden, bei Textvergleichen nicht.


Einfache Gültigkeitsprüfung

Geben Sie einen Wert zwischen 1 und 10 ein:


Copyright

Die in diesen Unterlagen enthaltenen Angaben und Daten können ohne vorherige Ankündigung geändert werden. Die hierin genannten Namen von Firmen, Produkten, Personen, Charakteren und/oder Daten sind fiktiv und sollen in keiner Weise reale Individuen, Firmen, Produkte oder Ereignisse darstellen, falls dies nicht ausdrücklich angemerkt ist. Die Benutzerinnen und Benutzer sind verpflichtet, sich an alle anwendbaren Urheberrechtsgesetze zu halten. Ohne ausdrückliche schriftliche Erlaubnis von Microsoft Corporation darf kein Teil dieser Unterlagen für irgendwelche Zwecke vervielfältigt oder übertragen werden, unabhängig davon, auf welche Weise oder mit welchen Mitteln, elektronisch oder mechanisch, dies geschieht.

Microsoft verfügt möglicherweise über Patente, angemeldete Patente, Marken, Urheberrechte oder andere geistige Eigentumsrechte an Inhalten in diesen Unterlagen. Durch die Bereitstellung dieser Unterlagen erhalten Sie keinerlei Lizenzrechte an diesen Patenten, Marken, Urheberrechten oder anderen Rechten geistigen Eigentums, es sei denn, dies wurde explizit durch einen schriftlichen Lizenzvertrag mit Microsoft vereinbart.

© 1991-1999 Microsoft Corporation. Alle Rechte vorbehalten.

Microsoft, MS, MS-DOS, ActiveX, JScript, Microsoft Press, Visual Basic, Windows, Windows NT, Win32 und Win32s sind Marken oder eingetragene Marken der Microsoft Corporation in den USA und/oder anderen Ländern.

Andere hierin genannten Produkt- oder Firmennamen können Marken der jeweiligen Eigentümer sein.


Versionsbezogene Information zu Funktionsmerkmalen

Versionsbezogene Information zu Funktionsmerkmalen 		Sprachverzeichnis

Versionsinformationen

Die nachstehende Tabelle führt Funktionsmerkmale der VBScript-Sprache und die Version auf, in der sie eingeführt wurden.

Sprachelement | Erstmalig in Version
1.0 | 2.0 | 3.0 | 4.0 | 5.0
Abs-Funktion | X
Additionsoperator (+) | X
And-Operator | X
Array-Funktion | X
Asc-Funktion | X
Atn-Funktion | X
Call-Anweisung | X
CBool-Funktion | X
CByte-Funktion | X
CCur-Funktion | X
CDate-Funktion | X
CDbl-Funktion | X
Chr-Funktion | X
CInt-Funktion | X
Class-Anweisung | X
Class-Objekt | X
Clear-Methode | X
CLng-Funktion | X
Const-Anweisung | X
Cos-Funktion | X
CreateObject-Funktion | X
CSng-Funktion | X
CStr-Funktion | X
Date-Funktion | X
DateAdd-Funktion | X
DateDiff-Funktion | X
DatePart-Funktion | X
DateSerial-Funktion | X
DateValue-Funktion | X
Datums- und Uhrzeitkonstanten | X
Datumsformatkonstanten | X
Day-Funktion | X
Description-Eigenschaft | X
Dim-Anweisung | X
Divisionsoperator (/) | X
Do...Loop-Anweisung | X
Empty | X
Eqv-Operator | X
Erase-Anweisung | X
Err-Objekt | X
Eval-Funktion | X
Execute-Anweisung | X
Execute-Methode | X
ExecuteGlobal-Anweisung | X
Exit-Anweisung | X
Exp-Funktion | X
Exponentialoperator (^) | X
False | X
Farbkonstanten | X
Filter-Funktion | X
FirstIndex-Eigenschaft | X
Fix-Funktion | X
For Each...Next-Anweisung | X
For...Next-Anweisung | X
FormatCurrency-Funktion | X
FormatDateTime-Funktion | X
FormatNumber-Funktion | X
FormatPercent-Funktion | X
Function-Anweisung | X
Ganzzahl-Divisionsoperator (\) | X
GetLocale-Funktion | X
GetObject-Funktion | X
GetRef-Funktion | X
Global-Eigenschaft | X
HelpContext-Eigenschaft | X
HelpFile-Eigenschaft | X
Hex-Funktion | X
Hour-Funktion | X
If...Then...Else-Anweisung | X
IgnoreCase-Eigenschaft | X
Imp-Operator | X
Initialize-Ereignis
 X
InputBox-Funktion | X
InStr-Funktion | X
InStrRev-Funktion | X
Int-Funktion | X
Is-Operator | X
IsArray-Funktion | X
IsDate-Funktion | X
IsEmpty-Funktion | X
IsNull-Funktion | X
IsNumeric-Funktion | X
IsObject-Funktion | X
Join-Funktion | X
LBound-Funktion | X
LCase-Funktion | X
Left-Funktion | X
Len-Funktion | X
Length-Eigenschaft | X
LoadPicture-Funktion | X
Log-Funktion | X
LTrim-Funktion | X
Match-Objekt | X
Matches-Auflistung | X
Mid-Funktion | X
Minute-Funktion | X
Mod-Operator | X
Month-Funktion | X
MonthName-Funktion | X
MsgBox-Funktion | X
MsgBox-Konstanten | X
Multiplikationsoperator (*) | X
Negationsoperator (-) | X
Not-Operator | X
Nothing | X
Now-Funktion | X
Null | X
Number-Eigenschaft | X
Oct-Funktion | X
On Error-Anweisung | X
Option Explicit-Anweisung | X
Or-Operator | X
Pattern-Eigenschaft | X
Private-Anweisung | X
Property Get-Anweisung | X
Property Let-Anweisung | X
Property Set-Anweisung | X
Public-Anweisung | X
Raise-Methode | X
Randomize-Anweisung | X
ReDim-Anweisung | X
RegExp-Objekt | X
Rem-Anweisung | X
Replace-Funktion | X
Replace-Methode | X
RGB-Funktion | X
Right-Funktion | X
Rnd-Funktion | X
Round-Funktion | X
RTrim-Funktion | X
ScriptEngine-Funktion | X
ScriptEngineBuildVersion-Funktion | X
ScriptEngineMajorVersion-Funktion | X
ScriptEngineMinorVersion-Funktion | X
Second-Funktion | X
Select Case-Anweisung | X
Set-Anweisung | X
SetLocale-Funktion | X
Sgn-Funktion | X
Sin-Funktion | X
Source-Eigenschaft | X
Space-Funktion | X
Split-Funktion | X
Sqr-Funktion | X
StrComp-Funktion | X
String-Funktion | X
StrReverse-Funktion | X
Sub-Anweisung | X
Subtraktionsoperator (-) | X
Tan-Funktion | X
Terminate-Ereignis
 X
Test-Methode | X
Time-Funktion | X
Timer-Funktion | X
TimeSerial-Funktion | X
TimeValue-Funktion | X
Trim-Funktion | X
Tristate-Konstanten | X
True | X
TypeName-Funktion | X
UBound-Funktion | X
UCase-Funktion | X
Value-Eigenschaft | X
VarType-Funktion | X
VarType-Konstanten | X
VBScript-Konstanten | X
Vergleichskonstanten | X
Verkettungsoperator (&) | X
Verschiedene Konstanten | X
Weekday-Funktion | X
WeekdayName-Funktion | X
While...Wend-Anweisung | X
With-Anweisung | X
Xor-Operator | X
Year-Funktion | X
Zeichenfolgenkonstanten | X
Zuweisungsoperator (=) | X


Eine einfache erste Seite


Scripting-Laufzeitreferenz

Scripting-Laufzeitreferenz 		Sprachverzeichnis
Versionsinformationen

Informationen über
Funktionsmerkmale
Alphabetische
Schlüsselwortliste
Eigenschaften
Konstanten
Methoden
Objekte
© 1999 Microsoft Corporation. Alle Rechte vorbehalten.


Objektbeispiel

Zum Anzeigen dieser Seite muss das Label-Steuerelement installiert sein.


VBScript-Sprachverzeichnis

VBScript-Sprachverzeichnis 		VBScript-Tutorium
Versionsinformationen

Informationen über
Funktionsmerkmale
Alphabetische
Schlüsselwortliste
Anweisungen
Eigenschaften
Ereignisse
Fehler
Funktionen
Konstanten
Methoden
Objekte
Operatoren
© 1999 Microsoft Corporation. Alle Rechte vorbehalten.


Versionsinformationen

Versionsinformationen 		Sprachverzeichnis

Die folgende Tabelle zeigt die Version von Microsoft Visual Basic Scripting Edition, die in einzelnen Hostanwendungen implementiert ist.

Hostanwendung | VBScript-Version
1.0 | 2.0 | 3.0 | 4.0 | 5.0
Microsoft Internet Explorer 3.0 | x
Microsoft Internet Information Server 3.0 | x
Microsoft Internet Explorer 4.0 | x
Microsoft Internet Information Server 4.0 | x
Microsoft Windows Scripting Host 1.0 | x
Microsoft Outlook 98 | x
Microsoft Visual Studio 6.0 | x
Microsoft Internet Explorer 5.0 | x
Microsoft Internet-Informationsdienste 5.0 | x

Die folgende Tabelle listet Funktionsmerkmale der VBScript-Sprache und die Version, in der sie eingeführt wurden, auf.

Sprachelement | Erstmalig in Version
1.0 | 2.0 | 3.0 | 4.0 | 5.0
Abs-Funktion | x
Additionsoperator (+) | x
And-Operator | x
Array-Funktion | x
Asc-Funktion | x
Atn-Funktion | x
Call-Anweisung | x
CBool-Funktion | x
CByte-Funktion | x
CCur-Funktion | x
CDate-Funktion | x
CDbl-Funktion | x
Chr-Funktion | x
CInt-Funktion | x
Class-Anweisung | x
Class-Objekt | x
Clear-Methode | x
CLng-Funktion | x
Const-Anweisung | x
Cos-Funktion | x
CreateObject-Funktion | x
CSng-Funktion | x
CStr-Funktion | x
Date-Funktion | x
DateAdd-Funktion | x
DateDiff-Funktion | x
DatePart-Funktion | x
DateSerial-Funktion | x
DateValue-Funktion | x
Datums- und Uhrzeitkonstanten | x
Datumsformat-Konstanten | x
Day-Funktion | x
Description-Eigenschaft | x
Dim-Anweisung | x
Divisionsoperator (/) | x
Do...Loop-Anweisung | x
Empty | x
Eqv-Operator | x
Erase-Anweisung | x
Err-Objekt | x
Eval-Funktion | x
Execute-Anweisung | x
Execute-Methode | x
ExecuteGlobal-Anweisung | x
Exit-Anweisung | x
Exp-Funktion | x
Exponentialoperator (^) | x
False | x
Farbkonstanten | x
Filter-Funktion | x
FirstIndex-Eigenschaft | x
Fix-Funktion | x
For Each...Next-Anweisung | x
For...Next-Anweisung | x
FormatCurrency-Funktion | x
FormatDateTime-Funktion | x
FormatNumber-Funktion | x
FormatPercent-Funktion | x
Function-Anweisung | x
Ganzzahliger Divisionsoperator (\) | x
GetLocale-Funktion | x
GetObject-Funktion | x
GetRef-Funktion | x
Global-Eigenschaft | x
HelpContext-Eigenschaft | x
HelpFile-Eigenschaft | x
Hex-Funktion | x
Hour-Funktion | x
If...Then...Else-Anweisung | x
IgnoreCase-Eigenschaft | x
Imp-Operator | x
Initialize-Ereignis | x
InputBox-Funktion | x
InStr-Funktion | x
InStrRev-Funktion | x
Int-Funktion | x
Is-Operator | x
IsArray-Funktion | x
IsDate-Funktion | x
IsEmpty-Funktion | x
IsNull-Funktion | x
IsNumeric-Funktion | x
IsObject-Funktion | x
Join-Funktion | x
LBound-Funktion | x
LCase-Funktion | x
Left-Funktion | x
Len-Funktion | x
Length-Eigenschaft | x
LoadPicture-Funktion | x
Log-Funktion | x
LTrim-Funktion | x
Match-Objekt | x
Matches-Auflistung | x
Mid-Funktion | x
Minute-Funktion | x
Mod-Operator | x
Month-Funktion | x
MonthName-Funktion | x
MsgBox-Funktion | x
MsgBox-Konstanten | x
Multiplikationsoperator (*) | x
Negationsoperator (-) | x
Not-Operator | x
Nothing | x
Now-Funktion | x
Null | x
Number-Eigenschaft | x
Oct-Funktion | x
On Error-Anweisung | x
Option Explicit-Anweisung | x
Or-Operator | x
Pattern-Eigenschaft | x
Private-Anweisung | x
PropertyGet-Anweisung | x
PropertyLet-Anweisung | x
PropertySet-Anweisung | x
Public-Anweisung | x
Raise-Methode | x
Randomize-Anweisung | x
ReDim-Anweisung | x
RegExp-Objekt | x
Rem-Anweisung | x
Replace-Funktion | x
Replace-Methode | x
RGB-Funktion | x
Right-Funktion | x
Rnd-Funktion | x
Round-Funktion | x
RTrim-Funktion | x
ScriptEngine-Funktion | x
ScriptEngineBuildVersion-Funktion | x
ScriptEngineMajorVersion-Funktion | x
ScriptEngineMinorVersion-Funktion | x
Second-Funktion | x
Select Case-Anweisung | x
Set-Anweisung | x
SetLocale-Funktion | x
Sgn-Funktion | x
Sin-Funktion | x
Source-Eigenschaft | x
Space-Funktion | x
Split-Funktion | x
Sqr-Funktion | x
StrComp-Funktion | x
String-Funktion | x
StrReverse-Funktion | x
Sub-Anweisung | x
Subtraktionsoperator (-) | x
Tan-Funktion | x
Terminate-Ereignis | x
Test-Methode | x
Time-Funktion | x
Timer-Funktion | x
TimeSerial-Funktion | x
TimeValue-Funktion | x
Trim-Funktion | x
Tristate-Konstanten | x
True | x
TypeName-Funktion | x
UBound-Funktion | x
UCase-Funktion | x
Value-Eigenschaft | x
VarType-Funktion | x
VarType-Konstanten | x
VBScript-Konstanten | x
Vergleichskonstanten | x
Verkettungsoperator (&) | x
Verschiedene Konstanten | x
Weekday-Funktion | x
WeekdayName-Funktion | x
While...Wend-Anweisung | x
With-Anweisung | x
Xor-Operator | x
Year-Funktion | x
Zeichenfolgenkonstanten | x
Zuweisungsoperator (=) | x


Drives-Auflistung

Drives-Auflistung 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Schreibgeschützte Auflistung aller verfügbarer Laufwerke.
Hinweise
In Laufwerken mit austauschbaren Datenträgern muss kein Datenträger eingelegt sein, damit diese in der Drives-Auflistung angezeigt werden.

Der folgende Code veranschaulicht das Abrufen der Drives-Auflistung und das Durchlaufen der Auflistung mit der For Each...Next-Anweisung:

Function LWListeAnzeigen
  Dim fso, l, la, s, n
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set la = fso.Drives
  For Each l in la
    n = ""
    s = s & l.DriveLetter & " - "
    If l.DriveType = Remote Then
      n = l.ShareName
    ElseIf l.IsReady Then
      n = l.VolumeName
    End If
    s = s & n & "<BR>"
  Next
  LWListeAnzeigen = s
End Function


Drives-Auflistung

Drives-Auflistung
Siehe auch 		Scripting-Laufzeitreferenz

Drive-Objekt
Drives-Eigenschaft
File-Objekt
Files-Auflistung
Folder-Objekt
Folders-Auflistung


Drives-Auflistung

Drives-Auflistung
Methoden 		Scripting-Laufzeitreferenz

Die Drives-Auflistung besitzt keine Methoden.


Drives-Auflistung

Drives-Auflistung
Eigenschaften 		Scripting-Laufzeitreferenz

Count-Eigenschaft
Item-Eigenschaft


Files-Auflistung

Files-Auflistung 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Auflistung aller File-Objekte in einem Ordner.
Hinweise
Der folgende Code veranschaulicht das Abrufen der Files-Auflistung und das Durchlaufen der Auflistung mit der For Each...Next-Anweisung:
Function DateilisteAnzeigen(Ordnerangabe)
  Dim fso, o, d, da, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set o = fso.GetFolder(Ordnerangabe)
  Set da = o.Files
  For Each d in da
    s = s & d.name
    s = s & "<BR>"
  Next
  DateilisteAnzeigen = s
End Function


Files-Auflistung

Files-Auflistung
Siehe auch 		Scripting-Laufzeitreferenz

Drive-Objekt
Drives-Auflistung
File-Objekt
Folder-Objekt
Folders-Auflistung


Files-Auflistung

Files-Auflistung
Methoden 		Scripting-Laufzeitreferenz

Die Files-Auflistung besitzt keine Methoden.


Files-Auflistung

Files-Auflistung
Eigenschaften 		Scripting-Laufzeitreferenz

Count-Eigenschaft
Item-Eigenschaft


Folders-Auflistung

Folders-Auflistung 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Auflistung aller Folder-Objekte in einem Folder-Objekt.
Hinweise
Der folgende Code veranschaulicht das Abrufen der Folders-Auflistung und das Durchlaufen der Auflistung mit der For Each...Next-Anweisung:
Function OrdnerlisteAnzeigen(Ordnerangabe)
  Dim fso, o, o1, oa, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set o = fso.GetFolder(Ordnerangabe)
  Set oa = o.SubFolders
  For Each o1 in oa
    s = s & o1.name
    s = s & "<BR>"
  Next
  OrdnerlisteAnzeigen = s
End Function


Folders-Auflistung

Folders-Auflistung
Siehe auch 		Scripting-Laufzeitreferenz

Drive-Objekt
Drives-Auflistung
File-Objekt
Files-Auflistung
Folder-Objekt
SubFolders-Eigenschaft


Folders-Auflistung

Folders-Auflistung
Methoden 		Scripting-Laufzeitreferenz

Add-Methode


Folders-Auflistung

Folders-Auflistung
Eigenschaften 		Scripting-Laufzeitreferenz

Count-Eigenschaft
Item-Eigenschaft


Matches-Auflistung

Matches-Auflistung 		Sprachverzeichnis
Version 5

Siehe auch Eigenschaften

Beschreibung
Auflistung von Match-Objekten aus Suche mit regulärem Ausdruck.
Hinweise
Eine Matches-Auflistung enthält einzelne Match-Objekte und kann nur mit der Execute-Methode des RegExp-Objekts erstellt werden. Die einzige Eigenschaft einer Matches-Auflistung ist gleichermaßen wie die der einzelnen Match-Objekte schreibgeschützt.

Wird ein regulärer Ausdruck ausgeführt, werden keine oder mehr Match-Objekte ausgegeben. Jedes Match-Objekt gewährt Zugriff auf eine mit dem regulären Ausdruck gefundene Zeichenfolge, deren Länge sowie auf den Index, in dem die Entsprechung gefunden wurde.

Der folgende Code veranschaulicht, wie eine Matches-Auflistung über die Suche mit einem regulärem Ausdruck angefordert wird und wie die Auflistung durchlaufen werden soll:

Function RegAusTest(Muster, Zeichenfolge)
  Dim regAus, Uebereinstimmung, Uebereinstimmungen		' Erstellt Variablen.
  Set regAus = New RegExp			' Erstellt einen regulären Ausdruck.
  regAus.Pattern = Muster			' Legt das Muster fest.
  regAus.IgnoreCase = True		' Ignoriert die Schreibweise.
  regAus.Global = True			' Legt globales Anwenden fest.
  Set Uebereinstimmungen = regAus.Execute(Zeichenfolge)	' Führt die Suche aus.
  For Each Uebereinstimmung in Uebereinstimmungen		' Durchläuft die Matches-Auflistung.
    RetStr = RetStr & "Entsprechung gefunden bei "
    RetStr = RetStr & Uebereinstimmung.FirstIndex & ". Wert ist '"
    RetStr = RetStr & Uebereinstimmung.Value & "'." & vbCRLF
  Next
  RegAusTest = RetStr
End Function

MsgBox(RegAusTest("is.", "IS1 is2 IS3 is4"))


Matches-Auflistung

Matches-Auflistung
Siehe auch 		Sprachverzeichnis

For Each...Next-Anweisung
Match-Objekt
RegExp-Objekt


Matches-Auflistung

Matches-Auflistung
Eigenschaften 		Sprachverzeichnis
Count-Eigenschaft
Item-Eigenschaft


Farbkonstanten

Farbkonstanten 		Sprachverzeichnis
Version 2

Siehe auch

Da diese Konstanten in VBScript integriert sind, müssen Sie sie vor einer Verwendung nicht definieren. Verwenden Sie diese Konstanten in Ihrem Code an einer beliebigen Stelle, um die jeweils angezeigten Werte darzustellen.

Konstante | Wert | Beschreibung
vbBlack | &h00 | Schwarz
vbRed | &hFF | Rot
vbGreen | &hFF00 | Grün
vbYellow | &hFFFF | Gelb
vbBlue | &hFF0000 | Blau
vbMagenta | &hFF00FF | Magenta
vbCyan | &hFFFF00 | Zyan
vbWhite | &hFFFFFF | Weiß


Farbkonstanten

Farbkonstanten
Siehe auch 		Sprachverzeichnis

Datums- und Uhrzeitkonstanten
Datumsformat-Konstanten
MsgBox-Konstanten
Tristate-Konstanten
VarType-Konstanten
Vergleichskonstanten
Verschiedene Konstanten
Zeichenfolgenkonstanten


Vergleichskonstanten

Vergleichskonstanten 		Sprachverzeichnis
Version 2

Siehe auch

Da diese Konstanten in VBScript integriert sind, müssen Sie sie vor einer Verwendung nicht definieren. Verwenden Sie diese Konstanten in Ihrem Code an einer beliebigen Stelle, um die jeweils angezeigten Werte darzustellen.

Konstante | Wert | Beschreibung
vbBinaryCompare | 0 | Führt einen binären Vergleich durch.
vbTextCompare | 1 | Führt einen Textvergleich durch.


Vergleichskonstanten

Vergleichskonstanten
Siehe auch 		Sprachverzeichnis

Datums- und Uhrzeitkonstanten
Datumsformat-Konstanten
Farbkonstanten
MsgBox-Konstanten
Tristate-Konstanten
VarType-Konstanten
Verschiedene Konstanten
Zeichenfolgenkonstanten


Datumsformat-Konstanten

Datumsformat-Konstanten 		Sprachverzeichnis
Version 2

Siehe auch

Da diese Konstanten in VBScript integriert sind, müssen Sie sie vor einer Verwendung nicht definieren. Verwenden Sie diese Konstanten in Ihrem Code an einer beliebigen Stelle, um die jeweils angezeigten Werte darzustellen.

Konstante | Wert | Beschreibung
vbGeneralDate | 0 | Anzeigen von Datum und/oder Uhrzeit. Bei reellen Zahlen Anzeige von Datum und Uhrzeit. Keine Dezimalstellen: nur Datumsanzeige. Kein ganzzahliger Teil: nur Uhrzeitanzeige. Die Datums- und Uhrzeitanzeige ist von Ihren Systemeinstellungen abhängig.
vbLongDate | 1 | Anzeigen eines Datums im langen Datumsformat Ihrer Ländereinstellungen.
vbShortDate | 2 | Anzeigen des Datums im kurzen Datumsformat Ihrer Ländereinstellungen.
vbLongTime | 3 | Anzeigen der Zeit im langen Zeitformat Ihrer Ländereinstellungen.
vbShortTime | 4 | Anzeigen der Zeit im kurzen Zeitformat Ihrer Ländereinstellungen.


Datumsformat-Konstanten

Datumsformat-Konstanten
Siehe auch 		Sprachverzeichnis

Datums- und Uhrzeitkonstanten
Farbkonstanten
MsgBox-Konstanten
Tristate-Konstanten
VarType-Konstanten
Vergleichskonstanten
Verschiedene Konstanten
Zeichenfolgenkonstanten


Datums- und Uhrzeitkonstanten

Datums- und Uhrzeitkonstanten 		Sprachverzeichnis
Version 2

Siehe auch

Da diese Konstanten in VBScript integriert sind, müssen Sie sie vor einer Verwendung nicht definieren. Verwenden Sie diese Konstanten in Ihrem Code an einer beliebigen Stelle, um die jeweils angezeigten Werte darzustellen.

Konstante | Wert | Beschreibung
vbSunday | 1 | Sonntag
vbMonday | 2 | Montag
vbTuesday | 3 | Dienstag
vbWednesday | 4 | Mittwoch
vbThursday | 5 | Donnerstag
vbFriday | 6 | Freitag
vbSaturday | 7 | Samstag
vbUseSystem | 0 | Verwenden des in den Ländereinstellungen festgelegten Datumsformats.
vbUseSystemDayOfWeek | 0 | Verwenden des in den Ländereinstellungen als erster Wochentag festgelegten Tages.
vbFirstJan1 | 1 | Verwenden der Woche, in der der 1. Januar liegt (Standard).
vbFirstFourDays | 2 | Verwenden der ersten Woche, die im neuen Jahr mindestens vier Tage hat.
vbFirstFullWeek | 3 | Verwenden der ersten vollen Woche eines Jahres.


Datums- und Uhrzeitkonstanten

Datums- und Uhrzeitkonstanten
Siehe auch 		Sprachverzeichnis

Datumsformat-Konstanten
Farbkonstanten
MsgBox-Konstanten
Tristate-Konstanten
VarType-Konstanten
Vergleichskonstanten
Verschiedene Konstanten
Zeichenfolgenkonstanten


Laufwerktypkonstanten

Laufwerktypkonstanten 		Scripting-Laufzeitreferenz
Version 3

Siehe auch

Folgende Konstanten sind nur verfügbar, wenn Ihr Projekt explizit auf eine entsprechende Typbibliothek verweist, die diese Definitionen der Konstanten enthält. In VBScript müssen Sie diese Konstanten explizit in Ihrem Code deklarieren.

Konstante | Wert | Beschreibung
Unknown | 0 | Laufwerktyp kann nicht bestimmt werden.
Removable | 1 | Laufwerk verfügt über austauschbare Datenträger. Dazu zählen Disketten und viele andere Speichermedien.
Fixed | 2 | Laufwerk verfügt über einen festen (nicht entfernbaren) Datenträger. Dazu zählen alle Festplatten sowie auch austauschbare Festplatten.
Remote | 3 | Netzlaufwerke. Dazu gehören alle beliebigen Netzwerkverzeichnisse im Netzwerk.
CDROM | 4 | Laufwerk ist ein CD-Laufwerk. Es wird nicht zwischen Nur-Lese- und Lese/Schreib-CD-Laufwerken unterschieden.
RAMDisk | 5 | Das RAM-Laufwerk ist ein Arbeitsspeicherblock auf dem lokalen Computer, das wie ein Festplattenlaufwerk angesprochen wird.


Laufwerktypkonstanten

Laufwerktypkonstanten
Siehe auch 		Scripting-Laufzeitreferenz

Dateiattributkonstanten
Dateieingabe-/-ausgabekonstanten
SpecialFolder-Konstante
Tristate-Konstanten
Vergleichskonstanten


Dateiattributkonstanten

Dateiattributkonstanten 		Scripting-Laufzeitreferenz
Version 3

Siehe auch

Folgende Konstanten sind nur verfügbar, wenn Ihr Projekt explizit auf eine entsprechende Typbibliothek verweist, die diese Definitionen der Konstanten enthält. In VBScript müssen Sie diese Konstanten explizit in Ihrem Code deklarieren.

Konstante | Wert | Beschreibung
Normal | 0 | Normale Datei. Es sind keine Attribute gesetzt.
ReadOnly | 1 | Schreibgeschützte Datei.
Hidden | 2 | Versteckte Datei.
System | 4 | Systemdatei.
Directory | 16 | Ordner oder Verzeichnis.
Archive | 32 | Datei hat sich nach der letzten Sicherung geändert.
Alias | 1024 | Verknüpfung oder Kurzbefehl.
Compressed | 2048 | Komprimierte Datei.


Dateiattributkonstanten

Dateiattributkonstanten
Siehe auch 		Scripting-Laufzeitreferenz

Dateieingabe-/-ausgabekonstanten
Laufwerktypkonstanten
SpecialFolder-Konstanten
Tristate-Konstanten
Vergleichskonstanten


Dateieingabe-/-ausgabekonstanten

Dateieingabe-/
-ausgabekonstanten 		Scripting-Laufzeitreferenz
Version 2

Siehe auch

Folgende Konstanten sind nur verfügbar, wenn Ihr Projekt explizit auf eine entsprechende Typbibliothek verweist, die diese Definitionen der Konstanten enthält. In VBScript müssen Sie diese Konstanten explizit in Ihrem Code deklarieren.

Konstante | Wert | Beschreibung
ForReading | 1 | Öffnet eine Datei nur zum Lesen. Schreibzugriffe sind nicht möglich.
ForWriting | 2 | Öffnet eine Datei zum Schreiben. Ist eine Datei mit demselben Namen vorhanden, wird der vorherige Inhalt überschrieben.
ForAppending | 8 | Öffnet eine Datei und schreibt an das Dateiende.


Dateieingabe-/-ausgabekonstanten

Dateieingabe-/
-ausgabekonstanten
Siehe auch 		Scripting-Laufzeitreferenz

Dateiattributkonstanten
Laufwerktypkonstanten
SpecialFolder-Konstanten
Tristate-Konstanten
Vergleichskonstanten


FileSystemObject-Konstanten

FileSystemObject-Konstanten 		Scripting-Laufzeitreferenz
Version 2

Siehe auch

FileSystemObject verfügt über zahlreiche hilfreiche Konstanten, die Sie in Ihrem Code verwenden können. Konstanten bieten eine ausgezeichnete Möglichkeit, bestimmte Werte zu verwenden, ohne sich dabei den eigentlichen Wert merken zu müssen. Darüber hinaus ist der Code einfacher zu pflegen, wenn sich der Wert von Konstanten ändert.

Je nach Scripting-Host sind diese Konstanten möglicherweise bereits definiert. In diesem Fall können Sie die Konstanten an der gewünschten Stelle im Code anstelle der darzustellenden Werte einsetzen. In den Fällen, wo der Scripting-Host nicht explizit auf die Datei SCRRUN.DLL verweist, müssen Sie diese Konstanten vor einer Verwendung in Ihrem Code definieren. Beispiele dafür sind Microsoft Internet Explorer und Microsoft Internet-Informationsdienste (IIS).

Die folgende Auflistung beschreibt die verschiedenen Kategorien von Konstanten, die für FileSystemObject zur Verfügung stehen:

Dateiattributkonstanten
Definiert die verschiedenen Dateiattribute, z. B. Versteckt, Schreibgeschützt usw.

Dateieingabe-/-ausgabekonstanten
Definiert die mit Dateiein- und -ausgaben verwendeten Konstanten.

Laufwerktypkonstanten
Definiert die verschiedenen auf dem Hostcomputer verfügbaren Laufwerktypen, z. B. Fest, Austauschbar, CD-ROM usw.

SpecialFolder-Konstante
Definiert in Ihrem Betriebssystem verfügbare Sonderordner.


FileSystemObject-Konstanten

FileSystemObject-Konstanten
Siehe auch 		Scripting-Laufzeitreferenz

VBScript-Konstanten


Verschiedene Konstanten

Verschiedene Konstanten 		Sprachverzeichnis
Version 2

Siehe auch

Da diese Konstante in VBScript integriert ist, müssen Sie diese vor einer Verwendung nicht definieren. Verwenden Sie diese Konstante in Ihrem Code an einer beliebigen Stelle, um die jeweils angezeigten Werte darzustellen.

Konstante Wert Beschreibung
vbObjectError -2147221504 Benutzerdefinierte Fehlernummern sollten größer als dieser Wert sein. Beispiel:
Err.Raise Number = vbObjectError + 1000


Verschiedene Konstanten

Verschiedene Konstanten
Siehe auch 		Sprachverzeichnis

Datums- und Uhrzeitkonstanten
Datumsformatkonstanten
Farbkonstanten
MsgBox-Konstanten
Tristate-Konstanten
VarType-Konstanten
Vergleichskonstanten
Zeichenfolgenkonstanten


MsgBox-Konstanten

MsgBox-Konstanten 		Sprachverzeichnis
Version 2

Siehe auch

Die folgenden Konstanten werden mit der MsgBox-Funktion verwendet, um festzulegen, welche Schaltflächen und Symbole in einem Meldungsfeld angezeigt werden und welche Schaltfläche standardmäßig aktiviert ist. Darüber hinaus kann die "Gebundenheit von" MsgBox festgelegt werden. Da diese Konstanten in VBScript integriert sind, müssen Sie diese vor einer Verwendung nicht definieren. Verwenden Sie diese Konstanten in Ihrem Code an einer beliebigen Stelle, um die jeweils angezeigten Werte darzustellen.

Konstante | Wert | Beschreibung
vbOKOnly | 0 | Nur Schaltfläche OK anzeigen.
vbOKCancel | 1 | Anzeigen der Schaltflächen OK und Abbrechen.
vbAbortRetryIgnore | 2 | Anzeigen der Schaltflächen Abbrechen, Wiederholen und Ignorieren.
vbYesNoCancel | 3 | Anzeigen der Schaltflächen Ja, Nein und Abbrechen.
vbYesNo | 4 | Anzeigen der Schaltflächen Ja und Nein.
vbRetryCancel | 5 | Anzeigen der Schaltflächen Wiederholen und Abbrechen.
vbCritical | 16 | Meldung mit Stopp-Symbol anzeigen.
vbQuestion | 32 | Meldung mit Fragezeichen-Symbol anzeigen.
vbExclamation | 48 | Anzeigen des Symbols Warnung.
vbInformation | 64 | Anzeigen des Symbols Information.
vbDefaultButton1 | 0 | Erste Schaltfläche ist Standard.
vbDefaultButton2 | 256 | Zweite Schaltfläche ist Standard.
vbDefaultButton3 | 512 | Dritte Schaltfläche ist Standard.
vbDefaultButton4 | 768 | Vierte Schaltfläche ist Standard.
vbApplicationModal | 0 | Anwendungsgebunden. Der Benutzer muss das Meldungsfeld bestätigen, bevor mit der Anwendung fortgefahren werden kann.
vbSystemModal | 4096 | Systemgebunden. Bei Win16-Systemen werden alle Anwendungen angehalten, bis der Benutzer das Meldungsfeld bestätigt hat. Bei Win32-Systemen wird durch diese Konstante ein anwendungsgebundenes Meldungsfeld eingeblendet, das immer im Vordergrund steht und andere ausgeführte Programme überlagert.

Die folgenden Konstanten werden mit der MsgBox-Funktion verwendet, um festzustellen, welche Schaltfläche ein Benutzer gewählt hat. Diese Konstanten sind nur verfügbar, wenn Ihr Projekt explizit auf die entsprechende Typbibliothek mit diesen Definitionen der Konstanten verweist. In VBScript müssen Sie diese Konstanten explizit in Ihrem Code deklarieren.

Konstante | Wert | Beschreibung
vbOK | 1 | Es wurde auf die Schaltfläche OK geklickt.
vbCancel | 2 | Es wurde auf die Schaltfläche Abbrechen geklickt.
vbAbort | 3 | Es wurde auf die Schaltfläche Abbrechen geklickt.
vbRetry | 4 | Es wurde auf die Schaltfläche Wiederholen geklickt.
vbIgnore | 5 | Es wurde auf die Schaltfläche Ignorieren geklickt.
vbYes | 6 | Es wurde auf die Schaltfläche Ja geklickt.
vbNo | 7 | Es wurde auf die Schaltfläche Nein geklickt.


MsgBox-Konstanten

MsgBox-Konstanten
Siehe auch 		Sprachverzeichnis

Datums- und Uhrzeitkonstanten
Datumsformatkonstanten
Farbkonstanten
Tristate-Konstanten
VarType-Konstanten
Verschiedene Konstanten
Vergleichskonstanten
Zeichenfolgenkonstanten


SpecialFolder-Konstanten

SpecialFolder-Konstanten 		Scripting-Laufzeitreferenz
Version 3

Siehe auch

Folgende Konstanten sind nur verfügbar, wenn Ihr Projekt explizit auf eine entsprechende Typbibliothek verweist, die diese Definitionen der Konstanten enthält. In VBScript müssen Sie diese Konstanten explizit in Ihrem Code deklarieren.

Konstante | Wert | Beschreibung
WindowsFolder | 0 | Der Ordner Windows enthält die Dateien, die vom Betriebssystem Windows installiert werden.
SystemFolder | 1 | Der Ordner System enthält Bibliotheken, Schriften und Gerätetreiber.
TemporaryFolder | 2 | Im Ordner Temp werden temporäre Dateien gespeichert. Den Pfad finden Sie in der Umgebungsvariablen TMP.


SpecialFolder-Konstanten

SpecialFolder-Konstanten
Siehe auch 		Scripting-Laufzeitreferenz

Dateiattributkonstanten
Dateieingabe-/-ausgabekonstanten
Laufwerktypkonstanten
Tristate-Konstanten
Vergleichskonstanten


Zeichenfolgenkonstanten

Zeichenfolgenkonstanten 		Sprachverzeichnis
Version 2

Siehe auch

Da diese Konstanten in VBScript integriert sind, müssen Sie sie vor einer Verwendung nicht definieren. Verwenden Sie diese Konstanten in Ihrem Code an einer beliebigen Stelle, um die jeweils angezeigten Werte darzustellen.

Konstante | Wert | Beschreibung
vbCr | Chr(13) | Wagenrücklauf.
vbCrLf | Chr(13) & Chr(10) | Wagenrücklauf-Zeilenvorschub.
vbFormFeed | Chr(12) | Seitenvorschub (nicht sinnvoll unter Microsoft Windows).
vbLf | Chr(10) | Zeilenvorschub.
vbNewLine | Chr(13) & Chr(10) oder Chr(10) | Plattformspezifisches Zeilenumbruchzeichen (je nach Plattform unterschiedlich).
vbNullChar | Chr(0) | Zeichen mit dem Wert 0.
vbNullString | Zeichenfolge mit dem Wert 0 | Entspricht nicht einer Zeichenfolge mit der Länge Null (""); für den Aufruf externer Prozeduren.
vbTab | Chr(9) | Horizontaler Tabstopp.
vbVerticalTab | Chr(11) | Vertikaler Tabstopp (nicht sinnvoll unter Microsoft Windows).


Zeichenfolgenkonstanten

Zeichenfolgenkonstanten
Siehe auch 		Sprachverzeichnis

Datums- und Uhrzeitkonstanten
Datumsformatkonstanten
Farbkonstanten
MsgBox-Konstanten
Tristate-Konstanten
VarType-Konstanten
Vergleichskonstanten
Verschiedene Konstanten


Tristate-Konstanten

Tristate-Konstanten 		Sprachverzeichnis
Version 2

Siehe auch

Da diese Konstanten in VBScript integriert sind, müssen Sie sie vor einer Verwendung nicht definieren. Verwenden Sie diese Konstanten in Ihrem Code an einer beliebigen Stelle, um die jeweils angezeigten Werte darzustellen.

Konstante | Wert | Beschreibung
vbUseDefault | -2 | Verwendet die Standardeinstellungen des Gebietsschemas des Computers.
vbTrue | -1 | True
vbFalse | 0 | False


Tristate-Konstanten

Tristate-Konstanten
Siehe auch 		Sprachverzeichnis

Datums- und Uhrzeitkonstanten
Datumsformat-Konstanten
Farbkonstanten
MsgBox-Konstanten
VarType-Konstanten
Vergleichskonstanten
Verschiedene-Konstanten
Zeichenfolgenkonstanten


VarType-Konstanten

VarType-Konstanten 		Sprachverzeichnis
Version 2

Siehe auch

Folgende Konstanten sind nur verfügbar, wenn Ihr Projekt explizit auf eine entsprechende Typbibliothek verweist, die diese Definitionen der Konstanten enthält. In VBScript müssen Sie diese Konstanten explizit in Ihrem Code deklarieren.

Konstante | Wert | Beschreibung
vbEmpty | 0 | Nicht initialisiert (Voreinstellung)
vbNull | 1 | Enthält keine gültigen Daten
vbInteger | 2 | Untertyp Integer
vbLong | 3 | Untertyp Long
vbSingle | 4 | Untertyp Single
vbSingle | 5 | Untertyp Double
vbCurrency | 6 | Untertyp Currency
vbDate | 7 | Untertyp Date
vbString | 8 | Untertyp String
vbObject | 9 | Objekt
vbError | 10 | Untertyp Error
vbBoolean | 11 | Untertyp Boolean
vbVariant | 12 | Variant (nur für Variant-Datenfelder)
vbDataObject | 13 | Datenzugriffsobjekt
vbDecimal | 14 | Untertyp Decimal
vbByte | 17 | Untertyp Byte
vbArray | 8192 | Datenfeld


VarType-Konstanten

VarType-Konstanten
Siehe auch 		Sprachverzeichnis

Datums- und Uhrzeitkonstanten
Datumsformat-Konstanten
Farbkonstanten
MsgBox-Konstanten
Tristate-Konstanten
Vergleichskonstanten
Verschiedene Konstanten
Zeichenfolgenkonstanten


VBScript-Konstanten

VBScript-Konstanten 		Sprachverzeichnis
Version 2

Siehe auch

In VBScript sind zahlreiche hilfreiche Konstanten integriert, die Sie in Ihrem Code verwenden können. Konstanten bieten eine ausgezeichnete Möglichkeit, bestimmte Werte zu verwenden, ohne sich dabei den eigentlichen Wert merken zu müssen. Darüber hinaus ist der Code einfacher zu pflegen, wenn sich der Wert von Konstanten ändert. Da diese Konstanten bereits in VBScript definiert sind, müssen Sie diese in Ihrem Code nicht mehr explizit deklarieren. Setzen Sie die Konstanten einfach anstelle der darzustellenden Werte.

Die folgende Auflistung beschreibt die verschiedenen Kategorien von Konstanten, die in VBScript zur Verfügung stehen:

Datums- und Uhrzeitkonstanten
Definieren die für die verschiedenen Datums- und Uhrzeitfunktionen relevanten Konstanten.

Datumsformat-Konstanten
Definieren Konstanten für die Formatierung von Datums- und Zeitangaben.

Farbkonstanten
Definieren die acht grundlegenden in Skripten verwendbaren Farben.

MsgBox-Konstanten
Definieren Konstanten zur Verwendung in MsgBox-Funktionen, um Schaltflächendarstellung, -bezeichnung, -verhalten sowie Rückgabewerte zu beschreiben.

Tristate-Konstanten
Definieren Konstanten zur Verwendung mit Funktionen, mit denen Zahlen formatiert werden.

VarType-Konstanten
Definieren die verschiedenen Variant-Untertypen.

Verschiedene Konstanten
Definieren Konstanten, die nicht problemlos einer anderen Kategorie zugeordnet werden können.

Zeichenfolgenkonstanten
Definieren zahlreiche nicht druckbare Zeichen für die Verwendung in Zeichenfolgenbearbeitungen.


VBScript-Konstanten

VBScript-Konstanten
Siehe auch 		Sprachverzeichnis

FileSystemObject-Konstanten


Initialize-Ereignis

Initialize-Ereignis 		Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Tritt auf, wenn eine Instanz der zugeordneten Klasse erstellt wird.
Syntax
Private Sub Class_Initialize()
Anweisungen
End Sub

Der Anweisungen-Teil besteht aus ein oder mehreren Programmieranweisungen, die bei der Initialisierung der Klasse ausgeführt werden.

Hinweise
Das folgende Beispiel veranschaulicht die Verwendung des Initialize-Ereignisses:
Class TestKlasse
  Private Sub Class_Initialize	' Initialize-Ereignis einrichten.
    MsgBox("TestKlasse wird ausgeführt")
  End Sub
  Private Sub Class_Terminate	' Terminate-Ereignis einrichten.
    MsgBox("TestKlasse beendet")
  End Sub
End Class

Set X = New TestKlasse	' Neue Instanz von TestKlasse erstellen.
Set X = Nothing		' Instanz freigeben.


Initialize-Ereignis

Initialize-Ereignis
Betrifft 		Sprachverzeichnis

Class-Objekt


Initialize-Ereignis

Initialize-Ereignis
Siehe auch 		Sprachverzeichnis

Class-Anweisung
Class-Objekt
Terminate-Ereignis


Terminate-Ereignis

Terminate-Ereignis 		Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Tritt auf, wenn die Instanz einer zugewiesenen Klasse beendet wird.
Syntax
Private Sub Class_Terminate()
Anweisungen
End Sub

Der Anweisungen-Teil besteht aus ein oder mehreren Programmieranweisungen, die bei der Initialisierung der Klasse ausgeführt werden.

Hinweise
Das folgende Beispiel veranschaulicht die Verwendung des Terminate-Ereignisses:
Class TestKlasse
  Private Sub Class_Initialize	' Initialize-Ereignis einrichten.
    MsgBox("TestKlasse wird ausgeführt")
  End Sub
  Private Sub Class_Terminate	' Terminate-Ereignis einrichten.
    MsgBox("TestKlasse beendet")
  End Sub
End Class

Set X = New TestKlasse	' Neue Instanz von TestKlasse erstellen.
Set X = Nothing		' Instanz freigeben.


Terminate-Ereignis

Terminate-Ereignis
Betrifft 		Sprachverzeichnis

Class-Objekt


Terminate-Ereignis

Terminate-Ereignis
Siehe auch 		Sprachverzeichnis

Class-Anweisung
Class-Objekt
Initialize-Ereignis


Abs-Funktion

Abs-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt den Absolutwert einer Zahl zurück.
Syntax
Abs(Zahl)

Das Argument Zahl kann ein beliebiger gültiger numerischer Ausdruck sein. Wenn Zahl den Wert Null enthält, wird Null zurückgegeben. Wenn die Variable nicht initialisiert ist, wird der Wert Null (0) zurückgegeben.

Hinweise
Der Absolutwert einer Zahl ist der positive Betrag der Zahl. Sowohl Abs(-1) als auch Abs(1) geben z. B. den Wert 1 zurück.

Das folgende Beispiel verwendet die Abs-Funktion, um den Absolutwert einer Zahl zu errechnen:

Dim MeineZahl
MeineZahl = Abs(50.3)   ' gibt 50,3 zurück.
MeineZahl = Abs(-50.3)  ' gibt 50,3 zurück.


Abs-Funktion

Abs-Funktion
Siehe auch 		Sprachverzeichnis

Sgn-Funktion


Array-Funktion

Array-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt einen Wert vom Typ Variant zurück, der ein Datenfeld enthält.
Syntax
Array(Argumentliste)

Der erforderliche Parameter Argumentliste ist eine kommagetrennte Reihe von Werten, die den Datenfeldelementen in der Variant-Variablen zugewiesen werden. Werden keine Argumente angegeben, wird ein Datenfeld mit der Länge 0 erzeugt.

Hinweise
Die Notation zum Verweisen auf Elemente eines Datenfelds besteht aus dem Variablennamen, gefolgt von einer in Klammern stehenden Indexzahl für das betreffende Element. Im folgenden Beispiel erzeugt die erste Anweisung eine Variable A. Die zweite Anweisung weist der Variablen A ein Datenfeld zu. Die letzte Anweisung weist den Wert des zweiten Datenfeldelements einer anderen Variablen zu.
Dim A
A = Array(10,20,30)
B = A(2)  ' B ist jetzt 30.
Anmerkung Eine Variable, die nicht als Datenfeld deklariert ist, kann dennoch ein Datenfeld enthalten. Obwohl eine Variant-Variable, die ein Datenfeld enthält, sich konzeptionell von einer Variant-Elemente enthaltenden Datenfeldvariablen unterscheidet, wird auf die Elemente der Datenfelds auf dieselbe Weise zugegriffen.


Array-Funktion

Array-Funktion
Siehe auch 		Sprachverzeichnis

Dim-Anweisung


Asc-Funktion

Asc-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt den ANSI-Zeichencode zurück, der dem ersten Buchstaben in einer Zeichenfolge entspricht.
Syntax
Asc(Zeichenfolge)

Das Argument Zeichenfolge ist ein beliebiger gültiger Zeichenfolgenausdruck. Wenn Zeichenfolge keine Zeichen enthält, tritt ein Laufzeitfehler auf.

Hinweise
Im folgenden Beispiel gibt Asc den ANSI-Zeichencode des jeweiligen ersten Buchstabens einer Zeichenfolge zurück:
Dim EineZahl
EineZahl = Asc("A")      ' gibt 65 zurück.
EineZahl = Asc("a")      ' gibt 97 zurück.
EineZahl = Asc("Apfel")  ' gibt 65 zurück.
Anmerkung Die AscB-Funktion wird für Daten vom Typ Byte in einer Zeichenfolge verwendet. Statt den Zeichencode für das erste Zeichen zurückzugeben, gibt AscB das erste Byte zurück. AscW ist für 32-Bit-Plattformen vorgesehen, die Unicode-Zeichen verwenden. Sie gibt den Unicode-Zeichencode (wide) zurück, wodurch die Konvertierung von Unicode in ANSI entfällt.


Asc-Funktion

Asc-Funktion
Siehe auch 		Sprachverzeichnis

Chr-Funktion


Atn-Funktion

Atn-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt den Arkustangens einer Zahl zurück.
Syntax
Atn(Zahl)

Das Argument Zahl kann ein beliebiger gültiger numerischer Ausdruck sein.

Hinweise
Die Atn-Funktion berechnet aus dem Verhältnis von zwei Seiten eines rechtwinkligen Dreiecks (Zahl) den zugehörigen Winkel im Bogenmaß. Der Quotient ist das Längenverhältnis von Gegenkathete zu Ankathete. Der Wertebereich des Ergebnisses reicht von -pi/2 bis pi/2 (Bogenmaß).

Zur Umrechnung von Grad ins Bogenmaß muss die Gradangabe mit pi/180 multipliziert werden. Zur Umrechnung von Bogenmaß in Grad muss das Bogenmaß mit 180/pi multipliziert werden.

Das folgende Beispiel verwendet die Atn-Funktion, um den Wert von pi zu berechnen:

Dim pi
pi = 4 * Atn(1)   ' Berechnen des Wertes von pi.
Anmerkung Atn ist die Umkehrfunktion der trigonometrischen Funktion Tan. Diese berechnet aus dem im Argument angegebenen Winkel das Verhältnis der beiden Katheten eines rechtwinkligen Dreiecks. Verwechseln Sie Atn nicht mit dem Kotangens, der dem Kehrwert des Tangens (1/Tangens) entspricht.


Atn-Funktion

Atn-Funktion
Siehe auch 		Sprachverzeichnis

Abgeleitete mathematische Funktionen
Cos-Funktion
Sin-Funktion
Tan-Funktion


CBool-Funktion

CBool-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Boolean konvertiert wurde.
Syntax
CBool(Ausdruck)

Das Argument Ausdruck ist ein beliebiger gültiger Ausdruck.

Hinweise
Wenn Ausdruck gleich Null ist, wird False zurückgegeben, ansonsten wird True zurückgegeben. Wenn Ausdruck nicht als numerischer Wert interpretiert werden kann, tritt ein Laufzeitfehler auf.

Das folgende Beispiel verwendet die CBool-Funktion, um einen Ausdruck in den Untertyp Boolean zu konvertieren. Wenn der Ausdruck einen Wert ungleich Null darstellt, gibt CBool True zurück; andernfalls False.

Dim A, B, Probe
A = 5: B = 5            ' Initialisieren der Variablen.
Probe = CBool(A = B)    ' Probe wird True zugewiesen.
A = 0                   ' Legt den Wert der Variablen fest.
Probe = CBool(A)        ' Probe wird False zugewiesen.


CBool-Funktion

CBool-Funktion
Siehe auch 		Sprachverzeichnis

CByte-Funktion
CCur-Funktion
CDate-Funktion
CDbl-Funktion
CInt-Funktion
CLng-Funktion
CSng-Funktion
CStr-Funktion


CByte-Funktion

CByte-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Byte konvertiert wurde.
Syntax
CByte(Ausdruck)

Das Argument Ausdruck ist ein beliebiger gültiger Ausdruck.

Hinweise
Sie können Code mithilfe der Funktionen zum Umwandeln von Datentypen dokumentieren, um zu zeigen, dass das Ergebnis einer Operation einen bestimmten, vom Standarddatentyp abweichenden Datentyp haben soll. Verwenden Sie beispielsweise CByte, um bytebezogene Berechnungen zu erzwingen, wenn normalerweise Berechnungen auf Basis von Währungsbeträgen, Werten einfacher oder doppelter Genauigkeit oder ganzzahligen Werten erfolgen würden.

Verwenden Sie die CByte-Funktion, um international gültige Umwandlungen von einem beliebigen anderen Datentyp in den Untertyp Byte vorzunehmen. So werden z. B.verschiedene vom Gebietsschema des Computers abhängige Dezimalzeichen ebenso erkannt wie unterschiedliche Tausendertrennzeichen.

Wenn Ausdruck außerhalb des zulässigen Bereichs für den Unterdatentyp Byte liegt, tritt ein Fehler auf. Das folgende Beispiel verwendet die CByte-Funktion, um einen Ausdruck in den Untertyp Byte zu konvertieren:

Dim MeinDouble, MeinByte
MeinDouble = 125.5678           ' MeinDouble ist vom Typ Double.
MeinByte = CByte(MeinDouble)    ' MeinByte hat den Wert 126.


CByte-Funktion

CByte-Funktion
Siehe auch 		Sprachverzeichnis

CBool-Funktion
CCur-Funktion
CDate-Funktion
CDbl-Funktion
CInt-Funktion
CLng-Funktion
CSng-Funktion
CStr-Funktion


CCur-Funktion

CCur-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit Untertyp Currency konvertiert wurde.
Syntax
CCur(Ausdruck)

Das Argument Ausdruck ist ein beliebiger gültiger Ausdruck.

Hinweise
Sie können Code mithilfe der Funktionen zum Umwandeln von Datentypen dokumentieren, um anzuzeigen, dass das Ergebnis einer Operation einen bestimmten, vom Standarddatentyp abweichenden Datentyp haben soll. Verwenden Sie z. B. Ccur, um Gleitkommaarithmetik in Fällen zu erzwingen, in denen sonst Ganzzahlarithmetik verwendet würde.

Die CCur-Funktion sollte zum Konvertieren von Daten in den Untertyp Currency nach den internationalen Normen verwendet werden. So werden zum Beispiel verschiedene vom Gebietsschema des Computers abhängige Dezimalzeichen ebenso erkannt wie unterschiedliche Tausendertrennzeichen.

Das folgende Beispiel verwendet die CCur-Funktion, um einen Ausdruck in den Untertyp Currency zu konvertieren:

Dim MeinDouble, MeinCurr
MeinDouble = 543.214588          ' MeinDouble ist vom Typ Double.
MeinCurr = CCur(MeinDouble * 2)  ' Konvertiert das Ergebnis von MeinDouble * 2 (1086,429176)
                                 ' in den Typ Currency (1086,4292).


CCur-Funktion

CCur-Funktion
Siehe auch 		Sprachverzeichnis

CBool-Funktion
CByte-Funktion
CDate-Funktion
CDbl-Funktion
CInt-Funktion
CLng-Funktion
CSng-Funktion
CStr-Funktion


CDate-Funktion

CDate-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Date konvertiert wurde.
Syntax
CDate(Datum)

Das Argument Datum ist ein beliebiger zulässiger Datumsausdruck.

Hinweise
Mit der IsDate-Funktion können Sie bestimmen, ob Datum in ein Datum oder eine Uhrzeit umgewandelt werden kann. CDate erkennt sowohl Datumsliterale und Zeitliterale als auch bestimmte Zahlen, die im zulässigen Bereich für ein Datum liegen. Beim Umwandeln einer Zahl in ein Datumsformat wird der ganzzahlige Teil für das Datum verwendet. Nachkommastellen der Zahl werden in eine Tageszeit (beginnend bei 0:00) umgewandelt.

CDate erkennt alle Datumsformate, die im Gebietsschema des Systems ausgewählt werden können. Die richtige Reihenfolge von Tag, Monat und Jahr kann nicht immer bestimmt werden, wenn sich das Datumsformat von den im Gebietsschema verfügbaren Formaten unterscheidet. Außerdem wird ein langes Datumsformat nicht erkannt, wenn es auch eine Zeichenfolge für den Wochentag enthält.

Das folgende Beispiel verwendet die CDate-Funktion, um eine Zeichenfolge in ein Datum zu konvertieren. Im Allgemeinen wird das feste Kodieren von Datums- und Uhrzeitangaben als Zeichenfolgen (wie in diesem Beispiel) nicht empfohlen. Verwenden Sie stattdessen Datums- und Zeitliterale (z. B. #14/06/1962#, #16:45:23#).

MeinDate = "30 April 1961"      ' Legt das Datum fest.
MeinShortDate = CDate(MeinDate)	' Konvertierung zum Datentyp Date.
MeinTime = "16:35:47"		' Legt die Uhrzeit fest.
MeinShortTime = CDate(MeinTime)	' Konvertierung zum Datentyp Date.


CDate-Funktion

CDate-Funktion
Siehe auch 		Sprachverzeichnis

IsDate-Funktion


CDbl-Funktion

CDbl-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Double konvertiert wurde.
Syntax
CDbl(Ausdruck)

Das Argument Ausdruck ist ein beliebiger gültiger Ausdruck.

Hinweise
Sie können Code mithilfe der Funktionen zum Umwandeln von Datentypen dokumentieren, um anzuzeigen, dass das Ergebnis einer Operation einen bestimmten, vom Standarddatentyp abweichenden Datentyp haben soll. Mit CDbl oder CSng können Sie zum Beispiel Berechnungen mit Werten einfacher oder doppelter Genauigkeit durchführen, die normalerweise Währungswerte oder ganzzahlige Werte verwenden würden.

Verwenden Sie die CDbl-Funktion, um international gültige Umwandlungen eines beliebigen Datentyps in den Untertyp Double zu ermöglichen. So werden zum Beispiel verschiedene vom Gebietsschema des Computers abhängige Dezimalzeichen ebenso erkannt wie unterschiedliche Tausendertrennzeichen.

Dieses Beispiel verwendet die CDbl-Funktion, um einen Ausdruck in den Untertyp Double zu konvertieren.

Dim MeinCurr, MeinDouble
MeinCurr = CCur(234.456784)               ' MeinCurr ist eine vom Typ Currency (234,4567).
MeinDouble = CDbl(MeinCurr * 8.2 * 0.01)  ' Konvertiert das Ergebnis in einen Double-Typ (19,2254576).


CDbl-Funktion

CDbl-Funktion
Siehe auch 		Sprachverzeichnis

CBool-Funktion
CByte-Funktion
CCur-Funktion
CDate-Funktion
CInt-Funktion
CLng-Funktion
CSng-Funktion
CStr-Funktion


Chr-Funktion

Chr-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt das dem ANSI-Zeichencode entsprechende Zeichen zurück.
Syntax
Chr(Zeichencode)

Das Argument Zeichencode ist eine Zahl, die ein Zeichen festlegt.

Hinweise
Die Zahlen von 0 bis 31 entsprechen den (nicht darstellbaren) Standard-ASCII-Codes. Chr(10) gibt zum Beispiel ein Zeilenvorschubzeichen zurück.

Das folgende Beispiel verwendet die Chr-Funktion, um das Zeichen mit dem angegebenen Zeichencode zurückzugeben:

Dim MeinChr
MeinChr = Chr(65)    ' Gibt A zurück.
MeinChr = Chr(97)    ' Gibt a zurück.
MeinChr = Chr(62)    ' Gibt > zurück.
MeinChr = Chr(37)    ' Gibt % zurück.
Anmerkung Eine andere Funktion (ChrB) wird für Byte-Daten verwendet, die in einer Zeichenfolge enthalten sind. Anstelle eines Zeichens, das aus einem oder zwei Bytes bestehen kann, gibt ChrB immer ein einzelnes Byte zurück.ChrW ist für 32-Bit-Plattformen vorgesehen, die Unicode-Zeichen verwenden. Ihr Argument ist ein Unicode-Zeichencode (wide), wodurch die Konvertierung von ANSI in Unicode vermieden wird.


Chr-Funktion

Chr-Funktion
Siehe auch 		Sprachverzeichnis

Asc-Funktion


CInt-Funktion

CInt-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Integer konvertiert wurde.
Syntax
CInt(Ausdruck)

Das Argument Ausdruck ist ein beliebiger gültiger Ausdruck.

Hinweise
Sie können Code mithilfe der Funktionen zum Umwandeln von Datentypen dokumentieren, um anzuzeigen, dass das Ergebnis einer Operation einen bestimmten, vom Standarddatentyp abweichenden Datentyp haben soll. Mit CInt oder CLng können Sie zum Beispiel Berechnungen mit ganzzahligen Werten durchführen, die normalerweise Währungswerte oder Werte mit einfacher oder doppelter Genauigkeit verwenden würden.

Verwenden Sie die CInt-Funktion, um international gültige Umwandlungen eines beliebigen Datentyps in den Untertyp Integer zu ermöglichten. So werden zum Beispiel verschiedene vom Gebietsschema des Computers abhängige Dezimalzeichen ebenso erkannt wie unterschiedliche Tausendertrennzeichen.

Wenn Ausdruck außerhalb des zulässigen Bereichs für den Unterdatentyp Integer liegt, tritt ein Fehler auf.

Das folgende Beispiel verwendet die CInt-Funktion, um einen Wert zu einem Integer-Wert zu konvertieren:

Dim MeinDouble, MeinInt
MeinDouble = 2345.5678        ' MeinDouble ist vom Typ Double.
MeinInt = CInt(MeinDouble)    ' MeinInt hat den Wert 2346.
Hinweis CInt unterscheidet sich von den Funktionen Fix und Int, welche die Nachkommastellen einer Zahl abschneiden anstatt die Zahl zu runden. Ist der Nachkommateil einer Zahl genau gleich 0,5, rundet die CInt-Funktion immer auf die nächste gerade Zahl. So wird zum Beispiel 0,5 auf 0 gerundet, während 1,5 auf 2 gerundet wird.


CInt-Funktion

CInt-Funktion
Siehe auch 		Sprachverzeichnis

CBool-Funktion
CByte-Funktion
CCur-Funktion
CDate-Funktion
CDbl-Funktion
CLng-Funktion
CSng-Funktion
CStr-Funktion
Int-, Fix-Funktionen


CLng-Funktion

CLng-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Long konvertiert wurde.
Syntax
CLng(Ausdruck)

Das Argument Ausdruck ist ein beliebiger gültiger Ausdruck.

Hinweise
Sie können Code mithilfe der Funktionen zum Umwandeln von Datentypen dokumentieren, um anzuzeigen, dass das Ergebnis einer Operation einen bestimmten, vom Standarddatentyp abweichenden Datentyp haben soll. Mit CInt oder CLng können Sie zum Beispiel Berechnungen mit ganzzahligen Werten durchführen, die normalerweise Währungswerte oder Werte mit einfacher oder doppelter Genauigkeit verwenden würden.

Verwenden Sie die CLng-Funktion, um international gültige Umwandlungen eines beliebigen Datentyps in den Untertyp Long zu ermöglichen. So werden zum Beispiel verschiedene vom Gebietsschema des Computers abhängige Dezimalzeichen ebenso erkannt wie unterschiedliche Tausendertrennzeichen.

Wenn Ausdruck außerhalb des zulässigen Bereichs für den Unterdatentyp Long liegt, tritt ein Fehler auf.

Das folgende Beispiel verwendet die CLng-Funktion, um einen Wert in einen Long-Wert zu konvertieren:

Dim MeinWert1, MeinWert2, MeinLong1, MeinLong2
MeinWert1 = 25427.45: MeinWert2 = 25427.55	' MeinWert1, MeinWert2 sind vom Typ Double.
MeinLong1 = CLng(MeinWert1)			' MeinLong1 hat den Wert 25427.
MeinLong2 = CLng(MeinWert2)			' MeinLong2 hat den Wert 25428.
Anmerkung CLng unterscheidet sich von den Funktionen Fix und Int, welche die Nachkommastellen einer Zahl abschneiden, anstatt die Zahl zu runden. Ist der Nachkommateil einer Zahl genau gleich 0,5, rundet dieCLng-Funktion immer auf die nächste gerade Zahl. So wird zum Beispiel 0,5 auf 0 gerundet, während 1,5 auf 2 gerundet wird.


CLng-Funktion

CLng-Funktion
Siehe auch 		Sprachverzeichnis

CBool-Funktion
CByte-Funktion
CCur-Funktion
CDate-Funktion
CDbl-Funktion
CInt-Funktion
CSng-Funktion
CStr-Funktion
Int-, Fix-Funktionen


Cos-Funktion

Cos-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Berechnet den Kosinus eines Winkels.
Syntax
Cos(Zahl)

Das Argument Zahl kann ein beliebiger numerischer Ausdruck sein, der einen Winkel im Bogenmaß angibt.

Hinweise
Die Cos-Funktion berechnet das Verhältnis von zwei Seiten eines rechtwinkligen Dreiecks aus einem Winkel. Das Verhältnis ergibt sich aus der Länge der Ankathete dividiert durch die Länge der Hypotenuse. Das Ergebnis liegt im Bereich von -1 bis 1.

Zur Umrechnung von Grad ins Bogenmaß muss die Gradangabe mit pi/180 multipliziert werden. Zur Umrechnung von Bogenmaß in Grad muss das Bogenmaß mit 180/pi multipliziert werden.

Das folgende Beispiel verwendet die Cos-Funktion, um den Sekans eines Winkels zu berechnen:

Dim MeinWinkel, MeinSekans
MeinWinkel = 1.3                  ' Legt einen Winkel im Bogenmaß fest.
MeinSekans = 1 / Cos(MeinWinkel)  ' Berechnen des Sekans.


Cos-Funktion

Cos-Funktion
Siehe auch 		Sprachverzeichnis

Abgeleitete mathematische Funktionen
Atn-Funktion
Sin-Funktion
Tan-Funktion


CreateObject-Funktion

CreateObject-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Erstellt ein Automatisierungsobjekt und gibt einen Verweis darauf zurück.
Syntax
CreateObject(Servername.Klassenname [, Speicherort])

Die Syntax der CreateObject-Funktion hat folgende Teile:

Teil | Beschreibung
Servername | Erforderlich. Der Name der Anwendung, die das Objekt bereitstellt.
Klassenname | Erforderlich. Der Typ oder die Klasse des zu erstellenden Objekts.
Speicherort | Optional. Der Name des Netzwerkservers, auf dem das Objekt erstellt werden soll. Dieses Funktionsmerkmal ist ab Version 5.1 verfügbar.

Hinweise
Alle Automatisierungsserver stellen mindestens einen Objekttyp zur Verfügung. Eine Textverarbeitung kann beispielsweise ein Anwendungsobjekt, ein Dokumentobjekt und ein Symbolleistenobjekt bereitstellen.

Sie erstellen ein Automatisierungsobjekt, indem Sie das Objekt, das von CreateObject zurückgegeben wird, einer Objektvariablen zuweisen:

Dim ExcelTabelle
Set ExcelTabelle = CreateObject("Excel.Sheet")
Der Code startet die Anwendung, die das Objekt erstellt (in diesem Fall eine Microsoft Excel-Tabelle). Anschließend können Sie aus dem Code mit der von Ihnen festgelegten Objektvariablen auf das Objekt zugreifen. In diesem Beispiel können Sie auf Eigenschaften und Methoden des neuen Objekts mit der Objektvariablen ExcelTabelle und auf Eigenschaften und Methoden anderer Excel-Objekte wie dem Application-Objekt und der ActiveSheet.Cells-Auflistung zugreifen:
' Excel über das Application-Objekt sichtbar machen.
ExcelTabelle.Application.Visible = True
' Text in die ersten Zelle der Tabelle einfügen.
ExcelTabelle.ActiveSheet.Cells(1,1).Value = "Das ist Spalte A, Zeile 1"
' Tabelle speichern.
ExcelTabelle.SaveAs "C:\Eigene Dateien\TEST.XLS"
' Excel über die Quit-Methode des Application-Objekts beenden.
ExcelTabelle.Application.Quit
' Objektvariable freigeben.
Set ExcelTabelle = Nothing
Das Erstellen von Objekten auf einem Remoteserver kann nur durchgeführt werden, wenn die Internetsicherheit deaktiviert wurde. Sie können ein Objekt auf einem entfernten Netzwerkcomputer erstellen, indem Sie den Computernamen an das Argument Servername von CreateObject übergeben. Dieser Name entspricht dem Computernamenteil im Freigabenamen. Bei der Netzwerkfreigabe "\\meinserver\public" ist der Servername "meinserver". Darüber hinaus können Sie auch den Servernamen unter Verwendung des DNS-Formats oder einer IP-Adresse angeben.

Der nachstehend aufgeführte Code gibt die Versionsnummer einer Excel-Instanz zurück, die auf dem entfernten Netzwerkcomputer "meinserver" ausgeführt wird:

Function VersionAnzeigen
  Dim XLApp
  Set XLApp = CreateObject("Excel.Application", "MeinServer")
  VersionAnzeigen = XLApp.Version
End Function
Ist der angegebene Remoteserver nicht vorhanden oder kann er nicht gefunden werden, wird eine Fehlermeldung generiert.


CreateObject-Funktion

CreateObject-Funktion
Siehe auch 		Sprachverzeichnis

GetObject-Funktion


CSng-Funktion

CSng-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp Single konvertiert wurde.
Syntax
CSng(Ausdruck)

Das Argument Ausdruck ist ein beliebiger gültiger Ausdruck.

Hinweise
Sie können Code mithilfe der Funktionen zum Umwandeln von Datentypen dokumentieren, um anzuzeigen, dass das Ergebnis einer Operation einen bestimmten, vom Standarddatentyp abweichenden Datentyp haben soll. Mit CDbl oder CSng können Sie zum Beispiel Berechnungen mit Werten einfacher oder doppelter Genauigkeit durchführen, die normalerweise Währungswerte oder ganzzahlige Werte verwenden würden.

Verwenden Sie die CSng-Funktion, um international gültige Umwandlungen eines beliebigen Datentyps in den Untertyp Single zu ermöglichen. So werden zum Beispiel verschiedene vom Gebietsschema des Computers abhängige Dezimalzeichen ebenso erkannt wie unterschiedliche Tausendertrennzeichen.

Wenn Ausdruck außerhalb des zulässigen Bereichs für den Unterdatentyp Single liegt, tritt ein Fehler auf.

Das folgende Beispiel verwendet die CSng-Funktion, um einen Wert in den Untertyp Single zu konvertieren:

Dim MeinDouble1, MeinDouble2, MeinSingle1, MeinSingle2	' MeinDouble1, MeinDouble2 sind vom Typ Double.
MeinDouble1 = 75.3421115: MeinDouble2 = 75.3421555
MeinSingle1 = CSng(MeinDouble1)	  				' MeinSingle1 enthält den Wert 75,34211.
MeinSingle2 = CSng(MeinDouble2)	  				' MeinSingle2 enthält den Wert 75,34216.


CSng-Funktion

CSng-Funktion
Siehe auch 		Sprachverzeichnis

CBool-Funktion
CByte-Funktion
CCur-Funktion
Cdate-Funktion
CDbl-Funktion
CInt-Funktion
CLng-Funktion
CStr-Funktion


CStr-Funktion

CStr-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Ausdruck zurück, der in einen Wert vom Typ Variant mit dem Untertyp String konvertiert wurde.
Syntax
CStr(Ausdruck)

Das Argument Ausdruck ist ein beliebiger gültiger Ausdruck.

Hinweise
Sie können Code mithilfe der Funktionen zum Umwandeln von Datentypen dokumentieren, um anzuzeigen, dass das Ergebnis einer Operation einen bestimmten, vom Standarddatentyp abweichenden Datentyp haben soll. Verwenden Sie z. B. CStr, um zu erzwingen, dass das Ergebnis als String ausgedrückt wird.

Die CStr-Funktion sollte anstelle von Str verwendet werden, um Konvertierungen von Daten in den Untertyp Currency nach den internationalen Normen vorzunehmen. So werden beispielsweise in Abhängigkeit von den Einstellungen für das Gebietsschema des Computers verschiedene Dezimalzeichen erkannt.

Die Daten in Ausdruck legen die Rückgabewerte von CStr fest, wie in der folgenden Tabelle aufgeführt:

Datentyp von Ausdruck | Rückgabe von CStr
Boolean | Datentyp String mit dem Wert True oder False.
Date | Datentyp String mit Datum im kurzen Datumsformat Ihres Systems.
Null | Laufzeitfehler.
Empty | Eine leere Zeichenfolge vom Typ String ("").
Error | Eine Zeichenfolge vom Typ String mit dem Wort "Fehler" und der Fehlernummer.
Anderer numerischer Wert | Eine Zeichenfolge vom Typ String mit der Zahl.

Das folgende Beispiel verwendet die CStr-Funktion, um einen numerischen Wert in eine Zeichenfolge zu konvertieren:

Dim MeinDouble, MeinStr
MeinDouble = 437.324         ' MeinDouble ist vom Typ Double.
MeinStr = CStr(MeinDouble)   ' MeinStr enthält "437.324".


CStr-Funktion

CStr-Funktion
Siehe auch 		Sprachverzeichnis

CBool-Funktion
CByte-Funktion
CCur-Funktion
CDate-Funktion
CDbl-Funktion
CInt-Funktion
CLng-Funktion
CSng-Funktion


Date-Funktion

Date-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt das aktuelle Systemdatum zurück.
Syntax
Date
Hinweise
Das folgende Beispiel verwendet die Date-Funktion, um die aktuelle Systemzeit zurückzugeben:
Dim MeinDatum
MeinDatum = Date    ' MeinDatum enthält das aktuelle Systemdatum.


DateAdd Function

DateAdd-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt ein Datum zurück, zu dem ein angegebenes Zeitintervall addiert wurde.
Syntax
DateAdd(Intervall, Anzahl, Datum)

Die Syntax der DateAdd-Funktion hat die folgenden Teile:

Teil | Beschreibung
Intervall | Erforderlich. Zeichenfolgenausdruck für die Zeitspanne, die addiert werden soll. Gültige Werte werden im Abschnitt "Einstellungen" beschrieben.
Anzahl | Erforderlich. Numerischer Ausdruck für die Anzahl der Zeiträume, die Sie addieren möchten. Er kann entweder positiv für Daten in der Zukunft oder negativ für Daten in der Vergangenheit sein.
Datum | Erforderlich. Variant oder Literal für das Datum, zu dem Intervall addiert werden soll.

Einstellungen
Das Argument Intervall kann die folgenden Werte haben:

Einstellung | Beschreibung
yyyy | Jahr
q | Quartal
m | Monat
y | Tag im Jahr
d | Tag
w | Wochentag
ww | Woche im Jahr
h | Stunde
n | Minute
s | Sekunde

Hinweise
Mit der DateAdd-Funktion können Sie eine bestimmte Zeitspanne zu einem Datum addieren oder von einem Datum subtrahieren. Sie können mit DateAdd beispielsweise das Datum 30 Tage in der Zukunft oder die Zeit 45 Minuten in der Zukunft bestimmen. Um Tage zu Datum zu addieren, verwenden Sie den Tag des Jahres ("y"), den Tag ("d") oder den Wochentag ("w").

Von der Funktion DateAdd werden keine ungültigen Datumsangaben zurückgegeben. Im folgenden Beispiel wird ein Monat zum 31. Januar addiert:

NewDate = DateAdd("m", 1, "31-Jan-95")
In diesem Falle gibt DateAdd den Wert 28-Feb-95 zurück, nicht 31-Feb-95. Falls Datum den Wert 31-Jan-96 hat, wird der Wert 29-Feb-96 zurückgegeben, da 1996 ein Schaltjahr ist.

Liegt das berechnete Datum vor dem Jahr 100, wird ein Fehler ausgegeben.

Wenn Anzahl keine Zahl vom Typ Long ist, rundet die Funktion den Wert vor der Auswertung auf die nächste ganze Zahl.


DateAdd-Funktion

DateAdd-Funktion
Siehe auch 		Sprachverzeichnis

DateDiff-Funktion
DatePart-Funktion


Date-Funktion

Date-Funktion
Siehe auch 		Sprachverzeichnis

CDate-Funktion
Now-Funktion
Time-Funktion


DateDiff-Funktion

DateDiff-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt den Zeitraum zwischen zwei Datumsangaben zurück.
Syntax
DateDiff(Intervall, Datum1, Datum2 [,ErsterWochentag[, ErsteWocheimJahr]])

Die Syntax der DateDiff-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Intervall | Erforderlich. Zeichenfolgenausdruck für die Zeitspanne, die verwendet werden soll, um die Differenz zwischen Datum1 und Datum2 zu berechnen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.
Datum1, Datum2 | Erforderlich. Datumsausdrücke. Die beiden Datumsangaben zur Berechnung der Differenz.
ErsterWochentag | Optional. Konstante zur Angabe des Wochentags. Falls nicht angegeben, wird Sonntag als Wert angenommen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.
ErsteWocheimJahr | Optional. Konstante zur Angabe der ersten Woche des Jahres. Falls nicht angegeben, wird die Woche mit dem 1. Januar angenommen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.

Einstellungen
Das Argument Intervall kann die folgenden Werte haben:

Einstellung | Beschreibung
yyyy | Jahr
q | Quartal
m | Monat
y | Tag im Jahr
d | Tag
w | Wochentag
ww | Woche im Jahr
h | Stunde
n | Minute
s | Sekunde

Das Argument ErsterWochentag kann die folgenden Werte haben:

Konstante | Wert | Beschreibung
vbUseSystem | 0 | Einstellung der NLS (National Language Support)-API verwenden.
vbSunday | 1 | Sonntag (Standard)
vbMonday | 2 | Montag
vbTuesday | 3 | Dienstag
vbWednesday | 4 | Mittwoch
vbThursday | 5 | Donnerstag
vbFriday | 6 | Freitag
vbSaturday | 7 | Samstag

Das Argument ErsteWocheimJahr kann die folgenden Werte haben:

Konstante | Wert | Beschreibung
vbUseSystem | 0 | Einstellung der NLS (National Language Support)-API verwenden.
vbFirstJan1 | 1 | Mit der Woche beginnen, in die der 1. Januar fällt (Standard).
vbFirstFourDays | 2 | Mit der Woche beginnen, die mindestens 4 Tage des neuen Jahres hat.
vbFirstFullWeek | 3 | Mit der ersten vollen Woche im neuen Jahr beginnen.

Hinweise
Verwenden Sie die DateDiff-Funktion, um die Anzahl der angegebenen Zeiträume zwischen zwei Datumsangaben zu bestimmen. Mit DateDiff können Sie zum Beispiel die Anzahl der Tage zwischen zwei Datumsangaben oder die Anzahl der Wochen zwischen dem heutigen Tag und dem Jahresende berechnen.

Zur Berechnung der Tage zwischen Datum1 und Datum2 können Sie entweder den Tag im Jahr ("y") oder einen Tag ("d") verwenden. Ist Intervall der Wochentag ("w"), gibt DateDiff die Anzahl der Wochen zwischen zwei Datumsangaben zurück. Fällt Datum1 auf einen Montag, zählt DateDiff die Anzahl der Montage bis zu Datum2. Datum2 wird einbezogen, Datum1 jedoch nicht. Ist Intervall dagegen die Woche im Jahr ("ww"), gibt die DateDiff-Funktion die Anzahl der Kalenderwochen zwischen den beiden Datumsangaben zurück. Die Anzahl der Sonntage zwischen Datum1 und Datum2 wird gezählt. DateDiff bezieht Datum2 in die Zählung ein, wenn Letzteres auf einen Sonntag fällt. Datum1 wird selbst dann nicht einbezogen, wenn es auf einen Sonntag fällt.

Bezieht sich Datum1 auf einen späteren Zeitpunkt als Datum2, gibt die DateDiff-Funktion einen negativen Wert zurück.

Das Argument ErsterWochentag wirkt sich auf Berechnungen aus, welche die Zeitraumsymbole "w" und "ww" verwenden.

Ist Datum1 oder Datum2 ein Datumsliteral, wird das angegebene Jahr ein permanenter Teil dieses Datums. Wird Datum1 oder Datum2 in Anführungszeichen (" ") eingeschlossen und das Jahr nicht angegeben, wird das laufende Jahr immer dann in den Code eingefügt, wenn der Ausdruck Datum1 oder Datum2 ausgewertet wird. Auf diese Weise können Sie Code schreiben, der unabhängig von der Jahreszahl verwendet werden kann.

Wenn Sie den 31. Dezember mit dem 1. Januar des unmittelbar darauf folgenden Jahres vergleichen, gibt DateDiff für Jahr ("yyyy") den Wert 1 zurück, obwohl nur ein Tag vergangen ist.

Das folgende Beispiel zeigt die Verwendung der DateDiff-Funktion, um die Anzahl der Tage zwischen einem gegebenen und dem heutigen Datum anzuzeigen:

Function Datumsunterschied(dasDatum)
  Datumsunterschied = "Tage ab heute: " & DateDiff("d", Now, dasDatum)
End Function


DateDiff-Funktion

DateDiff-Funktion
Siehe auch 		Sprachverzeichnis

DateAdd-Funktion
DatePart-Funktion


DatePart-Funktion

DatePart-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt den angegebenen Teil eines Datums zurück.
Syntax
DatePart(Intervall, Datum [,ErsterWochentag[, ErsteWocheimJahr]])

Die Syntax der DatePart-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Intervall | Erforderlich. Zeichenfolgenausdruck für die Zeitspanne, die zurückgegeben werden soll. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.
Datum | Erforderlich. Datumsausdruck, der ausgewertet werden soll.
ErsterWochentag | Optional. Konstante zur Angabe des Wochentags. Falls nicht angegeben, wird Sonntag als Wert angenommen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.
ErsteWocheimJahr | Optional. Konstante zur Angabe der ersten Woche des Jahres. Falls nicht angegeben, wird die Woche mit dem 1. Januar angenommen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.

Einstellungen
Das Argument Intervall kann die folgenden Werte haben:

Einstellung | Beschreibung
yyyy | Jahr
q | Quartal
m | Monat
y | Tag im Jahr
d | Tag
w | Wochentag
ww | Woche im Jahr
h | Stunde
n | Minute
s | Sekunde

Das Argument ErsterWochentag kann die folgenden Werte haben:

Konstante | Wert | Beschreibung
vbUseSystem | 0 | Einstellung der NLS (National Language Support)-API verwenden.
vbSunday | 1 | Sonntag (Standard)
vbMonday | 2 | Montag
vbTuesday | 3 | Dienstag
vbWednesday | 4 | Mittwoch
vbThursday | 5 | Donnerstag
vbFriday | 6 | Freitag
vbSaturday | 7 | Samstag

Das Argument ErsteWocheimJahr kann die folgenden Werte haben:

Konstante | Wert | Beschreibung
vbUseSystem | 0 | Einstellung der NLS (National Language Support)-API verwenden.
vbFirstJan1 | 1 | Mit der Woche beginnen, in die der 1. Januar fällt (Standard).
vbFirstFourDays | 2 | Mit der Woche beginnen, die mindestens 4 Tage des neuen Jahres enthält.
vbFirstFullWeek | 3 | Mit der ersten vollen Woche im neuen Jahr beginnen.

Hinweise
Mit der DatePart-Funktion können Sie ein Datum auswerten und eine bestimmte Zeitspanne zurückgeben. Sie können mit DatePart zum Beispiel den Wochentag oder die aktuelle Stunde berechnen.

Das Argument ErsterWochentag wirkt sich auf Berechnungen aus, welche die Zeitraumsymbole "w" und "ww" verwenden.

Ist Datum ein Datumsliteral, wird das angegebene Jahr ein permanenter Teil dieses Datums. Wird Datum jedoch in Anführungszeichen (" ") eingeschlossen und das Jahr nicht angegeben, wird das laufende Jahr immer dann in den Code eingefügt, wenn der Ausdruck Datum ausgewertet wird. Auf diese Weise können Sie Code schreiben, der unabhängig von der Jahreszahl verwendet werden kann.

Dieses Beispiel zeigt die Verwendung der DatePart-Funktion, indem es das Quartal eines gegebenen Datums anzeigt.

Function QuartalAnzeigen(dasDatum)
  QuartalAnzeigen = DatePart("q", dasDatum)
End Function


DatePart Function

DatePart-Funktion
Siehe auch 		Sprachverzeichnis

DateAdd-Funktion
DateDiff-Funktion


DateSerial-Funktion

DateSerial-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Wert vom Typ Variant mit dem Untertyp Date einer Tages-, Monats- oder Jahresangabe zurück.
Syntax
DateSerial(Jahr, Monat, Tag)

Die Syntax der DateSerial-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Jahr | Zahl im Bereich von 100 bis 9999 (je einschließlich) oder ein numerischer Ausdruck.
Monat | Beliebiger numerischer Ausdruck.
Tag | Beliebiger numerischer Ausdruck.

Hinweise
Wenn Sie ein Datum (zum Beispiel den 31. Dezember 1993) angeben, müssen sich die Werte für die Argumente von DateSerial im jeweils gültigen Bereich befinden, also im Bereich 1-31 für Tage und 1-12 für Monate. Alternativ können Sie einen relativen Wert für die einzelnen Argumente mit einem beliebigen numerischen Ausdruck angeben, der eine bestimmte Anzahl an Tagen, Monaten oder Jahren vor oder nach einem Datum angibt.

Das folgende Beispiel verwendet numerische Ausdrücke anstelle von absoluten Datumszahlen. Die DateSerial-Funktion gibt in diesem Fall das Datum für den Tag vor dem ersten Tag (1 - 1) des Monats zurück, der zwei Monate vor August (8 - 2) liegt, und zwar 10 Jahre vor dem Jahr 1990 (1990 - 10). Das Ergebnis ist der 31. Mai 1980.

Dim MeinDate1, MeinDate2
MeinDate1 = DateSerial(1970, 1, 1)			' Gibt den 1. Januar 1970 zurück.
MeinDate2 = DateSerial(1990 - 10, 8 - 2, 1 - 1)	' Gibt den 31. Mai 1980 zurück.
Für das Argument Jahr werden Werte zwischen 0 und 99 (je einschließlich) als die Jahre 1900-1999 angesehen. Für alle anderen Argumente in Jahr müssen alle vier Stellen der Jahreszahl angegeben werden (z. B. 1800).

Wenn ein Argument den normalen zulässigen Bereich für das Argument überschreitet, erfolgt ein Übertrag auf die nächstgrößere Einheit. Wenn Sie zum Beispiel 35 Tage angeben, wird dies als ein Monat und eine bestimmte Anzahl von Tagen interpretiert, wobei die Anzahl der Tage vom verwendeten Jahr abhängt. Wenn aber entweder eines der Argumente außerhalb des Bereichs -32.768 bis 32.767 oder das durch die drei Argumente (direkt oder durch einen Ausdruck) angegebene Datum außerhalb des zulässigen Bereichs liegt, tritt ein Fehler auf.


DateSerial-Funktion

DateSerial-Funktion
Siehe auch 		Sprachverzeichnis

Date-Funktion
DateValue-Funktion
Day-Funktion
Month-Funktion
Now-Funktion
TimeSerial-Funktion
TimeValue-Funktion
Weekday-Funktion
Year-Funktion


DateValue-Funktion

DateValue-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück.
Syntax
DateValue(Datum)

Das Argument Datum ist normalerweise ein Zeichenfolgenausdruck, der ein Datum aus dem Bereich vom 1. Januar 100 bis 31. Dezember 9999 darstellt. Alternativ können Sie für Datum aber auch einen beliebigen Ausdruck angeben, der ein Datum und/oder eine Zeit aus diesem Bereich darstellen kann.

Hinweise
Wenn das Argument Datum eine Zeitangabe enthält, wird diese von DateValue nicht zurückgegeben. Wenn Datum jedoch eine ungültige Zeitangabe enthält (zum Beispiel "89:98"), tritt ein Fehler auf.

Wenn Datum eine Zeichenfolge ist, die nur durch gültige Datumstrennzeichen getrennte Zahlen enthält, wird von DateValue die Reihenfolge für Monat, Tag und Jahr entsprechend dem für das System eingestellten Format für kurze Datumsangaben angenommen. DateValue erkennt auch eindeutige Datumsangaben, die Monatsnamen sowohl in langer als auch in Kurzform enthalten. DateValue erkennt zum Beispiel neben 30.12.1993 und 30.12.93 auch 30. Dezember 1993 und 30. Dez 1993.

Wenn Sie das Jahr in Datum nicht angeben, verwendet DateValue das aktuelle Jahr aus dem Systemdatum des Computers.

Das folgende Beispiel verwendet die Funktion DateValue, um eine Zeichenfolge in ein Datum zu konvertieren. Sie können auch Datumsliterale verwenden, um ein Datum direkt einer Variant-Variablen zuzuweisen. Beispiel: MeinDatum = #9/11/63#.

Dim MeinDatum
MeinDatum = DateValue("11. September 1963")    ' Gibt ein Datum zurück.


DateValue-Funktion

DateValue-Funktion
Siehe auch 		Sprachverzeichnis

CDate-Funktion
DateSerial-Funktion
Day-Funktion
Month-Funktion
Now-Funktion
TimeSerial-Funktion
TimeValue-Funktion
Weekday-Funktion
Year-Funktion


Day-Funktion

Day-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt den Tag des Monats als ganze Zahl im Bereich von 1 bis 31 zurück.
Syntax
Day(Datum)

Das Argument Datum ist ein beliebiger Ausdruck, der ein Datum darstellen kann. Wenn Datum den Wert Null enthält, wird Null zurückgegeben.

Das folgende Beispiel verwendet die Day-Funktion, um den Tag in einem Monat eines bestimmten Datums zu ermitteln:

Dim EinTag
EinTag = Day("19. Oktober 1962")  ' EinTag enthält 19.


Day-Funktion

Day-Funktion
Siehe auch 		Sprachverzeichnis

Date-Funktion
Hour-Funktion
Minute-Funktion
Month-Funktion
Now-Funktion
Second-Funktion
Weekday-Funktion
Year-Funktion


Eval-Funktion

Eval-Funktion 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Wertet einen Ausdruck aus und gibt das Ergebnis zurück.
Syntax
[Ergebnis = ]Eval(Ausdruck)

Die Syntax der Eval-Funktion hat folgende Teile:

Teil | Beschreibung
Ergebnis | Optional. Variable zu der die Rückgabezuweisung erfolgt. Wird Ergebnis nicht angegeben, sollten Sie die Execute-Anweisung verwenden.
Ausdruck | Erforderlich. Zeichenfolge, die einen gültigen VBScript-Ausdruck enthält.

Hinweise
In VBScript kann x = y auf zwei Arten interpretiert werden. Die erste Möglichkeit ist eine Zuweisungsanweisung, bei der der y-Wert x zugewiesen wird. Die zweite Interpretation ist ein Ausdruck, der überprüft, ob x und y den gleichen Wert haben. In diesem Fall wird Ergebnis der Wert True zugewiesen; sind sie nicht gleich, ist Ergebnis False. Die Eval-Funktion verwendet stets die zweite Interpretation, wohingegen bei der Execute-Anweisung die erste Interpretation verwendet wird.

Hinweis Bei Microsoft® Jscript® besteht keine Verwechslungsgefahr zwischen Zuweisungen und Vergleichen, da Zuweisungsoperator (=) und Vergleichsoperator (==) unterschiedlich sind.

Das folgende Beispiel verdeutlicht die Verwendung der Eval-Funktion:

Sub ZahlAusdenken
  Dim Annahme, Zufallszahl
  Zufallszahl = Int((100) * Rnd(1) + 1)
  Annahme = CInt(InputBox("Geben Sie Ihre Annahme ein:",,0))
  Do
    If Eval("Annahme = Zufallszahl") Then
      MsgBox "Glückwunsch! Richtig geraten!"
      Exit Sub
    Else
      Annahme = CInt(InputBox("Leider nein! Versuchen Sie es noch einmal.",,0))
    End If
  Loop Until Annahme = 0
End Sub


Eval-Funktion

Eval-Funktion
Siehe auch 		Sprachverzeichnis

Execute-Anweisung


Exp-Funktion

Exp-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt e (die Basis des natürlichen Logarithmus) potenziert mit einer Zahl zurück.
Syntax
Exp(Zahl)

Das Argument Zahl kann ein beliebiger gültiger numerischer Ausdruck sein.

Hinweise
Überschreitet Zahl den Wert 709,782712893, tritt ein Fehler auf. Die Konstante e entspricht ungefähr dem Wert 2,718282.
Anmerkung Die Exp-Funktion stellt die Umkehrfunktion zur Log-Funktion dar und wird manchmal als Antilogarithmus bezeichnet.

Das folgende Beispiel zeigt die Verwendung der Exp-Funktion, um eine Potenz zur Basis e zu berechnen:

Dim MeinWinkel, MeinHSin   ' Legt einen Winkel im Bogenmaß fest.
MeinWinkel = 1.3           ' Berechnet den Sinus Hyperbolicus
MeinHSin = (Exp(MeinWinkel) - Exp(-1 * MeinWinkel)) / 2


Exp-Funktion

Exp-Funktion
Siehe auch 		Sprachverzeichnis

Abgeleitete mathematische Funktionen
Log-Funktion


Filter-Funktion

Filter-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gib ein nullbasiertes Datenfeld zurück, das anhand bestimmter Filterkriterien einen Teilbereich eines ZeichenfolgenDatenfeldes enthält.
Syntax
Filter(Zeichenfolgen, Wert[, Einschließen[, Vergleich]])

Die Syntax der Filter-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Zeichenfolgen | Erforderlich. Eindimensionales Datenfeld aus Zeichenfolgen, das durchsucht werden soll.
Wert | Erforderlich. Zeichenfolge, nach der gesucht werden soll.
Einschließen | Optional. Optionaler boolescher Wert, der anzeigt, ob Teilzeichenfolgen zurückgegeben werden sollen, die Wert enthalten oder nicht enthalten. Ist Einschließen gleich True, gibt Filter die Teile des Datenfeldes zurück, die Wert als Teilzeichenfolge enthalten. Ist Einschließen gleich False, gibt Filter die Teile des Datenfeldes zurück, die Wert nicht als Teilzeichenfolge enthalten.
Vergleich | Optional. Numerischer Wert für die zu verwendende Art des Zeichenfolgenvergleichs. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.

Einstellungen
Das Argument Vergleich kann die folgenden Werte haben:

Konstante | Wert | Beschreibung
vbBinaryCompare | 0 | Führt einen binären Vergleich durch.
vbTextCompare | 1 | Führt einen Textvergleich durch.

Hinweise
Werden keine Übereinstimmungen mit Wert in Zeichenfolgen gefunden, gibt Filter ein leeres Datenfeld zurück. Ein Fehler tritt auf, wenn Zeichenfolgen den Wert Null hat oder kein eindimensionales Datenfeld ist.

Das von der Filter-Funktion zurückgegebene Datenfeld enthält nur so viele Elemente, wie zur Aufnahme der übereinstimmenden Elemente notwendig sind.

Das folgende Beispiel zeigt die Verwendung der Filter-Funktion, um ein Datenfeld nach der Zeichenfolge "Mon" zu durchsuchen:

Dim MeinIndex
Dim MeinDatenfeld(3)
MeinDatenfeld(0) = "Sonntag"
MeinDatenfeld(1) = "Montag"
MeinDatenfeld(2) = "Dienstag"
MeinIndex = Filter(MeinDatenfeld, "Mon") ' MeinIndex(0) enthält "Montag".


Filter-Funktion

Filter-Funktion
Siehe auch 		Sprachverzeichnis

Replace-Funktion


FormatCurrency-Funktion

FormatCurrency-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt einen Ausdruck als Währungsbetrag zurück, der mit dem in der Systemsteuerung festgelegten Währungssymbol formatiert ist.
Syntax
FormatCurrency(Ausdruck[,AnzDezimalstellen [,FührendeNull [,KlammernFürNegativeWerte [,ZiffernGruppieren]]]])

Die Syntax der FormatCurrency-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Ausdruck | Erforderlich. Zu formatierender Ausdruck.
AnzDezimalstellen | Optional. Numerischer Wert, der angibt, wie viele Stellen rechts vom Dezimalkomma angezeigt werden. Die Voreinstellung lautet -1. Sie zeigt an, dass die Ländereinstellungen des Computers verwendet werden.
FührendeNull | Optional. Tristate-Konstante für die Anzeige von führenden Nullen bei Dezimalzahlen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.
KlammernFürNegativeWerte | Optional. Tristate-Konstante für die Verwendung von Klammern bei negativen Werten. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.
ZiffernGruppieren | Optional. Tristate-Konstante für die Gruppierung von Zahlen mit dem in den Ländereinstellungen des Computers angegebenen Trennzeichen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.

Einstellungen
Die Argumente FührendeNull, KlammernFürNegativeWerte und ZiffernGruppieren haben folgende Werte:

Konstante | Wert | Beschreibung
TristateTrue | -1 | True
TristateFalse | 0 | False
TristateUseDefault | -2 | Ländereinstellungen des Computers verwenden.

Hinweise
Fehlende Werte durch Weglassen eines oder mehrerer optionaler Argumente werden aus den Ländereinstellungen des Computers übernommen. Die Position des Währungssymbols relativ zum Währungsbetrag wird durch die Ländereinstellungen des Computers bestimmt.

Anmerkung Die Position des Währungssymbols relativ zum Währungsbetrag wird durch die Ländereinstellungen des Computers bestimmt.

Das folgende Beispiel zeigt die Verwendung der FormatCurrency-Funktion, um einen Ausdruck als Währung zu formatieren und der Variablen MeinGeld zuzuweisen:

Dim MeinGeld
MeinGeld = FormatCurrency(1000)  ' MeinGeld enthält 1.000,00 DM.


FormatCurrency-Funktion

FormatCurrency-Funktion
Siehe auch 		Sprachverzeichnis

FormatDateTime-Funktion
FormatNumber-Funktion
FormatPercent-Funktion


FormatDateTime-Funktion

FormatDateTime-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt einen Ausdruck im Datums- oder Zeitformat zurück.
Syntax
FormatDateTime(Datum[,Formatname])

Die Syntax der FormatDateTime-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Datum | Erforderlich. Zu formatierender Datumsausdruck.
Formatname | Optional. Numerischer Wert zum Kennzeichnen des verwendeten Datum/Uhrzeit-Formats. Ohne Angabe dieses Wertes wird vbGeneralDate verwendet.

Einstellungen
Das Argument Formatname hat folgende Einstellungen:

Konstante | Wert | Beschreibung
vbGeneralDate | 0 | Anzeigen von Datum und/oder Uhrzeit. Gibt es einen Datumsanteil, wird dafür das kurze Datumsformat verwendet. Gibt es einen Zeitanteil, erfolgt die Anzeige mit dem langen Zeitformat. Wenn vorhanden, werden beide Teile angezeigt.
vbLongDate | 1 | Anzeigen eines Datums im langen Datumsformat Ihrer Ländereinstellungen.
vbShortDate | 2 | Anzeigen des Datums im kurzen Datumsformat Ihrer Ländereinstellungen.
vbLongTime | 3 | Anzeige einer Zeit im Format entsprechend den Ländereinstellungen des Computers.
vbShortTime | 4 | Anzeige einer Zeit im 24-Stunden-Format (hh:mm).

Hinweise
Das folgende Beispiel zeigt die Verwendung der FormatDateTime-Funktion, um einen Ausdruck mit dem langen Datumsformat zu formatieren und der Variablen MeinDatumZeit zuzuweisen:
Function AktuellesDatumLesen
  ' FormatDateTime formatiert das Datum als langes Datumsformat.
  AktuellesDatumLesen = FormatDateTime(Date, 1)
End Function


FormatDateTime-Funktion

FormatDateTime-Funktion
Siehe auch 		Sprachverzeichnis

FormatCurrency-Funktion
FormatNumber-Funktion
FormatPercent-Funktion


FormatNumber-Funktion

FormatNumber-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt einen als Zahl formatierten Ausdruck zurück.
Syntax
FormatNumber(Ausdruck[,AnzDezimalstellen [,FührendeNull [,KlammernFürNegativeWerte [,ZiffernGruppieren]]]])

Die Syntax der FormatNumber-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Ausdruck | Erforderlich. Zu formatierender Ausdruck.
AnzDezimalstellen | Optional. Numerischer Wert, der angibt, wie viele Stellen rechts vom Dezimalkomma angezeigt werden. Die Voreinstellung lautet -1. Sie zeigt an, dass die Ländereinstellungen des Computers verwendet werden.
FührendeNull | Optional. Tristate-Konstante für die Anzeige von führenden Nullen bei Dezimalzahlen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.
KlammernFürNegativeWerte | Optional. Tristate-Konstante für die Verwendung von Klammern bei negativen Werten. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.
ZiffernGruppieren | Optional. Tristate-Konstante für die Gruppierung von Zahlen mit dem in der Systemsteuerung des Computers angegebenen Trennzeichen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.

Einstellungen
Die Argumente FührendeNull, KlammernFürNegativeWerte und ZiffernGruppieren haben folgende Werte:

Konstante | Wert | Beschreibung
TristateTrue | -1 | True
TristateFalse | 0 | False
TristateUseDefault | -2 | Ländereinstellungen des Computers verwenden.

Hinweise
Fehlende Werte durch Weglassen eines oder mehrerer optionaler Argumente werden aus den Ländereinstellungen des Computers übernommen.
Anmerkung Sämtliche Einstellungsinformationen stammen von der Registerkarte Zahlen im Dialogfeld Ländereinstellungen.

Das folgende Beispiel zeigt die Verwendung der FormatNumber-Funktion, um eine Zahl mit vier Dezimalstellen zu formatieren:

Function DemoZahlFormatieren
  Dim MeinWinkel, MeinSekans, MeineZahl
  MeinWinkel = 1.3                  ' Legt einen Winkel im Bogenmaß fest.
  MeinSekans = 1 / Cos(MeinWinkel)  ' Berechnen des Sekans.
  DemoZahlFormatieren = FormatNumber(MeinSekans,4) ' Formatieren von MeinSekans mit vier Dezimalstellen.
End Function


FormatNumber-Funktion

FormatNumber-Funktion
Siehe auch 		Sprachverzeichnis

FormatCurrency-Funktion
FormatDateTime-Funktion
FormatPercent-Funktion


FormatPercent-Funktion

FormatPercent-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt einen Ausdruck als Prozentangabe (multipliziert mit 100) und einem abschließenden %-Zeichen zurück.
Syntax
FormatPercent(Ausdruck[,AnzDezimalstellen [,FührendeNull [,KlammernFürNegativeWerte [,ZiffernGruppieren]]]])

Die Syntax der FormatPercent-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Ausdruck | Erforderlich. Zu formatierender Ausdruck.
AnzDezimalstellen | Optional. Numerischer Wert, der angibt, wie viele Stellen rechts vom Dezimalkomma angezeigt werden. Die Voreinstellung lautet -1. Sie zeigt an, dass die Ländereinstellungen des Computers verwendet werden.
FührendeNull | Optional. Tristate-Konstante für die Anzeige von führenden Nullen bei Dezimalzahlen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.
KlammernFürNegativeWerte | Optional. Tristate-Konstante für die Verwendung von Klammern bei negativen Werten. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.
ZiffernGruppieren | Optional. Tristate-Konstante für die Gruppierung von Zahlen mit dem in der Systemsteuerung des Computers angegebenen Trennzeichen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.

Einstellungen
Die Argumente FührendeNull, KlammernFürNegativeWerte und ZiffernGruppieren haben folgende Werte:

Konstante | Wert | Beschreibung
TristateTrue | -1 | True
TristateFalse | 0 | False
TristateUseDefault | -2 | Ländereinstellungen des Computers verwenden.

Hinweise
Fehlende Werte durch Weglassen eines oder mehrerer optionaler Argumente werden aus den Ländereinstellungen des Computers übernommen.
Anmerkung Sämtliche Einstellungsinformationen sind auf der Registerkarte Zahlen im Dialogfeld Ländereinstellungen enthalten.

Das folgende Beispiel zeigt die Verwendung der FormatPercent-Funktion, um einen Ausdruck als Prozentzahl zu formatieren:

Dim MeinProzent
MeinProzent = FormatPercent(2/32) ' MeinProzent enthält 6,25%.


FormatPercent-Funktion

FormatPercent-Funktion
Siehe auch 		Sprachverzeichnis

FormatCurrency-Funktion
FormatDateTime-Funktion
FormatNumber-Funktion


GetLocale-Funktion

GetLocale-Funktion 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Gibt den aktuellen Gebietsschema-ID-Wert zurück.
Syntax
GetLocale()
Hinweise
Eine Ländereinstellung enthält verschiedene Benutzereinstellungsinformationen, die sich auf die Sprache, das Land und kulturelle Konventionen des Benutzers beziehen. Die Ländereinstellung legt beispielsweise das Tastaturlayout, die alphabetische Sortierreihenfolge sowie die Formate für Datum, Uhrzeit, Zahlen und Währungen fest.

Der Rückgabewert kann ein beliebiger 32-Bit-Wert aus dem Gebietsschema-ID (LCID)-Diagramm sein.

Das folgende Beispiel verdeutlicht die Verwendung der GetLocale-Funktion: Um diesen Code zu verwenden, fügen Sie das gesamte Beispiel zwischen die <BODY>-Tags einer HTML-Standardseite ein.

Geben Sie ein Datum im britischen Datumsformat ein: <input type="text" id="GBDatum" size="20"><p>
Hier ist die deutsche Entsprechung: <input type="text" id="DEDatum" size="20"><p>
<input type="button" value="Konvertieren" id="Schaltfl1"><p>
Geben Sie einen Preis im deutschen Währungsformat ein:   <input type="text" id="DEZahl" size="20">
<p>
Hier ist die britische Entsprechung: <input type="text" id="GBZahl" size="20"><p>
<input type="button" value="Konvertieren" id="Schaltfl2"><p>

<script language="vbscript">
Dim aktuellesGebietsschema
' Ruft die aktuelle Ländereinstellung ab.
aktuellesGebietsschema = GetLocale

Sub Schaltfl1_onclick
  Dim original
  original = SetLocale("en-gb")
  meindatum = CDate(GBDatum.value)
  ' Ein deutscher Internet Explorer setzt die Ländereinstellung immer auf Deutsch; verwenden Sie
  ' also die aktuellesGebietsschema-Variable, um die Ländereinstellungen auf Deutsch zu setzen.
  original = SetLocale(aktuellesGebietsschema)
  DEDatum.value = FormatDateTime(meindatum,vbShortDate)
End Sub

Sub Schaltfl2_onclick
  Dim original
  original = SetLocale(aktuellesGebietsschema)
  meinwert = CCur(DEZahl.value)
  original = SetLocale("en-gb")
  GBZahl.value = FormatCurrency(meinwert)
  original = SetLocale(aktuellesGebietsschema)
End Sub

</script>


GetLocale-Funktion

GetLocale-Funktion
Siehe auch 		Sprachverzeichnis

Gebietsschema-ID (LCID)-Diagramm
SetLocale-Funktion


GetObject-Funktion

GetObject-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt einen Verweis auf ein Automatisierungsobjekt aus einer Datei zurück.
Syntax
GetObject([Pfadname] [, Klasse])

Die Syntax der GetObject-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Pfadname | Optional; Zeichenfolge. Der vollständige Pfad und Name der Datei, die das abzurufende Objekt enthält. Wird Pfadname weggelassen, ist Klasse erforderlich.
Klasse | Optional; Zeichenfolge. Klasse des Objekts.

Das Argument Klasse verwendet die Syntax AnwName.Objekttyp und besteht aus folgenden Teilen:

Teil | Beschreibung
AnwName | Erforderlich; Zeichenfolge. Name der Anwendung, die das Objekt zur Verfügung stellt.
Objekttyp | Erforderlich; Zeichenfolge. Typ oder Klasse des zu erzeugenden Objekts.

Hinweise
Verwenden Sie die GetObject-Funktion zum Zugreifen auf ein Automatisierungsobjekt aus einer Datei und Zuweisen des Objekts an eine Objektvariable. Verwenden Sie die Set-Anweisung, um der Objektvariablen das von GetObject zurückgegebene Objekt zuzuweisen. Beispiele:
Dim CADObjekt
Set CADObjekt = GetObject("C:\CAD\SCHEMA.CAD")
Wird dieser Code ausgeführt, startet die mit dem Pfadnamen verknüpfte Anwendung, und das Objekt in der angegebenen Datei wird aktiviert. Ist Pfadname eine Zeichenfolge mit der Länge 0 (""), gibt GetObject eine neue Objektinstanz vom angegebenen Typ zurück. Wird das Argument Pfadname nicht angegeben, gibt GetObject ein momentan aktives Objekt vom angegebenen Typ zurück. Existiert kein Objekt des angegebenen Typs, tritt ein Fehler auf.

Bei einigen Anwendungen können Sie einen Teil einer Datei aktivieren. Fügen Sie hinter dem Dateinamen ein Ausrufezeichen (!) gefolgt von der Zeichenfolge hinzu, die den Namen des zu aktivierenden Teils enthält. Weitere Informationen zum Erstellen dieser Zeichenfolge finden Sie in der Dokumentation der Anwendung, die das Objekt erstellt hat.

In einem Zeichenprogramm können z. B.mehrere Ebenen einer Zeichnung vorhanden sein, die in einer Datei gespeichert sind. Mit der folgenden Anweisung können Sie eine Ebene in einer Zeichnung mit dem Namen SCHEMA.CAD aktivieren:

Set EbenenObjekt= GetObject("C:\CAD\SCHEMA.CAD!Ebene3")
Wenn Sie die Objektklasse nicht angeben, werden die zu startende Anwendung und das zu aktivierende Objekt automatisch anhand des Dateinamens festgelegt. Einige Dateien unterstützen jedoch mehr als nur eine Objektklasse. Eine Zeichnung kann z. B. drei unterschiedliche Typen von Objekten unterstützen: ein Objekt "Anwendung", ein Objekt "Zeichnung" und ein Objekt "Symbolleiste". Alle drei Objekte befinden sich in derselben Datei. Um anzugeben, welches Objekt Sie in einer Datei aktivieren möchten, verwenden Sie das optionale Argument Klasse. Beispiele:
Dim MeinObjekt
Set MeinObjekt = GetObject("C:\ZEICHNUNGEN\BEISPIEL.DRW", "ERDICHTUNG.ZEICHNUNG")
Im vorhergehenden Beispiel ist ERDICHTUNG der Name des Zeichenprogramms und ZEICHNUNG einer der unterstützten Objekttypen. Sobald ein Objekt aktiviert ist, wird im Programm durch die von Ihnen definierte Objektvariable darauf verwiesen. Im letzten Beispiel greifen sie auf Eigenschaften und Methoden des neuen Objekts über die Objektvariable MeinObjekt zu. Beispiele:
MeinObjekt.Line 9, 90
MeinObjekt.InsertText 9, 100, "Hallo, Welt."
MeinObjekt.SaveAs "C:\ZEICHNUNGEN\BEISPIEL.DRW"
Anmerkung: Verwenden Sie die GetObject-Funktion, wenn es eine aktuelle Instanz des Objekts gibt oder Sie das Objekt mit einer bereits geöffneten Datei erstellen möchten. Wenn es keine aktuelle Instanz gibt und Sie das Objekt nicht mit einer geöffneten Datei starten möchten, verwenden Sie die CreateObject-Funktion.

Wenn sich ein Objekt als Einzelinstanzobjekt registriert hat, wird nur eine einzige Instanz dieses Objekts erstellt, unabhängig davon, wie oft CreateObject ausgeführt wird. Bei einem Einzelinstanzobjekt gibt GetObject bei einem Syntaxaufruf mit der Nulllängenzeichenfolge ("") stets die gleiche Instanz zurück, und es tritt ein Fehler auf, wenn das Argument-Pfadname nicht angegeben wird.


GetObject-Funktion

GetObject-Funktion
Siehe auch 		Sprachverzeichnis

CreateObject-Funktion


GetRef-Funktion

GetRef-Funktion 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Gibt einen Verweis auf eine Prozedur zurück, die an ein Ereignis gebunden werden kann.
Syntax
Set Objekt.Ereignisname = GetRef(ProzName)

Die Syntax der GetRef-Funktion hat folgende Teile:

Teil | Beschreibung
Objekt | Erforderlich. Name des Objekts, dem Ereignis zugeordnet ist.
Ereignis | Erforderlich. Name des Ereignisses, an das die Funktion gebunden werden soll.
ProzName | Erforderlich. Zeichenfolge, die den Namen der Sub- oder Function-Prozedur enthält, die Ereignisname zugeordnet wird.

Hinweise
Die GetRef-Funktion ermöglicht die Verbindung einer VBScript-Prozedur (Function oder Sub) mit einem beliebigen Ereignis auf Ihren DHTML (Dynamic HTML)-Seiten. Das DHTML-Objektmodell stellt Informationen zu den für die verschiedenen Objekte verfügbaren Ereignissen bereit.

In anderen Skript- und Programmiersprachen wird die durch GetRef bereitgestellte Funktionalität als Funktionszeiger bezeichnet, d. h. sie zeigt auf die Adresse einer Prozedur, die beim Eintreten eines bestimmten Ereignisses ausgeführt werden soll.

Das folgende Beispiel verdeutlicht die Verwendung der GetRef-Funktion:

<SCRIPT LANGUAGE="VBScript">

Function TestRefLesen()
  Dim Info
  Info = "TestRefLesen Version 1.0"  & vbCrLf
  Info = Info & Chr(169) & " Ihre Firma 1999 "
  MsgBox Info
End Function

Set Window.Onload = GetRef("TestRefLesen")

</SCRIPT>


GetRef-Funktion

GetRef-Funktion
Siehe auch 		Sprachverzeichnis

Function-Anweisung
Set-Anweisung
Sub-Anweisung


Hex-Funktion

Hex-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine Zeichenfolge mit der Hexadezimaldarstellung einer Zahl zurück.
Syntax
Hex(Zahl)

Das Argument Zahl ist ein beliebiger gültiger Ausdruck.

Hinweise
Wenn Zahl keine ganze Zahl ist, rundet die Funktion den Wert vor der Auswertung auf die nächste ganze Zahl.

Wenn Zahl | Rückgabewert von Hex
Null | Null.
Empty | Null (0).
Andere Zahl | Bis zu acht hexadezimale Zeichen.

Sie können Hexadezimalzahlen direkt angeben, indem Sie vor eine Zahl im zulässigen Bereich die Zeichen &H setzen. &H10 entspricht zum Beispiel der Dezimalzahl 16 in Hexadezimaldarstellung.

Das folgende Beispiel zeigt die Verwendung der Hex-Funktion, um den Hexadezimalwert einer Zahl zurückzugeben:

Dim MeineHex
MeineHex = Hex(5)      ' Gibt 5 zurück.
MeineHex = Hex(10)     ' Gibt A zurück.
MeineHex = Hex(459)    ' Gibt 1CB zurück.


Hex-Funktion

Hex-Funktion
Siehe auch 		Sprachverzeichnis

Oct-Funktion


Hour-Funktion

Hour-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine ganze Zahl im Bereich von 0 bis 23 zurück, die die Stunde des Tages darstellt.
Syntax
Hour(Uhrzeit)

Das Argument Uhrzeit ist ein beliebiger Ausdruck, der eine Uhrzeit darstellen kann. Wenn Uhrzeit den Wert Null enthält, wird Null zurückgegeben.

Das folgende Beispiel zeigt die Verwendung der Hour-Funktion, um die Stunde der aktuellen Zeit zurückzugeben:

Dim MeineZeit, MeineStunde
MeineZeit = Jetzt
MeineStunde = Hour(MeineZeit) ' MeineStunde enthält die Zahl
                              ' der aktuellen Stunde.


Hour-Funktion

Hour-Funktion
Siehe auch 		Sprachverzeichnis

Day-Funktion
Minute-Funktion
Now-Funktion
Second-Funktion
Time-Funktion


InputBox-Funktion

InputBox-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Zeigt in einem Dialogfeld eine Eingabeaufforderung an, wartet auf eine Texteingabe oder die Auswahl einer Schaltfläche durch den Benutzer und gibt den Inhalt des Textfelds zurück.
Syntax
InputBox(Eingabeaufforderung[, Titel][, Standard][, xpos][, ypos][, Hilfedatei, Kontext])

Die Syntax der InputBox-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Eingabeaufforderung | Zeichenfolgenausdruck, der als Meldung im Dialogfeld angezeigt wird. Die maximale Länge der Eingabeaufforderung beträgt etwa 1024 Zeichen, abhängig von der Breite der verwendeten Zeichen. Wenn die Eingabeaufforderung mehr als eine Zeile umfasst, können Sie zwei Zeilen jeweils durch ein Wagenrücklaufzeichen (Chr(13)), ein Zeilenvorschubzeichen (Chr(10)) oder eine Kombination aus Wagenrücklauf- und Zeilenvorschubzeichen (Chr(13) & Chr(10)) trennen.
Titel | Zeichenfolgenausdruck, der in der Titelleiste des Dialogfelds angezeigt wird. Wenn Sie Titel nicht angeben, wird der Name der Anwendung in der Titelleiste angezeigt.
Standard | Zeichenfolgenausdruck, der im Textfeld standardmäßig angezeigt wird, wenn keine andere Eingabe erfolgt. Wenn Sie Standard nicht angeben, wird ein leeres Textfeld angezeigt.
xpos | Numerischer Ausdruck, der den horizontalen Abstand des linken Dialogfeldrands vom linken Bildschirmrand in Twips angibt. Wenn xpos nicht angegeben wird, wird das Dialogfeld horizontal zentriert.
ypos | Numerischer Ausdruck, der den vertikalen Abstand des oberen Dialogfeldrands vom oberen Bildschirmrand in Twips angibt. Bei fehlender Angabe von ypos wird das Dialogfeld vertikal um etwa ein Drittel der Bildschirmhöhe nach unten verschoben.
Hilfedatei | Zeichenfolgenausdruck, der die Hilfedatei angibt, die für die kontextbezogene Hilfe zum Dialogfeld geöffnet wird. Bei Angabe von Hilfedatei muss Kontext ebenfalls angegeben werden.
Kontext | Numerischer Ausdruck, der die Hilfe-Kontextnummer angibt, die der Hilfeautor dem zugehörigen Hilfethema zugeordnet hat. Wenn Kontext angegeben wird, muss Hilfedatei ebenfalls angegeben werden.

Hinweise
Wenn sowohl Hilfedatei als auch Kontext angegeben werden, wird dem Dialogfeld automatisch die Schaltfläche Hilfe hinzugefügt.

Wenn der Benutzer auf OK klickt oder die EINGABETASTE drückt, gibt die InputBox-Funktion den Inhalt des Textfelds zurück. Klickt der Benutzer auf Abbrechen, gibt die Funktion eine Zeichenfolge der Länge 0 ("") zurück.

Das folgende Beispiel zeigt die Verwendung der InputBox-Funktion, um ein Textfeld anzuzeigen und die eingegebene Zeichenfolge der Variablen Eingabe zuzuweisen:

Dim Eingabe
Eingabe = InputBox("Geben Sie Ihren Namen ein")
MsgBox ("Ihre Eingabe: " & Eingabe)


InputBox-Funktion

InputBox-Funktion
Siehe auch 		Sprachverzeichnis

MsgBox-Funktion


InStr-Funktion

InStr-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt die Position des ersten Auftretens einer Zeichenfolge innerhalb einer anderen Zeichenfolge zurück.
Syntax
InStr([Start, ]Zeichenfolge1, Zeichenfolge2[, Vergleich])

Die Syntax der InStr-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Anfang | Optional. Numerischer Ausdruck, der die Startposition für die Suche festlegt. Wird Start nicht angegeben, beginnt die Suche mit dem ersten Zeichen. Wenn Start den Wert Null enthält, tritt ein Fehler auf. Bei Angabe von Vergleich muss auch Start angegeben werden.
Zeichenfolge1 | Erforderlich. Durchsuchter Zeichenfolgenausdruck.
Zeichenfolge2 | Erforderlich. Gesuchter Zeichenfolgenausdruck.
Vergleich | Optional. Numerischer Wert für die zu verwendende Art des Vergleichs bei der Auswertung von Teilzeichenfolgen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt. Wird Vergleich nicht angegeben, wird ein binärer Vergleich durchgeführt.

Einstellungen
Das Argument Vergleich kann die folgenden Werte haben:

Konstante | Wert | Beschreibung
vbBinaryCompare | 0 | Führt einen binären Vergleich durch.
vbTextCompare | 1 | Führt einen Textvergleich durch.

Rückgabewerte
Die InStr-Funktion gibt die folgenden Werte zurück:

Wenn | Dann ist Rückgabewert von InStr
Zeichenfolge1 die Länge Null hat | 0
Zeichenfolge1 Null ist | Null
Zeichenfolge2 die Länge Null hat | Anfang
Zeichenfolge2 Null ist | Null
Zeichenfolge2 nicht vorhanden ist | 0
Zeichenfolge2 in Zeichenfolge1 enthalten ist | Position, an der Übereinstimmung gefunden wurde
Start > Len(Zeichenfolge2) | 0

Hinweise
Das folgende Beispiel zeigt die Verwendung der InStr-Funktion, um eine Zeichenfolge zu suchen:
Dim SuchZf, SuchZeichen, MeinePosition
SuchZf ="XXpXXpXXPXXP"					' Zu durchsuchende Zeichenfolge.
SuchZeichen = "P"						' Suchen nach "P".
MeinePosition = Instr(4, SuchZf, SuchZeichen, 1)	' Ein Textvergleich, der bei
                                ' Position 4 beginnt und den Wert 6 zurückgibt.
MeinePosition = Instr(1, SuchZf, SuchZeichen, 0)	' Ein Binärvergleich, der bei
                                ' Position 1 beginnt und den Wert 9 zurückgibt.
MeinePosition = Instr(SuchZf, SuchZeichen)		' Der Binärvergleich ist die Voreinstellung
                                ' (letztes Argument wird weggelassen).
                                ' Gibt den Wert 9 zurück.
MeinePosition = Instr(1, SuchZf, "W")			' Ein Binärvergleich, der bei Position 1 beginnt.
                                ' Gibt den Wert 0 zurück ("W" wurde nicht gefunden).
Anmerkung Eine andere Funktion (InStrB) steht für Bytedaten zur Verfügung, die in einer Zeichenfolge enthalten sind. InStrB gibt nicht die Zeichenposition des ersten Auftretens einer Zeichenfolge innerhalb einer anderen Zeichenfolge zurück, sondern die Byteposition.


InStr-Funktion

InStr-Funktion
Siehe auch 		Sprachverzeichnis

InStrRev-Funktion


InStrRev-Funktion

InStrRev-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt die Position des Vorkommens einer Zeichenfolge in einer anderen Zeichenfolge zurück, wobei vom Ende der Zeichenfolge aus gezählt wird.
Syntax
InStrRev(Zeichenfolge1, Zeichenfolge2[, Start[, Vergleich]])

Die Syntax der InStrRev-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Zeichenfolge1 | Erforderlich. Durchsuchter Zeichenfolgenausdruck.
Zeichenfolge2 | Erforderlich. Gesuchter Zeichenfolgenausdruck.
Anfang | Optional. Numerischer Ausdruck, der die Startposition für die Suche festlegt. Ohne Angabe von Start wird -1 verwendet, d. h. die Suche beginnt an der letzten Zeichenposition Wenn Start den Wert Null enthält, tritt ein Fehler auf.
Vergleich | Optional. Numerischer Wert für die zu verwendende Art des Vergleichs bei der Auswertung von Teilzeichenfolgen. Ohne Angabe von Vergleich wird ein binärer Vergleich durchgeführt. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.

Einstellungen
Das Argument Vergleich kann die folgenden Werte haben:

Konstante | Wert | Beschreibung
vbBinaryCompare | 0 | Führt einen binären Vergleich durch.
vbTextCompare | 1 | Führt einen Textvergleich durch.

Rückgabewerte
InStrRev gibt die folgenden Werte zurück:

Wenn | Dann ist Rückgabewert von InStrRev
Zeichenfolge1 die Länge Null hat | 0
Zeichenfolge1 Null ist | Null
Zeichenfolge2 die Länge Null hat | Anfang
Zeichenfolge2 Null ist | Null
Zeichenfolge2 nicht vorhanden ist | 0
Zeichenfolge2 in Zeichenfolge1 enthalten ist | Position, an der Übereinstimmung gefunden wurde
Start > Len(Zeichenfolge2) | 0

Hinweise
Die folgenden Beispiele zeigen die Verwendung der InStrRev-Funktion, um eine Zeichenfolge zu durchsuchen:
Dim SuchZf, SuchZeichen, MeinePosition
SuchZf ="XXpXXpXXPXXP"						' Zu durchsuchende Zeichenfolge.
SuchZeichen = "P"							' Suchen nach "P".
MeinePosition = InstrRev(SuchZf, SuchZeichen, 10, 0)	' Ein Binärvergleich, der bei
                                    ' Position 10 beginnt und den Wert 9 zurückgibt.
MeinePosition = InstrRev(SuchZf, SuchZeichen, -1, 1)	' Ein Textvergleich, der bei
                                    ' der letzten Position beginnt. Gibt den Wert 12 zurück.
MeinePosition = InstrRev(SuchZf, SuchZeichen, 8)		' Der Binärvergleich ist die Voreinstellung
                                    ' (letztes Argument wird weggelassen). Gibt den Wert 0 zurück.
Anmerkung Die Syntax der InStrRev-Funktion entspricht nicht der Syntax der InStr-Funktion.


InStrRev-Funktion

InStrRev-Funktion
Siehe auch 		Sprachverzeichnis

InStr-Funktion


Int, Fix-Funktionen

Int, Fix-Funktionen 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt den ganzzahligen Anteil einer Zahl zurück.
Syntax
Int(Zahl)

Fix(Zahl)

Das Argument Zahl kann ein beliebiger gültiger numerischer Ausdruck sein. Wenn Zahl den Wert Null enthält, wird Null zurückgegeben.

Hinweise
Sowohl Int als auch Fix entfernen die Nachkommastellen einer Zahl und geben den daraus resultierenden ganzzahligen Wert zurück.

Der Unterschied zwischen Int und Fix besteht darin, dass bei negativen Zahlen Int die negative ganze Zahl zurückgibt, die kleiner oder gleich dem Argument Zahl ist, während Fix die negative ganze Zahl zurückgibt, die größer oder gleich dem Argument Zahl ist. Int wandelt -8,4 zum Beispiel in -9 um, während Fix -8,4 in -8 umwandelt.

Fix(Zahl) entspricht dem folgenden Ausdruck:

Sgn(Zahl) * Int(Abs(Zahl))
Das folgende Beispiel zeigt die Verwendung der Funktionen Int und Fix, um die ganzzahligen Teile einer Zahl zurückzugeben:
MeineZahl = Int(99.8)    ' Gibt 99 zurück.
MeineZahl = Fix(99.2)    ' Gibt 99 zurück.
MeineZahl = Int(-99.8)   ' Gibt -100 zurück.
MeineZahl = Fix(-99.8)   ' Gibt -99 zurück.
MeineZahl = Int(-99.2)   ' Gibt -100 zurück.
MeineZahl = Fix(-99.2)   ' Gibt -99 zurück.


Int, Fix-Funktionen

Int, Fix-Funktionen
Siehe auch 		Sprachverzeichnis

CInt-Funktion
Round-Funktion


IsArray-Funktion

IsArray-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen booleschen Wert zurück, der angibt, ob eine Variable ein Datenfeld ist.
Syntax
IsArray(VarName)

Das Argument VarName kann eine beliebige Variable sein.

Hinweise
IsArray gibt den Wert True zurück, wenn die Variable ein Datenfeld ist, andernfalls wird False zurückgegeben. IsArray ist insbesondere bei Variant-Werten hilfreich, die Datenfelder enthalten.

Das folgende Beispiel zeigt die Verwendung der IsArray-Funktion, um zu testen, ob die Variable MeinDatenfeld ein Datenfeld ist:

Dim MeineVar
Dim MeinDatenfeld(3)
MeinDatenfeld(0) = "Sonntag"
MeinDatenfeld(1) = "Montag"
MeinDatenfeld(2) = "Dienstag"
MeineVar = IsArray(MeinDatenfeld) ' MeineVar enthält "True".


IsArray-Funktion

IsArray-Funktion
Siehe auch 		Sprachverzeichnis

IsDate-Funktion
IsEmpty-Funktion
IsNull-Funktion
IsNumeric-Funktion
IsObject-Funktion
VarType-Funktion


IsDate-Funktion

IsDate-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen booleschen Wert zurück, der angibt, ob ein Ausdruck in ein Datum umgewandelt werden kann.
Syntax
IsDate(Ausdruck)

Das Argument Ausdruck kann ein beliebiger Datums- oder Zeichenfolgenausdruck sein, der als Datum oder Uhrzeit erkannt wird.

Hinweise
IsDate gibt den Wert True zurück, wenn der Ausdruck ein Datum ist oder in ein gültiges Datum konvertiert werden kann. Andernfalls ist der Rückgabewert False. In Microsoft Windows liegen gültige Datumswerte im Bereich vom 1. Januar 100 n.Chr. bis einschließlich 31. Dezember 9999 n.Chr. Dieser Bereich kann bei anderen Betriebssystemen unterschiedlich sein.

Das folgende Beispiel zeigt die Verwendung der IsDate-Funktion, um festzustellen, ob ein Ausdruck in ein Datum konvertiert werden kann:

Dim MeinDatum, IhrDatum, KeinDatum, MeineProbe
MeinDatum = "14. Juni 1962": IhrDatum = #06/14/62#: KeinDatum = "Hallo"
MeineProbe = IsDate(MeinDatum)           ' Gibt den Wert True zurück.
MeineProbe = IsDate(IhrDatum)            ' Gibt den Wert True zurück.
MeineProbe = IsDate(KeinDatum)           ' Gibt den Wert False zurück.


IsDate-Funktion

IsDate-Funktion
Siehe auch 		Sprachverzeichnis

CDate-Funktion
IsArray-Funktion
IsEmpty-Funktion
IsNull-Funktion
IsNumeric-Funktion
IsObject-Funktion
VarType-Funktion


IsEmpty-Funktion

IsEmpty-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen booleschen Wert zurück, der angibt, ob eine Variable initialisiert wurde.
Syntax
IsEmpty(Ausdruck)

Das Argument Ausdruck kann ein beliebiger Ausdruck sein. Da mit der IsEmpty-Funktion jedoch geprüft wird, ob einzelne Variablen initialisiert worden sind, enthält das Argument Ausdruck in der Regel nur einen einzelnen Variablennamen.

Hinweise
IsEmpty gibt den Wert True zurück, wenn die Variable nicht initialisiert ist oder explizit auf Empty gesetzt wurde. Andernfalls wird False zurückgegeben. False wird immer zurückgegeben, wenn Ausdruck mehr als eine Variable enthält.

Das folgende Beispiel zeigt die Verwendung der IsEmpty-Funktion, um festzustellen, ob eine Variable initialisiert wurde:

Dim MeineVar, MeineProbe
MeineProbe = IsEmpty(MeineVar)    ' Gibt den Wert True zurück.
MeineVar = Null                   ' Zuweisen des Werts Null.
MeineProbe = IsEmpty(MeineVar)    ' Gibt den Wert False zurück.
MeineVar = Empty                  ' Zuweisen des Werts Empty.
MeineProbe = IsEmpty(MeineVar)    ' Gibt den Wert True zurück.


IsEmpty-Funktion

IsEmpty-Funktion
Siehe auch 		Sprachverzeichnis

IsArray-Funktion
IsDate-Funktion
IsNull-Funktion
IsNumeric-Funktion
IsObject-Funktion
VarType-Funktion


IsNull-Funktion

IsNull-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen booleschen Wert zurück, der angibt, ob ein Ausdruck ungültige Daten (Null) enthält.
Syntax
IsNull(Ausdruck)

Das Argument Ausdruck kann ein beliebiger Ausdruck sein.

Hinweise
IsNull gibt den Wert True zurück, wenn Ausdruck gleich Null ist, d. h. keine gültigen Daten enthält. Andernfalls gibt IsNull den Wert False zurück. Wenn Ausdruck aus mehreren Variablen besteht, führt ein Null-Wert in einer der Variablen dazu, dass True für den gesamten Ausdruck zurückgegeben wird.

Null bedeutet, dass die Variable keine gültigen Daten enthält. Der Wert Null darf nicht mit dem Wert Empty verwechselt werden, der anzeigt, dass eine Variable noch nicht initialisiert wurde. Null ist auch keine Null-Zeichenfolge (eine Zeichenfolge der Länge Null).

Wichtig Mit der IsNull-Funktion können Sie feststellen, ob ein Ausdruck den Wert Null enthält. Ausdrücke, die dem Anschein nach den Wert True ergeben könnten, wie z. B. If Var = Null oder If Var <> Null, sind immer False. Dies liegt darin begründet, dass jeder Ausdruck den Wert Null enthaltende Ausdruck selbst den Wert Null hat und daher False ist.

Das folgende Beispiel zeigt die Verwendung der IsNull-Funktion, um festzustellen, ob eine Variable Null enthält:

Dim MeineVar, MeinePrüfung
MeinePrüfung = IsNull(MeineVar)    ' Gibt den Wert False zurück.
MeineVar = Null                    ' Zuweisen des Werts Null.
MeinePrüfung = IsNull(MeineVar)    ' Gibt den Wert True zurück.
MeineVar = Empty                   ' Zuweisen des Werts Empty.
MeinePrüfung = IsNull(MeineVar)    ' Gibt den Wert False zurück.


IsNull-Funktion

IsNull-Funktion
Siehe auch 		Sprachverzeichnis

IsArray-Funktion
IsDate-Funktion
IsEmpty-Funktion
IsNumeric-Funktion
IsObject-Funktion
VarType-Funktion


IsNumeric-Funktion

IsNumeric-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen booleschen Wert zurück, der angibt, ob ein Ausdruck als Zahl ausgewertet werden kann.
Syntax
IsNumeric(Ausdruck)

Das Argument Ausdruck kann ein beliebiger Ausdruck sein.

Hinweise
IsNumeric gibt den Wert True zurück, wenn der gesamte Ausdruck als Zahl erkannt wird. Andernfalls wird False zurückgegeben. IsNumeric gibt False zurück, wenn Ausdruck ein Datumsausdruck ist.

Das folgende Beispiel zeigt die Verwendung der IsNumeric-Funktion, um festzustellen, ob eine Variable als Zahl ausgewertet werden kann:

Dim MeineVar, MeinProbe
MeineVar = 53                     ' Zuweisen eines Werts.
MeinProbe = IsNumeric(MeineVar)   ' Gibt den Wert True zurück.
MeineVar = "459.95"               ' Zuweisen eines Werts.
MeinProbe = IsNumeric(MeineVar)   ' Gibt den Wert True zurück.
MeineVar = "45 Hilfe"             ' Zuweisen eines Werts.
MeinProbe = IsNumeric(MeineVar)   ' Gibt den Wert False zurück.


IsNumeric-Funktion

IsNumeric-Funktion
Siehe auch 		Sprachverzeichnis

IsArray-Funktion
IsDate-Funktion
IsEmpty-Funktion
IsNull-Funktion
IsObject-Funktion
VarType-Funktion


IsObject-Funktion

IsObject-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen booleschen Wert zurück, der angibt, ob ein Ausdruck auf ein gültiges Automatisierungsobjekt verweist.
Syntax
IsObject(Ausdruck)

Das Argument Ausdruck kann ein beliebiger Ausdruck sein.

Hinweise
IsObject gibt True zurück, wenn Ausdruck eine Variable mit dem Untertyp Object oder ein benutzerdefiniertes Objekt ist. Andernfalls wird False zurückgegeben.

Das folgende Beispiel zeigt die Verwendung der IsObject-Funktion, um festzustellen, ob ein Bezeichner eine Objektvariable darstellt:

Dim MeinInt, MeineProbe, MeinObjekt
Set MeinObjekt = Ich
MeineProbe = IsObject(MeinObjekt)   ' Ergibt True.
MeineProbe = IsObject(MeinInt)      ' Ergibt False.


IsObject-Funktion

IsObject-Funktion
Siehe auch 		Sprachverzeichnis

IsArray-Funktion
IsDate-Funktion
IsEmpty-Funktion
IsNull-Funktion
IsNumeric-Funktion
Set-Anweisung
VarType-Funktion


Join-Funktion

Join-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt eine durch Verbinden einer Reihe von Teilzeichenfolgen in einem Datenfeld erzeugte Zeichenfolge zurück.
Syntax
Join(Liste[, Trennzeichen])

Die Syntax der Join-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Liste | Erforderlich. Eindimensionales Datenfeld, das die zu verbindenden Teilzeichenfolgen enthält.
Trennzeichen | Optional. Zeichen vom Typ String zur Trennung der Teilzeichenfolgen in der zurückgegebenen Zeichenfolge. Ohne Angabe wird das Leerzeichen (" ") verwendet. Ist Trennzeichen eine Zeichenfolge mit der Länge 0, werden alle Teile ohne Trennzeichen miteinander verbunden.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Join-Funktion, mit der die Teilzeichenfolgen von MeinDatenfeld zusammengefasst werden:
Dim MeineZf
Dim MeinDatenfeld(3)
MeinDatenfeld(0) = "Herr "
MeinDatenfeld(1) = "Berti "
MeinDatenfeld(2) = "Mustermann "
MeinDatenfeld(3) = "III"
MeineZf = Join(MeinDatenfeld)
                   ' MeineZf enthält "Herr Berti Mustermann III".


Join-Funktion

Join-Funktion
Siehe auch 		Sprachverzeichnis

Split-Funktion


LBound-Funktion

LBound-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt den kleinsten verfügbaren Index für die angegebene Dimension eines Datenfelds zurück.
Syntax
LBound(Datenfeldname[, Dimension])

Die Syntax der LBound-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Datenfeldname | Name der Datenfeldvariablen gemäß den Standardkonventionen für Namen von Variablen.
Dimension | Ganze Zahl, die angibt, für welche Dimension die untere Grenze zurückgegeben werden soll. Verwenden Sie für die erste Dimension 1, für die zweite Dimension 2 usw. Ohne Angabe von Dimension wird von 1 ausgegangen.

Hinweise
Die LBound-Funktion kann zusammen mit der UBound-Funktion verwendet werden, um die Größe eines Datenfelds festzulegen. Die UBound-Funktion liefert die Obergrenze einer Datenfelddimension.

Die Untergrenze für jede Dimension ist stets 0.


LBound-Funktion

LBound-Funktion
Siehe auch 		Sprachverzeichnis

Dim-Anweisung
ReDim-Anweisung
UBound-Funktion


LCase-Funktion

LCase-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine Zeichenfolge zurück, bei der alle Buchstaben in Kleinbuchstaben umgewandelt wurden.
Syntax
LCase(Zeichenfolge)

Das Argument Zeichenfolge ist ein beliebiger gültiger Zeichenfolgenausdruck. Wenn Zeichenfolge den Wert Null enthält, wird Null zurückgegeben.

Hinweise
Es werden lediglich Groß- in Kleinbuchstaben umgewandelt. Alle Kleinbuchstaben und sonstigen Zeichen bleiben unverändert.

Das folgende Beispiel zeigt die Verwendung der LCase-Funktion, um Groß- in Kleinbuchstaben zu konvertieren:
Dim MeineZf
Dim ZfKlein
MeineZf = "VBScript"
ZfKlein = LCase(MeineZf) ' ZfKlein enthält "vbscript".


LCase-Funktion

LCase-Funktion
Siehe auch 		Sprachverzeichnis

UCase-Funktion


Left-Funktion

Left-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine bestimmte Anzahl von Zeichen ab dem ersten (linken) Zeichen einer Zeichenfolge zurück.
Syntax
Left(Zeichenfolge, Länge)

Die Syntax der Left-Funktion verwendet folgende Argumente:

Teil | Beschreibung
Zeichenfolge | Zeichenfolgenausdruck, aus dem die ersten (linken) Zeichen zurückgegeben werden. Wenn Zeichenfolge den Wert Null enthält, wird Null zurückgegeben.
Länge | Numerischer Ausdruck, der die Anzahl der zurückzugebenden Zeichen angibt. 0 führt zur Rückgabe einer leeren Zeichenfolge (""). Ist Länge größer oder gleich der Zeichenanzahl in Zeichenfolge, wird die gesamte Zeichenfolge zurückgegeben.

Hinweise
Sie können die Zeichenanzahl in Zeichenfolge mit der Len-Funktion festlegen.

Das folgende Beispiel verwendet die Left-Funktion, um die ersten drei Zeichen von MeineZf zurückzugeben:

Dim MeineZf, ZfLinks
MeineZf = "VBSCript"
ZfLinks = Left(MeineZf, 3) ' ZfLinks enthält "VBS".
Anmerkung Die Funktion (LeftB) wird für Byte-Daten verwendet, die in einer Zeichenfolge enthalten sind. Länge gibt nicht Anzahl der zurückzugebenden Zeichen zurück, sondern die Anzahl der Byte.


Left-Funktion

Left-Funktion
Siehe auch 		Sprachverzeichnis

Len-Funktion
Mid-Funktion
Right-Funktion


Len-Funktion

Len-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt die Anzahl der Zeichen in einer Zeichenfolge oder die zum Speichern einer Variablen erforderlichen Byte zurück.
Syntax
Len(Zeichenfolge | Variablenname)

Die Syntax der Len-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Zeichenfolge | Ein beliebiger gültiger Zeichenfolgenausdruck. Wenn Zeichenfolge den Wert Null enthält, wird Null zurückgegeben.
Variablenname | Jeder gültige Variablenname. Wenn Variablennname den Wert Null enthält, wird Null zurückgegeben.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Len-Funktion, um die Anzahl der Buchstaben in einer Zeichenfolge zurückzugeben:
Dim MeineZf
MeineZf = Len("VBSCRIPT") ' MeineZf enthält den Wert 8.
Hinweis Die Funktion (LenB) wird für Bytedaten verwendet, die in einer Zeichenfolge enthalten sind. LenB gibt nicht die Anzahl der Zeichen in einer Zeichenfolge zurück, sondern die Anzahl der Bytes, die zur Darstellung dieser Zeichenfolge verwendet werden.


Len-Funktion

Len-Funktion
Siehe auch 		Sprachverzeichnis

InStr-Funktion


LoadPicture-Funktion

LoadPicture-Funktion 		Sprachverzeichnis
Version 2

Beschreibung
Gibt ein Bildobjekt zurück. Diese Funktion ist nur auf 32-Bit-Plattformen verfügbar.
Syntax
LoadPicture(Bildname)

Das Argument Bildname ist ein Zeichenfolgenausdruck, der den Namen der zu ladenden Grafikdatei angibt.

Hinweise
Zu den von LoadPicture lesbaren Grafikformaten zählen u.a.: Bitmap-Dateien (.bmp), Icon-Dateien (.ico), Run-Length-Encoded-Dateien (.rle), Windows-Metafiles (.wmf), Enhanced Metafiles (.emf), GIF-Dateien (.gif) und JPEG-Dateien (.jpg).


Log-Funktion

Log-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt den natürlichen Logarithmus einer Zahl zurück.
Syntax
Log(Zahl)

Das Argument Zahl kann ein beliebiger zulässiger numerischer Ausdruck mit einem Wert größer als 0 sein.

Hinweise
Der natürliche Logarithmus ist der Logarithmus zur Basis e. Die Konstante e entspricht ungefähr dem Wert 2,718282.

Sie können den Logarithmus zur Basis n für jede Zahl x berechnen, indem Sie den natürlichen Logarithmus von x wie folgt durch den natürlichen Logarithmus von n dividieren:

Logn(x) = Log(x) / Log(n)
Das folgende Beispiel veranschaulicht eine Function-Prozedur zur Berechnung von Logarithmen mit der Basis 10:
Function Log10(X)
    Log10 = Log(X) / Log(10)
End Function


Log-Funktion

Log-Funktion
Siehe auch 		Sprachverzeichnis

Abgeleitete mathematische Funktionen
Exp-Funktion


LTrim-, RTrim- und Trim-Funktionen

LTrim-, RTrim- und Trim-Funktionen 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Geben eine Kopie einer Zeichenfolge zurück, die keine führenden Leerzeichen (LTrim), keine nachgestellten Leerzeichen (RTrim) oder weder führende noch nachgestellte Leerzeichen (Trim) enthält.
Syntax
LTrim(Zeichenfolge)

RTrim(Zeichenfolge)

Trim(Zeichenfolge)

Das Argument Zeichenfolge ist ein beliebiger gültiger Zeichenfolgenausdruck. Wenn Zeichenfolge den Wert Null enthält, wird Null zurückgegeben.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Funktionen LTrim, RTrim und Trim, um führende, nachgestellte bzw. führende und nachgestellte Leerzeichen zu entfernen:
Dim MeineVar
MeineVar = LTrim("  vbscript ")  ' MeineVar enthält "vbscript ".
MeineVar = RTrim("  vbscript ")  ' MeineVar enthält "  vbscript".
MeineVar = Trim("  vbscript ")   ' MeineVar enthält "vbscript".


LTrim-, RTrim- und Trim-Funktionen

LTrim-, RTrim- und Trim-Funktionen
Siehe auch 		Sprachverzeichnis

Left-Funktion
Right-Funktion


Mid-Funktion

Mid-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine bestimmte Anzahl von Zeichen aus einer Zeichenfolge zurück.
Syntax
Mid(Zeichenfolge, Start[, Länge])

Die Syntax der Mid-Funktion verwendet die folgenden Teile:

Teil | Beschreibung
Zeichenfolge | Zeichenfolgenausdruck, aus dem Zeichen zurückgegeben werden. Wenn Zeichenfolge den Wert Null enthält, wird Null zurückgegeben.
Anfang | Position in Zeichenfolge, an der die zurückzugebende Zeichenfolge beginnt. Ist Start größer als die Anzahl der Zeichen in Zeichenfolge, gibt Mid eine leere Zeichenfolge ("") zurück.
Länge | Anzahl der zurückzugebenden Zeichen. Wird Länge nicht angegeben oder befinden sich weniger Zeichen im Text (das Zeichen an der Stelle Starteingeschlossen), als durch Länge angegeben, werden alle Zeichen ab Start bis zum Ende der Zeichenfolge zurückgegeben.

Hinweise
Sie können die Zeichenanzahl in Zeichenfolge mit der Len-Funktion bestimmen.

Das folgende Beispiel verwendet die Mid-Funktion, um - beginnend beim vierten - sechs Zeichen in einer Zeichenfolge zurückzugeben:

Dim MeineVar
MeineVar = Mid("VB Script macht Freude!", 4, 6) ' MeineVar enthält "Script".
Hinweis Eine andere Funktion (MidB) steht für Bytedaten, die in einer Zeichenfolge enthalten sind, zur Verfügung. Die Argumente geben nicht die Anzahl der Zeichen an, sondern die Anzahl der Bytes.


Mid-Funktion

Mid-Funktion
Siehe auch 		Sprachverzeichnis

Left-Funktion
Len-Funktion
LTrim-, RTrim- und Trim-Funktionen
Right-Funktion


Minute-Funktion

Minute-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine ganze Zahl im Bereich von 0 bis 59 zurück, die die Minute in der Stunde darstellt.
Syntax
Minute(Uhrzeit)

Das Argument Uhrzeit ist ein beliebiger Ausdruck, der eine Uhrzeit darstellen kann. Wenn Uhrzeit den Wert Null enthält, wird Null zurückgegeben.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Minute-Funktion, um die Minute der aktuellen Stunde anzugeben:
Dim MeineVar
MeineVar = Minute(Now)


Minute-Funktion

Minute-Funktion
Siehe auch 		Sprachverzeichnis

Day-Funktion
Hour-Funktion
Now-Funktion
Second-Funktion
Time-Funktion


Month-Funktion

Month-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine ganze Zahl im Bereich von 1 bis 12 zurück, die den Monat im Jahr darstellt.
Syntax
Month(Datum)

Das Argument Datum ist ein beliebiger Ausdruck, der ein Datum darstellen kann. Wenn Datum den Wert Null enthält, wird Null zurückgegeben.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Month-Funktion, um den aktuellen Monat zurückzugeben:
Dim MeineVar
MeineVar = Month(Now)  ' MeineVar enthält die Monatszahl des
                       ' aktuellen Monats.


Month-Funktion

Month-Funktion
Siehe auch 		Sprachverzeichnis

Date-Funktion
Day-Funktion
Now-Funktion
Weekday-Funktion
Year-Funktion


MonthName-Funktion

MonthName-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt eine Zeichenfolge für den angegebenen Monat zurück.
Syntax
MonthName(Monat[, Abkürzung])

Die Syntax der MonthName-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Monat | Erforderlich. Der numerische Wert für den Monat. Beispiel: Januar ist 1, Februar ist 2 usw.
Abkürzung | Optional. Boolescher Wert für die Abkürzung des Monatsnamens. Ohne Angabe ist die Voreinstellung False, d. h. der Name wird nicht abgekürzt.

Hinweise
Das folgende Beispiel zeigt die Verwendung der MonthName-Funktion, um den abgekürzten Namen des Monats für einen Datumsausdruck zurückzugeben:
Dim MeineVar
MeineVar = MonthName(10, True) ' MeineVar enthält "Okt".


MonthName-Funktion

MonthName-Funktion
Siehe auch 		Sprachverzeichnis

WeekdayName-Funktion


MsgBox-Funktion

MsgBox-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Zeigt eine Meldung in einem Dialogfeld an, wartet darauf, dass der Benutzer auf eine Schaltfläche klickt, und gibt einen Wert zurück, der anzeigt, auf welche Schaltfläche geklickt wurde.
Syntax
MsgBox(Eingabeaufforderung[, Schaltflächen][, Titel][, Hilfedatei, Kontext])

Die Syntax der MsgBox-Funktion besitzt folgende Teile:

Teil | Beschreibung
Eingabeaufforderung | Zeichenfolgenausdruck, der als Meldung im Dialogfeld angezeigt wird. Die maximale Länge von Eingabeaufforderung beträgt etwa 1024 Zeichen, abhängig von der Breite der verwendeten Zeichen. Wenn Eingabeaufforderung mehr als eine Zeile umfasst, können Sie zwei Zeilen jeweils durch ein Wagenrücklaufzeichen (Chr(13)), ein Zeilenvorschubzeichen (Chr(10)) oder eine Kombination aus Wagenrücklauf- und Zeilenvorschubzeichen (Chr(13) & Chr(10)) trennen.
Schaltflächen | Numerischer Ausdruck, der die Summe der Werte für folgende Angaben darstellt: Anzahl und Art der anzuzeigenden Schaltflächen, Art des zu verwendenden Symbols, Angabe der Standardschaltfläche und Verhalten des Meldungsfeldes (gebunden/ungebunden). Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt. Falls nichts angegeben wird, ist der Standardwert für Schaltflächen 0.
Titel | Zeichenfolgenausdruck, der in der Titelleiste des Dialogfeldes angezeigt wird. Wenn Sie Titel nicht angeben, wird der Name der Anwendung in der Titelleiste angezeigt.
Hilfedatei | Zeichenfolgenausdruck, der die Hilfedatei angibt, die für die kontextbezogene Hilfe zum Dialogfeld geöffnet wird. Wenn Hilfedatei angegeben wird, muß Kontext ebenfalls angegeben werden. Nicht verfügbar auf 16-Bit-Plattformen.
Kontext | Numerischer Ausdruck, der die Hilfe-Kontextnummer angibt, die der Hilfeautor dem zugehörigen Hilfethema zugeordnet hat. Wenn Kontext angegeben wird, muss Hilfedatei ebenfalls angegeben werden. Nicht verfügbar auf 16-Bit-Plattformen.

Einstellungen
Die Einstellungen für das Argument Schaltflächen sind:

Konstante | Wert | Beschreibung
vbOKOnly | 0 | Nur Schaltfläche OK anzeigen.
vbOKCancel | 1 | Anzeigen der Schaltflächen OK und Abbrechen.
vbAbortRetryIgnore | 2 | Anzeigen der Schaltflächen Abbrechen, Wiederholen und Ignorieren.
vbYesNoCancel | 3 | Anzeigen der Schaltflächen Ja, Nein und Abbrechen.
vbYesNo | 4 | Anzeigen der Schaltflächen Ja und Nein.
vbRetryCancel | 5 | Anzeigen der Schaltflächen Wiederholen und Abbrechen.
vbCritical | 16 | Anzeigen des Stopp-Symbols.
vbQuestion | 32 | Anzeigen des Fragezeichen-Symbols.
vbExclamation | 48 | Anzeigen des Symbols Warnung.
vbInformation | 64 | Anzeigen des Symbols Information.
vbDefaultButton1 | 0 | Erste Schaltfläche ist Voreinstellung.
vbDefaultButton2 | 256 | Zweite Schaltfläche ist Voreinstellung.
vbDefaultButton3 | 512 | Dritte Schaltfläche ist Voreinstellung.
vbDefaultButton4 | 768 | Vierte Schaltfläche ist Voreinstellung.
vbApplicationModal | 0 | Anwendungsgebunden. Der Benutzer muss auf das Meldungsfeld reagieren, bevor er die Arbeit mit der aktuellen Anwendung fortsetzen kann.
vbSystemModal | 4096 | Systemgebunden. Alle Anwendungen werden unterbrochen, bis der Benutzer auf das Meldungsfeld reagiert.

Die erste Gruppe von Werten (0 - 5) beschreibt Anzahl und Typ der im Dialogfeld angezeigten Schaltflächen, die zweite Gruppe (16, 32, 48, 64) beschreibt die Art des Symbols, die dritte Gruppe (0, 256, 512, 768) bestimmt die voreingestellte Schaltfläche, und die vierte Gruppe (0, 4096) bestimmt, in welcher Form das Meldungsfeld gebunden ist. Verwenden Sie beim Addieren von Zahlen zu einen Gesamtwert für das Argument Schaltflächen nur einen Wert aus jeder Gruppe.

Rückgabewerte
Die MsgBox-Funktion besitzt die folgenden Rückgabewerte:

Konstante | Wert | Schaltfläche
vbOK | 1 | OK
vbCancel | 2 | Abbrechen
vbAbort | 3 | Abbrechen
vbRetry | 4 | Wiederholen
vbIgnore | 5 | Ignorieren
vbYes | 6 | Ja
vbNo | 7 | Nein

Hinweise
Wenn Sie Hilfedatei und Kontext angeben, kann der Benutzer F1 drücken, um das zum Kontext passende Hilfethema anzuzeigen.

Wenn im Dialogfeld die Schaltfläche Abbrechen angezeigt wird, hat das Drücken der ESC-Taste dieselbe Wirkung wie das Klicken auf Abbrechen. Wenn im Dialogfeld die Schaltfläche Hilfe angezeigt wird, wird eine kontextbezogene Hilfe für das Dialogfeld zur Verfügung gestellt. Ein Wert wird aber erst zurückgegeben, wenn auf eine der anderen Schaltflächen geklickt wird.

Wenn die MsgBox-Funktion zusammen mit Microsoft Internet Explorer verwendet wird, enthält der Titel aller angezeigten Dialogfelder immer "VBScript:", um sie von Standardsystemdialogfeldern zu unterscheiden.

Das folgende Beispiel zeigt die Verwendung der MsgBox-Funktion, um ein Meldungsfeld anzuzeigen und einen Wert zurückzugeben, der angibt, auf welche Schaltfläche geklickt wurde:

Dim MeineVar
MeineVar = MsgBox ("Hallo Welt!", 65, "MsgBox-Beispiel") ' MeineVar enthält entweder 1
                                                         ' oder 2, je nachdem, auf welche
                                                         ' Schaltfläche geklickt wurde.


MsgBox-Funktion

MsgBox-Funktion
Siehe auch 		Sprachverzeichnis

InputBox-Funktion


Now-Funktion

Now-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt das aktuelle Datum und die aktuelle Zeit aus den Einstellungen für das Systemdatum und die Systemzeit auf Ihrem Computer zurück.
Syntax
Now
Hinweise
Das folgende Beispiel zeigt die Verwendung der Now-Funktion, um das aktuelle Datum und die Zeit zurückzugeben:
Dim MeineVar
MeineVar = Now ' MeineVar enthält das aktuelle Datum und die aktuelle Uhrzeit.


Now-Funktion

Now-Funktion
Siehe auch 		Sprachverzeichnis

Date-Funktion
Day-Funktion
Hour-Funktion
Minute-Funktion
Month-Funktion
Second-Funktion
Time-Funktion
Weekday-Funktion
Year-Funktion


Oct-Funktion

Oct-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine Zeichenfolge mit der Oktaldarstellung einer Zahl zurück.
Syntax
Oct(Zahl)

Das Argument Zahl ist ein beliebiger gültiger Ausdruck.

Hinweise
Wenn Zahl keine ganze Zahl ist, rundet die Funktion den Wert vor der Auswertung auf die nächste ganze Zahl.

Ist Zahl | Rückgabewert von Oct
Null | Null.
Empty | Null (0).
Eine beliebige andere Zahl | Bis zu 11 oktale Zeichen.

Sie können Oktalzahlen direkt angeben, indem Sie &O vor eine Zahl im zulässigen Bereich setzen. &O10 entspricht zum Beispiel der Dezimalzahl 8 in Oktaldarstellung.

Das folgende Beispiel zeigt die Verwendung der Oct-Funktion, um die Oktaldarstellung einer Zahl zurückzugeben:

Dim MeineOktaleZahl
MeineOktaleZahl = Oct(4)     ' Ergibt 4.
MeineOktaleZahl = Oct(8)     ' Ergibt 10.
MeineOktaleZahl = Oct(459)   ' Ergibt 713.


Oct-Funktion

Oct-Funktion
Siehe auch 		Sprachverzeichnis

Hex-Funktion


Replace-Funktion

Replace-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt eine Zeichenfolge zurück, in der eine bestimmte Teilzeichenfolge durch eine andere Zeichenfolge so oft wie angegeben ersetzt wurde.
Syntax
Replace(Ausdruck, SuchZF, ErsetzenDurch[, Start[, Anzahl[, Vergleich]]])

Die Syntax der Replace-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Ausdruck | Erforderlich. Zeichenfolgenausdruck, der die zu ersetzende Teilzeichenfolge enthält.
SuchZF | Erforderlich. Zu suchende Teilzeichenfolge.
ErsetzenDurch | Erforderlich. Ersatzteilzeichenfolge.
Anfang | Optional. Position in Ausdruck, an der die Suche nach der Teilzeichenfolge beginnen soll. Ohne Angabe wird 1 angenommen. Muss in Verbindung mit Anzahl verwendet werden.
Anzahl | Optional. Anzahl der auszuführenden Ersetzungen für die Teilzeichenfolge. Ohne Angabe wird die Voreinstellung -1 verwendet, d. h. alle möglichen Ersetzungen werden vorgenommen. Muss in Verbindung mit Start verwendet werden.
Vergleich | Optional. Numerischer Wert für die zu verwendende Art des Vergleichs bei der Auswertung von Teilzeichenfolgen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt. Wenn dieser Wert weggelassen wird, ist die Voreinstellung 0, wodurch ein binärer Vergleich durchgeführt wird.

Einstellungen
Das Argument Vergleich kann die folgenden Werte haben:

Konstante | Wert | Beschreibung
vbBinaryCompare | 0 | Führt einen binären Vergleich durch.
vbTextCompare | 1 | Führt einen Textvergleich durch.

Rückgabewerte
Replace gibt die folgenden Werte zurück:

Wenn | Replace-Rückgabe
Ausdruck Länge 0 hat | Zeichenfolge mit Länge Null ("").
Ausdruck Null ist | Fehler
SuchZF Länge Null hat | Kopie von Ausdruck
ErsetzenDurch Länge Null hat | Kopie von Ausdruck, in der alle gefundenen SuchZF entfernt sind
Start > Len(Ausdruck) | Zeichenfolge mit Länge Null.
Anzahl 0 ist | Kopie von Ausdruck

Hinweise
Die Replace-Funktion liefert eine Zeichenfolge mit den erfolgten Ersetzungen, die mit der Position Start beginnt und am Ende der Zeichenfolge Ausdruck aufhört. Sie ist keine Kopie der ursprünglichen Zeichenfolge vom Anfang bis zum Ende.

Das folgende Beispiel zeigt die Verwendung der Replace-Funktion, um eine Zeichenfolge zurückzugeben:

Dim MeineZf
MeineZf = Replace("XXpXXPXXp", "p", "Y")
  ' Ein am Anfang der Zeichenfolge beginnender Binärvergleich. Gibt "XXYXXPXXY" zurück.
MeineZf = Replace("XXpXXPXXp", "p", "Y", 3, -1, 1)
  ' Ein an Position 3 der Zeichenfolge beginnender Textvergleich. Gibt "YXXYXXY" zurück.


Replace-Funktion

Replace-Funktion
Siehe auch 		Sprachverzeichnis

Filter-Funktion


RGB-Funktion

RGB-Funktion 		Sprachverzeichnis
Version 2

Beschreibung
Gibt eine ganze Zahl zurück, die einen RGB-Farbwert darstellt.
Syntax
RGB(Rot, Grün, Blau)

Die Syntax der RGB-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Rot | Erforderlich. Zahl im Bereich von 0-255, die den Rotanteil der Farbe darstellt.
Grün | Erforderlich. Zahl im Bereich von 0-255, die den Grünanteil der Farbe darstellt.
Blau | Erforderlich. Zahl im Bereich von 0-255, die den Blauanteil der Farbe darstellt.

Hinweise
Anwendungsmethoden und -Eigenschaften, die eine Farbspezifikation akzeptieren, erwarten, dass diese ein Zahl ist, die einen RGB-Farbwert darstellt. Ein RGB-Farbwert gibt die relative Intensität von Rot, Grün und Blau an, um eine bestimmte Farbe anzuzeigen.

Das niederwertige Byte enthält den Wert für Rot, das mittlere Byte den Wert für Grün, und das höherwertige Byte den Wert für Blau.

Für Anwendungen, die eine umgekehrte Bytereihenfolge erfordern, stellt die folgende Funktion die gleiche Information in umgekehrter Bytereihenfolge bereit:

Function UmgRGB(Rot, Gruen, Blau)
    UmgRGB = CLng(Blau + (Gruen * 256) + (Rot * 65536))
End Function

Jedes Argument von RGB größer als 255 wird als 255 angenommen.


Right-Funktion

Right-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine bestimmte Anzahl von Zeichen vom rechten Teil (dem Ende) einer Zeichenfolge zurück.
Syntax
Right(Zeichenfolge, Länge)

Die Syntax der Right-Funktion verwendet die folgenden Argumente:

Teil | Beschreibung
Zeichenfolge | Zeichenfolgenausdruck, von dem die letzten (rechts stehenden) Zeichen zurückgegeben werden. Wenn Zeichenfolge den Wert Null enthält, wird Null zurückgegeben.
Länge | Numerischer Ausdruck, der die Anzahl der zurückzugebenden Zeichen angibt. 0 führt zur Rückgabe einer leeren Zeichenfolge. Ist Länge größer oder gleich der Zeichenanzahl in Zeichenfolge, wird die gesamte Zeichenfolge zurückgegeben.

Hinweise
Sie können die Zeichenanzahl in Zeichenfolge mit der Len-Funktion bestimmen.

Das folgende Beispiel zeigt die Verwendung der Right-Funktion, um die angegebene Zahl von Zeichen vom rechten Teil einer Zeichenfolge zurückzugeben:

Dim BeliebZf, MeineZf
BeliebZf = "Hallo Welt"         ' Definieren der Zeichenfolge.
MeineZf = Right(BeliebZf , 1)   ' Gibt "t" zurück.
MeineZf = Right(BeliebZf, 6)    ' Gibt "o Welt" zurück.
MeineZf = Right(BeliebZf, 20)   ' Gibt "Hallo Welt" zurück.
Hinweis Eine andere Funktion (RightB) steht für die Bytedaten zur Verfügung, die in einer Zeichenfolge enthalten sind. Länge gibt nicht Anzahl der zurückzugebenden Zeichen zurück, sondern die Anzahl der Bytes.


Right-Funktion

Right-Funktion
Siehe auch 		Sprachverzeichnis

Left-Funktion
Len-Funktion
Mid-Funktion


Rnd-Funktion

Rnd-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine Zufallszahl zurück.
Syntax
Rnd[(Zahl)]

Das Argument Zahl kann ein beliebiger gültiger numerischer Ausdruck sein.

Hinweise
Die Rnd-Funktion gibt einen Wert zurück, der kleiner als 1, aber größer oder gleich 0 ist. Der Wert von Zahl bestimmt, wie Rnd eine Zufallszahl generiert:

Zahl | Generierte Zufallszahl
Kleiner als Null | Immer dieselbe Zahl, mit Zahl als Startwert.
Größer als Null | Die nächste Zufallszahl der Folge.
Gleich Null | Die zuletzt generierte Zahl.
Nicht angegeben | Die nächste Zufallszahl der Folge.

Für jeden gegebenen Startwert wird dieselbe Zufallszahlenfolge generiert, weil bei jedem Aufruf der Rnd-Funktion die vorherige Zahl als Startwert für die nächste Zahl in der Folge dient.

Bevor Sie Rnd aufrufen, verwenden Sie die Randomize-Anweisung ohne Argument, um den Zufallszahlengenerator mit einem Startwert zu initialisieren, der auf dem Systemzeitgeber basiert.

Verwenden Sie die folgende Formel, um ganzzahlige Zufallszahlen innerhalb eines bestimmten Bereichs zu erzeugen:

Int((Obergrenze - Untergrenze + 1) * Rnd + Untergrenze)
Obergrenze steht für die größte und Untergrenze für die kleinste Zahl des Bereichs.

Hinweis Wenn Sie Folgen von Zufallszahlen wiederholen möchten, rufen Sie unmittelbar vor dem Aufruf von Randomize mit einem numerischen Argument die Rnd-Funktion mit einem negativen Argument auf. Durch Verwenden von Randomize mit demselben Wert für Zahl wird die vorherige Folge nicht wiederholt.


Rnd-Funktion

Rnd-Funktion
Siehe auch 		Sprachverzeichnis

Randomize-Anweisung


Round-Funktion

Round-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt eine auf die angegebene Anzahl Dezimalstellen gerundete Zahl zurück.
Syntax
Round(Ausdruck[, AnzDezimalstellen])

Die Syntax der Round-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Ausdruck | Erforderlich. Zu rundender numerischer Ausdruck.
AnzDezimalstellen | Optional. Optionale Zahl für die Anzahl der Dezimalstellen, auf die gerundet werden soll. Erfolgt keine Angabe, werden durch die Round-Funktion ganzzahlige Werte zurückgegeben.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Round-Funktion, um eine Zahl auf zwei Dezimalstellen zu runden:
Dim MeineVar, pi
pi = 3.14159
MeineVar = Round(pi, 2) ' MeineVar enthält 3,14.


Round-Funktion

Round-Funktion
Siehe auch 		Sprachverzeichnis

Int, Fix-Funktionen


ScriptEngine-Funktion

ScriptEngine-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt eine Zeichenfolge mit der gerade verwendeten Skriptsprache zurück.
Syntax
ScriptEngine
Rückgabewerte
Die ScriptEngine-Funktion kann jeden der folgenden Werte zurückgeben:

Zeichenfolge | Beschreibung
VBScript | Gibt an, dass Microsoft® Visual Basic® Scripting Edition das aktuelle Skriptmodul ist.
JScript | Gibt an, dass Microsoft JScript® das aktuelle Skriptmodul ist.
VBA | Gibt an, dass Microsoft Visual Basic für Applikationen das verwendete Skriptmodul ist.

Hinweise
Das folgende Beispiel zeigt die Verwendung der ScriptEngine-Funktion, um eine Zeichenfolge zurückzugeben, die die verwendete Skriptsprache beschreibt:
Function ScriptModulInfoHolen
  Dim s
  s = ""				' Erstellt die Zeichenfolge mit den notwendigen Informationen.
  s = ScriptEngine & " Version "
  s = s & ScriptEngineMajorVersion & "."
  s = s & ScriptEngineMinorVersion & "."
  s = s & ScriptEngineBuildVersion
  ScriptModulInfoHolen =  s	' Gibt die Ergebnisse zurück.
End Function


ScriptEngineBuildVersion-Funktion

ScriptEngineBuildVersion-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt die Build-Versionsnummer des verwendeten Skriptmoduls zurück.

Syntax
ScriptEngineBuildVersion

Hinweise
Der Rückgabewert bezieht sich direkt auf die Versionsinformationen in der DLL der verwendeten Skriptsprache.

Das folgende Beispiel zeigt die Verwendung der ScriptEngineBuildVersion-Funktion, um die Build-Versionsnummer des verwendeten Skriptmoduls zurückzugeben:

Function ScriptModulInfoHolen
 Dim s
 s = ""				' Erstellt die Zeichenfolge mit den notwendigen Informationen.
 s = ScriptEngine & " Version "
 s = s & ScriptEngineMajorVersion & "."
 s = s & ScriptEngineMinorVersion & "."
 s = s & ScriptEngineBuildVersion
 ScriptModulInfoHolen = s		' Gibt die Ergebnisse zurück.
End Function


ScriptEngineBuildVersion-Funktion

ScriptEngineBuildVersion-Funktion
Siehe auch 		Sprachverzeichnis

ScriptEngine-Funktion
ScriptEngineMajorVersion-Funktion
ScriptEngineMinorVersion-Funktion


ScriptEngine-Funktion

ScriptEngine-Funktion
Siehe auch 		Sprachverzeichnis

ScriptEngineBuildVersion-Funktion
ScriptEngineMajorVersion-Funktion
ScriptEngineMinorVersion-Funktion


ScriptEngineMajorVersion-Funktion

ScriptEngineMajorVersion-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt die Haupt-Versionsnummer des verwendeten Skriptmoduls zurück.
Syntax
ScriptEngineMajorVersion
Hinweise
Der Rückgabewert bezieht sich direkt auf die Versionsinformationen in der DLL der verwendeten Skriptsprache.

Das folgende Beispiel zeigt die Verwendung der ScriptEngineMajorVersion-Funktion, um die Versionsnummer des verwendeten Skriptmoduls zurückzugeben:

Function ScriptModulInfoHolen
  Dim s
  s = ""                         ' Erstellt die Zeichenfolge mit den notwendigen Informationen.
  s = ScriptEngine & " Version "
  s = s & ScriptEngineMajorVersion & "."
  s = s & ScriptEngineMinorVersion & "."
  s = s & ScriptEngineBuildVersion
  ScriptModulInfoHolen = s       ' Gibt die Ergebnisse zurück.
End Function


ScriptEngineMajorVersion-Funktion

ScriptEngineMajorVersion-Funktion
Siehe auch 		Sprachverzeichnis

ScriptEngine-Funktion
ScriptEngineBuildVersion-Funktion
ScriptEngineMinorVersion-Funktion


ScriptEngineMinorVersion-Funktion

ScriptEngineMinorVersion-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt die Neben-Versionsnummer des verwendeten Skriptmoduls zurück.
Syntax
ScriptEngineMinorVersion
Hinweise
Der Rückgabewert bezieht sich direkt auf die Versionsinformationen in der DLL der verwendeten Skriptsprache.

Das folgende Beispiel zeigt die Verwendung der ScriptEngineMinorVersion-Funktion, um die Neben-Versionsnummer des verwendeten Skriptmoduls zurückzugeben:

Function ScriptModulInfoHolen
  Dim s
  s = ""                         ' Erstellt die Zeichenfolge mit den notwendigen Informationen.
  s = ScriptEngine & " Version "
  s = s & ScriptEngineMajorVersion & "."
  s = s & ScriptEngineMinorVersion & ".
  s = s & ScriptEngineBuildVersion
  ScriptModulInfoHolen = s       ' Gibt die Ergebnisse zurück.
End Function


ScriptEngineMinorVersion-Funktion

ScriptEngineMinorVersion-Funktion
Siehe auch 		Sprachverzeichnis

ScriptEngine-Funktion
ScriptEngineBuildVersion-Funktion
ScriptEngineMajorVersion-Funktion


Second-Funktion

Second-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine ganze Zahl im Bereich von 0 bis 59 zurück, die die Sekunde in der Minute darstellt.
Syntax
Second(Uhrzeit)

Das Argument Uhrzeit ist ein beliebiger Ausdruck, der eine Uhrzeit darstellen kann. Wenn Uhrzeit den Wert Null enthält, wird Null zurückgegeben.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Second-Funktion, um die aktuelle Sekunde zurückzugeben:
Dim MeineSek
MeineSek = Second(Now)  ' MeineSek enthält die z. Z.
                        ' aktuelle Sekundenzahl.


Second-Funktion

Second-Funktion
Siehe auch 		Sprachverzeichnis

Day-Funktion
Hour-Funktion
Minute-Funktion
Now-Funktion
Time-Funktion


SetLocale Function

SetLocale-Funktion 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Legt das globale Gebietsschema fest und gibt das vorherige Gebietsschema zurück.
Syntax
SetLocale(lcid)

Das Argument lcid kann ein beliebiger gültiger 32-Bit-Wert oder eine Kurzzeichenfolge sein, der/die eine geografische Ländereinstellung eindeutig identifiziert. Erkannte Werte finden Sie im Gebietsschema-ID (LCID)-Diagramm.

Hinweise

Falls lcid Null ist, wird die Ländereinstellung entsprechend der aktuellen Systemeinstellung gesetzt.

Eine Ländereinstellung enthält verschiedene Benutzereinstellungsinformationen, die sich auf die Sprache, das Land und kulturelle Konventionen des Benutzers beziehen. Die Ländereinstellung bestimmt beispielsweise das Tastaturlayout, die alphabetische Sortierreihenfolge sowie die Formate für Datum, Uhrzeit, Zahlen und Währungen.

Das folgende Beispiel verdeutlicht die Verwendung der SetLocale-Funktion: Um diesen Code zu verwenden, fügen Sie das gesamte Beispiel zwischen die <BODY>-Tags einer HTML-Standardseite ein.

Geben Sie ein Datum im britischen Datumsformat ein: <input type="text" id="UKDate" size="20"><p>
Hier ist die US-amerikanische Entsprechung: <input type="text" id="USdate" size="20"><p>
<input type="button" value="Convert" id="schaltflaeche1"><p>
Geben Sie einen Preis im deutschen Währungsformat ein:   <input type="text" id="GermanNumber" size="20">
<p>
Hier ist die britische Entsprechung: <input type="text" id="USNumber" size="20"><p>
<input type="button" value="Convert" id="schaltflaeche2"><p>

<script language="vbscript">
Dim aktuellesGebietsschema
' Ruft die aktuelle Ländereinstellung ab.
aktuellesGebietsschema = GetLocale

Sub schaltflaeche1_onclick
  Dim original
  original = SetLocale("en-gb")
  meindatum = CDate(UKDate.value)
  ' Internet Explorer setzt die Ländereinstellung immer auf US-Englisch; verwenden Sie also die
  ' aktuellesGebietsschema-Variable, um die Ländereinstellungen auf US-Englisch zu setzen.
  original = SetLocale(aktuellesGebietsschema)
  USDate.value = FormatDateTime(meindatum,vbShortDate)
End Sub

Sub schaltflaeche2_onclick
  Dim original
  original = SetLocale("de")
  meinwert = CCur(GermanNumber.value)
  original = SetLocale("en-gb")
  USNumber.value = FormatCurrency(meinwert)
End Sub

</script>


SetLocale-Funktion

SetLocale-Funktion
Siehe auch 		Sprachverzeichnis

GetLocale-Funktion
Gebietsschema-ID (LCID)-Diagramm


Sgn-Funktion

Sgn-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen ganzzahligen Wert zurück, der das Vorzeichen einer Zahl darstellt.
Syntax
Sgn(Zahl)

Das Argument Zahl kann ein beliebiger gültiger numerischer Ausdruck sein.

Rückgabewerte
Die Sgn-Funktion hat die folgenden Rückgabewerte:

Wenn Zahl | Rückgabewert von Sgn
Größer als Null | 1
Gleich Null | 0
Kleiner als Null | -1

Hinweise
Das Vorzeichen des Arguments Zahl bestimmt den Rückgabewert der Sgn-Funktion.

Das folgende Beispiel zeigt die Verwendung der Sgn-Funktion, um das Vorzeichen einer Zahl zu bestimmen:

Dim MeineVar1, MeineVar2, MeineVar3, MeinVorz
MeineVar1 = 12: MeineVar2 = -2.4: MeineVar3 = 0
MeinVorz = Sgn(MeineVar1)    ' Ergibt 1.
MeinVorz = Sgn(MeineVar2)    ' Ergibt -1.
MeinVorz = Sgn(MeineVar3)    ' Ergibt 0.


Sgn-Funktion

Sgn-Funktion
Siehe auch 		Sprachverzeichnis

Abs-Funktion


Sin-Funktion

Sin-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Berechnet den Sinus eines Winkels.
Syntax
Sin(Zahl)

Das Argument Zahl kann ein beliebiger numerischer Ausdruck sein, der einen Winkel im Bogenmaß angibt.

Hinweise
Die Funktion Sin berechnet aus einem Winkel den Quotienten von zwei Seiten eines rechtwinkligen Dreiecks. Der Quotient ergibt sich aus dem Längenverhältnis von Gegenkathete zu Hypotenuse. Das Ergebnis liegt im Bereich von -1 bis 1.

Zur Umrechnung von Grad ins Bogenmaß muss die Gradangabe mit pi/180 multipliziert werden. Zur Umrechnung von Bogenmaß in Grad muss das Bogenmaß mit 180/pi multipliziert werden.

Im folgenden Beispiel wird mithilfe der Sin-Funktion der Kosekans eines Winkels berechnet.

Dim MeinWinkel, MeinKosekans
MeinWinkel = 1.3                    ' Definiert einen Winkel im Bogenmaß.
MeinKosekans = 1 / Sin(MeinWinkel)  ' Berechnen des Kosekans.


Sin-Funktion

Sin-Funktion
Siehe auch 		Sprachverzeichnis

Abgeleitete mathematische Funktionen
Atn-Funktion
Cos-Funktion
Tan-Funktion


Space-Funktion

Space-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine Zeichenfolge mit einer bestimmten Anzahl an Leerzeichen zurück.
Syntax
Space(Zahl)

Das Argument Zahl entspricht der Anzahl gewünschter Leerzeichen in der Zeichenfolge.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Space-Funktion, um eine Zeichenfolge zurückzugeben, die die angegebene Zahl von Leerzeichen enthält:
Dim MeineZf
MeineZf = Space(10)                     ' Gibt eine Zeichenfolge mit 10 Leerzeichen zurück.
MeineZf = "Hallo" & Space(10) & "Welt"  ' Fügt 10 Leerzeichen zwischen zwei Zeichenfolgen ein.


Space-Funktion

Space-Funktion
Siehe auch 		Sprachverzeichnis

String-Funktion


Split-Funktion

Split-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt ein nullbasiertes, eindimensionales Datenfeld zurück, das eine angegebene Anzahl von Teilzeichenfolgen enthält.
Syntax
Split(Ausdruck[, Trennzeichen[, Anzahl[, Vergleich]]])

Die Syntax der Split-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Ausdruck | Erforderlich. Zeichenfolgenausdruck mit Teilzeichenfolgen und Trennzeichen. Ist Ausdruck eine Zeichenfolge mit der Länge 0, gibt Split ein leeres Datenfeld, d. h. ein Datenfeld ohne Elemente und Daten, zurück.
Trennzeichen | Optional. Zeichen zum Identifizieren der Begrenzungen von Teilzeichenfolgen. Ohne Angabe wird das Leerzeichen (" ") als Trennzeichen angenommen. Ist Trennzeichen eine Zeichenfolge mit der Länge Null, wird ein Datenfeld mit einem Element, das die ganze Zeichenfolge Ausdruck enthält, zurückgegeben.
Anzahl | Optional. Anzahl der Teilzeichenfolgen, die zurückgegeben werden sollen. -1 zeigt an, dass alle Teilzeichenfolgen zurückgegeben werden.
Vergleich | Optional. Numerischer Wert für die zu verwendende Art des Vergleichs bei der Auswertung von Teilzeichenfolgen. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.

Einstellungen
Das Argument Vergleich kann die folgenden Werte haben:

Konstante | Wert | Beschreibung
vbBinaryCompare | 0 | Führt einen binären Vergleich durch.
vbTextCompare | 1 | Führt einen Textvergleich durch.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Split-Funktion, um ein aus einer Zeichenfolge erzeugtes Datenfeld zurückzugeben. Die Funktion für einen Textvergleich durch (Suche nach dem Trennzeichen) und gibt jede Teilzeichenfolge zurück.
Dim MeineZf, MeinDatenfeld, Meldung
MeineZf = "VBScriptXistXtoll!"
MeinDatenfeld = Split(MeineZf, "x", -1, 1)
' MeinDatenfeld(0) enthält "VBScript".
' MeinDatenfeld(1) enthält "ist".
' MeinDatenfeld(2) enthält "toll!".
Meldung = MeinDatenfeld(0) & " " & MeinDatenfeld(1)
Meldung = Meldung & " " & MeinDatenfeld(2)
MsgBox Meldung


Split-Funktion

Split-Funktion
Siehe auch 		Sprachverzeichnis

Join-Funktion


Sqr-Funktion

Sqr-Funktion 		Sprachverzeichnis
Version 1

Beschreibung
Gibt die Quadratwurzel einer Zahl zurück.
Syntax
Sqr(Zahl)

Das Argument Zahl kann jeder beliebige numerische Ausdruck größer oder gleich 0 sein.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Sqr-Funktion, um die Quadratwurzel einer Zahl zu berechnen:
Dim MeineWurzel
MeineWurzel = Sqr(4)     ' Ergibt 2.
MeineWurzel = Sqr(23)    ' Ergibt 4,79583152331272.
MeineWurzel = Sqr(0)     ' Ergibt 0.
MeineWurzel = Sqr(-4)    ' Löst einen Laufzeitfehler aus.


StrComp-Funktion

StrComp-Funktion 		Sprachverzeichnis
Version 1

Beschreibung
Gibt einen Wert zurück, der das Ergebnis eines Zeichenfolgenvergleichs anzeigt.
Syntax
StrComp(Zeichenfolge1, Zeichenfolge2[, Vergleich])

Die Syntax der StrComp-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Zeichenfolge1 | Erforderlich. Ein beliebiger gültiger Zeichenfolgenausdruck.
Zeichenfolge2 | Erforderlich. Ein beliebiger gültiger Zeichenfolgenausdruck.
Vergleich | Optional. Numerischer Wert für die zu verwendende Art des Vergleichs bei der Auswertung von Zeichenfolgen. Wird Vergleich nicht angegeben, wird ein binärer Vergleich durchgeführt. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.

Einstellungen
Das Argument Vergleich kann die folgenden Werte haben:

Konstante | Wert | Beschreibung
vbBinaryCompare | 0 | Führt einen binären Vergleich durch.
vbTextCompare | 1 | Führt einen Textvergleich durch.

Rückgabewerte
Die StrComp-Funktion besitzt die folgenden Rückgabewerte:

Wenn | Rückgabewerte
Zeichenfolge1 kleiner als Zeichenfolge2 ist | -1
Zeichenfolge1 gleich Zeichenfolge2 ist | 0
Zeichenfolge1 größer als Zeichenfolge2 ist | 1
Zeichenfolge1 oder Zeichenfolge2 Null ist | Null

Hinweise
Das folgende Beispiel zeigt die Verwendung der StrComp-Funktion, um das Ergebnis eines Zeichenfolgenvergleichs zurückzugeben. Ist das dritte Argument 1, wird ein Textvergleich ausgeführt. Ist das dritte Argument 0 oder nicht vorhanden, wird ein binärer Vergleich ausgeführt.
Dim MeineZf1, MeineZf2, MeinVergleich
MeineZf1 = "ABCD": MeineZf2 = "abcd"             ' Definieren der Variablen.
MeinVergleich = StrComp(MeineZf1, MeineZf2, 1)   ' Gibt 0 zurück.
MeinVergleich = StrComp(MeineZf1, MeineZf2, 0)   ' Gibt -1 zurück.
MeinVergleich = StrComp(MeineZf2, MeineZf1)      ' Gibt 1 zurück.


String-Funktion

String-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine Zeichenfolge der angegebenen Länge mit einem sich wiederholenden Zeichen zurück.
Syntax
String(Zahl, Zeichen)

Die Syntax der String-Funktion verwendet die folgenden Teile:

Teil | Beschreibung
Anzahl | Länge der zurückgegebenen Zeichenfolge. Wenn Zahl den Wert Null enthält, wird Null zurückgegeben.
Zeichen | Ein Zeichencode, welcher das Zeichen angibt, oder ein Zeichenfolgenausdruck, dessen erstes Zeichen zum Erstellen der Rückgabe-Zeichenfolge verwendet wird. Wenn Zeichen den Wert Null enthält, wird Null zurückgegeben.

Hinweise
Wenn Sie für Zeichen eine Zahl größer als 255 angeben, wandelt String die Zahl mit der folgenden Formel in einen gültigen Zeichencode um:
Zeichen Mod 256
Das folgende Beispiel zeigt die Verwendung der String-Funktion, um eine Zeichenfolge mit sich wiederholenden Zeichen in der angegebenen Länge zurückzugeben:
Dim MeineZf
MeineZf = String(5, "*")       ' Ergibt "*****".
MeineZf = String(5, 42)        ' Ergibt "*****".
MeineZf = String(10, "ABC")    ' Ergibt "AAAAAAAAAA".


String-Funktion

String-Funktion
Siehe auch 		Sprachverzeichnis

Space-Funktion


StrReverse-Funktion

StrReverse-Funktion 		Sprachverzeichnis
Version 2

Beschreibung
Gibt eine Zeichenfolge zurück, in der die Reihenfolge der Zeichen der angegebenen Zeichenfolge umgekehrt wurde.
Syntax
StrReverse(Zeichenfolge1)

Das Argument Zeichenfolge1 gibt die Zeichenfolge an, in der die Reihenfolge der Zeichen umgekehrt werden soll. Ist Zeichenfolge1 eine Zeichenfolge der Länge Null (""), wird auch eine Zeichenfolge der Länge 0 zurückgegeben. Handelt es sich bei Zeichenfolge1 um Null, tritt ein Fehler auf.

Hinweise
Das folgende Beispiel zeigt die Verwendung der StrReverse-Funktion, um eine Zeichenfolge umgekehrt auszugeben:
Dim MeineZf
MeineZf = StrReverse("VBScript") ' MeineZf enthält "tpircSBV".


Tan-Funktion

Tan-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Berechnet den Tangens eines Winkels.
Syntax
Tan(Zahl)

Das Argument Zahl kann ein beliebiger numerischer Ausdruck sein, der einen Winkel im Bogenmaß angibt.

Hinweise
Tan berechnet aus einem Winkel den Quotienten von zwei Seiten eines rechtwinkligen Dreiecks. Der Quotient ist das Längenverhältnis von Gegenkathete zu Ankathete.

Zur Umrechnung von Grad ins Bogenmaß muss die Gradangabe mit pi/180 multipliziert werden. Zur Umrechnung von Bogenmaß in Grad muss das Bogenmaß mit 180/pi multipliziert werden.

Das folgende Beispiel zeigt die Verwendung der Tan-Funktion, um den Kotangens eines Winkels zu berechnen:

Dim MeinWinkel, MeinKotangens
MeinWinkel = 1.3                      ' Definiert einen Winkel im Bogenmaß.
MeinKotangens = 1 / Tan(MeinWinkel)   ' Berechnet den Kotangens.


Tan-Funktion

Tan-Funktion
Siehe auch 		Sprachverzeichnis

Abgeleitete mathematische Funktionen
Atn-Funktion
Cos-Funktion
Sin-Funktion


Time-Funktion

Time-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück, der die aktuelle Systemzeit angibt.
Syntax
Time
Hinweise
Das folgende Beispiel zeigt die Verwendung der Time-Funktion, um die aktuelle Systemzeit zurückzugeben:
Dim MeineZeit
MeineZeit = Time    ' Gibt die aktuelle Systemzeit zurück.


Time-Funktion

Time-Funktion
Siehe auch 		Sprachverzeichnis

Date-Funktion


Timer-Funktion

Timer-Funktion 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Gibt die Anzahl der seit 24:00 Uhr (Mitternacht) vergangenen Sekunden an.
Syntax
Timer

Hinweise
Das folgende Beispiel verwendet die Timer-Funktion, um die benötigte Zeit zum N-maligen Durchlaufen einer For...Next-Schleife zu bestimmen:
Function ZeitMessen(N)
  Dim Beginn, Ende
  Beginn = Timer
  For I = 1 To N
  Next
  Ende = Timer
  ZeitMessen = Ende - Beginn
End Function


Timer-Funktion

Timer-Funktion
Siehe auch 		Sprachverzeichnis

Randomize-Anweisung


TimeSerial-Funktion

TimeSerial-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück, der die Uhrzeit für eine bestimmte Stunde, Minute und Sekunde enthält.
Syntax
TimeSerial(Stunde, Minute, Sekunde)

Die Syntax der TimeSerial-Funktion verwendet die folgenden Teile:

Teil | Beschreibung
Stunde | Zahl im Bereich von 0 (00:00) bis 23 (23:00) (je einschließlich) oder ein numerischer Ausdruck.
Minute | Beliebiger numerischer Ausdruck.
Sekunde | Beliebiger numerischer Ausdruck.

Hinweise
Wenn Sie eine Zeit (zum Beispiel 11:59:59) angeben, sollten sich die Zahlen für die Argumente von TimeSerial im jeweils gültigen Bereich befinden, also im Bereich 0-23 für Stunden und 0-59 für Minuten und Sekunden. Alternativ können Sie einen relativen Wert für die einzelnen Argumente mit einem beliebigen numerischen Ausdruck angeben, der eine bestimmte Anzahl an Stunden, Minuten oder Sekunden vor oder nach einem Zeitpunkt angibt.

Das folgende Beispiel zeigt die Verwendung von Ausdrücken anstelle absoluter Zeitwerte. Die TimeSerial-Funktion gibt die Uhrzeit für den Zeitpunkt 15 Minuten vor (-15) der Stunde zurück, die sechs Stunden vor 12 Uhr (12 - 6) liegt. Das Ergebnis ist 5:45:00.

Dim MeineZeit
MeineZeit = TimeSerial(12 - 6, -15, 0) ' Gibt 5:45:00 zurück.
Wenn ein Argument den zulässigen Bereich für das Argument überschreitet, erfolgt ein Übertrag auf die nächstgrößere Einheit. Wenn Sie beispielsweise 75 Minuten angeben, wird dies als eine Stunde und 15 Minuten interpretiert. Wenn aber eines der Argumente außerhalb des Bereichs -32.768 bis 32.767 liegt oder wenn die durch die drei Argumente (direkt oder durch einen Ausdruck) angegebene Zeit außerhalb des zulässigen Bereichs liegt, tritt ein Fehler auf.


TimeSerial-Funktion

TimeSerial-Funktion
Siehe auch 		Sprachverzeichnis

DateSerial-Funktion
DateValue-Funktion
Hour-Funktion
Minute-Funktion
Now-Funktion
Second-Funktion
TimeValue-Funktion


TimeValue-Funktion

TimeValue-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Wert vom Typ Variant mit dem Untertyp Date zurück, der die Uhrzeit enthält.
Syntax
TimeValue(Uhrzeit)

Das Argument Uhrzeit ist normalerweise ein Zeichenfolgenausdruck, der eine Zeit im Bereich von 0:00:00 bis 23:59:59 darstellt. Alternativ können Sie für Uhrzeit einen beliebigen Ausdruck angeben, der eine Zeit aus diesem Bereich ergibt. Wenn Uhrzeit den Wert Null enthält, wird Null zurückgegeben.

Hinweise
Zeitangaben sind in der 24-Stunden-Schreibweise und der 12-Stunden-Schreibweise zulässig. Die Angaben 2:24PM und 14:24 sind daher beide gültige Werte für Uhrzeit. Wenn das Argument Uhrzeit eine Datumsangabe enthält, wird diese von TimeValue nicht zurückgegeben. Wenn Uhrzeit jedoch ein ungültiges Datum enthält, tritt ein Fehler auf.

Das folgende Beispiel verwendet die TimeValue-Funktion, um eine Zeichenfolge in eine Uhrzeit zu konvertieren. Sie können auch mit den Datumsliteralen Variant (beispielsweise, MeineZeit = #4:35:17 PM#) direkt eine Uhrzeit zuweisen.

Dim MeineZeit
MeineZeit = TimeValue("4:35:17 PM")    ' MeineZeit enthält 16:35:17.


TimeValue-Funktion

TimeValue-Funktion
Siehe auch 		Sprachverzeichnis

DateSerial-Funktion
DateValue-Funktion
Hour-Funktion
Minute-Funktion
Now-Funktion
Second-Funktion
TimeSerial-Funktion


TypeName-Funktion

TypeName-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt eine Zeichenfolge mit Informationen zum Variant-Untertyp einer Variablen zurück.
Syntax
TypeName(Variablenname)

Das erforderliche Argument Variablenname kann jede beliebige Variable sein.

Rückgabewerte
Die TypeName-Funktion hat folgende Rückgabewerte:

Wert | Beschreibung
Byte | Bytewert
Integer | Ganzzahliger Wert
Long | Long Integer-Wert
Single | Fließkommawert mit einfacher Genauigkeit
Double | Fließkommawert mit doppelter Genauigkeit
Currency | Währungsbetrag
Decimal | Dezimalwert
Date | Datums- oder Zeitangabe
String | Zeichenfolge
Boolean | Boolescher Wert; True oder False
Empty | Nicht initialisiert
Null | Keine gültigen Daten
<Objekttyp> | Tatsächlicher Typname eines Objekts
Objekt | Allgemeines Objekt
Unknown | Unbekannter Objekttyp
Nothing | Objektvariable, noch ohne Bezug auf Objektinstanz
Error | Fehler

Hinweise
Das folgende Beispiel zeigt die Verwendung der TypeName-Funktion, um Informationen über eine Variable zurückzugeben:
Dim DialogfeldVar(4), MeinTyp
NullVar = Null			  ' Weist Nullwert zu.

MeinTyp = TypeName("VBScript")    ' Gibt "String" zurück.
MeinTyp = TypeName(4)             ' Gibt "Integer" zurück.
MeinTyp = TypeName(37.50)         ' Gibt "Double" zurück.
MeinTyp = TypeName(NullVar)       ' Gibt "Null" zurück.
MeinTyp = TypeName(DialogfeldVar) ' Gibt "Variant()" zurück.


TypeName-Funktion

TypeName-Funktion
Siehe auch 		Sprachverzeichnis

IsArray-Funktion
IsDate-Funktion
IsEmpty-Funktion
IsNull-Funktion
IsNumeric-Funktion
IsObject-Funktion
VarType-Funktion


UBound-Funktion

UBound-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Liefert den größten verfügbaren Index für die angegebene Dimension eines Datenfeldes.
Syntax
UBound(Datenfeldname[, Dimension])

Die Syntax der UBound-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Datenfeldname | Erforderlich. Name der Datenfeldvariablen gemäß den Standardkonventionen für Namen von Variablen.
Dimension | Optional. Ganze Zahl, die angibt, für welche Dimension die obere Grenze zurückgegeben werden soll. Verwenden Sie für die erste Dimension 1, für die zweite Dimension 2 usw. Wird Dimension nicht angegeben, wird von 1 ausgegangen.

Hinweise
Die UBound-Funktion kann zusammen mit der LBound-Funktion verwendet werden, um die Größe eines Datenfeldes zu bestimmen. LBound liefert die Untergrenze einer Datenfelddimension.

Die Untergrenze für jede Dimension ist immer 0. UBound gibt für ein Datenfeld mit den folgenden Dimensionen die in der nachfolgenden Tabelle aufgeführten Werte zurück:

Dim A(100,3,4)
Anweisung | Rückgabewert
UBound(A, 1) | 100
UBound(A, 2) | 3
UBound(A, 3) | 4


UBound-Funktion

UBound-Funktion
Siehe auch 		Sprachverzeichnis

Dim-Anweisung
LBound-Funktion
ReDim-Anweisung


Ucase-Funktion

UCase-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt eine Zeichenfolge zurück, die in Großbuchstaben umgewandelt wurde.
Syntax
UCase(Zeichenfolge)

Das Argument Zeichenfolge ist ein beliebiger gültiger Zeichenfolgenausdruck. Wenn Zeichenfolge den Wert Null enthält, wird Null zurückgegeben.

Hinweise
Lediglich Kleinbuchstaben werden in Großbuchstaben umgewandelt. Alle Großbuchstaben und sonstigen Zeichen bleiben unverändert.

Das folgende Beispiel zeigt die Verwendung der UCase-Funktion, um eine Zeichenfolge in Großbuchstaben zu konvertieren:

Dim MeinWort
MeinWort = UCase("Hallo Welt")    ' Gibt "HALLO WELT" zurück.


UCase-Funktion

UCase-Funktion
Siehe auch 		Sprachverzeichnis

LCase-Funktion


VarType-Funktion

VarType-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt einen Wert zurück, der den Untertyp einer Variablen angibt.
Syntax
VarType(VarName)

Das Argument VarName kann eine beliebige Variable sein.

Rückgabewerte
Die VarType-Funktion gibt die folgenden Werte zurück:

Konstante | Wert | Beschreibung
vbEmpty | 0 | Empty (nicht initialisiert)
vbNull | 1 | Null (ungültigeDaten)
vbInteger | 2 | Ganzzahl
vbLong | 3 | Long Integer
vbSingle | 4 | Fließkommazahl einfacher Genauigkeit
vbDouble | 5 | Fließkommazahl doppelter Genauigkeit
vbCurrency | 6 | Währung
vbDate | 7 | Datum
vbString | 8 | Zeichenfolge
vbObject | 9 | Automatisierungsobjekt
vbError | 10 | Fehler
vbBoolean | 11 | Boolesch
vbVariant | 12 | Variant (nur bei Datenfeldern mit Variant-Werten).
vbDataObject | 13 | Datenzugriffsobjekt
vbByte | 17 | Byte
vbArray | 8192 | Datenfeld

Anmerkung Diese Konstanten sind von VBScript festgelegt. Aus diesem Grund können die Namen in Ihrem Code an einer beliebigen Stelle statt der tatsächlichen Werte verwendet werden.

Hinweise
Die VarType-Funktion gibt niemals nur den Wert für das Datenfeld zurück. Der Wert wird immer zu einem anderen Wert addiert, um ein Datenfeld eines bestimmten Types anzugeben. Der Wert für den Datentyp Variant wird erst zurückgegeben, wenn es zum Wert für Datenfeld addiert wurde, um anzuzeigen, dass das Argument für die VarType-Funktion ein Datenfeld ist. Zum Beispiel wird der Wert, der für ein Datenfeld aus Ganzzahlen zurückgegeben wird, als 2 + 8192 oder 8194 angegeben. Wenn ein Objekt eine Standardeigenschaft hat, gibt VarType(Objekt) den Typ dieser Standardeigenschaft zurück.

Das folgende Beispiel verwendet die VarType-Funktion, um den Untertyp einer Variablen zu bestimmen.

Dim MeinTest
MeinTest = VarType(300)             ' Gibt 2 zurück.
MeinTest = VarType(#10/19/62#)      ' Gibt 7 zurück.
MeinTest = VarType("VBScript")      ' Gibt 8 zurück.


VarType-Funktion

VarType-Funktion
Siehe auch 		Sprachverzeichnis

IsArray-Funktion
IsDate-Funktion
IsEmpty-Funktion
IsNull-Funktion
IsNumeric-Funktion
IsObject-Funktion
TypeName-Funktion


Weekday-Funktion

Weekday-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt den Wochentag als ganze Zahl zurück.
Syntax
Weekday(Datum,[ErsterWochentag])

Die Syntax der Weekday-Funktion verwendet die folgenden Teile:

Teil | Beschreibung
Datum | Ein beliebiger Ausdruck , der ein Datum darstellen kann. Wenn Datum den Wert Null enthält, wird Null zurückgegeben.
ErsterWochentag | Eine Konstante, die den ersten Wochentag angibt. Wird kein Wert angegeben, wird vbSunday angenommen.

Einstellungen
Das Argument ErsterWochentag hat die folgenden Einstellungen:

Konstante | Wert | Beschreibung
vbUseSystem | 0 | Einstellung der NLS (National Language Support)-API verwenden.
vbSunday | 1 | Sonntag
vbMonday | 2 | Montag
vbTuesday | 3 | Dienstag
vbWednesday | 4 | Mittwoch
vbThursday | 5 | Donnerstag
vbFriday | 6 | Freitag
vbSaturday | 7 | Samstag

Rückgabewerte
Die Weekday-Funktion kann einen der folgenden Werte zurückgeben:

Konstante | Wert | Beschreibung
vbSunday | 1 | Sonntag
vbMonday | 2 | Montag
vbTuesday | 3 | Dienstag
vbWednesday | 4 | Mittwoch
vbThursday | 5 | Donnerstag
vbFriday | 6 | Freitag
vbSaturday | 7 | Samstag

Hinweise
Das folgende Beispiel zeigt die Verwendung der Weekday-Funktion, um den Wochentag eines gegebenen Datums anzufordern:
Dim MeinDatum, MeinWochenTag
MeinDatum = #5 April 1974#          ' Datum zuweisen.
MeinWochenTag = Weekday(MeinDatum)  ' MeinWochenTag enthält 6,
                                    ' da MeinDatum einen Freitag darstellt.


Weekday-Funktion

Weekday-Funktion
Siehe auch 		Sprachverzeichnis

Date-Funktion
Day-Funktion
Month-Funktion
Now-Funktion
Year-Funktion


WeekdayName-Funktion

WeekdayName-Funktion 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Gibt eine Zeichenfolge mit dem angegebenen Wochentag zurück.
Syntax
WeekDayName(Wochentag, Abkürzen, ErsterWochentag)

Die Syntax der WeekDayName-Funktion besteht aus folgenden Teilen:

Teil | Beschreibung
Wochentag | Erforderlich. Der numerische Wert für den Wochentag. Der numerische Wert für jeden Tag ist abhängig von der Einstellung für ErsterWochentag.
Abkürzen | Optional. Boolescher Wert, der angibt, ob der Name des Wochentags abgekürzt werden soll. Ohne weitere Angabe ist die Voreinstellung False, d. h. der Name des Wochentages wird nicht abgekürzt.
ErsterWochentag | Optional. Numerischer Wert, der den ersten Wochentag angibt. Gültige Werte sind im Abschnitt "Einstellungen" aufgeführt.

Einstellungen
Das Argument ErsterWochentag kann die folgenden Werte haben:

Konstante | Wert | Beschreibung
vbUseSystem | 0 | Einstellung der NLS (National Language Support)-API verwenden.
vbSunday | 1 | Sonntag (Standard)
vbMonday | 2 | Montag
vbTuesday | 3 | Dienstag
vbWednesday | 4 | Mittwoch
vbThursday | 5 | Donnerstag
vbFriday | 6 | Freitag
vbSaturday | 7 | Samstag

Hinweise
Das folgende Beispiel zeigt die Verwendung der WeekDayName-Funktion, um den angegebenen Tag zurückzugeben:
Dim MeinDatum
MeinDatum = WeekDayName(6, True)  ' MeinDatum enthält Fr.


WeekdayName-Funktion

WeekdayName-Funktion
Siehe auch 		Sprachverzeichnis

MonthName-Funktion


Year-Funktion

Year-Funktion 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Gibt das Jahr als ganze Zahl zurück.
Syntax
Year(Datum)

Das Argument Datum ist ein beliebiger Ausdruck, der ein Datum darstellen kann. Wenn Datum den Wert Null enthält, wird Null zurückgegeben.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Year-Funktion, um das Jahr eines gegebenen Datums anzufordern:
Dim MeinDatum, MeinJahr
MeinDatum = #19 Januar 1962#     ' Datum zuweisen.
MeinJahr = Year(MeinDatum)       ' MeinJahr enthält 1962.


Year-Funktion

Year-Funktion
Siehe auch 		Sprachverzeichnis

Date-Funktion
Day-Funktion
Month-Funktion
Now-Funktion
Weekday-Funktion


Vergleichsoperatoren

Vergleichsoperatoren 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Dienen zum Vergleichen von Ausdrücken.
Syntax
Ergebnis = Ausdruck1 Vergleichsoperator Ausdruck2

Ergebnis = Objekt1 Is Objekt2

Die Syntax der Vergleichsoperatoren besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Ausdruck | Beliebiger Ausdruck.
Vergleichsoperator | Beliebiger Vergleichsoperator.
Objekt | Beliebiger Objektname.

Hinweise
Der Operator Is hat eine spezielle Bedeutung und unterscheidet sich in der Funktionalität von den Operatoren in der folgenden Tabelle. Die Tabelle enthält eine Liste der Vergleichsoperatoren und die Bedingungen, unter denen das Ergebnis True, False oder Null wird:

Operator Beschreibung True, wenn False, wenn Null, wenn
< Kleiner als Ausdruck1 < Ausdruck2 Ausdruck1 >= Ausdruck 2 Ausdruck1 oder Ausdruck2 = Null
<= Kleiner oder gleich Ausdruck1 <= Ausdruck 2 Ausdruck1 > Ausdruck2 Ausdruck1 oder Ausdruck2 = Null
> Größer als Ausdruck1 > Ausdruck2 Ausdruck1 <= Ausdruck 2 Ausdruck1 oder Ausdruck2 = Null
>= Größer oder gleich Ausdruck1 >= Ausdruck 2 Ausdruck1 < Ausdruck2 Ausdruck1 oder Ausdruck2 = Null
= Gleich Ausdruck1 = Ausdruck 2 Ausdruck1 <> Ausdruck2 Ausdruck1 oder Ausdruck2 = Null
<> Ungleich Ausdruck1 <> Ausdruck2 Ausdruck1 = Ausdruck 2 Ausdruck1 oder Ausdruck2 = Null

Beim Vergleich zweier Ausdrücke ist nicht immer offensichtlich, ob die Ausdrücke als Zahlen oder als Zeichenfolgen verglichen werden.

Aus der folgenden Tabelle können Sie ersehen, wie abhängig vom zugrunde liegenden Untertyp Ausdrücke verglichen werden bzw. wie das Ergebnis aussieht:

Wenn | Dann
Beide Ausdrücke numerisch sind | Numerischer Vergleich.
Beide Ausdrücke Zeichenfolgen sind | Durchführung eines Zeichenfolgenvergleichs.
Ein Ausdruck numerisch ist, der andere eine Zeichenfolge | Ist der numerische Ausdruck kleiner als der Zeichenfolgenausdruck.
Ein Ausdruck den Wert Empty hat, und der andere numerisch ist | Numerischer Vergleich, wobei 0 für den Empty-Ausdruck verwendet wird.
Ein Ausdruck den Wert Empty hat, der andere eine Zeichenfolge ist | Zeichenfolgenvergleich, wobei eine Nullzeichenfolge ("") für den Empty-Ausdruck verwendet wird.
Beide Ausdrücke den Wert Empty haben | Sind die Ausdrücke gleich.


Vergleichsoperatoren

Vergleichsoperatoren
Siehe auch 		Sprachverzeichnis

Is-Operator
Operatoren: Zusammenfassung
Operatorvorrang
Zuweisungsoperator (=)


Abgeleitete mathematische Funktionen

Abgeleitete mathematische Funktionen 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Im Folgenden werden die nicht integrierten mathematischen Funktionen aufgelistet, die von den integrierten mathematischen Funktionen abgeleitet werden können:

Funktion | Abgeleitete äquivalente Funktionen
Sekans | Sec(X) = 1 / Cos(X)
Kosekans | Cosec(X) = 1 / Sin(X)
Kotangens | Cotan(X) = 1 / Tan(X)
Arkussinus | Arcsin(X) = Atn(X / Sqr(-X * X + 1))
Arkuskosinus | Arccos(X) = Atn(-X / Sqr(-X * X + 1)) + 2 * Atn(1)
Arkussekans | Arcsec(X) = Atn(X / Sqr(X * X - 1)) +Sgn((X) - 1) *(2 * Atn(1))
Arkuskosekans | Arccosec(X) =Atn(X / Sqr(X * X - 1)) + (Sgn(X) - 1) * (2 * Atn(1))
Arkuskotangens | Arccotan(X) = Atn(X) + 2 * Atn(1)
Sinus Hyperbol. | HSin(X) = (Exp(X) - Exp(-X)) / 2
Kosinus Hyperbol. | HCos(X) = (Exp(X) + Exp(-X)) / 2
Tangens Hyperbol. | HTan(X) = (Exp(X) - Exp(-X)) / (Exp(X) +Exp(-X))
Sekans Hyperbol. | HSec(X) = 2 / (Exp(X) + Exp(-X))
Kosekans Hyperbol. | HCosec(X) = 2 /(Exp(X) - Exp(-X))
Kotangens Hyperbol. | HCotan(X) = (Exp(X) + Exp(-X)) / (Exp(X) - Exp(-X))
Arkussinus Hyperbol. | HArcsin(X) = Log(X + Sqr(X * X + 1))
Arkuskosinus Hyperbol. | HArccos(X) = Log(X + Sqr(X * X - 1))
Arkustangens Hyperbol. | HArctan(X) = Log((1 + X)/ (1 - X)) / 2
Arkussekans Hyperbol. | HArcsec(X) =Log((Sqr(-X * X + 1) + 1) / X)
Arkuskosekans Hyperbol. | HArccosec(X) = Log((Sgn(X) * Sqr(X * X + 1) +1) / X)
Arkuskotangens Hyperbol. | HArccotan(X) = Log((X + 1) / (X - 1)) / 2
Logarithmus zur Basis N | LogN(X) = Log(X) / Log(N)


Abgeleitete mathematische Funktionen

Abgeleitete mathematische Funktionen
Siehe auch 		Sprachverzeichnis

Atn-Funktion
Cos-Funktion
Exp-Funktion
Log-Funktion
Sin-Funktion
Sqr-Funktion
Tan-Funktion


VBScript-Funktionen

VBScript-Funktionen 		Sprachverzeichnis

Kategorie | Schlüsselwörter
Ablaufsteuerung Do...Loop
For Each...Next
For...Next
If...Then...Else
Select Case
While...Wend
With
Ausdrücke Eval
Execute
RegExp
Replace
Test
Datums-/Zeitangaben Date, Time
DateAdd, DateDiff, DatePart
DateSerial, DateValue
Day, Month, MonthName
Weekday, WeekdayName, Year
Hour, Minute, Second
Now
TimeSerial, TimeValue
Deklaration Class
Const
Dim, Private, Public, ReDim
Function, Sub
Property Get, Property Let, Property Set
Eingabe/Ausgabe InputBox
LoadPicture
MsgBox
Fehlersuche On Error
Err
Handhabung von Datenfeldern Array
Dim, Private, Public, ReDim
IsArray
Erase
LBound, UBound
Kommentare | Kommentare mit ' oder Rem
Konstanten/Literale Empty
Nothing
Null
True, False
Konvertierung Abs
Asc, AscB, AscW
Chr, ChrB, ChrW
CBool, CByte
CCur, CDate
CDbl, CInt
CLng, CSng, CStr
DateSerial, DateValue
Hex, Oct
Fix, Int
Sgn
TimeSerial, TimeValue
Literalwerte Empty
False
Nothing
Null
True
Mathematik Atn, Cos, Sin, Tan
Exp, Log, Sqr
Randomize, Rnd
Objekte CreateObject
Err-Objekt
GetObject
RegExp
Operatoren Addition (+), Subtraktion (-)
Potenzierung (^)
Modulo (Mod)
Multiplikation (*), Division (/)
Ganzzahl-Division (\)
Negation (-)
Zeichenfolgenverkettung (&)
Gleichheit (=), Ungleichheit (<>)
Kleiner als (<), Kleiner oder gleich (<=)
Größer als (>)
Größer oder gleich (>=)
Is
And, Or, Xor
Eqv, Imp
Optionen | Option Explicit
Prozeduren Call
Function, Sub
Property Get, Property Let, Property Set
Rundung Abs
Int, Fix, Round
Sgn
Skriptmodul-ID ScriptEngine
ScriptEngineBuildVersion
ScriptEngineMajorVersion
ScriptEngineMinorVersion
Sonstige Eval-Funktion
Execute-Anweisung
RGB-Funktion
Variant IsArray
IsDate
IsEmpty
IsNull
IsNumeric
IsObject
TypeName
VarType
Zeichenfolgen Asc, AscB, AscW
Chr, ChrB, ChrW
Filter, InStr, InStrB
InStrRev
Join
Len, LenB
LCase, UCase
Left, LeftB
Mid, MidB
Right, RightB
Replace
Space
Split
StrComp
String
StrReverse
LTrim, RTrim, Trim
Zeichenfolgenformatierung FormatCurrency
FormatDateTime
FormatNumber
FormatPercent
Zuweisung | Set


Nicht in VBScript enthaltene Visual Basic für Applikationen-Funktionen

Nicht in VBScript enthaltene Visual Basic für Applikationen-Funktionen 		Sprachverzeichnis

Kategorie | Funktion/Schlüsselwort nicht verfügbar
Ablaufsteuerung DoEvents
GoSub...Return, GoTo
On Error GoTo
On...GoSub, On...GoTo
Zeilennummern, Zeilenmarken
Auflistung Add, Count, Item, Remove
Zugriff auf Auflistungen unter Verwendung von Ausrufezeichen (!) (z. B., MeineAuflistung!Foo)
Bedingte Kompilierung #Const
#If...Then...#Else
Dateieingabe/-ausgabe | Alle in Basic üblichen Dateiein- und -ausgaben
Datentypen Alle integrierten Datentypen außer Variant
Type...End Type
Datums-/Zeitangaben | Date-Anweisung, Time-Anweisung
DDE | LinkExecute, LinkPoke, LinkRequest, LinkSend
Deklaration Declare (zum Deklarieren von DLLs)
Optional
ParamArray
Static
Fehlerbehandlung Erl
Error
Resume, Resume Next
Fehlersuche Debug.Print
End, Stop
Finanziell | Alle finanziellen Funktionen
Handhabung von Datenfeldern Option Base
Deklarieren von Datenfeldern mit Untergrenzen <> 0
Konvertierung CVar, CVDate
Str, Val
Objektbearbeitung | TypeOf
Objekte Clipboard
Collection
Operatoren | Like
Optionen Deftype
Option Base
Option Compare
Option Private Module
Select Case Ausdrücke, die das Is-Schlüsselwort oder einen oder mehrere Vergleichsoperatoren enthalten.
Ausdrücke, die einen bestimmten Wertebereich unter Verwendung des To-Schlüsselworts enthalten.
Verwendung von Objekten | Zugriff auf Auflistungen mittels Ausrufezeichen (!)
Zeichenfolgen Zeichenfolgen mit fester Länge
LSet, RSet
Mid-Anweisung
StrConv


Operatorvorrang

Operatorvorrang 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Treten mehrere Operatoren in einem Ausdruck auf, wird jeder Teil in einer vorbestimmten Reihenfolge ausgewertet und aufgelöst. Diese wird als Operatorvorrang bezeichnet. Sie können den Operatorvorrang mit Klammern übergehen und die Auswertung von Bestandteilen eines Ausdruckes vor anderen Bestandteilen erzwingen. Operationen innerhalb von Klammern werden immer vor Operationen außerhalb von Klammern ausgeführt. Innerhalb der Klammern gilt jedoch der normale Operatorvorrang.

Wenn Ausdrücke Operatoren aus verschiedenen Kategorien enthalten, werden zuerst arithmetische, dann Vergleichs- und schließlich logische Operatoren ausgewertet. Vergleichsoperatoren haben alle denselben Rang, d. h. sie werden von links nach rechts in der Reihenfolge ihres Erscheinens ausgewertet. Arithmetische und logische Operatoren werden nach der folgenden Rangfolge ausgewertet:

Arithmetisch | Vergleich | Logisch
Potenzieren (^) | Gleich (=) | Not
Negation (-) | Ungleich (<>) | And
Multiplikation und Division (*, /) | Kleiner als (<) | Or
Ganzzahl-Division (\) | Größer als (>) | Xor
Modulo (Mod) | Kleiner oder gleich (<=) | Eqv
Addition und Subtraktion (+, -) | Größer oder gleich (>=) | Imp
Zeichenfolgenverkettung (&) Is &

Treten Multiplikation und Division zusammen in einem Ausdruck auf, wird jede Operation entsprechend ihres Auftretens von links nach rechts ausgewertet. Desgleichen wird beim Auftreten von Addition und Subtraktion in einem Ausdruck jede Operation entsprechend ihrem Auftreten von links nach rechts ausgewertet.

Der Operator zur Zeichenfolgenverkettung (&) ist kein arithmetischer Operator, er liegt in der Rangfolge jedoch hinter den arithmetischen und vor den Vergleichsoperatoren. Der Operator Is ist ein Vergleichsoperator für Objektverweise. Er vergleicht weder Objekte noch deren Werte, sondern prüft lediglich, ob zwei Objektverweise auf dasselbe Objekt verweisen.


Operatorvorrang

Operatorvorrang
Siehe auch 		Sprachverzeichnis

Is-Operator
Operatoren: Zusammenfassung


Operatoren: Zusammenfassung

Operatoren: Zusammenfassung 		Sprachverzeichnis
Version 1

Siehe auch

Arithmetische Operatoren
Operatoren zum Ausführen von mathematischen Berechnungen.
Logische Operatoren
Operatoren zum Ausführen von logischen Operationen.
Vergleichsoperatoren
Operatoren zum Durchführen von Vergleichen.
Verkettungsoperatoren
Operatoren zum Kombinieren von Zeichenfolgen.
Zuweisungsoperator
Operator für die Zuweisung eines Wertes zu einer Eigenschaft oder Variablen.


Operatoren: Zusammenfassung

Operatoren: Zusammenfassung
Siehe auch 		Sprachverzeichnis

Operatorvorrang


Merkmale der Microsoft Scripting-Laufzeitbibliothek

Merkmale der
Microsoft Scripting-Laufzeitbibliothek 		Sprachverzeichnis

Kategorie Funktion/Schlüsselwort
Auflistungen Drives
Files
Folders
Datenspeicherung Dictionary
Dictionary Add
Exists
Items, Keys
Remove, RemoveAll
Count
Item, Key
Dateisystem Drive
File
FileSystemObject
Folder
TextStream
FileSystemObject-Objekt BuildPath
CopyFile, CopyFolder
CreateFolder,CreateTextFile
DeleteFile,DeleteFolder
DriveExists, FileExists, FolderExists
GetAbsolutePathName, GetBaseName
GetDrive, GetDriveName
GetExtensionName, GetFile, GetFileName
GetFolder, GetParentFolderName
GetSpecialFolder
GetTempName
MoveFile, MoveFolder
OpenTextFile
Drives
Drive-Objekt, Drives-Auflistung AvailableSpace
Count
DriveLetter
DriveType
FileSystem
FreeSpace
IsReady
Item
RootFolder
SerialNumber
ShareName
TotalSize
VolumeName
File-Objekt, Files-Auflistung
Folder-Objekt, Folders-Auflistung 		Add
Attributes
Copy, Delete, Move
Count
OpenAsTextStream
DateCreated, DateLastAccessed, DateLastModified
Drive
Item
ParentFolder
Name, Path
ShortName, ShortPath
Size
TextStream-Objekt Close
Read, ReadAll, ReadLine
Skip, SkipLine
Write, WriteBlankLines, WriteLine
AtEndOfLine, AtEndOfStream
Column, Line


VBScript-Funktionen, die nicht in Visual Basic für Applikationen verfügbar sind

VBScript-Funktionen, die nicht in Visual Basic für Applikationen verfügbar sind 		Sprachverzeichnis

Kategorie | Funktion/Schlüsselwort
Deklarationen | Class
Objekte | RegExp
Skriptmodul-Identifikation ScriptEngine
ScriptEngineBuildVersion
ScriptEngineMajorVersion
ScriptEngineMinorVersion
Sonstiges Eval
Execute


Arithmetische Operatoren

Arithmetische Operatoren 		Sprachverzeichnis
Version 1

Additionsoperator (+)
Divisionsoperator (/)
Exponentialoperator (^)
Ganzzahl-Divisionsoperator (\)
Minusoperator (-)
Mod-Operator
Multiplikationsoperator (*)
Verkettungsoperatoren


Zuweisungsoperator

Zuweisungsoperator 		Sprachverzeichnis
Version 1

Zuweisungsoperator (=)


Verkettungsoperatoren

Verkettungsoperatoren 		Sprachverzeichnis
Version 1

Additionsoperator (+)
Verkettungsoperator (&)


Konvertierungsfunktionen

Konvertierungsfunktionen 		Sprachverzeichnis
Version 1

Asc-Funktion
CBool-Funktion
CByte-Funktion
CCur-Funktion
CDate-Funktion
CDbl-Funktion
Chr-Funktion
CInt-Funktion
CLng-Funktion
CSng-Funktion
CStr-Funktion
Hex-Funktion
Oct-Funktion


VBScript-Fehlermeldungen

VBScript-Fehlermeldungen 		Sprachverzeichnis

Fehlercode | Meldung
5 | Ungültiger Prozeduraufruf oder ungültiges Argument
6 | Überlauf
7 | Nicht genügend Speicher
9 | Index außerhalb des gültigen Bereichs
10 | Datenfeld ist unveränderlich oder momentan gesperrt
11 | Division durch Null
13 | Typen unverträglich
14 | Nicht genügend Zeichenfolgenspeicher
28 | Nicht genügend Stapelspeicher
35 | Sub- oder Function-Prozedur nicht definiert
48 | Fehler beim Laden einer DLL
51 | Interner Fehler
53 | Datei nicht gefunden
57 | Fehler beim Lesen von/Schreiben auf Gerät
58 | Datei existiert bereits
61 | Datenträger voll
67 | Zu viele Dateien
70 | Zugriff verweigert
75 | Fehler beim Zugriff auf Pfad/Datei
76 | Pfad nicht gefunden
91 | Objektvariable nicht gesetzt
92 | For-Schleife nicht initialisiert
94 | Unzulässige Verwendung von Null
322 | Erforderliche temporäre Datei kann nicht angelegt werden
424 | Objekt erforderlich
429 | ActiveX-Komponente kann kein Objekt erstellen
430 | Klasse unterstützt keine Automatisierung
432 | Datei- oder Klassenname während der Automatisierungsoperation nicht gefunden
438 | Objekt unterstützt diese Eigenschaft oder Methode nicht
440 | Automatisierungsfehler
445 | Objekt unterstützt diese Aktion nicht
446 | Objekt unterstützt keine benannten Argumente
447 | Objekt unterstützt die aktuelle Ländereinstellung nicht
448 | Benanntes Argument nicht gefunden
449 | Argument ist nicht optional
450 | Falsche Anzahl an Argumenten oder ungültige Eigenschaftszuweisung
451 | Objekt ist keine Auflistung
453 | Angegebene DLL-Funktion nicht gefunden
455 | Fehler durch gesperrte Coderessource
457 | Dieser Schlüssel ist bereits einem Element dieser Auflistung zugeordnet
458 | Die Variable verwendet einen Automatisierungstyp, der in VBScript nicht unterstützt wird
500 | Variable ist nicht definiert
501 | Ungültige Zuweisung
502 | Objekt nicht sicher für Skriptverarbeitung
503 | Objekt nicht sicher für Initialisierung
1001 | Nicht genügend Speicher
1002 | Syntaxfehler
1003 | ':' erwartet
1004 | ';' erwartet
1005 | '(' erwartet
1006 | ')' erwartet
1007 | ']' erwartet
1008 | '{' erwartet
1009 | '}' erwartet
1010 | Bezeichner erwartet
1011 | '=' erwartet
1012 | 'If' erwartet
1013 | 'To' erwartet
1014 | 'End' erwartet
1015 | 'Function' erwartet
1016 | 'Sub' erwartet
1017 | 'Then' erwartet
1018 | 'Wend' erwartet
1019 | 'Loop' erwartet
1020 | 'Next' erwartet
1021 | 'Case' erwartet
1022 | 'Select' erwartet
1023 | Ausdruck erwartet
1024 | Anweisung erwartet
1025 | Anweisungsende erwartet
1026 | Ganzzahlige Konstante erwartet
1027 | 'While' oder 'Until' erwartet
1028 | 'While', 'Until' oder Anweisungsende erwartet
1029 | 'With' erwartet
1030 | Bezeichner zu lang
1031 | Ungültige Zahl
1032 | Ungültiges Zeichen
1033 | Nichtabgeschlossene Zeichenfolgenkonstante
1034 | Nichtabgeschlossener Kommentar
1035 | Verschachtelter Kommentar
1037 | Ungültige Verwendung des Schlüsselwortes 'Me'
1038 | 'Loop' ohne 'Do'
1039 | Ungültige 'Exit'-Anweisung
1040 | Ungültige Steuervariable für 'For'-Schleife
1041 | Name erneut definiert
1042 | Muss die erste Anweisung in der Zeile sein
1043 | Zuweisung nur an ByVal-Argument möglich
1044 | Beim Aufrufen einer Unterroutine dürfen keine Klammern verwendet werden
1045 | Literalkonstante erwartet
1046 | 'In' erwartet
32766 | Wahr
32767 | Falsch
32811 | Element nicht gefunden


Logische Operatoren

Logische Operatoren 		Sprachverzeichnis
Version 1

And-Operator
Eqv-Operator
Imp-Operator
Not-Operator
Or-Operator
Xor-Operator


Mathematische Funktionen

Mathematische Funktionen 		Sprachverzeichnis
Version 1

Abgeleitete mathematische Funktionen
Abs-Funktion
Atn-Funktion
Cos-Funktion
Exp-Funktion
Fix-Funktion
Int-Funktion
Log-Funktion
Rnd-Funktion
Sgn-Funktion
Sin-Funktion
Sqr-Funktion
Tan-Funktion


Empty

Empty 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Mit dem Schlüsselwort Empty wird ein nicht initialisierter Variablenwert angegeben. Dies ist jedoch nicht dasselbe wie Null.


False

False 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Das Schlüsselwort False hat einen Wert von 0.


Nothing

Nothing 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Das Schlüsselwort Nothing wird in VBScript verwendet, um eine Objektvariable von jedem tatsächlichen Objekt zu trennen. Sie können mit der Set-Anweisung einer Objektvariablen den Wert Nothing zuweisen. Zum Beispiel:
Set MeinObjekt = Nothing
Mehrere Objektvariablen können auf dasselbe Objekt verweisen. Wird Nothing einer Objektvariablen zugewiesen, verweist diese Variable nicht länger auf ein tatsächliches Objekt. Verweisen mehrere Objektvariablen auf dasselbe Objekt, werden mit diesem Objekt über die zugehörigen Variablen zugewiesene Speicher- und Systemressourcen nur freigegeben, nachdem all diese auf Nothing gesetzt wurden; dies wird entweder explizit über Set realisiert oder implizit, nachdem die letzte auf Nothing gesetzte Objektvariable aus dem Gültigkeitsbereich fällt.


Nothing

Nothing
Siehe auch 		Sprachverzeichnis

Dim-Anweisung
Set-Anweisung


Null

Null 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Das Schlüsselwort Null wird verwendet, um anzugeben, dass eine Variable keine gültigen Daten enthält. Dies ist jedoch nicht dasselbe wie Empty.


True

True 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Das Schlüsselwort True hat einen Wert von -1.


Zeichensatz (0 - 127)

Zeichensatz (0 - 127) 		Sprachverzeichnis
Version 1

Zeichensatz (128 - 255)

Code Zeichen Code Zeichen Code Zeichen Code Zeichen
0 32 [Leer] 64 @ 96 `
1  33 ! 65 A 97 a
2  34 " 66 B 98 b
3  35 # 67 C 99 c
4  36 $ 68 D 100 d
5  37 % 69 E 101 e
6  38 & 70 F 102 f
7  39 ' 71 G 103 g
8 ** 40 ( 72 H 104 h
9 ** 41 ) 73 I 105 i
10 ** 42 * 74 J 106 j
11 43 + 75 K 107 k
12 44 , 76 L 108 l
13 ** 45 - 77 M 109 m
14  46 . 78 N 110 n
15  47 / 79 O 111 o
16  48 0 80 P 112 p
17  49 1 81 Q 113 q
18  50 2 82 R 114 r
19  51 3 83 S 115 s
20  52 4 84 T 116 t
21  53 5 85 U 117 u
22  54 6 86 V 118 v
23  55 7 87 W 119 w
24  56 8 88 X 120 x
25  57 9 89 Y 121 y
26  58 : 90 Z 122 z
27  59 ; 91 [ 123 {
28  60 < 92 \ 124 |

29  61 = 93 ] 125 }
30  62 > 94 ^ 126 ~
31  63 ? 95 _ 127 
** Die Werte 8, 9, 10 und 13 werden zu Rücktasten-, Tabulator-, Zeilenvorschub- bzw. Wagenrücklaufzeichen konvertiert. Sie können grafisch zwar nicht dargestellt werden, haben jedoch, je nach verwendeter Anwendung, Auswirkungen auf die visuelle Darstellung von Text.

 Werden auf diesem System nicht unterstützt.


Zeichensatz (128 - 255)

Zeichensatz (128 - 255) 		Sprachverzeichnis
Version 1

Zeichensatz (0 - 127)

Code | Zeichen | Code | Zeichen | Code | Zeichen | Code | Zeichen
128 € 160 [Leer] 192 À 224 à
129  161 ¡ 193 À 225 á
130 ‚ 162 ¢ 194 Â 226 â
131 ƒ 163 £ 195 Ã 227 ã
132 „ 164 ¤ 196 Ä 228 ä
133 … 165 ¥ 197 Å 229 å
134 † 166 ¦ 198 Æ 230 æ
135 ‡ 167 § 199 Ç 231 ç
136 ˆ 168 ¨ 200 È 231 è
137 ‰ 169 © 201 É 233 é
138 | Š | 170 | ª | 202 | Ê | 234 | ê
139 ‹ 171 « 203 Ë 235 ë
140 Œ 172 ¬ 204 Ì 236 ì
141  173 205 Í 237 í
142 Ž 174 ® 206 Î 238 î
143  175 ¯ 207 Ï 239 ï
144  176 ° 208 Ð 240 ð
145 ‘ 177 ± 209 Ñ 241 ñ
146 ’ 178 ² 210 Ò 242 ò
147 “ 179 ³ 211 Ó 243 ó
148 ” 180 ´ 212 Ô 244 ô
149 • 181 µ 213 Õ 245 õ
150 – 182 ¶ 214 Ö 246 ö
151 — 183 · 215 × 247 ÷
152 ˜ 184 ¸ 216 Ø 248 ø
153 ™ 185 ¹ 217 Ù 249 ù
154 | š | 186 | º | 218 | Ú | 250 | ú
155 › 187 » 219 Û 251 û
156 | œ | 188 | ¼ | 220 | Ü | 252 | ü
157  189 ½ 221 Ý 253 ý
158 | ž | 190 | ¾ | 222 | Þ | 254 | þ
159 Ÿ 191 ¿ 223 ß 255 ÿ
 Werden auf diesem System nicht unterstützt.


Gebietsschema-ID (LCID)-Diagramm

Gebietsschema-ID (LCID)-Diagramm 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung des Gebietsschemas | Kurzzeichenfolge | Hexadezimalwert | Dezimalwert | Beschreibung des Gebietsschemas | Kurzzeichenfolge | Hexadezimalwert | Dezimalwert
Afrikaans | af | 0x0436 | 1078 | Japanisch | ja | 0x0411 | 1041
Albanisch | sq | 0x041C | 1052 | Jiddisch | ji | 0x043D | 1085
Arabisch - Ägypten | ar-eg | 0x0C01 | 3073 | Katalanisch | ca | 0x0403 | 1027
Arabisch - Algerien | ar-dz | 0x1401 | 5121 | Koreanisch | ko | 0x0412 | 1042
Arabisch - Bahrain | ar-bh | 0x3C01 | 15361 | Kroatisch | hr | 0x041A | 1050
Arabisch - Irak | ar-iq | 0x0801 | 2049 | Lettisch | lv | 0x0426 | 1062
Arabisch - Jemen | ar-ye | 0x2401 | 9217 | Litauisch | lt | 0x0427 | 1063
Arabisch - Jordanien | ar-jo | 0x2C01 | 11265 | Malaiisch - Malaysia | ms | 0x043E | 1086
Arabisch - Kuwait | ar-kw | 0x3401 | 13313 | Maltesisch | mt | 0x043A | 1082
Arabisch - Libanon | ar-lb | 0x3001 | 12289 | Mazedonisch | mk | 0x042F | 1071
Arabisch - Libyen | ar-ly | 0x1001 | 4097 | Niederländisch | nl | 0x0413 | 1043
Arabisch - Marokko | ar-ma | 0x1801 | 6145 | Niederländisch - Belgien | nl-be | 0x0813 | 2067
Arabisch - Oman | ar-om | 0x2001 | 8193 | Norwegisch - Bokmål | no | 0x0414 | 1044
Arabisch - Qatar | ar-qa | 0x4001 | 16385 | Polnisch | pl | 0x0415 | 1045
Arabisch - Saudi-Arabien | ar-sa | 0x0401 | 1025 | Portugiesisch - Brasilien | pt-br | 0x0416 | 1046
Arabisch - Syrien | ar-sy | 0x2801 | 10241 | Portugiesisch - Standard | pt | 0x0816 | 2070
Arabisch - Tunesien | ar-tn | 0x1C01 | 7169 | Rätoromanisch | rm | 0x0417 | 1047
Arabisch - V.A.E. | ar-ae | 0x3801 | 14337 | Rumänisch | ro | 0x0418 | 1048
Baskisch | eu | 0x042D | 1069 | Rumänisch - Moldawien | ro-mo | 0x0818 | 2072
Bulgarisch | bg | 0x0402 | 1026 | Russisch | ru | 0x0419 | 1049
Chinesisch | zh | 0x0004 | 4 | Russisch - Moldawien | ru-mo | 0x0819 | 2073
Chinesisch - Hongkong | zh-hk | 0x0C04 | 3076 | Schwedisch | sv | 0x041D | 1053
Chinesisch - Singapur | zh-sg | 0x1004 | 4100 | Schwedisch - Finnland | sv-fi | 0x081D | 2077
Chinesisch - Taiwan | zh-tw | 0x0404 | 1028 | Serbisch - Kyrillisch | sr | 0x0C1A | 3098
Chinesisch - VRC | zh-cn | 0x0804 | 2052 | Setschuan | tn | 0x0432 | 1074
Dänisch | da | 0x0406 | 1030 | Slowakisch | sk | 0x041B | 1051
Deutsch - Liechtenstein | de-li | 0x1407 | 5127 | Slowenisch | sl | 0x0424 | 1060
Deutsch - Luxemburg | de-lu | 0x1007 | 4103 | Sorbisch | sb | 0x042E | 1070
Deutsch - Österreich | de-at | 0x0C07 | 3079 | Spanisch - Argentinien | es-ar | 0x2C0A | 11274
Deutsch - Schweiz | de-ch | 0x0807 | 2055 | Spanisch - Bolivien | es-bo | 0x400A | 16394
Deutsch - Standard | de | 0x0407 | 1031 | Spanisch - Chile | es-cl | 0x340A | 13322
Englisch | en | 0x0009 | 9 | Spanisch - Costa Rica | es-cr | 0x140A | 5130
Englisch - Australien | en-au | 0x0C09 | 3081 | Spanisch - Dominikanische Republik | es-do | 0x1C0A | 7178
Englisch - Belize | en-bz | 0x2809 | 10249 | Spanisch - Ecuador | es-ec | 0x300A | 12298
Englisch - Großbritannien | en-gb | 0x0809 | 2057 | Spanisch - El Salvador | es-sv | 0x440A | 17418
Englisch - Irland | en-ie | 0x1809 | 6153 | Spanisch - Guatemala | es-gt | 0x100A | 4106
Englisch - Jamaika | en-jm | 0x2009 | 8201 | Spanisch - Honduras | es-hn | 0x480A | 18442
Englisch - Kanada | en-ca | 0x1009 | 4105 | Spanisch - Kolumbien | es-co | 0x240A | 9226
Englisch - Neuseeland | en-nz | 0x1409 | 5129 | Spanisch - Mexiko | es-mx | 0x080A | 2058
Englisch - Südafrika | en-za | 0x1C09 | 7177 | Spanisch - Nicaragua | es-ni | 0x4C0A | 19466
Englisch - Trinidad | en-tt | 0x2C09 | 11273 | Spanisch - Panama | es-pa | 0x180A | 6154
Englisch - USA | en-us | 0x0409 | 1033 | Spanisch - Paraguay | es-py | 0x3C0A | 15370
Estnisch | et | 0x0425 | 1061 | Spanisch - Peru | es-pe | 0x280A | 10250
Färöisch | fo | 0x0438 | 1080 | Spanisch - Puerto Rico | es-pr | 0x500A | 20490
Farsi | fa | 0x0429 | 1065 | Spanisch - Standard | es | 0x040A | 1034
Finnisch | fi | 0x040B | 1035 | Spanisch - Uruguay | es-uy | 0x380A | 14346
Französisch - Belgien | fr-be | 0x080C | 2060 | Spanisch - Venezuela | es-ve | 0x200A | 8202
Französisch - Kanada | fr-ca | 0x0C0C | 3084 | Sutu | sx | 0x0430 | 1072
Französisch - Luxemburg | fr-lu | 0x140C | 5132 | Thai | th | 0x041E | 1054
Französisch - Schweiz | fr-ch | 0x100C | 4108 | Tschechisch | cs | 0x0405 | 1029
Französisch - Standard | fr | 0x040C | 1036 | Tsonga | ts | 0x0431 | 1073
Gälisch - Schottland | gd | 0x043C | 1084 | Türkisch | tr | 0x041F | 1055
Griechisch | el | 0x0408 | 1032 | Ukrainisch | uk | 0x0422 | 1058
Hebräisch | he | 0x040D | 1037 | Ungarisch | hu | 0x040E | 1038
Hindi | hi | 0x0439 | 1081 | Urdu - Pakistan | ur | 0x0420 | 1056
Indonesisch | in | 0x0421 | 1057 | Vietnamesisch | vi | 0x042A | 1066
Isländisch | is | 0x040F | 1039 | Weißrussisch | be | 0x0423 | 1059
Italienisch - Schweiz | it-ch | 0x0810 | 2064 | Xhosa | xh | 0x0434 | 1076
Italienisch - Standard | it | 0x0410 | 1040 | Zulu | zu | 0x0435 | 1077


Gebietsschema-ID (LCID)-Diagramm

Gebietsschema-ID (LCID)-Diagramm
Siehe auch 		Sprachverzeichnis

GetLocale-Funktion
SetLocale-Funktion


VBScript-Laufzeitfehler

VBScript-Laufzeitfehler 		Sprachverzeichnis
Version 1

VBScript-Syntaxfehler

Fehlernummer | Beschreibung
5 | Ungültiger Prozeduraufruf oder ungültiges Argument
6 | Überlauf
7 | Nicht genügend Speicher
9 | Index außerhalb des gültigen Bereichs
10 | Datenfeld ist unveränderlich oder momentan gesperrt
11 | Division durch Null
13 | Typen unverträglich
14 | Nicht genügend Zeichenfolgenspeicher
17 | Angeforderte Operation kann nicht durchgeführt werden
28 | Nicht genügend Stapelspeicher
35 | Sub- oder Function-Prozedur nicht definiert
48 | Fehler beim Laden einer DLL
51 | Interner Fehler
52 | Fehlerhafte(r) Dateiname oder -nummer
53 | Datei nicht gefunden
54 | Fehlerhafter Dateimodus
55 | Datei ist bereits geöffnet
57 | Fehler beim Lesen von/Schreiben auf Gerät
58 | Datei existiert bereits
61 | Datenträger voll
62 | Eingabe überschreitet Dateiende
67 | Zu viele Dateien
68 | Gerät nicht verfügbar
70 | Zugriff verweigert
71 | Datenträger nicht bereit
74 | Umbenennen bei Angabe unterschiedlicher Laufwerke nicht möglich
75 | Fehler beim Zugriff auf Pfad/Datei
76 | Pfad nicht gefunden
91 | Objektvariable nicht gesetzt
92 | For-Schleife nicht initialisiert
94 | Unzulässige Verwendung von Null
322 | Erforderliche temporäre Datei kann nicht angelegt werden
424 | Objekt erforderlich
429 | ActiveX-Komponente kann kein Objekt erstellen
430 | Klasse unterstützt keine Automatisierung
432 | Datei- oder Klassenname während der Automatisierungsoperation nicht gefunden
438 | Objekt unterstützt diese Eigenschaft oder Methode nicht
440 | Automatisierungsfehler
445 | Objekt unterstützt diese Aktion nicht
446 | Objekt unterstützt keine benannten Argumente
447 | Objekt unterstützt die aktuelle Ländereinstellung nicht
448 | Benanntes Argument nicht gefunden
449 | Argument ist nicht optional
450 | Falsche Anzahl an Argumenten oder ungültige Eigenschaftszuweisung
451 | Objekt ist keine Auflistung
453 | Angegebene DLL-Funktion nicht gefunden
455 | Fehler durch gesperrte Coderessource
458 | Die Variable verwendet einen Automatisierungstyp, der von VBScript nicht unterstützt wird
462 | Der Remote-Server-Computer existiert nicht oder ist nicht verfügbar.
481 | Ungültiges Bild
500 | Variable ist nicht definiert
501 | Ungültige Zuweisung
502 | Objekt nicht sicher für Skriptverarbeitung
503 | Objekt nicht sicher für Initialisierung
504 | Objekt nicht sicher für Erstellung
505 | Unzulässiger oder nicht ausreichend definierter Verweis
506 | Klasse nicht definiert
507 | Schwerwiegender Ausnahmefehler aufgetreten
5016 | Regulärer Ausdruck als Objekt erwartet
5017 | Syntaxfehler in regulärem Ausdruck
5018 | Unerwarteter Quantifier
5019 | Erwartet ']' in regulärem Ausdruck
5020 | Erwartet ')' in regulärem Ausdruck
5021 | Ungültiger Bereich in Zeichensatz
32811 | Element nicht gefunden


VBScript-Syntaxfehler

VBScript-Syntaxfehler 		Sprachverzeichnis
Version 1

VBScript-Laufzeitfehler

Fehlernummer | Beschreibung
1001 | Nicht genügend Speicher
1002 | Syntaxfehler
1003 | ':' erwartet
1005 | '(' erwartet
1006 | ')' erwartet
1007 | ']' erwartet
1010 | Bezeichner erwartet
1011 | '=' erwartet
1012 | 'If' erwartet
1013 | 'To' erwartet
1014 | 'End' erwartet
1015 | 'Function' erwartet
1016 | 'Sub' erwartet
1017 | 'Then' erwartet
1018 | 'Wend' erwartet
1019 | 'Loop' erwartet
1020 | 'Next' erwartet
1021 | 'Case' erwartet
1022 | 'Select' erwartet
1023 | Ausdruck erwartet
1024 | Anweisung erwartet
1025 | Anweisungsende erwartet
1026 | Ganzzahlige Konstante erwartet
1027 | 'While' oder 'Until' erwartet
1028 | 'While', 'Until' oder Anweisungsende erwartet
1029 | 'With' erwartet
1030 | Bezeichner zu lang
1031 | Ungültige Zahl
1032 | Ungültiges Zeichen
1033 | Nichtabgeschlossene Zeichenfolgenkonstante
1034 | Nichtabgeschlossener Kommentar
1037 | Ungültige Verwendung des Schlüsselwortes 'Me'
1038 | 'Loop' ohne 'Do'
1039 | Ungültige 'Exit'-Anweisung
1040 | Ungültige Steuervariable für 'For'-Schleife
1041 | Name erneut definiert
1042 | Muss die erste Anweisung in der Zeile sein
1043 | Zuweisung nur an ByVal-Argument möglich
1044 | Beim Aufrufen einer Unterroutine dürfen keine Klammern verwendet werden
1045 | Literalkonstante erwartet
1046 | 'In' erwartet
1047 | 'Class' erwartet
1048 | Muss innerhalb einer Klasse definiert sein
1049 | 'Let' oder 'Set' oder 'Get' in Eigenschaftsdeklaration erwartet
1050 | 'Property' erwartet
1051 | Die Anzahl der Argumente muss in den Spezifikationen der Eigenschaften konsistent sein
1052 | Eine Klasse kann nicht mehrere Standard-Eigenschaften/-Methoden enthalten
1053 | 'Class initialize' oder 'Class terminate' haben keine Argumente
1054 | Property 'Set' oder 'Let' muss mindestens ein Argument enthalten
1055 | Nicht erwartet: 'Next'
1056 | 'Default' darf nur für 'Property', 'Function' oder 'Sub' bestimmt werden
1057 | 'Default'-Spezifikation muss auch 'Public' bestimmen
1058 | 'Default'-Spezifikation nur für 'Property Get' möglich


Add-Methode (Dictionary)

Add-Methode (Dictionary) 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Fügt einem Dictionary-Objekt ein neues Element/Schlüssel-Paar hinzu.
Syntax
Objekt.Add Schlüssel, Element

Die Syntax der Add-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name des Dictionary-Objekts.
Schlüssel | Erforderlich. Der Schlüssel für das hinzuzufügende Element.
Element | Erforderlich. Das Element für den hinzuzufügenden Schlüssel.

Hinweise
Existiert der Schlüssel bereits, tritt ein Fehler auf.

Das folgende Beispiel zeigt die Verwendung der Add-Methode:

Dim d                  ' Erstellt eine Variable.
Set d = CreateObject("Scripting.Dictionary")
d.Add "a", "Athen"     ' Fügt einige Schlüssel und Elemente hinzu.
d.Add "b", "Belgrad"
d.Add "c", "Chicago"


Add-Methode (Dictionary)

Add-Methode (Dictionary)
Betrifft 		Scripting-Laufzeitreferenz

Dictionary-Objekt


Add-Methode (Dictionary)

Add-Methode (Dictionary)
Siehe auch 		Scripting-Laufzeitreferenz

Add-Methode (Folders)
Exists-Methode
Items-Methode
Keys-Methode
Remove-Methode
RemoveAll-Methode


Add-Methode (Folders)

Add-Methode (Folders) 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Fügt der Folders-Auflistung ein neues Folder-Objekt hinzu.
Syntax
Objekt.Add(Ordnername)

Die Syntax der Add-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name einer Folders-Auflistung.
Ordnername | Erforderlich. Der Name des neuen hinzuzufügenden Ordners.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Add-Methode, um einen neuen Ordner hinzuzufügen:
Sub NeuenOrdnerHinzufuegen(Pfad, Ordnername)
  Dim fso, f, fc, nf
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.GetFolder(Pfad)
  Set fc = f.SubFolders
  If Ordnername <> "" Then
    Set nf = fc.Add(Ordnername)
  Else
    Set nf = fc.Add("Neuer Ordner")
  End If
End Sub
Ist Ordnername bereits vorhanden, tritt ein Fehler auf.


Add-Methode (Folders)

Add-Methode (Folders)
Betrifft 		Scripting-Laufzeitreferenz

Folders-Auflistung


Add-Methode (Folders)

Add-Methode (Folders)
Siehe auch 		Scripting-Laufzeitreferenz

Add-Methode (Dictionary)


BuildPath-Methode

BuildPath-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Hängt einen Namen an einen vorhandenen Pfad an.
Syntax
Objekt.BuildPath(Pfad, Name)

Die Syntax der BuildPath-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Pfad | Erforderlich. Vorhandener Pfad, an den Name angehängt wird. Der Pfad kann absolut oder relativ sein und muss keinen vorhandenen Ordner angeben.
Name | Erforderlich. Name, der an den vorhandenen Pfad Pfad angehängt wird.

Hinweise
Die BuildPath-Methode fügt, nur falls erforderlich, ein zusätzliches Pfadtrennzeichen zwischen dem vorhandenen Pfad und dem Namen ein.

Das folgende Beispiel zeigt die Verwendung der BuildPath-Methode:

Function BuildPathHolen(Pfad)
  Dim fso, NeuerPfad
  Set fso = CreateObject("Scripting.FileSystemObject")
  NeuerPfad = fso.BuildPath(Pfad, "Unterordner")
  GetBuildPath = NeuerPfad
End Function


BuildPath-Methode

BuildPath-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


BuildPath-Methode

BuildPath-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFileName-Methode
GetParentFolderName-Methode
GetTempName-Methode


Clear-Methode

Clear-Methode 		Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Löscht die Einstellungen aller Eigenschaften des Err-Objekts.
Syntax
Objekt.Clear

Das Objekt ist immer das Err-Objekt.

Hinweise
Mit Clear löschen Sie explizit das Err-Objekt, nachdem ein Fehler bearbeitet wurde. Dies ist zum Beispiel erforderlich, wenn Sie On Error Resume Next verwenden und die Fehler erst später verarbeiten. VBScript ruft die Clear-Methode automatisch auf, sobald eine der folgenden Anweisungen ausgeführt wird:
  • On Error Resume Next
  • Exit Sub
  • Exit Function
Das folgende Beispiel zeigt die Verwendung der Clear-Methode:
On Error Resume Next
Err.Raise 6  ' Erzeugt einen Überlauffehler.
MsgBox ("Fehler # " & CStr(Err.Number) & " " & Err.Description)
Err.Clear    ' Löscht die Fehlermeldung.


Clear-Methode

Clear-Methode
Betrifft 		Sprachverzeichnis

Err-Objekt


Clear-Methode

Clear-Methode
Siehe auch 		Sprachverzeichnis

Description-Eigenschaft
Err-Objekt
Number-Eigenschaft
On Error-Anweisung
Raise-Methode
Source-Eigenschaft


Close-Methode

Close-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Schließt eine geöffnete TextStream-Datei.
Syntax
Objekt.Close

Objekt ist stets der Name eines TextStream-Objekts.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Close-Methode, um eine geöffnete TextStream-Datei zu schließen:
Sub DateiErstellen
  Dim fso, MeineDatei
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set MeineDatei = fso.CreateTextFile("c:\test.txt", True)
  MeineDatei.WriteLine("Dies ist ein Test.")
  MeineDatei.Close
End Sub


Close-Methode

Close-Methode
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


Close-Methode

Close-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Read-Methode
ReadAll-Methode
ReadLine-Methode
Skip-Methode
SkipLine-Methode
Write-Methode
WriteLine-Methode
WriteBlankLines-Methode


Copy-Methode

Copy-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Kopiert eine angegebene Datei bzw. einen angegebenen Ordner von einem Speicherort in einen anderen.
Syntax
Objekt.Copy Ziel[, Überschreiben]

Die Syntax der Copy-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines File- oder Folder-Objekts.
Ziel | Erforderlich. Ziel, in das die Datei oder der Ordner kopiert werden soll. Platzhalterzeichen sind nicht erlaubt.
Überschreiben | Optional. Boolescher Wert, der True ist, wenn vorhandene Dateien oder Ordner überschrieben werden sollen (dies ist der Standardwert), und der False ist, wenn nicht überschrieben werden soll.

Hinweise
Die Ergebnisse der Copy-Methode für eine Datei oder einen Ordner sind identisch mit denen der Operationen, die mithilfe von FileSystemObject.CopyFile oder FileSystemObject.CopyFolder durchgeführt werden, bei denen die Datei oder der Ordner, auf die Objekt verweist, als Argumente übergeben werden. Beachten Sie jedoch, dass bei diesen alternativen Operationen mehrere Dateien bzw. Ordner kopiert werden können.

Das folgende Beispiel zeigt die Verwendung der Copy-Methode:

Dim fso, MeineDatei
Set fso = CreateObject("Scripting.FileSystemObject")
Set MeineDatei = fso.CreateTextFile("c:\test.txt", True)
MeineDatei.WriteLine("Dies ist ein Test.")
MeineDatei.Close
Set MeineDatei = fso.GetFile("c:\test.txt")
MeineDatei.Copy "c:\windows\desktop\test2.txt"


Copy-Methode

Copy-Methode
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


Copy-Methode

Copy-Methode
Siehe auch 		Scripting-Laufzeitreferenz

CopyFile-Methode
CopyFolder-Methode
Delete-Methode
Move-Methode
OpenAsTextStream-Methode


CopyFile-Methode

CopyFile-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Kopiert eine oder mehrere Dateien von einem Speicherort in einen anderen.
Syntax
Objekt.CopyFile Quelle, Ziel[, Überschreiben]

Die Syntax der CopyFile-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Objekt ist stets der Name eines FileSystemObject.
Quelle | Erforderlich. Zeichenfolge zur Angabe der zu kopierenden Dateien. Darf Platzhalterzeichen enthalten.
Ziel | Erforderlich. Zeichenfolge zur Angabe des Ziels, in das die Dateien aus Quelle kopiert werden sollen. Platzhalterzeichen sind nicht erlaubt.
Überschreiben | Optional. Boolescher Wert, der angibt, ob vorhandene Dateien überschrieben werden sollen. Ist dieser True, werden vorhandene Dateien überschrieben, ist er False, werden sie nicht überschrieben. Der Standard ist True. Beachten Sie, dass CopyFile fehlschlägt, wenn für Ziel das Schreibschutzattribut gesetzt ist. Dabei ist der Wert von Überschreiben nicht relevant.

Hinweise
Platzhalterzeichen dürfen nur in der letzten Pfadkomponente des Arguments Quelle verwendet werden. Dies ist z. B. erlaubt:
FileSystemObject.CopyFile "c:\Eigene Dateien\Briefe\*.doc", "c:\temp\"
Dies hingegen nicht:
FileSystemObject.CopyFile "c:\Eigene Dateien\*\R1???97.xls", "c:\temp"
Wenn Quelle Platzhalterzeichen enthält oder Ziel mit einem Pfadtrennzeichen endet (\), wird angenommen, dass Ziel ein vorhandener Ordner ist, in den die übereinstimmenden Dateien kopiert werden. Andernfalls ist das Ziel der Name einer zu erstellenden Datei. Folgende drei Situationen können eintreten, wenn eine einzelne Datei kopiert wird:
  • Falls Ziel nicht vorhanden ist, wird Quelle kopiert. Dies ist der Normalfall.
  • Falls Ziel eine vorhandene Datei ist, tritt ein Fehler auf, wenn Überschreiben auf False eingestellt ist. Andernfalls wird versucht, Quelle über die vorhandene Datei zu kopieren.
  • Falls Ziel ein Verzeichnis ist, tritt ein Fehler auf.
Es kommt des Weiteren zu einem Fehler, wenn eine Quelle mit Platzhalterzeichen mit keiner der Dateien übereinstimmt. Die CopyFile-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.


CopyFile-Methode

CopyFile-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


CopyFile-Methode

CopyFile-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Copy-Methode
CopyFolder-Methode
CreateTextFile-Methode
DeleteFile-Methode
MoveFile-Methode


CopyFolder-Methode

CopyFolder-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Kopiert rekursiv einen Ordner von einem Speicherort in einen anderen.
Syntax
Objekt.CopyFolder Quelle, Ziel[, Überschreiben]

Die Syntax der CopyFolder-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Quelle | Erforderlich. Zeichenfolge zur Angabe der zu kopierenden Ordner. Darf Platzhalterzeichen enthalten.
Ziel | Erforderlich. Zeichenfolge zur Angabe des Ziels, in das die Ordner und untergeordneten Ordner aus der Quelle kopiert werden sollen. Platzhalterzeichen sind nicht erlaubt.
Überschreiben | Optional. Boolescher Wert, der angibt, ob vorhandene Ordner überschrieben werden sollen. Ist dieser True, werden vorhandene Dateien überschrieben, ist er False, werden sie nicht überschrieben. Der Standard ist True.

Hinweise
Platzhalterzeichen dürfen nur in der letzten Pfadkomponente des Arguments Quelle verwendet werden. Dies ist z. B. erlaubt:
FileSystemObject.CopyFolder "c:\Eigene Dateien\Briefe\*", "c:\temp\"
Dies hingegen nicht:
FileSystemObject.CopyFolder "c:\Eigene Dateien\*\*", "c:\temp\"
Wenn Quelle Platzhalterzeichen enthält oder Ziel mit einem Pfadtrennzeichen endet (\), wird angenommen, dass Ziel ein vorhandener Ordner ist, in den die übereinstimmenden Ordner und untergeordneten Ordner kopiert werden. Andernfalls wird angenommen, dass Ziel der Name eines zu erstellenden Ordners ist. Folgende vier Situationen können eintreten, wenn ein einzelner Ordner kopiert wird:
  • Falls Ziel nicht vorhanden ist, wird der Quellordner mit seinem vollständigen Inhalt kopiert. Dies ist der Normalfall.
  • Falls Ziel eine vorhandene Datei ist, tritt ein Fehler auf.
  • Falls Ziel ein Verzeichnis ist, wird versucht, den Ordner mitsamt Inhalt zu kopieren. Falls eine Datei in Quelle bereits im Ziel vorhanden ist, tritt ein Fehler auf, wenn Überschreiben auf False eingestellt ist. Andernfalls wird versucht, Quelle über die vorhandene Datei zu kopieren.
  • Falls Ziel ein schreibgeschütztes Verzeichnis ist, tritt ein Fehler auf, wenn eine vorhandene schreibgeschützte Datei in dieses Verzeichnis kopiert werden soll und Überschreiben auf False gesetzt ist.
Es kommt des Weiteren zu einem Fehler, wenn eine Quelle mit Platzhalterzeichen mit keinem der Ordner übereinstimmt.

Die CopyFolder-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.


CopyFolder-Methode

CopyFolder-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


CopyFolder-Methode

CopyFolder-Methode
Siehe auch 		Scripting-Laufzeitreferenz

CopyFile-Methode
Copy-Methode
CreateFolder-Methode
DeleteFolder-Methode
MoveFolder-Methode


CreateFolder-Methode

CreateFolder-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Erstellt einen Ordner.
Syntax
Objekt.CreateFolder(Ordnername)

Die Syntax der CreateFolder-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Ordnername | Erforderlich. Zeichenfolgenausdruck, der den zu erstellenden Ordner bezeichnet.

Hinweise
Ein Fehler tritt auf, wenn der angegebene Ordner bereits vorhanden ist.

Das folgende Beispiel zeigt die Verwendung der CreateFolder-Methode:

Function CreateFolderDemo
  Dim fso, f
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.CreateFolder("c:\Neuer Ordner")
  CreateFolderDemo = f.Path
End Function


CreateFolder-Methode

CreateFolder-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


CreateFolder-Methode

CreateFolder-Methode
Siehe auch 		Scripting-Laufzeitreferenz

CopyFolder-Methode
DeleteFolder-Methode
MoveFolder-Methode


CreateTextFile-Methode

CreateTextFile-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Erstellt eine Datei mit dem angegebenen Namen und gibt ein TextStream-Objekt für Schreib- und Lesezugriffe auf die Datei zurück.
Syntax
Objekt.CreateTextFile(Dateiname[, Überschreiben[, Unicode]])

Die Syntax der CreateTextFile-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name des FileSystemObject-Objekts oder des Folder-Objekts.
Dateiname | Erforderlich. Zeichenfolgenausdruck, der die zu erstellende Datei bezeichnet.
Überschreiben | Optional. Boolescher Wert, der angibt, ob eine vorhandene Datei überschrieben werden kann. True, wenn die Datei überschrieben werden kann, False, wenn sie nicht überschrieben werden darf. Ohne Angabe werden vorhandene Dateien nicht überschrieben.
Unicode | Optional. Boolescher Wert, der anzeigt, ob eine Unicode- oder ASCII-Datei erstellt werden soll. Der Wert ist True, wenn die Datei als Unicode-Datei erstellt wird, und False, wenn die Datei als ASCII-Datei erstellt wird. Ohne Angabe wird eine ASCII-Datei erstellt.

Hinweise
Die folgenden Codezeilen demonstrieren, wie Sie mit der CreateTextFile-Methode eine Datei erstellen und öffnen:
Sub DateiErstellen
  Dim fso, MeineDatei
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set MeineDatei = fso.CreateTextFile("c:\test.txt", True)
  MeineDatei.WriteLine("Dies ist ein Test.")
  MeineDatei.Close
End Sub
Ist das Argument Überschreiben False oder nicht angegeben, tritt bei einem bereits vorhandenen Dateinamen ein Fehler auf.


CreateTextFile-Methode

CreateTextFile-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt
Folder-Objekt


CreateTextFile-Methode

CreateTextFile-Methode
Siehe auch 		Scripting-Laufzeitreferenz

CreateFolder-Methode
OpenAsTextStream-Methode
OpenTextFile-Methode


Delete-Methode

Delete-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Löscht eine angegebene Datei bzw. einen angegebenen Ordner.
Syntax
Objekt.Delete Erzwingen

Die Syntax der Delete-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines File- oder Folder-Objekts.
Erzwingen | Optional. Boolescher Wert, der True ist, wenn Dateien oder Ordner mit gesetztem Schreibschutzattribut gelöscht werden sollen. Der Wert ist False (Standard), wenn dem nicht so sein soll.

Hinweise
Ein Fehler tritt auf, wenn die angegebene Datei bzw. der angegebene Ordner nicht vorhanden ist. Die Delete-Methode unterscheidet nicht zwischen Ordnern mit oder ohne Inhalt. Die ausgewählten Ordner werden ungeachtet des Inhalts gelöscht.

Die Ergebnisse der Delete-Methode für eine Datei oder einen Ordner entsprechen denen der Operationen, die mithilfe von FileSystemObject.DeleteFile oder FileSystemObject.DeleteFolder durchgeführt werden.

Das folgende Beispiel zeigt die Verwendung der Delete-Methode:

Dim fso, MeineDatei
Set fso = CreateObject("Scripting.FileSystemObject")
Set MeineDatei = fso.CreateTextFile("c:\test.txt", True)
MeineDatei.WriteLine("Dies ist ein Test.")
MeineDatei.Close
Set MeineDatei = fso.GetFile("c:\test.txt")
MeineDatei.Delete


Delete-Methode

Delete-Methode
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


Delete-Methode

Delete-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Copy-Methode
DeleteFile-Methode
DeleteFolder-Methode
Move-Methode
OpenAsTextStream-Methode


DeleteFile-Methode

DeleteFile-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Löscht eine angegebene Datei.
Syntax
Objekt.DeleteFile Dateiangabe[, Erzwingen]

Die Syntax der DeleteFile-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Dateiangabe | Erforderlich. Name der zu löschenden Datei. Dateiangabe darf in der letzten Pfadkomponente Platzhalterzeichen enthalten.
Erzwingen | Optional. Boolescher Wert, der True ist, wenn Dateien mit gesetztem Schreibschutzattribut gelöscht werden sollen. Er ist False (Standard), wenn dem nicht so sein soll.

Hinweise
Ein Fehler tritt auf, wenn keine übereinstimmenden Dateien gefunden werden. Die DeleteFile-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.

Das folgende Beispiel zeigt die Verwendung der DeleteFile-Methode:

Sub DateiLoeschen(Dateiangabe)
  Dim fso
  Set fso = CreateObject("Scripting.FileSystemObject")
  fso.DeleteFile Dateiangabe
End Sub


DeleteFile-Methode

DeleteFile-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


DeleteFile-Methode

DeleteFile-Methode
Siehe auch 		Scripting-Laufzeitreferenz

CopyFile-Methode
CreateTextFile-Methode
Delete-Methode
DeleteFolder-Methode
MoveFile-Methode


DeleteFolder-Methode

DeleteFolder-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Löscht einen angegebenen Ordner mitsamt Inhalt.
Syntax
Objekt.DeleteFolder Ordnerangabe[, Erzwingen]

Die Syntax der DeleteFolder-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Ordnerangabe | Erforderlich. Name des zu löschenden Ordners. Ordnerangabe darf in der letzten Pfadkomponente Platzhalterzeichen enthalten.
Erzwingen | Optional. Boolescher Wert, der True ist, wenn Ordner mit gesetztem Schreibschutzattribut gelöscht werden sollen. Er ist False (Standard), wenn dem nicht so sein soll.

Hinweise
Die DeleteFolder-Methode unterscheidet nicht zwischen Ordnern mit oder ohne Inhalt. Die ausgewählten Ordner werden ungeachtet des Inhalts gelöscht.

Ein Fehler tritt auf, wenn keine übereinstimmenden Ordner gefunden werden. Die DeleteFolder-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.

Das folgende Beispiel zeigt die Verwendung der DeleteFolder-Methode:

Sub OrdnerLoeschen(Ordnerangabe)
  Dim fso
  Set fso = CreateObject("Scripting.FileSystemObject")
  fso.DeleteFolder Dateiangabe
End Sub


DeleteFolder-Methode

DeleteFolder-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


DeleteFolder-Methode

DeleteFolder-Methode
Siehe auch 		Scripting-Laufzeitreferenz

CopyFolder-Methode
CreateFolder-Methode
Delete-Methode
DeleteFile-Methode
MoveFolder-Methode


DriveExists-Methode

DriveExists-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn das angegebene Laufwerk vorhanden ist, andernfalls False.
Syntax
Objekt.DriveExists(Laufwerksangabe)

Die Syntax der DriveExists-Methode hat folgende Komponenten:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Laufwerksangabe | Erforderlich. Ein Laufwerkbuchstabe bzw. eine vollständige Pfadangabe.

Hinweise
Die DriveExists-Methode gibt bei Laufwerken mit Wechselmedien auch dann True zurück, wenn kein Datenträger eingelegt ist. Verwenden Sie die IsReady-Eigenschaft des Drive-Objekts, um zu ermitteln, ob das Laufwerk bereit ist.

Das folgende Beispiel zeigt die Verwendung der DriveExists-Methode:

Function LaufwerksStatusBerichten(LW)
  Dim fso, mld
  Set fso = CreateObject("Scripting.FileSystemObject")
  If fso.DriveExists(LW) Then
    mld = ("Laufwerk " & UCase(LW) & " vorhanden.")
  Else
    mld = ("Laufwerk " & UCase(LW) & " nicht vorhanden.")
  End If
  LaufwerksStatusBerichten = mld
End Function


DriveExists-Methode

DriveExists-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


DriveExists-Methode

DriveExists-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Drive-Objekt
Drives-Auflistung
FileExists-Methode
FolderExists-Methode
GetDrive-Methode
GetDriveName-Methode
IsReady-Eigenschaft


Execute-Methode

Execute-Methode 		Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Führt die Suche mit regulärem Ausdruck in einer angegebenen Zeichenfolge aus.
Syntax
Objekt.Execute(Zeichenfolge)

Die Syntax der Execute-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines RegExp-Objekts.
Zeichenfolge | Erforderlich. Die Textzeichenfolge, auf der der reguläre Ausdruck ausgeführt wird.

Hinweise
Das eigentliche Muster für die Suche mit regulärem Ausdruck wird mithilfe der Pattern-Eigenschaft des RegExp-Objekts festgelegt.

Die Execute-Methode gibt eine Matches-Auflistung mit einem Match-Objekt für jede in Zeichenfolge gefundene Entsprechung zurück. Execute gibt eine leere Matches-Auflistung zurück, wenn keine Entsprechung gefunden wurde.

Der folgende Code verdeutlicht die Verwendung der Execute-Methode:

Function RegAusdrTest(Suchmuster, Zeichenfolge)
  Dim regAusdr, Uebereinstimmung, Uebereinstimmungen, RueckgabeZf	' Variablen erstellen.
  Set regAusdr = New RegExp			' Erstellt einen regulären Ausdruck.
  regAusdr.Pattern = Suchmuster			' Legt das Suchmuster fest.
  regAusdr.IgnoreCase = True			' Ignoriert die Schreibweise.
  regAusdr.Global = True				' Legt globales Anwenden fest.
  Set Übereinstimungen = regEx.Execute(Zeichenfolge)	' Führt die Suche aus.
  For Each Uebereinstimmung in Uebereinstimmungen		' Durchläuft die Matches-Auflistung.
    RueckgabeZf = RueckgabeZf & "Entsprechung gefunden bei "
    RueckgabeZf = RueckgabeZf & Match.FirstIndex & ". Wert ist '"
    RueckgabeZf = RueckgabeZf & Uebereinstimmung.Value & "'." & vbCRLF
  Next
  RegAusdrTest = RueckgabeZf
End Function

MsgBox(RegAusdrTest ("is.", "IS1 is2 IS3 is4"))


Execute-Methode

Execute-Methode
Betrifft 		Sprachverzeichnis

RegExp-Objekt


Execute-Methode

Execute-Methode
Siehe auch 		Sprachverzeichnis

Replace-Methode
Test-Methode


Exists-Methode

Exists-Methode 		Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn ein angegebener Schlüssel in einem Dictionary-Objekt existiert, andernfalls False.
Syntax
Objekt.Exists(Schlüssel)

Die Syntax der Exists-Methode besteht aus folgenden Komponenten:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name des Dictionary-Objekts.
Schlüssel | Erforderlich. Schlüssel, nach dem im Dictionary-Objekt gesucht werden soll.

Hinweise
Das folgende Beispiel zeigt die Verwendung der Exists-Methode:
Function SchluesselExistiert
  Dim d, mld             ' Erstellt einige Variablen.
  Set d = CreateObject("Scripting.Dictionary")
  d.Add "a", "Athen"     ' Fügt einige Schlüssel und Elemente hinzu.
  d.Add "b", "Belgrad"
  d.Add "c", "Chicago"
  If d.Exists("c") Then
    mld = "Angegebener Schlüssel ist vorhanden."
  Else
    mld = "Angegebener Schlüssel ist nicht vorhanden."
  End If
  SchluesselExistiert = mld
End Function


Exists-Methode

Exists-Methode
Betrifft 		Sprachverzeichnis

Dictionary-Objekt


Exists-Methode

Exists-Methode
Siehe auch 		Sprachverzeichnis

Add-Methode (Dictionary)
Items-Methode
Keys-Methode
Remove-Methode
RemoveAll-Methode


FileExists-Methode

FileExists-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn die angegebene Datei vorhanden ist, andernfalls False.
Syntax
Objekt.FileExists(Dateiangabe)

Die Syntax der FileExists-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Dateiangabe | Erforderlich. Der Name der Datei, deren Vorhandensein bestimmt werden soll. Ein vollständiger Pfad (entweder absolut oder relativ) muss angegeben werden, wenn anzunehmen ist, dass die Datei nicht in dem aktuellen Ordner vorhanden ist.

Hinweise
Das folgende Beispiel zeigt die Verwendung der FileExists-Methode:
Function DateiStatusBericht(Dateiangabe)
  Dim fso, mld
  Set fso = CreateObject("Scripting.FileSystemObject")
  If (fso.FileExists(Dateiangabe)) Then
    mld = Dateiangabe & " ist vorhanden."
  Else
    mld = Dateiangabe & " ist nicht vorhanden."
  End If
  DateiStatusBericht = mld
End Function


FileExists-Methode

FileExists-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


FileExists-Methode

FileExists-Methode
Siehe auch 		Scripting-Laufzeitreferenz

DriveExists-Methode
FolderExists-Methode
GetFile-Methode
GetFileName-Methode


FolderExists-Methode

FolderExists-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn der angegebene Ordner vorhanden ist, andernfalls False.
Syntax
Objekt.FolderExists(Ordnerangabe)

Die Syntax der FolderExists-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Ordnerangabe | Erforderlich. Der Name des Ordners, dessen Vorhandensein bestimmt werden soll. Ein vollständiger Pfad (entweder absolut oder relativ) muss angegeben werden, wenn anzunehmen ist, dass der Ordner nicht in dem aktuellen Ordner vorhanden ist.

Hinweise
Das folgende Beispiel zeigt die Verwendung der FolderExists-Methode:
Function OrdnerStatusBericht(Ordner)
  Dim fso, mld
  Set fso = CreateObject("Scripting.FileSystemObject")
  If (fso.FolderExists(Ordner)) Then
    mld = Ordner & " ist vorhanden."
  Else
    mld = Ordner & " ist nicht vorhanden."
  End If
  OrdnerStatusBericht = mld
End Function


FolderExists-Methode

FolderExists-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


FolderExists-Methode

FolderExists-Methode
Siehe auch 		Scripting-Laufzeitreferenz

DriveExists-Methode
FileExists-Methode
GetFolder-Methode
GetParentFolderName-Methode


GetAbsolutePathName-Methode

GetAbsolutePathName-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt aus einer angegebenen Pfadangabe einen vollständigen und eindeutigen Pfad zurück.
Syntax
Objekt.GetAbsolutePathName(Pfadangabe)

Die Syntax der GetAbsolutePathName-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Pfadangabe | Erforderlich. Pfadangabe, die in einen vollständigen und eindeutigen Pfad geändert werden soll.

Hinweise
Ein Pfad ist vollständig und eindeutig, wenn er einen vollständigen Verweis auf den Stammordner des angegebenen Laufwerkes enthält. Ein vollständiger Pfad darf nur mit einem Pfadtrennzeichen (\) enden, wenn er den Stammordner eines zugeordneten Laufwerkes angibt.

Für die folgende Tabelle, die die Funktionsweise der GetAbsolutePathName-Methode verdeutlichen soll, wird angenommen, dass c:\Eigene Dateien\Berichte das aktuelle Verzeichnis ist.

Pfadangabe | Rückgabepfad
"c:" | "c:\Eigene Dateien\Berichte"
"c:.." | "c:\Eigene Dateien"
"c:\\\" | "c:\"
"c:*.*\Mai97" | "c:\Eigene Dateien\Berichte\*.*\Mai97"
"Region1" | "c:\Eigene Dateien\Berichte\Region1"
"c:\..\..\Eigene Dateien" | "c:\Eigene Dateien"


GetAbsolutePathName-Methode

GetAbsolutePathName-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetAbsolutePathName-Methode

GetAbsolutePathName-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFileVersion-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetBaseName-Methode

GetBaseName-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Zeichenfolge zurück, die den Basisnamen einer Datei (Name ohne Erweiterung) oder den Ordner aus einer Pfadangabe enthält.
Syntax
Objekt.GetBaseName(Pfad)

Die Syntax der GetBaseName-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Pfad | Erforderlich. Die Pfadangabe der Datei oder des Ordners, dessen Basisname zurückgegeben werden soll.

Hinweise
Die GetBaseName-Methode gibt eine Zeichenfolge der Länge Null ("") zurück, wenn keine Datei oder kein Ordner mit dem Argument Pfad übereinstimmt.

Das folgende Beispiel zeigt die Verwendung der GetBaseName-Methode:

Function BasisAbrufen(Dateiangabe)
  Dim fso
  Set fso = CreateObject("Scripting.FileSystemObject")
  BasisAbrufen = fso.GetBaseName(Dateiangabe)
End Function
Anmerkung Die GetBaseName-Methode kann nur auf die angegebene Pfad-Zeichenfolge angewendet werden. Sie versucht weder, den Pfad aufzulösen, noch prüft sie das Vorhandensein des angegebenen Pfades.


GetBaseName-Methode

GetBaseName-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetBaseName-Methode

GetBaseName-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFileVersion-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetDrive-Methode

GetDrive-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt ein Drive-Objekt zurück, das dem Laufwerk in einem angegebenen Pfad entspricht.
Syntax
Objekt.GetDrive(Laufwerksangabe)

Die Syntax der GetDrive-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Laufwerksangabe | Erforderlich. Das Argument Laufwerksangabe kann ein Laufwerkbuchstabe (c), ein Laufwerkbuchstabe mit angefügtem Doppelpunkt (c:), ein Laufwerkbuchstabe mit angefügtem Doppelpunkt und Pfadtrennzeichen (c:\) oder eine UNC-Angabe (\\Computer2\Freigabe1) sein.

Hinweise
Bei Netzwerkfreigaben wird geprüft, ob diese vorhanden sind.

Ein Fehler tritt auf, wenn Laufwerksangabe nicht einem dieser erlaubten Formate entspricht oder nicht vorhanden ist. Verwenden Sie zum Aufrufen der GetDrive-Methode für eine normale Pfadzeichenfolge die folgende Sequenz, um eine Zeichenfolge abzurufen, die als Laufwerksangabe geeignet ist:

Laufwerksangabe = GetDriveName(GetAbsolutePathName(Pfad))
Das folgende Beispiel zeigt die Verwendung der GetDrive-Methode:
Function FreienLaufwerksspeicherAnzeigen(LWPfad)
  Dim fso, d, s
  Set fso = CreateObject("Scripting.FileSystemObject")

  Set d = fso.GetDrive(fso.GetDriveName(LWPfad))
  s = "Laufwerk" & UCase(LWPfad) & " - "
  s = s & d.VolumeName  & "<BR>"
  s = s & "Freier Speicherplatz: " & FormatNumber(d.FreeSpace/1024, 0)
  s = s & " KB"
  FreienLaufwerksspeicherAnzeigen = s
End Function


GetDrive-Methode

GetDrive-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetDrive-Methode

GetDrive-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFileVersion-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetDriveName-Methode

GetDriveName-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Zeichenfolge zurück, die den Namen des Laufwerkes in einem angegebenen Pfad enthält.
Syntax
Objekt.GetDriveName(Pfad)

Die Syntax der GetDriveName-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Pfad | Erforderlich. Die Pfadangabe der Komponente, deren Laufwerksnamen zurückgegeben werden soll.

Hinweise
Die GetDriveName-Methode gibt eine Zeichenfolge der Längen Null ("") zurück, wenn das Laufwerk nicht bestimmt werden kann.

Das folgende Beispiel zeigt die Verwendung der GetDriveName-Methode:

Function NamenAbrufen(Laufwerksangabe)
  Dim fso
  Set fso = CreateObject("Scripting.FileSystemObject")
  NamenAbrufen = fso.GetDriveName(Laufwerksangabe)
End Function
Hinweis Die GetDriveName-Methode kann nur auf die angegebene Pfad-Zeichenfolge angewendet werden. Sie versucht weder, den Pfad aufzulösen, noch prüft sie das Vorhandensein des angegebenen Pfades.


GetDriveName-Methode

GetDriveName-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetDriveName-Methode

GetDriveName-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFileVersion-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetExtensionName-Methode

GetExtensionName-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Zeichenfolge zurück, die den Erweiterungsnamen der letzten Komponente eines Pfades enthält.
Syntax
Objekt.GetExtensionName(Pfad)

Die Syntax der GetExtensionName-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Pfad | Erforderlich. Die Pfadangabe der Komponente, deren Erweiterungsname zurückgegeben werden soll.

Hinweise
Bei Netzlaufwerken gilt der Stammordner (\) als Komponente.

Die GetExtensionName-Methode gibt eine Zeichenfolge der Länge Null ("") zurück, wenn keine Komponente mit dem Argument Pfad übereinstimmt.

Das folgende Beispiel zeigt die Verwendung der GetExtensionName-Methode:

Function ErweiterungAbrufen(Laufwerkangabe)
  Dim fso
  Set fso = CreateObject("Scripting.FileSystemObject")
  ErweiterungAbrufen = fso.GetExtensionName(Laufwerkangabe)
End Function


GetExtensionName-Methode

GetExtensionName-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetExtensionName-Methode

GetExtensionName-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetFile-Methode
GetFileName-Methode
GetFileVersion-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetFile-Methode

GetFile-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt ein File-Objekt zurück, das der Datei in einem angegebenen Pfad entspricht.
Syntax
Objekt.GetFile(Dateiangabe)

Die Syntax der GetFile-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Dateiangabe | Erforderlich. Dateiangabe ist der Pfad (absolut oder relativ) zu einer bestimmten Datei.

Hinweise
Ein Fehler tritt auf, wenn die angegebene Datei nicht vorhanden ist.

Das folgende Beispiel zeigt die Verwendung der GetFile-Methode:

Function DateiZugriffsInfoAnzeigen(Dateiangabe)
  Dim fso, f, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.GetFile(Dateiangabe)
  s = f.Path & "<br>"
  s = s & "Erstellt: " & f.DateCreated & "<br>"
  s = s & "Letzter Zugriff: " & f.DateLastAccessed & "<br>"
  s = s & "Letzte Änderung: " & f.DateLastModified
  DateiZugriffsInfoAnzeigen = s
End Function


GetFile-Methode

GetFile-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetFile-Methode

GetFile-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFileName-Methode
GetFileVersion-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetFileName-Methode

GetFileName-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den letzten Dateinamen oder Ordner eines angegebenen Pfades zurück, der nicht Teil der Laufwerkangabe ist.
Syntax
Objekt.GetFileName(Pfadangabe)

Die Syntax der GetFileName-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Pfadangabe | Erforderlich. Der Pfad (absolut oder relativ) zu einer bestimmten Datei.

Hinweise
Die GetFileName-Methode gibt eine Zeichenfolge der Länge Null ("") zurück, wenn Pfadangabe nicht mit einer benannten Datei oder Ordner endet.

Das folgende Beispiel zeigt die Verwendung der GetFileName-Methode:

Function NameHolen(LWAngabe)
  Dim fso
  Set fso = CreateObject("Scripting.FileSystemObject")
  NameHolen = fso.GetFileName(LWAngabe)
End Function
Anmerkung Die GetFileName-Methode kann nur auf die angegebene Pfadangabe-Zeichenfolge angewendet werden. Sie versucht weder, den Pfad aufzulösen, noch prüft sie das Vorhandensein des angegebenen Pfades.


GetFileName-Methode

GetFileName-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetFileName-Methode

GetFileName-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileVersion-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetFileVersion-Methode

GetFileVersion-Methode 		Scripting-Laufzeitreferenz
Version 5

Siehe auch Betrifft

Beschreibung
Gibt die Versionsnummer einer angegebenen Datei zurück.
Syntax
Objekt.GetFileVersion(Pfadangabe)

Die Syntax der GetVersion-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Pfadangabe | Erforderlich. Der Pfad (absolut oder relativ) zu einer bestimmten Datei.

Hinweise
Die GetFileVersion-Methode gibt eine Zeichenfolge der Länge Null ("") zurück, wenn Pfadangabe nicht mit einer benannten Datei oder Ordner endet.

Das folgende Beispiel zeigt die Verwendung der GetFileVersion-Methode:

Function VersionHolen(Pfadangabe)
  Dim fso, temp
  Set fso = CreateObject("Scripting.FileSystemObject")
  temp = fso.GetFile(Pfadangabe);
  If Len(temp) Then
    VersionHolen = temp
  Else
    VersionHolen = "Keine Versionsinformationen verfügbar."
  End If
End Function
Anmerkung Die GetFileVersion-Methode kann nur auf die angegebene Pfad-Zeichenfolge angewendet werden. Sie versucht weder, den Pfad aufzulösen, noch prüft sie das Vorhandensein des angegebenen Pfades.


GetFileVersion-Methode

GetFileVersion-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetFileVersion-Methode

GetFileVersion-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetFolder-Methode

GetFolder-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt ein Folder-Objekt zurück, das dem Ordner in einem angegebenen Pfad entspricht.
Syntax
Objekt.GetFolder(Ordnerangabe)

Die Syntax der GetFolder-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Ordnerangabe | Erforderlich. Ordnerangabe ist der Pfad (absolut oder relativ) zu einem bestimmten Ordner.

Hinweise
Ein Fehler tritt auf, wenn der angegebene Ordner nicht vorhanden ist.

Das folgende Beispiel zeigt die Verwendung der GetFolder-Methode, um ein Folder-Objekt zurückzugeben:

Sub NeuenOrdnerHinzufuegen(Pfad, ordnerName)
  Dim fso, f, fc, nf
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.GetFolder(Pfad)
  Set fc = f.SubFolders
  If ordnName <> "" Then
    Set nf = fc.Add(ordnName)
  Else
    Set nf = fc.Add("Neuer Ordner")
  End If
End Sub


GetFolder-Methode

GetFolder-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetFolder-Methode

GetFolder-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFileVersion-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetParentFolderName-Methode

GetParentFolderName-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Zeichenfolge zurück, die den Namen des übergeordneten Ordners der letzten Datei oder des letzten Ordners in einem angegebenen Pfad enthält.
Syntax
Objekt.GetParentFolderName(Pfad)

Die Syntax der GetParentFolderName-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Pfad | Erforderlich. Die Pfadangabe der Datei oder des Ordners, dessen übergeordneter Ordner zurückgegeben werden soll.

Hinweise
Die GetParentFolderName-Methode gibt eine Zeichenfolge der Länge Null ("") zurück, wenn Pfadangabe keinen übergeordneten Ordner für die angegebene Datei oder den angegebenen Ordner enthält.

Das folgende Beispiel zeigt die Verwendung der GetParentFolderName-Methode:

Function UebergeordnetenHolen(Laufwerksangabe)
  Dim fso
  Set fso = CreateObject("Scripting.FileSystemObject")
  UebergeordnetenHolen = fso.GetParentFolderName(Laufwerksangabe)
End Function
Anmerkung Die GetParentFolderName-Methode kann nur auf die angegebene Pfad-Zeichenfolge angewendet werden. Sie versucht weder, den Pfad aufzulösen, noch prüft sie das Vorhandensein des angegebenen Pfades.


GetParentFolderName-Methode

GetParentFolderName-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetParentFolderName-Methode

GetParentFolderName-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFileVersion-Methode
GetFolder-Methode
GetSpecialFolder-Methode
GetTempName-Methode


GetSpecialFolder-Methode

GetSpecialFolder-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den angegebenen Sonderordner zurück.
Syntax
Objekt.GetSpecialFolder(Ordnerangabe)

Die Syntax der GetSpecialFolder-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Ordnerangabe | Erforderlich. Der Name des zurückzugebenden Sonderordners. Möglich ist eine der Konstanten, die im Abschnitt "Einstellungen" gezeigt werden.

Einstellungen
Das Argument Ordnerangabe kann einen der folgenden Werte aufweisen:

Konstante | Wert | Beschreibung
WindowsFolder | 0 | Der Ordner Windows enthält Dateien, die vom Betriebssystem Windows installiert werden.
SystemFolder | 1 | Der Ordner System enthält Bibliotheken, Schriftarten und Gerätetreiber.
TemporaryFolder | 2 | Im Ordner Temp werden temporäre Dateien gespeichert. Den Pfad finden Sie in der Umgebungsvariablen TMP.

Hinweise
Das folgende Beispiel zeigt die Verwendung der GetSpecialFolder-Methode:
Dim fso, tempDatei
Set fso = CreateObject("Scripting.FileSystemObject")

Function TempDateiErstellen
   Dim tOrdner, tName, tDatei
   Const TemporaryFolder = 2
   Set tOrdner = fso.GetSpecialFolder(TemporaryFolder)
   tName = fso.GetTempName
   Set tDatei = tOrdner.CreateTextFile(tName)
   Set TempDateiErstellen = tDatei
End Function

Set tempDatei = TempDateiErstellen
tempDatei.WriteLine "Hallo Welt"
tempDatei.Close


GetSpecialFolder-Methode

GetSpecialFolder-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetSpecialFolder-Methode

GetSpecialFolder-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFileVersion-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetTempName-Methode


GetTempName-Methode

GetTempName-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt einen willkürlich erstellten Namen einer temporären Datei bzw. eines temporären Ordners zurück, die bzw. der nützlich beim Durchführen von Operationen ist, die eine temporäre Datei oder einen temporären Ordner erfordern.
Syntax
Objekt.GetTempName

Das optionale Objekt ist stets der Name eines FileSystemObject.

Hinweise
Die GetTempName-Methode erstellt keine Datei. Sie stellt nur einen temporären Dateinamen bereit, der zusammen mit CreateTextFile zum Erstellen einer Datei verwendet werden kann.

Das folgende Beispiel zeigt die Verwendung der GetTempName-Methode:

Dim fso, tempDatei
Set fso = CreateObject("Scripting.FileSystemObject")

Function TempDateiErstellen
   Dim tOrdner, tName, tDatei
   Const TemporaryFolder = 2
   Set tOrdner = fso.GetSpecialFolder(TemporaryFolder)
   tName = fso.GetTempName
   Set tDatei = tOrdner.CreateTextFile(tName)
   Set TempDateiErstellen = tDatei
End Function

Set tempDatei = TempDateiErstellen
tempDatei.WriteLine "Hallo Welt"
tempDatei.Close


GetTempName-Methode

GetTempName-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


GetTempName-Methode

GetTempName-Methode
Siehe auch 		Scripting-Laufzeitreferenz

GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFileVersion-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode


Items-Methode

Items-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Gibt ein Datenfeld zurück, das alle Elemente in einem Dictionary-Objekt enthält.
Syntax
Objekt.Elemente

Objekt ist stets der Name eines Dictionary-Objekts.

Hinweise
Der folgende Code verdeutlicht die Verwendung der Items-Methode:
Function ItemsDemo
  Dim a, d, i, s          ' Erstellt einige Variablen.
  Set d = CreateObject("Scripting.Dictionary")
  d.Add "a", "Athen"      ' Fügt einige Schlüssel und Elemente hinzu.
  d.Add "b", "Belgrad"
  d.Add "c", "Chicago"
  a = d.Items             ' Lädt die Elemente.
  For i = 0 To d.Count -1 ' Durchläuft das Datenfeld.
    s = s & a(i) & "<BR>" ' Erstellt die Rückgabezeichenfolge.
  Next
  ItemsDemo = s
End Function


Items-Methode

Items-Methode
Betrifft 		Scripting-Laufzeitreferenz

Dictionary-Objekt


Items-Methode

Items-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Add-Methode (Dictionary)
Exists-Methode
Keys-Methode
Remove-Methode
RemoveAll-Methode


Keys-Methode

Keys-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Gibt ein Datenfeld mit allen Schlüsseln in einem Dictionary-Objekt zurück.
Syntax
Objekt.Schlüssel

Objekt ist stets der Name eines Dictionary-Objekts.

Hinweise
Der folgende Code verdeutlicht die Verwendung der Keys-Methode:
Function KeysDemo
  Dim a, d, i, s          ' Erstellt einige Variablen.
  Set d = CreateObject("Scripting.Dictionary")
  d.Add "a", "Athen"      ' Fügt einige Schlüssel und Elemente hinzu.
  d.Add "b", "Belgrad"
  d.Add "c", "Chicago"
  a = d. Keys             ' Lädt die Schlüssel.
  For i = 0 To d.Count -1 ' Durchläuft das Datenfeld.
    s = s & a(i) & "<BR>" ' Gibt die Ergebnisse zurück.
  Next
  KeysDemo = s
End Function


Keys-Methode

Keys-Methode
Betrifft 		Scripting-Laufzeitreferenz

Dictionary-Objekt


Keys-Methode

Keys-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Add-Methode (Dictionary)
Exists-Methode
Items-Methode
Remove-Methode
RemoveAll-Methode


Move-Methode

Move-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Verschiebt eine angegebene Datei bzw. einen angegebenen Ordner von einem Speicherort zu einem anderen.
Syntax
Objekt.Move Ziel

Die Syntax der Move-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines File- oder Folder-Objekts.
Ziel | Erforderlich. Ziel, in das die Datei oder der Ordner verschoben werden soll. Platzhalterzeichen sind nicht erlaubt.

Hinweise
Die Ergebnisse der Move-Methode für eine Datei oder einen Ordner sind identisch mit denen der Operationen, die mithilfe von FileSystemObject.MoveFile oder FileSystemObject.MoveFolder durchgeführt werden. Beachten Sie jedoch, dass bei diesen alternativen Operationen mehrere Dateien bzw. Ordner verschoben werden können.

Das folgende Beispiel zeigt die Verwendung der Move-Methode:

Dim fso, MeineDatei
Set fso = CreateObject("Scripting.FileSystemObject")
Set MeineDatei = fso.CreateTextFile("c:\test.txt", True)
MeineDatei.WriteLine("Dies ist ein Test.")
MeineDatei.Close
Set MeineDatei = fso.GetFile("c:\test.txt")
MeineDatei.Move "c:\windows\desktop\"


Move-Methode

Move-Methode
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


Move-Methode

Move-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Copy-Methode
Delete-Methode
MoveFile-Methode
MoveFolder-Methode
OpenAsTextStream-Methode


MoveFile-Methode

MoveFile-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Verschiebt eine Datei oder mehrere Dateien von einem Speicherort in einen anderen.
Syntax
Objekt.MoveFile Quelle, Ziel

Die Syntax der MoveFile-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Quelle | Erforderlich. Der Pfad zu den zu verschiebenden Dateien. Das Argument Quelle darf nur in der letzten Pfadkomponente Platzhalterzeichen enthalten.
Ziel | Erforderlich. Der Pfad, in den die Dateien verschoben werden. Das Argument Ziel darf keine Platzhalterzeichen enthalten.

Hinweise
Wenn Quelle Platzhalterzeichen enthält oder Ziel mit einem Pfadtrennzeichen (\) endet, wird angenommen, dass Ziel einen vorhandenen Ordner angibt, in den die übereinstimmenden Dateien verschoben werden. Andernfalls ist Ziel der Name der zu erstellenden Zieldatei. Beim Verschieben einer einzelnen Datei können folgende drei Situationen eintreten:
  • Wenn Ziel nicht vorhanden ist, wird die Datei verschoben. Dies ist der Normalfall.
  • Falls Ziel eine vorhandene Datei ist, tritt ein Fehler auf.
  • Falls Ziel ein Verzeichnis ist, tritt ein Fehler auf.
Ein Fehler tritt des Weiteren auf, wenn ein in Quelle verwendetes Platzhalterzeichen mit keiner Datei übereinstimmt. Die MoveFile-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.

Das folgende Beispiel zeigt die Verwendung der MoveFile-Methode:

Sub DateiVerschieben(Laufwerkangabe)
  Dim fso
  Set fso = CreateObject("Scripting.FileSystemObject")
  fso.MoveFile Laufwerkangabe, "c:\windows\desktop\"
End Sub
Wichtig Diese Methode erlaubt das Verschieben von Dateien zwischen Datenträgern nur, wenn dies vom Betriebssystem unterstützt wird.


MoveFile-Methode

MoveFile-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


MoveFile-Methode

MoveFile-Methode
Siehe auch 		Scripting-Laufzeitreferenz

CopyFile-Methode
DeleteFile-Methode
GetFile-Methode
GetFileName-Methode
Move-Methode
MoveFolder-Methode
OpenTextFile-Methode


MoveFolder-Methode

MoveFolder-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Verschiebt einen oder mehrere Ordner von einem Speicherort in einen anderen.
Syntax
Objekt.MoveFolder Quelle, Ziel

Die Syntax der MoveFolder-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Quelle | Erforderlich. Der Pfad zu den zu verschiebenden Ordnern. Das Argument Quelle darf nur in der letzten Pfadkomponente Platzhalterzeichen enthalten.
Ziel | Erforderlich. Der Pfad, in den die Ordner verschoben werden sollen. Das Argument Ziel darf keine Platzhalterzeichen enthalten.

Hinweise
Wenn Quelle Platzhalterzeichen enthält oder Ziel mit einem Pfadtrennzeichen (\) endet, wird angenommen, dass Ziel einen vorhandenen Ordner angibt, in den die übereinstimmenden Dateien verschoben werden. Andernfalls ist Ziel der Name des zu erstellenden Zielordners. Beim Verschieben eines einzelnen Ordners können folgende drei Situationen eintreten:
  • Wenn Ziel nicht vorhanden ist, wird der Ordner verschoben. Dies ist der Normalfall.
  • Falls Ziel eine vorhandene Datei ist, tritt ein Fehler auf.
  • Falls Ziel ein Verzeichnis ist, tritt ein Fehler auf.
Ein Fehler tritt des Weiteren auf, wenn ein in Quelle verwendetes Platzhalterzeichen mit keinem der Ordner übereinstimmt. Die MoveFolder-Methode wird beim ersten auftretenden Fehler abgebrochen. Vor dem Fehler durchgeführte Änderungen werden nicht rückgängig gemacht.

Das folgende Beispiel zeigt die Verwendung der MoveFolder-Methode:

Sub OrdnerVerschieben(Laufwerkangabe)
  Dim fso
  Set fso = CreateObject("Scripting.FileSystemObject")
  fso.MoveFolder Laufwerkangabe, "c:\windows\desktop\"
End Sub
Wichtig Diese Methode erlaubt das Verschieben von Ordnern zwischen Datenträgern nur, wenn dies vom Betriebssystem unterstützt wird.


MoveFolder-Methode

MoveFolder-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


MoveFolder-Methode

MoveFolder-Methode
Siehe auch 		Scripting-Laufzeitreferenz

CopyFolder-Methode
CreateFolder-Methode
DeleteFolder-Methode
GetFolder-Methode
GetParentFolderName-Methode
Move-Methode
MoveFile-Methode


OpenAsTextStream-Methode

OpenAsTextStream-Methode 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zum Lesen aus der Datei, Schreiben in die Datei oder Anfügen an die Datei zurück.
Syntax
Objekt.OpenAsTextStream([E/A-Modus, [Format]])

Die Syntax der OpenAsTextStream-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines File-Objekts.
E/A-Modus | Optional. Gibt den Ein-/Ausgabemodus an. Es gibt drei mögliche Konstanten: ForReading, ForWriting oder ForAppending.
Format | Optional. Einer von drei Tristate-Werten, mit denen das Format der geöffneten Datei angegeben wird. Ohne Angabe wird die Datei als ASCII geöffnet.

Einstellungen
Das Argument E/A-Modus kann eine der folgenden Einstellungen aufweisen:

Konstante | Wert | Beschreibung
ForReading | 1 | Öffnet eine Datei nur zum Lesen. Schreibzugriffe sind nicht möglich.
ForWriting | 2 | Öffnet eine Datei zum Schreiben. Ist eine Datei mit demselben Namen vorhanden, wird der vorherige Inhalt überschrieben.
ForAppending | 8 | Öffnet eine Datei und schreibt an das Dateiende.

Das Argument Format kann eine der folgenden Einstellungen aufweisen:

Konstante | Wert | Beschreibung
TristateUseDefault | -2 | Öffnen der Datei im Format des Systemstandards.
TristateTrue | -1 | Öffnen der Datei im Unicode-Format.
TristateFalse | 0 | Öffnen der Datei im ASCII-Format.

Hinweise
Die OpenAsTextStream-Methode bietet dieselbe Funktionalität wie die OpenTextFile-Methode von FileSystemObject. Darüber hinaus kann die OpenAsTextStream-Methode zum Schreiben in eine Datei verwendet werden.

Der folgende Code verdeutlicht das Verwenden der OpenAsTextStream-Methode:

Function TextStreamTest
  Const ForReading = 1, ForWriting = 2, ForAppending = 8
  Const TristateUseDefault = -2, TristateTrue = -1, TristateFalse = 0
  Dim fso, f, ts
  Set fso = CreateObject("Scripting.FileSystemObject")
  fso.CreateTextFile "test1.txt"            ' Erstellt eine Datei.
  Set f = fso.GetFile("test1.txt")
  Set ts = f.OpenAsTextStream(ForWriting, TristateUseDefault)
  ts.Write "Hallo Welt"
  ts.Close
  Set ts = f.OpenAsTextStream(ForReading, TristateUseDefault)
  TextStreamTest = ts.ReadLine
  ts.Close
End Function


OpenAsTextStream-Methode

OpenAsTextStream-Methode
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt


OpenAsTextStream-Methode

OpenAsTextStream-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Copy-Methode
CreateTextFile-Methode
Delete-Methode
Move-Methode
OpenTextFile-Methode


OpenTextFile-Methode

OpenTextFile-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Öffnet eine angegebene Datei und gibt ein TextStream-Objekt zum Lesen aus der Datei, Schreiben in die Datei oder Anfügen an die Datei zurück.
Syntax
Objekt.OpenTextFile(Dateiname[, E/A-Modus[, Erstellen[, Format]]])

Die Syntax der OpenTextFile-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines FileSystemObject-Objekts.
Dateiname | Erforderlich. Zeichenfolgenausdruck, der die zu öffnende Datei angibt.
E/A-Modus | Optional. Gibt den Ein-/Ausgabemodus an. Es gibt drei mögliche Konstanten: ForReading, ForWriting oder ForAppending.
Erstellen | Optional. Boolescher Wert, der angibt, ob eine neue Datei erstellt werden soll, wenn der angegebene Dateiname nicht existiert. True, wenn eine neue, False, wenn keine neue Datei erstellt werden soll. Der Standard ist False.
Format | Optional. Einer von drei Tristate-Werten, mit denen das Format der geöffneten Datei angegeben wird. Ohne Angabe wird die Datei als ASCII geöffnet.

Einstellungen
Das Argument E/A-Modus kann einen der folgenden Werte annehmen:

Konstante | Wert | Beschreibung
ForReading | 1 | Öffnet eine Datei nur zum Lesen. Schreibzugriffe sind nicht möglich.
ForWriting | 2 | Öffnet eine Datei nur zum Schreiben. Sie können nicht aus ihr lesen.
ForAppending | 8 | Öffnet eine Datei und schreibt an das Dateiende.

Das Argument Format kann eine der folgenden Einstellungen aufweisen:

Konstante | Wert | Beschreibung
TristateUseDefault | -2 | Öffnen der Datei im Format des Systemstandards.
TristateTrue | -1 | Öffnen der Datei im Unicode-Format.
TristateFalse | 0 | Öffnen der Datei im ASCII-Format.

Hinweise
Der folgende Code verdeutlicht die Verwendung der OpenTextFile-Methode, um eine Datei zum Schreiben von Text zu öffnen:
Sub OpenTextFileDemo
  Const ForReading = 1, ForWriting = 2, ForAppending = 8
  Dim fso, f
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.OpenTextFile("c:\test.txt", ForWriting, True)
  f.Write "Hallo Welt!"
  f.Close
End Sub


OpenTextFile-Methode

OpenTextFile-Methode
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


OpenTextFile-Methode

OpenTextFile-Methode
Siehe auch 		Scripting-Laufzeitreferenz

OpenAsTextStream-Methode
CreateTextFile-Methode


Raise-Methode

Raise-Methode 		Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Löst einen Laufzeitfehler aus.
Syntax
Objekt.Raise(Zahl, Quelle, Beschreibung, Hilfedatei, Hilfekontext)

Die Syntax der Raise-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Stets das Err-Objekt.
Zahl | Ein Wert des Untertyps Long, der den Fehler kennzeichnet. VBScript-Fehler (sowohl integrierte VBScript-Fehler als auch benutzerdefinierte Fehler) liegen im Bereich 0-65535.
Quelle | Ein Zeichenfolgenausdruck, der das Objekt oder die Anwendung bezeichnet, das oder die ursprünglich den Fehler ausgelöst hat. Wenn Sie diese Eigenschaft für ein Automatisierungsobjekt festlegen, verwenden Sie die Form Projekt.Klasse. Wenn kein Ausdruck angegeben wird, wird die Ressourcenkennzeichnung (Programmatic ID) des aktuellen VBScript-Projekts verwendet.
Beschreibung | Ein Zeichenfolgenausdruck, der den Fehler beschreibt. Wenn kein Ausdruck angegeben wird, wird der Wert in Zahl untersucht. Wenn er dem Code eines VBScript-Laufzeitfehlers zugeordnet werden kann, wird die Zeichenfolge, die von VBScript zurückgegeben wurde, für Beschreibung verwendet. Wenn kein VBScript-Fehler dem Wert von Zahl entspricht, wird eine allgemeine Fehlermeldung verwendet.
Hilfedatei | Die vollständige Pfadangabe zur Hilfedatei, in der sich eine Beschreibung zu diesem Fehler befindet. Wird dieser Teil nicht angegeben, verwendet VBScript die vollständigen Angaben zu Laufwerk, Pfad und Dateiname der VBScript-Hilfedatei.
Hilfekontext | Die Kontext-ID gibt ein Thema innerhalb von Hilfedatei an, die Hilfeinformationen zu diesem Fehler bereitstellt. Wird dieser Teil nicht angegeben, wird die Kontext-ID der VBScript-Hilfedatei verwendet, die der entsprechenden number-Eigenschaft (sofern vorhanden) für diesen Fehler entspricht.

Hinweise
Alle Argumente bis auf Zahl sind optional. Wenn Sie dagegen Raise verwenden, ohne Argumente anzugeben, und die Einstellungen der Eigenschaften des Err-Objekts Werte enthalten, die noch nicht gelöscht wurden, werden diese Werte für Ihren Fehler verwendet.

Wenn Sie die number-Eigenschaft in einem Automatisierungsobjekt auf Ihren eigenen Fehlercode einstellen möchten, müssen Sie die Fehlercodenummer zur Konstanten vbObjectError addieren. Um beispielsweise die Fehlernummer 1050 zu erzeugen, weisenSie der Number-Eigenschaft den Wert vbObjectError + 1050 zu.

Das folgende Beispiel zeigt die Verwendung der Raise-Methode:

On Error Resume Next
Err.Raise 6  ' Erzeugt einen Überlauffehler.
MsgBox ("Fehler Nr. " & CStr(Err.Number) & " " & Err.Description)
Err.Clear    ' Löscht die Fehlermeldung.


Raise-Methode

Raise-Methode
Betrifft 		Sprachverzeichnis

Err-Objekt


Raise-Methode

Raise-Methode
Siehe auch 		Sprachverzeichnis

Clear-Methode
Description-Eigenschaft
Err-Objekt
Number-Eigenschaft
Source-Eigenschaft


Read-Methode

Read-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Liest eine angegebene Anzahl von Zeichen aus einer TextStream-Datei und gibt die daraus resultierende Zeichenfolge zurück.
Syntax
Objekt.Read(Zeichen)

Die Syntax der Read-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines TextStream-Objekts.
Zeichen | Erforderlich. Anzahl der Zeichen, die aus der Datei gelesen werden sollen.

Hinweise

Das folgende Beispiel veranschaulicht die Verwendung der Read-Methode, um fünf Zeichen aus einer Datei zu lesen und die Ergebniszeichenfolge zurückzugeben:
Function TextDateiLesen
  Const ForReading = 1, ForWriting = 2, ForAppending = 8
  Dim fso, f
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.OpenTextFile("c:\test.txt", ForWriting, True)
  f.Write "Hallo Welt!"
  Set f = fso.OpenTextFile("c:\test.txt", ForReading)
  TextDateiLesen =  f.Read(5)
End Function


Read-Methode

Read-Methode
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


ReadAll-Methode

ReadAll-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Liest eine ganze TextStream-Datei und gibt die daraus resultierende Zeichenfolge zurück.
Syntax
Objekt.ReadAll

Objekt ist stets der Name eines TextStream-Objekts.

Hinweise
Bei großen Dateien werden beim Einsatz der ReadAll-Methode unnötig Speicherressourcen belegt. Andere Vorgehensweisen wie zeilenweises Einlesen einer Datei sind dafür besser geeignet.
Function ReadAllDemo
  Const ForReading = 1, ForWriting = 2
  Dim fso, f
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.OpenTextFile("c:\test.txt", ForWriting, True)
  f.Write "Hallo Welt!"
  Set f = fso.OpenTextFile("c:\test.txt", ForReading)
  ReadAllDemo =  f.ReadAll
End Function


ReadAll-Methode

ReadAll-Methode
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


ReadAll-Methode

ReadAll-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Close-Methode
Read-Methode
ReadLine-Methode
Skip-Methode
SkipLine-Methode
Write-Methode
WriteLine-Methode
WriteBlankLines-Methode


Read-Methode

Read-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Close-Methode
ReadAll-Methode
ReadLine-Methode
Skip-Methode
SkipLine-Methode
Write-Methode
WriteLine-Methode
WriteBlankLines-Methode


ReadLine-Methode

ReadLine-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Liest eine ganze Zeile (bis zum Zeilenumbruchzeichen, aber nicht dieses Zeichen selbst) aus einer TextStream-Datei und gibt die resultierende Zeichenfolge zurück.
Syntax
Objekt.ReadLine

Das Argument Objekt ist immer der Name eines TextStream-Objekts.

Hinweise
Das folgende Beispiel zeigt die Verwendung der ReadLine-Methode, um eine Zeile aus einer TextStream-Datei zu lesen und die Zeichenfolge zurückzugeben:
Function ReadLineDemo
  Const ForReading = 1, ForWriting = 2
  Dim fso, MeineDatei
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set MeineDatei = fso.OpenTextFile("c:\test.txt", ForWriting, True)
  MeineDatei.WriteLine "Hallo Welt!"
  MeineDatei.WriteLine "Franz jagt im komplett verwahrlosten Taxi quer durch Bayern."
  MeineDatei.Close
  Set MeineDatei = fso.OpenTextFile("c:\test.txt", ForReading)
  ReadLineDemo = MeineDatei.ReadLine	' Gibt "Hallo Welt!" zurück.
End Function


ReadLine-Methode

ReadLine-Methode
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


ReadLine-Methode

ReadLine-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Close-Methode
Read-Methode
ReadAll-Methode
Skip-Methode
SkipLine-Methode
Write-Methode
WriteLine-Methode
WriteBlankLines-Methode


Remove-Methode

Remove-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Entfernt ein Element/Schlüssel-Paar aus einem Dictionary-Objekt.
Syntax
Objekt.Remove(Schlüssel)

Die Syntax der Remove-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name des Dictionary-Objekts.
Schlüssel | Erforderlich. Schlüssel für das Element/Schlüssel-Paar, das aus dem Dictionary-Objekt entfernt werden soll.

Hinweise
Existiert das angegebene Element/Schlüssel-Paar nicht, tritt ein Fehler auf.

Der folgende Code veranschaulicht die Verwendung der Remove-Methode:

Dim a, d               ' Erstellt einige Variablen.
Set d = CreateObject("Scripting.Dictionary")
d.Add "a", "Athen"     ' Fügt einige Schlüssel und Elemente hinzu.
d.Add "b", "Belgrad"
d.Add "c", "Chicago"
...
d.Remove("b")          ' Entfernt das zweite Paar.


RemoveAll-Methode

Remove-Methode
Betrifft 		Scripting-Laufzeitreferenz

Dictionary-Objekt


RemoveAll-Methode

RemoveAll-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Die RemoveAll-Methode entfernt alle Element/Schlüssel-Paare aus einem Dictionary-Objekt.
Syntax
Objekt.RemoveAll

Objekt ist stets der Name eines Dictionary-Objekts.

Hinweise
Der folgende Code veranschaulicht die Verwendung der RemoveAll-Methode:
Dim a, d               ' Erstellt einige Variablen.
Set d = CreateObject("Scripting.Dictionary")
d.Add "a", "Athen"     ' Fügt einige Schlüssel und Elemente hinzu.
d.Add "b", "Belgrad"
d.Add "c", "Chicago"
...
a = d.RemoveAll        ' Leert das Dictionary-Objekt.


RemoveAll-Methode

RemoveAll-Methode
Betrifft 		Scripting-Laufzeitreferenz

Dictionary-Objekt


RemoveAll-Methode

RemoveAll-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Add-Methode (Dictionary)
Exists-Methode
Items-Methode
Keys-Methode
Remove-Methode


Remove-Methode

Remove-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Add-Methode (Dictionary)
Exists-Methode
Items-Methode
Keys-Methode
RemoveAll-Methode


Replace-Methode

Replace-Methode 		Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Ersetzt den bei einer Suche mit regulärem Ausdruck gefundenen Text.
Syntax
Objekt.Replace(Zeichenfolge1, Zeichenfolge2)

Die Syntax der Replace-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines RegExp-Objekts.
Zeichenfolge1 | Erforderlich. Zeichenfolge1 ist die Textzeichenfolge, in der Textersetzungen durchgeführt werden.
Zeichenfolge2 | Erforderlich. Zeichenfolge2 ist die ersetzende Textzeichenfolge.

Hinweise
Das eigentliche Muster für den zu ersetzenden Text wird durch Verwendung der Pattern-Eigenschaft des RegExp-Objekts festgelegt.

Die Replace-Methode gibt eine Kopie von Zeichenfolge1 zurück, in der der text aus RegExp.Pattern durch Zeichenfolge2 ersetzt ist. Wird keine Entsprechung gefunden, wird eine nicht geänderte Kopie von Zeichenfolge1 zurückgegeben.

Der folgende Code veranschaulicht die Verwendung der Replace-Methode:

Function ReplaceDemo(Suchmuster, ErsatzZf)
  Dim regAusdr, Zf1						' Variablen erstellen.
  Zf1 = "Franz jagt im komplett verwahrlosten Taxi quer durch Bayern."
  Set regAusdr = New RegExp				' Erstellt einen regulären Ausdruck.
  regAusdr.Pattern = Suchmuster				' Legt das Suchmuster fest.
  regAusdr.IgnoreCase = True				' Ignoriert die Groß-/Kleinschreibung.
  regAusdr.Global = True					' Legt globales Anwenden fest.
  ReplaceDemo = regAusdr.Replace(Zf1, ErsatzZf)	' Führt die Ersetzung durch.
End Function

MsgBox(ReplaceDemo("Taxi", "Auto"))			' Ersetzt 'Taxi' durch 'Auto'.
Darüber hinaus kann die Replace-Methode Teilausdrücke in einem Muster ersetzen. Der folgende Aufruf des zuvor beschriebenen Beispiels vertauscht die einzelnen Wortpaare in der ursprünglichen Zeichenfolge:
MsgBox(ReplaceDemo("(\S+)(\s+)(\S+)", "$3$2$1"))	' Vertauscht die Wortpaare.


Replace-Methode

Replace-Methode
Betrifft 		Sprachverzeichnis

RegExp-Objekt


Replace-Methode

Replace-Methode
Siehe auch 		Sprachverzeichnis

Execute-Methode
Test-Methode


Skip-Methode

Skip-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Überspringt eine bestimmte Anzahl von Zeichen beim Einlesen einer TextStream-Datei.
Syntax
Objekt.Skip(Zeichen)

Die Syntax der Skip-Methode enthält die folgenden Teile:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines TextStream-Objekts.
Zeichen | Erforderlich. Anzahl von Zeichen, die beim Einlesen übersprungen werden sollen.

Hinweise
Übersprungene Zeichen werden verworfen.

Das folgende Beispiel zeigt die Verwendung der Skip-Methode, um die ersten sechs Zeichen vor dem Lesen zu überspringen:

Function SkipDemo
  Const ForReading = 1, ForWriting = 2
  Dim fso, f
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.OpenTextFile("c:\test.txt", ForWriting, True)
  f.Write "Hallo Welt!"
  Set f = fso.OpenTextFile("c:\test.txt", ForReading)
  f.Skip(6)
  SkipDemo =  f.ReadLine
End Function


Skip-Methode

Skip-Methode
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


Skip-Methode

Skip-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Close-Methode
Read-Methode
ReadAll-Methode
ReadLine-Methode
SkipLine-Methode
Write-Methode
WriteLine-Methode
WriteBlankLines-Methode


SkipLine-Methode

SkipLine-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Überspringt die nächste Zeile beim Einlesen einer TextStream-Datei.
Syntax
Objekt.SkipLine

Objekt ist stets der Name eines TextStream-Objekts.

Hinweise
Eine Zeile überspringen heißt, alle Zeichen in einer Zeile bis zu dem Zeilenumbruchzeichen werden eingelesen und inklusive dem Zeilenumbruchzeichen selbst verworfen. Ist die Datei nicht zum Lesen geöffnet, tritt ein Fehler auf.

Das folgende Beispiel veranschaulicht die Verwendung der SkipLine-Methode:

Function SkipLineDemo
  Const ForReading = 1, ForWriting = 2
  Dim fso, f
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.OpenTextFile("c:\test.txt", ForWriting, True)
  f.Write "Hallo Welt!" & vbCrLf & "VB Script macht Spaß!"
  Set f = fso.OpenTextFile("c:\test.txt", ForReading)
  f.SkipLine
  SkipLineDemo = f.ReadLine
End Function


SkipLine-Methode

SkipLine-Methode
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


SkipLine-Methode

SkipLine-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Close-Methode
Read-Methode
ReadAll-Methode
ReadLine-Methode
Skip-Methode
Write-Methode
WriteLine-Methode
WriteBlankLines-Methode


Test-Methode

Test-Methode 		Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Führt eine Suche mit regulärem Ausdruck auf eine angegebene Zeichenfolge aus und gibt einen booleschen Wert zurück, der angibt, ob ein Muster gefunden wurde.
Syntax
Objekt.Test(Zeichenfolge)

Die Syntax der Execute-Methode enthält folgende Teile:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines RegExp-Objekts.
Zeichenfolge | Erforderlich. Die Textzeichenfolge, auf der der reguläre Ausdruck ausgeführt wird.

Hinweise
Das eigentliche Muster für die Suche mit regulärem Ausdruck wird mithilfe der Pattern-Eigenschaft des RegExp-Objekts festgelegt. Die RegExp.Global-Eigenschaft hat keine Auswirkungen auf die Test-Methode.

Die Test-Methode gibt True zurück, wenn ein Muster gefunden wurde, andernfalls False.

Der folgende Code veranschaulicht die Verwendung der Test-Methode:

Function RegAusdrTest(Suchmuster, Zeichenfolge)
  Dim regAusdr, Rueckgabewert			' Variablen erstellen.
  Set regAusdr = New RegExp			' Erstellt einen regulären Ausdruck.
  regAusdr.Pattern = Suchmuster			' Legt das Suchmuster fest.
  regAusdr.IgnoreCase = False			' Legt Groß-/Kleinschreibung fest.
  Rueckgabewert = regAusdr.Test(Zeichenfolge)	' Führt den Suchtest aus.
  If Rueckgabewert Then
    RegAusdrTest = "Es wurden eine oder mehrere Entsprechungen gefunden."
  Else
    RegAusdrTest = "Es wurden keine Entsprechung gefunden."
  End If
End Function

MsgBox(RegAusdrTest ("is.", "IS1 is2 IS3 is4"))


Test-Methode

Test-Methode
Betrifft 		Sprachverzeichnis

RegExp-Objekt


Test-Methode

Test-Methode
Siehe auch 		Sprachverzeichnis

Execute-Methode
Replace-Methode


Write-Methode

Write-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Schreibt eine angegebene Zeichenfolge in eine TextStream-Datei.
Syntax
Objekt.Write(Zeichenfolge)

Die Syntax der Write-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines TextStream-Objekts.
Zeichenfolge | Erforderlich. Text, der in die Datei geschrieben werden soll.

Hinweise
Die angegebenen Zeichenfolgen werden ohne zwischenstehende Leerzeichen oder andere Zeichen in die Datei geschrieben. Um ein Zeilenumbruchzeichen oder eine Zeichenfolge, die mit einem Zeilenumbruchzeichen endet, in eine Datei zu schreiben, verwenden Sie die WriteLine-Methode.

Das folgende Beispiel veranschaulicht die Verwendung der Write-Methode:

Function InDateiSchreiben
  Const ForReading = 1, ForWriting = 2
  Dim fso, f
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.OpenTextFile("c:\test.txt", ForWriting, True)
  f.Write "Hallo Welt!"
  Set f = fso.OpenTextFile("c:\test.txt", ForReading)
  InDateiSchreiben =  f.ReadLine
End Function


Write-Methode

Write-Methode
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


WriteBlankLines-Methode

WriteBlankLines-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Schreibt eine angegebene Anzahl von Zeilenumbruchzeichen in eine TextStream-Datei.
Syntax
Objekt.WriteBlankLines(Anzahl)

Die Syntax der WriteBlankLines-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines TextStream-Objekts.
Anzahl | Erforderlich. Anzahl von Zeilenumbruchzeichen, die in die Datei geschrieben werden sollen.

Hinweise
Das folgende Beispiel veranschaulicht die Verwendung der WriteBlankLines-Methode:
Function LeerzeilenInDateiSchreiben
  Const ForReading = 1, ForWriting = 2
  Dim fso, f
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.OpenTextFile("c:\test.txt", ForWriting, True)
  f.WriteBlankLines 2
  f.WriteLine "Hallo Welt!"
  Set f = fso.OpenTextFile("c:\test.txt", ForReading)
  LeerzeilenInDateiSchreiben = f.ReadAll
End Function


WriteBlankLines-Methode

WriteBlankLines-Methode
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


WriteBlankLines-Methode

WriteBlankLines-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Close-Methode
Read-Methode
ReadAll-Methode
ReadLine-Methode
Skip-Methode
SkipLine-Methode
Write-Methode
WriteLine-Methode


Write-Methode

Write-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Close-Methode
Read-Methode
ReadAll-Methode
ReadLine-Methode
Skip-Methode
SkipLine-Methode
WriteLine-Methode
WriteBlankLines-Methode


WriteLine-Methode

WriteLine-Methode 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Schreibt eine angegebene Zeichenfolge und ein Zeilenumbruchzeichen in eine TextStream-Datei.
Syntax
Objekt.WriteLine([Zeichenfolge])

Die Syntax der WriteLine-Methode besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines TextStream-Objekts.
Zeichenfolge | Optional. Text, der in die Datei geschrieben werden soll. Ohne Angabe wird ein Zeilenumbruchzeichen in die Datei geschrieben.

Hinweise
Das folgende Beispiel zeigt die Verwendung der WriteLine-Methode:
Function ZeileInDateiSchreiben
  Const ForReading = 1, ForWriting = 2
  Dim fso, f
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.OpenTextFile("c:\test.txt", ForWriting, True)
  f.WriteLine "Hallo Welt!"
  f.WriteLine "VBScript macht Spaß!"
  Set f = fso.OpenTextFile("c:\test.txt", ForReading)
  ZeileInDateiSchreiben = f.ReadAll
End Function


WriteLine-Methode

WriteLine-Methode
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


WriteLine-Methode

WriteLine-Methode
Siehe auch 		Scripting-Laufzeitreferenz

Close-Methode
Read-Methode
ReadAll-Methode
ReadLine-Methode
Skip-Methode
SkipLine-Methode
Write-Methode
WriteBlankLines-Methode


Class-Objekt

Class-Objekt 		Sprachverzeichnis
Version 5

Siehe auch Ereignisse

Beschreibung
Das Objekt, das mithilfe der Class-Anweisung erstellt wird. Gewährt Zugriff auf die Ereignisse der Klasse.
Hinweise
Sie können eine Variable nicht explizit zu einem Class-Typ deklarieren. Bei VBScript wird unter dem Begriff Klassenobjekt ein beliebiges Objekt verstanden, das mithilfe der Class-Anweisung von VBScript festgelegt wurde.

Nachdem Sie eine Klassendefinition mithilfe der Class-Anweisung erstellt haben, können Sie eine Instanz dieser Klasse mit der folgenden Formel erstellen:

Dim X
Set X = New Klassenname
Da VBScript eine late-bound-Sprache (Bindung erfolgt zur Laufzeit) ist, können Sie folgende Aktionen nicht durchführen:

Dim X as New Klassenname
oder
Dim X
X = New Klassenname
oder
Set X = New Scripting.FileSystemObject


Class-Objekt

Class-Objekt
Siehe auch 		Sprachverzeichnis

Class-Anweisung
Dim-Anweisung
Set-Anweisung


Class-Objekt

Class-Objekt
Ereignisse 		Sprachverzeichnis

Initialize-Ereignis
Terminate-Ereignis


Dictionary-Objekt

Dictionary-Objekt 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Eigenschaften Methoden

Beschreibung
Ein Objekt, das Element/Schlüssel-Paare speichert.
Hinweise
Ein Dictionary-Objekt ist vergleichbar mit einem assoziativen Datenfeld in PERL. Einträge, die aus beliebigen Daten bestehen können, werden in einem Datenfeld gespeichert. Jeder Eintrag wird mit einem eindeutigen Schlüssel verbunden. Der Schlüssel wird zum Auslesen eines einzelnen Eintrags verwendet und ist gewöhnlich ein ganzzahliger Wert oder eine Zeichenfolge, kann aber jeden Datentyp (außer Datenfeld) haben.

Der folgende Code veranschaulicht die Verwendung eines Dictionary-Objekts:

Dim d                  ' Erstellt eine Variable.
Set d = CreateObject("Scripting.Dictionary")
d.Add "a", "Athen"     ' Fügt einige Schlüssel und Elemente hinzu.
d.Add "b", "Belgrad"
d.Add "c", "Chicago"
...


Dictionary-Objekt

Dictionary-Objekt
Siehe auch 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt
TextStream-Objekt


Dictionary-Objekt

Dictionary-Objekt
Methoden 		Scripting-Laufzeitreferenz

Add-Methode (Dictionary)
Exists-Methode
Items-Methode
Keys-Methode
Remove-Methode
RemoveAll-Methode


Dictionary-Objekt

Dictionary-Objekt
Eigenschaften 		Scripting-Laufzeitreferenz

CompareMode-Eigenschaft
Count-Eigenschaft
Item-Eigenschaft
Key-Eigenschaft


Drive-Objekt

Drive-Objekt 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Bietet Zugriff auf die Eigenschaften einer bestimmten Festplatten- oder Netzwerkfreigabe.
Hinweise
Der folgende Code veranschaulicht die Verwendung des Drive-Objekts, um auf die Laufwerkeigenschaften zuzugreifen:
Function FreienLaufwerkspeicherAnzeigen(LWPfad)
  Dim fso, l, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set l = fso.GetDrive(fso.GetDriveName(LWPfad))
  s = "Laufwerk " & UCase(LWPfad) & " - "
  s = s & l.VolumeName  & "<BR>"
  s = s & "Freier Speicherplatz: " & FormatNumber(l.FreeSpace/1024, 0)
  s = s & " KB"
  FreienLaufwerkspeicherAnzeigen = s
End Function


Drive-Objekt

Drive-Objekt
Siehe auch 		Scripting-Laufzeitreferenz

Drives-Auflistung
File-Objekt
Files-Auflistung
Folder-Objekt
Folders-Auflistung
GetDrive-Methode


Drive-Objekt

Drive-Objekt
Methoden 		Scripting-Laufzeitreferenz

Das Drive-Objekt besitzt keine Methoden.


Drive-Objekt

Drive-Objekt
Eigenschaften 		Scripting-Laufzeitreferenz

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


Err-Objekt

Err-Objekt 		Sprachverzeichnis
Version 1

Siehe auch Eigenschaften Methoden

Beschreibung
Enthält Informationen zu Laufzeitfehlern. Akzeptiert die Methoden Raise und Clear zum Auslösen und Löschen von Laufzeitfehlern.
Hinweise
Das Err-Objekt ist ein integriertes Objekt mit globalem Gültigkeitsbereich. Sie müssen keine Instanz dieses Objekts in Ihrem Code erstellen. Die Eigenschaften des Err-Objekts werden durch den Auslöser eines Fehlers festgelegt: Visual Basic, ein Automatisierungsobjekt oder der VBScript-Programmierer.

Die Standardeigenschaft des Err-Objekts ist Number. Err.Number enthält eine Ganzzahl und kann in einem Automatisierungsobjekt verwendet werden, um einen SCODE zurückzugeben.

Tritt ein Laufzeitfehler auf, werden die Eigenschaften des Err-Objekts mit Informationen gefüllt, die den Fehler eindeutig identifizieren und zur Bearbeitung des Fehlers verwendet werden können. Mit der Raise-Methode können Sie einen Laufzeitfehler in Ihrem Code auslösen.

Die Eigenschaften des Err-Objekts werden auf Null oder Zeichenfolgen mit Nulllänge ("") zurückgesetzt, nachdem eine On Error Resume Next-Anweisung innerhalb einer Fehlerbehandlungsroutine auftritt. Die Clear-Methode kann verwendet werden, um Err explizit zurückzusetzen.

Das folgende Beispiel veranschaulicht die Verwendung des Err-Objekts:

On Error Resume Next
Err.Raise 6  ' Erzeugt einen Überlauffehler.
MsgBox ("Fehler Nr. " & CStr(Err.Number) & " " & Err.Description)
Err.Clear    ' Löscht die Fehlermeldung.


Err-Objekt

Err-Objekt
Siehe auch 		Sprachverzeichnis

Fehlermeldungen
On Error-Anweisung


Err-Objekt

Err-Objekt
Methoden 		Sprachverzeichnis

Clear-Methode
Raise-Methode


Err-Objekt

Err-Objekt
Eigenschaften 		Sprachverzeichnis

Description-Eigenschaft
HelpContext-Eigenschaft
HelpFile-Eigenschaft
Number-Eigenschaft
Source-Eigenschaft


File-Objekt

File-Objekt 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Bietet Zugriff auf alle Eigenschaften einer Datei.
Hinweise
Der folgende Code veranschaulicht das Abrufen eines File-Objekts und das Anzeigen seiner Eigenschaften.
Function ErstellungsdatumAnzeigen(Dateiangabe)
  Dim fso, d
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetFile(Dateiangabe)
   ErstellungsdatumAnzeigen = d.DateCreated
End Function


File-Objekt

File-Objekt
Siehe auch 		Scripting-Laufzeitreferenz

Drive-Objekt
Drives-Auflistung
Files-Auflistung
Folder-Objekt
Folders-Auflistung


File-Objekt

File-Objekt
Methoden 		Scripting-Laufzeitreferenz

Copy-Methode
Delete-Methode
Move-Methode
OpenAsTextStream-Methode


File-Objekt

File-Objekt
Eigenschaften 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
Type-Eigenschaft


FileSystemObject-Objekt

FileSystemObject-Objekt 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Eigenschaften Methoden

Beschreibung
Ermöglicht den Zugriff auf das Dateisystem des Computers.
Hinweise
Der folgende Code veranschaulicht die Verwendung des FileSystemObject-Objekts, um ein TextStream-Objekt zurückzugeben, auf das geschrieben werden kann:
Dim fso, MeineDatei
Set fso = CreateObject("Scripting.FileSystemObject")
Set MeineDatei = fso.CreateTextFile("c:\test.txt", True)
MeineDatei.WriteLine("Dies ist ein Test.")
MeineDatei.Close
Im Codebeispiel weiter oben gibt die CreateObject-Funktion das FileSystemObject-Objekt (fso) zurück. Die CreateTextFile-Methode erstellt anschließend eine Datei als TextStream-Objekt (MeineDatei), und die WriteLine-Methode schreibt eine Textzeile in die erstellte Textdatei. Die Close-Methode leert den Puffer und schließt die Datei.


FileSystemObject-Objekt

FileSystemObject-Objekt
Siehe auch 		Scripting-Laufzeitreferenz

CreateObject-Funktion
Dictionary-Objekt
Drive-Objekt
Drives-Auflistung
File-Objekt
FileSystem-Eigenschaft
Files-Auflistung
Folder-Objekt
Folders-Auflistung
TextStream-Objekt


FileSystemObject-Objekt

FileSystemObject-Objekt
Methoden 		Scripting-Laufzeitreferenz

BuildPath-Methode
CopyFile-Methode
CopyFolder-Methode
CreateFolder-Methode
CreateTextFile-Methode
DeleteFile-Methode
DeleteFolder-Methode
DriveExists-Methode
FileExists-Methode
FolderExists-Methode
GetAbsolutePathName-Methode
GetBaseName-Methode
GetDrive-Methode
GetDriveName-Methode
GetExtensionName-Methode
GetFile-Methode
GetFileName-Methode
GetFolder-Methode
GetParentFolderName-Methode
GetSpecialFolder-Methode
GetTempName-Methode
MoveFile-Methode
MoveFolder-Methode
OpenTextFile-Methode


FileSystemObject-Objekt

FileSystemObject-Objekt
Eigenschaften 		Scripting-Laufzeitreferenz

Drives-Eigenschaft


Folder-Objekt

Folder-Objekt 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Eigenschaften Methoden

Beschreibung
Bietet Zugriff auf alle Eigenschaften eines Ordners.
Hinweise
Der folgende Code veranschaulicht das Abrufen eines Folder-Objekts und das Zurückgeben einer seiner Eigenschaften:
Function ErstellungsdatumAnzeigen(Ordnerangabe)
  Dim fso, o
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set o = fso.GetFolder(Ordnerangabe)
  ErstellungsdatumAnzeigen = o.DateCreated
End Function


Folder-Objekt

Folder-Objekt
Siehe auch 		Scripting-Laufzeitreferenz

Drive-Objekt
Drives-Auflistung
File-Objekt
Files-Auflistung
Folders-Auflistung


Folder-Objekt

Folder-Objekt
Methoden 		Scripting-Laufzeitreferenz

Copy-Methode
Delete-Methode
Move-Methode
CreateTextFile-Methode


Folder-Objekt

Folder-Objekt
Eigenschaften 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Match-Objekt

Match-Objekt 		Sprachverzeichnis
Version 5

Siehe auch Eigenschaften

Beschreibung
Bietet Zugriff auf die schreibgeschützten Eigenschaften einer Suche mit regulärem Ausdruck.
Hinweise
Ein Match-Objekt kann nur mithilfe der Execute-Methode des RegExp-Objekts erstellt werden, wodurch eigentlich eine Auflistung von Match-Objekten zurückgegeben wird. Alle Eigenschaften von Match-Objekten sind schreibgeschützt.

Wird ein regulärer Ausdruck ausgeführt, werden keine oder mehr Match-Objekte ausgegeben. Jedes Match-Objekt gewährt Zugriff auf eine mit regulärem Ausdruck gefundene Zeichenfolge, deren Länge sowie auf den Index, an dem die Entsprechung gefunden wurde.

Der folgende Code veranschaulicht die Verwendung des Match-Objekts:

Function RegAusdrTest(Suchmuster, Zeichenfolge)
  Dim regAusdr, Uebereinstimmung, Uebereinstimmungen, Rueckgabe		' Variablen erstellen.
  Set regAusdr = New RegExp			' Erstellt einen regulären Ausdruck.
  regAusdr.Pattern = Suchmuster			' Legt das Suchmuster fest.
  regAusdr.IgnoreCase = True			' Ignoriert die Schreibweise.
  regAusdr.Global = True				' Legt globales Anwenden fest.
  Set Uebereinstimmungen = regAusdr.Execute(Zeichenfolge)	' Führt die Suche aus.
  For Each Uebereinstimmung in Uebereinstimmungen		' Durchläuft die Auflistung der Übereinstimmungen.
    Rueckgabe = Rueckgabe & "Entsprechung " & I & " gefunden bei "
    Rueckgabe = Rueckgabe & Uebereinstimmung.FirstIndex & ". Wert ist '"
    Rueckgabe = Rueckgabe & Uebereinstimmung.Value & "'." & vbCRLF
  Next
  RegAusdrTest = Rueckgabe
End Function

MsgBox(RegAusdrTest ("is.", "IS1 is2 IS3 is4"))


Match-Objekt

Match-Objekt
Siehe auch 		Sprachverzeichnis

Matches-Auflistung
RegExp-Objekt


Match-Objekt

Match-Objekt
Eigenschaften 		Sprachverzeichnis

FirstIndex-Eigenschaft
Length-Eigenschaft
Value-Eigenschaft


RegExp-Objekt

RegExp-Objekt 		Sprachverzeichnis
Version 5

Siehe auch Methoden Eigenschaften

Beschreibung
Bietet Unterstützung einfacher regulärer Ausdrücke.
Hinweise
Der folgende Code veranschaulicht die Verwendung des RegExp-Objekts:

Function RegAusdrTest(Suchmuster, Zeichenfolge)
  Dim regAusdr, Uebereinstimmung, Uebereinstimmungen, Rueckgabe		' Erstellt Variablen.
  Set regAusdr = New RegExp			' Erstellt einen regulären Ausdruck.
  regAusdr.Pattern = Suchmuster			' Setzt das Muster.
  regAusdr.IgnoreCase = True			' Ignoriert die Schreibweise.
  regAusdr.Global = True				' Legt globales Anwenden fest.
  Set Uebereinstimmungen = regAusdr.Execute(Zeichenfolge)	' Führt die Suche aus.
  For Each Uebereinstimmung in Uebereinstimmungen		' Durchläuft die Auflistung der Übereinstimmungen.
    Rueckgabe = Rueckgabe & "Entsprechung gefunden bei "
    Rueckgabe = Rueckgabe & Uebereinstimmung.FirstIndex & ". Wert ist '"
    Rueckgabe = Rueckgabe & Uebereinstimmung.Value & "'." & vbCRLF
  Next
  RegAusdrTest = Rueckgabe
End Function

MsgBox(RegAusdrTest("is.", "IS1 is2 IS3 is4"))


RegExp-Objekt

RegExp-Objekt
Siehe auch 		Sprachverzeichnis

Match-Objekt
Matches-Auflistung


RegExp-Objekt

RegExp-Objekt
Methoden 		Sprachverzeichnis

Execute-Methode
Replace-Methode
Test-Methode


RegExp-Objekt

RegExp-Objekt
Eigenschaften 		Sprachverzeichnis

Global-Eigenschaft
IgnoreCase-Eigenschaft
Pattern-Eigenschaft


TextStream-Objekt

TextStream-Objekt 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Eigenschaften Methoden

Beschreibung
Erleichtert den sequenziellen Zugriff auf eine Datei.
Hinweise
Im folgenden Code ist MeineDatei das TextStream-Objekt, das von der CreateTextFile-Methode beim Ausführen auf dem FileSystemObject-Objekt zurückgegeben wird:
Dim fso, MeineDatei
Set fso = CreateObject("Scripting.FileSystemObject")
Set MeineDatei = fso.CreateTextFile("c:\testfile.txt", True)
MeineDatei.WriteLine("Dies ist ein Test.")
MeineDatei.Close
WriteLine und Close sind zwei Methoden des TextStream-Objekts.


TextStream-Objekt

TextStream-Objekt
Siehe auch 		Scripting-Laufzeitreferenz

Dictionary-Objekt
FileSystemObject-Objekt


TextStream-Objekt

TextStream-Objekt
Methoden 		Scripting-Laufzeitreferenz

Close-Methode
Read-Methode
ReadAll-Methode
ReadLine-Methode
Skip-Methode
SkipLine-Methode
Write-Methode
WriteLine-Methode
WriteBlankLines-Methode


TextStream-Objekt

TextStream-Objekt
Eigenschaften 		Scripting-Laufzeitreferenz

AtEndOfLine-Eigenschaft
AtEndOfStream-Eigenschaft
Column-Eigenschaft
Line-Eigenschaft


Additionsoperator (+)

Additionsoperator (+) 		Scripting-Laufzeitreferenz
Version 1

Siehe auch

Beschreibung
Addiert zwei Zahlen miteinander.
Syntax
Ergebnis = Ausdruck1 + Ausdruck2

Die Syntax des Additionsoperators (+) besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Ausdruck1 | Beliebiger Ausdruck.
Ausdruck2 | Beliebiger Ausdruck.

Hinweise
Sie können den Operator + auch zum Verketten zweier Zeichenfolgen verwenden, sollten dazu aber vorzugsweise den Operator & verwenden. Dadurch schließen Sie Mehrdeutigkeiten aus und erstellen Code, der sich selbst dokumentiert.

Wenn Sie den Operator + verwenden, können Sie nicht immer bestimmen, ob eine Addition oder eine Zeichenverkettung erfolgt.

Die zugrunde liegenden Untertypen der Ausdrücke bestimmen das Verhalten des Operators + auf folgende Weise:

Wenn | Ergebnis
Beide Ausdrücke numerisch sind | Addition
Beide Ausdrücke Zeichenfolgen sind | Verkettung
Ein Ausdruck numerisch, der andere eine Zeichenfolge ist | Addition

Handelt es sich bei einem oder beiden Ausdrücken um Null-Ausdrücke, ist Ergebnis gleich Null. Sind beide Ausdrücke Empty, ist Ergebnis ein Integer-Untertyp. Ist jedoch nur ein Ausdruck Empty, wird der andere Ausdruck unverändert als Ergebnis zurückgegeben.


Additionsoperator (+)

Additionsoperator (+)
Siehe auch 		Scripting-Laufzeitreferenz

Arithmetische Operatoren
Minusoperator (-)
Operatoren: Zusammenfassung
Operatorvorrang
Verkettungsoperator (&)
Verkettungsoperatoren


And-Operator

And-Operator 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine logische Konjunktion zweier Ausdrücke durch.
Syntax
Ergebnis = Ausdruck1 And Ausdruck2

Die Syntax des And-Operators besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Ausdruck1 | Beliebiger Ausdruck
Ausdruck2 | Beliebiger Ausdruck.

Hinweise
Das Argument Ergebnis ist nur dann True, wenn tatsächlich beide Ausdrücke True sind. Sobald einer der beiden Ausdrücke False ist, ist das Ergebnis ebenfalls False. Die folgende Tabelle zeigt, wie Ergebnis festgelegt wird:

Ist Ausdruck1 | und ist Ausdruck2 | Dann ist Ergebnis
True | True | True
True | False | False
True | Null | Null
False | True | False
False | False | False
False | Null | False
Null | True | Null
Null | False | False
Null | Null | Null

Der Operator And führt darüber hinaus einen bitweisen Vergleich gleich positionierter Bits in zwei numerischen Ausdrücken durch und setzt das zugehörige Bit in Ergebnis gemäß der folgenden Tabelle:

Ist Bit in Ausdruck1 | Und ist Bit in Ausdruck2 | Dann ist Bit in Ergebnis
0 | 0 | 0
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1


And-Operator

And-Operator
Siehe auch 		Sprachverzeichnis

Logische Operatoren
Not-Operator
Operatoren: Zusammenfassung
Operatorvorrang
Or-Operator
Xor-Operator


Zuweisungsoperator (=)

Zuweisungsoperator (=) 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Weist einer Variablen oder einer Eigenschaft einen Wert zu.
Syntax
Variable = Wert

Die Syntax des Zuweisungsoperators (=) besteht aus folgenden Teilen:

Teil | Beschreibung
Variable | Jede Variable oder schreibbare Eigenschaft.
Wert | Jedes numerische- oder Zeichenfolgenliteral, jede Konstante, oder jeder Ausdruck.

Hinweise
Bei dem Namen links des Gleichheitszeichens kann es sich um einfache skalierbare Variablen oder Elemente eines Datenfeldes handeln. Bei Eigenschaften auf der linken Seite des Gleichheitszeichens kann es sich nur um solche handeln, die bei Laufzeit nicht schreibgeschützt sind.


Zuweisungsoperator (=)

Zuweisungsoperator (=)
Siehe auch 		Sprachverzeichnis

Operatoren: Zusammenfassung
Operatorvorrang
Set-Anweisung
Vergleichsoperatoren


Verkettungsoperator (&)

Verkettungsoperator (&) 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Erzwingt eine Zeichenfolgenverkettung zweier Ausdrücke.
Syntax
Ergebnis = Ausdruck1 & Ausdruck2

Die Syntax des Verkettungsoperators (&) besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige Variable
Ausdruck1 | Beliebiger Ausdruck
Ausdruck2 | Beliebiger Ausdruck.

Hinweise
Wenn es sich bei Ausdruck nicht um eine Zeichenfolge handelt, wird diese in einen String-Untertyp konvertiert. Sind beide Ausdrücke Null, ist Ergebnis ebenfalls Null. Ist jedoch lediglich ein Ausdruck gleich Null, wird dieser Ausdruck bei einer Verkettung mit dem anderen Ausdruck als Nulllängenzeichenfolge ("") behandelt. Ausdrücke, die Empty sind, werden ebenfalls als Nulllängenzeichenfolgen behandelt.


Verkettungsoperator (&)

Verkettungsoperator (&)
Siehe auch 		Sprachverzeichnis

Operatoren: Zusammenfassung
Operatorvorrang
Verkettungsoperatoren


Divisionsoperator (/)

Divisionsoperator (/) 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Dividiert zwei Zahlen und gibt ein Fließkommaergebnis zurück.
Syntax
Ergebnis = Zahl1 / Zahl2

Die Syntax des Divisionsoperator (/) besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Zahl1 | Beliebiger numerischer Ausdruck
Zahl2 | Beliebiger numerischer Ausdruck.

Hinweise
Handelt es sich bei einem oder beiden Ausdrücken um Null-Ausdrücke, ist Ergebnis gleich Null. Ausdrücke, die Empty sind, werden als 0 interpretiert.


Divisionsoperator (/)

Divisionsoperator (/)
Siehe auch 		Sprachverzeichnis

Arithmetische Operatoren
Ganzzahl-Divisionsoperator (\)
Multiplikationsoperator (*)
Operatoren: Zusammenfassung
Operatorvorrang


Eqv-Operator

Eqv-Operator 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine logische Äquivalenz auf zwei Ausdrücken aus.
Syntax
Ergebnis = Ausdruck1 Eqv Ausdruck2

Die Syntax des Eqv-Operators besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Ausdruck1 | Beliebiger Ausdruck
Ausdruck2 | Beliebiger Ausdruck.

Hinweise
Hat einer der beiden Ausdrücke den Wert Null, ist Ergebnis ebenfalls Null. Ist keiner der Ausdrücke Null, ist das jeweilige Ergebnis der folgenden Tabelle zu entnehmen:

Ist Ausdruck1 | und ist Ausdruck2 | Dann ist Ergebnis
True | True | True
True | False | False
False | True | False
False | False | True

Der Operator Eqv führt darüber hinaus einen bitweisen Vergleich gleich positionierter Bits in zwei numerischen Ausdrücken durch und setzt das zugehörige Bit in Ergebnis gemäß der folgenden Tabelle:

Ist Bit in Ausdruck1 | Und ist Bit in Ausdruck2 | Dann ist Bit in Ergebnis
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1


Eqv-Operator

Eqv-Operator
Siehe auch 		Sprachverzeichnis

Imp-Operator
Logische Operatoren
Operatoren: Zusammenfassung
Operatorvorrang


Exponentialoperator (^)

Exponentialoperator (^) 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Erhebt eine Zahl zur Potenz eines Exponenten.
Syntax
Ergebnis = Zahl^Exponent

Die Syntax des Exponentialoperators (^) besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Zahl | Beliebiger numerischer Ausdruck
Exponent | Beliebiger numerischer Ausdruck.

Hinweise
Zahl kann nur einen negativen Wert haben, wenn Exponent ein Ganzzahlwert ist. Werden mehrere Potenzierungen in einem einzigen Ausdruck durchgeführt, werden die ^ Operatoren nacheinander von links nach rechts ausgewertet.

Handelt es sich bei Zahl oder Exponent um Null-Ausdrücke, ist Ergebnis ebenfalls Null.


Exponentialoperator (^)

Exponentialoperator (^)
Siehe auch 		Sprachverzeichnis

Arithmetische Operatoren
Operatoren: Zusammenfassung
Operatorvorrang


Imp-Operator

Imp-Operator 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine logische Implikation auf zwei Ausdrücken durch.
Syntax
Ergebnis = Ausdruck1 Imp Ausdruck2

Die Syntax des Imp-Operators besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Ausdruck1 | Beliebiger Ausdruck
Ausdruck2 | Beliebiger Ausdruck.

Hinweise
Die folgende Tabelle zeigt, wie Ergebnis festgelegt wird:

Ist Ausdruck1 | und ist Ausdruck2 | Dann ist Ergebnis
True | True | True
True | False | False
True | Null | Null
False | True | True
False | False | True
False | Null | True
Null | True | True
Null | False | Null
Null | Null | Null

Der Imp-Operator führt einen bitweisen Vergleich gleich positionierter Bits in zwei numerischen Ausdrücken durch und setzt das zugehörige Bit in Ergebnis gemäß der folgenden Tabelle:

Ist Bit in Ausdruck1 | Und ist Bit in Ausdruck2 | Dann ist Bit in Ergebnis
0 | 0 | 1
0 | 1 | 1
1 | 0 | 0
1 | 1 | 1


Imp-Operator

Imp-Operator
Siehe auch 		Sprachverzeichnis

Eqv-Operator
Logische Operatoren
Operatoren: Zusammenfassung
Operatorvorrang


Ganzzahl-Divisionsoperator (\)

Ganzzahl-Divisionsoperator (\) 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Dividiert zwei Zahlen miteinander und gibt das Ergebnis als Ganzzahl zurück.
Syntax
Ergebnis = Zahl1\Zahl2

Die Syntax des Ganzzahl-Divisionsoperators (\) besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Zahl1 | Beliebiger numerischer Ausdruck
Zahl2 | Beliebiger numerischer Ausdruck.

Hinweise
Vor einer Division werden numerische Ausdrücke auf Byte-, Integer- oder Long-Untertypenausdrücke gerundet.

Ist einer der Ausdrücke gleich Null, ist Ergebnis ebenfalls Null. Ausdrücke, die Empty sind, werden als 0 interpretiert.


Ganzzahl-Divisionsoperator (\)

Ganzzahl-Divisionsoperator (\)
Siehe auch 		Sprachverzeichnis

Arithmetische Operatoren
Divisionsoperator (/)
Multiplikationsoperator (*)
Operatoren: Zusammenfassung
Operatorvorrang


Is-Operator

Is-Operator 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Vergleicht zwei Objektverweisvariablen miteinander.
Syntax
Ergebnis = Objekt1 Is Objekt2

Die Syntax des Is-Operators besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Objekt1 | Beliebiger Objektname.
Objekt2 | Beliebiger Objektname.

Hinweise
Wenn sowohl Objekt1 als auch Objekt2 auf dasselbe Objekt verweisen, ist das Ergebnis True, andernfalls ist Ergebnis False. Zwei Variablen können auf mehrere Arten auf dasselbe Objekt verweisen.

Im folgenden Beispiel verweist A nach der Zuweisung auf dasselbe Objekt wie B:

Set A = B
Nach den folgenden Zuweisungen verweisen A und B auf dasselbe Objekt wie C:
Set A = C
Set B = C


Is-Operator

Is-Operator
Siehe auch 		Sprachverzeichnis

Operatoren: Zusammenfassung
Operatorvorrang
Vergleichsoperatoren


Mod-Operator

Mod-Operator 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Dividiert zwei Zahlen und gibt nur den Rest zurück.
Syntax
Ergebnis = Zahl1 Mod Zahl2

Die Syntax des Mod-Operators besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Zahl1 | Beliebiger numerischer Ausdruck
Zahl2 | Beliebiger numerischer Ausdruck.

Hinweise
Der Modulo-Operator (oder Rest-Operator) dividiert Zahl1 durch Zahl2, rundet dabei Fließkommawerte in ganze Zahlen und gibt den Rest als Ergebnis zurück. Das Ergebnis des folgenden Ausdruckes (A) ist zum Beispiel 5.
A = 19 Mod 6.7
Ist einer der Ausdrücke gleich Null, ist Ergebnis ebenfalls Null. Ausdrücke, die Empty sind, werden als 0 interpretiert.


Mod-Operator

Mod-Operator
Siehe auch 		Sprachverzeichnis

Arithmetische Operatoren
Operatoren: Zusammenfassung
Operatorvorrang


Multiplikationsoperator (*)

Multiplikationsoperator (*) 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Multipliziert zwei Zahlen miteinander.
Syntax
Ergebnis = Zahl1*Zahl2

Die Syntax des Multiplikationsoperators (*) besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Zahl1 | Beliebiger numerischer Ausdruck
Zahl2 | Beliebiger numerischer Ausdruck.

Hinweise
Handelt es sich bei einem oder beiden Ausdrücken um Null-Ausdrücke, ist Ergebnis gleich Null. Ist einer der beiden Ausdrücke Empty, wird dieser als 0 interpretiert.


Multiplikationsoperator (*)

Multiplikationsoperator (*)
Siehe auch 		Sprachverzeichnis

Arithmetische Operatoren
Ganzzahl-Divisionsoperator (\)
Operatoren: Zusammenfassung
Operatorvorrang


Not-Operator

Not-Operator 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine logische Negation auf einem Ausdruck durch.
Syntax
Ergebnis = Not Ausdruck

Die Syntax des Not-Operators besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Ausdruck | Beliebiger Ausdruck

Hinweise
Die folgende Tabelle zeigt, wie Ergebnis festgelegt wird:

Ist Ausdruck | Dann ist Ergebnis
True | False
False | True
Null | Null

Darüber hinaus invertiert der Not-Operator die einzelnen Bits einer (beliebigen) Variablen und legt die jeweiligen Bits in Ergebnis gemäß der folgenden Tabelle fest:

Ist Bit in Ausdruck | Dann ist Bit in Ergebnis
0 | 1
1 | 0


Not-Operator

Not-Operator
Siehe auch 		Sprachverzeichnis

And-Operator
Logische Operatoren
Operatoren: Zusammenfassung
Operatorvorrang
Or-Operator
Xor-Operator


Or-Operator

Or-Operator 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine logische Disjunktion auf zwei Ausdrücken durch.
Syntax
Ergebnis = Ausdruck1 Or Ausdruck2

Die Syntax des Or-Operators besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Ausdruck1 | Beliebiger Ausdruck
Ausdruck2 | Beliebiger Ausdruck.

Hinweise
Ist einer der beiden Ausdrücke True, ist das Ergebnis ebenfalls True. Die folgende Tabelle zeigt, wie Ergebnis festgelegt wird:

Ist Ausdruck1 | und ist Ausdruck2 | Dann ist Ergebnis
True | True | True
True | False | True
True | Null | True
False | True | True
False | False | False
False | Null | Null
Null | True | True
Null | False | Null
Null | Null | Null

Der Or-Operator führt darüber hinaus einen bitweisen Vergleich gleich positionierter Bits in zwei numerischen Ausdrücken durch und setzt das zugehörige Bit in Ergebnis gemäß der folgenden Tabelle:

Ist Bit in Ausdruck1 | Und ist Bit in Ausdruck2 | Dann ist Bit in Ergebnis
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 1


Or-Operator

Or-Operator
Siehe auch 		Sprachverzeichnis

And-Operator
Logische Operatoren
Not-Operator
Operatoren: Zusammenfassung
Operatorvorrang
Xor-Operator


Minusoperator (-)

Minusoperator (-) 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Ermittelt die Differenz zwischen zwei Zahlen oder gibt den negativen Wert eines numerischen Ausdruckes an.
Syntax 1
Ergebnis = Zahl1-Zahl2
Syntax 2
-Zahl

Die Syntax des Minusoperators (-) besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Zahl | Beliebiger numerischer Ausdruck
Zahl1 | Beliebiger numerischer Ausdruck.
Zahl2 | Beliebiger numerischer Ausdruck.

Hinweise
Bei Syntax 1 wird der Minusoperator zur Bestimmung der Differenz zweier Zahlen durch arithmetische Subtraktion eingesetzt. Bei Syntax 2 wird der Minusoperator als unärer Negationsoperator zur Anzeige des negativen Wertes eines Ausdruckes verwendet.

Handelt es sich bei einem oder beiden Ausdrücken um Null-Ausdrücke, ist Ergebnis gleich Null. Ist einer der beiden Ausdrücke Empty, wird dieser als 0 interpretiert.


Minusoperator (-)

Minusoperator (-)
Siehe auch 		Sprachverzeichnis

Additionsoperator (+)
Arithmetische Operatoren
Operatoren: Zusammenfassung
Operatorvorrang


Xor-Operator

Xor-Operator 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt einen logischen Ausschluss auf zwei Ausdrücken durch.
Syntax
Ergebnis = Ausdruck1 Xor Ausdruck2

Die Syntax des Xor-Operators besteht aus folgenden Teilen:

Teil | Beschreibung
Ergebnis | Beliebige numerische Variable.
Ausdruck1 | Beliebiger Ausdruck
Ausdruck2 | Beliebiger Ausdruck.

Hinweise
Ist genau ein einziger Ausdruck True, ist das Ergebnis ebenfalls True. Ist jedoch einer der beiden Ausdrücke Null, ist Ergebnis ebenfalls Null. Ist keiner der Ausdrücke Null, ist das jeweilige Ergebnis der folgenden Tabelle zu entnehmen:

Ist Ausdruck1 | und ist Ausdruck2 | Dann ist Ergebnis
True | True | False
True | False | True
False | True | True
False | False | False

Der Xor-Operator führt darüber hinaus einen bitweisen Vergleich gleich positionierter Bits in zwei numerischen Ausdrücken durch und setzt das zugehörige Bit in Ergebnis gemäß der folgenden Tabelle:

Ist Bit in Ausdruck1 | Und ist Bit in Ausdruck2 | Dann ist Bit in Ergebnis
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0


Xor-Operator

Xor-Operator
Siehe auch 		Sprachverzeichnis

And-Operator
Logische Operatoren
Not-Operator
Operatoren: Zusammenfassung
Operatorvorrang
Or-Operator


AtEndOfLine-Eigenschaft

AtEndOfLine-Eigenschaft 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn sich der Dateizeiger unmittelbar vor einer Zeilenendemarkierung einer TextStream-Datei befindet, andernfalls False. Schreibgeschützt.
Syntax
Objekt.AtEndOfLine

Objekt ist stets der Name eines TextStream-Objekts.

Hinweise
Die AtEndOfLine-Eigenschaft kann nur auf TextStream-Dateien, die zum Lesen geöffnet sind, angewendet werden, andernfalls tritt ein Fehler auf.

Der folgende Code zeigt die Verwendung der AtEndOfLine-Eigenschaft:

Function GanzeZeileLesen(Dateiangabe)
  Const ForReading = 1
  Dim fso, DieDatei, Rueckgabe
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set DieDatei = fso.OpenTextFile(Dateiangabe, ForReading, False)
  Do While DieDatei.AtEndOfLine <> True
    Rueckgabe = Rueckgabe & DieDatei.Read(1)
  Loop
  DieDatei.Close
  GanzeZeileLesen = Rueckgabe
End Function


AtEndOfLine-Eigenschaft

AtEndOfLine-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


AtEndOfLine-Eigenschaft

AtEndOfLine-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AtEndOfStream-Eigenschaft
Column-Eigenschaft
Line-Eigenschaft


AtEndOfStream-Eigenschaft

AtEndOfStream-Eigenschaft 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn sich der Dateizeiger am Ende einer TextStream-Datei befindet, andernfalls False. Schreibgeschützt.
Syntax
Objekt.AtEndOfStream

Objekt ist stets der Name eines TextStream-Objekts.

Hinweise
Die Eigenschaft AtEndOfStream kann nur auf TextStream-Dateien, die zum Lesen geöffnet sind, angewendet werden, andernfalls tritt ein Fehler auf.

Der folgende Code veranschaulicht die Verwendung der AtEndOfStream-Eigenschaft:

Function GanzeDateiLesen(Dateiangabe)
  Const ForReading = 1
  Dim fso, DieDatei, Rueckgabe
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set DieDatei = fso.OpenTextFile(Dateiangabe, ForReading, False)
  Do While DieDatei.AtEndOfStream <> True
    Rueckgabe = Rueckgabe & DieDatei.ReadLine
  Loop
  DieDatei.Close
  GanzeDateiLesen = Rueckgabe
End Function


AtEndOfStream-Eigenschaft

AtEndOfStream-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


AtEndOfStream-Eigenschaft

AtEndOfStream-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AtEndOfLine-Eigenschaft
Column-Eigenschaft
Line-Eigenschaft


Attributes-Eigenschaft

Attributes-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Legt die Attribute von Dateien bzw. Ordnern fest oder gibt sie zurück. Je nach Attribut Lesen/Schreiben oder schreibgeschützt.
Syntax
Objekt.Attributes [= NeueAttribute]

Die Syntax der Attributes-Eigenschaft besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines File- oder Folder-Objekts.
NeueAttribute | Optional. Falls angegeben, ist NeueAttribute der neue Wert für die Attribute des angegebenen Objekts.

Einstellungen
Das Argument NeueAttribute kann jeden der folgenden Werte bzw. beliebige sinnvolle Kombinationen der folgenden Werte aufweisen:

Konstante | Wert | Beschreibung
Normal | 0 | Normale Datei. Es sind keine Attribute gesetzt.
ReadOnly | 1 | Schreibgeschützte Datei. Für das Attribut gilt Lesen/Schreiben.
Hidden | 2 | Versteckte Datei. Für das Attribut gilt Lesen/Schreiben.
System | 4 | Systemdatei. Für das Attribut gilt Lesen/Schreiben.
Directory | 16 | Ordner oder Verzeichnis. Das Attribut ist schreibgeschützt.
Archive | 32 | Datei hat sich seit der letzten Sicherung geändert. Für das Attribut gilt Lesen/Schreiben.
Alias | 1024 | Verknüpfung oder Shortcut. Das Attribut ist schreibgeschützt.
Compressed | 2048 | Komprimierte Datei. Das Attribut ist schreibgeschützt.

Hinweise
Versuche, eines der schreibgeschützten Attribute (Alias, Compressed oder Directory) zu ändern, werden ignoriert.

Beim Festlegen von Attributen ist es im Allgemeinen ratsam, zuerst die aktuellen Attribute zu lesen, dann einzelne Attribute wie gewünscht zu ändern und am Schluss die Attribute zurück zu schreiben.

Der folgende Code veranschaulicht das Verwenden der Attributes-Eigenschaft mit einer Datei:

Function ArchiveBitAendern(Dateiangabe)
  Dim fso, d
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetFile(Dateiangabe)
  If d.attributes and 32 Then
    d.attributes = d.attributes - 32
    ArchiveBitAendern = "Archive-Bit gelöscht."
  Else
    d.attributes = d.attributes + 32
    ArchiveBitAendern = "Archive-Bit gesetzt."
  End If
End Function


Attributes-Eigenschaft

Attributes-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


Attributes-Eigenschaft

Attributes-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


AvailableSpace-Eigenschaft

AvailableSpace-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Größe des Speicherplatzes zurück, der einem Benutzer auf dem angegebenen Laufwerk bzw. Netzlaufwerk zur Verfügung steht.
Syntax
Objekt.AvailableSpace

Objekt ist stets ein Drive-Objekt.

Hinweise
Der von der AvailableSpace-Eigenschaft zurückgegebene Wert entspricht in der Regel dem von der FreeSpace-Eigenschaft zurückgegebenen Wert. Unterschiede zwischen beiden können bei Computersystemen auftreten, die Quoten unterstützen.

Der folgende Code veranschaulicht die Verwendung der AvailableSpace-Eigenschaft:

Function VerfuegbarenPlatzAnzeigen(LWPfad)
  Dim fso, d, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetDrive(fso.GetDriveName(LWPfad))
  s = "Laufwerk " & UCase(LWPfad) & " - "
  s = s & d.VolumeName  & "<BR>"
  s = s & "Verfügbarer Speicherplatz: " & FormatNumber(d.AvailableSpace/1024, 0)
  s = s & " KB"
  VerfuegbarenPlatzAnzeigen = s
End Function


AvailableSpace-Eigenschaft

AvailableSpace-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt


AvailableSpace-Eigenschaft

AvailableSpace-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


Column-Eigenschaft

Column-Eigenschaft 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Schreibgeschützte Eigenschaft, die die Spaltennummer der aktuellen Zeichenposition in einer TextStream-Datei zurückgibt.
Syntax
Objekt.Column

Objekt ist stets der Name eines TextStream-Objekts.

Hinweise
Nachdem ein Zeilenumbruchzeichen jedoch bevor ein anderes Zeichen geschrieben wird, hat Column den Wert 1.

Das folgende Beispiel veranschaulicht die Verwendung der Column-Eigenschaft:

Function HoleSpalte
  Const ForReading = 1, ForWriting = 2
  Dim fso, d, m
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.OpenTextFile("c:\test.txt", ForWriting, True)
  d.Write "Hallo Welt!"
  d.Close
  Set d = fso.OpenTextFile("c:\test.txt", ForReading)
  m =  d.ReadLine
  HoleSpalte = d.Column
End Function


Column-Eigenschaft

Column-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


Column-Eigenschaft

Column-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AtEndOfLine-Eigenschaft
AtEndOfStream-Eigenschaft
Line-Eigenschaft


CompareMode-Eigenschaft

CompareMode-Eigenschaft 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Legt den Vergleichsmodus zum Vergleich von Zeichenfolge-Schlüsseln in einem Dictionary-Objekt fest oder gibt ihn zurück.
Syntax
Objekt.CompareMode[ = Vergleich]

Die Syntax der CompareMode-Eigenschaft besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines Dictionary-Objekts.
Vergleich | Optional. Wenn angegeben, stellt Vergleich den Wert für den Vergleichsmodus dar, der von Funktionen wie StrComp verwendet wird.

Einstellungen
Das Argument Vergleich kann die folgenden Werte annehmen:

Konstante | Wert | Beschreibung
vbBinaryCompare | 0 | Führt einen binären Vergleich durch.
vbTextCompare | 1 | Führt einen Textvergleich durch.

Hinweise
Werte größer als 2 können für Verweise auf Vergleiche eingesetzt werden, die bestimmte LCIDs (Gebietsschema-IDs) verwenden. Ein Fehler tritt auf, wenn Sie den Vergleichsmodus eines Dictionary-Objekts ändern möchten, das bereits Daten enthält.

Die CompareMode-Eigenschaft verwendet die gleichen Werte wie das Argument Vergleich in der StrComp-Funktion.

Der folgende Code veranschaulicht die Verwendung der CompareMode-Eigenschaft:

Dim d
Set d = CreateObject("Scripting.Dictionary")
d.CompareMode = vbTextCompare
d.Add "a", "Athen"     ' Fügt einige Schlüssel und Elemente hinzu.
d.Add "b", "Belgrad"
d.Add "c", "Chicago"
d.Add "B", "Bonn"      ' Add-Methode funktioniert in dieser Zeile nicht,
                       ' da der Buchstabe b im Dictionary bereits belegt ist.


CompareMode-Eigenschaft

CompareMode-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Dictionary-Objekt


CompareMode-Eigenschaft

CompareMode-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Count-Eigenschaft
Item-Eigenschaft
Key-Eigenschaft


Count-Eigenschaft

Count-Eigenschaft 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Gibt die Zahl der Elemente in einer Auflistung oder in einem Dictionary-Objekt zurück. Schreibgeschützt.
Syntax
Objekt.Count

Objekt ist stets der Name eines der Elemente in der Liste "Betrifft".

Hinweise
Der folgende Code zeigt die Verwendung der Count-Eigenschaft:
Function SchluesselAnzeigen
  Dim a, d, i, s            ' Erstellt einige Variablen.
  Set d = CreateObject("Scripting.Dictionary")
  d.Add "a", "Athen"        ' Fügt einige Schlüssel und Elemente hinzu.
  d.Add "b", "Belgrad"
  d.Add "c", "Chicago"
  a = d.Keys                ' Lädt die Schlüssel.
  For i = 0 To d.Count - 1  ' Durchläuft das Datenfeld.
    s = s & a(i) & "<BR>"   ' Erstellt die Rückgabezeichenfolge.
  Next
  SchluesselAnzeigen = s
End Function


Count-Eigenschaft

Count-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Dictionary-Objekt
Drives-Auflistung
Files-Auflistung
Folders-Auflistung
Matches-Auflistung


Count-Eigenschaft

Count-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

CompareMode-Eigenschaft
Item-Eigenschaft
Key-Eigenschaft


DateCreated-Eigenschaft

DateCreated-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt Datum und Zeitpunkt zurück, an denen die angegebene Datei bzw. der angegebene Ordner erstellt wurde. Schreibgeschützt.
Syntax
Objekt.DateCreated

Objekt ist stets ein File- oder Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der DateCreated-Eigenschaft mit einer Datei:
Function DateiInfoAnzeigen(Dateiangabe)
  Dim fso, d
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetFile(Dateiangabe)
  DateiInfoAnzeigen = "Erstellt: " & d.DateCreated
End Function


DateCreated-Eigenschaft

DateCreated-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


DateCreated-Eigenschaft

DateCreated-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


DateLastAccessed-Eigenschaft

DateLastAccessed-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt Datum und Zeitpunkt zurück, an denen auf die angegebene Datei bzw. den angegebenen Ordner zuletzt zugegriffen wurde. Schreibgeschützt.
Syntax
Objekt.DateLastAccessed

Objekt ist stets ein File- oder Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der Eigenschaft DateLastAccessed-Eigenschaft mit einer Datei:
Function DateiZugriffsInfoAnzeigen(Dateiangabe)
  Dim fso, d, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetFile(Dateiangabe)
  s = UCase(Dateiangabe) & "<BR>"
  s = s & "Erstellt: " & d.DateCreated & "<BR>"
  s = s & "Letzter Zugriff: " & d.DateLastAccessed & "<BR>"
  s = s & "Letzte Änderung: " & d.DateLastModified
  DateiZugriffsInfoAnzeigen = s
End Function
Wichtig Das Verhalten dieser Methode hängt von dem verwendeten Betriebssystem ab. Unterstützt dieses keine Zeitinformationen, wird nichts zurückgegeben.


DateLastAccessed-Eigenschaft

DateLastAccessed-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


DateLastAccessed-Eigenschaft

DateLastAccessed-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


DateLastModified-Eigenschaft

DateLastModified-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt Datum und Zeitpunkt zurück, an denen die angegebene Datei bzw. der angegebene Ordner zuletzt geändert wurde. Schreibgeschützt.
Syntax
Objekt.DateLastModified

Objekt ist stets ein File- oder Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der DateLastModified-Eigenschaft mit einer Datei:
Function DateiZugriffsInfoAnzeigen(Dateiangabe)
  Dim fso, d, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetFile(Dateiangabe)
  s = UCase(Dateiangabe) & "<BR>"
  s = s & "Erstellt: " & d.DateCreated & "<BR>"
  s = s & "Letzter Zugriff: " & d.DateLastAccessed & "<BR>"
  s = s & "Letzte Änderung: " & d.DateLastModified
  DateiZugriffsInfoAnzeigen = s
End Function


DateLastModified-Eigenschaft

DateLastModified-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


DateLastModified-Eigenschaft

DateLastModified-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Description-Eigenschaft

Description-Eigenschaft 		Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt eine beschreibende Zeichenfolge zu einem Fehler zurück oder legt sie fest.
Syntax
Objekt.Description [=Zeichenfolgenausdruck]

Die Syntax der Description-Eigenschaft besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Stets das Err-Objekt.
Zeichenfolgenausdruck | Ein Zeichenfolgenausdruck, der eine Beschreibung des Fehlers enthält.

Hinweise
Die Description-Eigenschaft enthält eine Kurzbeschreibung des Fehlers. Verwenden Sie diese Eigenschaft, um den Benutzer über einen Fehler zu informieren, den Sie nicht beheben können oder möchten. Weisen Sie beim Erstellen eines benutzerdefinierten Fehlers eine Kurzbeschreibung des Fehlers dieser Eigenschaft zu. Wird Description nicht angegeben und entspricht der Number-Wert einem VBScript-Laufzeitfehler, wird die dem Fehler zugeordnete Beschreibungszeichenfolge zurückgegeben.
On Error Resume Next
Err.Raise 6  ' Erzeugt einen Überlauffehler.
MsgBox ("Fehler Nr. " & CStr(Err.Number) & ", " & Err.Description)
Err.Clear    ' Löscht den Fehler.


Description-Eigenschaft

Description-Eigenschaft
Betrifft 		Sprachverzeichnis

Err-Objekt


Description-Eigenschaft

Description-Eigenschaft
Siehe auch 		Sprachverzeichnis

Err-Objekt
HelpContext-Eigenschaft
HelpFile-Eigenschaft
Number-Eigenschaft
Source-Eigenschaft


Drive-Eigenschaft

Drive-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Buchstaben des Laufwerkes zurück, auf dem sich die angegebene Datei bzw. der angegebene Ordner befindet. Schreibgeschützt.
Syntax
Objekt.Drive

Objekt ist stets ein File- oder Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der Drive-Eigenschaft:
Function DateiZugriffsInfoAnzeigen(Dateiangabe)
  Dim fso, d, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetFile(Dateiangabe)
  s = d.Name & " auf Laufwerk " & UCase(d.Drive) & "<BR>"
  s = s & "Erstellt: " & d.DateCreated & "<BR>"
  s = s & "Letzter Zugriff: " & d.DateLastAccessed & "<BR>"
  s = s & "Letzte Änderung: " & d.DateLastModified
  DateiZugriffsInfoAnzeigen = s
End Function


Drive-Eigenschaft

Drive-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


Drive-Eigenschaft

Drive-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


DriveLetter-Eigenschaft

DriveLetter-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Laufwerkbuchstaben eines physischen lokalen Laufwerkes oder einer Netzwerkfreigabe zurück. Schreibgeschützt.
Syntax
Objekt.DriveLetter

Objekt ist stets ein Drive-Objekt.

Hinweise
Die Eigenschaft DriveLetter gibt eine Zeichenfolge der Länge Null ("") zurück, wenn das angegebene Laufwerk nicht mit einem Laufwerkbuchstaben verknüpft ist, z. B. wenn einem Netzlaufwerk kein Laufwerkbuchstabe zugeordnet wurde.

Der folgende Code veranschaulicht die Verwendung der DriveLetter-Eigenschaft:

Function LaufwerkbuchstabeAnzeigen(LWPfad)
  Dim fso, l, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set l = fso.GetDrive(fso.GetDriveName(LWPfad))
  s = "Laufwerk " & l.DriveLetter & ": - "
  s = s & l.VolumeName  & "<BR>"
  s = s & "Freier Speicherplatz: " & FormatNumber(l.FreeSpace/1024, 0)
  s = s & " KB"
  LaufwerkbuchstabeAnzeigen = s
End Function


DriveLetter-Eigenschaft

DriveLetter-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt


DriveLetter-Eigenschaft

DriveLetter-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AvailableSpace-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


Drives-Eigenschaft

Drives-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Drives-Auflistung zurück, die alle Drive-Objekte enthält, die auf dem lokalen Computer verfügbar sind.
Syntax
Objekt.Drives

Objekt ist stets ein FileSystemObject-Objekt.

Hinweise
In Laufwerken für Wechselmedien muss kein Datenträger eingelegt sein, damit diese in der Drives-Auflistung angezeigt werden.

Sie können die Elemente der Drives-Auflistung mit der For Each...Next-Anweisung durchlaufen, wie der folgende Code veranschaulicht:

Function LaufwerklisteAnzeigen
  Dim fso, l, da, s, n
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set da = fso.Drives
  For Each l in da
    n = ""
    s = s & l.DriveLetter & " - "
    If l.DriveType = 3 Then
      n = l.ShareName
    ElseIf l.IsReady Then
      n = l.VolumeName
    End If
    s = s & n & "<BR>"
  Next
  LaufwerklisteAnzeigen = s
End Function


Drives-Eigenschaft

Drives-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

FileSystemObject-Objekt


Drives-Eigenschaft

Drives-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Drives-Auflistung
Files-Eigenschaft
SubFolders-Eigenschaft


DriveType-Eigenschaft

DriveType-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt einen Wert zurück, der den Typ des angegebenen Laufwerkes anzeigt.
Syntax
Objekt.DriveType

Objekt ist stets ein Drive-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der DriveType-Eigenschaft:
Function LaufwerktypAnzeigen(Laufwerkangabe)
  Dim fso, d, t
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetDrive(Laufwerkangabe)
  Select Case d.DriveType
    Case 0: t = "Unbekanntes Laufwerk"
    Case 1: t = "Wechselmedium"
    Case 2: t = "Festplatte"
    Case 3: t = "Netzlaufwerk"
    Case 4: t = "CD-ROM"
    Case 5: t = "RAM-Laufwerk"
  End Select
  LaufwerktypAnzeigen = "Laufwerk " & d.DriveLetter & ": - " & t
End Function


DriveType-Eigenschaft

DriveType-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt


DriveType-Eigenschaft

DriveType-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


Files-Eigenschaft

Files-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Files-Auflistung zurück, die alle File-Objekte in dem angegebenen Ordner enthält, einschließlich der Dateien, für die die Attribute "Versteckt" und "System" gesetzt sind.
Syntax
Objekt.Files

Objekt ist stets ein Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der Files-Eigenschaft:
Function DateiListeAnzeigen(Ordnerangabe)
  Dim fso, o, d, da, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set o = fso.GetFolder(Ordnerangabe)
  Set da= o.Files
  For Each d in da
    s = s & d.name
    s = s &  "<BR>"
  Next
  DateiListeAnzeigen = s
End Function


Files-Eigenschaft

Files-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Folder-Objekt


Files-Eigenschaft

Files-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drives-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


FileSystem-Eigenschaft

FileSystem-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt das für das angegebene Laufwerk verwendete Dateisystem zurück.
Syntax
Objekt.FileSystem

Objekt ist stets ein Drive-Objekt.

Hinweise
Die verfügbaren Rückgabetypen sind FAT, NTFS und CDFS.

Der folgende Code veranschaulicht die Verwendung der FileSystem-Eigenschaft:

Function DateiSystemTypAnzeigen(Laufwerkangabe)
  Dim fso,l
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set l = fso.GetDrive(Laufwerkangabe)
  DateiSystemTypAnzeigen = l.FileSystem
End Function


FileSystem-Eigenschaft

FileSystem-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt


FileSystem-Eigenschaft

FileSystem-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystemObject-Objekt
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


FirstIndex-Eigenschaft

FirstIndex-Eigenschaft 		Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Gibt die Position in einer Suchzeichenfolge zurück, an der eine Entsprechung gefunden wurde.
Syntax
Objekt.FirstIndex

Objekt ist stets ein Match-Objekt.

Hinweise
Die FirstIndex-Eigenschaft verwendet einen nullbasierten Versatz vom Anfang der Suchzeichenfolge. Das heißt, dass das erste Zeichen in einer Zeichenfolge das Zeichen Nummer 0 ist. Der folgende Code veranschaulicht die Verwendung der FirstIndex-Eigenschaft:
Function RegAusdrTest(Suchmuster, Zeichenfolge)
  Dim regAusdr, Uebereinstimmung, Uebereinstimmungen, Rueckgabe		' Variablen erstellen.
  Set regAusdr = New RegExp			' Erstellt einen regulären Ausdruck.
  regAusdr.Pattern = Suchmuster			' Legt das Suchmuster fest.
  regAusdr.IgnoreCase = True			' Ignoriert die Schreibweise.
  regAusdr.Global = True				' Legt globales Anwenden fest.
  Set Uebereinstimmungen = regAusdr.Execute(Zeichenfolge)	' Führt die Suche aus.
  For Each Uebereinstimmung in Uebereinstimmungen		' Durchläuft die Auflistung der Übereinstimmungen.
    Rueckgabe = Rueckgabe & "Entsprechung " & I & " gefunden bei "
    Rueckgabe = Rueckgabe & Uebereinstimmung.FirstIndex & ". Wert ist '"
    Rueckgabe = Rueckgabe & Uebereinstimmung.Value & "'." & vbCRLF
  Next
  RegAusdrTest = Rueckgabe
End Function

MsgBox(RegAusdrTest ("is.", "IS1 is2 IS3 is4"))


FirstIndex-Eigenschaft

FirstIndex-Eigenschaft
Betrifft 		Sprachverzeichnis

Match-Objekt


FirstIndex-Eigenschaft

FirstIndex-Eigenschaft
Siehe auch 		Sprachverzeichnis

Length-Eigenschaft
Value-Eigenschaft


FreeSpace-Eigenschaft

FreeSpace-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die Größe des freien Speicherplatzes zurück, der einem Benutzer auf dem angegebenen Laufwerk bzw. der Netzwerkfreigabe zur Verfügung steht. Schreibgeschützt.
Syntax
Objekt.FreeSpace

Objekt ist stets ein Drive-Objekt.

Hinweise
Der von der FreeSpace-Eigenschaft zurückgegebene Wert entspricht in der Regel dem von der AvailableSpace-Eigenschaft zurückgegebenen Wert. Unterschiede zwischen beiden können bei Computersystemen auftreten, die Quoten unterstützen.

Der folgende Code veranschaulicht die Verwendung der FreeSpace-Eigenschaft:

Function FreienLaufwerkspeicherAnzeigen(LWPfad)
  Dim fso, l, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set l = fso.GetDrive(fso.GetDriveName(LWPfad))
  s = "Laufwerk " & UCase(LWPfad) & " - "
  s = s & l.VolumeName  & "<BR>"
  s = s & "Freier Speicherplatz: " & FormatNumber(l.FreeSpace/1024, 0)
  s = s & " KB"
  FreienLaufwerkspeicherAnzeigen = s
End Function


FreeSpace-Eigenschaft

FreeSpace-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt


FreeSpace-Eigenschaft

FreeSpace-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


Global-Eigenschaft

Global-Eigenschaft 		Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Legt einen Boolean-Wert fest, der angibt, ob ein Muster mit allen oder nur einer Entsprechung in einer gesuchten Zeichenfolge übereinstimmen soll, oder gibt diesen zurück.
Syntax
Objekt.Global [= True | False ]

Das Argument Objekt ist stets ein RegExp-Objekt. Der Wert der Global-Eigenschaft ist True, wenn sich die Suche auf die gesamte Zeichenfolge bezieht, andernfalls False. Voreinstellung ist False.

Hinweise
Der folgende Code veranschaulicht die Verwendung der Global-Eigenschaft (ändern Sie den der Global-Eigenschaft zugewiesenen Wert, um die Auswirkungen zu sehen):
Function RegAusdrTest(Suchmuster, Zeichenfolge)
  Dim regAusdr, Uebereinstimmung, Uebereinstimmungen, Rueckgabe		' Variablen erstellen.
  Set regAusdr = New RegExp			' Erstellt einen regulären Ausdruck.
  regAusdr.Pattern = Suchmuster			' Legt das Suchmuster fest.
  regAusdr.IgnoreCase = True			' Ignoriert die Schreibweise.
  regAusdr.Global = True				' Legt globales Anwenden fest.
  Set Uebereinstimmungen = regAusdr.Execute(Zeichenfolge)	' Führt die Suche aus.
  For Each Uebereinstimmung in Uebereinstimmungen		' Durchläuft die Auflistung der Uebereinstimmungen.
    Rueckgabe = Rueckgabe & "Entsprechung gefunden bei "
    Rueckgabe = Rueckgabe & Uebereinstimmung.FirstIndex & ". Wert ist '"
    Rueckgabe = Rueckgabe & Uebereinstimmung.Value & "'." & vbCRLF
  Next
  RegAusdrTest = Rueckgabe
End Function

MsgBox(RegAusdrTest ("is.", "IS1 is2 IS3 is4"))


Global-Eigenschaft

Global-Eigenschaft
Betrifft 		Sprachverzeichnis

RegExp-Objekt


Global-Eigenschaft

Global-Eigenschaft
Siehe auch 		Sprachverzeichnis

IgnoreCase-Eigenschaft
Pattern-Eigenschaft


HelpContext-Eigenschaft

HelpContext-Eigenschaft 		Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Gibt die Kontext-ID eines Themas in einer Hilfedatei zurück oder legt eine Kontext-ID fest.
Syntax
Objekt.HelpContext [= Kontext-ID]

Die Syntax der HelpContext-Eigenschaft besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets das Err-Objekt.
Kontext-ID | Optional. Eine gültige Kennung für ein Hilfethema in der Hilfedatei.

Hinweise
Wenn eine Hilfedatei in HelpFile angegeben ist, wird die HelpContext-Eigenschaft verwendet, um automatisch das bezeichnete Hilfethema anzuzeigen. Wenn sowohl HelpFile als auch HelpContext keinen Wert enthalten, wird der Wert der Number-Eigenschaft überprüft. Wenn es sich um einen Wert eines VBScript-Laufzeitfehlers handelt, wird die Kontext-ID der VBScript-Hilfe für diesen Fehler verwendet. Entspricht die Number-Eigenschaft keinem VBScript-Fehler, wird das Inhaltsverzeichnis der VBScript-Hilfedatei angezeigt.

Der folgende Code veranschaulicht die Verwendung der HelpContext-Eigenschaft:

On Error Resume Next
Dim Meldung
Err.Clear
Err.Raise 6  ' Erzeugt einen Überlauffehler.
Err.Helpfile = "MeineHilfe.hlp"
Err.HelpContext = MeineKontextID
If Err.Number <> 0 Then
   Meldung = "Drücken Sie F1, oder klicken Sie auf Hilfe, um das Hilfethema aus " & Err.Helpfile & " für" & _
   " den folgenden Hilfekontext einzublenden: " & Err.HelpContext
   MsgBox Meldung, , "Fehler: " & Err.Description, Err.Helpfile, Err.HelpContext
End If


HelpContext-Eigenschaft

HelpContext-Eigenschaft
Betrifft 		Sprachverzeichnis

Err-Objekt


HelpContext-Eigenschaft

HelpContext-Eigenschaft
Siehe auch 		Sprachverzeichnis

Description-Eigenschaft
HelpFile-Eigenschaft
Number-Eigenschaft
Source-Eigenschaft


HelpFile-Eigenschaft

HelpFile-Eigenschaft 		Sprachverzeichnis
Version 2

Siehe auch Betrifft

Beschreibung
Legt den vollständigen Pfad zu einer Hilfedatei fest oder gibt ihn zurück.
Syntax
Objekt.HelpFile [= Kontext-ID]

Die Syntax der HelpFile-Eigenschaft besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets das Err-Objekt.
Kontext-ID | Optional. Vollständiger Pfad zur Hilfedatei.

Hinweise
Ist eine Hilfedatei in HelpFile angegeben, wird sie automatisch aufgerufen, wenn der Benutzer im Dialogfeld der Fehlermeldung die Schaltfläche Hilfe wählt (oder die F1-Taste drückt). Wenn die HelpContext-Eigenschaft eine gültige Kontext-ID für die angegebene Datei enthält, wird das entsprechende Thema automatisch angezeigt. Wird kein Pfad für HelpFile angegeben, wird die VBScript-Hilfedatei angezeigt.
On Error Resume Next
Dim Meldung
Err.Clear
Err.Raise 6  ' Erzeugt einen Überlauffehler.
Err.Helpfile = "MeineHilfe.hlp"
Err.HelpContext = MeineKontextID
If Err.Number <> 0 Then
   Meldung = "Drücken Sie F1, oder klicken Sie auf Hilfe, um das Hilfethema aus " & Err.Helpfile & " für" & _
   " den folgenden Hilfekontext einzublenden: " & Err.HelpContext
   MsgBox Meldung, , "Fehler: " & Err.Description, Err.Helpfile, Err.HelpContext
End If


HelpFile-Eigenschaft

HelpFile-Eigenschaft
Betrifft 		Sprachverzeichnis

Err-Objekt


HelpFile-Eigenschaft

HelpFile-Eigenschaft
Siehe auch 		Sprachverzeichnis

Description-Eigenschaft
HelpContext-Eigenschaft
Number-Eigenschaft
Source-Eigenschaft


IgnoreCase-Eigenschaft

IgnoreCase-Eigenschaft 		Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Legt einen Boolean-Wert fest, der anzeigt, ob bei einer Mustersuche die Groß-/Kleinschreibung relevant ist, oder gibt diesen zurück.
Syntax
Objekt.IgnoreCase [= True | False ]

Das Argument Objekt ist stets ein RegExp-Objekt. Der Wert der IgnoreCase-Eigenschaft ist False, wenn bei der Suche die Schreibweise relevant ist, andernfalls True. Voreinstellung ist False.

Hinweise
Der folgende Code veranschaulicht die Verwendung der IgnoreCase-Eigenschaft (ändern Sie den der IgnoreCase-Eigenschaft zugewiesen Wert, um die Auswirkungen zu sehen):
Function RegAusdrTest(Suchmuster, Zeichenfolge)
  Dim regAusdr, Uebereinstimmung, Uebereinstimmungen, Rueckgabe		' Variablen erstellen.
  Set regAusdr = New RegExp			' Erstellt einen regulären Ausdruck.
  regAusdr.Pattern = Suchmuster			' Legt das Suchmuster fest.
  regAusdr.IgnoreCase = True			' Groß-/Kleinschreibung ignorieren.
  regAusdr.Global = True				' Legt globales Anwenden fest.
  Set Uebereinstimmungen = regAusdr.Execute(Zeichenfolge)	' Führt die Suche aus.
  For Each Uebereinstimmung in Uebereinstimmungen		' Durchläuft die Auflistung der Übereinstimmungen.
    Rueckgabe = Rueckgabe & "Entsprechung gefunden bei "
    Rueckgabe = Rueckgabe & Uebereinstimmung.FirstIndex & ". Wert ist '"
    Rueckgabe = Rueckgabe & Uebereinstimmung.Value & "'." & vbCRLF
  Next
  RegAusdrTest = Rueckgabe
End Function

MsgBox(RegAusdrTest ("is.", "IS1 is2 IS3 is4"))


IgnoreCase-Eigenschaft

IgnoreCase-Eigenschaft
Betrifft 		Sprachverzeichnis

RegExp-Objekt


IgnoreCase-Eigenschaft

IgnoreCase-Eigenschaft
Siehe auch 		Sprachverzeichnis

Global-Eigenschaft
Pattern-Eigenschaft


IsReady-Eigenschaft

IsReady-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn das angegebene Laufwerk bereit ist, andernfalls False.
Syntax
Objekt.IsReady

Objekt ist stets ein Drive-Objekt.

Hinweise
Bei Laufwerken mit austauschbaren Datenträgern und CD-ROM-Laufwerken gibt IsReady nur dann True zurück, wenn der entsprechende Datenträger eingelegt und zugriffsbereit ist.

Der folgende Code veranschaulicht die Verwendung der IsReady-Eigenschaft:

Function LaufwerkInfoAnzeigen(Laufwerkangabe)
  Dim fso, l, s, t
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set l = fso.GetDrive(Laufwerkangabe)
  Select Case l.DriveType
    Case 0: t = "Unbekanntes Laufwerk"
    Case 1: t = "Wechselmedium"
    Case 2: t = "Festplatte"
    Case 3: t = "Netzlaufwerk"
    Case 4: t = "CD-ROM-Laufwerk"
    Case 5: t = "RAM-Laufwerk"
  End Select
  s = "Laufwerk " & l.DriveLetter & ": - " & t
  If l.IsReady Then
    s = s & "<BR>" & "Laufwerk ist bereit."
  Else
    s = s & "<BR>" & "Laufwerk ist nicht bereit."
  End If
  LaufwerkInfoAnzeigen = s
End Function


IsReady-Eigenschaft

IsReady-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt


IsReady-Eigenschaft

IsReady-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


IsRootFolder-Eigenschaft

IsRootFolder-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt True zurück, wenn der angegebene Ordner der Stammordner ist, andernfalls False.
Syntax
Objekt.IsRootFolder

Objekt ist stets ein Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der IsRootFolder-Eigenschaft:
Function AnzahlEbenenAnzeigen(Pfadangabe)
  Dim fso, o, n
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set o = fso.GetFolder(Pfadangabe)
  If o.IsRootFolder Then
    AnzahlEbenenAnzeigen = "Der angegebene Ordner ist der Stammordner."
  Else
    Do Until o.IsRootFolder
      Set o = o.ParentFolder
      n = n + 1
    Loop
    AnzahlEbenenAnzeigen = "Der angegebene Ordner ist " & n & " Ebenen tief verschachtelt."
  End If
End Function


IsRootFolder-Eigenschaft

IsRootFolder-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Folder-Objekt


IsRootFolder-Eigenschaft

IsRootFolder-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Item-Eigenschaft

Item-Eigenschaft 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Legt ein Element für einen angegebenen Schlüssel in einem Dictionary-Objekt fest oder gibt dieses zurück. Bei Auflistungen wird ein auf dem angegebenen Schlüssel basierendes Element zurückgegeben. Lesen/Schreiben.
Syntax
Objekt.Item(Schlüssel) [= NeuesElement]

Die Syntax der Item-Eigenschaft besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name einer Auflistung oder eines Dictionary-Objekts.
Schlüssel | Erforderlich. Schlüssel, der mit dem Element verbunden ist, das gelesen oder hinzugefügt werden soll.
NeuesElement | Optional. Wird nur für Dictionary-Objekte verwendet und findet bei Auflistungen keine Anwendung. Wenn angegeben, ist NeuesElement der neue Wert, der dem angegebenen Schlüssel zugewiesen wird.

Hinweise
Wird Schlüssel nicht gefunden, wenn ein Element geändert wird, wird ein neuer Schlüssel mit dem angegebenen NeuesElement angelegt. Wird der Schlüssel beim Versuch, ein bestehendes Element zurückzugeben, nicht gefunden, wird ein neuer Schlüssel erstellt, und das entsprechende Element bleibt leer.

Der folgende Code veranschaulicht die Verwendung der Item-Eigenschaft:

Function ItemDemo
  Dim d                   ' Erstellt eine Variable.
  Set d = CreateObject("Scripting.Dictionary")
  d.Add "a", "Athen"      ' Fügt einige Schlüssel und Elemente hinzu.
  d.Add "b", "Belgrad"
  d.Add "c", "Chicago"
  ItemDemo = d.Item("c")  ' Liest das Element.
End Function


Item-Eigenschaft

Item-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Dictionary-Objekt
Drives-Auflistung
Files-Auflistung
Folders-Auflistung
Matches-Auflistung


Item-Eigenschaft

Item-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

CompareMode-Eigenschaft
Count-Eigenschaft
Key-Eigenschaft


Key-Eigenschaft

Key-Eigenschaft 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Legt einen Schlüssel in einem Dictionary-Objekt fest oder gibt diesen zurück.
Syntax
Objekt.Key(Schlüssel) = NeuerSchlüssel

Die Syntax der Key-Eigenschaft besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines Dictionary-Objekts.
Schlüssel | Erforderlich. Zu ändernder Key-Wert.
NeuerSchlüssel | Erforderlich. Neuer Wert, der den angegebenen Schlüssel ersetzen soll.

Hinweise
Wird Schlüssel beim Ändern eines Schlüssels nicht gefunden, tritt ein Laufzeitfehler auf.

Der folgende Code veranschaulicht die Verwendung der Key-Eigenschaft:

Function KeyDemo
  Dim d                   ' Erstellt einige Variablen.
  Set d = CreateObject("Scripting.Dictionary")
  d.Add "a", "Athen"      ' Fügt einige Schlüssel und Elemente hinzu.
  d.Add "b", "Belgrad"
  d.Add "c", "Chicago"
  d.Key("c") = "d"        ' Ersetzt Schlüssel "c" durch "d".
  KeyDemo = d.Item("d")   ' Gibt das zugewiesene Element zurück.
End Function


Key-Eigenschaft

Key-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Dictionary-Objekt


Key-Eigenschaft

Key-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

CompareMode-Eigenschaft
Count-Eigenschaft
Item-Eigenschaft


Length-Eigenschaft

Length-Eigenschaft 		Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Gibt die Länge einer Entsprechung in einer Suchzeichenfolge zurück.
Syntax
Objekt.Length

Objekt ist stets ein Match-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der Length-Eigenschaft:
Function RegAusdrTest(Suchmuster, Zeichenfolge)
  Dim regAusdr, Uebereinstimmung, Uebereinstimmungen		' Erstellt Variablen.
  Set regAusdr = New RegExp			' Erstellt einen regulären Ausdruck.
  regAusdr.Pattern = Suchmuster			' Legt das Suchmuster fest.
  regAusdr.IgnoreCase = True			' Ignoriert die Schreibweise.
  regAusdr.Global = True				' Legt globales Anwenden fest.
  Set Uebereinstimmungen = regAusdr.Execute(Zeichenfolge)	' Führt die Suche aus.
  For Each Uebereinstimmung in Uebereinstimmungen		' Durchläuft die Liste der Uebereinstimmungen.
    Rueckgabe = Rueckgabe & "Entsprechung " & I & " gefunden bei "
    Rueckgabe = Rueckgabe & Uebereinstimmung.FirstIndex & ". Länge der Übereinstimmung ist "
    Rueckgabe = Rueckgabe & Uebereinstimmung.Length
    Rueckgabe = Rueckgabe & " Zeichen." & vbCRLF
  Next
  RegAusdrTest = Rueckgabe
End Function

MsgBox(RegAusdrTest ("is.", "IS1 is2 IS3 is4"))


Length-Eigenschaft

Length-Eigenschaft
Betrifft 		Sprachverzeichnis

Match-Objekt


Length-Eigenschaft

Length-Eigenschaft
Siehe auch 		Sprachverzeichnis

FirstIndex-Eigenschaft
Value-Eigenschaft


Line-Eigenschaft

Line-Eigenschaft 		Scripting-Laufzeitreferenz
Version 2

Siehe auch Betrifft

Beschreibung
Schreibgeschützte Eigenschaft, welche die aktuelle Zeilennummer in einer TextStream-Datei zurückgibt.
Syntax
Objekt.Line

Objekt ist stets der Name eines TextStream-Objekts.

Hinweise
Nach dem unmittelbaren Öffnen einer Datei und vor Schreibzugriffen hat Line den Wert 1.

Der folgende Code veranschaulicht die Verwendung der Line-Eigenschaft:

Function ZeileAnzeigen
  Const ForReading = 1, ForWriting = 2
  Dim fso, d, ra
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.OpenTextFile("c:\test.txt", ForWriting, True)
  d.Write "Hallo Welt!" & vbCrLf & "VB Script macht Spaß!" & vbCrLf
  Set d = fso.OpenTextFile("c:\test.txt", ForReading)
  ra =  d.ReadAll
  ZeileAnzeigen = d.Line
End Function


Line-Eigenschaft

Line-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

TextStream-Objekt


Line-Eigenschaft

Line-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AtEndOfLine-Eigenschaft
AtEndOfStream-Eigenschaft
Column-Eigenschaft


Name-Eigenschaft

Name-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Legt den Namen einer angegebenen Datei bzw. eines angegebenen Ordners fest oder gibt diesen zurück. Lesen/Schreiben.
Syntax
Objekt.Name [= NeuerName]

Die Name-Eigenschaft hat folgende Komponenten:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines File- oder Folder-Objekts.
NeuerName | Optional. Falls angegeben, ist NeuerName der neue Name des angegebenen Objekts.

Hinweise
Der folgende Code veranschaulicht die Verwendung der Name-Eigenschaft:
Function DateiZugriffsInfoAnzeigen(Dateiangabe)
  Dim fso, d, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetFile(Dateiangabe)
  s = d.Name & " auf Laufwerk " & UCase(d.Drive) & "<BR>"
  s = s & "Erstellt: " & d.DateCreated & "<BR>"
  s = s & "Letzter Zugriff: " & d.DateLastAccessed & "<BR>"
  s = s & "Letzte Änderung: " & d.DateLastModified
  DateiZugriffsInfoAnzeigen = s
End Function


Name-Eigenschaft

Name-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


Name-Eigenschaft

Name-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Number-Eigenschaft

Number-Eigenschaft 		Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt einen numerischen Wert zurück oder legt einen numerischen Wert fest, der einen Fehler angibt. Number ist die Standardeigenschaft des Err-Objekts.
Syntax
Objekt.Number [= Fehlernummer]

Die Syntax der Number-Eigenschaft besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Stets das Err-Objekt.
Fehlernummer | Eine Ganzzahl, die eine VBScript-Fehlernummer oder einen SCODE-Fehlerwert darstellt.

Hinweise
Soll ein benutzerdefinierter Fehler von einem Automatisierungsobjekt zurückgegeben werden, setzen Sie Err.Number, indem Sie die als Fehlercode ausgewählte Zahl der vbObjectError-Konstante hinzufügen.

Der folgende Code veranschaulicht die Verwendung der Number-Eigenschaft:

On Error Resume Next
Err.Raise vbObjectError + 1, "IrgendeinObjekt"	' Erzeugt einen Objektfehler.
MsgBox ("Fehler Nr. " & CStr(Err.Number) & " " & Err.Description)
Err.Clear					' Löscht die Fehlermeldung.


Number-Eigenschaft

Number-Eigenschaft
Betrifft 		Sprachverzeichnis

Err-Objekt


Number-Eigenschaft

Number-Eigenschaft
Siehe auch 		Sprachverzeichnis

Description-Eigenschaft
Err-Objekt
Fehlermeldungen
HelpContext-Eigenschaft
HelpFile-Eigenschaft
Source-Eigenschaft


ParentFolder-Eigenschaft

ParentFolder-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt das Folder-Objekt des übergeordneten Ordners der angegebenen Datei bzw. des angegebenen Ordners zurück. Schreibgeschützt.
Syntax
Objekt.ParentFolder

Objekt ist stets ein File- oder Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der ParentFolder-Eigenschaft mit einer Datei:
Function DateiZugriffsInfoAnzeigen(Dateiangabe)
  Dim fso, d, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetFile(Dateiangabe)
  s = UCase(d.Name) & " in " & UCase(d.ParentFolder) & "<BR>"
  s = s & "Erstellt: " & d.DateCreated & "<BR>"
  s = s & "Letzter Zugriff: " & d.DateLastAccessed & "<BR>"
  s = s & "Letzte Änderung: " & d.DateLastModified
  DateiZugriffsInfoAnzeigen = s
End Function


ParentFolder-Eigenschaft

ParentFolder-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


ParentFolder-Eigenschaft

ParentFolder-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Path-Eigenschaft

Path-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Pfad einer angegebenen Datei bzw. eines angegebenen Ordners oder Laufwerkes zurück.
Syntax
Objekt.Path

Objekt ist stets ein File-, Folder- oder Drive- Objekt.

Hinweise
Bei Laufwerkbuchstaben ist das Stammlaufwerk nicht enthalten. Der Pfad für das Laufwerk C ist also C: und nicht C:\.

Der folgende Code veranschaulicht die Verwendung der Path-Eigenschaft mit einem File-Objekt:

Function DateiZugriffsInfoAnzeigen(Dateiangabe)
  Dim fso, d, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetFile(Dateiangabe)
  s = UCase(d.Path) & "<BR>"
  s = s & "Erstellt: " & d.DateCreated & "<BR>"
  s = s & "Letzter Zugriff: " & d.DateLastAccessed & "<BR>"
  s = s & "Letzte Änderung: " & d.DateLastModified
  DateiZugriffsInfoAnzeigen = s
End Function


Path-Eigenschaft

Path-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt
File-Objekt
Folder-Objekt


Path-Eigenschaft

Path-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
AvailableSpace-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
Files-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
TotalSize-Eigenschaft
Type-Eigenschaft
VolumeName-Eigenschaft


Pattern-Eigenschaft

Pattern-Eigenschaft 		Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Legt das Suchmuster eines regulären Ausdruckes fest oder gibt dieses zurück.
Syntax
Objekt.Pattern [= "Suchzeichenfolge"]

Die Syntax der Pattern-Eigenschaft besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets eine RegExp-Objektvariable.
Suchzeichenfolge | Optional. Regulärer Zeichenfolgenausdruck, mit dem gesucht wird. Kann Zeichen für reguläre Ausdrücke enthalten (siehe Tabelle im Abschnitt "Einstellungen").

Einstellungen
Beim Erstellen von Mustern für reguläre Ausdrücke werden Sonderzeichen und Folgen verwendet. Die folgende Tabelle beschreibt diese verwendbaren Zeichen und Zeichenfolgen und führt ein Beispiel auf.

Zeichen | Beschreibung
\ Markiert das folgende Zeichen als Sonder- oder wortgenaues (literales) Zeichen. Beispielsweise entspricht "n" dem Zeichen "n". "\n" entspricht einem Zeilenumbruchzeichen. Die Folge "\\" entspricht "\", und "\(" entspricht "(".
^ Entspricht dem Anfang der Eingabe.
$ Entspricht dem Ende der Eingabe.
* Entspricht dem vorhergehenden Zeichen kein oder mehrere Male. Beispielsweise entspricht "zo*" entweder "z" oder "zoo".
+ Entspricht dem vorhergehenden Zeichen ein oder mehrere Male. "zo+" entspricht beispielsweise "zoo", nicht aber "z".
? Entspricht dem vorhergehenden Zeichen kein- oder einmal. Beispielsweise entspricht "a?eu?" dem "eu" in "neuer".
. Entspricht allen Einzelzeichen außer einem Zeilenumbruchzeichen.
(Muster) | Entspricht Muster und speichert die Entsprechung. Die übereinstimmende Teilzeichenfolge kann aus der sich ergebenden Matches-Auflistung unter Verwendung von Item [0]...[n] abgerufen werden. Verwenden Sie zum Abgleichen von in Klammern ( ) gesetzten Zeichen "\(" oder "\)".
x|y | Entspricht entweder x oder y. Beispielsweise entspricht "sch|blau" entweder "sch" oder "blau". "(sch|b)lau" entspricht "schlau" oder "blau".
{n} | n ist eine nicht negative Ganzzahl. Entspricht exakt n Mal. Beispielsweise entspricht "o{2}" nicht dem "o" in "Robert", jedoch den ersten beiden "o" in "Booooot".
{n,} | n ist eine nicht negative Ganzzahl. Entspricht mindestens n Mal. Zum Beispiel entspricht "o{2,}" nicht dem "o" in "Robert", aber allen "o" in "Booooot". "o{1,}" ist äquivalent mit "o+". "o{0,}" ist äquivalent mit "o*".
{n,m} | m und n sind nicht negative Ganzzahlen. Entspricht mindestens n und höchstens m Mal. Beispielsweise entspricht "o{1,3}" den ersten drei "o" in "Boooooot". "o{0,1}" ist äquivalent mit "o?".
[xyz] | Eine Gruppe von Zeichen. Entspricht einem beliebigen der enthaltenen Zeichen. "[abc]" entspricht z. B. dem "a" in "fallen".
[^xyz] | Eine Gruppe ausgeschlossener Zeichen. Entspricht allen nicht enthaltenen Zeichen. "[^abc]" entspricht z. B. dem "f" in "fallen".
[a-z] | Ein Zeichenbereich. Entspricht allen Zeichen im angegebenen Bereich. Beispielsweise entspricht "[a-z]" allen alphabetischen Zeichen in Kleinschreibung des Bereichs "a" bis "z".
[^m-z] | Ein ausgeschlossener Bereich an Zeichen. Entspricht allen Zeichen, die im angegebenen Bereich nicht enthalten sind. Zum Beispiel entspricht "[^m-z]" allen Zeichen, die im Bereich "m" bis "z" nicht enthalten sind.
\b | Entspricht einer Wortgrenze, d. h. der Position zwischen einem Wort und einem Leerzeichen. "er\b" entspricht beispielsweise dem "er" in "neuer", nicht jedoch dem "er" in "verb".
\B | Entspricht einer Nicht-Wortgrenze. "ee*r\B" entspricht dem "eer" in "leeren".
\d | Entspricht einer Ziffer. Äquivalent zu [0-9].
\D | Entspricht einer Nicht-Ziffer. Äquivalent zu [^0-9].
\f | Entspricht einem Seitenvorschubzeichen.
\n | Entspricht einem Zeilenumbruchzeichen.
\r | Entspricht einem Wagenrücklaufzeichen.
\s | Entspricht beliebigen Leerräumen wie Leerzeichen, Tabulator, Seitenvorschub usw. Äquivalent zu "[ \f\n\r\t\v]".
\S | Entspricht beliebigen Nichtleerräumen. Äquivalent zu "[^ \f\n\r\t\v]".
\t | Entspricht einem Tabulatorzeichen.
\v | Entspricht einem vertikalen Tabulatorzeichen.
\w | Entspricht allen alphabetischen Zeichen einschließlich Unterstrich. Äquivalent zu "[A-Za-z0-9_]".
\W | Entspricht allen nicht alphabetischen Zeichen. Äquivalent zu "[^A-Za-z0-9_]".
\Zahl | Entspricht Zahl, wenn Zahl eine positive Ganzzahl ist. Ein Rückverweis auf gespeicherte Entsprechungen. "(.)\1" entspricht z. B. zwei aufeinander folgenden identischen Zeichen.
\n | Entspricht n, wobei n ein oktaler Escape-Wert ist. Oktale Escape-Werte können 1, 2 oder 3 Stellen aufweisen. Beispielsweise entspricht sowohl "\11" als auch "\011" dem Tabulatorzeichen. "\0011" ist äquivalent zu "\001" & "1". Oktale Escape-Werte dürfen 256 nicht überschreiten, da andernfalls nur die ersten beiden Stellen den Ausdruck enthalten. Ermöglicht die Verwendung von ASCII-Codes in regulären Ausdrücken.
\x n | Entspricht n, wobei n ein hexadezimaler Escape-Wert ist. Hexadezimale Escape-Werte können nur genau zwei Stellen aufweisen. "\x41" entspricht beispielsweise "A". "\x041" ist äquivalent zu "\x04" & "1". Ermöglicht die Verwendung von ASCII-Codes in regulären Ausdrücken.

Hinweise
Der folgende Code veranschaulicht die Verwendung der Pattern-Eigenschaft:
Function RegAusdrTest(Suchmuster, Zeichenfolge)
  Dim regAusdr, Uebereinstimmung, Uebereinstimmungen, Rueckgabe		' Variablen erstellen.
  Set regAusdr = New RegExp			' Erstellt einen regulären Ausdruck.
  regAusdr.Pattern = Suchmuster			' Legt das Suchmuster fest.
  regAusdr.IgnoreCase = True			' Ignoriert die Schreibweise.
  regAusdr.Global = True				' Legt globales Anwenden fest.
  Set Uebereinstimmungen = regAusdr.Execute(Zeichenfolge)	' Führt die Suche aus.
  For Each Uebereinstimmung in Uebereinstimmungen		' Durchläuft die Auflistung der Übereinstimmungen.
    Rueckgabe = Rueckgabe & "Entsprechung gefunden bei "
    Rueckgabe = Rueckgabe & Uebereinstimmung.FirstIndex & ". Wert ist '"
    Rueckgabe = Rueckgabe & Uebereinstimmung.Value & "'." & vbCRLF
  Next
  RegAusdrTest = Rueckgabe
End Function

MsgBox(RegAusdrTest ("is.", "IS1 is2 IS3 is4"))


Pattern-Eigenschaft

Pattern-Eigenschaft
Betrifft 		Sprachverzeichnis

RegExp-Objekt


Pattern-Eigenschaft

Pattern-Eigenschaft
Siehe auch 		Sprachverzeichnis

Global-Eigenschaft
IgnoreCase-Eigenschaft


RootFolder-Eigenschaft

RootFolder-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt ein Folder-Objekt zurück, das den Stammordner eines angegebenen Laufwerkes darstellt. Schreibgeschützt.
Syntax
Objekt.RootFolder

Objekt ist stets ein Drive-Objekt.

Hinweise
Mithilfe des zurückgegebenen Folder-Objekts kann auf alle Dateien und Ordner auf diesem Laufwerk zugegriffen werden.

Der folgende Code veranschaulicht die Verwendung der RootFolder-Eigenschaft:

Function RootFolderDemo(Laufwerkangabe)
  Dim fso, l
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set l = fso.GetDrive(Laufwerkangabe)
  RootFolderDemo = l.RootFolder
End Function


RootFolder-Eigenschaft

RootFolder-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt


RootFolder-Eigenschaft

RootFolder-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


SerialNumber-Eigenschaft

SerialNumber-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt die dezimale Seriennummer zurück, mit der ein Datenträger eindeutig gekennzeichnet wird.
Syntax
Objekt.SerialNumber

Objekt ist stets ein Drive-Objekt.

Hinweise
Mithilfe der SerialNumber-Eigenschaft können Sie sicherstellen, dass der richtige Datenträger in ein Laufwerk mit austauschbaren Datenträgern eingelegt ist.

Der folgende Code veranschaulicht die Verwendung der SerialNumber-Eigenschaft:

Function LaufwerkInfoAnzeigen(Laufwerkangabe)
  Dim fso, l, s, t
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set l = fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(Laufwerkangabe)))
  Select Case l.DriveType
    Case 0: t = "Unbekannt"
    Case 1: t = "Wechselmedium"
    Case 2: t = "Fest"
    Case 3: t = "Netzwerk"
    Case 4: t = "CD-ROM"
    Case 5: t = "RAM-Laufwerk"
  End Select
  s = "Drive " & l.DriveLetter & ": - " & t
  s = s & "<BR>" & "Seriennummer: " & l.SerialNumber
  LaufwerkInfoAnzeigen = s
End Function


SerialNumber-Eigenschaft

SerialNumber-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt


SerialNumber-Eigenschaft

SerialNumber-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


ShareName-Eigenschaft

ShareName-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Netzwerkfreigabename eines angegebenen Laufwerkes zurück.
Syntax
Objekt.ShareName

Objekt ist stets ein Drive-Objekt.

Hinweise
Falls Objekt kein Netzlaufwerk ist, gibt die ShareName-Eigenschaft eine Nulllängenzeichenfolge zurück ("").

Der folgende Code veranschaulicht die Verwendung der ShareName-Eigenschaft:

Function LaufwerkInfoAnzeigen(Laufwerkangabe)
  Dim fso, l
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set l = fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(Laufwerkangabe)))
  LaufwerkInfoAnzeigen = "Drive " & l.DriveLetter & ": - " & l.ShareName
End Function


ShareName-Eigenschaft

ShareName-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt


ShareName-Eigenschaft

ShareName-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
TotalSize-Eigenschaft
VolumeName-Eigenschaft


ShortName-Eigenschaft

ShortName-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Kurznamen zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
Syntax
Objekt.ShortName

Objekt ist stets ein File- oder Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der ShortName-Eigenschaft mit einem File-Objekt:
Function ShortNameDemo(Dateiangabe)
  Dim fso, d, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetFile(Dateiangabe)
  s = "Der Kurzname für "  & UCase(d.Name) & "<BR>"
  s = s & "ist: " & d.ShortName
  ShortNameDemo = s
End Function


ShortName-Eigenschaft

ShortName-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


ShortName-Eigenschaft

ShortName-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


ShortPath-Eigenschaft

ShortPath-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den Kurzpfad zurück, der von Programmen verwendet wird, für die die frühere 8.3-Benennungskonvention erforderlich ist.
Syntax
Objekt.ShortPath

Objekt ist stets ein File- oder Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der ShortPath-Eigenschaft mit einem File-Objekt:
Function ShortPathDemo(Dateiangabe)
  Dim fso, d, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set d = fso.GetFile(Dateiangabe)
  s = "Der Kurzpfad für "  & UCase(d.Name) & "<BR>"
  s = s & "ist: " & d.ShortPath
  ShortPathDemo = s
End Function


ShortPath-Eigenschaft

ShortPath-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


ShortPath-Eigenschaft

ShortPath-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Size-Eigenschaft

Size-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt für Dateien die Größe (in Byte) der angegebenen Datei zurück. Gibt für Ordner die Größe (in Byte) aller in dem Ordner enthaltenen Dateien und untergeordneten Ordner zurück.
Syntax
Objekt.Size

Objekt ist stets ein File- oder Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der Size-Eigenschaft mit einem Folder-Objekt:
Function OrdnerGroesseAnzeigen(Ordnerangabe)
  Dim fso, o, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set o = fso.GetFolder(Ordnerangabe)
  s = UCase(o.Name) & " belegt " & o.size & " bytes."
  OrdnerGroesseAnzeigen = s
End Function


Size-Eigenschaft

Size-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


Size-Eigenschaft

Size-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
SubFolders-Eigenschaft
Type-Eigenschaft


Source-Eigenschaft

Source-Eigenschaft 		Sprachverzeichnis
Version 1

Siehe auch Betrifft

Beschreibung
Gibt den Namen des Objekts oder der Anwendung zurück, das/die ursprünglich den Fehler ausgelöst hat, oder legt den Namen fest.
Syntax
Objekt.Source [= Zeichenfolgenausdruck]

Die Syntax der Source-Eigenschaft besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Stets das Err-Objekt.
Zeichenfolgenausdruck | Ein Zeichenfolgenausdruck, der die Anwendung identifiziert, die den Fehler ausgelöst hat.

Hinweise
Die Source-Eigenschaft gibt einen Zeichenfolgenausdruck an, der den Namen der Klasse des Objekts oder die Ressourcen-ID des Objekts darstellt, das den Fehler ursprünglich ausgelöst hat. Mit Source stellen Sie Benutzern Informationen zur Verfügung, wenn der Code den Fehler, der in einem Objekt ausgelöst wurde, auf das der Code zugegriffen hat, nicht verarbeiten kann. Wenn Sie zum Beispiel auf Microsoft Excel zugreifen und der Fehler Division durch Null ausgelöst wird, setzt Microsoft Excel Err.Number auf den internen Excel-Fehlercode für diesen Fehler und Source auf Excel.Application. Wenn der Fehler von einem anderen Objekt ausgelöst wird, das von Microsoft Excel aufgerufen wird, fängt Microsoft Excel den Fehler ab und setzt Err.Number auf den internen Excel-Fehlercode für Division durch Null. Allerdings bleiben die anderen Eigenschaften des Err-Objekts (einschließlich Source) in dem Zustand, in den sie durch das Objekt versetzt wurden, das den Fehler ausgelöst hat.

Source enthält immer den Namen des Objekts, das den Fehler ursprünglich ausgelöst hat. Ihr Code kann versuchen, den Fehler entsprechend der Fehlerdokumentation des verwendeten Objekts zu verarbeiten. Wenn Ihre Fehlerbehandlungsroutine erfolglos bleibt, können Sie die Informationen des Err-Objekts verwenden, um dem Benutzer eine Beschreibung des Fehlers zu geben. Mit Source und den anderen Err-Eigenschaften können Sie den Benutzer darüber informieren, welches Objekt den Fehler ursprünglich verursacht hat, wie dieses Objekt den Fehler beschreibt usw.

Wenn Sie einen Fehler aus dem Code auslösen, ist Source die Ressourcen-ID Ihrer Anwendung.

Der folgende Code zeigt die Verwendung der Source-Eigenschaft:

On Error Resume Next
Err.Raise 6  ' Erzeugt einen Überlauffehler.
MsgBox ("Fehler Nr. " & CStr(Err.Number) & " " & Err.Description & " " & Err.Source)
Err.Clear    ' Löscht die Fehlermeldung.


Source-Eigenschaft

Source-Eigenschaft
Betrifft 		Sprachverzeichnis

Err-Objekt


Source-Eigenschaft

Source-Eigenschaft
Siehe auch 		Sprachverzeichnis

Description-Eigenschaft
Err-Objekt
HelpContext-Eigenschaft
HelpFile-Eigenschaft
Number-Eigenschaft
On Error-Anweisung


SubFolders-Eigenschaft

SubFolders-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt eine Folders-Auflistung zurück, die alle Folder-Objekte in dem angegebenen Folder-Objekt einschließlich derjenigen enthält, deren Attribute "Hidden" (Versteckt) oder "System" gesetzt sind.
Syntax
Objekt.SubFolders

Objekt ist stets ein Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der SubFolders-Eigenschaft:
Function OrdnerListeAnzeigen(Ordnerangabe)
  Dim fso, o, o1, s, uo
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set o = fso.GetFolder(Ordnerangabe)
  Set uo = o.SubFolders
  For Each o1 in uo
    s = s & o1.name
    s = s & "<BR>"
  Next
  OrdnerListeAnzeigen = s
End Function


SubFolders-Eigenschaft

SubFolders-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Folder-Objekt


SubFolders-Eigenschaft

SubFolders-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
Type-Eigenschaft


TotalSize-Eigenschaft

TotalSize-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt den gesamten Speicherplatz (in Byte) eines Laufwerkes oder einer Netzwerkfreigabe zurück.
Syntax
Objekt.TotalSize

Objekt ist stets ein Drive-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der TotalSize-Eigenschaft:
Function PlatzInfoAnzeigen(Laufwerkpfad)
  Dim fso, l, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set l = fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(Laufwerkpfad)))
  s = "Laufwerk " & l.DriveLetter & ":"
  s = s & vbCrLf
  s = s & "Insgesamt: " & FormatNumber(l.TotalSize/1024, 0) & " KB"
  s = s & vbCrLf
  s = s & "Verfügbar: " & FormatNumber(l.AvailableSpace/1024, 0) & " KB"
  PlatzInfoAnzeigen = s
End Function


TotalSize-Eigenschaft

TotalSize-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt


TotalSize-Eigenschaft

TotalSize-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
VolumeName-Eigenschaft


Type-Eigenschaft

Type-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Gibt Informationen zum Datei- oder Ordnertyp zurück. Für Dateien mit z. B. der Endung TXT wird "Textdatei" zurückgegeben.
Syntax
Objekt.Type

Objekt ist stets ein File- oder Folder-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der Type-Eigenschaft, um einen Ordnertypen zurückzugeben. Geben Sie in diesem Beispiel für die Prozedur den Pfad des Papierkorbs oder eines anderen eindeutigen Ordners an.
Function OrdnertypAnzeigen(Ordnerangabe)
  Dim fso, o, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set o = fso.GetFolder(Ordnerangabe)
  s = UCase(o.Name) & " ist ein " & o.Type
  OrdnertypAnzeigen = s
End Function


Type-Eigenschaft

Type-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

File-Objekt
Folder-Objekt


Type-Eigenschaft

Type-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

Attributes-Eigenschaft
DateCreated-Eigenschaft
DateLastAccessed-Eigenschaft
DateLastModified-Eigenschaft
Drive-Eigenschaft
Files-Eigenschaft
IsRootFolder-Eigenschaft
Name-Eigenschaft
ParentFolder-Eigenschaft
Path-Eigenschaft
ShortName-Eigenschaft
ShortPath-Eigenschaft
Size-Eigenschaft
SubFolders-Eigenschaft


Value-Eigenschaft

Value-Eigenschaft 		Sprachverzeichnis
Version 5

Siehe auch Betrifft

Beschreibung
Gibt den Wert oder Text einer Entsprechung zurück, der in einer Suchzeichenfolge gefunden wurde.
Syntax
Objekt.Value

Objekt ist stets ein Match-Objekt.

Hinweise
Der folgende Code veranschaulicht die Verwendung der Value-Eigenschaft:
Function RegAusdrTest(Suchmuster, Zeichenfolge)
  Dim regAusdr, Uebereinstimmung, Uebereinstimmungen, Rueckgabe		' Erstellt Variablen.
  Set regAusdr = New RegExp			' Erstellt einen regulären Ausdruck.
  regAusdr.Pattern = Suchmuster			' Setzt das Muster.
  regAusdr.IgnoreCase = True			' Ignoriert die Schreibweise.
  regAusdr.Global = True				' Legt globales Anwenden fest.
  Set Uebereinstimmungen = regAusdr.Execute(Zeichenfolge)	' Führt die Suche aus.
  For Each Uebereinstimmung in Uebereinstimmungen		' Durchläuft die Auflistung der Übereinstimmungen.
    Rueckgabe = Rueckgabe & "Entsprechung " & I & " gefunden bei "
    Rueckgabe = Rueckgabe & Uebereinstimmung.FirstIndex & ". Wert ist '"
    Rueckgabe = Rueckgabe & Uebereinstimmung.Value & "'." & vbCRLF
  Next
  RegAusdrTest = Rueckgabe
End Function

MsgBox(RegAusdrTest("is.", "IS1 is2 IS3 is4"))


Value-Eigenschaft

Value-Eigenschaft
Betrifft 		Sprachverzeichnis

Match-Objekt


Value-Eigenschaft

Value-Eigenschaft
Siehe auch 		Sprachverzeichnis

FirstIndex-Eigenschaft
Length-Eigenschaft


VolumeName-Eigenschaft

VolumeName-Eigenschaft 		Scripting-Laufzeitreferenz
Version 3

Siehe auch Betrifft

Beschreibung
Legt den Datenträgernamen des angegebenen Laufwerkes fest bzw. gibt diesen zurück. Lesen/Schreiben.
Syntax
Objekt.VolumeName [= NeuerName]

Die Syntax der VolumeName-Eigenschaft besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Stets der Name eines Drive-Objekts.
NeuerName | Optional. Falls angegeben, ist NeuerName der neue Name des angegebenen Objekts.

Hinweise
Der folgende Code veranschaulicht die Verwendung der VolumeName-Eigenschaft:
Function LWBezeichnungAnzeigen(Laufwerkangabe)
  Dim fso, l, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set l = fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(Laufwerkangabe)))
  s = "Laufwerk " & l.DriveLetter & ": - " & l.VolumeName
  LWBezeichnungAnzeigen = s
End Function


VolumeName-Eigenschaft

VolumeName-Eigenschaft
Betrifft 		Scripting-Laufzeitreferenz

Drive-Objekt


VolumeName-Eigenschaft

VolumeName-Eigenschaft
Siehe auch 		Scripting-Laufzeitreferenz

AvailableSpace-Eigenschaft
DriveLetter-Eigenschaft
DriveType-Eigenschaft
FileSystem-Eigenschaft
FreeSpace-Eigenschaft
IsReady-Eigenschaft
Path-Eigenschaft
RootFolder-Eigenschaft
SerialNumber-Eigenschaft
ShareName-Eigenschaft
TotalSize-Eigenschaft


Call-Anweisung

Call-Anweisung 		Sprachverzeichnis
Version 1

Beschreibung
Überträgt die Steuerung auf eine Sub- oder Function-Prozedur.
Syntax
[Call] Name [(ArgumentListe)]

Die Syntax der Call-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Call Optionales Schlüsselwort. Falls angegeben, muss ArgumentListe in Klammern hinzugefügt werden. Beispiele:

Call MeineProzedur(0)

Name | Erforderlich. Der Name der aufzurufenden Prozedur.
ArgumentListe | Optional. Durch Kommata getrennte Auflistung von Variablen, Datenfeldern oder Ausdrücken, die an die Prozedur übergeben werden sollen.

Hinweise
Es ist nicht erforderlich, das Call-Schlüsselwort beim Aufrufen einer Prozedur zu verwenden. Wenn Sie jedoch das Call-Schlüsselwort zum Aufrufen einer Prozedur verwenden, die Argumente benötigt, muss ArgumentListe in Klammern eingeschlossen werden. Wird das Call-Schlüsselwort nicht eingegeben, dürfen Sie die Klammern um Argumentliste ebenfalls nicht eingeben. Wenn Sie die Call-Syntax verwenden, um eine intrinsische oder benutzerdefinierte Funktion aufzurufen, wird der Rückgabewert der Funktion verworfen.
Call MeineFunktion("Hallo Welt!")

Function MeineFunktion(Text)
    MsgBox Text
End Function


Class-Anweisung

Class-Anweisung 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Deklariert sowohl den Namen einer Klasse als auch eine Definition der Variablen, Eigenschaften und Methoden, die in der Klasse enthalten sind.
Syntax
Class Name
Anweisungen
End Class

Die Syntax der Class-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Name | Erforderlich. Name der Klasse; entspricht den Standardkonventionen für Namen von Variablen.
Anweisungen | Erforderlich. Eine oder mehrere Anweisungen, die die Variablen, Eigenschaften und Methoden der Klasse festlegen.

Hinweise
Innerhalb eines Class-Blockes werden Elemente mithilfe der entsprechenden Deklarationsanweisung als Private oder Public deklariert. Als Private deklarierte Elemente sind nur im Class-Block sichtbar. Als Public deklarierte Elemente sind sowohl im Class-Block als auch im Code außerhalb des Class-Blockes sichtbar. Elemente, die nicht explizit als Private oder Public deklariert wurden, sind standardmäßig Public. Als Public innerhalb des Klassenblockes deklarierte Prozeduren (Sub oder Function) werden zu Methoden dieser Klasse. Public-Variablen dienen genauso als Eigenschaften für die Klasse wie Eigenschaften, die mithilfe von Property Get, Property Let und Property Set explizit deklariert wurden. Standardeigenschaften und -methoden für die Klasse werden in deren Deklarationen mithilfe des Default-Schlüsselworts definiert. Weitere Informationen zur Verwendung dieses Schlüsselworts finden Sie unter den jeweiligen Themen der einzelnen Deklarationsanweisungen.


Class-Anweisung

Class-Anweisung
Siehe auch 		Sprachverzeichnis

Dim-Anweisung
Function-Anweisung
Private-Anweisung
Property Get-Anweisung
Property Let-Anweisung
Property Set-Anweisung
Public-Anweisung
Set-Anweisung
Sub-Anweisung


Const-Anweisung

Const-Anweisung 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Deklariert Konstanten zur Verwendung anstelle von Literalwerten.
Syntax
[Public | Private] Const KonstName = Ausdruck

Die Syntax der Anweisung Const besteht aus folgenden Teilen:

Teil | Beschreibung
Public | Optional. Schlüsselwort auf Skriptebene zur Deklaration von Konstanten, die in allen Prozeduren und Skripten verfügbar sind. In Prozeduren nicht erlaubt.
Private | Optional. Schlüsselwort auf Skriptebene zur Deklaration von Konstanten, die nur innerhalb des Skriptes verfügbar sind, in dem sie deklariert wurden. In Prozeduren nicht erlaubt.
KonstName | Erforderlich. Name der Konstanten gemäß den Standardkonventionen für Namen von Variablen.
Ausdruck | Erforderlich. Literalwert oder andere Konstante oder eine Kombination daraus, die arithmetische oder logische Operatoren außer Is enthält.

Hinweise
Konstanten sind standardmäßig Public. Innerhalb von Prozeduren sind Konstanten immer Private, und ihr Gültigkeitsbereich kann nicht geändert werden. Innerhalb eines Skriptes kann die Voreinstellung für den Gültigkeitsbereich einer Konstanten auf Skriptebene mit dem Schlüsselwort Private geändert werden.

Zur Kombination von mehreren Konstantendeklarationen in der gleichen Zeile trennen Sie die Konstantenzuweisungen durch ein Komma. Werden Konstantendeklarationen auf diese Weise kombiniert, bezieht sich das Schlüsselwort Public oder Private (falls verwendet) auf alle diese Konstanten.

In Konstantendeklarationen dürfen Sie keine Variablen, benutzerdefinierten Funktionen oder intrinsische VBScript-Funktionen (wie z. B. Chr) verwenden. Laut Definition können diese keine Konstanten sein. Sie können auch keine Konstante aus einem Ausdruck erstellen, der einen Operator enthält, d. h., es sind nur einfache Konstanten erlaubt. Innerhalb einer Sub- oder Function-Prozedur deklarierte Konstanten sind nur lokal in dieser Prozedur gültig. Eine außerhalb einer Prozedur deklarierte Konstante gilt in dem ganzen Skript, in dem sie deklariert wurde. An allen Stellen, an denen Sie einen Ausdruck verwenden können, können Sie auch Konstanten einsetzen. Der folgende Code veranschaulicht die Verwendung der Const-Anweisung:

Const MeineVar = 459				' Konstanten sind standardmäßig Public.
Private Const MeineZf = "HILFE"			' Deklariert eine Private-Konstante.
Const MeineZf = "Hallo", MeineZahl = 3,4567	' Deklariert mehrere Konstanten in der gleichen Zeile.
Hinweis Mithilfe von Konstanten können Ihre Skripte selbstdokumentierend und einfach zu ändern sein. Im Gegensatz zu Variablen können Konstanten nicht versehentlich geändert werden, während Ihr Skript ausgeführt wird.


Const-Anweisung

Const-Anweisung
Siehe auch 		Sprachverzeichnis

Dim-Anweisung
Function-Anweisung
Private-Anweisung
Public-Anweisung
Sub-Anweisung


Dim-Anweisung

Dim-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Deklariert Variablen und reserviert Speicherplatz für sie.
Syntax
Dim VarName[([Dimensionen])][, VarName[([Dimensionen])]] . . .

Die Syntax der Dim-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
VarName | Name der Variablen gemäß den Standardkonventionen für Namen von Variablen.
Dimensionen Dimensionen einer Datenfeldvariablen. Bis zu 60 Dimensionen gleichzeitig sind zulässig. Die folgende Syntax wird für das Argument Dimensionen verwendet:

Obergrenze [,Obergrenze] . . .

Die Untergrenze der Elementzahl ist immer Null.

Hinweise
Variablen, die mit Dim auf Skriptebene deklariert wurden, stehen allen Prozeduren des Skriptes zur Verfügung. Auf Prozedurebene deklarierte Variablen stehen nur innerhalb der Prozedur zur Verfügung.

Die Dim-Anweisung in Kombination mit einem leeren Klammernpaar deklariert ein dynamisches Datenfeld. Nach einer solchen Deklaration können Sie mit der ReDim-Anweisung innerhalb einer Prozedur die Anzahl der Dimensionen und Elemente definieren. Wenn Sie eine Dimension für eine Datenfeldvariable mit einer weiteren Deklaration ändern möchten, die Größe des Datenfeldes aber bereits explizit mit einer Dim-Anweisung festgelegt wurde, tritt ein Fehler auf.

Tipp Wenn Sie die Dim-Anweisung in einer Prozedur verwenden, setzen Sie sie am Besten an den Anfang der Prozedur.

Der folgende Code veranschaulicht die Verwendung der Dim-Anweisung:

Dim Namen(9)     ' Deklariert ein Datenfeld mit 10 Elementen.
Dim Namen()      ' Deklariert ein dynamisches Datenfeld.
Dim MeineVar, MeineZahlen ' Deklariert zwei Variablen.


Dim-Anweisung

Dim-Anweisung
Siehe auch 		Sprachverzeichnis

Private-Anweisung
Public-Anweisung
ReDim-Anweisung
Set-Anweisung


Do...Loop-Anweisung

Do...Loop-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Wiederholt einen Block mit Anweisungen, solange eine Bedingung True ist oder bis eine Bedingung True wird.
Syntax
Do [{While | Until} Bedingung]
[Anweisungen]
[Exit Do]
[Anweisungen]
Loop

Sie können auch die folgende Syntax verwenden:

Do
[Anweisungen]
[Exit Do]
[Anweisungen]
Loop [{While | Until} Bedingung]

Die Syntax der Do...Loop-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Bedingung | Numerischer oder Zeichenfolgenausdruck, der True oder False zurückgibt. Hat Bedingung den Wert Null, wird Bedingung als False interpretiert.
Anweisungen | Eine oder mehrere Anweisungen, die wiederholt werden, während bzw. bis Bedingung True ist.

Hinweise
Exit Do ist nur innerhalb einer Do...Loop-Kontrollstruktur zulässig und stellt eine Alternative zum Verlassen von Do...Loop dar. Exit Do-Anweisungen können an beliebiger Stelle und beliebig oft in Do...Loop verwendet werden. Exit Do wird oft in Zusammenhang mit der Auswertung einer Bedingung (beispielsweise If...Then) eingesetzt und überträgt die Steuerung an die erste Anweisung, die auf Loop folgt.

In verschachtelten Do...Loop-Anweisungen übergibt Exit Do die Steuerung an die Schleife der nächsthöheren Verschachtelungsebene.

Der folgende Code veranschaulicht die Verwendung der Do...Loop-Anweisung:

Do Until StdAntwort = vbNo
  MeineZahl = Int (6 * Rnd + 1)	' Erzeugt eine zufällige Ganzzahl zwischen 1 und 6.
  StdAntwort = MsgBox (MeineZahl & " Möchten Sie eine weitere Zahl?", vbYesNo)
Loop

Dim Test, Zaehler
Test = True: Zaehler = 0		' Initialisiert die Variablen.
Do					' Äußere Schleife.
  Do While Zaehler < 20		' Innere Schleife.
    Zaehler = Zaehler + 1		' Zähler inkrementieren.
    If Zaehler = 10 Then		' Wenn die Bedingung erfüllt ist, ...
      Test = False			' ... wird der Wert von Test auf False gesetzt.
      Exit Do			' Beendet die innere Schleife.
    End If
  Loop
Loop Until Test = False		' Beendet die äußere Schleife sofort.


Do...Loop-Anweisung

Do...Loop-Anweisung
Siehe auch 		Sprachverzeichnis

Exit-Anweisung
For...Next-Anweisung
While...Wend-Anweisung


Erase-Anweisung

Erase-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Initialisiert die Elemente von Datenfeldern fester Größe neu und gibt den von einem dynamischen Datenfeld belegten Speicherplatz frei.
Syntax
Erase Datenfeld

Das Argument Datenfeld ist der Name der Datenfeldvariablen, die gelöscht werden soll.

Hinweise
Sie sollten wissen, ob es sich um ein (normales) Datenfeld mit fester Größe oder ein dynamisches Datenfeld handelt, da sich Erase je nach Datenfeldtyp unterschiedlich verhält. Erase gibt bei Datenfeldern mit fester Größe keinen Speicherplatz frei. Erase legt darüber hinaus die Elemente in Datenfeldern mit fester Größe folgendermaßen fest:

Datenfeldtyp | Wirkung von Erase auf Datenfeldelemente
Numerisch, feste Größe | Alle Elemente erhalten den Wert Null.
Zeichenfolgen, feste Größe | Alle Elemente werden auf Nulllänge ("") gesetzt.
Objekte | Alle Elemente erhalten den Sonderwert Nothing.

Erase gibt den von dynamischen Datenfeldern verwendeten Speicher frei. Vor dem nächsten Verweis auf das dynamische Datenfeld aus dem Programm müssen Sie die Dimensionen der Datenfeldvariablen mit einer ReDim-Anweisung neu deklarieren.

Der folgende Code veranschaulicht die Verwendung der Erase-Anweisung:

Dim FestesDatenfeld(9)
Dim DynamischesDatenfeld()
ReDim DynamischesDatenfeld(9)  ' Weist Speicherplatz zu.
Erase FestesDatenfeld          ' Initialisiert die einzelnen Elemente neu.
Erase DynamischesDatenfeld     ' Gibt den vom Datenfeld verwendeten Speicher frei.


Erase-Anweisung

Erase-Anweisung
Siehe auch 		Sprachverzeichnis

Dim-Anweisung
Nothing
ReDim-Anweisung


Execute-Anweisung

Execute-Anweisung 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Führt eine oder mehrere angegebene Anweisungen aus.
Syntax
Execute Anweisung

Das erforderliche Argument Anweisung ist ein Zeichenfolgenausdruck, der eine oder mehrere auszuführende Anweisungen enthält. Sie können mehrere Anweisungen in das Argument Anweisung einschließen, indem Sie diese durch Doppelpunkte oder eingebettete Zeilenumbrüche voneinander trennen.

Hinweise
In VBScript kann x = y auf zweierlei Weise interpretiert werden. Die erste Möglichkeit ist eine Zuweisungsanweisung, bei der x der Wert von y zugewiesen wird. Die zweite Interpretation ist ein Ausdruck, der überprüft, ob x und y den gleichen Wert haben. In diesem Fall wird Ergebnis der Wert True zugewiesen; sind sie nicht gleich, ist Ergebnis False. Die Execute-Anweisung verwendet stets die erste Interpretation, wohingegen bei der Eval-Methode die zweite verwendet wird.

Hinweis Bei Microsoft® JScript® besteht keine Verwechslungsgefahr zwischen Zuweisungen und Vergleichen, da Zuweisungsoperator (=) und Vergleichsoperator (==) unterschiedlich sind.

Der Kontext, in dem die Execute-Anweisung aufgerufen wird, legt fest, welche Objekte und Variablen für den auszuführenden Code verfügbar sind. Im Gültigkeitsbereich liegende Objekte und Variablen sind für Code verfügbar, der in einer Execute-Anweisung ausgeführt wird. Es ist jedoch wichtig, dass beim Ausführen von Code, der eine Prozedur erstellt, diese Prozedur nicht den Gültigkeitsbereich der Prozedur übernimmt, in der der Code steht.

Wie bei jeder Prozedur ist der Gültigkeitsbereich der neuen Prozedur global und übernimmt alle Elemente in den globalen Gültigkeitsbereich. Im Gegensatz zu anderen Prozeduren fällt der zugehörige Kontext nicht in den globalen Gültigkeitsbereich, sodass er nur in dem Kontext der Prozedur ausgeführt werden kann, in dem die Execute-Anweisung aufgetreten ist. Wird jedoch dieselbe Execute-Anweisung außerhalb einer Prozedur (d. h. im globalen Gültigkeitsbereich) aufgerufen, werden nicht nur alle Elemente in den globalen Gültigkeitsbereich übernommen, sondern sie kann auch von einer beliebigen Stelle aus aufgerufen werden, da der Kontext global ist. Das folgende Beispiel veranschaulicht dieses Verhalten:

Dim X			' Deklariert X im globalen Gültigkeitsbereich.
X = "Global"		' Weist globalem X einen Wert zu.
Sub Proz1	' Deklariert die Prozedur.
  Dim X		' Deklariert X im lokalen Gültigkeitsbereich.
  X = "Lokal"	' Weist lokalem X einen Wert zu.
            ' Die Execute-Anweisung erstellt hier eine
            ' Prozedur, die beim Aufruf X ausgibt.
            ' Das globale X wird ausgegeben, da Proz2
            ' alles im globalen Gültigkeitsbereich übernimmt.
  Execute "Sub Proz2: document.write X: End Sub"
  document.write Eval("X")	' Gibt lokales X aus.
  Proz2		' Ruft Proz2 im Proz1-Gültigkeitsbereich auf.
End Sub
Proz2			' Diese Zeile verursacht einen Fehler, da
            ' Proz2 außerhalb von Proz1 nicht verfügbar ist.
Proz1			' Ruft Proz1 auf.
  Execute "Sub Proz2: document.write X: End Sub"
Proz2			' Dieser Aufruf funktioniert, da Proz2
            ' nun global zur Verfügung steht.
Das folgende Beispiel zeigt, wie die Execute-Anweisung umgeschrieben werden kann, damit Sie nicht die gesamte Prozedur in Anführungszeichen einschließen müssen:

S = "Sub Proz2" & vbCrLf
S = S & "  document.write X" & vbCrLf
S = S & "End Sub"
Execute S


Execute-Anweisung

Execute-Anweisung
Siehe auch 		Sprachverzeichnis

Eval-Funktion
ExecuteGlobal-Anweisung


ExecuteGlobal-Anweisung

ExecuteGlobal-Anweisung 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Führt eine oder mehrere angegebene Anweisungen im globalen Namensraum eines Skriptes aus.
Syntax
ExecuteGlobal Anweisung

Das erforderliche Argument Anweisung ist ein Zeichenfolgenausdruck, der eine oder mehrere Ausführungsanweisungen enthält. Sie können mehrere Anweisungen in das Argument Anweisung einschließen, indem Sie diese durch Doppelpunkte oder eingebette Zeilenumbrüche voneinander trennen.

Hinweise
In VBScript kann x = y auf zweierlei Weise interpretiert werden. Die erste Möglichkeit ist eine Zuweisungsanweisung, bei der x der Wert von y zugewiesen wird. Die zweite Interpretation ist ein Ausdruck, der überprüft, ob x und y den gleichen Wert haben. In diesem Fall wird Ergebnis der Wert True zugewiesen; sind sie nicht gleich, ist Ergebnis False. Die ExecuteGlobal-Anweisung verwendet stets die erste Interpretation, wohingegen bei der Eval-Methode die zweite verwendet wird.

Anmerkung Bei Microsoft® JScript® besteht keine Verwechslungsgefahr zwischen Zuweisungen und Vergleichen, da Zuweisungsoperator (=) und Vergleichsoperator (==) unterschiedlich sind.

Alle mit ExecuteGlobal verwendeten Anweisungen werden im globalen Namensraum eines Skriptes ausgeführt. Damit ist es möglich, dem Programm Code hinzuzufügen, auf den jede Prozedur zugreifen kann. So kann z. B. eine VBScript Class-Anweisung zur Laufzeit ausgeführt werden, und Funktionen können anschließend neue Instanzen der Klasse erstellen.

Das Hinzufügen von Prozeduren und Klassen zur Laufzeit kann nützlich sein, bringt jedoch auch die Gefahr mit sich, dass zur Laufzeit globale Variablen und Funktionen überschrieben werden. Da dies erhebliche Programmierprobleme verursachen kann, ist die ExecuteGlobal-Anweisung mit Vorsicht zu verwenden. Verwenden Sie besser die Execute-Anweisung, wenn Sie auf eine Variable oder Funktion nicht außerhalb einer Prozedur zugreifen müssen. Diese wirkt sich nur auf den Namensraum der aufrufenden Funktion aus.

Das folgende Beispiel veranschaulicht die Verwendung der ExecuteGlobal-Anweisung:

Dim X			' Deklariert X im globalen Gültigkeitsbereich.
X = "Global"		' Weist globalem X einen Wert zu.
Sub Proz1	' Deklariert die Prozedur.
  Dim X		' Deklariert X im lokalen Gültigkeitsbereich.
  X = "Lokal"	' Weist lokalem X einen Wert zu.
            ' Die Execute-Anweisung erstellt hier eine
            ' Prozedur, die beim Aufruf X ausgibt.
            ' Das globale X wird ausgegeben, da Proz2
            ' alles im globalen Gültigkeitsbereich übernimmt.
  ExecuteGlobal "Sub Proz2: document.write X: End Sub"
  document.write Eval("X")	' Gibt lokales X aus.
  Proz2		' Ruft Proz2 im globalen Gültigkeitsbereich auf.
            ' Daher wird "Global" ausgegeben.
End Sub
Proz2			' Diese Zeile verursacht einen Fehler, da
            ' Proz2 außerhalb von Proz1 nicht verfügbar ist.
Proz1			' Ruft Proz1 auf.
  Execute "Sub Proz2: document.write X: End Sub"
Proz2			' Dieser Aufruf funktioniert, da Proz2
            ' nun global zur Verfügung steht.
Das folgende Beispiel zeigt, wie die ExecuteGlobal-Anweisung umgeschrieben werden kann, damit Sie nicht die gesamte Prozedur in Anführungszeichen einschließen müssen:

S = "Sub Proz2" & vbCrLf
S = S & "  document.write X" & vbCrLf
S = S & "End Sub"
ExecuteGlobal S


ExecuteGlobal-Anweisung

ExecuteGlobal-Anweisung
Siehe auch 		Sprachverzeichnis

Eval-Funktion
Execute-Anweisung


Exit-Anweisung

Exit-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Beendet die Ausführung eines durch Do...Loop, For...Next, Function oder Sub definierten Codeblockes.
Syntax
Exit Do

Exit For

Exit Function

Exit Property

Exit Sub

Sie können die Exit-Anweisung mit folgender Syntax verwenden:

Anweisung | Beschreibung
Exit Do | Eine Möglichkeit zum Verlassen einer Do...Loop-Anweisung. Die Anweisung ist nur innerhalb einer Do...Loop-Anweisung zulässig. Exit Do gibt die Steuerung an die erste Anweisung im Anschluss an die Loop-Anweisung weiter. In verschachtelten Do...Loop-Anweisungen übergibt Exit Do die Steuerung an die Schleife der nächsthöheren Verschachtelungsebene.
Exit For | Eine Möglichkeit zum Verlassen einer For-Schleife. Kann nur bei einer For...Next- oder For Each...Next-Schleife verwendet werden. Exit For gibt die Steuerung an die erste Anweisung im Anschluss an die Next-Anweisung weiter. In verschachtelten For-Schleifen übergibt Exit For die Steuerung an die Schleife der nächsthöheren Verschachtelungsebene.
Exit Function | Beendet die umgebende Function-Prozedur mit sofortiger Wirkung. Das Programm setzt die Ausführung mit der Anweisung fort, die dem Aufruf der Function-Prozedur folgt.
Exit Property | Beendet die umgebende Property-Prozedur mit sofortiger Wirkung. Die Ausführung wird mit der Anweisung fortgesetzt, die dem Aufruf der Property-Prozedur folgt.
Exit Sub | Beendet die umgebende Sub-Prozedur mit sofortiger Wirkung. Das Programm setzt die Ausführung mit der Anweisung fort, die dem Aufruf der Sub-Prozedur folgt.

Der folgende Code veranschaulicht die Verwendung der Exit-Anweisung:

Sub Zufallsschleife
  Dim I, MeineZahl
  Do                           ' Startet unbegrenzte Schleife.
    For I = 1 To 1000          ' Legt 1000 Schleifendurchläufe fest.
      MeineZahl = Int(Rnd * 100)   ' Generiert Zufallszahlen.
      Select Case MeineZahl        ' Wertet Zufallszahlen aus.
        Case 17: MsgBox "MeineZahl ist 17"
          Exit For             ' Beendet For...Next, wenn MeineZahl = 17.
        Case 29: MsgBox "MeineZahl ist 29"
          Exit Do              ' Beendet Do...Loop, wenn MeineZahl = 29.
        Case 54: MsgBox "MeineZahl ist 54"
          Exit Sub             ' Beendet Sub-Prozedur, wenn MeineZahl = 54.
        End Select
    Next
  Loop
End Sub


Exit-Anweisung

Exit-Anweisung
Siehe auch 		Sprachverzeichnis

Do...Loop-Anweisung
For Each...Next-Anweisung
For...Next-Anweisung
Function-Anweisung
Sub-Anweisung


For...Next-Anweisung

For...Next-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Wiederholt eine Gruppe von Anweisungen, bis ein Schleifenzähler einen bestimmten Wert erreicht.
Syntax
For Zähler = Start To Ende [Step Schritt]
[Anweisungen]
[Exit For]
[Anweisungen]
Next

Die Syntax der For...Next-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Zähler | Numerische Variable, die als Schleifenzähler verwendet wird. Ein Element eines Datenfeldes oder eines benutzerdefinierten Types ist an dieser Stelle nicht zulässig.
Start | Startwert von Zähler.
Ende | Endwert von Zähler.
Schritt | Schrittweite, um die Zähler bei jedem Schleifendurchlauf verändert wird. Der Standardwert für Schritt ist 1, falls kein Wert angegeben wird.
Anweisungen | Eine oder mehrere Anweisungen zwischen For und Next, die so oft wie angegeben wiederholt werden.

Hinweise
Das Argument Schritt kann positiv oder negativ sein. Der Wert des Arguments Schritt hat folgende Auswirkungen auf die Schleifenausführung:

Wert | Schleifenausführung
Positiv oder 0 | Wenn Zähler <= Ende
Negativ | Wenn Zähler >= Ende

Nachdem im ersten Schleifendurchlauf alle Anweisungen ausgeführt wurden, addiert das Programm Schritt zum Wert von Zähler hinzu. Die Anweisungen in der Schleife werden dann entweder erneut ausgeführt (aufgrund desselben Tests, der auch zu Beginn des ersten Durchlaufs durchgeführt wurde), oder das Programm beendet die Schleife und setzt die Ausführung mit der Anweisung fort, die auf die Next-Anweisung folgt.

Tipp Wenn Sie den Wert von Zähler innerhalb einer Schleife ändern, erschwert dies das Verständnis und das Testen des Codes.

Exit For ist nur innerhalb einer For Each...Next- oder For...Next-Kontrollstruktur zulässig und stellt eine Alternative zum Verlassen der Kontrollstruktur da. Exit For kann an beliebiger Stelle und beliebig oft in der Schleife verwendet werden. Exit For wird oft in Zusammenhang mit der Auswertung einer Bedingung (zum Beispiel If...Then) eingesetzt und weist das Programm an, die Ausführung mit der ersten Anweisung hinter Next fortzusetzen.

Sie können For...Next-Schleifen verschachteln, indem Sie eine For...Next-Schleife in eine andere setzen. Verwenden Sie für jede Schleife einen eindeutigen Variablennamen als Zähler. Die folgende Konstruktion ist korrekt:

For I = 1 To 10
    For J = 1 To 10
        For K = 1 To 10
        . . .
        Next
    Next
Next


For...Next-Anweisung

For...Next-Anweisung
Siehe auch 		Sprachverzeichnis

Do...Loop-Anweisung
Exit-Anweisung
For Each...Next-Anweisung
While...Wend-Anweisung


For Each...Next-Anweisung

For Each...Next-Anweisung 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Wiederholt eine Reihe von Anweisungen für alle Elemente eines Datenfeldes oder einer Auflistung.
Syntax
For Each Element In Gruppe
[Anweisungen]
[Exit For]
[Anweisungen]
Next [Element]

Die Syntax der For Each...Next-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Element | Variable zum Durchlaufen der Elemente der Auflistung oder des Datenfeldes. Bei Auflistungen sind für Element nur Variablen vom Typ Variant, allgemeine Variablen vom Typ Object oder spezielle Variablen für Automatisierungsobjekte zulässig. Bei Datenfeldern sind für Element nur Variablen vom Typ Variant zulässig.
Gruppe | Name einer Objektauflistung oder eines Datenfeldes.
Anweisungen | Eine oder mehrere Anweisungen, die für jedes Element in Gruppe ausgeführt werden.

Hinweise
Der For Each-Block wird ausgeführt, wenn sich mindestens ein Element in Gruppe befindet. In diesem Fall führt das Programm alle Anweisungen in der Schleife für das erste Element in Gruppe aus. Die Schleife wird für alle Elemente in Gruppe wiederholt, bis sich keine Elemente mehr in Gruppe befinden. Dann verlässt das Programm die Schleife und setzt die Ausführung mit der Anweisung fort, die auf die Next-Anweisung folgt.

Exit For ist nur innerhalb einer For Each...Next- oder For...Next-Kontrollstuktur zulässig und stellt eine Alternative zum Verlassen der Struktur dar. Exit For kann an beliebiger Stelle und beliebig oft in der Schleife verwendet werden. Exit For wird oft in Zusammenhang mit der Auswertung einer Bedingung (zum Beispiel If...Then) eingesetzt und weist das Programm an, die Ausführung mit der ersten Anweisung im Anschluss an Next fortzusetzen.

Sie können For Each...Next-Schleifen verschachteln, indem Sie eine For Each...Next-Schleife innerhalb einer anderen verwenden. Das Argument Element muss jedoch für alle Schleifen eindeutig sein.

Hinweis Wird Element in einer Next-Anweisung nicht angegeben, wird die Ausführung dennoch fortgesetzt. Eine Next-Anweisung vor der zugehörigen For-Anweisung führt zu einem Fehler.

Der folgende Code veranschaulicht die Verwendung der For Each...Next-Anweisung:

Function OrdnerlisteAnzeigen(Ordnerangabe)
  Dim fso, f, f1, fc, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f = fso.GetFolder(Ordnerangabe)
  Set fc = f.Files
  For Each f1 in fc
    s = s & f1.name
    s = s & "<BR>"
  Next
  OrdnerlisteAnzeigen = s
End Function


For Each...Next-Anweisung

For Each...Next-Anweisung
Siehe auch 		Sprachverzeichnis

Do...Loop-Anweisung
Exit-Anweisung
For...Next-Anweisung
While...Wend-Anweisung


Function-Anweisung

Function-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Deklariert Namen, Argumente und Code, die den Rumpf einer Function-Prozedur bilden.
Syntax
[Public [Default] | Private] Function Name [(ArgListe)]
[Anweisungen]
[Name = Ausdruck]
[Exit Function]
[Anweisungen]
[Name = Ausdruck]
End Function

Die Syntax der Function-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Public | Gibt an, dass auf die Function-Prozedur von allen anderen Prozeduren in allen Skripten zugegriffen werden kann.
Default | Wird nur mit einem Public-Schlüsselwort in einem Class-Block verwendet, um anzugeben, dass die Function-Prozedur die Standardmethode für die Klasse ist. Ist mehr als eine Default-Prozedur in einer Klasse angegeben, tritt ein Fehler auf.
Private | Gibt an, dass nur Prozeduren in dem Skript, in denen sie deklariert wurde, auf die Function-Prozedur zugreifen können, oder wenn die Funktion Element einer Klasse ist, nur andere Prozeduren in dieser Klasse.
Name | Name der Function-Prozedur gemäß den Standardkonventionen für Namen von Variablen.
ArgListe | Variablenliste mit den Argumenten, die an die Function-Prozedur beim Aufruf übergeben werden. Mehrere Variablen werden durch Kommata voneinander getrennt.
Anweisungen | Eine beliebige Gruppe auszuführender Anweisungen im Rumpf einer Function-Prozedur.
Ausdruck | Rückgabewert von Function.

Das Argument ArgListe verwendet die folgende Syntax und die folgenden Teile:

[ByVal | ByRef] VarName[( )]

Teil | Beschreibung
ByVal | Gibt an, dass das Argument als Wert übergeben wird.
ByRef | Gibt an, dass das Argument als Verweis übergeben wird.
VarName | Name der Variablen, die das Argument darstellt, gemäß den Standardkonventionen für den Namen von Variablen.

Hinweise
Auf Function-Prozeduren kann standardmäßig von allen anderen Prozeduren aus zugegriffen werden, wenn dies nicht explizit durch Public oder Private angegeben wird, das heißt, sie sind für alle anderen Prozeduren im Skript sichtbar. Der Wert lokaler Variablen in Function wird zwischen Aufrufen der Prozedur nicht zwischengespeichert.

Sie können eine Function-Prozedur nicht innerhalb einer anderen Prozedur festlegen (z. B. Sub oder Property Get).

Die Exit Function-Anweisung führt zur sofortigen Beendigung der Function-Prozedur. Die Programmausführung wird mit der Anweisung fortgesetzt, die auf die Anweisung folgt, welche die Function-Prozedur aufgerufen hat. In einer Function-Prozedur kann eine beliebige Anzahl von Exit Function-Anweisungen an beliebiger Stelle vorkommen.

Ähnlich wie eine Sub-Prozedur ist eine Function-Prozedur eine separate Prozedur, die Argumente übernehmen, eine Reihe von Anweisungen ausführen und die Werte ihrer Argumente ändern kann. Im Unterschied zu einer Sub-Prozedur können Sie eine Function-Prozedur auf der rechten Seite eines Ausdruckes auf gleiche Weise verwenden wie eine intrinsische Funktion, wie z. B. Sqr, Cos oder Chr, wenn Sie den von der Funktion zurückgegebenen Wert verwenden möchten.

Sie rufen eine Function-Prozedur in einem Ausdruck über den Funktionsnamen auf, gefolgt von der Argumentliste in Klammern. Unter Call-Anweisung finden Sie spezifische Informationen über das Aufrufen von Function-Prozeduren.

Vorsicht Function-Prozeduren können rekursiv sein; d. h. sie können sich selbst aufrufen, um eine bestimmte Aufgabe durchzuführen. Rekursionen können jedoch zu Stapelüberlauffehlern führen.

Um aus einer Funktion einen Wert zurückzugeben, weisen Sie den Wert dem Funktionsnamen zu. Innerhalb der Prozedur kann eine beliebige Anzahl solcher Zuweisungen an beliebiger Stelle auftreten. Wird Name kein Wert zugewiesen, gibt die Prozedur einen Standardwert zurück: Eine numerische Funktion gibt 0 zurück, und eine Zeichenfolgenfunktion gibt eine Zeichenfolge der Länge Null ("") zurück. Eine Funktion, die einen Objektverweis zurückgibt, liefert als Standardwert Nothing, falls Name kein Objektverweis zugewiesen wurde (durch Set) innerhalb der Function.

Das folgende Beispiel zeigt, wie einer Funktion namens BinaerSuche ein Rückgabewert zugewiesen wird. In diesem Fall wird dem Namen der Wert False zugewiesen, um anzuzeigen, dass der gesuchte Wert nicht gefunden wurde.

Function BinaerSuche(. . .)
    . . .
    ' Wert nicht gefunden. Gibt einen False-Wert zurück.
    If unten > oben Then
        BinaerSuche = False
        Exit Function
    End If
    . . .
End Function
Es gibt zwei Arten von Variablen, die in Function-Prozeduren verwendet werden: solche, die innerhalb der Prozedur explizit deklariert werden, und andere. Variablen, die explizit in einer Prozedur deklariert werden (mit Dim oder gleichwertiger Anweisung) sind immer prozedurlokal. Variablen, die verwendet, aber nicht explizit innerhalb einer Prozedur deklariert werden, sind ebenfalls lokal, es sei denn, sie wurden auf einer höheren Ebene außerhalb der Prozedur explizit deklariert.

Vorsicht Eine Prozedur kann eine nicht explizit in der Prozedur deklarierte Variable zwar verwenden, jedoch können Namenskonflikte auftreten, falls ein anderes auf Skriptebene definiertes Element denselben Namen hat. Verwendet Ihre Prozedur eine nicht deklarierte Variable mit einem Namen, der dem Namen einer anderen Prozedur, Konstanten oder Variablen entspricht, wird davon ausgegangen, dass Ihre Prozedur auf diesen Skriptebenennamen verweist. Verwenden Sie eine Option Explicit-Anweisung, um solche Konflikte zu vermeiden und eine explizite Deklaration von Variablen zu erzwingen.

Vorsicht VBScript ordnet u. U. arithmetische Ausdrücke anders an, um die interne Effizienz zu erhöhen. Vermeiden Sie die Verwendung von Function-Prozeduren in einem arithmetischen Ausdruck, wenn die Funktion den Wert von Variablen im selben Ausdruck ändert.


Function-Anweisung

Function-Anweisung
Siehe auch 		Sprachverzeichnis

Call-Anweisung
Dim-Anweisung
Exit-Anweisung
Nothing
Set-Anweisung
Sub-Anweisung


If...Then...Else-Anweisung

If...Then...Else-Anweisung 		Sprachverzeichnis
Version 1

Beschreibung
Wertet einen Ausdruck aus und führt in Abhängigkeit vom Ergebnis eine Reihe von Anweisungen aus.
Syntax
If Bedingung Then Anweisungen [Else elseAnweisungen ]

Sie können auch die folgende flexiblere Syntax verwenden:

If Bedingung Then
[Anweisungen]
[ElseIf Bedingung-n Then
[elseifAnweisungen]] . . .
[Else
[elseAnweisungen]]
End If

Die Syntax der If...Then...Else-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Bedingung Ein oder mehrere Ausdrücke der beiden folgenden Arten:

Numerischer Ausdruck oder Zeichenfolgenausdruck, der als Ergebnis True oder False liefert. Hat Bedingung den Wert Null, wird Bedingung als False interpretiert.

Ein Ausdruck der Form TypeOf Objektname Is Objekttyp. Objektname ist eine Objektreferenz und Objekttyp ein beliebiger gültiger Objekttyp. Der Ausdruck ist True, wenn Objektname den Objekttyp hat, der durch Objekttyp angegeben wird; andernfalls ist das Ergebnis False.

Anweisungen | Eine Anweisung oder mehrere durch Doppelpunkte voneinander getrennte Anweisungen, die ausgeführt werden, wenn Bedingung den Wert True hat.
Bedingung-n | Dieselbe Bedeutung wie Bedingung.
elseifAnweisungen | Eine oder mehrere Anweisungen, die ausgeführt werden, wenn die zugehörige Bedingung (Bedingung-n) True ergibt.
elseAnweisungen | Eine oder mehrere Anweisungen, die ausgeführt werden, wenn keine der Bedingungen (Bedingung oder Bedingung-n) den Wert True ergibt.

Hinweise
Die einzeilige Variante (erste Syntax) bietet sich bei einfachen Tests an. Die Blockvariante (zweite Syntax) ist dagegen strukturierter und flexibler als die einzeilige Variante und kann in der Regel leichter gelesen, gepflegt und getestet werden.

Anmerkungen Die einzeilige Syntax erlaubt die Ausführung mehrerer Anweisungen als Ergebnis einer If...Then-Entscheidung. Dazu müssen sich aber alle Anweisungen in einer Zeile befinden und durch Doppelpunkte voneinander getrennt sein, wie in der folgenden Zeile:
If A > 10 Then A = A + 1 : B = B + A : C = C + B

Beim Ausführen eines If-Blockes (zweite Syntax) wird Bedingung getestet. Ist Bedingung True, werden die auf Then folgenden Anweisungen ausgeführt. Ist Bedingung False, werden die einzelnen ElseIf (sofern vorhanden) nacheinander ausgewertet. Wird eine Bedingung als True ausgewertet, werden die auf das dazugehörige Then folgenden Anweisungen ausgeführt. Ist keine der ElseIf-Anweisungen True (oder sind keine ElseIf-Klauseln vorhanden), werden die auf Else folgenden Anweisungen ausgeführt. Nach Ausführung der Anweisungen, die auf Then oder Else folgen, wird die Ausführung mit den Anweisungen fortgesetzt, die auf End If folgen.

Die Else- und ElseIf-Klauseln sind optional. In einem If-Block können Sie beliebig viele ElseIf-Abschnitte verwenden. Nach einer Else-Klausel sind jedoch keine ElseIf-Klauseln zulässig. If-Anweisungsblöcke können verschachtelt werden, d. h. wiederum selbst If-Blöcke enthalten.

Der Code im Anschluss an das Schlüsselwort Then entscheidet darüber, ob es sich bei der Anweisung um einen If-Block handelt oder nicht. Befindet sich hinter Then in derselben Zeile weiterer Code (Kommentare ausgenommen), handelt es sich um eine einzeilige If-Anweisung.

Eine Anweisung für einen If-Block muss die erste Anweisung in einer Zeile sein. Der If-Block muss mit einer End If-Anweisung beendet werden.


On Error-Anweisung

On Error-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Aktiviert oder deaktiviert die Fehlerbehandlung.
Syntax
On Error Resume Next
On Error GoTo 0
Hinweise
Wenn Sie in Ihrem Code keine On Error Resume Next-Anweisung verwenden, kann jeder Laufzeitfehler bewirken, dass eine Fehlermeldung angezeigt und die Codeausführung beendet wird. Das tatsächliche Verhalten wird jedoch von dem Host bestimmt, der den Code ausführt. Der Host kann manchmal entscheiden, solche Fehler anders zu behandeln. In einigen Fällen wird beim Auftreten des Fehlers der Script Debugger aufgerufen. In anderen Fällen wird möglicherweise übersehen, dass ein Fehler auftrat, da der Host den Benutzer nicht informiert. Auch dies richtet sich allein danach, wie der Host aufgetretene Fehler behandelt.

Innerhalb einer bestimmten Prozedur ist ein Fehler nicht unbedingt schwerwiegend, wenn an irgendeiner Stelle im Aufrufstapel die Fehlerbehandlung aktiviert ist. Wenn in einer Prozedur die lokale Fehlerbehandlung nicht aktiviert ist und ein Fehler auftritt, geht die Steuerung durch den Stapel zurück, bis eine Prozedur mit aktivierter Fehlerbehandlung gefunden wird. Nun wird der Fehler verarbeitet. Wenn im Stapel keine Prozedur mit aktivierter Fehlerbehandlung gefunden wird, wird eine Fehlermeldung angezeigt und die Ausführung wird beendet, oder der Host behandelt den Fehler entsprechend.

Das Programm setzt nach einer On Error Resume Next-Anweisung die Ausführung mit der Anweisung fort, die unmittelbar auf die Anweisung folgt, die den Laufzeitfehler verursacht hat, oder mit der Anweisung, die unmittelbar auf den letzten Aufruf einer anderen Prozedur folgt, in der die On Error Resume Next-Anweisung enthalten ist. Dadurch kann das Programm die Ausführung trotz eines Laufzeitfehlers fortsetzen, und Sie können die Fehlerbehandlung direkt im Anschluß an eine fehlerverursachende Anweisung durchführen anstatt an eine andere Stelle innerhalb der Prozedur zu verzweigen. Sie können dann die Fehlerbehandlungsroutine direkt innerhalb der Prozedur integrieren.

Eine On Error Resume Next-Anweisung wird inaktiv, wenn eine andere Prozedur aufgerufen wird, weshalb Sie in jeder aufgerufenen Routine eine On Error Resume Next-Anweisung ausführen sollten, wenn Sie die Fehlerbehandlung direkt in der jeweiligen Routine durchführen möchten. Wenn eine Prozedur beendet wird, kehrt die Fehlerbehandlung zu dem Verfahren zurück, das vor dem Eintreten in die gerade beendete Prozedur in Kraft war.

Verwenden Sie On Error GoTo 0, um die Fehlerbehandlung zu deaktivieren, wenn Sie sie vorher mit On Error Resume Next aktiviert haben.

Das folgende Beispiel veranschaulicht die Verwendung der On Error Resume Next-Anweisung:

On Error Resume Next
Err.Raise 6  ' Erzeugt einen Überlauffehler.
MsgBox "Fehler Nr. " & CStr(Err.Number) & " " & Err.Description
Err.Clear    ' Löscht die Fehlermeldung.


On Error-Anweisung

On Error-Anweisung
Siehe auch 		Sprachverzeichnis

Err-Objekt
Exit-Anweisung


Option Explicit-Anweisung

Option Explicit-Anweisung 		Sprachverzeichnis
Version 1

Beschreibung
Erzwingt die explizite Deklaration aller Variablen in einem Skript.
Syntax
Option Explicit
Hinweise
Wird die Option Explicit-Anweisung verwendet, muss sie im jeweiligen Script vor allen Anweisungen stehen.

Wenn Sie die Option Explicit-Anweisung verwenden, müssen alle Variablen explizit mit den Anweisungen Dim, Private, Public oder ReDim deklariert werden. Wenn Sie einen nicht deklarierten Variablennamen verwenden, tritt ein Fehler auf.

Tipp Mit Option Explicit vermeiden Sie falsch geschriebene Namen bereits bestehender Variablen oder Verwechslungen im Code bei unklarem Gültigkeitsbereich von Variablen.

Der folgende Code veranschaulicht die Verwendung der Option Explicit-Anweisung:

Option Explicit     ' Erzwingt explizites Deklarieren von Variablen.
Dim MeineVar        ' Deklariert eine Variable.
MeinInt = 10        ' Nicht deklarierte Variable verursacht einen Fehler.
MeineVar = 10       ' Deklarierte Variable verursacht keinen Fehler.


Private-Anweisung

Private-Anweisung 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Deklariert private Variablen und reserviert Speicherplatz. Deklariert in einem Class-Block private Variablen.
Syntax
Private VarName[([Dimensionen])][, VarName[([Dimensionen])]] . . .

Die Syntax der Private-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
VarName | Name der Variablen; entspricht den Standardkonventionen für Namen von Variablen.
Dimensionen Dimensionen einer Datenfeldvariablen. Bis zu 60 Dimensionen gleichzeitig sind zulässig. Die folgende Syntax wird für das Argument Dimensionen verwendet:

Obergrenze [, Obergrenze] . . .

Die Untergrenze der Elementzahl ist immer Null.

Hinweise
Private-Variablen sind nur in dem Skript verfügbar, in dem sie deklariert wurden.

Einer Variablen, die auf ein Objekt verweist, muss ein vorhandenes Objekt mit der Set-Anweisung zugeordnet sein, bevor sie eingesetzt werden kann. Bis zur eigentlichen Objektzuordnung wird die deklarierte Objektvariable als Empty initialisiert.

Sie können die Private-Anweisung mit leeren Klammern auch zum Deklarieren von dynamischen Datenfeldern einsetzen. Verwenden Sie dann anschließend die ReDim-Anweisung innerhalb einer Prozedur, um die Anzahl der Dimensionen und Elemente in diesem Datenfeld festzulegen. Wenn Sie versuchen, die Dimension einer Datenfeldvariablen, deren Größe explizit in einer Private-, Public- oder Dim-Anweisung angegeben war, neu zu deklarieren, tritt ein Fehler auf.

Tipp Wenn Sie die Private-Anweisung in einer Prozedur verwenden, sollten Sie sie nach der allgemeinen Programmierpraxis an den Anfang der Prozedur stellen.

Der folgende Code veranschaulicht die Verwendung der Private-Anweisung:

Private MeineZahl   	' Private Variant-Variable.
Private MeinDatenfeld(9)	' Private Datenfeldvariable.
            ' Mehrere Private-Deklarationen von Variant-Variablen.
Private MeineZahl, MeineVar, DeineZahl


Private-Anweisung

Private-Anweisung
Siehe auch 		Sprachverzeichnis

Dim-Anweisung
Public-Anweisung
ReDim-Anweisung
Set-Anweisung


Property Get-Anweisung

Property Get-Anweisung 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Deklariert in einem Class-Block den Namen, Argumente sowie den Code, die den Rumpf einer Property-Prozedur bilden, die den Wert einer Eigenschaft liest (zurückgibt).
Syntax
[Public [Default]| Private] Property Get Name [(ArgListe)]
[Anweisungen]
[[Set] Name = Ausdruck]
[Exit Property]
[Anweisungen]
[[Set] Name = Ausdruck]
End Property

Die Syntax der Property Get-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Public | Gibt an, dass alle anderen Prozeduren in sämtlichen Skripten auf die Property Get-Prozedur zugreifen können.
Default | Wird nur mit dem Public-Schlüsselwort verwendet, um anzugeben, dass es sich bei der in der Property Get-Prozedur festgelegten Eigenschaft um die standardmäßige Eigenschaft für die Klasse handelt.
Private | Gibt an, dass auf die Property Get-Prozedur nur von Prozeduren in dem Class-Block zugegriffen werden kann, in dem sie deklariert wurde.
Name | Name der Property Get-Prozedur; entspricht den standardmäßigen Benennungskonventionen von Variablen, mit der Ausnahme, dass der Name mit einer Property Let- oder Property Set-Prozedur im selben Class-Block übereinstimmen kann.
ArgListe | Auflistung von Variablen, die Argumente darstellen und an die Property Get-Prozedur weitergeleitet werden, wenn diese aufgerufen wird. Mehrere Argumente werden voneinander durch Kommata getrennt. Der Name der einzelnen Argumente in einer Property Get-Prozedur muss dem zugehörigen Argument in einer Property Let-Prozedur (sofern vorhanden) entsprechen.
Anweisungen | Eine beliebige Gruppe von Anweisungen, die innerhalb des Rumpfs einer Property Get-Prozedur auszuführen sind.
Set | Schlüsselwort, das beim Zuweisen eines Objekts als Rückgabewert einer Property Get-Prozedur verwendet wird.
Ausdruck | Rückgabewert der Property Get-Prozedur.

Hinweise
Auf Property Get-Prozeduren kann standardmäßig von allen anderen Prozeduren aus zugegriffen werden, wenn dies nicht explizit durch Public oder Private angegeben wird, das heißt, sie sind für alle anderen Prozeduren im Skript sichtbar. Der Wert lokaler Variablen in der Property Get-Prozedur wird zwischen Aufrufen der Prozedur nicht zwischengespeichert.

Sie können eine Property Get-Prozedur nicht innerhalb einer anderen Prozedur (z. B. Function oder Property Let) festlegen.

Die Exit Property-Anweisung führt zur sofortigen Beendigung einer Property Get-Prozedur. Die Programmausführung wird mit der Anweisung fortgeführt, die auf die Anweisung folgt, die die Property Get-Prozedur aufgerufen hat. In einer Property Get-Prozedur kann eine beliebige Anzahl von Exit Property-Anweisungen an beliebiger Stelle stehen.

Ähnlich wie eine Sub- bzw. Property Let- ist eine Property Get-Prozedur eine separate Prozedur, die Argumente übernehmen, eine Reihe von Anweisungen durchführen und die Werte ihrer Argumente ändern kann. Im Gegensatz zu einer Sub- und Property Let-Prozedur können Sie eine Property Get-Prozedur auf der rechten Seite eines Ausdruckes auf die gleiche Weise verwenden wie Function oder einen Eigenschaftennamen, wenn Sie den Wert einer Eigenschaft zurückgeben möchten.


Property Get-Anweisung

Property Get-Anweisung
Siehe auch 		Sprachverzeichnis

Class-Anweisung
Dim-Anweisung
Exit-Anweisung
Function-Anweisung
Private-Anweisung
Property Let-Anweisung
Property Set-Anweisung
Public-Anweisung
Set-Anweisung
Sub-Anweisung


Property Let-Anweisung

Property Let-Anweisung 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Deklariert in einem Class-Block den Namen, Argumente sowie den Code, die den Rumpf einer Property-Prozedur bilden, die den Wert einer Eigenschaft zuweist (festlegt).
Syntax
[Public | Private] Property Let Name ([ArgListe,] Wert)
[Anweisungen]
[Exit Property]
[Anweisungen]
End Property

Die Syntax der Property Let-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Public | Gibt an, dass auf die Property Let-Prozedur von allen anderen Prozeduren in allen Skripten zugegriffen werden kann.
Private | Gibt an, dass auf die Property Let-Prozedur nur von Prozeduren in dem Class-Block zugegriffen werden kann, in dem sie deklariert wurde.
Name | Name der Property Let-Prozedur; entspricht den standardmäßigen Benennungskonventionen von Variablen, mit der Ausnahme, dass der Name mit einer Property Get- oder Property Set-Prozedur im selben Class-Block übereinstimmen kann.
ArgListe | Auflistung von Variablen, die Argumente darstellen und an die Property Let-Prozedur übergeben werden, wenn diese aufgerufen wird. Mehrere Argumente werden voneinander durch Kommata getrennt. Der Name der einzelnen Argumente in einer Property Let-Prozedur muss dem zugehörigen Argument in einer Property Get-Prozedur entsprechen. Darüber hinaus weist die Property Let-Prozedur stets ein Argument mehr als seine zugehörige Property Get-Prozedur auf. Das Argument ist der der Eigenschaft zugewiesene Wert.
Wert | Variable, die den einer Eigenschaft zuzuweisenden Wert enthält. Wird die Prozedur aufgerufen, steht dieses Argument auf der rechten Seite des aufrufenden Ausdruckes.
Anweisungen | Eine beliebige Gruppe von Anweisungen, die innerhalb des Rumpfs einer Property Let-Prozedur auszuführen sind.

Anmerkung Jede Property Let-Anweisung muss mindestens ein Argument für die festzulegende Prozedur festlegen. Dieses Argument (bzw. bei mehreren das letzte) enthält den eigentlichen Wert, der der Eigenschaft zugewiesen werden soll, wenn die von der Property Let-Anweisung festgelegte Prozedur aufgerufen wird. Dieses Argument wird in der vorhergehenden Syntax als Wert bezeichnet.

Hinweise
Auf Property Let-Prozeduren kann standardmäßig von allen anderen Prozeduren aus zugegriffen werden, wenn dies nicht explizit durch Public oder Private angegeben wird, das heißt, sie sind für alle anderen Prozeduren im Skript sichtbar. Der Wert lokaler Variablen in einer Property Let-Prozedur wird zwischen Aufrufen der Prozedur nicht zwischengespeichert.

Sie können eine Property Let-Prozedur nicht innerhalb einer anderen Prozedur (z. B. Function oder Property Get) festlegen.

Die Exit Property-Anweisung führt zur sofortigen Beendigung einer Property Let-Prozedur. Die Programmausführung wird mit der Anweisung fortgeführt, die auf die Anweisung folgt, die die Property Let-Prozedur aufgerufen hat. In einer Property Let-Prozedur kann eine beliebige Anzahl von Exit Property-Anweisungen an beliebiger Stelle stehen.

Ähnlich wie eine Function- bzw. Property Get- ist eine Property Let-Prozedur eine separate Prozedur, die Argumente übernehmen, eine Reihe von Anweisungen durchführen und die Werte ihrer Argumente ändern kann. Im Gegensatz zu einer Function- und Property Get-Prozedur, die beide einen Wert zurückgeben, können Sie eine Property Let-Prozedur nur auf der linken Seite eines Eigenschaftenzuweisungsausdruckes verwenden.


Property Let-Anweisung

Property Let-Anweisung
Siehe auch 		Sprachverzeichnis

Class-Anweisung
Dim-Anweisung
Exit-Anweisung
Function-Anweisung
Private-Anweisung
Property Get-Anweisung
Property Set-Anweisung
Public-Anweisung
Set-Anweisung
Sub-Anweisung


Property Set-Anweisung

Property Set-Anweisung 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Deklariert in einem Class-Block den Namen, Argumente sowie den Code, die den Rumpf einer Property-Prozedur bilden, die den Verweis auf ein Objekt festlegt.
Syntax
[Public | Private] Property Set Name([ArgListe,] Verweis)
[Anweisungen]
[Exit Property]
[Anweisungen]
End Property

Die Syntax der Property Set-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Public | Gibt an, dass alle anderen Prozeduren in sämtlichen Skripten auf die Property Set-Prozedur zugreifen können.
Private | Gibt an, dass von anderen Prozeduren auf die Property Set-Prozedur nur in dem Class-Block zugegriffen werden kann, in dem sie deklariert wurde.
Name | Name der Property Set-Prozedur; entspricht den standardmäßigen Benennungskonventionen von Variablen Variablen, mit der Ausnahme, dass der Name mit einer Property Get- oder Property Let-Prozedur im selben Class-Block übereinstimmen kann.
ArgListe | Auflistung von Variablen, die Argumente darstellen und an die Property Set-Prozedur übergeben werden, wenn diese aufgerufen wird. Mehrere Argumente werden voneinander durch Kommata getrennt. Darüber hinaus weist die Property Set-Prozedur stets ein Argument mehr als seine zugehörige Property Get-Prozedur auf. Das Argument ist das der Eigenschaft zugewiesene Objekt.
Verweis | Variable, die den Objektverweis enthält, der auf der rechten Seite der Objektverweiszuweisung verwendet wird.
Anweisungen | Eine beliebige Gruppe von Anweisungen, die innerhalb des Rumpfs einer Property Set-Prozedur auszuführen sind.

Hinweis Jede Property Set-Anweisung muss mindestens ein Argument für die festzulegende zugehörige Prozedur definieren. Dieses Argument (bzw. bei mehreren das letzte) enthält den eigentlichen Objektverweis für die Eigenschaft, wenn die von der Property Set-Anweisung festgelegte Prozedur aufgerufen wird. Dieses Argument wird in der vorhergehenden Syntax als Verweis bezeichnet.

Hinweise
Auf Property Set-Prozeduren kann standardmäßig von allen anderen Prozeduren aus zugegriffen werden, wenn dies nicht explizit durch Public oder Private angegeben wird, das heißt, sie sind für alle anderen Prozeduren im Skript sichtbar. Der Wert lokaler Variablen in einer Property Set-Prozedur wird zwischen Aufrufen der Prozedur nicht zwischengespeichert.

Sie können eine Property Set-Prozedur nicht innerhalb einer anderen Prozedur (z. B. Function oder Property Let) festlegen.

Die Exit Property-Anweisung führt zur sofortigen Beendigung einer Property Set-Prozedur. Die Programmausführung wird mit der Anweisung fortgeführt, die auf die Anweisung folgt, die die Property Set-Prozedur aufgerufen hat. In einer Property Set-Prozedur kann eine beliebige Anzahl von Exit Property-Anweisungen an beliebiger Stelle stehen.

Ähnlich wie eine Function- bzw. Property Get-Prozedur ist eine Property Set-Prozedur eine separate Prozedur, die Argumente übernehmen, eine Reihe von Anweisungen durchführen und die Werte ihrer Argumente ändern kann. Im Gegensatz zu einer Function- und Property Get-Prozedur, die beide einen Wert zurückgeben, können Sie eine Property Set-Prozedur nur auf der linken Seite einer Objektverweiszuweisung (Set-Anweisung) verwenden.


Property Set-Anweisung

Property Set-Anweisung
Siehe auch 		Sprachverzeichnis

Class-Anweisung
Dim-Anweisung
Exit-Anweisung
Function-Anweisung
Private-Anweisung
Property Get-Anweisung
Property Let-Anweisung
Public-Anweisung
Set-Anweisung
Sub-Anweisung


Public-Anweisung

Public-Anweisung 		Sprachverzeichnis
Version 2

Siehe auch

Beschreibung
Deklariert allgemeine Variablen und reserviert Speicherplatz für sie. Deklariert in einem Class-Block private Variablen.
Syntax
Public VarName[([Dimensionen])][, VarName[([Dimensionen])]] . . .

Die Syntax der Public-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
VarName | Name der Variablen; entspricht den Standardkonventionen für Namen von Variablen.
Dimensionen Dimensionen einer Datenfeldvariablen. Bis zu 60 Dimensionen gleichzeitig sind zulässig. Die folgende Syntax wird für das Argument Dimensionen verwendet:

Obergrenze [, Obergrenze] . . .

Die Untergrenze der Elementzahl ist immer Null.

Hinweise
Public-Variablen stehen allen Prozeduren in allen Skripten zur Verfügung.

Einer Variablen, die auf ein Objekt verweist, muss ein vorhandenes Objekt mit der Set-Anweisung zugeordnet werden, bevor sie verwendet werden kann. Bis zur eigentlichen Objektzuordnung wird die deklarierte Objektvariable mit Empty initialisiert.

Sie können die Public-Anweisung mit leeren Klammern auch zum Deklarieren von dynamischen Datenfeldern einsetzen. Verwenden Sie dann anschließend die ReDim-Anweisung innerhalb einer Prozedur, um die Anzahl der Dimensionen und Elemente in diesem Datenfeld festzulegen. Wenn Sie versuchen, die Dimension einer Datenfeldvariablen, deren Größe explizit in einer Private-, Public- oder Dim-Anweisung angegeben war, neu zu deklarieren, tritt ein Fehler auf.

Der folgende Code veranschaulicht die Verwendung der Public-Anweisung:

Public MeineZahl    	' Public-Variant-Variable.
Public MeinDatenfeld(9)	' Public-Datenfeldvariable.
            ' Mehrere Public-Deklarationen von Variant-Variablen.
Public MeineZahl, MeineVar, DeineZahl


Public-Anweisung

Public-Anweisung
Siehe auch 		Sprachverzeichnis

Dim-Anweisung
Private-Anweisung
ReDim-Anweisung
Set-Anweisung


Randomize-Anweisung

Randomize-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Initialisiert den Zufallszahlengenerator.
Syntax
Randomize[Zahl]

Das Argument Zahl kann ein beliebiger gültiger numerischer Ausdruck sein.

Hinweise
Randomize verwendet Zahl als Startwert zum Initialisieren des Zufallszahlengenerators der Rnd-Funktion. Wenn Sie Zahl nicht angeben, wird der vom Systemzeitgeber zurückgegebene Wert als neuer Startwert verwendet.

Wird Randomize nicht verwendet, verwendet die Rnd-Funktion (ohne Argumente) beim ersten Aufruf dieselbe Zahl als Startwert. Danach verwendet sie die zuletzt erzeugte Zahl als Startwert.

Anmerkung Wenn Sie Folgen von Zufallszahlen wiederholen möchten, rufen Sie unmittelbar vor dem Aufruf von Randomize mit einem numerischen Argument die Rnd-Funktion mit einem negativen Argument auf. Durch Verwenden von Randomize mit demselben Wert für Zahl wird die vorherige Folge nicht wiederholt.

Der folgende Code veranschaulicht die Verwendung der Randomize-Anweisung:

Dim MeinWert, Antwort
Randomize				' Initialisiert den Zufallszahlengenerator.

Do Until Antwort = vbNo
   MeinWert = Int((6 * Rnd) + 1)	' Erzeugt eine Zufallszahl zwischen 1 und 6.
   MsgBox MeinWert
   Antwort = MsgBox ("Erneut würfeln? ", vbYesNo)
Loop


Randomize-Anweisung

Randomize-Anweisung
Siehe auch 		Sprachverzeichnis

Rnd-Funktion
Timer-Funktion


ReDim-Anweisung

ReDim-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Deklariert dynamische Datenfeldvariablen und reserviert Speicherplatz auf Prozedurebene (neu).
Syntax
ReDim [Preserve] VarName(Dimensionen) [,VarName(Dimensionen)] . . .

Die Syntax der ReDim-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Preserve | Die Daten in einem bestehenden Datenfeld bleiben erhalten, wenn die Größe der letzten Dimension geändert wird.
VarName | Name der Variablen gemäß den Standardkonventionen für Namen von Variablen.
Dimensionen Dimensionen einer Datenfeldvariablen. Bis zu 60 Dimensionen gleichzeitig können deklariert werden. Die folgende Syntax wird für das Argument Dimensionen verwendet:

Obergrenze [,Obergrenze] . . .

Die Untergrenze der Elementzahl ist immer Null.

Hinweise
Die ReDim-Anweisung dient zum Festlegen oder Ändern der Größe eines dynamischen Datenfeldes, das bereits formal mit einer Private, Public oder Dim-Anweisung und einem leeren Klammernpaar (ohne Indizes für die Dimensionen) deklariert wurde. Sie können die ReDim-Anweisung mehrmals verwenden, um die Anzahl der Elemente und Dimensionen in einem Datenfeld zu ändern.

Mit dem Preserve-Schlüsselwort können Sie nur die Größe der letzten Datenfelddimension ändern, nicht aber die Anzahl der Dimensionen. Wenn das Datenfeld zum Beispiel nur eine Dimension hat, können Sie die Größe dieser Dimension ändern, weil es die letzte und einzige Dimension ist. Hat das Datenfeld jedoch mindestens zwei Dimensionen, können Sie lediglich die Größe der letzten Dimension ändern, wenn der Inhalt des Datenfeldes erhalten bleiben soll.

Das folgende Beispiel veranschaulicht, wie Sie die letzte Dimension eines dynamischen Datenfeldes vergrößern können, ohne bereits bestehende Daten im Datenfeld zu löschen.

ReDim X(10, 10, 10)
. . .
ReDim Preserve X(10, 10, 15)
Vorsicht Wenn Sie ein Datenfeld verkleinern, gehen die Daten in den entfernten Elementen verloren.

Bei der Initialisierung von Variablen wird eine numerische Variable mit 0 und eine Zeichenfolgevariable mit einer Zeichenfolge der Länge Null ("") initialisiert. Einer Variablen, die auf ein Objekt verweist, muss ein vorhandenes Objekt mit der Set-Anweisung zugeordnet werden, bevor sie verwendet werden kann. Solange sie keinem Objekt zugewiesen ist, hat die deklarierte Objektvariable den Sonderwert Nothing.


ReDim-Anweisung

ReDim-Anweisung
Siehe auch 		Sprachverzeichnis

Dim-Anweisung
Set-Anweisung


Rem-Anweisung

Rem-Anweisung 		Sprachverzeichnis
Version 1

Beschreibung
Markiert erläuternde Kommentare in einem Programm.
Syntax
Rem Kommentar

oder

' Kommentar

Das Argument Kommentar entspricht dem Text des einzufügenden Kommentars. Zwischen dem Schlüsselwort Rem und dem Argument Kommentar muss ein Leerzeichen stehen.

Hinweise
Wie in den Syntaxbeispielen gezeigt, können Sie ein Apostroph (') anstelle des Schlüsselworts Rem verwenden. Das Schlüsselwort Rem im Anschluss an andere Anweisungen in einer Zeile muss durch einen Doppelpunkt von den anderen Anweisungen getrennt sein. Bei einem Apostroph ist der Doppelpunkt hinter anderen Anweisungen nicht erforderlich.

Der folgende Code veranschaulicht die Verwendung der Anweisung Rem:

Dim MeinKommentar1, MeinKommentar2
MeinKommentar1 = "Hallo" : Rem Kommentar nach einer Anweisung, getrennt durch einen Doppelpunkt.
MeinKommentar2 = "Und Tschüß"     ' Dies ist auch ein Kommentar; es wird kein Doppelpunkt benötigt.
Rem Kommentar in einer Zeile ohne Code; es wird kein Doppelpunkt benötigt.


Select Case-Anweisung

Select Case-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt abhängig vom Wert eines Ausdruckes eine von mehreren Anweisungsgruppen aus.
Syntax
Select Case Testausdruck
[Case Ausdruckliste-n
[Anweisungen-n]] . . .
[Case Else Ausdruckliste-n
[elseAnweisungen]]
End Select

Die Syntax der Select Case-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Testausdruck | Ein beliebiger numerischer Ausdruck oder Zeichenfolgenausdruck.
Ausdruckliste-n | Erforderlich, falls Case angegeben wird. Eine durch Kommata getrennte Liste mit einem oder mehreren Ausdrücken.
Anweisungen-n | Eine oder mehrere Anweisungen, die ausgeführt werden, wenn Testausdruck mit einem der Ausdrücke in Ausdruckliste-n übereinstimmt.
elseAnweisungen | Eine oder mehrere Anweisungen, die ausgeführt werden, wenn Testausdruck mit keinem der Ausdrücke in den Case-Klauseln übereinstimmt.

Hinweise
Wenn Testausdruck mit einem der Ausdrücke in einer Case-Ausdruckliste übereinstimmt, werden die Anweisungen dieser Case-Klausel bis zur nächsten Case-Klausel (oder bei der letzten Case-Klausel bis zu End Select) ausgeführt. Anschließend setzt das Programm die Ausführung mit der Anweisung im Anschluss an End Select fort. Wenn Testausdruck mit einem der Ausdrücke in der Ausdruckliste mehrerer Case-Klauseln übereinstimmt, werden nur die Anweisungen nach der ersten Übereinstimmung ausgeführt.

Die Case Else-Klausel wird verwendet, um die Anweisungen in elseAnweisungen auszuführen, wenn Testausdruck mit keinem Ausdruck in der Ausdruckliste keiner der Case-Klauseln übereinstimmt. Die Case Else-Anweisung ist optional, sollte aber in keinem Select Case-Block fehlen, damit unvorhergesehene Werte von Testausdruck verarbeitet werden können. Wenn Sie keine Case Else-Anweisung angeben und keine Case-Ausdruckliste mit Testausdruck übereinstimmt, setzt das Programm die Ausführung mit der Anweisung im Anschluss an End Select fort.

Select Case-Anweisungen können in sich verschachtelt sein. Jede Select Case-Anweisung muss eine zugehörige End Select-Anweisung besitzen.

Der folgende Code veranschaulicht die Verwendung der Select Case-Anweisung:

Dim Farbe, MeineVar
Sub HintergrundAendern(Farbe)
    MeineVar = lcase(Farbe)
       Select Case MeineVar
           Case "rot"    document.bgColor = "red"
           Case "grün"   document.bgColor = "green"
           Case "blau"   document.bgColor = "blue"
           Case Else     MsgBox "Andere Farbe aussuchen"
      End Select
End Sub


Select Case-Anweisung

Select Case-Anweisung
Siehe auch 		Sprachverzeichnis

If...Then...Else-Anweisung


Set-Anweisung

Set-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Weist einen Objektverweis einer Variablen oder einer Eigenschaft zu oder ordnet einen Prozedurverweis einem Ereignis zu.
Syntax 1
Set ObjektVar = {Objektausdruck | New Klassenname | Nothing}

Syntax 2
Set Objekt.Ereignis = GetRef(ProzName)

Die Syntax der Set-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
ObjektVar | Erforderlich. Name der Variablen oder Eigenschaft; entspricht standardmäßigen Benennungskonventionen.
ObjektAusdruck | Optional. Ausdruck, der aus einem Objektnamen, einer weiteren deklarierten Variable desselben Objekttypes oder einer Funktion bzw. Methode besteht, die ein Objekt desselben Objekttypes zurückgibt.
New | Schlüsselwort, das zum Erstellen einer neuen Instanz einer Klasse verwendet wird. Enthält ObjektVar einen Verweis auf ein Objekt, wird dieser Verweis freigegeben, wenn der neue zugewiesen wird. Das Schlüsselwort New kann nur für das Erstellen einer Instanz einer Klasse verwendet werden.
Klassenname | Optional. Name der zu erstellenden Klasse. Eine Klasse und ihre Elemente werden mithilfe der Class-Anweisung festgelegt.
Nothing | Optional. Hebt die Zuordnung von ObjektVar zu einem bestimmten Objekt oder einer bestimmten Klasse auf. Wird ObjektVar Nothing zugewiesen, werden alle System- und Speicherressourcen freigegeben, die zu dem Objekt gehören, auf das zuvor verwiesen wurde, wenn keine anderen Variablen darauf verweisen.
Objekt | Erforderlich. Name des Objekts, dem Ereignis zugeordnet ist.
Ereignis | Erforderlich. Name des Ereignisses, an das die Funktion gebunden werden soll.
ProzName | Erforderlich. Zeichenfolge, die den Namen der Sub- oder Function-Prozedur enthält, die Ereignis zugeordnet wird.

Hinweise
ObjektVar ist nur gültig, wenn der zugehörige Objekttyp mit dem Typ des zugewiesenen Objekts identisch ist.

Die Dim-, Private-, Public- oder ReDim-Anweisungen deklarieren nur eine Variable, die auf ein Objekt verweist. Es wird auf kein tatsächliches Objekt verwiesen, solange Sie nicht die Set-Anweisung zur Zuweisung eines bestimmten Objekts verwenden.

Wenn Sie mit Set einer Variablen einen Objektverweis zuweisen, wird keine Kopie des Objekts erzeugt. Vielmehr wird ein Verweis auf das Objekt erstellt. Mehrere Objektvariablen können gleichzeitig auf dasselbe Objekt verweisen. Da alle diese Variablen auf ein Objekt verweisen (und nicht auf eine Kopie davon), wirken sich Änderungen an dem Objekt immer auf alle Variablen mit einem Verweis auf das Objekt aus.

Function FreienLaufwerkspeicherAnzeigen(LWPfad)
  Dim fso, l, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set l = fso.GetDrive(fso.GetDriveName(LWPfad))
  s = "Laufwerk " & UCase(LWPfad) & " - "
  s = s & l.VolumeName  & "<BR>"
  s = s & "Freier Speicherplatz: " & FormatNumber(l.FreeSpace/1024, 0)
  s = s & " KB"
  FreienLaufwerkspeicherAnzeigen = s
End Function
Das Schlüsselwort New ermöglicht Ihnen gleichzeitig das Erstellen einer Klasseninstanz und ihre Zuweisung zu einer Objektverweisvariablen. Die Variable, die der Klasseninstanz zugewiesen wird, muss bereits mit der Dim- oder einer äquivalenten Anweisung deklariert worden sein.

Weitere Informationen zur Verwendung von Set, um eine Prozedur einem Ereignis zuzuordnen, finden Sie in der Dokumentation zur GetRef-Funktion.


Set-Anweisung

Set-Anweisung
Siehe auch 		Sprachverzeichnis

Dim-Anweisung
GetRef-Funktion
ReDim-Anweisung
Zuweisungsoperator (=)


Sub-Anweisung

Sub-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Deklariert Namen, Argumente und Code für den Rumpf einer Sub-Prozedur.
Syntax
[Public [Default] | Private] Sub Name [(ArgListe)]
[Anweisungen]
[Exit Sub]
[Anweisungen]
End Sub

Die Syntax der Sub-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Public | Die Sub-Prozedur steht allen anderen Prozeduren in allen Skripten zur Verfügung.
Default | Wird nur mit einem Public-Schlüsselwort in einem Class-Block verwendet, um anzugeben, dass die Sub-Prozedur die Standardmethode für die Klasse ist. Ist mehr als eine Default-Prozedur in einer Klasse angegeben, tritt ein Fehler auf.
Private | Die Sub-Prozedur steht anderen Prozeduren nur in dem Skript, in dem sie deklariert wurde, zur Verfügung.
Name | Name der Sub-Prozedur gemäß den Standardkonventionen für Namen von Variablen.
ArgListe | Variablenliste mit den Argumenten, die an die Sub-Prozedur beim Aufruf übergeben werden. Mehrere Variablen werden durch Kommata voneinander getrennt.
Anweisungen | Eine beliebige Gruppe auszuführender Anweisungen im Rumpf der Sub-Prozedur.

Das Argument ArgListe verwendet die folgende Syntax und die folgenden Teile:

[ByVal | ByRef] VarName[( )]

Teil | Beschreibung
ByVal | Gibt an, dass das Argument als Wert übergeben wird.
ByRef | Gibt an, dass das Argument als Verweis übergeben wird.
VarName | Name der Variablen, die das Argument darstellt, gemäß den Standardkonventionen für Namen von Variablen.

Hinweise
Auf Sub-Prozeduren kann standardmäßig von allen anderen Prozeduren aus zugegriffen werden, wenn dies nicht explizit durch Public oder Private angegeben wird, das heißt, sie sind für alle anderen Prozeduren im Skript sichtbar. Der Wert lokaler Variablen in einer Sub-Prozedur wird zwischen Aufrufen der Prozedur nicht zwischengespeichert.

Sie können eine Sub-Prozedur nicht innerhalb einer anderen Prozedur festlegen (z. B. Function oder Property Get).

Die Exit Sub-Anweisung führt zur unmittelbaren Beendigung der Sub-Prozedur. Die Programmausführung wird mit der Anweisung fortgesetzt, die auf die Anweisung folgt, welche die Sub-Prozedur aufgerufen hat. In einer Sub-Prozedur kann eine beliebige Anzahl von Exit Sub-Anweisungen an beliebiger Stelle vorkommen.

Wie bei einer Function-Prozedur handelt es sich bei einer Sub-Prozedur um eine eigenständige Prozedur, die Argumente erhalten, eine Reihe von Anweisungen durchführen und die Werte der übergebenen Argumente ändern kann. Im Gegensatz zu einer Function-Prozedur, die einen Wert zurückgibt, kann eine Sub-Prozedur jedoch nicht in einem Ausdruck verwendet werden.

Der Aufruf einer Sub-Prozedur erfolgt durch Angabe des Prozedurnamens, gefolgt von der Argumentliste. In der Beschreibung der Call-Anweisung finden Sie genauere Informationen zum Aufrufen von Sub-Prozeduren.

Vorsicht Sub-Prozeduren können rekursiv sein; das bedeutet, dass sie sich selbst aufrufen können, um eine bestimmte Aufgabe durchzuführen. Rekursionen können jedoch zu Stapelüberlauffehlern führen.

Es gibt zwei Arten von Variablen, die in Sub-Prozeduren verwendet werden: solche, die innerhalb der Prozedur explizit deklariert werden, und andere. Variablen, die explizit in einer Prozedur deklariert werden (mit Dim oder gleichwertiger Anweisung) sind immer prozedurlokal. Variablen, die verwendet, aber nicht explizit innerhalb einer Prozedur deklariert werden, sind ebenfalls lokal, es sei denn, sie sind auf einer höheren Ebene außerhalb der Prozedur explizit deklariert worden.

Vorsicht Eine Prozedur kann eine nicht explizit in der Prozedur deklarierte Variable zwar verwenden, jedoch können Namenskonflikte auftreten, falls ein anderes auf Skriptebene definiertes Element denselben Namen hat. Verwendet Ihre Prozedur eine nicht deklarierte Variable mit einem Namen, der dem Namen einer anderen Prozedur, Konstanten oder Variablen entspricht, wird davon ausgegangen, dass Ihre Prozedur auf diesen Skriptebenennamen verweist. Verwenden Sie eine Option Explicit-Anweisung, um solche Konflikte zu vermeiden und eine explizite Deklaration von Variablen zu erzwingen.


Sub-Anweisung

Sub-Anweisung
Siehe auch 		Sprachverzeichnis

Call-Anweisung
Dim-Anweisung
Exit-Anweisung
Function-Anweisung


While...Wend-Anweisung

While...Wend-Anweisung 		Sprachverzeichnis
Version 1

Siehe auch

Beschreibung
Führt eine Reihe von Anweisungen aus, solange eine gegebene Bedingung True ist.
Syntax
While Bedingung
Version [Anweisungen]
Wend

Die Syntax der While...Wend-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Bedingung | Numerischer Ausdruck oder Zeichenfolgenausdruck, der True oder False ergibt. Hat Bedingung den Wert Null, wird Bedingung als False interpretiert.
Anweisungen | Eine oder mehrere Anweisungen, die ausgeführt werden, solange Bedingung den Wert True hat.

Hinweise
Wenn Bedingung den Wert True hat, werden alle Anweisungen bis zur Wend-Anweisung ausgeführt. Das Programm kehrt dann zur While-Anweisung zurück und überprüft, ob Bedingung weiterhin True ergibt. In diesem Fall wird der Vorgang wiederholt. Hat Bedingung nicht den Wert True, setzt das Programm die Ausführung mit der Anweisung fort, die auf die Wend-Anweisung folgt.

While...Wend-Schleifen können beliebig ineinander verschachtelt werden. Eine Wend-Anweisung bezieht sich immer auf die zuletzt ausgeführte While-Anweisung derselben Ebene.

Tipp Die Do...Loop-Anweisung stellt eine strukturiertere und flexiblere Möglichkeit zur Implementierung von Schleifen dar.

Der folgende Code veranschaulicht die Verwendung der While...Wend-Anweisung:

Dim Zaehler
Zaehler = 0                ' Initialisiert die Variable.
While Zaehler < 20         ' Testet den Zählerwert.
   Zaehler = Zaehler + 1   ' Inkrementiert den Zähler.
   Alert Zaehler
Wend                       ' Beendet die While-Schleife, wenn der Zähler > 19 ist.


While...Wend-Anweisung

While...Wend-Anweisung
Siehe auch 		Sprachverzeichnis

Do...Loop-Anweisung


With-Anweisung

With-Anweisung 		Sprachverzeichnis
Version 5

Siehe auch

Beschreibung
Führt eine Reihe von Anweisungen auf einem einzelnen Objekt aus.
Syntax
With Objekt
Anweisungen
End With

Die Syntax der With-Anweisung besteht aus folgenden Teilen:

Teil | Beschreibung
Objekt | Erforderlich. Name eines Objekts oder einer Funktion, die ein Objekt zurückgibt.
Anweisungen | Erforderlich. Eine oder mehrere Anweisungen, die auf Objekt ausgeführt werden sollen.

Hinweise
Die With-Anweisung ermöglicht Ihnen, eine Reihe von Anweisungen auf ein bestimmtes Objekt auszuführen, ohne dabei den Namen des Objekts erneut zu überprüfen. Wenn Sie z. B. mehrere unterschiedliche Eigenschaften eines einzigen Objekts ändern möchten, setzen Sie die Eigenschaftenzuweisungsanweisungen in die With-Steuerstruktur, sodass auf das Objekt nur einmal und nicht über die einzelnen Eigenschaftenzuweisungen verwiesen wird. Das folgende Beispiel veranschaulicht die Verwendung der With-Anweisung, um mehreren Eigenschaften eines Objekts Werte zuzuweisen.

With MeineBezeichnung
  .Hoehe = 2000
  .Breite = 2000
  .Titel = "Meine Bezeichnung"
End With
Zwar ist die Bearbeitung von Eigenschaften ein wichtiger Aspekt bei der With-Funktionalität, jedoch nicht die einzige Verwendungsmöglichkeit. Innerhalb eines With-Blockes ist jeder gültige Code zulässig.
Hinweis Nachdem das Programm in einen With-Block eingetreten ist, kann Objekt nicht mehr geändert werden. Sie müssen daher mehrere With-Anweisungen verwenden, um mehrere unterschiedliche Objekte zu bearbeiten.
Sie können With-Anweisungen verschachteln, indem Sie einen With-Block in einen anderen setzen. Da jedoch Elemente von äußeren With-Blöcken innerhalb innerer With-Blöcke maskiert werden, müssen Sie in einem inneren With-Block für jedes Objektelement in einem äußeren With-Block einen vollständigen Objektverweis angeben.

Wichtig Springen Sie nicht in oder aus With-Blöcken. Werden Anweisungen in einem With-Block ausgeführt, die With- oder End With-Anweisung jedoch nicht, kann dies zu unvorhersagbarem Verhalten führen.


With-Anweisung

With-Anweisung
Siehe auch 		Sprachverzeichnis

Set-Anweisung